]> git.pld-linux.org Git - packages/evince.git/blob - evince.spec
- ver. 0.6.0
[packages/evince.git] / evince.spec
1 #
2 # TODO: fix t1lib build time misdetection (very low prio)
3 #
4 # Conditional build:
5 %bcond_without  dbus    # enable DBUS support
6 #
7 Summary:        Document viewer for multiple document formats
8 Summary(pl):    Przegl±darka dokumentów w wielu formatach
9 Name:           evince
10 Version:        0.6.0
11 Release:        1
12 License:        GPL v2
13 Group:          X11/Applications/Graphics
14 Source0:        http://ftp.gnome.org/pub/gnome/sources/evince/0.6/%{name}-%{version}.tar.bz2
15 # Source0-md5:  2c99fac184c6acf5ff500aea20ae267d
16 Patch0:         %{name}-desktop.patch
17 Patch1:         %{name}-gs8.patch
18 URL:            http://www.gnome.org/projects/evince/
19 BuildRequires:  GConf2-devel >= 2.14.0
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.71}
23 BuildRequires:  djvulibre-devel >= 3.5.17
24 BuildRequires:  ghostscript
25 BuildRequires:  gnome-doc-utils >= 0.7.2
26 BuildRequires:  gnome-vfs2-devel >= 2.15.91
27 BuildRequires:  gtk+2-devel >= 2:2.10.1
28 BuildRequires:  intltool >= 0.35.0
29 BuildRequires:  kpathsea-devel
30 BuildRequires:  libglade2-devel >= 1:2.6.0
31 BuildRequires:  libgnomeui-devel >= 2.15.91
32 BuildRequires:  libstdc++-devel
33 BuildRequires:  libtiff-devel
34 BuildRequires:  libxslt-progs >= 1.1.17
35 BuildRequires:  nautilus-devel >= 2.15.91
36 BuildRequires:  pkgconfig
37 BuildRequires:  poppler-glib-devel >= 0.5.3
38 BuildRequires:  python-libxml2
39 BuildRequires:  rpmbuild(macros) >= 1.197
40 BuildRequires:  scrollkeeper
41 Requires(post,preun):   GConf2
42 Requires(post,postun):  desktop-file-utils
43 Requires(post,postun):  gtk+2 >= 2:2.10.1
44 Requires(post,postun):  scrollkeeper
45 Requires:       cairo >= 1.2.2
46 Requires:       djvulibre >= 3.5.17
47 Requires:       gtk+2 >= 2:2.10.1
48 Requires:       libgnomeui >= 2.15.91
49 Requires:       poppler-glib >= 0.5.3
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Evince is a document viewer for multiple document formats like pdf,
54 postscript, and many others. The goal of evince is to replace the
55 multiple document viewers that exist on the GNOME Desktop, like ggv,
56 gpdf, and xpdf with a single simple application.
57
58 %description -l pl
59 Evince jest przegl±dark± dokumentów w wielu formatach takich jak pdf,
60 postscript i wielu innych. W zamierzeniach program ma zast±piæ
61 przegl±darki dokumentów dla ¶rodowiska GNOME, takie jak ggv, gpdf i
62 xpdf jedn± prost± aplikacj±.
63
64 %package -n nautilus-extension-evince
65 Summary:        Evince extension for Nautilus
66 Summary(pl):    Rozszerzenie Evince dla Nautilusa
67 Group:          X11/Applications
68 Requires:       %{name} = %{version}-%{release}
69 Requires:       nautilus >= 2.15.4
70
71 %description -n nautilus-extension-evince
72 Shows Evince document properties in Nautilus.
73
74 %description -n nautilus-extension-evince -l pl
75 Pokazuje w³a¶ciwo¶ci dokumentu Evince w Nautilusie.
76
77 %prep
78 %setup -q
79 %patch0 -p1
80 %patch1 -p1
81
82 %build
83 %{__gnome_doc_prepare}
84 %{__intltoolize}
85 %{__aclocal}
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 %configure \
90         --disable-static \
91         --disable-schemas-install \
92         --enable-comics \
93         %{?with_dbus:--enable-dbus} \
94         --enable-djvu \
95         --enable-dvi \
96         --enable-impress \
97         --enable-nautilus \
98         --enable-pixbuf \
99         --enable-tiff \
100         --with-print=gtk
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 rm -f $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-1.0/*.la
110
111 %find_lang %{name} --with-gnome
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post
117 %gconf_schema_install evince.schemas
118 %gconf_schema_install evince-thumbnailer-comics.schemas
119 %gconf_schema_install evince-thumbnailer-djvu.schemas
120 %gconf_schema_install evince-thumbnailer-dvi.schemas
121 %gconf_schema_install evince-thumbnailer.schemas
122 %update_desktop_database_post
123 %scrollkeeper_update_post
124 %update_icon_cache hicolor
125
126 %preun
127 %gconf_schema_uninstall evince.schemas
128 %gconf_schema_uninstall evince-thumbnailer-comics.schemas
129 %gconf_schema_uninstall evince-thumbnailer-djvu.schemas
130 %gconf_schema_uninstall evince-thumbnailer-dvi.schemas
131 %gconf_schema_uninstall evince-thumbnailer.schemas
132
133 %postun
134 %update_desktop_database_postun
135 %scrollkeeper_update_postun
136 %update_icon_cache hicolor
137
138 %files -f %{name}.lang
139 %defattr(644,root,root,755)
140 %doc AUTHORS ChangeLog NEWS README TODO
141 %attr(755,root,root) %{_bindir}/*
142 %{_sysconfdir}/gconf/schemas/evince.schemas
143 %{_sysconfdir}/gconf/schemas/evince-thumbnailer-comics.schemas
144 %{_sysconfdir}/gconf/schemas/evince-thumbnailer-djvu.schemas
145 %{_sysconfdir}/gconf/schemas/evince-thumbnailer-dvi.schemas
146 %{_sysconfdir}/gconf/schemas/evince-thumbnailer.schemas
147 %{_datadir}/%{name}
148 %{_desktopdir}/*.desktop
149 %{_iconsdir}/*/*/*/*
150 %{_omf_dest_dir}/evince
151
152 %files -n nautilus-extension-evince
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/nautilus/extensions-1.0/*.so*
This page took 0.796194 seconds and 4 git commands to generate.