]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- another l&f fix
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - system pear is incompatible, at least pear DB class seems broke Eventum
3 # - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
4 # - discard bundled packages (from INSTALL):
5 #  - JpGraph 1.5.3 (last GPL version)
6 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
7 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
8 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
9 #  - A few other small javascript libraries
10 # - need start-stop-daemon (from dpkg for now)
11 # - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
12 # before STBR:
13 # - put useradd/groupadd macros into PLD rpm
14
15 %bcond_with     pear    # build with system PEAR packages (or use bundled ones)
16
17 %define uid     146
18 %define gid     146
19
20 # snapshot: DATE
21 #define _snap 20050227
22
23 %if 0%{?_snap}
24 %define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
25 %else
26 %define _source http://mysql.wildyou.net/Downloads/%{name}/%{name}-%{version}.tar.gz
27 %endif
28
29 %define _rel 279
30
31 Summary:        Eventum Issue / Bug tracking system
32 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
33 Name:           eventum
34 Version:        1.5.1
35 Release:        0.%{?_snap:%{_snap}.}%{_rel}
36 License:        GPL
37 Group:          Applications/WWW
38 Source0:        %{_source}
39 # Source0-md5:  d326ef39b52001efcbbc0ae8db5454a5
40 Source1:        %{name}-apache.conf
41 Source2:        %{name}-mail-queue.cron
42 Source3:        %{name}-mail-download.cron
43 Source4:        %{name}-reminder.cron
44 Source5:        %{name}-monitor.cron
45 Source6:        %{name}-cvs.php
46 Source7:        %{name}-irc.php
47 Source8:        %{name}-irc.init
48 Source9:        %{name}-irc.sysconfig
49 Source10:       %{name}-config.php
50 Source11:       %{name}-router-qmail.sh
51 Source12:       http://dev.mysql.com/common/favicon.ico
52 # Source12-md5: 858be0130832da4144c08d4b59116411
53 Patch0:         %{name}-paths.patch
54 Patch1:         %{name}-cvs-config.patch
55 Patch2:         %{name}-irc-config.patch
56 Patch3:         %{name}-PEAR.patch
57 Patch4:         %{name}-db-20050227.patch
58 Patch10:        %{name}-charset-recent-activity.patch
59 Patch11:        http://glen.alkohol.ee/pld/%{name}-cli-rpc-base64.patch
60 Patch12:        http://glen.alkohol.ee/pld/%{name}-send-height.patch
61 Patch13:        http://glen.alkohol.ee/pld/%{name}-reply-subject.patch
62 Patch14:        http://glen.alkohol.ee/pld/%{name}-rss-updates.patch
63 Patch15:        http://glen.alkohol.ee/pld/%{name}-opera.patch
64 Patch16:        %{name}-lf.patch
65 Patch17:        %{name}-iss-ass-fix.patch
66 Patch18:        %{name}-iss-close.patch
67 Patch19:        http://glen.alkohol.ee/pld/%{name}-attach-activate-links.patch
68 Patch20:        %{name}-irc-memlimit.patch
69 Patch21:        http://glen.alkohol.ee/pld/eventum-link-tilde2.patch
70 Patch22:        http://glen.alkohol.ee/pld/eventum-reply-timestamp.patch
71 Patch23:        http://glen.alkohol.ee/pld/eventum-lf-checkins.patch
72 URL:            http://dev.mysql.com/downloads/other/eventum/
73 BuildRequires:  rpmbuild(macros) >= 1.177
74 BuildRequires:  sed >= 4.0
75 Requires:       php >= 4.2.0
76 Requires:       php-gd
77 Requires:       php-imap
78 Requires:       php-mysql
79 Requires:       php-pcre
80 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
81 Requires:       Smarty >= 2.6.2
82 %if %{with pear}
83 Requires:       php-pear-Benchmark
84 Requires:       php-pear-DB
85 Requires:       php-pear-Date
86 Requires:       php-pear-HTTP_Request
87 Requires:       php-pear-Mail
88 Requires:       php-pear-Math_Stats
89 Requires:       php-pear-Net_DIME
90 Requires:       php-pear-Net_POP3
91 Requires:       php-pear-Net_SMTP
92 Requires:       php-pear-Net_SmartIRC
93 Requires:       php-pear-Net_Socket
94 Requires:       php-pear-Net_URL
95 Requires:       php-pear-Net_UserAgent_Detect
96 Requires:       php-pear-PEAR
97 Requires:       php-pear-Text_Diff
98 Requires:       php-pear-XML_RPC
99 %endif
100 Requires:       apache >= 1.3.33-2
101 Requires:       apache(mod_dir)
102 Requires(triggerpostun):        sed >= 4.0
103 BuildArch:      noarch
104 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
105
106 %define         _sysconfdir     /etc/%{name}
107 %define         _libdir         %{_prefix}/%{_lib}/%{name}
108 %define         _appdir %{_datadir}/%{name}
109 %define         _smartyplugindir        %{php_pear_dir}/Smarty/plugins
110
111 %define         _apache1dir     /etc/apache
112 %define         _apache2dir     /etc/httpd
113
114 %description
115 Eventum is a user-friendly and flexible issue tracking system that can
116 be used by a support department to track incoming technical support
117 requests, or by a software development team to quickly organize tasks
118 and bugs. Eventum is used by the MySQL AB Technical Support team, and
119 has allowed us to dramatically improve our response times.
120
121 %description -l pl
122 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
123 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
124 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
125 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
126 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
127 reakcji.
128
129 %package base
130 Summary:        Eventum base package
131 Summary(pl):    Podstawowy pakiet Eventum
132 Group:          Applications/WWW
133
134 %description base
135 This package contains base directory structure for Eventum.
136
137 %description base -l pl
138 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
139
140 %package setup
141 Summary:        Eventum setup package
142 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
143 Group:          Applications/WWW
144 PreReq:         %{name} = %{epoch}:%{version}-%{release}
145
146 %description setup
147 Install this package to configure initial Eventum installation. You
148 should uninstall this package when you're done, as it considered
149 insecure to keep the setup files in place.
150
151 %description setup -l pl
152 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
153 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
154 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
155
156 %package mail-queue
157 Summary:        Eventum mail queue process
158 Summary(pl):    Przetwarzanie kolejki poczty Eventum
159 Group:          Applications/WWW
160 Requires:       %{name} = %{epoch}:%{version}-%{release}
161 Requires:       crondaemon
162 Requires:       php >= 4.1.0
163
164 %description mail-queue
165 Beginning with the first release of Eventum, emails are not directly
166 sent out from the various scripts, but rather added to a mail queue
167 table that is processed by a cron job. If an email cannot be sent, it
168 will be marked as such in the mail queue log, and the cron job script
169 will re-try to send it again the next time it runs.
170
171 This package contains the cron job.
172
173 %description mail-queue -l pl
174 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
175 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
176 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
177 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
178 nastêpnym razem.
179
180 Ten pakiet zawiera zadanie dla crona.
181
182 %package mail-download
183 Summary:        Eventum email download
184 Summary(pl):    ¦ci±ganie poczty Eventum
185 Group:          Applications/WWW
186 Requires:       %{name} = %{epoch}:%{version}-%{release}
187 Requires:       crondaemon
188 Requires:       php >= 4.1.0
189
190 %description mail-download
191 In order for Eventum's email integration feature to work, you need to
192 setup a cron job to run the script every so often.
193
194 This package contains the cron job.
195
196 %description mail-download -l pl
197 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
198 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
199 czêsto.
200
201 Ten pakiet zawiera zadanie dla crona.
202
203 %package reminder
204 Summary:        Eventum Reminder System
205 Summary(pl):    System przypominania dla Eventum
206 Group:          Applications/WWW
207 Requires:       %{name} = %{epoch}:%{version}-%{release}
208 Requires:       php >= 4.1.0
209 Requires:       crondaemon
210
211 %description reminder
212 The reminder system was designed with the objective as serving as a
213 safe net for issues that need attention. Depending on what
214 configuration you create, you may have several reminders (or alerts)
215 be sent out whenever an issue needs attention, for whatever parameter
216 you may deem necessary.
217
218 This package contains the cron job.
219
220 %description reminder -l pl
221 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
222 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
223 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
224 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
225 uwa¿aæ za potrzebny.
226
227 Ten pakiet zawiera zadanie dla crona.
228
229 %package monitor
230 Summary:        Eventum Heartbeat Monitor
231 Summary(pl):    Monitor ¿ycia dla Eventum
232 Group:          Applications/WWW
233 Requires:       %{name} = %{epoch}:%{version}-%{release}
234 Requires:       php >= 4.1.0
235 Requires:       php-posix
236 Requires:       crondaemon
237
238 %description monitor
239 The heartbeat monitor is a feature designed for the administrator that
240 wants to be alerted whenever a common problem in Eventum is detected,
241 like the database server not being available anymore, or maybe when
242 the recommended permissions for certain configuration files are
243 changed.
244
245 Please note that before running the heartbeat monitor, you may need to
246 customize some of the checks to be appropriate for your own system,
247 particularly the permission and file checks on
248 Monitor::checkConfiguration().
249
250 This package contains the cron job.
251
252 %description monitor -l pl
253 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
254 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
255 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
256 do plików konfiguracyjnych.
257
258 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
259 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
260 testów uprawnieñ i plików w Monitor::checkConfiguration().
261
262 Ten pakiet zawiera zadanie dla crona.
263
264 %package route-emails
265 Summary:        Eventum Email Routing
266 Summary(pl):    Przekazywanie poczty dla Eventum
267 Group:          Applications/WWW
268 Requires:       %{name} = %{epoch}:%{version}-%{release}
269 Requires:       php >= 4.1.0
270 Requires:       eventum(router)
271
272 %description route-emails
273 The email routing feature is used to automatically associate a thread
274 of emails into an Eventum issue. By setting up qmail (or even postfix)
275 to deliver emails sent to a specific address (usually
276 issue-<number>@<domain>) to the above script, users are able to use
277 their email clients to reply to emails coming from Eventum, and those
278 replies will be automatically associated with the issue and
279 broadcasted to the entire notification list.
280
281 %description route-emails -l pl
282 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
283 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
284 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
285 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
286 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
287 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
288 rozprowadzane do ca³ej listy og³oszeniowej.
289
290 %package route-notes
291 Summary:        Eventum Note Routing
292 Summary(pl):    Przekazywanie notatek dla Eventum
293 Group:          Applications/WWW
294 Requires:       %{name} = %{epoch}:%{version}-%{release}
295 Requires:       php >= 4.1.0
296 Requires:       eventum(router)
297
298 %description route-notes
299 The note routing feature is used to automatically associate a thread
300 of notes into an Eventum issue. By setting up qmail (or even postfix)
301 to deliver emails sent to a specific address (usually
302 note-<number>@<domain>) to the above script, users are able to use
303 their email clients to reply to internal notes coming from Eventum,
304 and those replies will be automatically associated with the issue and
305 broadcasted to the notification list staff members.
306
307 %description route-notes -l pl
308 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
309 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
310 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
311 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
312 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
313 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
314 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
315
316 %package router-qmail
317 Summary:        Eventum Mail Routing - qmail
318 Summary(pl):    Przekazywanie poczty Eventum - qmail
319 Group:          Applications/Mail
320 Requires:       %{name} = %{epoch}:%{version}-%{release}
321 Requires:       qmail >= 1.03
322 Provides:       eventum(router)
323 Obsoletes:      eventum(router)
324
325 %description router-qmail
326 This package provides way of routing notes and emails back to Eventum
327 via qmail.
328
329 %description router-qmail -l pl
330 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
331 przez qmaila.
332
333 %package router-postfix
334 Summary:        Eventum Mail Routing - Postfix
335 Summary(pl):    Przekazywanie poczty Eventum - Postfix
336 Group:          Applications/Mail
337 Requires:       %{name} = %{epoch}:%{version}-%{release}
338 Requires:       postfix
339 Provides:       eventum(router)
340 Obsoletes:      eventum(router)
341
342 %description router-postfix
343 This package provides way of routing notes and emails back to Eventum
344 via Postfix.
345
346 %description router-postfix -l pl
347 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
348 przez Postfiksa.
349
350 %package irc
351 Summary:        Eventum IRC Notification Bot
352 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
353 Group:          Applications/WWW
354 Requires:       %{name} = %{epoch}:%{version}-%{release}
355 Requires:       php >= 4.1.0
356 Requires:       php-sockets
357 Requires:       rc-scripts >= 0.4.0.18
358
359 %description irc
360 The IRC notification bot is a nice feature for remote teams that want
361 to handle issues and want to have a quick and easy way to get simple
362 notifications. Right now the bot notifies of the following actions:
363 - New Issues
364 - Blocked emails
365 - Issues that got their assignment list changed
366
367 NOTE: You will need to manually edit the bot.php script to set your
368 appropriate preferences, like IRC server and channel that the bot
369 should join.
370
371 %description irc -l pl
372 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
373 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
374 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
375 nastêpuj±cych zdarzeniach:
376 - nowych sprawach
377 - zablokowanych listach
378 - sprawach, dla których zmieni³a siê lista powi±zañ
379
380 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
381 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
382
383 %package cli
384 Summary:        Eventum command-line interface
385 Summary(pl):    Interfejs linii poleceñ dla Eventum
386 Group:          Applications/WWW
387 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
388 Requires:       php >= 4.1.0
389 Requires:       php-cli
390 Requires:       php-curl
391 Requires:       php-xml
392 Requires:       php-pear-XML_RPC
393
394 %description cli
395 The Eventum command-line interface allows you to access most of the
396 features of the web interface straight from your command shell.
397
398 %description cli -l pl
399 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
400 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
401
402 %package scm
403 Summary:        Eventum SCM integration
404 Summary(pl):    Integracja SCM dla Eventum
405 Group:          Applications/WWW
406 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
407 Requires:       php >= 4.1.0
408
409 %description scm
410 This feature allows your software development teams to integrate your
411 Source Control Management system with your Issue Tracking System.
412
413 The integration is implemented in such a way that it will be forward
414 compatible with pretty much any SCM system, such as CVS.
415
416 For installation see
417 </eventum/help.php?topic=scm_integration_installation>.
418
419 %description scm -l pl
420 Ten pakiet pozwala zespo³om programistów na integracjê systemu
421 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
422 ¶ledzenia spraw.
423
424 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
425 prawie ka¿dym systemem SCM, jak np. CVS.
426
427 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
428 </eventum/help.php?topic=scm_integration_installation>.
429
430 %prep
431 %setup -q %{?_snap:-n %{name}-%{_snap}}
432 # undos the source
433 find . -type f -print0 | xargs -0 sed -i -e 's,
434 $,,'
435
436 # packaging
437 %patch0 -p1 -b .paths
438 %patch1 -p1
439 %patch2 -p1
440 %{?with_pear:%patch3 -p1 -b .PEAR}
441 %patch4 -p1
442
443 # bug fixes.
444 %patch10 -p1
445 %patch11 -p1
446 %patch12 -p0
447 %patch13 -p1
448 %patch14 -p1
449 %patch15 -p1
450 %patch16 -p1
451 %patch17 -p1
452 %patch18 -p1
453 %patch19 -p1
454 %patch20 -p1
455 %patch21 -p1
456 %patch22 -p1
457 %patch23 -p1
458
459 # replace in remaining scripts config.inc.php to system one
460 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
461         s,include_once(".*config.inc.php"),include_once("%{_sysconfdir}/core.php"),
462 '
463 sed -i -e '
464         s,include(".*config.inc.php"),include_once("%{_sysconfdir}/core.php"),
465 ' misc/download_emails.php
466
467 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
468         s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_sysconfdir}/private_key.php"),
469 '
470
471 rm -f */*~ */*/*~
472
473 %install
474 rm -rf $RPM_BUILD_ROOT
475 install -d \
476         $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_libdir}} \
477         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
478         $RPM_BUILD_ROOT/var/{run,log,cache,lib}/%{name} \
479         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
480
481 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
482 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
483 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
484 cp -a misc/irc $RPM_BUILD_ROOT%{_appdir}
485 cp -a templates $RPM_BUILD_ROOT%{_appdir}
486 cp -a include/{customer,jpgraph,pear,workflow} $RPM_BUILD_ROOT%{_appdir}/include
487 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
488 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
489 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
490
491 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
492
493 # cli
494 install -d $RPM_BUILD_ROOT%{_appdir}/cli
495 install misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
496 install misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
497 sed -e '1s,#!.*/bin/php,#!%{_bindir}/php4,' \
498         misc/cli/eventum > $RPM_BUILD_ROOT%{_bindir}/%{name}
499 cp -f misc/cli/eventumrc_example eventumrc
500
501 # scm
502 echo '#!%{_bindir}/php4 -q' > %{name}-scm
503 cat misc/scm/process_cvs_commits.php >> %{name}-scm
504 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
505
506 # private key
507 mv $RPM_BUILD_ROOT{%{_appdir}/include/private_key.php,%{_sysconfdir}}
508 # change private key, so we can easily grep
509 sed -i -e '
510 s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
511 ' $RPM_BUILD_ROOT%{_sysconfdir}/private_key.php
512
513 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
514 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
515 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
516 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
517 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
518 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
519 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
520 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
521 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
522 sed -e 's,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}},' \
523         %{SOURCE10} > $RPM_BUILD_ROOT%{_sysconfdir}/core.php
524
525 # config
526 > $RPM_BUILD_ROOT%{_sysconfdir}/setup.php
527 mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_sysconfdir}/config}.php
528
529 # sample, not used in eventum
530 rm -f $RPM_BUILD_ROOT%{_appdir}/htdocs/rpc/xmlrpc_client.php
531
532 %if %{with pear}
533 # provided by PEAR
534 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
535 %endif
536
537 # use system Smarty
538 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
539 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
540 # These plugins are not in Smarty package (Smarty-2.6.2-3)
541 cp -a include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
542         $RPM_BUILD_ROOT%{_smartyplugindir}
543
544 # qmail router
545 d=$RPM_BUILD_ROOT/var/lib/%{name}
546 echo 'root' > $d/.qmail
547 echo 'root' > $d/.qmail-default
548 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
549 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
550 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
551 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
552
553 %clean
554 rm -rf $RPM_BUILD_ROOT
555
556 %pre
557 %addusertogroup http %{name}
558
559 %post
560 # apache1
561 if [ -d %{_apache1dir}/conf.d ]; then
562         ln -sf %{_sysconfdir}/apache.conf %{_apache1dir}/conf.d/99_%{name}.conf
563         if [ -f /var/lock/subsys/apache ]; then
564                 /etc/rc.d/init.d/apache restart 1>&2
565         fi
566 fi
567 # apache2
568 if [ -d %{_apache2dir}/httpd.conf ]; then
569         ln -sf %{_sysconfdir}/apache.conf %{_apache2dir}/httpd.conf/99_%{name}.conf
570         if [ -f /var/lock/subsys/httpd ]; then
571                 /etc/rc.d/init.d/httpd restart 1>&2
572         fi
573 fi
574
575 # check if the package is configured.
576 if grep -q 'header("Location: setup/")' %{_sysconfdir}/config.php; then
577 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
578 %banner %{name} -e <<EOF
579
580 You haven't yet configured Eventum!
581 Please open in browser <http://localhost/eventum/>
582 If you need access from elsewhere, you need to edit
583 %{_sysconfdir}/apache.conf and restart apache.
584
585 IMPORTANT: When You have configured Eventum, please uninstall the
586 setup package, so that %{name}-setup is able to secure your Eventum
587 installation.
588
589 EOF
590 #' vim stupidity.
591 else
592 %banner %{name} -e <<EOF
593
594 You haven't yet configured Eventum!
595
596 To setup eventum, please install %{name}-setup and open in browser
597 <http://localhost/eventum/>.
598 If you need access from elsewhere, you need to edit
599 %{_sysconfdir}/apache.conf and restart apache.
600
601 IMPORTANT: When You have configured Eventum, please uninstall the
602 setup package, so that %{name}-setup is able to secure your Eventum
603 installation.
604
605 EOF
606 #' vim stupidity.
607 fi
608
609 elif grep -q 'DEFAULTPRIVATEKEY' %{_sysconfdir}/private_key.php; then
610 %banner %{name} -e <<EOF
611
612 You have default private key installed!
613
614 Install %{name}-setup and open up http://yourserver/eventum/setup/
615 -- that will help you setup initial config.
616
617 when have configured Eventum, please uninstall the setup package,
618 so that %{name}-setup is able to secure your Eventum installation.
619
620 EOF
621         elif [ -d %{_appdir}/setup ]; then
622 %banner %{name} -e <<EOF
623
624 If you have have configured Eventum, please uninstall the setup package,
625 so that %{name}-setup is able to secure your Eventum installation.
626
627 EOF
628 fi
629
630 # nuke Smarty templates cache after upgrade
631 rm -f /var/cache/eventum/*.php
632
633 %preun
634 if [ "$1" = "0" ]; then
635         # apache1
636         if [ -f %{_apache1dir}/apache.conf ]; then
637                 rm -f %{_apache1dir}/conf.d/99_%{name}.conf
638                 if [ -f /var/lock/subsys/apache ]; then
639                         /etc/rc.d/init.d/apache restart 1>&2
640                 fi
641         fi
642         # apache2
643         if [ -d %{_apache2dir}/httpd.conf ]; then
644                 rm -f %{_apache2dir}/httpd.conf/99_%{name}.conf
645                 if [ -f /var/lock/subsys/httpd ]; then
646                         /etc/rc.d/init.d/httpd restart 1>&2
647                 fi
648         fi
649
650         # nuke cache
651         rm -f /var/cache/eventum/*.php 2>/dev/null || :
652 fi
653
654 %pre base
655 %groupadd -P %{name}-base %{name}
656 %useradd -P %{name}-base -d /var/lib/%{name} -g %{name} %{name} -c "Eventum User"
657
658 %postun base
659 if [ "$1" = "0" ]; then
660         %userremove %{name}
661         %groupremove %{name}
662 fi
663
664 %post router-qmail
665 CF=/etc/qmail/control/virtualdomains
666 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
667         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_sysconfdir}/config.php 2>/dev/null)
668         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
669         umask 022
670         echo "#${FQDN}:%{name}" >> $CF
671
672 %banner %{name}-qmail -e <<EOF
673
674 Added "#${FQDN}:%{name}" to $CF,
675 Please verify that it is correct and restart qmail:
676 # service qmail reload
677
678 Consult qmail-send(8) for more information on virtualdomains.
679
680 EOF
681 fi
682
683 %preun router-qmail
684 if [ "$1" = "0" ]; then
685         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
686 fi
687
688 %post setup
689 chmod 660 %{_sysconfdir}/{config,private_key}.php
690 chown root:eventum %{_sysconfdir}/{config,private_key}.php
691
692 %postun setup
693 if [ "$1" = "0" ]; then
694         chmod 640 %{_sysconfdir}/{config,private_key}.php
695         chown root:eventum %{_sysconfdir}/{config,private_key}.php
696 fi
697
698 %triggerpostun base -- eventum-base < 1.4-2.20050222.212
699 if [ "`getent passwd %{name} | cut -d: -f6`" = "%{_appdir}" ]; then
700         /usr/sbin/usermod -d /var/lib/%{name} %{name}
701 fi
702
703 %triggerpostun -- eventum < 1.5-0.240
704 scriptdir=%{_appdir}/upgrade/v1.4_to_1.5
705 %banner %{name}-trigger-1.5 -e <<-EOF
706
707         Running eventum upgrade scripts to 1.5 in $scriptdir
708         These will fail if your eventum user doesn't have ALTER privilege to database.
709
710 EOF
711 #'
712
713 /usr/bin/php4 -q $scriptdir/database_changes.php || {
714         echo >&2 "Please run manually: /usr/bin/php4 -q $scriptdir/database_changes.php"
715 }
716
717 %triggerpostun -- eventum < 1.5.1-0.257
718 scriptdir=%{_appdir}/upgrade/v1.5_to_v1.5.1
719 %banner %{name}-trigger-1.5.1 -e <<-EOF
720
721         Running eventum upgrade scripts to 1.5.1 in $scriptdir
722         These will fail if your eventum user doesn't have ALTER privilege to database.
723
724 EOF
725 #'
726
727 /usr/bin/php4 -q $scriptdir/database_changes.php || {
728         echo >&2 "Please run manually: /usr/bin/php4 -q $scriptdir/database_changes.php"
729 }
730
731 %files
732 %defattr(644,root,root,755)
733 %doc ChangeLog FAQ INSTALL README UPGRADE
734 %doc docs/* rpc/xmlrpc_client.php setup/schema.sql
735 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
736 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
737 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/private_key.php
738 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/setup.php
739 %attr(640,root,eventum) %config %verify(not mtime) %{_sysconfdir}/core.php
740
741 %dir %attr(731,root,eventum) /var/log/%{name}
742 %attr(620,root,eventum) %ghost /var/log/%{name}/*
743
744 %dir %{_appdir}/htdocs
745 %{_appdir}/htdocs/*.php
746 %{_appdir}/htdocs/*.ico
747 %{_appdir}/htdocs/css
748 %{_appdir}/htdocs/customer
749 %{_appdir}/htdocs/images
750 %{_appdir}/htdocs/js
751 %{_appdir}/htdocs/manage
752 %{_appdir}/htdocs/reports
753 %{_appdir}/htdocs/rpc
754 %{_appdir}/htdocs/misc
755
756 %{_appdir}/templates
757 %{_appdir}/upgrade
758
759 %{_smartyplugindir}/*
760 %if %{without pear}
761 %{_appdir}/include/pear
762 %endif
763
764 %dir %{_appdir}/include
765 %{_appdir}/include/customer
766 %{_appdir}/include/jpgraph
767 %{_appdir}/include/workflow
768 %{_appdir}/include/class.[!m]*.php
769 %{_appdir}/include/class.mail.php
770 %{_appdir}/include/class.mail_queue.php
771 %{_appdir}/include/class.mime_helper.php
772 %{_appdir}/include/class.misc.php
773 %{_appdir}/include/db_access.php
774 %{_appdir}/include/jsrsServer.inc.php
775
776 %dir %attr(730,root,eventum) /var/run/%{name}
777 %dir %attr(730,root,eventum) /var/cache/%{name}
778
779 %files base
780 %defattr(644,root,root,755)
781 %attr(751,root,root) %dir %{_sysconfdir}
782 %dir %{_libdir}
783 %dir %{_appdir}
784 # qmail will ignore user, if it's home directory is not owned
785 %attr(750,eventum,eventum) %dir /var/lib/%{name}
786
787 %files setup
788 %defattr(644,root,root,755)
789 %{_appdir}/htdocs/setup
790
791 %files mail-queue
792 %defattr(644,root,root,755)
793 %{_appdir}/process_mail_queue.php
794 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
795
796 %files mail-download
797 %defattr(644,root,root,755)
798 %{_appdir}/download_emails.php
799 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
800
801 %files reminder
802 %defattr(644,root,root,755)
803 %{_appdir}/check_reminders.php
804 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
805
806 %files monitor
807 %defattr(644,root,root,755)
808 %{_appdir}/include/class.monitor.php
809 %{_appdir}/monitor.php
810 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
811
812 %files route-emails
813 %defattr(644,root,root,755)
814 %{_appdir}/route_emails.php
815
816 %files route-notes
817 %defattr(644,root,root,755)
818 %{_appdir}/route_drafts.php
819 %{_appdir}/route_notes.php
820
821 %files router-qmail
822 %defattr(644,root,root,755)
823 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
824 %attr(755,root,root) %{_libdir}/router-qmail
825
826 %files router-postfix
827 %defattr(644,root,root,755)
828
829 %files irc
830 %defattr(644,root,root,755)
831 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
832 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
833 %{_appdir}/irc
834 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
835
836 %files cli
837 %defattr(644,root,root,755)
838 %doc eventumrc
839 %attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
840 %attr(755,root,root) %{_bindir}/%{name}
841 %{_appdir}/cli
842
843 %files scm
844 %defattr(644,root,root,755)
845 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
846 %attr(755,root,root) %{_libdir}/scm
This page took 0.109088 seconds and 4 git commands to generate.