]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
package secret_key.php; use filelist from upstream tarball
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1.1
6 %define         subver  134
7 %define         githash fd60b15
8 %define         php_min_version 5.3.7
9 %include        /usr/lib/rpm/macros.php
10 Summary:        Eventum Issue / Bug tracking system
11 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
12 Name:           eventum
13 Version:        3.0.12
14 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
15 License:        GPL v2+
16 Group:          Applications/WWW
17 #Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
18 Source0:        %{name}-%{version}-%{subver}-g%{githash}.tar.gz
19 # Source0-md5:  2887ecda29f9197275a61933fa09f6c5
20 Source1:        %{name}-apache.conf
21 Source2:        %{name}-mail-queue.cron
22 Source3:        %{name}-mail-download.cron
23 Source4:        %{name}-reminder.cron
24 Source5:        %{name}-monitor.cron
25 Source8:        %{name}-irc.init
26 Source9:        %{name}-irc.sysconfig
27 Source10:       sphinx.crontab
28 Source13:       %{name}-router-postfix.sh
29 Source14:       %{name}.logrotate
30 Source15:       %{name}-lighttpd.conf
31 Source16:       http://www.isocra.com/images/updown2.gif
32 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
33 Source17:       %{name}.tmpfiles
34 Patch2:         %{name}-order.patch
35 #Patch3:                group-users.patch
36 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
37 # packaging patches that probably never go upstream
38 Patch100:       %{name}-paths.patch
39 Patch107:       %{name}-gettext.patch
40 Patch108:       autoload.patch
41 # some tests
42 Patch200:       %{name}-fixed-nav.patch
43 URL:            http://eventum.mysql.org/
44 BuildRequires:  /usr/bin/php
45 BuildRequires:  gettext-tools
46 BuildRequires:  php(core) >= %{php_min_version}
47 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
48 BuildRequires:  rpmbuild(macros) >= 1.654
49 BuildRequires:  sed >= 4.0
50 Requires(postun):       /usr/sbin/groupdel
51 Requires(postun):       /usr/sbin/userdel
52 Requires(pre):  /bin/id
53 Requires(pre):  /usr/bin/getgid
54 Requires(pre):  /usr/sbin/groupadd
55 Requires(pre):  /usr/sbin/useradd
56 Requires:       fonts-TTF-RedHat-liberation
57 Requires:       php(core) >= %{php_min_version}
58 Requires:       php(filter)
59 Requires:       php(iconv)
60 Requires:       php(imap)
61 Requires:       php(json)
62 Requires:       php(mbstring)
63 Requires:       php(mysqli)
64 Requires:       php(pcre)
65 Requires:       php(session)
66 Requires:       php-Smarty >= 3.1
67 Requires:       php-Smarty-plugin-gettext
68 Requires:       php-ZendFramework-Config >= 2.4
69 Requires:       php-ZendFramework-Loader >= 2.4
70 Requires:       php-ZendFramework-Mail >= 2.4.9-2
71 Requires:       php-ZendFramework-Mime >= 2.4
72 Requires:       php-ZendFramework-Validator >= 2.4
73 Requires:       php-monolog >= 1.17.2
74 Requires:       php-pear-DB
75 Requires:       php-pear-Mail
76 Requires:       php-pear-Mail_Mime
77 Requires:       php-pear-Mail_mimeDecode
78 Requires:       php-pear-Math_Stats
79 Requires:       php-pear-Net_SMTP
80 Requires:       php-pear-Net_Socket
81 Requires:       php-pear-Net_URL
82 Requires:       php-pear-PEAR-core
83 Requires:       php-pear-Text_Diff
84 Requires:       php-pear-XML_RPC
85 Requires:       php-psr-Log >= 1.0.0-2
86 Requires:       php-symfony2-Config >= 2.7.7
87 Requires:       php-symfony2-Filesystem >= 2.7.7
88 Requires:       php-symfony2-HttpFoundation >= 2.7.7
89 Requires:       php-symfony2-OptionsResolver >= 2.7.7
90 Requires:       php-symfony2-Serializer >= 2.7.7
91 Requires:       php-symfony2-Yaml >= 2.7.7
92 Requires:       phplot >= 5.8.0
93 Requires:       webapps
94 Requires:       webserver(access)
95 Requires:       webserver(alias)
96 Requires:       webserver(indexfile)
97 Requires:       webserver(php) >= 4.2.0
98 Suggests:       localedb
99 Suggests:       php(mcrypt)
100 Suggests:       php(openssl)
101 Suggests:       php-pear-Net_LDAP2
102 Suggests:       php-pear-Net_POP3
103 Suggests:       webserver(setenv)
104 Provides:       group(eventum)
105 Provides:       user(eventum)
106 Obsoletes:      eventum-base < 3.0.3-1.305
107 Obsoletes:      eventum-route-drafts < 3.0.8-1.1
108 Obsoletes:      eventum-route-emails < 3.0.8-1.1
109 Obsoletes:      eventum-route-notes < 3.0.8-1.1
110 Conflicts:      logrotate < 3.8.0
111 BuildArch:      noarch
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %define         _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
115
116 # exclude optional php dependencies
117 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
118
119 %define         _noautoreq      %{_noautophp}
120
121 %define         _libdir         %{_prefix}/lib/%{name}
122 %define         _appdir         %{_datadir}/%{name}
123 %define         _smartydir      %{php_data_dir}/Smarty
124 %define         _webapps        /etc/webapps
125 %define         _webapp         %{name}
126 %define         _webappdir      %{_webapps}/%{_webapp}
127 %define         _sysconfdir     /etc/%{name}
128
129 %description
130 Eventum is a user-friendly and flexible issue tracking system that can
131 be used by a support department to track incoming technical support
132 requests, or by a software development team to quickly organize tasks
133 and bugs. Eventum is used by the MySQL AB Technical Support team, and
134 has allowed us to dramatically improve our response times.
135
136 %description -l pl.UTF-8
137 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
138 może być używany przez dział obsługi do śledzenia przychodzących żądań
139 obsługi technicznej albo przez zespół tworzący oprogramowanie do
140 szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
141 Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
142 reakcji.
143
144 %package setup
145 Summary:        Eventum setup package
146 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
147 Group:          Applications/WWW
148 Requires:       %{name} = %{version}-%{release}
149
150 %description setup
151 Install this package to configure initial Eventum installation. You
152 should uninstall this package when you're done, as it considered
153 insecure to keep the setup files in place.
154
155 %description setup -l pl.UTF-8
156 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
157 pierwszej instalacji. Potem należy go odinstalować, jako że
158 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
159
160 %package doc
161 Summary:        Eventum documentation and Wiki
162 Group:          Documentation
163
164 %description doc
165 Eventum documentation and copy of Wiki.
166
167 %package mail-queue
168 Summary:        Eventum mail queue process
169 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
170 Group:          Applications/WWW
171 Requires:       %{name} = %{version}-%{release}
172 Requires:       crondaemon
173
174 %description mail-queue
175 Beginning with the first release of Eventum, emails are not directly
176 sent out from the various scripts, but rather added to a mail queue
177 table that is processed by a cron job. If an email cannot be sent, it
178 will be marked as such in the mail queue log, and the cron job script
179 will re-try to send it again the next time it runs.
180
181 This package contains the cron job.
182
183 %description mail-queue -l pl.UTF-8
184 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
185 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
186 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
187 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
188 następnym razem.
189
190 Ten pakiet zawiera zadanie dla crona.
191
192 %package mail-download
193 Summary:        Eventum email download
194 Summary(pl.UTF-8):      Ściąganie poczty Eventum
195 Group:          Applications/WWW
196 Requires:       %{name} = %{version}-%{release}
197 Requires:       crondaemon
198
199 %description mail-download
200 In order for Eventum's email integration feature to work, you need to
201 setup a cron job to run the script every so often.
202
203 This package contains the cron job.
204
205 %description mail-download -l pl.UTF-8
206 Aby integracja poczty elektronicznej w Eventum działała, trzeba
207 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
208 często.
209
210 Ten pakiet zawiera zadanie dla crona.
211
212 %package reminder
213 Summary:        Eventum Reminder System
214 Summary(pl.UTF-8):      System przypominania dla Eventum
215 Group:          Applications/WWW
216 Requires:       %{name} = %{version}-%{release}
217 Requires:       crondaemon
218
219 %description reminder
220 The reminder system was designed with the objective as serving as a
221 safe net for issues that need attention. Depending on what
222 configuration you create, you may have several reminders (or alerts)
223 be sent out whenever an issue needs attention, for whatever parameter
224 you may deem necessary.
225
226 This package contains the cron job.
227
228 %description reminder -l pl.UTF-8
229 System przypominania został zaprojektowany tak, aby służył jako
230 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
231 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
232 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
233 uważać za potrzebny.
234
235 Ten pakiet zawiera zadanie dla crona.
236
237 %package monitor
238 Summary:        Eventum Heartbeat Monitor
239 Summary(pl.UTF-8):      Monitor życia dla Eventum
240 Group:          Applications/WWW
241 Requires:       %{name} = %{version}-%{release}
242 Requires:       crondaemon
243 Requires:       php(posix)
244
245 %description monitor
246 The heartbeat monitor is a feature designed for the administrator that
247 wants to be alerted whenever a common problem in Eventum is detected,
248 like the database server not being available anymore, or maybe when
249 the recommended permissions for certain configuration files are
250 changed.
251
252 Please note that before running the heartbeat monitor, you may need to
253 customize some of the checks to be appropriate for your own system,
254 particularly the permission and file checks on
255 Monitor::checkConfiguration().
256
257 This package contains the cron job.
258
259 %description monitor -l pl.UTF-8
260 Monitor życia to funkcjonalność zaprojektowana dla administratora
261 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
262 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
263 do plików konfiguracyjnych.
264
265 Należy zauważyć, że przed uruchomieniem tego monitora może być
266 konieczne dostosowanie niektórych testów do systemu, w szczególności
267 testów uprawnień i plików w Monitor::checkConfiguration().
268
269 Ten pakiet zawiera zadanie dla crona.
270
271 %package router-postfix
272 Summary:        Eventum Mail Routing - Postfix
273 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
274 Group:          Applications/Mail
275 Requires:       %{name} = %{version}-%{release}
276 Requires:       postfix
277 Provides:       eventum(router)
278 Obsoletes:      eventum(router)
279
280 %description router-postfix
281 This package provides way of routing notes and emails back to Eventum
282 via Postfix.
283
284 The Postfix configuration instructions you can find from
285 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
286
287 %description router-postfix -l pl.UTF-8
288 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
289 przez Postfiksa.
290
291 Opis konfiguracji Postfiksa można znaleźć pod adresem
292 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
293
294 %package irc
295 Summary:        Eventum IRC Notification Bot
296 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
297 Group:          Applications/WWW
298 Requires(post,preun):   /sbin/chkconfig
299 Requires:       %{name} = %{version}-%{release}
300 Requires:       php(pcntl)
301 Requires:       php(sockets)
302 Requires:       php-pear-Net_SmartIRC >= 1.1.9
303 Requires:       rc-scripts >= 0.4.0.18
304
305 %description irc
306 The IRC notification bot is a nice feature for remote teams that want
307 to handle issues and want to have a quick and easy way to get simple
308 notifications. Right now the bot notifies of the following actions:
309 - New Issues
310 - Blocked emails
311 - Issues that got their assignment list changed
312
313 NOTE: You will need to manually edit the bot.php script to set your
314 appropriate preferences, like IRC server and channel that the bot
315 should join.
316
317 %description irc -l pl.UTF-8
318 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
319 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
320 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
321 następujących zdarzeniach:
322 - nowych sprawach
323 - zablokowanych listach
324 - sprawach, dla których zmieniła się lista powiązań
325
326 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
327 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
328
329 %package cli
330 Summary:        Eventum command-line interface
331 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
332 Group:          Applications/WWW
333 Requires:       php(core) >= %{php_min_version}
334 Requires:       php(phar)
335 Requires:       php-pear-XML_RPC
336
337 %description cli
338 The Eventum command-line interface allows you to access most of the
339 features of the web interface straight from your command shell.
340
341 %description cli -l pl.UTF-8
342 Interfejs linii poleceń Eventum pozwala na dostęp do większości
343 funkcji interfejsu WWW prosto z linii poleceń powłoki.
344
345 %package sphinx
346 Summary:        Eventum Sphinx Search
347 Group:          Applications/WWW
348 Requires:       %{name} = %{version}-%{release}
349 Requires:       crondaemon
350 Requires:       sphinx
351
352 %description sphinx
353 Sphinx search integration for Eventum.
354
355 This package contains the cron job.
356
357 %prep
358 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
359
360 mv docs/examples .
361
362 # bug fixes / features
363 %{?with_order:%patch2 -p1}
364 #%patch3 -p0
365 #%patch4 -p1
366
367 %{?with_order:cp -p %{SOURCE16} htdocs/images}
368
369 #%patch200 -p1
370
371 # produce default sphinx config
372 # must be run before paths.patch
373 %if 0
374 cat <<'EOF' > config/config.php
375 <?php
376 define('APP_SQL_DBTYPE', 'mysql');
377 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
378 define('APP_SQL_DBPORT', 3306);
379 define('APP_SQL_DBNAME', 'eventum');
380 define('APP_SQL_DBUSER', 'mysql');
381 define('APP_SQL_DBPASS', '');
382 define('APP_TABLE_PREFIX', 'eventum_');
383 EOF
384 php config/sphinx.conf.php > config/sphinx.conf
385 rm config/config.php
386 %endif
387
388 # packaging
389 %patch100 -p1
390 %patch107 -p1
391 %patch108 -p1
392
393 rm htdocs/.htaccess.dist
394
395 mv config/irc_config{.dist.php,.php}
396 rm config/config.dist.php
397
398 # cleanup vendor. keep only needed libraries.
399 # (the rest are packaged with system packages)
400 mv vendor vendor.dist
401 vendor() {
402         local path dir
403         for path; do
404                 dir=$(dirname $path)
405                 test -d vendor/$dir || mkdir -p vendor/$dir
406                 mv vendor.dist/$path vendor/$path
407         done
408 }
409 vendor autoload.php
410 vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
411 vendor composer/ClassLoader.php
412 vendor ircmaxell/{password-compat,random-lib,security-lib}
413 vendor defuse/php-encryption
414 vendor ramsey/array_column
415 vendor willdurand/email-reply-parser
416 vendor theorchard/monolog-cascade
417 vendor symfony/polyfill-php55
418 vendor symfony/polyfill-mbstring
419
420 # remove backups from patching as we use globs to package files to buildroot
421 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
422
423 %build
424 %{__make} -C localization
425
426 %install
427 rm -rf $RPM_BUILD_ROOT
428 install -d \
429         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
430         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
431         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
432         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
433         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
434         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
435
436 %{__make} install-eventum install-cli install-localization \
437         sysconfdir=%{_webappdir} \
438         localedir=%{_localedir} \
439         DESTDIR=$RPM_BUILD_ROOT
440
441 ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
442
443 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
444
445 # unsupported locale
446 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
447
448 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
449 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
450
451 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
452
453 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
454 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
455 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
456 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
457
458 install -d $RPM_BUILD_ROOT/etc/sphinx
459 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
460 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
461
462 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
463 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
464 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
465 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
466 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
467
468 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
469 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
470
471 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
472
473 # postfix router
474 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
475
476 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
477
478 %find_lang %{name}
479
480 %clean
481 rm -rf $RPM_BUILD_ROOT
482
483 %pre
484 %groupadd -g 146 %{name}
485 %useradd -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
486 %addusertogroup http %{name}
487
488 %post
489 # create empty ghost files
490 # these permissions ensure the logs are write only
491 for a in \
492         errors.log login_attempts.log \
493         eventum.log \
494         cli.log \
495         irc_bot_error.log irc_bot_smartirc.log \
496 ; do
497         test -f /var/log/%{name}/$a && continue
498         install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
499 done
500
501 # run database update if configured
502 test -s %{_webappdir}/config.php && \
503 %{_appdir}/bin/upgrade.php || :
504
505 # nuke Smarty templates cache after upgrade
506 rm -f /var/cache/eventum/*.php
507
508 # Restart webserver on upgrade to get .mo translations reloaded.
509 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
510 %php_webserver_restart
511
512 %preun
513 if [ "$1" = "0" ]; then
514         # nuke cache
515         rm -f /var/cache/eventum/*.php 2>/dev/null || :
516 fi
517
518 %postun
519 if [ "$1" = "0" ]; then
520         %userremove %{name}
521         %groupremove %{name}
522 fi
523
524 %post setup
525 chmod 660 %{_webappdir}/{config,private_key,secret_key}.php
526 chown root:http %{_webappdir}/{config,private_key,secret_key}.php
527
528 %postun setup
529 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
530         chmod 640 %{_webappdir}/{config,private_key,secret_key}.php
531         chown root:http %{_webappdir}/{config,private_key,secret_key}.php
532 fi
533
534 %post irc
535 /sbin/chkconfig --add eventum-irc
536 %service eventum-irc restart "Eventum IRC Bot"
537
538 %preun irc
539 if [ "$1" = 0 ]; then
540         %service eventum-irc stop
541         /sbin/chkconfig --del eventum-irc
542 fi
543
544 %triggerin -- apache1 < 1.3.37-3, apache1-base
545 %webapp_register apache %{_webapp}
546
547 %triggerun -- apache1 < 1.3.37-3, apache1-base
548 %webapp_unregister apache %{_webapp}
549
550 %triggerin -- apache < 2.2.0, apache-base
551 %webapp_register httpd %{_webapp}
552
553 %triggerun -- apache < 2.2.0, apache-base
554 %webapp_unregister httpd %{_webapp}
555
556 %triggerin -- lighttpd
557 %webapp_register lighttpd %{_webapp}
558
559 %triggerun -- lighttpd
560 %webapp_unregister lighttpd %{_webapp}
561
562 %triggerpostun -- %{name} < 3.0.0-0.2
563 for f in /etc/cron.d/eventum-*; do
564         # crontabs moved to bin
565         %{__sed} -i -e '
566                 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
567                 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
568                 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
569                 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
570         ' $f
571 done
572
573 %files -f %{name}.lang
574 %defattr(644,root,root,755)
575 %attr(751,root,root) %dir %{_webappdir}
576 %attr(751,root,root) %dir %{_webappdir}/custom_field
577 %attr(751,root,root) %dir %{_webappdir}/templates
578 %attr(751,root,root) %dir %{_webappdir}/workflow
579 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
580 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
581 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
582 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
583 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
584 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
585 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
586 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
587
588 %dir %attr(711,root,http) /var/log/%{name}
589 %attr(620,root,http) %ghost /var/log/%{name}/*
590 %dir %attr(750,root,root) /var/log/archive/%{name}
591 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
592
593 %dir %{_appdir}
594 %{_appdir}/config
595
596 %dir %{_appdir}/bin
597 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
598 %attr(755,root,root) %{_appdir}/bin/upgrade.php
599
600 %{_appdir}/autoload.php
601 %{_appdir}/init.php
602 %dir %{_appdir}/htdocs
603 %{_appdir}/htdocs/*.php
604 %{_appdir}/htdocs/*.ico
605 %{_appdir}/htdocs/ajax
606 %{_appdir}/htdocs/css
607 %{_appdir}/htdocs/customer
608 %{_appdir}/htdocs/images
609 %{_appdir}/htdocs/js
610 %{_appdir}/htdocs/manage
611 %{_appdir}/htdocs/reports
612 %{_appdir}/htdocs/rpc
613 %{_appdir}/htdocs/components
614 %{_appdir}/templates
615
616 %dir %{_appdir}/upgrade
617 %{_appdir}/upgrade/*.sql
618 %{_appdir}/upgrade/patches
619
620 %{_appdir}/res
621 %{_appdir}/src
622 %{_appdir}/vendor
623 %dir %{_appdir}/lib
624 %{_appdir}/lib/eventum
625 %exclude %{_appdir}/lib/eventum/class.monitor.php
626
627 %dir %{_libdir}
628
629 %{systemdtmpfilesdir}/%{name}.conf
630
631 %dir /var/lib/%{name}
632 %dir %attr(730,root,http) /var/run/%{name}
633 %dir %attr(730,root,http) /var/cache/%{name}
634
635 # saved mail copies
636 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
637 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
638 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
639
640 %files setup
641 %defattr(644,root,root,755)
642 %{_appdir}/htdocs/setup
643
644 %files doc
645 %defattr(644,root,root,755)
646 %doc docs/*
647 %{_examplesdir}/%{name}-%{version}
648
649 %files mail-queue
650 %defattr(644,root,root,755)
651 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
652 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
653 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
654
655 %files mail-download
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_appdir}/bin/download_emails.php
658 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
659
660 %files reminder
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
663 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
664
665 %files monitor
666 %defattr(644,root,root,755)
667 %{_appdir}/lib/eventum/class.monitor.php
668 %attr(755,root,root) %{_appdir}/bin/monitor.php
669 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
670
671 %files router-postfix
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_libdir}/router-postfix
674
675 %files irc
676 %defattr(644,root,root,755)
677 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
678 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
679 %attr(755,root,root) %{_appdir}/bin/irc-bot.php
680 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
681
682 %files cli
683 %defattr(644,root,root,755)
684 %doc cli/eventumrc
685 %attr(755,root,root) %{_bindir}/%{name}
686
687 %files sphinx
688 %defattr(644,root,root,755)
689 %{_webappdir}/sphinx.conf.php
690 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
691 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.080136 seconds and 4 git commands to generate.