]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- add xml inline patch
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 # - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
9 #
10 # Conditional build:
11 %bcond_with     qmail   # build the router-qmail subpackage
12 %bcond_with     order_patch     # with custom issue order patch
13
14 #define _snap   20060330
15 #define _rc             RC3
16 %define _rel    2.17
17
18 %include        /usr/lib/rpm/macros.php
19 Summary:        Eventum Issue / Bug tracking system
20 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
21 Name:           eventum
22 Version:        1.7.1
23 Release:        %{?_snap:0.%{_snap}.}%{?_rc:%{_rc}.}%{_rel}
24 License:        GPL
25 Group:          Applications/WWW
26 #Source0:       http://downloads.mysql.com/snapshots/eventum/%{name}-nightly-%{_snap}.tar.gz
27 Source0:        http://mysql.dataphone.se/Downloads/eventum/%{name}-%{version}.tar.gz
28 # Source0-md5:  e1845de39b4d9bd30ddec9c26031a7d5
29 Source1:        %{name}-apache.conf
30 Source2:        %{name}-mail-queue.cron
31 Source3:        %{name}-mail-download.cron
32 Source4:        %{name}-reminder.cron
33 Source5:        %{name}-monitor.cron
34 Source6:        %{name}-cvs.php
35 Source7:        %{name}-irc.php
36 Source8:        %{name}-irc.init
37 Source9:        %{name}-irc.sysconfig
38 Source10:       %{name}-config.php
39 Source11:       %{name}-router-qmail.sh
40 Source12:       %{name}-config-setup.php
41 Source13:       %{name}-upgrade.sh
42 Source14:       %{name}-router-postfix.sh
43 Patch0:         %{name}-lf.patch
44 Patch1:         %{name}-perms.patch
45 Patch2:         %{name}-cli-wr-separated.patch
46 Patch3:         %{name}-scm-parse-response.patch
47 Patch4:         %{name}-double-decode.patch
48 Patch5:         %{name}-route-mem.patch
49 Patch6:         %{name}-scm-pluscharisbad.patch
50 Patch7:         %{name}-scm-updates.patch
51 Patch8:         %{name}-close-signature.patch
52 Patch9:         %{name}-list-sorting.patch
53 Patch10:        %{name}-workflow-handlenewnote-note_id.patch
54 Patch11:        %{name}-order4b.patch
55 Patch12:        %{name}-cli-errorcheck.patch
56 Patch13:        %{name}-combined.patch
57 Patch14:        %{name}-xml-inline.patch
58 # packaging patches that probably never go upstream
59 Patch100:       %{name}-paths.patch
60 Patch101:       %{name}-cvs-config.patch
61 Patch102:       %{name}-irc-mem.patch
62 Patch103:       %{name}-irc-config.patch
63 Patch104:       %{name}-PEAR.patch
64 Patch105:       %{name}-httpclient-clientside.patch
65 Patch106:       %{name}-bot-reconnect.patch
66 Patch107:       %{name}-private-key.patch
67 URL:            http://dev.mysql.com/downloads/other/eventum/
68 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
69 BuildRequires:  rpmbuild(macros) >= 1.268
70 BuildRequires:  sed >= 4.0
71 Requires(triggerpostun):        /usr/bin/php
72 Requires(triggerpostun):        sed >= 4.0
73 Requires:       %{name}-base = %{version}-%{release}
74 Requires:       Smarty >= 2.6.10-4
75 Requires:       apache(mod_dir)
76 Requires:       php >= 3:4.2.0
77 Requires:       php-gd
78 Requires:       php-imap
79 Requires:       php-mysql
80 Requires:       php-pcre
81 Requires:       php-pear-Benchmark
82 Requires:       php-pear-DB
83 Requires:       php-pear-Date
84 Requires:       php-pear-HTTP_Request
85 Requires:       php-pear-Mail
86 Requires:       php-pear-Mail_Mime
87 Requires:       php-pear-Math_Stats
88 Requires:       php-pear-Net_DIME
89 Requires:       php-pear-Net_SMTP
90 Requires:       php-pear-Net_Socket
91 Requires:       php-pear-Net_URL
92 Requires:       php-pear-Net_UserAgent_Detect
93 Requires:       php-pear-PEAR-core
94 Requires:       php-pear-Text_Diff
95 Requires:       php-pear-XML_RPC
96 Requires:       php-session
97 Requires:       webapps
98 BuildArch:      noarch
99 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101 %define         _noautoreq      'pear(/etc/webapps/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)'
102
103 %define         _libdir         %{_prefix}/lib/%{name}
104 %define         _appdir         %{_datadir}/%{name}
105 %define         _smartyplugindir        %{_appdir}/include/smarty
106 %define         _smartydir      /usr/share/php/Smarty
107 %define         _webapps        /etc/webapps
108 %define         _webapp         %{name}
109 %define         _webappdir      %{_webapps}/%{_webapp}
110 %define         _sysconfdir     /etc/%{name}
111
112 %description
113 Eventum is a user-friendly and flexible issue tracking system that can
114 be used by a support department to track incoming technical support
115 requests, or by a software development team to quickly organize tasks
116 and bugs. Eventum is used by the MySQL AB Technical Support team, and
117 has allowed us to dramatically improve our response times.
118
119 %description -l pl
120 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
121 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
122 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
123 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
124 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
125 reakcji.
126
127 %package base
128 Summary:        Eventum base package
129 Summary(pl):    Podstawowy pakiet Eventum
130 Group:          Applications/WWW
131 Requires(postun):       /usr/sbin/groupdel
132 Requires(postun):       /usr/sbin/userdel
133 Requires(pre):  /bin/id
134 Requires(pre):  /usr/bin/getgid
135 Requires(pre):  /usr/sbin/groupadd
136 Requires(pre):  /usr/sbin/useradd
137 Provides:       group(eventum)
138 Provides:       user(eventum)
139
140 %description base
141 This package contains base directory structure for Eventum.
142
143 %description base -l pl
144 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
145
146 %package setup
147 Summary:        Eventum setup package
148 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
149 Group:          Applications/WWW
150 Requires:       %{name} = %{version}-%{release}
151
152 %description setup
153 Install this package to configure initial Eventum installation. You
154 should uninstall this package when you're done, as it considered
155 insecure to keep the setup files in place.
156
157 %description setup -l pl
158 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
159 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
160 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
161
162 %package mail-queue
163 Summary:        Eventum mail queue process
164 Summary(pl):    Przetwarzanie kolejki poczty Eventum
165 Group:          Applications/WWW
166 Requires:       %{name} = %{version}-%{release}
167 Requires:       crondaemon
168
169 %description mail-queue
170 Beginning with the first release of Eventum, emails are not directly
171 sent out from the various scripts, but rather added to a mail queue
172 table that is processed by a cron job. If an email cannot be sent, it
173 will be marked as such in the mail queue log, and the cron job script
174 will re-try to send it again the next time it runs.
175
176 This package contains the cron job.
177
178 %description mail-queue -l pl
179 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
180 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
181 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
182 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
183 nastêpnym razem.
184
185 Ten pakiet zawiera zadanie dla crona.
186
187 %package mail-download
188 Summary:        Eventum email download
189 Summary(pl):    ¦ci±ganie poczty Eventum
190 Group:          Applications/WWW
191 Requires:       %{name} = %{version}-%{release}
192 Requires:       crondaemon
193
194 %description mail-download
195 In order for Eventum's email integration feature to work, you need to
196 setup a cron job to run the script every so often.
197
198 This package contains the cron job.
199
200 %description mail-download -l pl
201 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
202 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
203 czêsto.
204
205 Ten pakiet zawiera zadanie dla crona.
206
207 %package reminder
208 Summary:        Eventum Reminder System
209 Summary(pl):    System przypominania dla Eventum
210 Group:          Applications/WWW
211 Requires:       %{name} = %{version}-%{release}
212 Requires:       crondaemon
213
214 %description reminder
215 The reminder system was designed with the objective as serving as a
216 safe net for issues that need attention. Depending on what
217 configuration you create, you may have several reminders (or alerts)
218 be sent out whenever an issue needs attention, for whatever parameter
219 you may deem necessary.
220
221 This package contains the cron job.
222
223 %description reminder -l pl
224 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
225 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
226 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
227 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
228 uwa¿aæ za potrzebny.
229
230 Ten pakiet zawiera zadanie dla crona.
231
232 %package monitor
233 Summary:        Eventum Heartbeat Monitor
234 Summary(pl):    Monitor ¿ycia dla Eventum
235 Group:          Applications/WWW
236 Requires:       %{name} = %{version}-%{release}
237 Requires:       crondaemon
238 Requires:       php-posix
239
240 %description monitor
241 The heartbeat monitor is a feature designed for the administrator that
242 wants to be alerted whenever a common problem in Eventum is detected,
243 like the database server not being available anymore, or maybe when
244 the recommended permissions for certain configuration files are
245 changed.
246
247 Please note that before running the heartbeat monitor, you may need to
248 customize some of the checks to be appropriate for your own system,
249 particularly the permission and file checks on
250 Monitor::checkConfiguration().
251
252 This package contains the cron job.
253
254 %description monitor -l pl
255 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
256 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
257 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
258 do plików konfiguracyjnych.
259
260 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
261 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
262 testów uprawnieñ i plików w Monitor::checkConfiguration().
263
264 Ten pakiet zawiera zadanie dla crona.
265
266 %package route-drafts
267 Summary:        Eventum Draft Routing
268 Summary(pl):    Przekazywanie szkiców dla Eventum
269 Group:          Applications/WWW
270 Requires:       %{name} = %{version}-%{release}
271 Requires:       eventum(router)
272
273 %description route-drafts
274 The draft routing feature is used to automatically associate a thread
275 of drafts into an Eventum issue. By setting up qmail (or even Postfix)
276 to deliver emails sent to a specific address (usually
277 draft-<number>@<domain>) to the above script, users are able to send
278 drafts written in their mail client to be stored in Eventum. These
279 drafts will NOT broadcasted to the notification list.
280
281 %description route-drafts -l pl
282 Przekazywanie szkiców s³u¿y do automatycznego wi±zania w±tku szkiców z
283 problemem w Eventum. Ustawiaj±c qmaila (czy nawet Postfiksa), aby
284 dostarcza³ pocztê wys³an± na podany adres (zwykle
285 draft-<liczba>@<domena>) do tego skryptu umo¿liwia siê u¿ytkownikom
286 wysy³anie szkiców napisanych w ich kliencie pocztowym do zapisania w
287 Eventum. Szkice te NIE bêd± wysy³ane na listê powiadomieñ.
288
289 %package route-emails
290 Summary:        Eventum Email Routing
291 Summary(pl):    Przekazywanie poczty dla Eventum
292 Group:          Applications/WWW
293 Requires:       %{name} = %{version}-%{release}
294 Requires:       eventum(router)
295
296 %description route-emails
297 The email routing feature is used to automatically associate a thread
298 of emails into an Eventum issue. By setting up qmail (or even postfix)
299 to deliver emails sent to a specific address (usually
300 issue-<number>@<domain>) to the above script, users are able to use
301 their email clients to reply to emails coming from Eventum, and those
302 replies will be automatically associated with the issue and
303 broadcasted to the entire notification list.
304
305 %description route-emails -l pl
306 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
307 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
308 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
309 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
310 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
311 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
312 rozprowadzane do ca³ej listy og³oszeniowej.
313
314 %package route-notes
315 Summary:        Eventum Note Routing
316 Summary(pl):    Przekazywanie notatek dla Eventum
317 Group:          Applications/WWW
318 Requires:       %{name} = %{version}-%{release}
319 Requires:       eventum(router)
320
321 %description route-notes
322 The note routing feature is used to automatically associate a thread
323 of notes into an Eventum issue. By setting up qmail (or even postfix)
324 to deliver emails sent to a specific address (usually
325 note-<number>@<domain>) to the above script, users are able to use
326 their email clients to reply to internal notes coming from Eventum,
327 and those replies will be automatically associated with the issue and
328 broadcasted to the notification list staff members.
329
330 %description route-notes -l pl
331 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
332 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
333 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
334 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
335 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
336 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
337 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
338
339 %package router-qmail
340 Summary:        Eventum Mail Routing - qmail
341 Summary(pl):    Przekazywanie poczty Eventum - qmail
342 Group:          Applications/Mail
343 # loose dep is intentional. qmail subpackage isn't built on PLD
344 # builders and there really nothing changes.
345 Requires:       %{name} >= %{version}-%{release}
346 Requires:       qmail >= 1.03
347 Provides:       eventum(router)
348 Obsoletes:      eventum(router)
349
350 %description router-qmail
351 This package provides way of routing notes and emails back to Eventum
352 via qmail.
353
354 %description router-qmail -l pl
355 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
356 przez qmaila.
357
358 %package router-postfix
359 Summary:        Eventum Mail Routing - Postfix
360 Summary(pl):    Przekazywanie poczty Eventum - Postfix
361 Group:          Applications/Mail
362 Requires:       %{name} = %{version}-%{release}
363 Requires:       postfix
364 Provides:       eventum(router)
365 Obsoletes:      eventum(router)
366
367 %description router-postfix
368 This package provides way of routing notes and emails back to Eventum
369 via Postfix.
370
371 The Postfix configuration instructions you can find from
372 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
373
374 %description router-postfix -l pl
375 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
376 przez Postfiksa.
377
378 Opis konfiguracji Postfiksa mo¿na znale¼æ pod adresem
379 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
380
381 %package irc
382 Summary:        Eventum IRC Notification Bot
383 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
384 Group:          Applications/WWW
385 Requires(post,preun):   /sbin/chkconfig
386 Requires(triggerpostun):        sed >= 4.0
387 Requires:       %{name} = %{version}-%{release}
388 Requires:       php-pear-Net_SmartIRC
389 Requires:       php-sockets
390 Requires:       rc-scripts >= 0.4.0.18
391
392 %description irc
393 The IRC notification bot is a nice feature for remote teams that want
394 to handle issues and want to have a quick and easy way to get simple
395 notifications. Right now the bot notifies of the following actions:
396 - New Issues
397 - Blocked emails
398 - Issues that got their assignment list changed
399
400 NOTE: You will need to manually edit the bot.php script to set your
401 appropriate preferences, like IRC server and channel that the bot
402 should join.
403
404 %description irc -l pl
405 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
406 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
407 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
408 nastêpuj±cych zdarzeniach:
409 - nowych sprawach
410 - zablokowanych listach
411 - sprawach, dla których zmieni³a siê lista powi±zañ
412
413 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
414 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
415
416 %package cli
417 Summary:        Eventum command-line interface
418 Summary(pl):    Interfejs linii poleceñ dla Eventum
419 Group:          Applications/WWW
420 Requires:       %{name}-base = %{version}-%{release}
421 Requires:       php-cli
422 Requires:       php-common >= 3:4.1.0
423 Requires:       php-pear-XML_RPC
424
425 %description cli
426 The Eventum command-line interface allows you to access most of the
427 features of the web interface straight from your command shell.
428
429 %description cli -l pl
430 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
431 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
432
433 %package scm
434 Summary:        Eventum SCM integration
435 Summary(pl):    Integracja SCM dla Eventum
436 Group:          Applications/WWW
437 Requires:       %{name}-base = %{version}-%{release}
438 Requires:       php-cli
439 Requires:       php-common >= 3:4.1.0
440 Requires:       php-pcre
441
442 %description scm
443 This feature allows your software development teams to integrate your
444 Source Control Management system with your Issue Tracking System.
445
446 The integration is implemented in such a way that it will be forward
447 compatible with pretty much any SCM system, such as CVS.
448
449 For installation see
450 </eventum/help.php?topic=scm_integration_installation>.
451
452 %description scm -l pl
453 Ten pakiet pozwala zespo³om programistów na integracjê systemu
454 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
455 ¶ledzenia spraw.
456
457 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
458 prawie ka¿dym systemem SCM, jak np. CVS.
459
460 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
461 </eventum/help.php?topic=scm_integration_installation>.
462
463 %prep
464 %setup -q %{?_snap:-n %{name}-%{_snap}}
465 # undos the source
466 find . -type f -print0 | xargs -0 sed -i -e 's,\r$,,'
467
468 rm -f setup.conf.php # not to be installed by *.php glob
469 rm -rf misc/upgrade/*v1.[123]* # too old to support in PLD Linux
470 rm -f misc/upgrade/flush_compiled_templates.php
471 rm -rf misc/upgrade/*/upgrade_config.php # not needed in PLD Linux
472
473 # sample, not used in eventum
474 rm -f rpc/xmlrpc_client.php
475
476 # bug fixes.
477 %patch0 -p1
478 %patch1 -p1
479 %patch2 -p1
480 %patch3 -p1
481 %patch4 -p1
482 %patch5 -p1
483 %patch6 -p1
484 %patch7 -p1
485 %patch8 -p1
486 %patch9 -p1
487 %patch10 -p1
488 %{?with_order_patch:%patch11 -p1}
489 %patch12 -p1
490 %patch13 -p1
491 %patch14 -p1
492
493 # packaging
494 %patch100 -p1
495 %patch101 -p1
496 %patch102 -p1
497 %patch103 -p1
498 %patch104 -p1
499 %patch105 -p1
500 %patch106 -p1
501 %patch107 -p1
502
503 sed -e '1s,#!.*/bin/php -q,#!%{_bindir}/php,' misc/cli/eventum > %{name}-cli
504 sed -e '1i#!%{_bindir}/php' misc/scm/process_cvs_commits.php > %{name}-scm
505 sed -e '1i#!%{_bindir}/php' misc/irc/bot.php > %{name}-bot
506 mv misc/cli/eventumrc_example eventumrc
507 sed -i -e '1i#!%{_bindir}/php' misc/*.php
508 chmod +x misc/*.php
509 mv include/private_key.php private_key.php.in
510
511 # replace in remaining scripts config.inc.php to system one
512 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
513         s,include_once(".*config.inc.php"),include_once("%{_webappdir}/core.php"),
514 '
515
516 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
517         s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_webappdir}/private_key.php"),
518 '
519
520 # remove backups from patching as we use globs to package files to buildroot
521 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
522
523 %install
524 rm -rf $RPM_BUILD_ROOT
525 install -d \
526         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
527         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
528         $RPM_BUILD_ROOT/var/{run,log,cache,lib}/%{name} \
529         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
530         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
531
532 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
533 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
534 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
535 cp -a templates $RPM_BUILD_ROOT%{_appdir}
536 cp -a include/{customer,custom_field,jpgraph,workflow} $RPM_BUILD_ROOT%{_appdir}/include
537 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
538 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
539 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
540
541 cp -a favicon.ico $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
542 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/setup/config.inc.php
543 install %{SOURCE13} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
544
545 # cli
546 install -d $RPM_BUILD_ROOT%{_appdir}/cli
547 cp -a misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
548 cp -a misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
549 install %{name}-cli $RPM_BUILD_ROOT%{_bindir}/%{name}
550 install %{name}-bot $RPM_BUILD_ROOT%{_sbindir}
551
552 # scm
553 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
554 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
555
556 # private key
557 cp -a private_key.php.in $RPM_BUILD_ROOT%{_webappdir}/private_key.php
558
559 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
560 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
561 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
562 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
563 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
564 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
565 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
566 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
567 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
568
569 sed -e '
570 s,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}}%{?_rc:-%{_rc}},
571 s,%%{PHP_PEAR_DIR}%%,%{php_pear_dir},
572 s,%%{APP_PATH}%%,%{_appdir},
573 s,%%{SMARTY_DIR}%%,%{_smartydir},
574 s,%%{SYSCONFDIR}%%,%{_webappdir},
575 ' %{SOURCE10} > $RPM_BUILD_ROOT%{_webappdir}/core.php
576
577 # config
578 > $RPM_BUILD_ROOT%{_webappdir}/setup.php
579 mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_webappdir}/config}.php
580
581 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
582 # These plugins are not in Smarty package (Smarty-2.6.2-3)
583 cp -a \
584         include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
585         include/Smarty/plugins/modifier.highlight_quoted.php \
586         $RPM_BUILD_ROOT%{_smartyplugindir}
587
588 # qmail router
589 %if %{with qmail}
590 d=$RPM_BUILD_ROOT/var/lib/%{name}
591 echo 'root' > $d/.qmail
592 echo 'root' > $d/.qmail-default
593 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
594 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
595 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
596 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
597 %endif
598 # postfix router
599 install %{SOURCE14} $RPM_BUILD_ROOT%{_libdir}/router-postfix
600
601 %clean
602 rm -rf $RPM_BUILD_ROOT
603
604 %pre
605 %addusertogroup http %{name}
606
607 %post
608 # check if the package is configured.
609 if grep -q 'header("Location: setup/")' %{_webappdir}/config.php; then
610 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
611 %banner %{name} -e <<EOF
612
613 You haven't yet configured Eventum!
614 Please open in browser <http://localhost/eventum/>
615 If you need access from elsewhere, you need to edit
616 %{_webappdir}/apache.conf and restart apache.
617
618 IMPORTANT: When You have configured Eventum, please uninstall the
619 setup package, so that %{name}-setup is able to secure your Eventum
620 installation.
621
622 EOF
623 #' vim syntax hack
624 else
625 %banner %{name} -e <<EOF
626
627 You haven't yet configured Eventum!
628
629 To setup eventum, please install %{name}-setup and open in browser
630 <http://localhost/eventum/>.
631 If you need access from elsewhere, you need to edit
632 %{_webappdir}/apache.conf and restart apache.
633
634 IMPORTANT: When You have configured Eventum, please uninstall the
635 setup package, so that %{name}-setup is able to secure your Eventum
636 installation.
637
638 EOF
639 #' vim syntax hack
640 fi
641
642 elif grep -q 'DEFAULTPRIVATEKEY' %{_webappdir}/private_key.php; then
643 %banner %{name} -e <<EOF
644
645 You have default private key installed!
646
647 Install %{name}-setup and open up http://yourserver/eventum/setup/
648 -- that will help you setup initial config.
649
650 when have configured Eventum, please uninstall the setup package,
651 so that %{name}-setup is able to secure your Eventum installation.
652
653 EOF
654         elif [ -d %{_appdir}/setup ]; then
655 %banner %{name} -e <<EOF
656
657 If you have have configured Eventum, please uninstall the setup package,
658 so that %{name}-setup is able to secure your Eventum installation.
659
660 EOF
661 fi
662
663 # nuke Smarty templates cache after upgrade
664 rm -f /var/cache/eventum/*.php
665
666 %preun
667 if [ "$1" = "0" ]; then
668         # nuke cache
669         rm -f /var/cache/eventum/*.php 2>/dev/null || :
670 fi
671
672 %pre base
673 %groupadd -P %{name}-base -g 146 %{name}
674 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
675
676 %postun base
677 if [ "$1" = "0" ]; then
678         %userremove %{name}
679         %groupremove %{name}
680 fi
681
682 %post router-qmail
683 CF=/etc/qmail/control/virtualdomains
684 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
685         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_webappdir}/config.php 2>/dev/null)
686         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
687         umask 022
688         echo "#${FQDN}:%{name}" >> $CF
689
690 %banner %{name}-qmail -e <<EOF
691
692 Added "#${FQDN}:%{name}" to $CF,
693 Please verify that it is correct and restart qmail:
694 # service qmail reload
695
696 Consult qmail-send(8) for more information on virtualdomains.
697
698 EOF
699 fi
700
701 %preun router-qmail
702 if [ "$1" = "0" ]; then
703         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
704 fi
705
706 %post setup
707 chmod 660 %{_webappdir}/{config,private_key}.php
708 chown root:eventum %{_webappdir}/{config,private_key}.php
709
710 %postun setup
711 if [ "$1" = "0" ]; then
712         chmod 640 %{_webappdir}/{config,private_key}.php
713         chown root:eventum %{_webappdir}/{config,private_key}.php
714 fi
715
716 %post irc
717 /sbin/chkconfig --add eventum-irc
718 %service eventum-irc restart "Eventum IRC Bot"
719
720 %triggerin -- apache1
721 %webapp_register apache %{_webapp}
722
723 %triggerun -- apache1
724 %webapp_unregister apache %{_webapp}
725
726 %triggerin -- apache < 2.2.0, apache-base
727 %webapp_register httpd %{_webapp}
728
729 %triggerun -- apache < 2.2.0, apache-base
730 %webapp_unregister httpd %{_webapp}
731
732 # FIXME
733 # only one upgrade trigger is called if you're upgrading over two
734 # versions, say 1.5 to 1.5.3, only 1.5.3 trigger is called.
735 # use common trigger (the highest version and rpmvercmp from poldek?)
736 %triggerpostun -- eventum < 1.5.1-0.257
737 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5_to_v1.5.1 <<EOF
738 database_changes.php Perform database changes
739 EOF
740
741 %triggerpostun -- eventum < 1.5.2-0.289
742 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.1_to_v1.5.2 <<EOF
743 database_changes.php Perform database changes
744 set_priority_ranks.php Fix the ranking of priority values
745 EOF
746
747 %triggerpostun -- eventum < 1.5.3-0.291
748 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.2_to_v1.5.3 <<EOF
749 database_changes.php Perform database changes
750 EOF
751
752 %triggerpostun -- eventum < 1.5.4-1.12
753 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.3_to_v1.5.4 <<EOF
754 database_changes.php Perform database changes
755 EOF
756
757 %triggerpostun -- eventum < 1.6.0-RC2.6
758 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.5_to_v1.6.0 <<EOF
759 database_changes.php Perform database changes
760 upgrade_saved_searches.php Upgrade existing custom filters (saved searches)
761 EOF
762
763 %triggerpostun -- eventum < 1.6.1-0.2
764 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.0_to_v1.6.1 <<EOF
765 database_changes.php Perform database changes
766 EOF
767
768 %triggerpostun irc -- eventum-irc < 1.6.1-3.14
769 sed -i -e '
770 s,\$irc_host,$irc_server_hostname,
771 s,\$irc_port,$irc_server_port,
772 s,\$irc_nick,$nickname,
773 s,\$irc_realname,$realname,
774 s,\$irc_username,$username,
775 s,\$irc_password,$password,
776 ' /etc/eventum/irc.php
777
778 %triggerpostun -- eventum < 1.7.0-2.0.48
779 # migrate from apache-config macros
780 if [ -f /etc/%{name}/apache.conf.rpmsave ]; then
781         if [ -d /etc/apache/webapps.d ]; then
782                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
783                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
784         fi
785
786         if [ -d /etc/httpd/webapps.d ]; then
787                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
788                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
789         fi
790 fi
791
792 if [ -L /etc/apache/conf.d/99_%{_webapp}.conf ]; then
793         /usr/sbin/webapp register apache %{_webapp}
794         rm -f /etc/apache/conf.d/99_%{_webapp}.conf
795         %service -q apache reload
796 fi
797 if [ -L /etc/httpd/httpd.conf/99_%{_webapp}.conf ]; then
798         /usr/sbin/webapp register httpd %{_webapp}
799         rm -f /etc/httpd/httpd.conf/99_%{_webapp}.conf
800         %service -q httpd reload
801 fi
802
803 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.1_to_v1.7.0 <<EOF
804 database_changes.php Perform database changes
805 set_root_message_ids.php Set iss_root_message_id
806 EOF
807
808 # regular configs
809 for i in apache.conf config.php private_key.php setup.php; do
810         if [ -f /etc/eventum/$i.rpmsave ]; then
811                 mv -f %{_webappdir}/$i{,.rpmnew}
812                 mv -f /etc/eventum/$i.rpmsave %{_webappdir}/$i
813         fi
814 done
815
816 %triggerpostun cli -- %{name}-cli < 1.7.0-3.4
817 if [ -f %{_webappdir}/cli.php.rpmsave ]; then
818         mv -f %{_sysconfdir}/cli.php{,.rpmnew}
819         mv -f %{_webappdir}/cli.php.rpmsave %{_sysconfdir}/cli.php
820 fi
821
822 %triggerpostun irc -- %{name}-irc < 1.7.0-3.4
823 if [ -f %{_webappdir}/irc.php.rpmsave ]; then
824         mv -f %{_sysconfdir}/irc.php{,.rpmnew}
825         mv -f %{_webappdir}/irc.php.rpmsave %{_sysconfdir}/irc.php
826 fi
827
828 %files
829 %defattr(644,root,root,755)
830 %doc ChangeLog FAQ INSTALL README UPGRADE CONTRIB
831 %doc docs/* setup/schema.sql
832 %attr(751,root,root) %dir %{_webappdir}
833 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
834 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
835 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
836 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
837 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
838 %attr(640,root,eventum) %config %verify(not mtime) %{_webappdir}/core.php
839
840 %dir %attr(731,root,eventum) /var/log/%{name}
841 %attr(620,root,eventum) %ghost /var/log/%{name}/*
842
843 %dir %{_appdir}/htdocs
844 %{_appdir}/htdocs/*.php
845 %{_appdir}/htdocs/*.ico
846 %{_appdir}/htdocs/css
847 %{_appdir}/htdocs/customer
848 %{_appdir}/htdocs/images
849 %{_appdir}/htdocs/js
850 %{_appdir}/htdocs/manage
851 %{_appdir}/htdocs/reports
852 %{_appdir}/htdocs/rpc
853 %{_appdir}/htdocs/misc
854 %{_appdir}/templates
855 %dir %{_appdir}/upgrade
856 %attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
857 %{_appdir}/upgrade/[!u]*
858 %{_smartyplugindir}
859
860 %dir %{_appdir}/include
861 %{_appdir}/include/customer
862 %{_appdir}/include/custom_field
863 %{_appdir}/include/jpgraph
864 %{_appdir}/include/workflow
865 %{_appdir}/include/class.[!m]*.php
866 %{_appdir}/include/class.mail.php
867 %{_appdir}/include/class.mail_queue.php
868 %{_appdir}/include/class.mime_helper.php
869 %{_appdir}/include/class.misc.php
870 %{_appdir}/include/db_access.php
871
872 %dir %attr(730,root,eventum) /var/run/%{name}
873 %dir %attr(730,root,eventum) /var/cache/%{name}
874
875 %files base
876 %defattr(644,root,root,755)
877 %attr(751,root,root) %dir %{_sysconfdir}
878 %dir %{_libdir}
879 %dir %{_appdir}
880 # qmail will ignore user, if it's home directory is not owned
881 %attr(750,eventum,eventum) %dir /var/lib/%{name}
882 # saved mail copies
883 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_emails
884 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_drafts
885 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_notes
886
887 %files setup
888 %defattr(644,root,root,755)
889 %{_appdir}/htdocs/setup
890
891 %files mail-queue
892 %defattr(644,root,root,755)
893 %attr(755,root,root) %{_appdir}/process_mail_queue.php
894 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
895
896 %files mail-download
897 %defattr(644,root,root,755)
898 %attr(755,root,root) %{_appdir}/download_emails.php
899 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
900
901 %files reminder
902 %defattr(644,root,root,755)
903 %attr(755,root,root) %{_appdir}/check_reminders.php
904 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
905
906 %files monitor
907 %defattr(644,root,root,755)
908 %{_appdir}/include/class.monitor.php
909 %attr(755,root,root) %{_appdir}/monitor.php
910 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
911
912 %files route-drafts
913 %defattr(644,root,root,755)
914 %attr(755,root,root) %{_appdir}/route_drafts.php
915
916 %files route-emails
917 %defattr(644,root,root,755)
918 %attr(755,root,root) %{_appdir}/route_emails.php
919
920 %files route-notes
921 %defattr(644,root,root,755)
922 %attr(755,root,root) %{_appdir}/route_notes.php
923
924 %if %{with qmail}
925 %files router-qmail
926 %defattr(644,root,root,755)
927 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
928 %attr(755,root,root) %{_libdir}/router-qmail
929 %endif
930
931 %files router-postfix
932 %defattr(644,root,root,755)
933 %attr(755,root,root) %{_libdir}/router-postfix
934
935 %files irc
936 %defattr(644,root,root,755)
937 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
938 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
939 %attr(755,root,root) %{_sbindir}/%{name}-bot
940 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
941
942 %files cli
943 %defattr(644,root,root,755)
944 %doc eventumrc
945 %attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
946 %attr(755,root,root) %{_bindir}/%{name}
947 %{_appdir}/cli
948
949 %files scm
950 %defattr(644,root,root,755)
951 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
952 %attr(755,root,root) %{_libdir}/scm
This page took 0.194334 seconds and 4 git commands to generate.