]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- logrotate for eventum
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 # - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
9 #
10 # Conditional build:
11 %bcond_with     qmail   # build the router-qmail subpackage
12 %bcond_with     order_patch     # with custom issue order patch
13
14 #define _snap   20060330
15 #define _rc             RC3
16 %define _rel    2.22
17
18 %include        /usr/lib/rpm/macros.php
19 Summary:        Eventum Issue / Bug tracking system
20 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
21 Name:           eventum
22 Version:        1.7.1
23 Release:        %{?_snap:0.%{_snap}.}%{?_rc:%{_rc}.}%{_rel}
24 License:        GPL
25 Group:          Applications/WWW
26 #Source0:       http://downloads.mysql.com/snapshots/eventum/%{name}-nightly-%{_snap}.tar.gz
27 Source0:        http://mysql.dataphone.se/Downloads/eventum/%{name}-%{version}.tar.gz
28 # Source0-md5:  e1845de39b4d9bd30ddec9c26031a7d5
29 Source1:        %{name}-apache.conf
30 Source2:        %{name}-mail-queue.cron
31 Source3:        %{name}-mail-download.cron
32 Source4:        %{name}-reminder.cron
33 Source5:        %{name}-monitor.cron
34 Source6:        %{name}-cvs.php
35 Source7:        %{name}-irc.php
36 Source8:        %{name}-irc.init
37 Source9:        %{name}-irc.sysconfig
38 Source10:       %{name}-config.php
39 Source11:       %{name}-router-qmail.sh
40 Source12:       %{name}-config-setup.php
41 Source13:       %{name}-upgrade.sh
42 Source14:       %{name}-router-postfix.sh
43 Source15:       %{name}.logrotate
44 Patch0:         %{name}-lf.patch
45 Patch1:         %{name}-perms.patch
46 Patch2:         %{name}-cli-wr-separated.patch
47 Patch3:         %{name}-scm-parse-response.patch
48 Patch4:         %{name}-double-decode.patch
49 Patch5:         %{name}-route-mem.patch
50 Patch6:         %{name}-scm-pluscharisbad.patch
51 Patch7:         %{name}-scm-updates.patch
52 Patch8:         %{name}-close-signature.patch
53 Patch9:         %{name}-list-sorting.patch
54 Patch10:        %{name}-workflow-handlenewnote-note_id.patch
55 Patch11:        %{name}-order4b.patch
56 Patch12:        %{name}-cli-errorcheck.patch
57 Patch13:        %{name}-combined.patch
58 Patch14:        %{name}-xml-inline.patch
59 Patch15:        %{name}-timetracking-advanced-logic.patch
60 Patch16:        %{name}-timedisplay.patch
61 Patch17:        %{name}-bug-17267.patch
62 # packaging patches that probably never go upstream
63 Patch100:       %{name}-paths.patch
64 Patch101:       %{name}-cvs-config.patch
65 Patch102:       %{name}-irc-mem.patch
66 Patch103:       %{name}-irc-config.patch
67 Patch104:       %{name}-PEAR.patch
68 Patch105:       %{name}-httpclient-clientside.patch
69 Patch106:       %{name}-bot-reconnect.patch
70 Patch107:       %{name}-private-key.patch
71 URL:            http://dev.mysql.com/downloads/other/eventum/
72 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
73 BuildRequires:  rpmbuild(macros) >= 1.268
74 BuildRequires:  sed >= 4.0
75 Requires(triggerpostun):        /usr/bin/php
76 Requires(triggerpostun):        sed >= 4.0
77 Requires:       %{name}-base = %{version}-%{release}
78 Requires:       Smarty >= 2.6.10-4
79 Requires:       apache(mod_dir)
80 Requires:       php >= 3:4.2.0
81 Requires:       php-gd
82 Requires:       php-imap
83 Requires:       php-mysql
84 Requires:       php-pcre
85 Requires:       php-pear-Benchmark
86 Requires:       php-pear-DB
87 Requires:       php-pear-Date
88 Requires:       php-pear-HTTP_Request
89 Requires:       php-pear-Mail
90 Requires:       php-pear-Mail_Mime
91 Requires:       php-pear-Math_Stats
92 Requires:       php-pear-Net_DIME
93 Requires:       php-pear-Net_SMTP
94 Requires:       php-pear-Net_Socket
95 Requires:       php-pear-Net_URL
96 Requires:       php-pear-Net_UserAgent_Detect
97 Requires:       php-pear-PEAR-core
98 Requires:       php-pear-Text_Diff
99 Requires:       php-pear-XML_RPC
100 Requires:       php-session
101 Requires:       webapps
102 BuildArch:      noarch
103 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
104
105 %define         _noautoreq      'pear(/etc/webapps/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)'
106
107 %define         _libdir         %{_prefix}/lib/%{name}
108 %define         _appdir         %{_datadir}/%{name}
109 %define         _smartyplugindir        %{_appdir}/include/smarty
110 %define         _smartydir      /usr/share/php/Smarty
111 %define         _webapps        /etc/webapps
112 %define         _webapp         %{name}
113 %define         _webappdir      %{_webapps}/%{_webapp}
114 %define         _sysconfdir     /etc/%{name}
115
116 %description
117 Eventum is a user-friendly and flexible issue tracking system that can
118 be used by a support department to track incoming technical support
119 requests, or by a software development team to quickly organize tasks
120 and bugs. Eventum is used by the MySQL AB Technical Support team, and
121 has allowed us to dramatically improve our response times.
122
123 %description -l pl
124 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
125 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
126 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
127 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
128 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
129 reakcji.
130
131 %package base
132 Summary:        Eventum base package
133 Summary(pl):    Podstawowy pakiet Eventum
134 Group:          Applications/WWW
135 Requires(postun):       /usr/sbin/groupdel
136 Requires(postun):       /usr/sbin/userdel
137 Requires(pre):  /bin/id
138 Requires(pre):  /usr/bin/getgid
139 Requires(pre):  /usr/sbin/groupadd
140 Requires(pre):  /usr/sbin/useradd
141 Provides:       group(eventum)
142 Provides:       user(eventum)
143
144 %description base
145 This package contains base directory structure for Eventum.
146
147 %description base -l pl
148 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
149
150 %package setup
151 Summary:        Eventum setup package
152 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
153 Group:          Applications/WWW
154 Requires:       %{name} = %{version}-%{release}
155
156 %description setup
157 Install this package to configure initial Eventum installation. You
158 should uninstall this package when you're done, as it considered
159 insecure to keep the setup files in place.
160
161 %description setup -l pl
162 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
163 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
164 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
165
166 %package mail-queue
167 Summary:        Eventum mail queue process
168 Summary(pl):    Przetwarzanie kolejki poczty Eventum
169 Group:          Applications/WWW
170 Requires:       %{name} = %{version}-%{release}
171 Requires:       crondaemon
172
173 %description mail-queue
174 Beginning with the first release of Eventum, emails are not directly
175 sent out from the various scripts, but rather added to a mail queue
176 table that is processed by a cron job. If an email cannot be sent, it
177 will be marked as such in the mail queue log, and the cron job script
178 will re-try to send it again the next time it runs.
179
180 This package contains the cron job.
181
182 %description mail-queue -l pl
183 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
184 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
185 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
186 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
187 nastêpnym razem.
188
189 Ten pakiet zawiera zadanie dla crona.
190
191 %package mail-download
192 Summary:        Eventum email download
193 Summary(pl):    ¦ci±ganie poczty Eventum
194 Group:          Applications/WWW
195 Requires:       %{name} = %{version}-%{release}
196 Requires:       crondaemon
197
198 %description mail-download
199 In order for Eventum's email integration feature to work, you need to
200 setup a cron job to run the script every so often.
201
202 This package contains the cron job.
203
204 %description mail-download -l pl
205 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
206 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
207 czêsto.
208
209 Ten pakiet zawiera zadanie dla crona.
210
211 %package reminder
212 Summary:        Eventum Reminder System
213 Summary(pl):    System przypominania dla Eventum
214 Group:          Applications/WWW
215 Requires:       %{name} = %{version}-%{release}
216 Requires:       crondaemon
217
218 %description reminder
219 The reminder system was designed with the objective as serving as a
220 safe net for issues that need attention. Depending on what
221 configuration you create, you may have several reminders (or alerts)
222 be sent out whenever an issue needs attention, for whatever parameter
223 you may deem necessary.
224
225 This package contains the cron job.
226
227 %description reminder -l pl
228 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
229 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
230 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
231 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
232 uwa¿aæ za potrzebny.
233
234 Ten pakiet zawiera zadanie dla crona.
235
236 %package monitor
237 Summary:        Eventum Heartbeat Monitor
238 Summary(pl):    Monitor ¿ycia dla Eventum
239 Group:          Applications/WWW
240 Requires:       %{name} = %{version}-%{release}
241 Requires:       crondaemon
242 Requires:       php-posix
243
244 %description monitor
245 The heartbeat monitor is a feature designed for the administrator that
246 wants to be alerted whenever a common problem in Eventum is detected,
247 like the database server not being available anymore, or maybe when
248 the recommended permissions for certain configuration files are
249 changed.
250
251 Please note that before running the heartbeat monitor, you may need to
252 customize some of the checks to be appropriate for your own system,
253 particularly the permission and file checks on
254 Monitor::checkConfiguration().
255
256 This package contains the cron job.
257
258 %description monitor -l pl
259 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
260 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
261 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
262 do plików konfiguracyjnych.
263
264 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
265 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
266 testów uprawnieñ i plików w Monitor::checkConfiguration().
267
268 Ten pakiet zawiera zadanie dla crona.
269
270 %package route-drafts
271 Summary:        Eventum Draft Routing
272 Summary(pl):    Przekazywanie szkiców dla Eventum
273 Group:          Applications/WWW
274 Requires:       %{name} = %{version}-%{release}
275 Requires:       eventum(router)
276
277 %description route-drafts
278 The draft routing feature is used to automatically associate a thread
279 of drafts into an Eventum issue. By setting up qmail (or even Postfix)
280 to deliver emails sent to a specific address (usually
281 draft-<number>@<domain>) to the above script, users are able to send
282 drafts written in their mail client to be stored in Eventum. These
283 drafts will NOT broadcasted to the notification list.
284
285 %description route-drafts -l pl
286 Przekazywanie szkiców s³u¿y do automatycznego wi±zania w±tku szkiców z
287 problemem w Eventum. Ustawiaj±c qmaila (czy nawet Postfiksa), aby
288 dostarcza³ pocztê wys³an± na podany adres (zwykle
289 draft-<liczba>@<domena>) do tego skryptu umo¿liwia siê u¿ytkownikom
290 wysy³anie szkiców napisanych w ich kliencie pocztowym do zapisania w
291 Eventum. Szkice te NIE bêd± wysy³ane na listê powiadomieñ.
292
293 %package route-emails
294 Summary:        Eventum Email Routing
295 Summary(pl):    Przekazywanie poczty dla Eventum
296 Group:          Applications/WWW
297 Requires:       %{name} = %{version}-%{release}
298 Requires:       eventum(router)
299
300 %description route-emails
301 The email routing feature is used to automatically associate a thread
302 of emails into an Eventum issue. By setting up qmail (or even postfix)
303 to deliver emails sent to a specific address (usually
304 issue-<number>@<domain>) to the above script, users are able to use
305 their email clients to reply to emails coming from Eventum, and those
306 replies will be automatically associated with the issue and
307 broadcasted to the entire notification list.
308
309 %description route-emails -l pl
310 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
311 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
312 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
313 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
314 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
315 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
316 rozprowadzane do ca³ej listy og³oszeniowej.
317
318 %package route-notes
319 Summary:        Eventum Note Routing
320 Summary(pl):    Przekazywanie notatek dla Eventum
321 Group:          Applications/WWW
322 Requires:       %{name} = %{version}-%{release}
323 Requires:       eventum(router)
324
325 %description route-notes
326 The note routing feature is used to automatically associate a thread
327 of notes into an Eventum issue. By setting up qmail (or even postfix)
328 to deliver emails sent to a specific address (usually
329 note-<number>@<domain>) to the above script, users are able to use
330 their email clients to reply to internal notes coming from Eventum,
331 and those replies will be automatically associated with the issue and
332 broadcasted to the notification list staff members.
333
334 %description route-notes -l pl
335 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
336 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
337 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
338 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
339 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
340 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
341 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
342
343 %package router-qmail
344 Summary:        Eventum Mail Routing - qmail
345 Summary(pl):    Przekazywanie poczty Eventum - qmail
346 Group:          Applications/Mail
347 # loose dep is intentional. qmail subpackage isn't built on PLD
348 # builders and there really nothing changes.
349 Requires:       %{name} >= %{version}-%{release}
350 Requires:       qmail >= 1.03
351 Provides:       eventum(router)
352 Obsoletes:      eventum(router)
353
354 %description router-qmail
355 This package provides way of routing notes and emails back to Eventum
356 via qmail.
357
358 %description router-qmail -l pl
359 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
360 przez qmaila.
361
362 %package router-postfix
363 Summary:        Eventum Mail Routing - Postfix
364 Summary(pl):    Przekazywanie poczty Eventum - Postfix
365 Group:          Applications/Mail
366 Requires:       %{name} = %{version}-%{release}
367 Requires:       postfix
368 Provides:       eventum(router)
369 Obsoletes:      eventum(router)
370
371 %description router-postfix
372 This package provides way of routing notes and emails back to Eventum
373 via Postfix.
374
375 The Postfix configuration instructions you can find from
376 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
377
378 %description router-postfix -l pl
379 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
380 przez Postfiksa.
381
382 Opis konfiguracji Postfiksa mo¿na znale¼æ pod adresem
383 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
384
385 %package irc
386 Summary:        Eventum IRC Notification Bot
387 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
388 Group:          Applications/WWW
389 Requires(post,preun):   /sbin/chkconfig
390 Requires(triggerpostun):        sed >= 4.0
391 Requires:       %{name} = %{version}-%{release}
392 Requires:       php-pear-Net_SmartIRC
393 Requires:       php-sockets
394 Requires:       rc-scripts >= 0.4.0.18
395
396 %description irc
397 The IRC notification bot is a nice feature for remote teams that want
398 to handle issues and want to have a quick and easy way to get simple
399 notifications. Right now the bot notifies of the following actions:
400 - New Issues
401 - Blocked emails
402 - Issues that got their assignment list changed
403
404 NOTE: You will need to manually edit the bot.php script to set your
405 appropriate preferences, like IRC server and channel that the bot
406 should join.
407
408 %description irc -l pl
409 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
410 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
411 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
412 nastêpuj±cych zdarzeniach:
413 - nowych sprawach
414 - zablokowanych listach
415 - sprawach, dla których zmieni³a siê lista powi±zañ
416
417 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
418 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
419
420 %package cli
421 Summary:        Eventum command-line interface
422 Summary(pl):    Interfejs linii poleceñ dla Eventum
423 Group:          Applications/WWW
424 Requires:       %{name}-base = %{version}-%{release}
425 Requires:       php-cli
426 Requires:       php-common >= 3:4.1.0
427 Requires:       php-pear-XML_RPC
428
429 %description cli
430 The Eventum command-line interface allows you to access most of the
431 features of the web interface straight from your command shell.
432
433 %description cli -l pl
434 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
435 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
436
437 %package scm
438 Summary:        Eventum SCM integration
439 Summary(pl):    Integracja SCM dla Eventum
440 Group:          Applications/WWW
441 Requires:       %{name}-base = %{version}-%{release}
442 Requires:       php-cli
443 Requires:       php-common >= 3:4.1.0
444 Requires:       php-pcre
445
446 %description scm
447 This feature allows your software development teams to integrate your
448 Source Control Management system with your Issue Tracking System.
449
450 The integration is implemented in such a way that it will be forward
451 compatible with pretty much any SCM system, such as CVS.
452
453 For installation see
454 </eventum/help.php?topic=scm_integration_installation>.
455
456 %description scm -l pl
457 Ten pakiet pozwala zespo³om programistów na integracjê systemu
458 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
459 ¶ledzenia spraw.
460
461 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
462 prawie ka¿dym systemem SCM, jak np. CVS.
463
464 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
465 </eventum/help.php?topic=scm_integration_installation>.
466
467 %prep
468 %setup -q %{?_snap:-n %{name}-%{_snap}}
469 # undos the source
470 find . -type f -print0 | xargs -0 sed -i -e 's,\r$,,'
471
472 rm -f setup.conf.php # not to be installed by *.php glob
473 rm -rf misc/upgrade/*v1.[123]* # too old to support in PLD Linux
474 rm -f misc/upgrade/flush_compiled_templates.php
475 rm -rf misc/upgrade/*/upgrade_config.php # not needed in PLD Linux
476
477 # sample, not used in eventum
478 rm -f rpc/xmlrpc_client.php
479
480 # bug fixes.
481 %patch0 -p1
482 %patch1 -p1
483 %patch2 -p1
484 %patch3 -p1
485 %patch4 -p1
486 %patch5 -p1
487 %patch6 -p1
488 %patch7 -p1
489 %patch8 -p1
490 %patch9 -p1
491 %patch10 -p1
492 %{?with_order_patch:%patch11 -p1}
493 %patch12 -p1
494 %patch13 -p1
495 %patch14 -p1
496 %patch15 -p1
497 %patch16 -p1
498 %patch17 -p1
499
500 # packaging
501 %patch100 -p1
502 %patch101 -p1
503 %patch102 -p1
504 %patch103 -p1
505 %patch104 -p1
506 %patch105 -p1
507 %patch106 -p1
508 %patch107 -p1
509
510 sed -e '1s,#!.*/bin/php -q,#!%{_bindir}/php,' misc/cli/eventum > %{name}-cli
511 sed -e '1i#!%{_bindir}/php' misc/scm/process_cvs_commits.php > %{name}-scm
512 sed -e '1i#!%{_bindir}/php' misc/irc/bot.php > %{name}-bot
513 mv misc/cli/eventumrc_example eventumrc
514 sed -i -e '1i#!%{_bindir}/php' misc/*.php
515 chmod +x misc/*.php
516 mv include/private_key.php private_key.php.in
517
518 # replace in remaining scripts config.inc.php to system one
519 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
520         s,include_once(".*config.inc.php"),include_once("%{_webappdir}/core.php"),
521 '
522
523 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
524         s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_webappdir}/private_key.php"),
525 '
526
527 # remove backups from patching as we use globs to package files to buildroot
528 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
529
530 %install
531 rm -rf $RPM_BUILD_ROOT
532 install -d \
533         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
534         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
535         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
536         $RPM_BUILD_ROOT/var/log/{archiv/,}%{name} \
537         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
538         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
539
540 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
541 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
542 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
543 cp -a templates $RPM_BUILD_ROOT%{_appdir}
544 cp -a include/{customer,custom_field,jpgraph,workflow} $RPM_BUILD_ROOT%{_appdir}/include
545 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
546 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
547 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
548
549 cp -a favicon.ico $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
550 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/setup/config.inc.php
551 install %{SOURCE13} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
552
553 # cli
554 install -d $RPM_BUILD_ROOT%{_appdir}/cli
555 cp -a misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
556 cp -a misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
557 install %{name}-cli $RPM_BUILD_ROOT%{_bindir}/%{name}
558 install %{name}-bot $RPM_BUILD_ROOT%{_sbindir}
559
560 # scm
561 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
562 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
563
564 # private key
565 cp -a private_key.php.in $RPM_BUILD_ROOT%{_webappdir}/private_key.php
566
567 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
568 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
569 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
570 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
571 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
572 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
573 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
574 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
575 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
576
577 sed -e '
578 s,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}}%{?_rc:-%{_rc}},
579 s,%%{PHP_PEAR_DIR}%%,%{php_pear_dir},
580 s,%%{APP_PATH}%%,%{_appdir},
581 s,%%{SMARTY_DIR}%%,%{_smartydir},
582 s,%%{SYSCONFDIR}%%,%{_webappdir},
583 ' %{SOURCE10} > $RPM_BUILD_ROOT%{_webappdir}/core.php
584
585 # config
586 > $RPM_BUILD_ROOT%{_webappdir}/setup.php
587 mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_webappdir}/config}.php
588
589 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
590 # These plugins are not in Smarty package (Smarty-2.6.2-3)
591 cp -a \
592         include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
593         include/Smarty/plugins/modifier.highlight_quoted.php \
594         $RPM_BUILD_ROOT%{_smartyplugindir}
595
596 # qmail router
597 %if %{with qmail}
598 d=$RPM_BUILD_ROOT/var/lib/%{name}
599 echo 'root' > $d/.qmail
600 echo 'root' > $d/.qmail-default
601 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
602 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
603 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
604 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
605 %endif
606 # postfix router
607 install %{SOURCE14} $RPM_BUILD_ROOT%{_libdir}/router-postfix
608
609 install -D %{SOURCE15} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
610
611 %clean
612 rm -rf $RPM_BUILD_ROOT
613
614 %pre
615 %addusertogroup http %{name}
616
617 %post
618 # check if the package is configured.
619 if grep -q 'header("Location: setup/")' %{_webappdir}/config.php; then
620 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
621 %banner %{name} -e <<EOF
622
623 You haven't yet configured Eventum!
624 Please open in browser <http://localhost/eventum/>
625 If you need access from elsewhere, you need to edit
626 %{_webappdir}/apache.conf and restart apache.
627
628 IMPORTANT: When You have configured Eventum, please uninstall the
629 setup package, so that %{name}-setup is able to secure your Eventum
630 installation.
631
632 EOF
633 #' vim syntax hack
634 else
635 %banner %{name} -e <<EOF
636
637 You haven't yet configured Eventum!
638
639 To setup eventum, please install %{name}-setup and open in browser
640 <http://localhost/eventum/>.
641 If you need access from elsewhere, you need to edit
642 %{_webappdir}/apache.conf and restart apache.
643
644 IMPORTANT: When You have configured Eventum, please uninstall the
645 setup package, so that %{name}-setup is able to secure your Eventum
646 installation.
647
648 EOF
649 #' vim syntax hack
650 fi
651
652 elif grep -q 'DEFAULTPRIVATEKEY' %{_webappdir}/private_key.php; then
653 %banner %{name} -e <<EOF
654
655 You have default private key installed!
656
657 Install %{name}-setup and open up http://yourserver/eventum/setup/
658 -- that will help you setup initial config.
659
660 when have configured Eventum, please uninstall the setup package,
661 so that %{name}-setup is able to secure your Eventum installation.
662
663 EOF
664         elif [ -d %{_appdir}/setup ]; then
665 %banner %{name} -e <<EOF
666
667 If you have have configured Eventum, please uninstall the setup package,
668 so that %{name}-setup is able to secure your Eventum installation.
669
670 EOF
671 fi
672
673 # nuke Smarty templates cache after upgrade
674 rm -f /var/cache/eventum/*.php
675
676 %preun
677 if [ "$1" = "0" ]; then
678         # nuke cache
679         rm -f /var/cache/eventum/*.php 2>/dev/null || :
680 fi
681
682 %pre base
683 %groupadd -P %{name}-base -g 146 %{name}
684 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
685
686 %postun base
687 if [ "$1" = "0" ]; then
688         %userremove %{name}
689         %groupremove %{name}
690 fi
691
692 %post router-qmail
693 CF=/etc/qmail/control/virtualdomains
694 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
695         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_webappdir}/config.php 2>/dev/null)
696         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
697         umask 022
698         echo "#${FQDN}:%{name}" >> $CF
699
700 %banner %{name}-qmail -e <<EOF
701
702 Added "#${FQDN}:%{name}" to $CF,
703 Please verify that it is correct and restart qmail:
704 # service qmail reload
705
706 Consult qmail-send(8) for more information on virtualdomains.
707
708 EOF
709 fi
710
711 %preun router-qmail
712 if [ "$1" = "0" ]; then
713         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
714 fi
715
716 %post setup
717 chmod 660 %{_webappdir}/{config,private_key}.php
718 chown root:eventum %{_webappdir}/{config,private_key}.php
719
720 %postun setup
721 if [ "$1" = "0" ]; then
722         chmod 640 %{_webappdir}/{config,private_key}.php
723         chown root:eventum %{_webappdir}/{config,private_key}.php
724 fi
725
726 %post irc
727 /sbin/chkconfig --add eventum-irc
728 %service eventum-irc restart "Eventum IRC Bot"
729
730 %triggerin -- apache1
731 %webapp_register apache %{_webapp}
732
733 %triggerun -- apache1
734 %webapp_unregister apache %{_webapp}
735
736 %triggerin -- apache < 2.2.0, apache-base
737 %webapp_register httpd %{_webapp}
738
739 %triggerun -- apache < 2.2.0, apache-base
740 %webapp_unregister httpd %{_webapp}
741
742 # FIXME
743 # only one upgrade trigger is called if you're upgrading over two
744 # versions, say 1.5 to 1.5.3, only 1.5.3 trigger is called.
745 # use common trigger (the highest version and rpmvercmp from poldek?)
746 %triggerpostun -- eventum < 1.5.1-0.257
747 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5_to_v1.5.1 <<EOF
748 database_changes.php Perform database changes
749 EOF
750
751 %triggerpostun -- eventum < 1.5.2-0.289
752 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.1_to_v1.5.2 <<EOF
753 database_changes.php Perform database changes
754 set_priority_ranks.php Fix the ranking of priority values
755 EOF
756
757 %triggerpostun -- eventum < 1.5.3-0.291
758 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.2_to_v1.5.3 <<EOF
759 database_changes.php Perform database changes
760 EOF
761
762 %triggerpostun -- eventum < 1.5.4-1.12
763 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.3_to_v1.5.4 <<EOF
764 database_changes.php Perform database changes
765 EOF
766
767 %triggerpostun -- eventum < 1.6.0-RC2.6
768 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.5_to_v1.6.0 <<EOF
769 database_changes.php Perform database changes
770 upgrade_saved_searches.php Upgrade existing custom filters (saved searches)
771 EOF
772
773 %triggerpostun -- eventum < 1.6.1-0.2
774 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.0_to_v1.6.1 <<EOF
775 database_changes.php Perform database changes
776 EOF
777
778 %triggerpostun irc -- eventum-irc < 1.6.1-3.14
779 sed -i -e '
780 s,\$irc_host,$irc_server_hostname,
781 s,\$irc_port,$irc_server_port,
782 s,\$irc_nick,$nickname,
783 s,\$irc_realname,$realname,
784 s,\$irc_username,$username,
785 s,\$irc_password,$password,
786 ' /etc/eventum/irc.php
787
788 %triggerpostun -- eventum < 1.7.0-2.0.48
789 # migrate from apache-config macros
790 if [ -f /etc/%{name}/apache.conf.rpmsave ]; then
791         if [ -d /etc/apache/webapps.d ]; then
792                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
793                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
794         fi
795
796         if [ -d /etc/httpd/webapps.d ]; then
797                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
798                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
799         fi
800 fi
801
802 if [ -L /etc/apache/conf.d/99_%{_webapp}.conf ]; then
803         /usr/sbin/webapp register apache %{_webapp}
804         rm -f /etc/apache/conf.d/99_%{_webapp}.conf
805         %service -q apache reload
806 fi
807 if [ -L /etc/httpd/httpd.conf/99_%{_webapp}.conf ]; then
808         /usr/sbin/webapp register httpd %{_webapp}
809         rm -f /etc/httpd/httpd.conf/99_%{_webapp}.conf
810         %service -q httpd reload
811 fi
812
813 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.1_to_v1.7.0 <<EOF
814 database_changes.php Perform database changes
815 set_root_message_ids.php Set iss_root_message_id
816 EOF
817
818 # regular configs
819 for i in apache.conf config.php private_key.php setup.php; do
820         if [ -f /etc/eventum/$i.rpmsave ]; then
821                 mv -f %{_webappdir}/$i{,.rpmnew}
822                 mv -f /etc/eventum/$i.rpmsave %{_webappdir}/$i
823         fi
824 done
825
826 %triggerpostun cli -- %{name}-cli < 1.7.0-3.4
827 if [ -f %{_webappdir}/cli.php.rpmsave ]; then
828         mv -f %{_sysconfdir}/cli.php{,.rpmnew}
829         mv -f %{_webappdir}/cli.php.rpmsave %{_sysconfdir}/cli.php
830 fi
831
832 %triggerpostun irc -- %{name}-irc < 1.7.0-3.4
833 if [ -f %{_webappdir}/irc.php.rpmsave ]; then
834         mv -f %{_sysconfdir}/irc.php{,.rpmnew}
835         mv -f %{_webappdir}/irc.php.rpmsave %{_sysconfdir}/irc.php
836 fi
837
838 %files
839 %defattr(644,root,root,755)
840 %doc ChangeLog FAQ INSTALL README UPGRADE CONTRIB
841 %doc docs/* setup/schema.sql
842 %attr(751,root,root) %dir %{_webappdir}
843 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
844 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
845 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
846 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
847 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
848 %attr(640,root,eventum) %config %verify(not mtime) %{_webappdir}/core.php
849
850 %dir %attr(731,root,eventum) /var/log/%{name}
851 %attr(620,root,eventum) %ghost /var/log/%{name}/*
852 %dir %attr(750,root,root) /var/log/archiv/%{name}
853 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
854
855 %dir %{_appdir}/htdocs
856 %{_appdir}/htdocs/*.php
857 %{_appdir}/htdocs/*.ico
858 %{_appdir}/htdocs/css
859 %{_appdir}/htdocs/customer
860 %{_appdir}/htdocs/images
861 %{_appdir}/htdocs/js
862 %{_appdir}/htdocs/manage
863 %{_appdir}/htdocs/reports
864 %{_appdir}/htdocs/rpc
865 %{_appdir}/htdocs/misc
866 %{_appdir}/templates
867 %dir %{_appdir}/upgrade
868 %attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
869 %{_appdir}/upgrade/[!u]*
870 %{_smartyplugindir}
871
872 %dir %{_appdir}/include
873 %{_appdir}/include/customer
874 %{_appdir}/include/custom_field
875 %{_appdir}/include/jpgraph
876 %{_appdir}/include/workflow
877 %{_appdir}/include/class.[!m]*.php
878 %{_appdir}/include/class.mail.php
879 %{_appdir}/include/class.mail_queue.php
880 %{_appdir}/include/class.mime_helper.php
881 %{_appdir}/include/class.misc.php
882 %{_appdir}/include/db_access.php
883
884 %dir %attr(730,root,eventum) /var/run/%{name}
885 %dir %attr(730,root,eventum) /var/cache/%{name}
886
887 %files base
888 %defattr(644,root,root,755)
889 %attr(751,root,root) %dir %{_sysconfdir}
890 %dir %{_libdir}
891 %dir %{_appdir}
892 # qmail will ignore user, if it's home directory is not owned
893 %attr(750,eventum,eventum) %dir /var/lib/%{name}
894 # saved mail copies
895 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_emails
896 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_drafts
897 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_notes
898
899 %files setup
900 %defattr(644,root,root,755)
901 %{_appdir}/htdocs/setup
902
903 %files mail-queue
904 %defattr(644,root,root,755)
905 %attr(755,root,root) %{_appdir}/process_mail_queue.php
906 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
907
908 %files mail-download
909 %defattr(644,root,root,755)
910 %attr(755,root,root) %{_appdir}/download_emails.php
911 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
912
913 %files reminder
914 %defattr(644,root,root,755)
915 %attr(755,root,root) %{_appdir}/check_reminders.php
916 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
917
918 %files monitor
919 %defattr(644,root,root,755)
920 %{_appdir}/include/class.monitor.php
921 %attr(755,root,root) %{_appdir}/monitor.php
922 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
923
924 %files route-drafts
925 %defattr(644,root,root,755)
926 %attr(755,root,root) %{_appdir}/route_drafts.php
927
928 %files route-emails
929 %defattr(644,root,root,755)
930 %attr(755,root,root) %{_appdir}/route_emails.php
931
932 %files route-notes
933 %defattr(644,root,root,755)
934 %attr(755,root,root) %{_appdir}/route_notes.php
935
936 %if %{with qmail}
937 %files router-qmail
938 %defattr(644,root,root,755)
939 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
940 %attr(755,root,root) %{_libdir}/router-qmail
941 %endif
942
943 %files router-postfix
944 %defattr(644,root,root,755)
945 %attr(755,root,root) %{_libdir}/router-postfix
946
947 %files irc
948 %defattr(644,root,root,755)
949 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
950 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
951 %attr(755,root,root) %{_sbindir}/%{name}-bot
952 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
953
954 %files cli
955 %defattr(644,root,root,755)
956 %doc eventumrc
957 %attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
958 %attr(755,root,root) %{_bindir}/%{name}
959 %{_appdir}/cli
960
961 %files scm
962 %defattr(644,root,root,755)
963 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
964 %attr(755,root,root) %{_libdir}/scm
This page took 0.122524 seconds and 4 git commands to generate.