]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- up to bzr r3843
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 #
9 # Conditional build:
10 %bcond_with     qmail   # build the router-qmail subpackage
11 %bcond_without  order   # with experimental order patch
12
13 #define snap    20060921
14 %define rev             r3843
15 %define rel             2.13
16 #define _rc             RC3
17
18 %include        /usr/lib/rpm/macros.php
19 Summary:        Eventum Issue / Bug tracking system
20 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
21 Name:           eventum
22 Version:        2.2
23 Release:        %{?_rc:%{_rc}.}%{rel}%{?snap:.%{snap}}%{?rev:.%{rev}}
24 License:        GPL
25 Group:          Applications/WWW
26 #Source0:       http://downloads.mysql.com/snapshots/eventum/%{name}-nightly-%{snap}.tar.gz
27 #Source0:       http://eventum.mysql.org/downloads/eventum-2.0.RC3.tar.gz
28 #Source0:       http://mysql.easynet.be/Downloads/eventum/%{name}-%{version}.tar.gz
29 # bzr branch lp:eventum eventum && tar -cjf eventum.tar.bz2 --exclude=.bzr --exclude=.bzrignore eventum
30 Source0:        %{name}-%{rev}.tar.bz2
31 # Source0-md5:  394e94ebc88ad96fe9a71666e396113e
32 Source1:        %{name}-apache.conf
33 Source2:        %{name}-mail-queue.cron
34 Source3:        %{name}-mail-download.cron
35 Source4:        %{name}-reminder.cron
36 Source5:        %{name}-monitor.cron
37 Source6:        %{name}-cvs.php
38 Source7:        %{name}-irc.php
39 Source8:        %{name}-irc.init
40 Source9:        %{name}-irc.sysconfig
41 Source10:       %{name}-router-qmail.sh
42 Source12:       %{name}-upgrade.sh
43 Source13:       %{name}-router-postfix.sh
44 Source14:       %{name}.logrotate
45 Source15:       %{name}-lighttpd.conf
46 Source16:       http://www.isocra.com/images/updown2.gif
47 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
48 Patch0:         %{name}-lf.patch
49 Patch2:         %{name}-order.patch
50 # packaging patches that probably never go upstream
51 Patch100:       %{name}-paths.patch
52 Patch101:       %{name}-cvs-config.patch
53 Patch102:       %{name}-irc-config.patch
54 Patch105:       %{name}-bot-reconnect.patch
55 Patch106:       %{name}-mem-limits.patch
56 Patch107:       %{name}-gettext.patch
57 # some tests
58 Patch200:       %{name}-fixed-nav.patch
59 URL:            http://eventum.mysql.org/
60 BuildRequires:  gettext-devel
61 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
62 BuildRequires:  rpmbuild(macros) >= 1.461
63 BuildRequires:  sed >= 4.0
64 Requires(triggerpostun):        /usr/bin/php
65 Requires(triggerpostun):        sed >= 4.0
66 Requires:       %{name}-base = %{version}-%{release}
67 Requires:       Smarty >= 2.6.10-4
68 Requires:       php-common >= 4:5.0
69 Requires:       php-gd
70 Requires:       php-iconv
71 Requires:       php-imap
72 Requires:       php-mbstring
73 Requires:       php-mysql
74 Requires:       php-pcre
75 Requires:       php-pear-DB
76 Requires:       php-pear-Date
77 Requires:       php-pear-HTTP_Request
78 Requires:       php-pear-Mail
79 Requires:       php-pear-Mail_Mime
80 Requires:       php-pear-Mail_mimeDecode
81 Requires:       php-pear-Math_Stats
82 Requires:       php-pear-Net_DIME
83 Requires:       php-pear-Net_SMTP
84 Requires:       php-pear-Net_Socket
85 Requires:       php-pear-Net_URL
86 Requires:       php-pear-Net_UserAgent_Detect
87 Requires:       php-pear-PEAR-core
88 Requires:       php-pear-Text_Diff
89 Requires:       php-pear-XML_RPC
90 Requires:       smarty-gettext
91 Requires:       webapps
92 Requires:       webserver(access)
93 Requires:       webserver(alias)
94 Requires:       webserver(indexfile)
95 Requires:       webserver(php) >= 4.2.0
96 Conflicts:      logrotate < 3.7-4
97 BuildArch:      noarch
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %define         _noautoreq      'pear(/etc/webapps/.*)' 'pear(%{_appdir}/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)'
101
102 %define         _libdir         %{_prefix}/lib/%{name}
103 %define         _appdir         %{_datadir}/%{name}
104 %define         _smartyplugindir        %{_appdir}/include/smarty
105 %define         _smartydir      %{php_data_dir}/Smarty
106 %define         _webapps        /etc/webapps
107 %define         _webapp         %{name}
108 %define         _webappdir      %{_webapps}/%{_webapp}
109 %define         _sysconfdir     /etc/%{name}
110
111 %description
112 Eventum is a user-friendly and flexible issue tracking system that can
113 be used by a support department to track incoming technical support
114 requests, or by a software development team to quickly organize tasks
115 and bugs. Eventum is used by the MySQL AB Technical Support team, and
116 has allowed us to dramatically improve our response times.
117
118 %description -l pl.UTF-8
119 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
120 może być używany przez dział obsługi do śledzenia przychodzących żądań
121 obsługi technicznej albo przez zespół tworzący oprogramowanie do
122 szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
123 Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
124 reakcji.
125
126 %package base
127 Summary:        Eventum base package
128 Summary(pl.UTF-8):      Podstawowy pakiet Eventum
129 Group:          Applications/WWW
130 Requires(postun):       /usr/sbin/groupdel
131 Requires(postun):       /usr/sbin/userdel
132 Requires(pre):  /bin/id
133 Requires(pre):  /usr/bin/getgid
134 Requires(pre):  /usr/sbin/groupadd
135 Requires(pre):  /usr/sbin/useradd
136 Provides:       group(eventum)
137 Provides:       user(eventum)
138
139 %description base
140 This package contains base directory structure for Eventum.
141
142 %description base -l pl.UTF-8
143 Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
144
145 %package setup
146 Summary:        Eventum setup package
147 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
148 Group:          Applications/WWW
149 Requires:       %{name} = %{version}-%{release}
150
151 %description setup
152 Install this package to configure initial Eventum installation. You
153 should uninstall this package when you're done, as it considered
154 insecure to keep the setup files in place.
155
156 %description setup -l pl.UTF-8
157 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
158 pierwszej instalacji. Potem należy go odinstalować, jako że
159 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
160
161 %package mail-queue
162 Summary:        Eventum mail queue process
163 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
164 Group:          Applications/WWW
165 Requires:       %{name} = %{version}-%{release}
166 Requires:       crondaemon
167
168 %description mail-queue
169 Beginning with the first release of Eventum, emails are not directly
170 sent out from the various scripts, but rather added to a mail queue
171 table that is processed by a cron job. If an email cannot be sent, it
172 will be marked as such in the mail queue log, and the cron job script
173 will re-try to send it again the next time it runs.
174
175 This package contains the cron job.
176
177 %description mail-queue -l pl.UTF-8
178 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
179 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
180 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
181 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
182 następnym razem.
183
184 Ten pakiet zawiera zadanie dla crona.
185
186 %package mail-download
187 Summary:        Eventum email download
188 Summary(pl.UTF-8):      Ściąganie poczty Eventum
189 Group:          Applications/WWW
190 Requires:       %{name} = %{version}-%{release}
191 Requires:       crondaemon
192
193 %description mail-download
194 In order for Eventum's email integration feature to work, you need to
195 setup a cron job to run the script every so often.
196
197 This package contains the cron job.
198
199 %description mail-download -l pl.UTF-8
200 Aby integracja poczty elektronicznej w Eventum działała, trzeba
201 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
202 często.
203
204 Ten pakiet zawiera zadanie dla crona.
205
206 %package reminder
207 Summary:        Eventum Reminder System
208 Summary(pl.UTF-8):      System przypominania dla Eventum
209 Group:          Applications/WWW
210 Requires:       %{name} = %{version}-%{release}
211 Requires:       crondaemon
212
213 %description reminder
214 The reminder system was designed with the objective as serving as a
215 safe net for issues that need attention. Depending on what
216 configuration you create, you may have several reminders (or alerts)
217 be sent out whenever an issue needs attention, for whatever parameter
218 you may deem necessary.
219
220 This package contains the cron job.
221
222 %description reminder -l pl.UTF-8
223 System przypominania został zaprojektowany tak, aby służył jako
224 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
225 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
226 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
227 uważać za potrzebny.
228
229 Ten pakiet zawiera zadanie dla crona.
230
231 %package monitor
232 Summary:        Eventum Heartbeat Monitor
233 Summary(pl.UTF-8):      Monitor życia dla Eventum
234 Group:          Applications/WWW
235 Requires:       %{name} = %{version}-%{release}
236 Requires:       crondaemon
237 Requires:       php(posix)
238
239 %description monitor
240 The heartbeat monitor is a feature designed for the administrator that
241 wants to be alerted whenever a common problem in Eventum is detected,
242 like the database server not being available anymore, or maybe when
243 the recommended permissions for certain configuration files are
244 changed.
245
246 Please note that before running the heartbeat monitor, you may need to
247 customize some of the checks to be appropriate for your own system,
248 particularly the permission and file checks on
249 Monitor::checkConfiguration().
250
251 This package contains the cron job.
252
253 %description monitor -l pl.UTF-8
254 Monitor życia to funkcjonalność zaprojektowana dla administratora
255 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
256 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
257 do plików konfiguracyjnych.
258
259 Należy zauważyć, że przed uruchomieniem tego monitora może być
260 konieczne dostosowanie niektórych testów do systemu, w szczególności
261 testów uprawnień i plików w Monitor::checkConfiguration().
262
263 Ten pakiet zawiera zadanie dla crona.
264
265 %package route-drafts
266 Summary:        Eventum Draft Routing
267 Summary(pl.UTF-8):      Przekazywanie szkiców dla Eventum
268 Group:          Applications/WWW
269 Requires:       %{name} = %{version}-%{release}
270 Requires:       eventum(router)
271
272 %description route-drafts
273 The draft routing feature is used to automatically associate a thread
274 of drafts into an Eventum issue. By setting up qmail (or even Postfix)
275 to deliver emails sent to a specific address (usually
276 draft-<number>@<domain>) to the above script, users are able to send
277 drafts written in their mail client to be stored in Eventum. These
278 drafts will NOT broadcasted to the notification list.
279
280 %description route-drafts -l pl.UTF-8
281 Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
282 problemem w Eventum. Ustawiając qmaila (czy nawet Postfiksa), aby
283 dostarczał pocztę wysłaną na podany adres (zwykle
284 draft-<liczba>@<domena>) do tego skryptu umożliwia się użytkownikom
285 wysyłanie szkiców napisanych w ich kliencie pocztowym do zapisania w
286 Eventum. Szkice te NIE będą wysyłane na listę powiadomień.
287
288 %package route-emails
289 Summary:        Eventum Email Routing
290 Summary(pl.UTF-8):      Przekazywanie poczty dla Eventum
291 Group:          Applications/WWW
292 Requires:       %{name} = %{version}-%{release}
293 Requires:       eventum(router)
294
295 %description route-emails
296 The email routing feature is used to automatically associate a thread
297 of emails into an Eventum issue. By setting up qmail (or even postfix)
298 to deliver emails sent to a specific address (usually
299 issue-<number>@<domain>) to the above script, users are able to use
300 their email clients to reply to emails coming from Eventum, and those
301 replies will be automatically associated with the issue and
302 broadcasted to the entire notification list.
303
304 %description route-emails -l pl.UTF-8
305 Funkcjonalność przekazywania poczty służy do automatycznego wiązania
306 wątku listów ze sprawą w Eventum. Po ustawieniu qmaila (czy nawet
307 postfiksa), aby dostarczał listy wysyłane na pewien adres (zwykle
308 issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
309 używać klientów pocztowych do odpowiadania na listy przychodzące z
310 Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
311 rozprowadzane do całej listy ogłoszeniowej.
312
313 %package route-notes
314 Summary:        Eventum Note Routing
315 Summary(pl.UTF-8):      Przekazywanie notatek dla Eventum
316 Group:          Applications/WWW
317 Requires:       %{name} = %{version}-%{release}
318 Requires:       eventum(router)
319
320 %description route-notes
321 The note routing feature is used to automatically associate a thread
322 of notes into an Eventum issue. By setting up qmail (or even postfix)
323 to deliver emails sent to a specific address (usually
324 note-<number>@<domain>) to the above script, users are able to use
325 their email clients to reply to internal notes coming from Eventum,
326 and those replies will be automatically associated with the issue and
327 broadcasted to the notification list staff members.
328
329 %description route-notes -l pl.UTF-8
330 Funkcjonalność przekazywania notatek służy do automatycznego wiązania
331 wątku notatek ze sprawą w Eventum. Po ustawieniu qmaila (czy nawet
332 postfiksa), aby dostarczał listy wysyłane na pewien adres (zwykle
333 note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
334 używać klientów pocztowych do odpowiadania na wewnętrzne notatki
335 pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
336 sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
337
338 %package router-qmail
339 Summary:        Eventum Mail Routing - qmail
340 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - qmail
341 Group:          Applications/Mail
342 # loose dep is intentional. qmail subpackage isn't built on PLD
343 # builders and there really nothing changes.
344 Requires:       %{name} >= %{version}-%{release}
345 Requires:       qmail >= 1.03
346 Provides:       eventum(router)
347 Obsoletes:      eventum(router)
348
349 %description router-qmail
350 This package provides way of routing notes and emails back to Eventum
351 via qmail.
352
353 %description router-qmail -l pl.UTF-8
354 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
355 przez qmaila.
356
357 %package router-postfix
358 Summary:        Eventum Mail Routing - Postfix
359 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
360 Group:          Applications/Mail
361 Requires:       %{name} = %{version}-%{release}
362 Requires:       postfix
363 Provides:       eventum(router)
364 Obsoletes:      eventum(router)
365
366 %description router-postfix
367 This package provides way of routing notes and emails back to Eventum
368 via Postfix.
369
370 The Postfix configuration instructions you can find from
371 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
372
373 %description router-postfix -l pl.UTF-8
374 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
375 przez Postfiksa.
376
377 Opis konfiguracji Postfiksa można znaleźć pod adresem
378 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
379
380 %package irc
381 Summary:        Eventum IRC Notification Bot
382 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
383 Group:          Applications/WWW
384 Requires(post,preun):   /sbin/chkconfig
385 Requires(triggerpostun):        sed >= 4.0
386 Requires:       %{name} = %{version}-%{release}
387 Requires:       php(sockets)
388 Requires:       php-pear-Net_SmartIRC
389 Requires:       rc-scripts >= 0.4.0.18
390
391 %description irc
392 The IRC notification bot is a nice feature for remote teams that want
393 to handle issues and want to have a quick and easy way to get simple
394 notifications. Right now the bot notifies of the following actions:
395 - New Issues
396 - Blocked emails
397 - Issues that got their assignment list changed
398
399 NOTE: You will need to manually edit the bot.php script to set your
400 appropriate preferences, like IRC server and channel that the bot
401 should join.
402
403 %description irc -l pl.UTF-8
404 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
405 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
406 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
407 następujących zdarzeniach:
408 - nowych sprawach
409 - zablokowanych listach
410 - sprawach, dla których zmieniła się lista powiązań
411
412 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
413 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
414
415 %package cli
416 Summary:        Eventum command-line interface
417 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
418 Group:          Applications/WWW
419 Requires:       %{name}-base = %{version}-%{release}
420 Requires:       php-cli
421 Requires:       php-common >= 4:5.0
422 Requires:       php-pear-XML_RPC
423
424 %description cli
425 The Eventum command-line interface allows you to access most of the
426 features of the web interface straight from your command shell.
427
428 %description cli -l pl.UTF-8
429 Interfejs linii poleceń Eventum pozwala na dostęp do większości
430 funkcji interfejsu WWW prosto z linii poleceń powłoki.
431
432 %package scm
433 Summary:        Eventum SCM integration
434 Summary(pl.UTF-8):      Integracja SCM dla Eventum
435 Group:          Applications/WWW
436 Requires:       %{name}-base = %{version}-%{release}
437 Requires:       php-cli
438 Requires:       php-common >= 4:5.0
439 Requires:       php-pcre
440
441 %description scm
442 This feature allows your software development teams to integrate your
443 Source Control Management system with your Issue Tracking System.
444
445 The integration is implemented in such a way that it will be forward
446 compatible with pretty much any SCM system, such as CVS.
447
448 For installation see
449 </eventum/help.php?topic=scm_integration_installation>.
450
451 %description scm -l pl.UTF-8
452 Ten pakiet pozwala zespołom programistów na integrację systemu
453 zarządzania źródłami (SCM - Source Control Management) z systemem
454 śledzenia spraw.
455
456 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
457 prawie każdym systemem SCM, jak np. CVS.
458
459 Szczegóły na temat instalacji można przeczytać pod
460 </eventum/help.php?topic=scm_integration_installation>.
461
462 %prep
463 %setup -q %{?snap:-n %{name}-%{snap}}%{?rev:-n %{name}-%{rev}}
464
465 rm -r misc/upgrade/*v1.[123]* # too old to support in PLD Linux
466 rm -r misc/upgrade/v{1.,2.0,2.1_}* # no longer supported in PLD Linux
467 rm misc/upgrade/flush_compiled_templates.php
468 rm -r misc/upgrade/{*/,}index.html # not needed in PLD Linux
469
470 rm -r include/php-gettext
471 # sample, not used in eventum
472 rm rpc/xmlrpc_client.php
473
474 # bug fixes / features
475 %patch0 -p1
476 %{?with_order:%patch2 -p1}
477
478 cp -a %{SOURCE16} images
479
480 #%patch200 -p1
481
482 # packaging
483 %patch100 -p1
484 %patch101 -p1
485 %patch102 -p1
486 %patch105 -p1
487 %patch106 -p1
488 %patch107 -p1
489
490 cat <<'EOF'> mysql-permissions.sql
491 # use this schema if you want to grant permissions manually instead of using setup
492 # this schema is extracted from setup/index.php.
493 GRANT SELECT, UPDATE, DELETE, INSERT, ALTER, DROP, CREATE, INDEX ON eventum.* TO 'eventum'@'localhost' IDENTIFIED BY 'password';
494 EOF
495
496 sed -e '1s,#!.*/bin/php -q,#!%{_bindir}/php,' misc/cli/eventum > %{name}-cli
497 mv misc/cli/eventumrc_example eventumrc
498 sed -i -e '1i#!%{_bindir}/php' misc/*.php
499 chmod +x misc/*.php
500
501 %{__sed} -i -e "
502 s,require_once.*init.php.*;,require_once '%{_appdir}/htdocs/init.php';,
503 s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
504 /define('INSTALL_PATH'/d
505 " misc/upgrade/{*/,}*.php
506
507 # remove backups from patching as we use globs to package files to buildroot
508 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
509
510 %build
511 %{__make} -C misc/localization
512
513 %install
514 rm -rf $RPM_BUILD_ROOT
515 install -d \
516         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
517         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
518         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
519         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
520         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
521         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
522
523 cp -a *.php css customer images js manage reports rpc setup %{?with_order:ajax} $RPM_BUILD_ROOT%{_appdir}/htdocs
524 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
525 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
526 cp -a templates $RPM_BUILD_ROOT%{_appdir}
527 cp -a include/{customer,custom_field,jpgraph,workflow} $RPM_BUILD_ROOT%{_appdir}/include
528 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
529 touch $RPM_BUILD_ROOT/var/log/%{name}/{cli.log,errors.log,irc_bot.log,login_attempts.log}
530
531 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
532
533 cp -a favicon.ico $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
534 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
535
536 # cli
537 install -d $RPM_BUILD_ROOT%{_appdir}/cli
538 cp -a misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
539 cp -a misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
540 install %{name}-cli $RPM_BUILD_ROOT%{_bindir}/%{name}
541 install misc/irc/bot.php $RPM_BUILD_ROOT%{_sbindir}/%{name}-bot
542
543 # scm
544 install misc/scm/process_cvs_commits.php $RPM_BUILD_ROOT%{_libdir}/process_cvs_commits
545 install misc/scm/process_svn_commits.php $RPM_BUILD_ROOT%{_libdir}/process_svn_commits
546 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
547
548 # private key
549 echo '<?php
550 $private_key = "DEFAULTPRIVATEKEY";' > $RPM_BUILD_ROOT%{_webappdir}/private_key.php
551 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
552
553 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
554 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
555 cp -a %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
556 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
557 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
558 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
559 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
560 cp -a %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
561 cp -a %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
562 cp -a %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
563
564
565 %{__sed} -i -e "/define('APP_VERSION'/ {
566     idefine('APP_VERSION', '%{version}%{?snap:-%{snap}}%{?_rc:-%{_rc}}%{?svn:-%{svn}}');
567     d
568
569 }" $RPM_BUILD_ROOT%{_appdir}/htdocs/init.php
570
571 # config
572 > $RPM_BUILD_ROOT%{_webappdir}/setup.php
573 cat <<'EOF'> $RPM_BUILD_ROOT%{_webappdir}/config.php
574 EOF
575
576 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
577 # These plugins are not in Smarty package (Smarty-2.6.2-3)
578 cp -a \
579         include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
580         include/Smarty/plugins/modifier.highlight_quoted.php \
581         $RPM_BUILD_ROOT%{_smartyplugindir}
582
583 # qmail router
584 %if %{with qmail}
585 d=$RPM_BUILD_ROOT/var/lib/%{name}
586 echo 'root' > $d/.qmail
587 echo 'root' > $d/.qmail-default
588 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
589 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
590 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
591 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/router-qmail
592 %endif
593 # postfix router
594 install %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
595
596 install -D %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
597 # locale
598 cd misc/localization
599 for a in */LC_MESSAGES/*.mo; do
600         d=${a%/*}
601         install -d $RPM_BUILD_ROOT%{_datadir}/locale/$d
602         cp -a $a $RPM_BUILD_ROOT%{_datadir}/locale/$d
603 done
604 cd -
605
606 %find_lang %{name}
607
608 %clean
609 rm -rf $RPM_BUILD_ROOT
610
611 %pre
612 %addusertogroup http %{name}
613
614 %post
615 # check if the package is configured.
616 if grep -q "Header('Location: setup/')" %{_webappdir}/config.php; then
617 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
618 %banner %{name} -e <<EOF
619
620 You haven't yet configured Eventum!
621 Please open in browser <http://localhost/eventum/>
622 If you need access from elsewhere, you need to edit
623 %{_webappdir}/apache.conf and restart apache.
624
625 IMPORTANT: When You have configured Eventum, please uninstall the
626 setup package, so that %{name}-setup is able to secure your Eventum
627 installation.
628
629 EOF
630 #' vim syntax hack
631 else
632 %banner %{name} -e <<EOF
633
634 You haven't yet configured Eventum!
635
636 To setup eventum, please install %{name}-setup and open in browser
637 <http://localhost/eventum/>.
638 If you need access from elsewhere, you need to edit
639 %{_webappdir}/*.conf depending on webserver and restart the webserver.
640
641 IMPORTANT: When You have configured Eventum, please uninstall the
642 setup package, so that %{name}-setup is able to secure your Eventum
643 installation.
644
645 EOF
646 #' vim syntax hack
647 fi
648
649 elif grep -q 'DEFAULTPRIVATEKEY' %{_webappdir}/private_key.php; then
650 %banner %{name} -e <<EOF
651
652 You have default private key installed!
653
654 Install %{name}-setup and open up http://yourserver/eventum/setup/
655 -- that will help you setup initial config.
656
657 when have configured Eventum, please uninstall the setup package,
658 so that %{name}-setup is able to secure your Eventum installation.
659
660 EOF
661         elif [ -d %{_appdir}/setup ]; then
662 %banner %{name} -e <<EOF
663
664 If you have have configured Eventum, please uninstall the setup package,
665 so that %{name}-setup is able to secure your Eventum installation.
666
667 EOF
668 fi
669
670 # greate empty ghost files
671 for a in cli.log errors.log irc_bot.log login_attempts.log; do
672         if [ ! -f /var/log/%{name}/$a ]; then
673                 install -m620 -oroot -geventum /dev/null /var/log/%{name}/$a
674         fi
675 done
676
677 # database update
678 %{_appdir}/upgrade/update-database.php || :
679
680 # nuke Smarty templates cache after upgrade
681 rm -f /var/cache/eventum/*.php
682
683 %preun
684 if [ "$1" = "0" ]; then
685         # nuke cache
686         rm -f /var/cache/eventum/*.php 2>/dev/null || :
687 fi
688
689 %pre base
690 %groupadd -P %{name}-base -g 146 %{name}
691 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
692
693 %postun base
694 if [ "$1" = "0" ]; then
695         %userremove %{name}
696         %groupremove %{name}
697 fi
698
699 %post router-qmail
700 CF=/etc/qmail/control/virtualdomains
701 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
702         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_webappdir}/config.php 2>/dev/null)
703         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
704         umask 022
705         echo "#${FQDN}:%{name}" >> $CF
706
707 %banner %{name}-qmail -e <<EOF
708
709 Added "#${FQDN}:%{name}" to $CF,
710 Please verify that it is correct and restart qmail:
711 # service qmail reload
712
713 Consult qmail-send(8) for more information on virtualdomains.
714
715 EOF
716 fi
717
718 %preun router-qmail
719 if [ "$1" = "0" ]; then
720         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
721 fi
722
723 %post setup
724 chmod 660 %{_webappdir}/{config,private_key}.php
725 chown root:eventum %{_webappdir}/{config,private_key}.php
726
727 %postun setup
728 if [ "$1" = "0" ]; then
729         chmod 640 %{_webappdir}/{config,private_key}.php
730         chown root:eventum %{_webappdir}/{config,private_key}.php
731 fi
732
733 %post irc
734 /sbin/chkconfig --add eventum-irc
735 %service eventum-irc restart "Eventum IRC Bot"
736
737 %preun irc
738 if [ "$1" = 0 ]; then
739         %service eventum-irc stop
740         /sbin/chkconfig --del eventum-irc
741 fi
742
743 %triggerin -- apache1 < 1.3.37-3, apache1-base
744 %webapp_register apache %{_webapp}
745
746 %triggerun -- apache1 < 1.3.37-3, apache1-base
747 %webapp_unregister apache %{_webapp}
748
749 %triggerin -- apache < 2.2.0, apache-base
750 %webapp_register httpd %{_webapp}
751
752 %triggerun -- apache < 2.2.0, apache-base
753 %webapp_unregister httpd %{_webapp}
754
755 %triggerin -- lighttpd
756 %webapp_register lighttpd %{_webapp}
757
758 %triggerun -- lighttpd
759 %webapp_unregister lighttpd %{_webapp}
760
761 %triggerpostun -- eventum < 2.1.1-2.13
762 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v2.1.1_to_v2.2 <<EOF
763 db_version.php Add eventum_version table
764 EOF
765 # automated database update
766 %{_appdir}/upgrade/update-database.php || :
767
768 %files -f %{name}.lang
769 %defattr(644,root,root,755)
770 %doc ChangeLog FAQ INSTALL README UPGRADE CONTRIB
771 %doc docs/* setup/schema.sql mysql-permissions.sql
772 %attr(751,root,root) %dir %{_webappdir}
773 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
774 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
775 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
776 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
777 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
778 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
779 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
780
781 %dir %attr(731,root,eventum) /var/log/%{name}
782 %attr(620,root,eventum) %ghost /var/log/%{name}/*
783 %dir %attr(750,root,root) /var/log/archive/%{name}
784 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
785
786 %dir %{_appdir}/htdocs
787 %{_appdir}/htdocs/*.php
788 %{_appdir}/htdocs/*.ico
789 %{_appdir}/htdocs/css
790 %{_appdir}/htdocs/customer
791 %{_appdir}/htdocs/images
792 %{_appdir}/htdocs/js
793 %{_appdir}/htdocs/manage
794 %{_appdir}/htdocs/reports
795 %{_appdir}/htdocs/rpc
796 %{_appdir}/htdocs/misc
797 %if %{with order}
798 %{_appdir}/htdocs/ajax
799 %endif
800 %{_appdir}/templates
801
802 %dir %{_appdir}/upgrade
803 %attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
804 %attr(755,root,root) %{_appdir}/upgrade/update-database.php
805 %dir %{_appdir}/upgrade/v*
806 %attr(755,root,root) %{_appdir}/upgrade/v*/*.php
807 %{_appdir}/upgrade/patches
808
809 %{_smartyplugindir}
810
811 %dir %{_appdir}/include
812 %{_appdir}/include/customer
813 %{_appdir}/include/custom_field
814 %{_appdir}/include/jpgraph
815 %{_appdir}/include/workflow
816 %{_appdir}/include/autoload.php
817 %{_appdir}/include/class.*.php
818 %{_appdir}/include/db_access.php
819 %exclude %{_appdir}/include/class.monitor.php
820
821 %dir %attr(730,root,eventum) /var/run/%{name}
822 %dir %attr(730,root,eventum) /var/cache/%{name}
823
824 %files base
825 %defattr(644,root,root,755)
826 %attr(751,root,root) %dir %{_sysconfdir}
827 %dir %{_libdir}
828 %dir %{_appdir}
829 # qmail will ignore user, if it's home directory is not owned
830 %attr(750,eventum,eventum) %dir /var/lib/%{name}
831 # saved mail copies
832 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_emails
833 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_drafts
834 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_notes
835
836 %files setup
837 %defattr(644,root,root,755)
838 %{_appdir}/htdocs/setup
839
840 %files mail-queue
841 %defattr(644,root,root,755)
842 %attr(755,root,root) %{_appdir}/process_mail_queue.php
843 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
844
845 %files mail-download
846 %defattr(644,root,root,755)
847 %attr(755,root,root) %{_appdir}/download_emails.php
848 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
849
850 %files reminder
851 %defattr(644,root,root,755)
852 %attr(755,root,root) %{_appdir}/check_reminders.php
853 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
854
855 %files monitor
856 %defattr(644,root,root,755)
857 %{_appdir}/include/class.monitor.php
858 %attr(755,root,root) %{_appdir}/monitor.php
859 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
860
861 %files route-drafts
862 %defattr(644,root,root,755)
863 %attr(755,root,root) %{_appdir}/route_drafts.php
864
865 %files route-emails
866 %defattr(644,root,root,755)
867 %attr(755,root,root) %{_appdir}/route_emails.php
868
869 %files route-notes
870 %defattr(644,root,root,755)
871 %attr(755,root,root) %{_appdir}/route_notes.php
872
873 %if %{with qmail}
874 %files router-qmail
875 %defattr(644,root,root,755)
876 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
877 %attr(755,root,root) %{_libdir}/router-qmail
878 %endif
879
880 %files router-postfix
881 %defattr(644,root,root,755)
882 %attr(755,root,root) %{_libdir}/router-postfix
883
884 %files irc
885 %defattr(644,root,root,755)
886 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
887 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
888 %attr(755,root,root) %{_sbindir}/%{name}-bot
889 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
890
891 %files cli
892 %defattr(644,root,root,755)
893 %doc eventumrc
894 %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
895 %attr(755,root,root) %{_bindir}/%{name}
896 %{_appdir}/cli
897
898 %files scm
899 %defattr(644,root,root,755)
900 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
901 %attr(755,root,root) %{_libdir}/process_cvs_commits
902 %attr(755,root,root) %{_libdir}/process_svn_commits
This page took 0.243081 seconds and 4 git commands to generate.