]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- skip order patch!
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 #
9 # Conditional build:
10 %bcond_with     qmail   # build the router-qmail subpackage
11 %bcond_with     order   # with experimental order pathc
12
13 #define snap    20060921
14 %define svn             r3729
15 %define rel             0.34
16 #define _rc             RC3
17
18 %include        /usr/lib/rpm/macros.php
19 Summary:        Eventum Issue / Bug tracking system
20 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
21 Name:           eventum
22 Version:        2.2
23 Release:        %{?_rc:%{_rc}.}%{rel}%{?snap:.%{snap}}%{?svn:.%{svn}}
24 License:        GPL
25 Group:          Applications/WWW
26 #Source0:       http://downloads.mysql.com/snapshots/eventum/%{name}-nightly-%{snap}.tar.gz
27 #Source0:       http://eventum.mysql.org/downloads/eventum-2.0.RC3.tar.gz
28 #Source0:       http://mysql.tonnikala.org/Downloads/eventum/%{name}-%{version}.tar.gz
29 Source0:        %{name}-%{svn}.tar.bz2
30 # Source0-md5:  a5b8860ab537f839b3a4b385e1ecd6b4
31 Source1:        %{name}-apache.conf
32 Source2:        %{name}-mail-queue.cron
33 Source3:        %{name}-mail-download.cron
34 Source4:        %{name}-reminder.cron
35 Source5:        %{name}-monitor.cron
36 Source6:        %{name}-cvs.php
37 Source7:        %{name}-irc.php
38 Source8:        %{name}-irc.init
39 Source9:        %{name}-irc.sysconfig
40 Source10:       %{name}-router-qmail.sh
41 Source12:       %{name}-upgrade.sh
42 Source13:       %{name}-router-postfix.sh
43 Source14:       %{name}.logrotate
44 Source15:       %{name}-lighttpd.conf
45 Patch0:         %{name}-lf.patch
46 Patch1:         %{name}-order.patch
47 # packaging patches that probably never go upstream
48 Patch100:       %{name}-paths.patch
49 Patch101:       %{name}-cvs-config.patch
50 Patch102:       %{name}-irc-config.patch
51 Patch105:       %{name}-bot-reconnect.patch
52 Patch106:       %{name}-mem-limits.patch
53 Patch107:       %{name}-gettext.patch
54 # some tests
55 Patch200:       %{name}-fixed-nav.patch
56 URL:            http://eventum.mysql.org/
57 BuildRequires:  gettext-devel
58 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
59 BuildRequires:  rpmbuild(macros) >= 1.461
60 BuildRequires:  sed >= 4.0
61 Requires(triggerpostun):        /usr/bin/php
62 Requires(triggerpostun):        sed >= 4.0
63 Requires:       %{name}-base = %{version}-%{release}
64 Requires:       Smarty >= 2.6.10-4
65 Requires:       php-common >= 4:5.0
66 Requires:       php-gd
67 Requires:       php-iconv
68 Requires:       php-imap
69 Requires:       php-mbstring
70 Requires:       php-mysql
71 Requires:       php-pcre
72 Requires:       php-pear-DB
73 Requires:       php-pear-Date
74 Requires:       php-pear-HTTP_Request
75 Requires:       php-pear-Mail
76 Requires:       php-pear-Mail_Mime
77 Requires:       php-pear-Mail_mimeDecode
78 Requires:       php-pear-Math_Stats
79 Requires:       php-pear-Net_DIME
80 Requires:       php-pear-Net_SMTP
81 Requires:       php-pear-Net_Socket
82 Requires:       php-pear-Net_URL
83 Requires:       php-pear-Net_UserAgent_Detect
84 Requires:       php-pear-PEAR-core
85 Requires:       php-pear-Text_Diff
86 Requires:       php-pear-XML_RPC
87 Requires:       smarty-gettext
88 Requires:       webapps
89 Requires:       webserver(access)
90 Requires:       webserver(alias)
91 Requires:       webserver(indexfile)
92 Requires:       webserver(php) >= 4.2.0
93 Conflicts:      logrotate < 3.7-4
94 BuildArch:      noarch
95 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97 %define         _noautoreq      'pear(/etc/webapps/.*)' 'pear(%{_appdir}/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)' 'pear(Benchmark/.*)'
98
99 %define         _libdir         %{_prefix}/lib/%{name}
100 %define         _appdir         %{_datadir}/%{name}
101 %define         _smartyplugindir        %{_appdir}/include/smarty
102 %define         _smartydir      %{php_data_dir}/Smarty
103 %define         _webapps        /etc/webapps
104 %define         _webapp         %{name}
105 %define         _webappdir      %{_webapps}/%{_webapp}
106 %define         _sysconfdir     /etc/%{name}
107
108 %description
109 Eventum is a user-friendly and flexible issue tracking system that can
110 be used by a support department to track incoming technical support
111 requests, or by a software development team to quickly organize tasks
112 and bugs. Eventum is used by the MySQL AB Technical Support team, and
113 has allowed us to dramatically improve our response times.
114
115 %description -l pl.UTF-8
116 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
117 może być używany przez dział obsługi do śledzenia przychodzących żądań
118 obsługi technicznej albo przez zespół tworzący oprogramowanie do
119 szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
120 Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
121 reakcji.
122
123 %package base
124 Summary:        Eventum base package
125 Summary(pl.UTF-8):      Podstawowy pakiet Eventum
126 Group:          Applications/WWW
127 Requires(postun):       /usr/sbin/groupdel
128 Requires(postun):       /usr/sbin/userdel
129 Requires(pre):  /bin/id
130 Requires(pre):  /usr/bin/getgid
131 Requires(pre):  /usr/sbin/groupadd
132 Requires(pre):  /usr/sbin/useradd
133 Provides:       group(eventum)
134 Provides:       user(eventum)
135
136 %description base
137 This package contains base directory structure for Eventum.
138
139 %description base -l pl.UTF-8
140 Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
141
142 %package setup
143 Summary:        Eventum setup package
144 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
145 Group:          Applications/WWW
146 Requires:       %{name} = %{version}-%{release}
147
148 %description setup
149 Install this package to configure initial Eventum installation. You
150 should uninstall this package when you're done, as it considered
151 insecure to keep the setup files in place.
152
153 %description setup -l pl.UTF-8
154 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
155 pierwszej instalacji. Potem należy go odinstalować, jako że
156 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
157
158 %package mail-queue
159 Summary:        Eventum mail queue process
160 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
161 Group:          Applications/WWW
162 Requires:       %{name} = %{version}-%{release}
163 Requires:       crondaemon
164
165 %description mail-queue
166 Beginning with the first release of Eventum, emails are not directly
167 sent out from the various scripts, but rather added to a mail queue
168 table that is processed by a cron job. If an email cannot be sent, it
169 will be marked as such in the mail queue log, and the cron job script
170 will re-try to send it again the next time it runs.
171
172 This package contains the cron job.
173
174 %description mail-queue -l pl.UTF-8
175 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
176 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
177 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
178 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
179 następnym razem.
180
181 Ten pakiet zawiera zadanie dla crona.
182
183 %package mail-download
184 Summary:        Eventum email download
185 Summary(pl.UTF-8):      Ściąganie poczty Eventum
186 Group:          Applications/WWW
187 Requires:       %{name} = %{version}-%{release}
188 Requires:       crondaemon
189
190 %description mail-download
191 In order for Eventum's email integration feature to work, you need to
192 setup a cron job to run the script every so often.
193
194 This package contains the cron job.
195
196 %description mail-download -l pl.UTF-8
197 Aby integracja poczty elektronicznej w Eventum działała, trzeba
198 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
199 często.
200
201 Ten pakiet zawiera zadanie dla crona.
202
203 %package reminder
204 Summary:        Eventum Reminder System
205 Summary(pl.UTF-8):      System przypominania dla Eventum
206 Group:          Applications/WWW
207 Requires:       %{name} = %{version}-%{release}
208 Requires:       crondaemon
209
210 %description reminder
211 The reminder system was designed with the objective as serving as a
212 safe net for issues that need attention. Depending on what
213 configuration you create, you may have several reminders (or alerts)
214 be sent out whenever an issue needs attention, for whatever parameter
215 you may deem necessary.
216
217 This package contains the cron job.
218
219 %description reminder -l pl.UTF-8
220 System przypominania został zaprojektowany tak, aby służył jako
221 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
222 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
223 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
224 uważać za potrzebny.
225
226 Ten pakiet zawiera zadanie dla crona.
227
228 %package monitor
229 Summary:        Eventum Heartbeat Monitor
230 Summary(pl.UTF-8):      Monitor życia dla Eventum
231 Group:          Applications/WWW
232 Requires:       %{name} = %{version}-%{release}
233 Requires:       crondaemon
234 Requires:       php(posix)
235
236 %description monitor
237 The heartbeat monitor is a feature designed for the administrator that
238 wants to be alerted whenever a common problem in Eventum is detected,
239 like the database server not being available anymore, or maybe when
240 the recommended permissions for certain configuration files are
241 changed.
242
243 Please note that before running the heartbeat monitor, you may need to
244 customize some of the checks to be appropriate for your own system,
245 particularly the permission and file checks on
246 Monitor::checkConfiguration().
247
248 This package contains the cron job.
249
250 %description monitor -l pl.UTF-8
251 Monitor życia to funkcjonalność zaprojektowana dla administratora
252 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
253 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
254 do plików konfiguracyjnych.
255
256 Należy zauważyć, że przed uruchomieniem tego monitora może być
257 konieczne dostosowanie niektórych testów do systemu, w szczególności
258 testów uprawnień i plików w Monitor::checkConfiguration().
259
260 Ten pakiet zawiera zadanie dla crona.
261
262 %package route-drafts
263 Summary:        Eventum Draft Routing
264 Summary(pl.UTF-8):      Przekazywanie szkiców dla Eventum
265 Group:          Applications/WWW
266 Requires:       %{name} = %{version}-%{release}
267 Requires:       eventum(router)
268
269 %description route-drafts
270 The draft routing feature is used to automatically associate a thread
271 of drafts into an Eventum issue. By setting up qmail (or even Postfix)
272 to deliver emails sent to a specific address (usually
273 draft-<number>@<domain>) to the above script, users are able to send
274 drafts written in their mail client to be stored in Eventum. These
275 drafts will NOT broadcasted to the notification list.
276
277 %description route-drafts -l pl.UTF-8
278 Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
279 problemem w Eventum. Ustawiając qmaila (czy nawet Postfiksa), aby
280 dostarczał pocztę wysłaną na podany adres (zwykle
281 draft-<liczba>@<domena>) do tego skryptu umożliwia się użytkownikom
282 wysyłanie szkiców napisanych w ich kliencie pocztowym do zapisania w
283 Eventum. Szkice te NIE będą wysyłane na listę powiadomień.
284
285 %package route-emails
286 Summary:        Eventum Email Routing
287 Summary(pl.UTF-8):      Przekazywanie poczty dla Eventum
288 Group:          Applications/WWW
289 Requires:       %{name} = %{version}-%{release}
290 Requires:       eventum(router)
291
292 %description route-emails
293 The email routing feature is used to automatically associate a thread
294 of emails into an Eventum issue. By setting up qmail (or even postfix)
295 to deliver emails sent to a specific address (usually
296 issue-<number>@<domain>) to the above script, users are able to use
297 their email clients to reply to emails coming from Eventum, and those
298 replies will be automatically associated with the issue and
299 broadcasted to the entire notification list.
300
301 %description route-emails -l pl.UTF-8
302 Funkcjonalność przekazywania poczty służy do automatycznego wiązania
303 wątku listów ze sprawą w Eventum. Po ustawieniu qmaila (czy nawet
304 postfiksa), aby dostarczał listy wysyłane na pewien adres (zwykle
305 issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
306 używać klientów pocztowych do odpowiadania na listy przychodzące z
307 Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
308 rozprowadzane do całej listy ogłoszeniowej.
309
310 %package route-notes
311 Summary:        Eventum Note Routing
312 Summary(pl.UTF-8):      Przekazywanie notatek dla Eventum
313 Group:          Applications/WWW
314 Requires:       %{name} = %{version}-%{release}
315 Requires:       eventum(router)
316
317 %description route-notes
318 The note routing feature is used to automatically associate a thread
319 of notes into an Eventum issue. By setting up qmail (or even postfix)
320 to deliver emails sent to a specific address (usually
321 note-<number>@<domain>) to the above script, users are able to use
322 their email clients to reply to internal notes coming from Eventum,
323 and those replies will be automatically associated with the issue and
324 broadcasted to the notification list staff members.
325
326 %description route-notes -l pl.UTF-8
327 Funkcjonalność przekazywania notatek służy do automatycznego wiązania
328 wątku notatek ze sprawą w Eventum. Po ustawieniu qmaila (czy nawet
329 postfiksa), aby dostarczał listy wysyłane na pewien adres (zwykle
330 note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
331 używać klientów pocztowych do odpowiadania na wewnętrzne notatki
332 pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
333 sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
334
335 %package router-qmail
336 Summary:        Eventum Mail Routing - qmail
337 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - qmail
338 Group:          Applications/Mail
339 # loose dep is intentional. qmail subpackage isn't built on PLD
340 # builders and there really nothing changes.
341 Requires:       %{name} >= %{version}-%{release}
342 Requires:       qmail >= 1.03
343 Provides:       eventum(router)
344 Obsoletes:      eventum(router)
345
346 %description router-qmail
347 This package provides way of routing notes and emails back to Eventum
348 via qmail.
349
350 %description router-qmail -l pl.UTF-8
351 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
352 przez qmaila.
353
354 %package router-postfix
355 Summary:        Eventum Mail Routing - Postfix
356 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
357 Group:          Applications/Mail
358 Requires:       %{name} = %{version}-%{release}
359 Requires:       postfix
360 Provides:       eventum(router)
361 Obsoletes:      eventum(router)
362
363 %description router-postfix
364 This package provides way of routing notes and emails back to Eventum
365 via Postfix.
366
367 The Postfix configuration instructions you can find from
368 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
369
370 %description router-postfix -l pl.UTF-8
371 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
372 przez Postfiksa.
373
374 Opis konfiguracji Postfiksa można znaleźć pod adresem
375 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
376
377 %package irc
378 Summary:        Eventum IRC Notification Bot
379 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
380 Group:          Applications/WWW
381 Requires(post,preun):   /sbin/chkconfig
382 Requires(triggerpostun):        sed >= 4.0
383 Requires:       %{name} = %{version}-%{release}
384 Requires:       php(sockets)
385 Requires:       php-pear-Net_SmartIRC
386 Requires:       rc-scripts >= 0.4.0.18
387
388 %description irc
389 The IRC notification bot is a nice feature for remote teams that want
390 to handle issues and want to have a quick and easy way to get simple
391 notifications. Right now the bot notifies of the following actions:
392 - New Issues
393 - Blocked emails
394 - Issues that got their assignment list changed
395
396 NOTE: You will need to manually edit the bot.php script to set your
397 appropriate preferences, like IRC server and channel that the bot
398 should join.
399
400 %description irc -l pl.UTF-8
401 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
402 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
403 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
404 następujących zdarzeniach:
405 - nowych sprawach
406 - zablokowanych listach
407 - sprawach, dla których zmieniła się lista powiązań
408
409 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
410 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
411
412 %package cli
413 Summary:        Eventum command-line interface
414 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
415 Group:          Applications/WWW
416 Requires:       %{name}-base = %{version}-%{release}
417 Requires:       php-cli
418 Requires:       php-common >= 4:5.0
419 Requires:       php-pear-XML_RPC
420
421 %description cli
422 The Eventum command-line interface allows you to access most of the
423 features of the web interface straight from your command shell.
424
425 %description cli -l pl.UTF-8
426 Interfejs linii poleceń Eventum pozwala na dostęp do większości
427 funkcji interfejsu WWW prosto z linii poleceń powłoki.
428
429 %package scm
430 Summary:        Eventum SCM integration
431 Summary(pl.UTF-8):      Integracja SCM dla Eventum
432 Group:          Applications/WWW
433 Requires:       %{name}-base = %{version}-%{release}
434 Requires:       php-cli
435 Requires:       php-common >= 4:5.0
436 Requires:       php-pcre
437
438 %description scm
439 This feature allows your software development teams to integrate your
440 Source Control Management system with your Issue Tracking System.
441
442 The integration is implemented in such a way that it will be forward
443 compatible with pretty much any SCM system, such as CVS.
444
445 For installation see
446 </eventum/help.php?topic=scm_integration_installation>.
447
448 %description scm -l pl.UTF-8
449 Ten pakiet pozwala zespołom programistów na integrację systemu
450 zarządzania źródłami (SCM - Source Control Management) z systemem
451 śledzenia spraw.
452
453 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
454 prawie każdym systemem SCM, jak np. CVS.
455
456 Szczegóły na temat instalacji można przeczytać pod
457 </eventum/help.php?topic=scm_integration_installation>.
458
459 %prep
460 %setup -q %{?snap:-n %{name}-%{snap}}%{?svn:-n %{name}-%{svn}}
461 # undos the source
462 find . -type f -print0 | xargs -0 sed -i -e 's,\r$,,'
463
464 rm benchmark.php
465 rm -r misc/upgrade/*v1.[123]* # too old to support in PLD Linux
466 rm -r misc/upgrade/v{1.,2.0,2.1_}* # no longer supported in PLD Linux
467 rm misc/upgrade/flush_compiled_templates.php
468 rm -r misc/upgrade/{*/,}index.html # not needed in PLD Linux
469
470 rm -r include/php-gettext
471 # sample, not used in eventum
472 rm rpc/xmlrpc_client.php
473
474 # bug fixes / features
475 %patch0 -p1
476 %{?with_order:%patch1 -p1}
477
478 #%patch200 -p1
479
480 # packaging
481 %patch100 -p1
482 %patch101 -p1
483 %patch102 -p1
484 %patch105 -p1
485 %patch106 -p1
486 %patch107 -p1
487
488 cat <<'EOF'> mysql-permissions.sql
489 # use this schema if you want to grant permissions manually instead of using setup
490 # this schema is extracted from setup/index.php.
491 GRANT SELECT, UPDATE, DELETE, INSERT, ALTER, DROP, CREATE, INDEX ON eventum.* TO 'eventum'@'localhost' IDENTIFIED BY 'password';
492 EOF
493
494 sed -e '1s,#!.*/bin/php -q,#!%{_bindir}/php,' misc/cli/eventum > %{name}-cli
495 mv misc/cli/eventumrc_example eventumrc
496 sed -i -e '1i#!%{_bindir}/php' misc/*.php
497 chmod +x misc/*.php
498
499 %{__sed} -i -e "
500 s,require_once.*init.php.*;,require_once '%{_appdir}/htdocs/init.php';,
501 s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
502 /define('INSTALL_PATH'/d
503 " misc/upgrade/{*/,}*.php
504
505 # remove backups from patching as we use globs to package files to buildroot
506 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
507
508 %build
509 %{__make} -C misc/localization
510
511 %install
512 rm -rf $RPM_BUILD_ROOT
513 install -d \
514         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
515         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
516         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
517         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
518         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
519         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
520
521 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
522 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
523 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
524 cp -a templates $RPM_BUILD_ROOT%{_appdir}
525 cp -a include/{customer,custom_field,jpgraph,workflow} $RPM_BUILD_ROOT%{_appdir}/include
526 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
527 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
528 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
529
530 cp -a favicon.ico $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
531 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
532
533 # cli
534 install -d $RPM_BUILD_ROOT%{_appdir}/cli
535 cp -a misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
536 cp -a misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
537 install %{name}-cli $RPM_BUILD_ROOT%{_bindir}/%{name}
538 install misc/irc/bot.php $RPM_BUILD_ROOT%{_sbindir}/%{name}-bot
539
540 # scm
541 install misc/scm/process_cvs_commits.php $RPM_BUILD_ROOT%{_libdir}/process_cvs_commits
542 install misc/scm/process_svn_commits.php $RPM_BUILD_ROOT%{_libdir}/process_svn_commits
543 ln -s process_cvs_commits $RPM_BUILD_ROOT%{_libdir}/scm
544 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
545
546 # private key
547 echo '<?php
548 $private_key = "DEFAULTPRIVATEKEY";' > $RPM_BUILD_ROOT%{_webappdir}/private_key.php
549 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
550
551 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
552 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
553 cp -a %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
554 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
555 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
556 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
557 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
558 cp -a %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
559 cp -a %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
560 cp -a %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
561
562
563 %{__sed} -i -e "/define('APP_VERSION'/ {
564     idefine('APP_VERSION', '%{version}%{?snap:-%{snap}}%{?_rc:-%{_rc}}%{?svn:-%{svn}}');
565     d
566
567 }" $RPM_BUILD_ROOT%{_appdir}/htdocs/init.php
568
569 # config
570 > $RPM_BUILD_ROOT%{_webappdir}/setup.php
571 > $RPM_BUILD_ROOT%{_webappdir}/config.php
572
573 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
574 # These plugins are not in Smarty package (Smarty-2.6.2-3)
575 cp -a \
576         include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
577         include/Smarty/plugins/modifier.highlight_quoted.php \
578         $RPM_BUILD_ROOT%{_smartyplugindir}
579
580 # qmail router
581 %if %{with qmail}
582 d=$RPM_BUILD_ROOT/var/lib/%{name}
583 echo 'root' > $d/.qmail
584 echo 'root' > $d/.qmail-default
585 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
586 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
587 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
588 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/router-qmail
589 %endif
590 # postfix router
591 install %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
592
593 install -D %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
594 # locale
595 cd misc/localization
596 for a in */LC_MESSAGES/*.mo; do
597         d=${a%/*}
598         install -d $RPM_BUILD_ROOT%{_datadir}/locale/$d
599         cp -a $a $RPM_BUILD_ROOT%{_datadir}/locale/$d
600 done
601 cd -
602
603 %find_lang %{name}
604
605 %clean
606 rm -rf $RPM_BUILD_ROOT
607
608 %pre
609 %addusertogroup http %{name}
610
611 %post
612 # check if the package is configured.
613 if grep -q "Header('Location: setup/')" %{_webappdir}/config.php; then
614 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
615 %banner %{name} -e <<EOF
616
617 You haven't yet configured Eventum!
618 Please open in browser <http://localhost/eventum/>
619 If you need access from elsewhere, you need to edit
620 %{_webappdir}/apache.conf and restart apache.
621
622 IMPORTANT: When You have configured Eventum, please uninstall the
623 setup package, so that %{name}-setup is able to secure your Eventum
624 installation.
625
626 EOF
627 #' vim syntax hack
628 else
629 %banner %{name} -e <<EOF
630
631 You haven't yet configured Eventum!
632
633 To setup eventum, please install %{name}-setup and open in browser
634 <http://localhost/eventum/>.
635 If you need access from elsewhere, you need to edit
636 %{_webappdir}/*.conf depending on webserver and restart the webserver.
637
638 IMPORTANT: When You have configured Eventum, please uninstall the
639 setup package, so that %{name}-setup is able to secure your Eventum
640 installation.
641
642 EOF
643 #' vim syntax hack
644 fi
645
646 elif grep -q 'DEFAULTPRIVATEKEY' %{_webappdir}/private_key.php; then
647 %banner %{name} -e <<EOF
648
649 You have default private key installed!
650
651 Install %{name}-setup and open up http://yourserver/eventum/setup/
652 -- that will help you setup initial config.
653
654 when have configured Eventum, please uninstall the setup package,
655 so that %{name}-setup is able to secure your Eventum installation.
656
657 EOF
658         elif [ -d %{_appdir}/setup ]; then
659 %banner %{name} -e <<EOF
660
661 If you have have configured Eventum, please uninstall the setup package,
662 so that %{name}-setup is able to secure your Eventum installation.
663
664 EOF
665 fi
666
667 # database update
668 %{_appdir}/upgrade/update-database.php || :
669
670 # nuke Smarty templates cache after upgrade
671 rm -f /var/cache/eventum/*.php
672
673 %preun
674 if [ "$1" = "0" ]; then
675         # nuke cache
676         rm -f /var/cache/eventum/*.php 2>/dev/null || :
677 fi
678
679 %pre base
680 %groupadd -P %{name}-base -g 146 %{name}
681 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
682
683 %postun base
684 if [ "$1" = "0" ]; then
685         %userremove %{name}
686         %groupremove %{name}
687 fi
688
689 %post router-qmail
690 CF=/etc/qmail/control/virtualdomains
691 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
692         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_webappdir}/config.php 2>/dev/null)
693         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
694         umask 022
695         echo "#${FQDN}:%{name}" >> $CF
696
697 %banner %{name}-qmail -e <<EOF
698
699 Added "#${FQDN}:%{name}" to $CF,
700 Please verify that it is correct and restart qmail:
701 # service qmail reload
702
703 Consult qmail-send(8) for more information on virtualdomains.
704
705 EOF
706 fi
707
708 %preun router-qmail
709 if [ "$1" = "0" ]; then
710         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
711 fi
712
713 %post setup
714 chmod 660 %{_webappdir}/{config,private_key}.php
715 chown root:eventum %{_webappdir}/{config,private_key}.php
716
717 %postun setup
718 if [ "$1" = "0" ]; then
719         chmod 640 %{_webappdir}/{config,private_key}.php
720         chown root:eventum %{_webappdir}/{config,private_key}.php
721 fi
722
723 %post irc
724 /sbin/chkconfig --add eventum-irc
725 %service eventum-irc restart "Eventum IRC Bot"
726
727 %preun irc
728 if [ "$1" = 0 ]; then
729         %service eventum-irc stop
730         /sbin/chkconfig --del eventum-irc
731 fi
732
733 %triggerin -- apache1 < 1.3.37-3, apache1-base
734 %webapp_register apache %{_webapp}
735
736 %triggerun -- apache1 < 1.3.37-3, apache1-base
737 %webapp_unregister apache %{_webapp}
738
739 %triggerin -- apache < 2.2.0, apache-base
740 %webapp_register httpd %{_webapp}
741
742 %triggerun -- apache < 2.2.0, apache-base
743 %webapp_unregister httpd %{_webapp}
744
745 %triggerin -- lighttpd
746 %webapp_register lighttpd %{_webapp}
747
748 %triggerun -- lighttpd
749 %webapp_unregister lighttpd %{_webapp}
750
751 %triggerpostun -- eventum < 2.1.1-2.13
752 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v2.1.1_to_v2.2 <<EOF
753 db_version.php Add eventum_version table
754 EOF
755 # automated database update
756 %{_appdir}/upgrade/update-database.php || :
757
758 %files -f %{name}.lang
759 %defattr(644,root,root,755)
760 %doc ChangeLog FAQ INSTALL README UPGRADE CONTRIB
761 %doc docs/* setup/schema.sql mysql-permissions.sql
762 %attr(751,root,root) %dir %{_webappdir}
763 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
764 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
765 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
766 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
767 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
768 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
769 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
770
771 %dir %attr(731,root,eventum) /var/log/%{name}
772 %attr(620,root,eventum) %ghost /var/log/%{name}/*
773 %dir %attr(750,root,root) /var/log/archive/%{name}
774 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
775
776 %dir %{_appdir}/htdocs
777 %{_appdir}/htdocs/*.php
778 %{_appdir}/htdocs/*.ico
779 %{_appdir}/htdocs/css
780 %{_appdir}/htdocs/customer
781 %{_appdir}/htdocs/images
782 %{_appdir}/htdocs/js
783 %{_appdir}/htdocs/manage
784 %{_appdir}/htdocs/reports
785 %{_appdir}/htdocs/rpc
786 %{_appdir}/htdocs/misc
787 %{_appdir}/templates
788
789 %dir %{_appdir}/upgrade
790 %attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
791 %attr(755,root,root) %{_appdir}/upgrade/update-database.php
792 %dir %{_appdir}/upgrade/v*
793 %attr(755,root,root) %{_appdir}/upgrade/v*/*.php
794 %{_appdir}/upgrade/patches
795
796 %{_smartyplugindir}
797
798 %dir %{_appdir}/include
799 %{_appdir}/include/customer
800 %{_appdir}/include/custom_field
801 %{_appdir}/include/jpgraph
802 %{_appdir}/include/workflow
803 %{_appdir}/include/class.*.php
804 %{_appdir}/include/db_access.php
805 %exclude %{_appdir}/include/class.monitor.php
806
807 %dir %attr(730,root,eventum) /var/run/%{name}
808 %dir %attr(730,root,eventum) /var/cache/%{name}
809
810 %files base
811 %defattr(644,root,root,755)
812 %attr(751,root,root) %dir %{_sysconfdir}
813 %dir %{_libdir}
814 %dir %{_appdir}
815 # qmail will ignore user, if it's home directory is not owned
816 %attr(750,eventum,eventum) %dir /var/lib/%{name}
817 # saved mail copies
818 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_emails
819 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_drafts
820 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_notes
821
822 %files setup
823 %defattr(644,root,root,755)
824 %{_appdir}/htdocs/setup
825
826 %files mail-queue
827 %defattr(644,root,root,755)
828 %attr(755,root,root) %{_appdir}/process_mail_queue.php
829 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
830
831 %files mail-download
832 %defattr(644,root,root,755)
833 %attr(755,root,root) %{_appdir}/download_emails.php
834 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
835
836 %files reminder
837 %defattr(644,root,root,755)
838 %attr(755,root,root) %{_appdir}/check_reminders.php
839 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
840
841 %files monitor
842 %defattr(644,root,root,755)
843 %{_appdir}/include/class.monitor.php
844 %attr(755,root,root) %{_appdir}/monitor.php
845 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
846
847 %files route-drafts
848 %defattr(644,root,root,755)
849 %attr(755,root,root) %{_appdir}/route_drafts.php
850
851 %files route-emails
852 %defattr(644,root,root,755)
853 %attr(755,root,root) %{_appdir}/route_emails.php
854
855 %files route-notes
856 %defattr(644,root,root,755)
857 %attr(755,root,root) %{_appdir}/route_notes.php
858
859 %if %{with qmail}
860 %files router-qmail
861 %defattr(644,root,root,755)
862 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
863 %attr(755,root,root) %{_libdir}/router-qmail
864 %endif
865
866 %files router-postfix
867 %defattr(644,root,root,755)
868 %attr(755,root,root) %{_libdir}/router-postfix
869
870 %files irc
871 %defattr(644,root,root,755)
872 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
873 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
874 %attr(755,root,root) %{_sbindir}/%{name}-bot
875 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
876
877 %files cli
878 %defattr(644,root,root,755)
879 %doc eventumrc
880 %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
881 %attr(755,root,root) %{_bindir}/%{name}
882 %{_appdir}/cli
883
884 %files scm
885 %defattr(644,root,root,755)
886 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
887 %attr(755,root,root) %{_libdir}/process_cvs_commits
888 %attr(755,root,root) %{_libdir}/process_svn_commits
889 # legacy
890 %ghost %{_libdir}/scm
This page took 0.106378 seconds and 4 git commands to generate.