]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- R(php-session)
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - system pear is incompatible, at least pear DB class seems broke Eventum
3 # - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
4 # - discard bundled packages (from INSTALL):
5 #  - JpGraph 1.5.3 (last GPL version)
6 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
7 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
8 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
9 #  - A few other small javascript libraries
10 # - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
11 # - php4-pgsql crashes php (at least 4.3.11-1)
12
13 %bcond_with     pear    # build with system PEAR packages (or use bundled ones)
14 %bcond_with     qmail   # build the router-qmail subpackage     
15
16 %define uid     146
17 %define gid     146
18
19 # snapshot: DATE
20 #define _snap 20050227
21
22 %if 0%{?_snap}
23 %define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
24 %else
25 %define _source http://mysql.dataphone.se/Downloads/%{name}/%{name}-%{version}.tar.gz
26 %endif
27
28 %define _rel    1.5
29
30 Summary:        Eventum Issue / Bug tracking system
31 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
32 Name:           eventum
33 Version:        1.5.4
34 Release:        %{?_snap:0.%{_snap}.}%{_rel}
35 License:        GPL
36 Group:          Applications/WWW
37 Source0:        %{_source}
38 # Source0-md5:  0de0b1cfe4b92179cb7a52a819871856
39 %{?_snap:NoSource:      0}
40 Source1:        %{name}-apache.conf
41 Source2:        %{name}-mail-queue.cron
42 Source3:        %{name}-mail-download.cron
43 Source4:        %{name}-reminder.cron
44 Source5:        %{name}-monitor.cron
45 Source6:        %{name}-cvs.php
46 Source7:        %{name}-irc.php
47 Source8:        %{name}-irc.init
48 Source9:        %{name}-irc.sysconfig
49 Source10:       %{name}-config.php
50 Source11:       %{name}-router-qmail.sh
51 Source12:       http://dev.mysql.com/common/favicon.ico
52 # Source12-md5: 858be0130832da4144c08d4b59116411
53 Source13:       %{name}-config-setup.php
54 Source14:       %{name}-upgrade.sh
55 Patch0:         %{name}-paths.patch
56 Patch1:         %{name}-cvs-config.patch
57 Patch2:         %{name}-irc-config.patch
58 Patch3:         %{name}-PEAR.patch
59 Patch4:         http://glen.alkohol.ee/pld/%{name}-reply-subject.patch
60 Patch5:         %{name}-lf.patch
61 Patch6:         http://glen.alkohol.ee/pld/%{name}-maq-subject.patch
62 Patch7:         %{name}-bot-reconnect.patch
63 URL:            http://dev.mysql.com/downloads/other/eventum/
64 BuildRequires:  rpmbuild(macros) >= 1.200
65 BuildRequires:  sed >= 4.0
66 Requires:       php >= 4.2.0
67 Requires:       php-gd
68 Requires:       php-imap
69 Requires:       php-mysql
70 Requires:       php-pcre
71 Requires:       php-session
72 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
73 Requires:       Smarty >= 2.6.2
74 %if %{with pear}
75 Requires:       php-pear-Benchmark
76 Requires:       php-pear-DB
77 Requires:       php-pear-Date
78 Requires:       php-pear-HTTP_Request
79 Requires:       php-pear-Mail
80 Requires:       php-pear-Math_Stats
81 Requires:       php-pear-Net_DIME
82 Requires:       php-pear-Net_POP3
83 Requires:       php-pear-Net_SMTP
84 Requires:       php-pear-Net_SmartIRC
85 Requires:       php-pear-Net_Socket
86 Requires:       php-pear-Net_URL
87 Requires:       php-pear-Net_UserAgent_Detect
88 Requires:       php-pear-PEAR
89 Requires:       php-pear-Text_Diff
90 Requires:       php-pear-XML_RPC
91 %endif
92 Requires:       apache >= 1.3.33-2
93 Requires:       apache(mod_dir)
94 Requires(triggerpostun):        sed >= 4.0
95 BuildArch:      noarch
96 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
97
98 %define         _sysconfdir     /etc/%{name}
99 %define         _libdir         %{_prefix}/%{_lib}/%{name}
100 %define         _appdir %{_datadir}/%{name}
101 %define         _smartyplugindir        %{php_pear_dir}/Smarty/plugins
102
103 %define         _apache1dir     /etc/apache
104 %define         _apache2dir     /etc/httpd
105
106 %description
107 Eventum is a user-friendly and flexible issue tracking system that can
108 be used by a support department to track incoming technical support
109 requests, or by a software development team to quickly organize tasks
110 and bugs. Eventum is used by the MySQL AB Technical Support team, and
111 has allowed us to dramatically improve our response times.
112
113 %description -l pl
114 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
115 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
116 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
117 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
118 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
119 reakcji.
120
121 %package base
122 Summary:        Eventum base package
123 Summary(pl):    Podstawowy pakiet Eventum
124 Group:          Applications/WWW
125 Requires(pre):  /bin/id
126 Requires(pre):  /usr/bin/getgid
127 Requires(pre):  /usr/sbin/useradd
128 Requires(pre):  /usr/sbin/groupadd
129 Requires(postun):       /usr/sbin/userdel
130 Requires(postun):       /usr/sbin/groupdel
131 Provides:       user(eventum)
132 Provides:       group(eventum)
133
134 %description base
135 This package contains base directory structure for Eventum.
136
137 %description base -l pl
138 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
139
140 %package setup
141 Summary:        Eventum setup package
142 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
143 Group:          Applications/WWW
144 PreReq:         %{name} = %{epoch}:%{version}-%{release}
145
146 %description setup
147 Install this package to configure initial Eventum installation. You
148 should uninstall this package when you're done, as it considered
149 insecure to keep the setup files in place.
150
151 %description setup -l pl
152 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
153 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
154 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
155
156 %package mail-queue
157 Summary:        Eventum mail queue process
158 Summary(pl):    Przetwarzanie kolejki poczty Eventum
159 Group:          Applications/WWW
160 Requires:       %{name} = %{epoch}:%{version}-%{release}
161 Requires:       crondaemon
162 Requires:       php >= 4.1.0
163
164 %description mail-queue
165 Beginning with the first release of Eventum, emails are not directly
166 sent out from the various scripts, but rather added to a mail queue
167 table that is processed by a cron job. If an email cannot be sent, it
168 will be marked as such in the mail queue log, and the cron job script
169 will re-try to send it again the next time it runs.
170
171 This package contains the cron job.
172
173 %description mail-queue -l pl
174 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
175 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
176 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
177 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
178 nastêpnym razem.
179
180 Ten pakiet zawiera zadanie dla crona.
181
182 %package mail-download
183 Summary:        Eventum email download
184 Summary(pl):    ¦ci±ganie poczty Eventum
185 Group:          Applications/WWW
186 Requires:       %{name} = %{epoch}:%{version}-%{release}
187 Requires:       crondaemon
188 Requires:       php >= 4.1.0
189
190 %description mail-download
191 In order for Eventum's email integration feature to work, you need to
192 setup a cron job to run the script every so often.
193
194 This package contains the cron job.
195
196 %description mail-download -l pl
197 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
198 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
199 czêsto.
200
201 Ten pakiet zawiera zadanie dla crona.
202
203 %package reminder
204 Summary:        Eventum Reminder System
205 Summary(pl):    System przypominania dla Eventum
206 Group:          Applications/WWW
207 Requires:       %{name} = %{epoch}:%{version}-%{release}
208 Requires:       php >= 4.1.0
209 Requires:       crondaemon
210
211 %description reminder
212 The reminder system was designed with the objective as serving as a
213 safe net for issues that need attention. Depending on what
214 configuration you create, you may have several reminders (or alerts)
215 be sent out whenever an issue needs attention, for whatever parameter
216 you may deem necessary.
217
218 This package contains the cron job.
219
220 %description reminder -l pl
221 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
222 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
223 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
224 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
225 uwa¿aæ za potrzebny.
226
227 Ten pakiet zawiera zadanie dla crona.
228
229 %package monitor
230 Summary:        Eventum Heartbeat Monitor
231 Summary(pl):    Monitor ¿ycia dla Eventum
232 Group:          Applications/WWW
233 Requires:       %{name} = %{epoch}:%{version}-%{release}
234 Requires:       php >= 4.1.0
235 Requires:       php-posix
236 Requires:       crondaemon
237
238 %description monitor
239 The heartbeat monitor is a feature designed for the administrator that
240 wants to be alerted whenever a common problem in Eventum is detected,
241 like the database server not being available anymore, or maybe when
242 the recommended permissions for certain configuration files are
243 changed.
244
245 Please note that before running the heartbeat monitor, you may need to
246 customize some of the checks to be appropriate for your own system,
247 particularly the permission and file checks on
248 Monitor::checkConfiguration().
249
250 This package contains the cron job.
251
252 %description monitor -l pl
253 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
254 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
255 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
256 do plików konfiguracyjnych.
257
258 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
259 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
260 testów uprawnieñ i plików w Monitor::checkConfiguration().
261
262 Ten pakiet zawiera zadanie dla crona.
263
264 %package route-emails
265 Summary:        Eventum Email Routing
266 Summary(pl):    Przekazywanie poczty dla Eventum
267 Group:          Applications/WWW
268 Requires:       %{name} = %{epoch}:%{version}-%{release}
269 Requires:       php >= 4.1.0
270 Requires:       eventum(router)
271
272 %description route-emails
273 The email routing feature is used to automatically associate a thread
274 of emails into an Eventum issue. By setting up qmail (or even postfix)
275 to deliver emails sent to a specific address (usually
276 issue-<number>@<domain>) to the above script, users are able to use
277 their email clients to reply to emails coming from Eventum, and those
278 replies will be automatically associated with the issue and
279 broadcasted to the entire notification list.
280
281 %description route-emails -l pl
282 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
283 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
284 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
285 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
286 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
287 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
288 rozprowadzane do ca³ej listy og³oszeniowej.
289
290 %package route-notes
291 Summary:        Eventum Note Routing
292 Summary(pl):    Przekazywanie notatek dla Eventum
293 Group:          Applications/WWW
294 Requires:       %{name} = %{epoch}:%{version}-%{release}
295 Requires:       php >= 4.1.0
296 Requires:       eventum(router)
297
298 %description route-notes
299 The note routing feature is used to automatically associate a thread
300 of notes into an Eventum issue. By setting up qmail (or even postfix)
301 to deliver emails sent to a specific address (usually
302 note-<number>@<domain>) to the above script, users are able to use
303 their email clients to reply to internal notes coming from Eventum,
304 and those replies will be automatically associated with the issue and
305 broadcasted to the notification list staff members.
306
307 %description route-notes -l pl
308 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
309 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
310 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
311 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
312 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
313 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
314 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
315
316 %package router-qmail
317 Summary:        Eventum Mail Routing - qmail
318 Summary(pl):    Przekazywanie poczty Eventum - qmail
319 Group:          Applications/Mail
320 Requires:       %{name} = %{epoch}:%{version}-%{release}
321 Requires:       qmail >= 1.03
322 Provides:       eventum(router)
323 Obsoletes:      eventum(router)
324
325 %description router-qmail
326 This package provides way of routing notes and emails back to Eventum
327 via qmail.
328
329 %description router-qmail -l pl
330 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
331 przez qmaila.
332
333 %package router-postfix
334 Summary:        Eventum Mail Routing - Postfix
335 Summary(pl):    Przekazywanie poczty Eventum - Postfix
336 Group:          Applications/Mail
337 Requires:       %{name} = %{epoch}:%{version}-%{release}
338 Requires:       postfix
339 Provides:       eventum(router)
340 Obsoletes:      eventum(router)
341
342 %description router-postfix
343 This package provides way of routing notes and emails back to Eventum
344 via Postfix.
345
346 %description router-postfix -l pl
347 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
348 przez Postfiksa.
349
350 %package irc
351 Summary:        Eventum IRC Notification Bot
352 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
353 Group:          Applications/WWW
354 Requires:       %{name} = %{epoch}:%{version}-%{release}
355 Requires:       php >= 4.1.0
356 Requires:       php-sockets
357 Requires:       rc-scripts >= 0.4.0.18
358
359 %description irc
360 The IRC notification bot is a nice feature for remote teams that want
361 to handle issues and want to have a quick and easy way to get simple
362 notifications. Right now the bot notifies of the following actions:
363 - New Issues
364 - Blocked emails
365 - Issues that got their assignment list changed
366
367 NOTE: You will need to manually edit the bot.php script to set your
368 appropriate preferences, like IRC server and channel that the bot
369 should join.
370
371 %description irc -l pl
372 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
373 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
374 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
375 nastêpuj±cych zdarzeniach:
376 - nowych sprawach
377 - zablokowanych listach
378 - sprawach, dla których zmieni³a siê lista powi±zañ
379
380 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
381 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
382
383 %package cli
384 Summary:        Eventum command-line interface
385 Summary(pl):    Interfejs linii poleceñ dla Eventum
386 Group:          Applications/WWW
387 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
388 Requires:       php >= 4.1.0
389 Requires:       php-cli
390 Requires:       php-curl
391 Requires:       php-xml
392 Requires:       php-pear-XML_RPC
393
394 %description cli
395 The Eventum command-line interface allows you to access most of the
396 features of the web interface straight from your command shell.
397
398 %description cli -l pl
399 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
400 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
401
402 %package scm
403 Summary:        Eventum SCM integration
404 Summary(pl):    Integracja SCM dla Eventum
405 Group:          Applications/WWW
406 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
407 Requires:       php-cli >= 4.1.0
408 Requires:       php-pcre
409
410 %description scm
411 This feature allows your software development teams to integrate your
412 Source Control Management system with your Issue Tracking System.
413
414 The integration is implemented in such a way that it will be forward
415 compatible with pretty much any SCM system, such as CVS.
416
417 For installation see
418 </eventum/help.php?topic=scm_integration_installation>.
419
420 %description scm -l pl
421 Ten pakiet pozwala zespo³om programistów na integracjê systemu
422 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
423 ¶ledzenia spraw.
424
425 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
426 prawie ka¿dym systemem SCM, jak np. CVS.
427
428 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
429 </eventum/help.php?topic=scm_integration_installation>.
430
431 %prep
432 %setup -q %{?_snap:-n %{name}-%{_snap}}
433 # undos the source
434 find . -type f -print0 | xargs -0 sed -i -e 's,
435 $,,'
436
437 # packaging
438 %patch0 -p1 -b .paths
439 %patch1 -p1
440 %patch2 -p1
441 %{?with_pear:%patch3 -p1 -b .PEAR}
442
443 # bug fixes.
444 %patch4 -p1
445 %patch5 -p1
446 %patch6 -p1
447 %patch7 -p1
448
449 # replace in remaining scripts config.inc.php to system one
450 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
451         s,include_once(".*config.inc.php"),include_once("%{_sysconfdir}/core.php"),
452 '
453 sed -i -e '
454         s,include(".*config.inc.php"),include_once("%{_sysconfdir}/core.php"),
455 ' misc/download_emails.php
456
457 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
458         s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_sysconfdir}/private_key.php"),
459 '
460 find -name '*~' | xargs -r rm -v
461
462 %install
463 rm -rf $RPM_BUILD_ROOT
464 install -d \
465         $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_libdir}} \
466         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
467         $RPM_BUILD_ROOT/var/{run,log,cache,lib}/%{name} \
468         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
469
470 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
471 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
472 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
473 cp -a misc/irc $RPM_BUILD_ROOT%{_appdir}
474 cp -a templates $RPM_BUILD_ROOT%{_appdir}
475 cp -a include/{customer,jpgraph,pear,workflow} $RPM_BUILD_ROOT%{_appdir}/include
476 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
477 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
478 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
479
480 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
481 install %{SOURCE13} $RPM_BUILD_ROOT%{_appdir}/htdocs/setup/config.inc.php
482 install %{SOURCE14} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
483
484 # cli
485 install -d $RPM_BUILD_ROOT%{_appdir}/cli
486 install misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
487 install misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
488 sed -e '1s,#!.*/bin/php,#!%{_bindir}/php4,' \
489         misc/cli/eventum > $RPM_BUILD_ROOT%{_bindir}/%{name}
490 cp -f misc/cli/eventumrc_example eventumrc
491
492 # scm
493 echo '#!%{_bindir}/php4 -q' > %{name}-scm
494 cat misc/scm/process_cvs_commits.php >> %{name}-scm
495 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
496
497 # private key
498 mv $RPM_BUILD_ROOT{%{_appdir}/include/private_key.php,%{_sysconfdir}}
499 # change private key, so we can easily grep
500 sed -i -e '
501 s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
502 ' $RPM_BUILD_ROOT%{_sysconfdir}/private_key.php
503
504 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
505 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
506 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
507 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
508 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
509 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
510 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
511 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
512 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
513 sed -e 's,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}},' \
514         %{SOURCE10} > $RPM_BUILD_ROOT%{_sysconfdir}/core.php
515
516 # config
517 > $RPM_BUILD_ROOT%{_sysconfdir}/setup.php
518 mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_sysconfdir}/config}.php
519
520 # sample, not used in eventum
521 rm -f $RPM_BUILD_ROOT%{_appdir}/htdocs/rpc/xmlrpc_client.php
522
523 %if %{with pear}
524 # provided by PEAR
525 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
526 %endif
527
528 # use system Smarty
529 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
530 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
531 # These plugins are not in Smarty package (Smarty-2.6.2-3)
532 cp -a include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
533         $RPM_BUILD_ROOT%{_smartyplugindir}
534
535 # qmail router
536 %if %{with qmail}
537 d=$RPM_BUILD_ROOT/var/lib/%{name}
538 echo 'root' > $d/.qmail
539 echo 'root' > $d/.qmail-default
540 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
541 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
542 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
543 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
544 %endif
545
546 %clean
547 rm -rf $RPM_BUILD_ROOT
548
549 %pre
550 %addusertogroup http %{name}
551
552 %post
553 # apache1
554 if [ -d %{_apache1dir}/conf.d ]; then
555         ln -sf %{_sysconfdir}/apache.conf %{_apache1dir}/conf.d/99_%{name}.conf
556         if [ -f /var/lock/subsys/apache ]; then
557                 /etc/rc.d/init.d/apache restart 1>&2
558         fi
559 fi
560 # apache2
561 if [ -d %{_apache2dir}/httpd.conf ]; then
562         ln -sf %{_sysconfdir}/apache.conf %{_apache2dir}/httpd.conf/99_%{name}.conf
563         if [ -f /var/lock/subsys/httpd ]; then
564                 /etc/rc.d/init.d/httpd restart 1>&2
565         fi
566 fi
567
568 # check if the package is configured.
569 if grep -q 'header("Location: setup/")' %{_sysconfdir}/config.php; then
570 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
571 %banner %{name} -e <<EOF
572
573 You haven't yet configured Eventum!
574 Please open in browser <http://localhost/eventum/>
575 If you need access from elsewhere, you need to edit
576 %{_sysconfdir}/apache.conf and restart apache.
577
578 IMPORTANT: When You have configured Eventum, please uninstall the
579 setup package, so that %{name}-setup is able to secure your Eventum
580 installation.
581
582 EOF
583 #' vim stupidity.
584 else
585 %banner %{name} -e <<EOF
586
587 You haven't yet configured Eventum!
588
589 To setup eventum, please install %{name}-setup and open in browser
590 <http://localhost/eventum/>.
591 If you need access from elsewhere, you need to edit
592 %{_sysconfdir}/apache.conf and restart apache.
593
594 IMPORTANT: When You have configured Eventum, please uninstall the
595 setup package, so that %{name}-setup is able to secure your Eventum
596 installation.
597
598 EOF
599 #' vim stupidity.
600 fi
601
602 elif grep -q 'DEFAULTPRIVATEKEY' %{_sysconfdir}/private_key.php; then
603 %banner %{name} -e <<EOF
604
605 You have default private key installed!
606
607 Install %{name}-setup and open up http://yourserver/eventum/setup/
608 -- that will help you setup initial config.
609
610 when have configured Eventum, please uninstall the setup package,
611 so that %{name}-setup is able to secure your Eventum installation.
612
613 EOF
614         elif [ -d %{_appdir}/setup ]; then
615 %banner %{name} -e <<EOF
616
617 If you have have configured Eventum, please uninstall the setup package,
618 so that %{name}-setup is able to secure your Eventum installation.
619
620 EOF
621 fi
622
623 # nuke Smarty templates cache after upgrade
624 rm -f /var/cache/eventum/*.php
625
626 %preun
627 if [ "$1" = "0" ]; then
628         # apache1
629         if [ -f %{_apache1dir}/apache.conf ]; then
630                 rm -f %{_apache1dir}/conf.d/99_%{name}.conf
631                 if [ -f /var/lock/subsys/apache ]; then
632                         /etc/rc.d/init.d/apache restart 1>&2
633                 fi
634         fi
635         # apache2
636         if [ -d %{_apache2dir}/httpd.conf ]; then
637                 rm -f %{_apache2dir}/httpd.conf/99_%{name}.conf
638                 if [ -f /var/lock/subsys/httpd ]; then
639                         /etc/rc.d/init.d/httpd restart 1>&2
640                 fi
641         fi
642
643         # nuke cache
644         rm -f /var/cache/eventum/*.php 2>/dev/null || :
645 fi
646
647 %pre base
648 %groupadd -P %{name}-base -g %{gid} %{name}
649 %useradd -P %{name}-base -u %{uid} -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
650
651 %postun base
652 if [ "$1" = "0" ]; then
653         %userremove %{name}
654         %groupremove %{name}
655 fi
656
657 %if %{with qmail}
658 %post router-qmail
659 CF=/etc/qmail/control/virtualdomains
660 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
661         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_sysconfdir}/config.php 2>/dev/null)
662         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
663         umask 022
664         echo "#${FQDN}:%{name}" >> $CF
665
666 %banner %{name}-qmail -e <<EOF
667
668 Added "#${FQDN}:%{name}" to $CF,
669 Please verify that it is correct and restart qmail:
670 # service qmail reload
671
672 Consult qmail-send(8) for more information on virtualdomains.
673
674 EOF
675 fi
676
677 %preun router-qmail
678 if [ "$1" = "0" ]; then
679         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
680 fi
681 %endif
682
683 %post setup
684 chmod 660 %{_sysconfdir}/{config,private_key}.php
685 chown root:eventum %{_sysconfdir}/{config,private_key}.php
686
687 %postun setup
688 if [ "$1" = "0" ]; then
689         chmod 640 %{_sysconfdir}/{config,private_key}.php
690         chown root:eventum %{_sysconfdir}/{config,private_key}.php
691 fi
692
693 # FIXME
694 # only one upgrade trigger is called if you're upgrading over two
695 # versions, say 1.5 to 1.5.3, only 1.5.3 trigger is called.
696 # use common trigger (the highest version and rpmvercmp from poldek?)
697 %triggerpostun -- eventum < 1.5.1-0.257
698 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5_to_v1.5.1 <<EOF
699 database_changes.php Perform database changes
700 EOF
701
702 %triggerpostun -- eventum < 1.5.2-0.289
703 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.1_to_v1.5.2 <<EOF
704 database_changes.php Perform database changes
705 set_priority_ranks.php Fix the ranking of priority values
706 EOF
707
708 %triggerpostun -- eventum < 1.5.3-0.291
709 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.2_to_v1.5.3 <<EOF
710 database_changes.php Perform database changes
711 EOF
712
713 %triggerpostun -- eventum < 1.5.4-1.5
714 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.3_to_v1.5.4 <<EOF
715 database_changes.php Perform database changes
716 EOF
717
718 %files
719 %defattr(644,root,root,755)
720 %doc ChangeLog FAQ INSTALL README UPGRADE
721 %doc docs/* rpc/xmlrpc_client.php setup/schema.sql
722 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
723 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
724 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/private_key.php
725 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/setup.php
726 %attr(640,root,eventum) %config %verify(not mtime) %{_sysconfdir}/core.php
727
728 %dir %attr(731,root,eventum) /var/log/%{name}
729 %attr(620,root,eventum) %ghost /var/log/%{name}/*
730
731 %dir %{_appdir}/htdocs
732 %{_appdir}/htdocs/*.php
733 %{_appdir}/htdocs/*.ico
734 %{_appdir}/htdocs/css
735 %{_appdir}/htdocs/customer
736 %{_appdir}/htdocs/images
737 %{_appdir}/htdocs/js
738 %{_appdir}/htdocs/manage
739 %{_appdir}/htdocs/reports
740 %{_appdir}/htdocs/rpc
741 %{_appdir}/htdocs/misc
742
743 %{_appdir}/templates
744 %dir %{_appdir}/upgrade
745 %attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
746 %{_appdir}/upgrade/[!u]*
747
748 %{_smartyplugindir}/*
749 %if %{without pear}
750 %{_appdir}/include/pear
751 %endif
752
753 %dir %{_appdir}/include
754 %{_appdir}/include/customer
755 %{_appdir}/include/jpgraph
756 %{_appdir}/include/workflow
757 %{_appdir}/include/class.[!m]*.php
758 %{_appdir}/include/class.mail.php
759 %{_appdir}/include/class.mail_queue.php
760 %{_appdir}/include/class.mime_helper.php
761 %{_appdir}/include/class.misc.php
762 %{_appdir}/include/db_access.php
763 %{_appdir}/include/jsrsServer.inc.php
764
765 %dir %attr(730,root,eventum) /var/run/%{name}
766 %dir %attr(730,root,eventum) /var/cache/%{name}
767
768 %files base
769 %defattr(644,root,root,755)
770 %attr(751,root,root) %dir %{_sysconfdir}
771 %dir %{_libdir}
772 %dir %{_appdir}
773 # qmail will ignore user, if it's home directory is not owned
774 %attr(750,eventum,eventum) %dir /var/lib/%{name}
775
776 %files setup
777 %defattr(644,root,root,755)
778 %{_appdir}/htdocs/setup
779
780 %files mail-queue
781 %defattr(644,root,root,755)
782 %{_appdir}/process_mail_queue.php
783 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
784
785 %files mail-download
786 %defattr(644,root,root,755)
787 %{_appdir}/download_emails.php
788 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
789
790 %files reminder
791 %defattr(644,root,root,755)
792 %{_appdir}/check_reminders.php
793 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
794
795 %files monitor
796 %defattr(644,root,root,755)
797 %{_appdir}/include/class.monitor.php
798 %{_appdir}/monitor.php
799 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
800
801 %files route-emails
802 %defattr(644,root,root,755)
803 %{_appdir}/route_emails.php
804
805 %files route-notes
806 %defattr(644,root,root,755)
807 %{_appdir}/route_drafts.php
808 %{_appdir}/route_notes.php
809
810 %if %{with qmail}
811 %files router-qmail
812 %defattr(644,root,root,755)
813 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
814 %attr(755,root,root) %{_libdir}/router-qmail
815 %endif
816
817 %files router-postfix
818 %defattr(644,root,root,755)
819
820 %files irc
821 %defattr(644,root,root,755)
822 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
823 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
824 %{_appdir}/irc
825 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
826
827 %files cli
828 %defattr(644,root,root,755)
829 %doc eventumrc
830 %attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
831 %attr(755,root,root) %{_bindir}/%{name}
832 %{_appdir}/cli
833
834 %files scm
835 %defattr(644,root,root,755)
836 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
837 %attr(755,root,root) %{_libdir}/scm
This page took 0.084065 seconds and 4 git commands to generate.