]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- RC2, renumber patches
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 # - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
9 #
10 # Conditional build:
11 %bcond_with     qmail   # build the router-qmail subpackage
12
13 #define _snap   20060330
14 %define _rc             RC2
15 %define _rel    0.2
16
17 %include        /usr/lib/rpm/macros.php
18 Summary:        Eventum Issue / Bug tracking system
19 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
20 Name:           eventum
21 Version:        1.7.1
22 Release:        %{?_snap:0.%{_snap}.}%{?_rc:%{_rc}.}%{_rel}
23 License:        GPL
24 Group:          Applications/WWW
25 Source0:        http://eventum.mysql.org/downloads/%{name}-%{version}.%{_rc}.tar.gz
26 # Source0-md5:  1ca8dd3b9876537ac29c02a549e245e1
27 #Source0:       http://downloads.mysql.com/snapshots/eventum/%{name}-nightly-%{_snap}.tar.gz
28 Source1:        %{name}-apache.conf
29 Source2:        %{name}-mail-queue.cron
30 Source3:        %{name}-mail-download.cron
31 Source4:        %{name}-reminder.cron
32 Source5:        %{name}-monitor.cron
33 Source6:        %{name}-cvs.php
34 Source7:        %{name}-irc.php
35 Source8:        %{name}-irc.init
36 Source9:        %{name}-irc.sysconfig
37 Source10:       %{name}-config.php
38 Source11:       %{name}-router-qmail.sh
39 Source12:       %{name}-config-setup.php
40 Source13:       %{name}-upgrade.sh
41 Source14:       %{name}-router-postfix.sh
42 Patch0:         %{name}-lf.patch
43 Patch1:         %{name}-perms.patch
44 Patch2:         %{name}-cli-wr-separated.patch
45 Patch3:         %{name}-scm-parse-response.patch
46 Patch4:         %{name}-double-decode.patch
47 Patch5:         %{name}-route-mem.patch
48 Patch6:         %{name}-scm-pluscharisbad.patch
49 Patch7:         %{name}-scm-updates.patch
50 Patch100:       %{name}-paths.patch
51 Patch101:       %{name}-cvs-config.patch
52 Patch102:       %{name}-irc-mem.patch
53 Patch103:       %{name}-irc-config.patch
54 Patch104:       %{name}-PEAR.patch
55 Patch105:       %{name}-httpclient-clientside.patch
56 Patch106:       %{name}-bot-reconnect.patch
57 Patch107:       %{name}-private-key.patch
58 URL:            http://dev.mysql.com/downloads/other/eventum/
59 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
60 BuildRequires:  rpmbuild(macros) >= 1.268
61 BuildRequires:  sed >= 4.0
62 Requires(triggerpostun):        /usr/bin/php
63 Requires(triggerpostun):        sed >= 4.0
64 Requires:       %{name}-base = %{version}-%{release}
65 Requires:       Smarty >= 2.6.10-4
66 Requires:       apache(mod_dir)
67 Requires:       php >= 3:4.2.0
68 Requires:       php-gd
69 Requires:       php-imap
70 Requires:       php-mysql
71 Requires:       php-pcre
72 Requires:       php-pear-Benchmark
73 Requires:       php-pear-DB
74 Requires:       php-pear-Date
75 Requires:       php-pear-HTTP_Request
76 Requires:       php-pear-Mail
77 Requires:       php-pear-Mail_Mime
78 Requires:       php-pear-Math_Stats
79 Requires:       php-pear-Net_DIME
80 Requires:       php-pear-Net_SMTP
81 Requires:       php-pear-Net_Socket
82 Requires:       php-pear-Net_URL
83 Requires:       php-pear-Net_UserAgent_Detect
84 Requires:       php-pear-PEAR-core
85 Requires:       php-pear-Text_Diff
86 Requires:       php-pear-XML_RPC
87 Requires:       php-session
88 Requires:       webapps
89 BuildArch:      noarch
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 %define         _noautoreq      'pear(/etc/webapps/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)'
93
94 %define         _libdir         %{_prefix}/lib/%{name}
95 %define         _appdir         %{_datadir}/%{name}
96 %define         _smartyplugindir        %{_appdir}/include/smarty
97 %define         _smartydir      /usr/share/php/Smarty
98 %define         _webapps        /etc/webapps
99 %define         _webapp         %{name}
100 %define         _webappdir      %{_webapps}/%{_webapp}
101 %define         _sysconfdir     /etc/%{name}
102
103 %description
104 Eventum is a user-friendly and flexible issue tracking system that can
105 be used by a support department to track incoming technical support
106 requests, or by a software development team to quickly organize tasks
107 and bugs. Eventum is used by the MySQL AB Technical Support team, and
108 has allowed us to dramatically improve our response times.
109
110 %description -l pl
111 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
112 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
113 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
114 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
115 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
116 reakcji.
117
118 %package base
119 Summary:        Eventum base package
120 Summary(pl):    Podstawowy pakiet Eventum
121 Group:          Applications/WWW
122 Requires(postun):       /usr/sbin/groupdel
123 Requires(postun):       /usr/sbin/userdel
124 Requires(pre):  /bin/id
125 Requires(pre):  /usr/bin/getgid
126 Requires(pre):  /usr/sbin/groupadd
127 Requires(pre):  /usr/sbin/useradd
128 Provides:       group(eventum)
129 Provides:       user(eventum)
130
131 %description base
132 This package contains base directory structure for Eventum.
133
134 %description base -l pl
135 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
136
137 %package setup
138 Summary:        Eventum setup package
139 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
140 Group:          Applications/WWW
141 Requires:       %{name} = %{version}-%{release}
142
143 %description setup
144 Install this package to configure initial Eventum installation. You
145 should uninstall this package when you're done, as it considered
146 insecure to keep the setup files in place.
147
148 %description setup -l pl
149 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
150 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
151 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
152
153 %package mail-queue
154 Summary:        Eventum mail queue process
155 Summary(pl):    Przetwarzanie kolejki poczty Eventum
156 Group:          Applications/WWW
157 Requires:       %{name} = %{version}-%{release}
158 Requires:       crondaemon
159
160 %description mail-queue
161 Beginning with the first release of Eventum, emails are not directly
162 sent out from the various scripts, but rather added to a mail queue
163 table that is processed by a cron job. If an email cannot be sent, it
164 will be marked as such in the mail queue log, and the cron job script
165 will re-try to send it again the next time it runs.
166
167 This package contains the cron job.
168
169 %description mail-queue -l pl
170 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
171 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
172 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
173 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
174 nastêpnym razem.
175
176 Ten pakiet zawiera zadanie dla crona.
177
178 %package mail-download
179 Summary:        Eventum email download
180 Summary(pl):    ¦ci±ganie poczty Eventum
181 Group:          Applications/WWW
182 Requires:       %{name} = %{version}-%{release}
183 Requires:       crondaemon
184
185 %description mail-download
186 In order for Eventum's email integration feature to work, you need to
187 setup a cron job to run the script every so often.
188
189 This package contains the cron job.
190
191 %description mail-download -l pl
192 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
193 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
194 czêsto.
195
196 Ten pakiet zawiera zadanie dla crona.
197
198 %package reminder
199 Summary:        Eventum Reminder System
200 Summary(pl):    System przypominania dla Eventum
201 Group:          Applications/WWW
202 Requires:       %{name} = %{version}-%{release}
203 Requires:       crondaemon
204
205 %description reminder
206 The reminder system was designed with the objective as serving as a
207 safe net for issues that need attention. Depending on what
208 configuration you create, you may have several reminders (or alerts)
209 be sent out whenever an issue needs attention, for whatever parameter
210 you may deem necessary.
211
212 This package contains the cron job.
213
214 %description reminder -l pl
215 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
216 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
217 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
218 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
219 uwa¿aæ za potrzebny.
220
221 Ten pakiet zawiera zadanie dla crona.
222
223 %package monitor
224 Summary:        Eventum Heartbeat Monitor
225 Summary(pl):    Monitor ¿ycia dla Eventum
226 Group:          Applications/WWW
227 Requires:       %{name} = %{version}-%{release}
228 Requires:       crondaemon
229 Requires:       php-posix
230
231 %description monitor
232 The heartbeat monitor is a feature designed for the administrator that
233 wants to be alerted whenever a common problem in Eventum is detected,
234 like the database server not being available anymore, or maybe when
235 the recommended permissions for certain configuration files are
236 changed.
237
238 Please note that before running the heartbeat monitor, you may need to
239 customize some of the checks to be appropriate for your own system,
240 particularly the permission and file checks on
241 Monitor::checkConfiguration().
242
243 This package contains the cron job.
244
245 %description monitor -l pl
246 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
247 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
248 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
249 do plików konfiguracyjnych.
250
251 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
252 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
253 testów uprawnieñ i plików w Monitor::checkConfiguration().
254
255 Ten pakiet zawiera zadanie dla crona.
256
257 %package route-drafts
258 Summary:        Eventum Draft Routing
259 Summary(pl):    Przekazywanie szkiców dla Eventum
260 Group:          Applications/WWW
261 Requires:       %{name} = %{version}-%{release}
262 Requires:       eventum(router)
263
264 %description route-drafts
265 The draft routing feature is used to automatically associate a thread
266 of drafts into an Eventum issue. By setting up qmail (or even Postfix)
267 to deliver emails sent to a specific address (usually
268 draft-<number>@<domain>) to the above script, users are able to send
269 drafts written in their mail client to be stored in Eventum. These
270 drafts will NOT broadcasted to the notification list.
271
272 %description route-drafts -l pl
273 Przekazywanie szkiców s³u¿y do automatycznego wi±zania w±tku szkiców z
274 problemem w Eventum. Ustawiaj±c qmaila (czy nawet Postfiksa), aby
275 dostarcza³ pocztê wys³an± na podany adres (zwykle
276 draft-<liczba>@<domena>) do tego skryptu umo¿liwia siê u¿ytkownikom
277 wysy³anie szkiców napisanych w ich kliencie pocztowym do zapisania w
278 Eventum. Szkice te NIE bêd± wysy³ane na listê powiadomieñ.
279
280 %package route-emails
281 Summary:        Eventum Email Routing
282 Summary(pl):    Przekazywanie poczty dla Eventum
283 Group:          Applications/WWW
284 Requires:       %{name} = %{version}-%{release}
285 Requires:       eventum(router)
286
287 %description route-emails
288 The email routing feature is used to automatically associate a thread
289 of emails into an Eventum issue. By setting up qmail (or even postfix)
290 to deliver emails sent to a specific address (usually
291 issue-<number>@<domain>) to the above script, users are able to use
292 their email clients to reply to emails coming from Eventum, and those
293 replies will be automatically associated with the issue and
294 broadcasted to the entire notification list.
295
296 %description route-emails -l pl
297 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
298 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
299 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
300 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
301 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
302 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
303 rozprowadzane do ca³ej listy og³oszeniowej.
304
305 %package route-notes
306 Summary:        Eventum Note Routing
307 Summary(pl):    Przekazywanie notatek dla Eventum
308 Group:          Applications/WWW
309 Requires:       %{name} = %{version}-%{release}
310 Requires:       eventum(router)
311
312 %description route-notes
313 The note routing feature is used to automatically associate a thread
314 of notes into an Eventum issue. By setting up qmail (or even postfix)
315 to deliver emails sent to a specific address (usually
316 note-<number>@<domain>) to the above script, users are able to use
317 their email clients to reply to internal notes coming from Eventum,
318 and those replies will be automatically associated with the issue and
319 broadcasted to the notification list staff members.
320
321 %description route-notes -l pl
322 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
323 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
324 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
325 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
326 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
327 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
328 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
329
330 %package router-qmail
331 Summary:        Eventum Mail Routing - qmail
332 Summary(pl):    Przekazywanie poczty Eventum - qmail
333 Group:          Applications/Mail
334 # loose dep is intentional. qmail subpackage isn't built on PLD
335 # builders and there really nothing changes.
336 Requires:       %{name} >= %{version}-%{release}
337 Requires:       qmail >= 1.03
338 Provides:       eventum(router)
339 Obsoletes:      eventum(router)
340
341 %description router-qmail
342 This package provides way of routing notes and emails back to Eventum
343 via qmail.
344
345 %description router-qmail -l pl
346 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
347 przez qmaila.
348
349 %package router-postfix
350 Summary:        Eventum Mail Routing - Postfix
351 Summary(pl):    Przekazywanie poczty Eventum - Postfix
352 Group:          Applications/Mail
353 Requires:       %{name} = %{version}-%{release}
354 Requires:       postfix
355 Provides:       eventum(router)
356 Obsoletes:      eventum(router)
357
358 %description router-postfix
359 This package provides way of routing notes and emails back to Eventum
360 via Postfix.
361
362 The Postfix configuration instructions you can find from
363 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
364
365 %description router-postfix -l pl
366 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
367 przez Postfiksa.
368
369 Opis konfiguracji Postfiksa mo¿na znale¼æ pod adresem
370 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
371
372 %package irc
373 Summary:        Eventum IRC Notification Bot
374 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
375 Group:          Applications/WWW
376 Requires(triggerpostun):        sed >= 4.0
377 Requires:       %{name} = %{version}-%{release}
378 Requires:       php-pear-Net_SmartIRC
379 Requires:       php-sockets
380 Requires:       rc-scripts >= 0.4.0.18
381
382 %description irc
383 The IRC notification bot is a nice feature for remote teams that want
384 to handle issues and want to have a quick and easy way to get simple
385 notifications. Right now the bot notifies of the following actions:
386 - New Issues
387 - Blocked emails
388 - Issues that got their assignment list changed
389
390 NOTE: You will need to manually edit the bot.php script to set your
391 appropriate preferences, like IRC server and channel that the bot
392 should join.
393
394 %description irc -l pl
395 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
396 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
397 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
398 nastêpuj±cych zdarzeniach:
399 - nowych sprawach
400 - zablokowanych listach
401 - sprawach, dla których zmieni³a siê lista powi±zañ
402
403 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
404 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
405
406 %package cli
407 Summary:        Eventum command-line interface
408 Summary(pl):    Interfejs linii poleceñ dla Eventum
409 Group:          Applications/WWW
410 Requires:       %{name}-base = %{version}-%{release}
411 Requires:       php-cli
412 Requires:       php-common >= 3:4.1.0
413 Requires:       php-curl
414 Requires:       php-pear-XML_RPC
415 Requires:       php-xml
416
417 %description cli
418 The Eventum command-line interface allows you to access most of the
419 features of the web interface straight from your command shell.
420
421 %description cli -l pl
422 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
423 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
424
425 %package scm
426 Summary:        Eventum SCM integration
427 Summary(pl):    Integracja SCM dla Eventum
428 Group:          Applications/WWW
429 Requires:       %{name}-base = %{version}-%{release}
430 Requires:       php-cli
431 Requires:       php-common >= 3:4.1.0
432 Requires:       php-pcre
433
434 %description scm
435 This feature allows your software development teams to integrate your
436 Source Control Management system with your Issue Tracking System.
437
438 The integration is implemented in such a way that it will be forward
439 compatible with pretty much any SCM system, such as CVS.
440
441 For installation see
442 </eventum/help.php?topic=scm_integration_installation>.
443
444 %description scm -l pl
445 Ten pakiet pozwala zespo³om programistów na integracjê systemu
446 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
447 ¶ledzenia spraw.
448
449 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
450 prawie ka¿dym systemem SCM, jak np. CVS.
451
452 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
453 </eventum/help.php?topic=scm_integration_installation>.
454
455 %prep
456 %setup -q %{?_snap:-n %{name}-%{_snap}}
457 # undos the source
458 find . -type f -print0 | xargs -0 sed -i -e 's,\r$,,'
459
460 rm -f setup.conf.php # not to be installed by *.php glob
461 rm -rf misc/upgrade/*v1.[123]* # too old to support in PLD Linux
462 rm -f misc/upgrade/flush_compiled_templates.php
463 rm -rf misc/upgrade/*/upgrade_config.php # not needed in PLD Linux
464
465 # sample, not used in eventum
466 rm -f rpc/xmlrpc_client.php
467
468 # bug fixes.
469 %patch0 -p1
470 %patch1 -p1
471 %patch2 -p1
472 %patch3 -p1
473 %patch4 -p1
474 %patch5 -p1
475 %patch6 -p1
476 %patch7 -p1
477
478 # packaging
479 %patch100 -p1
480 %patch101 -p1
481 %patch102 -p1
482 %patch103 -p1
483 %patch104 -p1
484 %patch105 -p1
485 %patch106 -p1
486 %patch107 -p1
487
488 sed -e '1s,#!.*/bin/php -q,#!%{_bindir}/php,' misc/cli/eventum > %{name}-cli
489 sed -e '1i#!%{_bindir}/php' misc/scm/process_cvs_commits.php > %{name}-scm
490 sed -e '1i#!%{_bindir}/php' misc/irc/bot.php > %{name}-bot
491 mv misc/cli/eventumrc_example eventumrc
492 sed -i -e '1i#!%{_bindir}/php' misc/*.php
493 chmod +x misc/*.php
494 mv include/private_key.php private_key.php.in
495
496 # replace in remaining scripts config.inc.php to system one
497 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
498         s,include_once(".*config.inc.php"),include_once("%{_webappdir}/core.php"),
499 '
500
501 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
502         s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_webappdir}/private_key.php"),
503 '
504
505 # remove backups from patching as we use globs to package files to buildroot
506 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
507
508 %install
509 rm -rf $RPM_BUILD_ROOT
510 install -d \
511         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
512         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
513         $RPM_BUILD_ROOT/var/{run,log,cache,lib}/%{name} \
514         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
515         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
516
517 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
518 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
519 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
520 cp -a templates $RPM_BUILD_ROOT%{_appdir}
521 cp -a include/{customer,custom_field,jpgraph,workflow} $RPM_BUILD_ROOT%{_appdir}/include
522 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
523 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
524 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
525
526 cp -a favicon.ico $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
527 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/setup/config.inc.php
528 install %{SOURCE13} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
529
530 # cli
531 install -d $RPM_BUILD_ROOT%{_appdir}/cli
532 cp -a misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
533 cp -a misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
534 install %{name}-cli $RPM_BUILD_ROOT%{_bindir}/%{name}
535 install %{name}-bot $RPM_BUILD_ROOT%{_sbindir}
536
537 # scm
538 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
539 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
540
541 # private key
542 cp -a private_key.php.in $RPM_BUILD_ROOT%{_webappdir}/private_key.php
543
544 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
545 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
546 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
547 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
548 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
549 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
550 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
551 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
552 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
553
554 sed -e '
555 s,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}}%{?_rc:-%{_rc}},
556 s,%%{PHP_PEAR_DIR}%%,%{php_pear_dir},
557 s,%%{APP_PATH}%%,%{_appdir},
558 s,%%{SMARTY_DIR}%%,%{_smartydir},
559 s,%%{SYSCONFDIR}%%,%{_webappdir},
560 ' %{SOURCE10} > $RPM_BUILD_ROOT%{_webappdir}/core.php
561
562 # config
563 > $RPM_BUILD_ROOT%{_webappdir}/setup.php
564 mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_webappdir}/config}.php
565
566 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
567 # These plugins are not in Smarty package (Smarty-2.6.2-3)
568 cp -a \
569         include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
570         include/Smarty/plugins/modifier.highlight_quoted.php \
571         $RPM_BUILD_ROOT%{_smartyplugindir}
572
573 # qmail router
574 %if %{with qmail}
575 d=$RPM_BUILD_ROOT/var/lib/%{name}
576 echo 'root' > $d/.qmail
577 echo 'root' > $d/.qmail-default
578 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
579 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
580 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
581 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
582 %endif
583 # postfix router
584 install %{SOURCE14} $RPM_BUILD_ROOT%{_libdir}/router-postfix
585
586 %clean
587 rm -rf $RPM_BUILD_ROOT
588
589 %pre
590 %addusertogroup http %{name}
591
592 %post
593 # check if the package is configured.
594 if grep -q 'header("Location: setup/")' %{_webappdir}/config.php; then
595 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
596 %banner %{name} -e <<EOF
597
598 You haven't yet configured Eventum!
599 Please open in browser <http://localhost/eventum/>
600 If you need access from elsewhere, you need to edit
601 %{_webappdir}/apache.conf and restart apache.
602
603 IMPORTANT: When You have configured Eventum, please uninstall the
604 setup package, so that %{name}-setup is able to secure your Eventum
605 installation.
606
607 EOF
608 #' vim syntax hack
609 else
610 %banner %{name} -e <<EOF
611
612 You haven't yet configured Eventum!
613
614 To setup eventum, please install %{name}-setup and open in browser
615 <http://localhost/eventum/>.
616 If you need access from elsewhere, you need to edit
617 %{_webappdir}/apache.conf and restart apache.
618
619 IMPORTANT: When You have configured Eventum, please uninstall the
620 setup package, so that %{name}-setup is able to secure your Eventum
621 installation.
622
623 EOF
624 #' vim syntax hack
625 fi
626
627 elif grep -q 'DEFAULTPRIVATEKEY' %{_webappdir}/private_key.php; then
628 %banner %{name} -e <<EOF
629
630 You have default private key installed!
631
632 Install %{name}-setup and open up http://yourserver/eventum/setup/
633 -- that will help you setup initial config.
634
635 when have configured Eventum, please uninstall the setup package,
636 so that %{name}-setup is able to secure your Eventum installation.
637
638 EOF
639         elif [ -d %{_appdir}/setup ]; then
640 %banner %{name} -e <<EOF
641
642 If you have have configured Eventum, please uninstall the setup package,
643 so that %{name}-setup is able to secure your Eventum installation.
644
645 EOF
646 fi
647
648 # nuke Smarty templates cache after upgrade
649 rm -f /var/cache/eventum/*.php
650
651 %preun
652 if [ "$1" = "0" ]; then
653         # nuke cache
654         rm -f /var/cache/eventum/*.php 2>/dev/null || :
655 fi
656
657 %pre base
658 %groupadd -P %{name}-base -g 146 %{name}
659 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
660
661 %postun base
662 if [ "$1" = "0" ]; then
663         %userremove %{name}
664         %groupremove %{name}
665 fi
666
667 %post router-qmail
668 CF=/etc/qmail/control/virtualdomains
669 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
670         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_webappdir}/config.php 2>/dev/null)
671         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
672         umask 022
673         echo "#${FQDN}:%{name}" >> $CF
674
675 %banner %{name}-qmail -e <<EOF
676
677 Added "#${FQDN}:%{name}" to $CF,
678 Please verify that it is correct and restart qmail:
679 # service qmail reload
680
681 Consult qmail-send(8) for more information on virtualdomains.
682
683 EOF
684 fi
685
686 %preun router-qmail
687 if [ "$1" = "0" ]; then
688         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
689 fi
690
691 %post setup
692 chmod 660 %{_webappdir}/{config,private_key}.php
693 chown root:eventum %{_webappdir}/{config,private_key}.php
694
695 %postun setup
696 if [ "$1" = "0" ]; then
697         chmod 640 %{_webappdir}/{config,private_key}.php
698         chown root:eventum %{_webappdir}/{config,private_key}.php
699 fi
700
701 %post irc
702 /sbin/chkconfig --add eventum-irc
703 %service eventum-irc restart "Eventum IRC Bot"
704
705 %triggerin -- apache1
706 %webapp_register apache %{_webapp}
707
708 %triggerun -- apache1
709 %webapp_unregister apache %{_webapp}
710
711 %triggerin -- apache < 2.2.0, apache-base
712 %webapp_register httpd %{_webapp}
713
714 %triggerun -- apache < 2.2.0, apache-base
715 %webapp_unregister httpd %{_webapp}
716
717 # FIXME
718 # only one upgrade trigger is called if you're upgrading over two
719 # versions, say 1.5 to 1.5.3, only 1.5.3 trigger is called.
720 # use common trigger (the highest version and rpmvercmp from poldek?)
721 %triggerpostun -- eventum < 1.5.1-0.257
722 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5_to_v1.5.1 <<EOF
723 database_changes.php Perform database changes
724 EOF
725
726 %triggerpostun -- eventum < 1.5.2-0.289
727 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.1_to_v1.5.2 <<EOF
728 database_changes.php Perform database changes
729 set_priority_ranks.php Fix the ranking of priority values
730 EOF
731
732 %triggerpostun -- eventum < 1.5.3-0.291
733 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.2_to_v1.5.3 <<EOF
734 database_changes.php Perform database changes
735 EOF
736
737 %triggerpostun -- eventum < 1.5.4-1.12
738 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.3_to_v1.5.4 <<EOF
739 database_changes.php Perform database changes
740 EOF
741
742 %triggerpostun -- eventum < 1.6.0-RC2.6
743 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.5_to_v1.6.0 <<EOF
744 database_changes.php Perform database changes
745 upgrade_saved_searches.php Upgrade existing custom filters (saved searches)
746 EOF
747
748 %triggerpostun -- eventum < 1.6.1-0.2
749 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.0_to_v1.6.1 <<EOF
750 database_changes.php Perform database changes
751 EOF
752
753 %triggerpostun irc -- eventum-irc < 1.6.1-3.14
754 sed -i -e '
755 s,\$irc_host,$irc_server_hostname,
756 s,\$irc_port,$irc_server_port,
757 s,\$irc_nick,$nickname,
758 s,\$irc_realname,$realname,
759 s,\$irc_username,$username,
760 s,\$irc_password,$password,
761 ' /etc/eventum/irc.php
762
763 %triggerpostun -- eventum < 1.7.0-2.0.48
764 # migrate from apache-config macros
765 if [ -f /etc/%{name}/apache.conf.rpmsave ]; then
766         if [ -d /etc/apache/webapps.d ]; then
767                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
768                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
769         fi
770
771         if [ -d /etc/httpd/webapps.d ]; then
772                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
773                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
774         fi
775 fi
776
777 if [ -L /etc/apache/conf.d/99_%{_webapp}.conf ]; then
778         /usr/sbin/webapp register apache %{_webapp}
779         rm -f /etc/apache/conf.d/99_%{_webapp}.conf
780         %service -q apache reload
781 fi
782 if [ -L /etc/httpd/httpd.conf/99_%{_webapp}.conf ]; then
783         /usr/sbin/webapp register httpd %{_webapp}
784         rm -f /etc/httpd/httpd.conf/99_%{_webapp}.conf
785         %service -q httpd reload
786 fi
787
788 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.1_to_v1.7.0 <<EOF
789 database_changes.php Perform database changes
790 set_root_message_ids.php Set iss_root_message_id
791 EOF
792
793 # regular configs
794 for i in apache.conf config.php private_key.php setup.php; do
795         if [ -f /etc/eventum/$i.rpmsave ]; then
796                 mv -f %{_webappdir}/$i{,.rpmnew}
797                 mv -f /etc/eventum/$i.rpmsave %{_webappdir}/$i
798         fi
799 done
800
801 %triggerpostun cli -- %{name}-cli < 1.7.0-3.4
802 if [ -f %{_webappdir}/cli.php.rpmsave ]; then
803         mv -f %{_sysconfdir}/cli.php{,.rpmnew}
804         mv -f %{_webappdir}/cli.php.rpmsave %{_sysconfdir}/cli.php
805 fi
806
807 %triggerpostun irc -- %{name}-irc < 1.7.0-3.4
808 if [ -f %{_webappdir}/irc.php.rpmsave ]; then
809         mv -f %{_sysconfdir}/irc.php{,.rpmnew}
810         mv -f %{_webappdir}/irc.php.rpmsave %{_sysconfdir}/irc.php
811 fi
812
813 %files
814 %defattr(644,root,root,755)
815 %doc ChangeLog FAQ INSTALL README UPGRADE CONTRIB
816 %doc docs/* setup/schema.sql
817 %attr(751,root,root) %dir %{_webappdir}
818 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
819 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
820 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
821 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
822 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
823 %attr(640,root,eventum) %config %verify(not mtime) %{_webappdir}/core.php
824
825 %dir %attr(731,root,eventum) /var/log/%{name}
826 %attr(620,root,eventum) %ghost /var/log/%{name}/*
827
828 %dir %{_appdir}/htdocs
829 %{_appdir}/htdocs/*.php
830 %{_appdir}/htdocs/*.ico
831 %{_appdir}/htdocs/css
832 %{_appdir}/htdocs/customer
833 %{_appdir}/htdocs/images
834 %{_appdir}/htdocs/js
835 %{_appdir}/htdocs/manage
836 %{_appdir}/htdocs/reports
837 %{_appdir}/htdocs/rpc
838 %{_appdir}/htdocs/misc
839 %{_appdir}/templates
840 %dir %{_appdir}/upgrade
841 %attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
842 %{_appdir}/upgrade/[!u]*
843 %{_smartyplugindir}
844
845 %dir %{_appdir}/include
846 %{_appdir}/include/customer
847 %{_appdir}/include/custom_field
848 %{_appdir}/include/jpgraph
849 %{_appdir}/include/workflow
850 %{_appdir}/include/class.[!m]*.php
851 %{_appdir}/include/class.mail.php
852 %{_appdir}/include/class.mail_queue.php
853 %{_appdir}/include/class.mime_helper.php
854 %{_appdir}/include/class.misc.php
855 %{_appdir}/include/db_access.php
856
857 %dir %attr(730,root,eventum) /var/run/%{name}
858 %dir %attr(730,root,eventum) /var/cache/%{name}
859
860 %files base
861 %defattr(644,root,root,755)
862 %attr(751,root,root) %dir %{_sysconfdir}
863 %dir %{_libdir}
864 %dir %{_appdir}
865 # qmail will ignore user, if it's home directory is not owned
866 %attr(750,eventum,eventum) %dir /var/lib/%{name}
867 # saved mail copies
868 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_emails
869 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_drafts
870 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_notes
871
872 %files setup
873 %defattr(644,root,root,755)
874 %{_appdir}/htdocs/setup
875
876 %files mail-queue
877 %defattr(644,root,root,755)
878 %attr(755,root,root) %{_appdir}/process_mail_queue.php
879 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
880
881 %files mail-download
882 %defattr(644,root,root,755)
883 %attr(755,root,root) %{_appdir}/download_emails.php
884 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
885
886 %files reminder
887 %defattr(644,root,root,755)
888 %attr(755,root,root) %{_appdir}/check_reminders.php
889 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
890
891 %files monitor
892 %defattr(644,root,root,755)
893 %{_appdir}/include/class.monitor.php
894 %attr(755,root,root) %{_appdir}/monitor.php
895 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
896
897 %files route-drafts
898 %defattr(644,root,root,755)
899 %attr(755,root,root) %{_appdir}/route_drafts.php
900
901 %files route-emails
902 %defattr(644,root,root,755)
903 %attr(755,root,root) %{_appdir}/route_emails.php
904
905 %files route-notes
906 %defattr(644,root,root,755)
907 %attr(755,root,root) %{_appdir}/route_notes.php
908
909 %if %{with qmail}
910 %files router-qmail
911 %defattr(644,root,root,755)
912 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
913 %attr(755,root,root) %{_libdir}/router-qmail
914 %endif
915
916 %files router-postfix
917 %defattr(644,root,root,755)
918 %attr(755,root,root) %{_libdir}/router-postfix
919
920 %files irc
921 %defattr(644,root,root,755)
922 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
923 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
924 %attr(755,root,root) %{_sbindir}/%{name}-bot
925 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
926
927 %files cli
928 %defattr(644,root,root,755)
929 %doc eventumrc
930 %attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
931 %attr(755,root,root) %{_bindir}/%{name}
932 %{_appdir}/cli
933
934 %files scm
935 %defattr(644,root,root,755)
936 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
937 %attr(755,root,root) %{_libdir}/scm
This page took 0.093308 seconds and 4 git commands to generate.