]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- remove php-pear-HTTP_Request dep, i don't see it being used
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 #
9 # Conditional build:
10 %bcond_without  order   # with experimental order patch
11
12 #define snap    20060921
13 %define rev             r4018
14 %define rel             2.49
15 #define _rc             RC3
16
17 %define         php_min_version 5.1.2
18 %include        /usr/lib/rpm/macros.php
19 Summary:        Eventum Issue / Bug tracking system
20 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
21 Name:           eventum
22 Version:        2.2
23 Release:        %{?_rc:%{_rc}.}%{rel}%{?snap:.%{snap}}%{?rev:.%{rev}}
24 License:        GPL
25 Group:          Applications/WWW
26 #Source0:       http://downloads.mysql.com/snapshots/eventum/%{name}-nightly-%{snap}.tar.gz
27 #Source0:       http://eventum.mysql.org/downloads/eventum-2.0.RC3.tar.gz
28 #Source0:       http://mysql.easynet.be/Downloads/eventum/%{name}-%{version}.tar.gz
29 # bzr branch lp:eventum eventum && cd eventum && make dist
30 Source0:        %{name}-%{version}-dev-%{rev}.tar.gz
31 # Source0-md5:  74cc4307c0641c2fbe7e543e994cfbe0
32 Source1:        %{name}-apache.conf
33 Source2:        %{name}-mail-queue.cron
34 Source3:        %{name}-mail-download.cron
35 Source4:        %{name}-reminder.cron
36 Source5:        %{name}-monitor.cron
37 Source6:        %{name}-cvs.php
38 Source7:        %{name}-irc.php
39 Source8:        %{name}-irc.init
40 Source9:        %{name}-irc.sysconfig
41 Source13:       %{name}-router-postfix.sh
42 Source14:       %{name}.logrotate
43 Source15:       %{name}-lighttpd.conf
44 Source16:       http://www.isocra.com/images/updown2.gif
45 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
46 Patch0:         %{name}-lf.patch
47 Patch2:         %{name}-order.patch
48 # packaging patches that probably never go upstream
49 Patch100:       %{name}-paths.patch
50 Patch101:       %{name}-cvs-config.patch
51 Patch105:       %{name}-bot-reconnect.patch
52 Patch107:       %{name}-gettext.patch
53 # some tests
54 Patch200:       %{name}-fixed-nav.patch
55 URL:            http://eventum.mysql.org/
56 BuildRequires:  gettext-devel
57 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
58 BuildRequires:  rpmbuild(macros) >= 1.461
59 BuildRequires:  sed >= 4.0
60 Requires(triggerpostun):        /usr/bin/php
61 Requires(triggerpostun):        sed >= 4.0
62 Requires:       %{name}-base = %{version}-%{release}
63 Requires:       Smarty >= 2.6.10-4
64 Requires:       php-common >= 4:%{php_min_version}
65 Requires:       php-gd
66 Requires:       php-iconv
67 Requires:       php-imap
68 Requires:       php-mbstring
69 Requires:       php-mysql
70 Requires:       php-pcre
71 Requires:       php-pear-DB
72 Requires:       php-pear-Date
73 Requires:       php-pear-Mail
74 Requires:       php-pear-Mail_Mime
75 Requires:       php-pear-Mail_mimeDecode
76 Requires:       php-pear-Math_Stats
77 Requires:       php-pear-Net_DIME
78 Requires:       php-pear-Net_SMTP
79 Requires:       php-pear-Net_Socket
80 Requires:       php-pear-Net_URL
81 Requires:       php-pear-Net_UserAgent_Detect
82 Requires:       php-pear-PEAR-core
83 Requires:       php-pear-Text_Diff
84 Requires:       php-pear-XML_RPC
85 Requires:       php-session
86 Requires:       smarty-gettext
87 Requires:       webapps
88 Requires:       webserver(access)
89 Requires:       webserver(alias)
90 Requires:       webserver(indexfile)
91 Requires:       webserver(php) >= 4.2.0
92 Suggests:       localedb
93 Conflicts:      logrotate < 3.7-4
94 BuildArch:      noarch
95 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97 %define         _noautopear     'pear(init.php)' 'pear(/etc/webapps/.*)' 'pear(%{_appdir}/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)' 'pear(Services/JSON.php)'
98
99 # exclude optional php dependencies
100 %define         _noautophp      'php(gnupg)' 'php(hash)' 'php(pecl-http)' 'php(json)' 'php(tk)'
101
102 # we don't want php(xxx) being resolved to php-xxx
103 %define         _noautoreqdep   '^php(.*)$'
104
105 %define         _noautoreq      %{_noautophp} %{_noautopear}
106
107 %define         _libdir         %{_prefix}/lib/%{name}
108 %define         _appdir         %{_datadir}/%{name}
109 %define         _smartydir      %{php_data_dir}/Smarty
110 %define         _webapps        /etc/webapps
111 %define         _webapp         %{name}
112 %define         _webappdir      %{_webapps}/%{_webapp}
113 %define         _sysconfdir     /etc/%{name}
114
115 %description
116 Eventum is a user-friendly and flexible issue tracking system that can
117 be used by a support department to track incoming technical support
118 requests, or by a software development team to quickly organize tasks
119 and bugs. Eventum is used by the MySQL AB Technical Support team, and
120 has allowed us to dramatically improve our response times.
121
122 %description -l pl.UTF-8
123 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
124 może być używany przez dział obsługi do śledzenia przychodzących żądań
125 obsługi technicznej albo przez zespół tworzący oprogramowanie do
126 szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
127 Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
128 reakcji.
129
130 %package base
131 Summary:        Eventum base package
132 Summary(pl.UTF-8):      Podstawowy pakiet Eventum
133 Group:          Applications/WWW
134 Requires(postun):       /usr/sbin/groupdel
135 Requires(postun):       /usr/sbin/userdel
136 Requires(pre):  /bin/id
137 Requires(pre):  /usr/bin/getgid
138 Requires(pre):  /usr/sbin/groupadd
139 Requires(pre):  /usr/sbin/useradd
140 Provides:       group(eventum)
141 Provides:       user(eventum)
142
143 %description base
144 This package contains base directory structure for Eventum.
145
146 %description base -l pl.UTF-8
147 Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
148
149 %package setup
150 Summary:        Eventum setup package
151 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
152 Group:          Applications/WWW
153 Requires:       %{name} = %{version}-%{release}
154
155 %description setup
156 Install this package to configure initial Eventum installation. You
157 should uninstall this package when you're done, as it considered
158 insecure to keep the setup files in place.
159
160 %description setup -l pl.UTF-8
161 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
162 pierwszej instalacji. Potem należy go odinstalować, jako że
163 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
164
165 %package mail-queue
166 Summary:        Eventum mail queue process
167 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
168 Group:          Applications/WWW
169 Requires:       %{name} = %{version}-%{release}
170 Requires:       crondaemon
171
172 %description mail-queue
173 Beginning with the first release of Eventum, emails are not directly
174 sent out from the various scripts, but rather added to a mail queue
175 table that is processed by a cron job. If an email cannot be sent, it
176 will be marked as such in the mail queue log, and the cron job script
177 will re-try to send it again the next time it runs.
178
179 This package contains the cron job.
180
181 %description mail-queue -l pl.UTF-8
182 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
183 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
184 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
185 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
186 następnym razem.
187
188 Ten pakiet zawiera zadanie dla crona.
189
190 %package mail-download
191 Summary:        Eventum email download
192 Summary(pl.UTF-8):      Ściąganie poczty Eventum
193 Group:          Applications/WWW
194 Requires:       %{name} = %{version}-%{release}
195 Requires:       crondaemon
196
197 %description mail-download
198 In order for Eventum's email integration feature to work, you need to
199 setup a cron job to run the script every so often.
200
201 This package contains the cron job.
202
203 %description mail-download -l pl.UTF-8
204 Aby integracja poczty elektronicznej w Eventum działała, trzeba
205 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
206 często.
207
208 Ten pakiet zawiera zadanie dla crona.
209
210 %package reminder
211 Summary:        Eventum Reminder System
212 Summary(pl.UTF-8):      System przypominania dla Eventum
213 Group:          Applications/WWW
214 Requires:       %{name} = %{version}-%{release}
215 Requires:       crondaemon
216
217 %description reminder
218 The reminder system was designed with the objective as serving as a
219 safe net for issues that need attention. Depending on what
220 configuration you create, you may have several reminders (or alerts)
221 be sent out whenever an issue needs attention, for whatever parameter
222 you may deem necessary.
223
224 This package contains the cron job.
225
226 %description reminder -l pl.UTF-8
227 System przypominania został zaprojektowany tak, aby służył jako
228 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
229 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
230 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
231 uważać za potrzebny.
232
233 Ten pakiet zawiera zadanie dla crona.
234
235 %package monitor
236 Summary:        Eventum Heartbeat Monitor
237 Summary(pl.UTF-8):      Monitor życia dla Eventum
238 Group:          Applications/WWW
239 Requires:       %{name} = %{version}-%{release}
240 Requires:       crondaemon
241 Requires:       php(posix)
242
243 %description monitor
244 The heartbeat monitor is a feature designed for the administrator that
245 wants to be alerted whenever a common problem in Eventum is detected,
246 like the database server not being available anymore, or maybe when
247 the recommended permissions for certain configuration files are
248 changed.
249
250 Please note that before running the heartbeat monitor, you may need to
251 customize some of the checks to be appropriate for your own system,
252 particularly the permission and file checks on
253 Monitor::checkConfiguration().
254
255 This package contains the cron job.
256
257 %description monitor -l pl.UTF-8
258 Monitor życia to funkcjonalność zaprojektowana dla administratora
259 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
260 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
261 do plików konfiguracyjnych.
262
263 Należy zauważyć, że przed uruchomieniem tego monitora może być
264 konieczne dostosowanie niektórych testów do systemu, w szczególności
265 testów uprawnień i plików w Monitor::checkConfiguration().
266
267 Ten pakiet zawiera zadanie dla crona.
268
269 %package route-drafts
270 Summary:        Eventum Draft Routing
271 Summary(pl.UTF-8):      Przekazywanie szkiców dla Eventum
272 Group:          Applications/WWW
273 Requires:       %{name} = %{version}-%{release}
274 Requires:       eventum(router)
275
276 %description route-drafts
277 The draft routing feature is used to automatically associate a thread
278 of drafts into an Eventum issue. By setting up Postfix to deliver
279 emails sent to a specific address (usually draft-<number>@<domain>) to
280 the above script, users are able to send drafts written in their mail
281 client to be stored in Eventum. These drafts will NOT broadcasted to
282 the notification list.
283
284 %description route-drafts -l pl.UTF-8
285 Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
286 problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
287 wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
288 skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
289 kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
290 na listę powiadomień.
291
292 %package route-emails
293 Summary:        Eventum Email Routing
294 Summary(pl.UTF-8):      Przekazywanie poczty dla Eventum
295 Group:          Applications/WWW
296 Requires:       %{name} = %{version}-%{release}
297 Requires:       eventum(router)
298
299 %description route-emails
300 The email routing feature is used to automatically associate a thread
301 of emails into an Eventum issue. By setting up Postfix to deliver
302 emails sent to a specific address (usually issue-<number>@<domain>) to
303 the above script, users are able to use their email clients to reply
304 to emails coming from Eventum, and those replies will be automatically
305 associated with the issue and broadcasted to the entire notification
306 list.
307
308 %description route-emails -l pl.UTF-8
309 Funkcjonalność przekazywania poczty służy do automatycznego wiązania
310 wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
311 aby dostarczał listy wysyłane na pewien adres (zwykle
312 issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
313 używać klientów pocztowych do odpowiadania na listy przychodzące z
314 Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
315 rozprowadzane do całej listy ogłoszeniowej.
316
317 %package route-notes
318 Summary:        Eventum Note Routing
319 Summary(pl.UTF-8):      Przekazywanie notatek dla Eventum
320 Group:          Applications/WWW
321 Requires:       %{name} = %{version}-%{release}
322 Requires:       eventum(router)
323
324 %description route-notes
325 The note routing feature is used to automatically associate a thread
326 of notes into an Eventum issue. By setting up Postfix to deliver
327 emails sent to a specific address (usually note-<number>@<domain>) to
328 the above script, users are able to use their email clients to reply
329 to internal notes coming from Eventum, and those replies will be
330 automatically associated with the issue and broadcasted to the
331 notification list staff members.
332
333 %description route-notes -l pl.UTF-8
334 Funkcjonalność przekazywania notatek służy do automatycznego wiązania
335 wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
336 dostarczał listy wysyłane na pewien adres (zwykle
337 note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
338 używać klientów pocztowych do odpowiadania na wewnętrzne notatki
339 pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
340 sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
341
342 %package router-postfix
343 Summary:        Eventum Mail Routing - Postfix
344 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
345 Group:          Applications/Mail
346 Requires:       %{name} = %{version}-%{release}
347 Requires:       postfix
348 Provides:       eventum(router)
349 Obsoletes:      eventum(router)
350
351 %description router-postfix
352 This package provides way of routing notes and emails back to Eventum
353 via Postfix.
354
355 The Postfix configuration instructions you can find from
356 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
357
358 %description router-postfix -l pl.UTF-8
359 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
360 przez Postfiksa.
361
362 Opis konfiguracji Postfiksa można znaleźć pod adresem
363 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
364
365 %package irc
366 Summary:        Eventum IRC Notification Bot
367 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
368 Group:          Applications/WWW
369 Requires(post,preun):   /sbin/chkconfig
370 Requires(triggerpostun):        sed >= 4.0
371 Requires:       %{name} = %{version}-%{release}
372 Requires:       php(sockets)
373 Requires:       php-pear-Net_SmartIRC
374 Requires:       rc-scripts >= 0.4.0.18
375
376 %description irc
377 The IRC notification bot is a nice feature for remote teams that want
378 to handle issues and want to have a quick and easy way to get simple
379 notifications. Right now the bot notifies of the following actions:
380 - New Issues
381 - Blocked emails
382 - Issues that got their assignment list changed
383
384 NOTE: You will need to manually edit the bot.php script to set your
385 appropriate preferences, like IRC server and channel that the bot
386 should join.
387
388 %description irc -l pl.UTF-8
389 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
390 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
391 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
392 następujących zdarzeniach:
393 - nowych sprawach
394 - zablokowanych listach
395 - sprawach, dla których zmieniła się lista powiązań
396
397 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
398 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
399
400 %package cli
401 Summary:        Eventum command-line interface
402 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
403 Group:          Applications/WWW
404 Requires:       %{name}-base = %{version}-%{release}
405 Requires:       php-cli
406 Requires:       php-common >= 4:%{php_min_version}
407 Requires:       php-pear-XML_RPC
408
409 %description cli
410 The Eventum command-line interface allows you to access most of the
411 features of the web interface straight from your command shell.
412
413 %description cli -l pl.UTF-8
414 Interfejs linii poleceń Eventum pozwala na dostęp do większości
415 funkcji interfejsu WWW prosto z linii poleceń powłoki.
416
417 %package scm
418 Summary:        Eventum SCM integration
419 Summary(pl.UTF-8):      Integracja SCM dla Eventum
420 Group:          Applications/WWW
421 Requires:       %{name}-base = %{version}-%{release}
422 Requires:       php-cli
423 Requires:       php-common >= 4:%{php_min_version}
424 Requires:       php-pcre
425
426 %description scm
427 This feature allows your software development teams to integrate your
428 Source Control Management system with your Issue Tracking System.
429
430 The integration is implemented in such a way that it will be forward
431 compatible with pretty much any SCM system, such as CVS.
432
433 For installation see
434 </eventum/help.php?topic=scm_integration_installation>.
435
436 %description scm -l pl.UTF-8
437 Ten pakiet pozwala zespołom programistów na integrację systemu
438 zarządzania źródłami (SCM - Source Control Management) z systemem
439 śledzenia spraw.
440
441 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
442 prawie każdym systemem SCM, jak np. CVS.
443
444 Szczegóły na temat instalacji można przeczytać pod
445 </eventum/help.php?topic=scm_integration_installation>.
446
447 %prep
448 %setup -q
449
450 rm -r upgrade/*v1.[123]* # too old to support in PLD Linux
451 rm -r upgrade/v{1.,2.0,2.1_}* # no longer supported in PLD Linux
452 rm upgrade/flush_compiled_templates.php
453 rm -r upgrade/{*/,}index.html # not needed in PLD Linux
454
455 # bug fixes / features
456 %patch0 -p1
457 %{?with_order:%patch2 -p1}
458
459 cp -a %{SOURCE16} htdocs/images
460
461 #%patch200 -p1
462
463 # packaging
464 %patch100 -p1
465 %patch101 -p1
466 %patch105 -p1
467 %patch107 -p1
468
469 cat <<'EOF'> mysql-permissions.sql
470 # use this schema if you want to grant permissions manually instead of using setup
471 # this schema is extracted from setup/index.php.
472 GRANT SELECT, UPDATE, DELETE, INSERT, ALTER, DROP, CREATE, INDEX ON eventum.* TO 'eventum'@'localhost' IDENTIFIED BY 'password';
473 EOF
474
475 %{__sed} -i -e "
476 s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
477 " upgrade/{*/,}*.php
478
479 # remove backups from patching as we use globs to package files to buildroot
480 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
481
482 %build
483 %{__make} -C localization
484
485 %install
486 rm -rf $RPM_BUILD_ROOT
487 install -d \
488         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
489         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
490         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
491         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
492         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
493         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
494
495 %{__make} install-eventum install-cli install-irc install-scm install-jpgraph install-localization \
496         sysconfdir=%{_webappdir} \
497         DESTDIR=$RPM_BUILD_ROOT
498
499 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
500
501 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
502 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
503 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
504 cp -a %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
505
506 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
507 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
508 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
509 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
510
511 cp -a %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
512
513 cp -a %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
514 cp -a %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
515
516 # postfix router
517 install %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
518
519 install -D %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
520
521 %find_lang %{name}
522
523 # scm
524 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
525
526 # old compat
527 ln -s %{_sbindir}/eventum-cvs-hook $RPM_BUILD_ROOT%{_libdir}/process_cvs_commits
528 ln -s %{_sbindir}/eventum-svn-hook $RPM_BUILD_ROOT%{_libdir}/process_svn_commits
529
530 # skip pear for cli
531 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
532 cp -a cli/lib/eventum $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
533
534 %clean
535 rm -rf $RPM_BUILD_ROOT
536
537 %pre
538 %addusertogroup http %{name}
539
540 %post
541 # check if the package is configured.
542 if grep -q "Header('Location: setup/')" %{_webappdir}/config.php; then
543 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
544 %banner %{name} -e <<EOF
545
546 You haven't yet configured Eventum!
547 Please open in browser <http://localhost/eventum/>
548 If you need access from elsewhere, you need to edit
549 %{_webappdir}/apache.conf and restart apache.
550
551 IMPORTANT: When You have configured Eventum, please uninstall the
552 setup package, so that %{name}-setup is able to secure your Eventum
553 installation.
554
555 EOF
556 #' vim syntax hack
557 else
558 %banner %{name} -e <<EOF
559
560 You haven't yet configured Eventum!
561
562 To setup eventum, please install %{name}-setup and open in browser
563 <http://localhost/eventum/>.
564 If you need access from elsewhere, you need to edit
565 %{_webappdir}/*.conf depending on webserver and restart the webserver.
566
567 IMPORTANT: When You have configured Eventum, please uninstall the
568 setup package, so that %{name}-setup is able to secure your Eventum
569 installation.
570
571 EOF
572 #' vim syntax hack
573 fi
574
575 elif grep -q 'DEFAULTPRIVATEKEY' %{_webappdir}/private_key.php; then
576 %banner %{name} -e <<EOF
577
578 You have default private key installed!
579
580 Install %{name}-setup and open up http://yourserver/eventum/setup/
581 -- that will help you setup initial config.
582
583 when have configured Eventum, please uninstall the setup package,
584 so that %{name}-setup is able to secure your Eventum installation.
585
586 EOF
587         elif [ -d %{_appdir}/setup ]; then
588 %banner %{name} -e <<EOF
589
590 If you have have configured Eventum, please uninstall the setup package,
591 so that %{name}-setup is able to secure your Eventum installation.
592
593 EOF
594 fi
595
596 # greate empty ghost files
597 for a in cli.log errors.log irc_bot.log login_attempts.log; do
598         if [ ! -f /var/log/%{name}/$a ]; then
599                 install -m620 -oroot -geventum /dev/null /var/log/%{name}/$a
600         fi
601 done
602
603 # database update
604 %{_appdir}/upgrade/update-database.php || :
605
606 # nuke Smarty templates cache after upgrade
607 rm -f /var/cache/eventum/*.php
608
609 %preun
610 if [ "$1" = "0" ]; then
611         # nuke cache
612         rm -f /var/cache/eventum/*.php 2>/dev/null || :
613 fi
614
615 %pre base
616 %groupadd -P %{name}-base -g 146 %{name}
617 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
618
619 %postun base
620 if [ "$1" = "0" ]; then
621         %userremove %{name}
622         %groupremove %{name}
623 fi
624
625 %post setup
626 chmod 660 %{_webappdir}/{config,private_key}.php
627 chown root:eventum %{_webappdir}/{config,private_key}.php
628
629 %postun setup
630 if [ "$1" = "0" ]; then
631         chmod 640 %{_webappdir}/{config,private_key}.php
632         chown root:eventum %{_webappdir}/{config,private_key}.php
633 fi
634
635 %post irc
636 /sbin/chkconfig --add eventum-irc
637 %service eventum-irc restart "Eventum IRC Bot"
638
639 %preun irc
640 if [ "$1" = 0 ]; then
641         %service eventum-irc stop
642         /sbin/chkconfig --del eventum-irc
643 fi
644
645 %triggerin -- apache1 < 1.3.37-3, apache1-base
646 %webapp_register apache %{_webapp}
647
648 %triggerun -- apache1 < 1.3.37-3, apache1-base
649 %webapp_unregister apache %{_webapp}
650
651 %triggerin -- apache < 2.2.0, apache-base
652 %webapp_register httpd %{_webapp}
653
654 %triggerun -- apache < 2.2.0, apache-base
655 %webapp_unregister httpd %{_webapp}
656
657 %triggerin -- lighttpd
658 %webapp_register lighttpd %{_webapp}
659
660 %triggerun -- lighttpd
661 %webapp_unregister lighttpd %{_webapp}
662
663 %files -f %{name}.lang
664 %defattr(644,root,root,755)
665 %doc ChangeLog FAQ INSTALL README UPGRADE CONTRIB
666 %doc docs/* htdocs/setup/schema.sql mysql-permissions.sql
667 %attr(751,root,root) %dir %{_webappdir}
668 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
669 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
670 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
671 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
672 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
673 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
674 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
675
676 %dir %attr(731,root,eventum) /var/log/%{name}
677 %attr(620,root,eventum) %ghost /var/log/%{name}/*
678 %dir %attr(750,root,root) /var/log/archive/%{name}
679 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
680
681 %{_appdir}/init.php
682 %dir %{_appdir}/htdocs
683 %{_appdir}/htdocs/*.php
684 %{_appdir}/htdocs/*.ico
685 %{_appdir}/htdocs/css
686 %{_appdir}/htdocs/customer
687 %{_appdir}/htdocs/images
688 %{_appdir}/htdocs/js
689 %{_appdir}/htdocs/manage
690 %{_appdir}/htdocs/reports
691 %{_appdir}/htdocs/rpc
692 %{_appdir}/htdocs/misc
693 %if %{with order}
694 %{_appdir}/htdocs/ajax
695 %endif
696 %{_appdir}/templates
697
698 %dir %{_appdir}/upgrade
699 %{_appdir}/upgrade/init.php
700 %attr(755,root,root) %{_appdir}/upgrade/update-database.php
701 %dir %{_appdir}/upgrade/v*
702 %attr(755,root,root) %{_appdir}/upgrade/v*/*.php
703 %{_appdir}/upgrade/patches
704
705 %dir %{_appdir}/lib
706 %{_appdir}/lib/eventum
707 %{_appdir}/lib/jpgraph
708 %exclude %{_appdir}/lib/eventum/class.monitor.php
709
710 %dir %attr(730,root,eventum) /var/run/%{name}
711 %dir %attr(730,root,eventum) /var/cache/%{name}
712
713 %files base
714 %defattr(644,root,root,755)
715 %attr(751,root,root) %dir %{_sysconfdir}
716 %dir %{_libdir}
717 %dir %{_appdir}
718 %dir /var/lib/%{name}
719 # saved mail copies
720 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_emails
721 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_drafts
722 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_notes
723
724 %files setup
725 %defattr(644,root,root,755)
726 %{_appdir}/htdocs/setup
727
728 %files mail-queue
729 %defattr(644,root,root,755)
730 %attr(755,root,root) %{_appdir}/process_mail_queue.php
731 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
732
733 %files mail-download
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{_appdir}/download_emails.php
736 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
737
738 %files reminder
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{_appdir}/check_reminders.php
741 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
742
743 %files monitor
744 %defattr(644,root,root,755)
745 %{_appdir}/lib/eventum/class.monitor.php
746 %attr(755,root,root) %{_appdir}/monitor.php
747 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
748
749 %files route-drafts
750 %defattr(644,root,root,755)
751 %attr(755,root,root) %{_appdir}/route_drafts.php
752
753 %files route-emails
754 %defattr(644,root,root,755)
755 %attr(755,root,root) %{_appdir}/route_emails.php
756
757 %files route-notes
758 %defattr(644,root,root,755)
759 %attr(755,root,root) %{_appdir}/route_notes.php
760
761 %files router-postfix
762 %defattr(644,root,root,755)
763 %attr(755,root,root) %{_libdir}/router-postfix
764
765 %files irc
766 %defattr(644,root,root,755)
767 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
768 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
769 %attr(755,root,root) %{_sbindir}/%{name}-irc-bot
770 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
771
772 %files cli
773 %defattr(644,root,root,755)
774 %doc cli/eventumrc
775 %attr(755,root,root) %{_bindir}/%{name}
776 %{_appdir}/cli
777
778 %files scm
779 %defattr(644,root,root,755)
780 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
781 %attr(755,root,root) %{_libdir}/process_cvs_commits
782 %attr(755,root,root) %{_libdir}/process_svn_commits
783 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
784 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
This page took 0.07548 seconds and 4 git commands to generate.