]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- avoid passwords showing up in backtrace
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 # - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
9 #
10 # Conditional build:
11 %bcond_with     qmail   # build the router-qmail subpackage
12 %bcond_with     order_patch     # with custom issue order patch
13
14 #define _snap   20060330
15 #define _rc             RC3
16 %define _rel    2.35
17
18 %include        /usr/lib/rpm/macros.php
19 Summary:        Eventum Issue / Bug tracking system
20 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
21 Name:           eventum
22 Version:        1.7.1
23 Release:        %{?_snap:0.%{_snap}.}%{?_rc:%{_rc}.}%{_rel}
24 License:        GPL
25 Group:          Applications/WWW
26 #Source0:       http://downloads.mysql.com/snapshots/eventum/%{name}-nightly-%{_snap}.tar.gz
27 Source0:        http://mysql.dataphone.se/Downloads/eventum/%{name}-%{version}.tar.gz
28 # Source0-md5:  e1845de39b4d9bd30ddec9c26031a7d5
29 Source1:        %{name}-apache.conf
30 Source2:        %{name}-mail-queue.cron
31 Source3:        %{name}-mail-download.cron
32 Source4:        %{name}-reminder.cron
33 Source5:        %{name}-monitor.cron
34 Source6:        %{name}-cvs.php
35 Source7:        %{name}-irc.php
36 Source8:        %{name}-irc.init
37 Source9:        %{name}-irc.sysconfig
38 Source10:       %{name}-config.php
39 Source11:       %{name}-router-qmail.sh
40 Source12:       %{name}-config-setup.php
41 Source13:       %{name}-upgrade.sh
42 Source14:       %{name}-router-postfix.sh
43 Source15:       %{name}.logrotate
44 Patch0:         %{name}-lf.patch
45 Patch1:         %{name}-perms.patch
46 Patch2:         %{name}-cli-wr-separated.patch
47 Patch3:         %{name}-scm-parse-response.patch
48 Patch4:         %{name}-double-decode.patch
49 Patch5:         %{name}-route-mem.patch
50 Patch6:         %{name}-scm-pluscharisbad.patch
51 Patch7:         %{name}-scm-updates.patch
52 Patch8:         %{name}-close-signature.patch
53 Patch9:         %{name}-list-sorting.patch
54 Patch10:        %{name}-workflow-handlenewnote-note_id.patch
55 Patch11:        %{name}-order4b.patch
56 Patch12:        %{name}-cli-errorcheck.patch
57 Patch13:        %{name}-combined.patch
58 Patch14:        %{name}-xml-inline.patch
59 Patch15:        %{name}-timetracking-advanced-logic.patch
60 Patch16:        %{name}-timedisplay.patch
61 Patch17:        %{name}-bug-17267.patch
62 Patch18:        %{name}-compact-issue-display.patch
63 Patch19:        %{name}-fixed-nav.patch
64 Patch20:        %{name}-scm-ssl.patch
65 Patch21:        %{name}-scm-quick-out.patch
66 Patch22:        %{name}-mem-limits.patch
67 Patch23:        %{name}-backtraces.patch
68 # packaging patches that probably never go upstream
69 Patch100:       %{name}-paths.patch
70 Patch101:       %{name}-cvs-config.patch
71 Patch102:       %{name}-irc-mem.patch
72 Patch103:       %{name}-irc-config.patch
73 Patch104:       %{name}-PEAR.patch
74 Patch105:       %{name}-httpclient-clientside.patch
75 Patch106:       %{name}-bot-reconnect.patch
76 Patch107:       %{name}-private-key.patch
77 URL:            http://dev.mysql.com/downloads/other/eventum/
78 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
79 BuildRequires:  rpmbuild(macros) >= 1.268
80 BuildRequires:  sed >= 4.0
81 Requires(triggerpostun):        /usr/bin/php
82 Requires(triggerpostun):        sed >= 4.0
83 Requires:       %{name}-base = %{version}-%{release}
84 Requires:       Smarty >= 2.6.10-4
85 Requires:       apache(mod_dir)
86 Requires:       php >= 3:4.2.0
87 Requires:       php-gd
88 Requires:       php-imap
89 Requires:       php-mysql
90 Requires:       php-pcre
91 Requires:       php-pear-Benchmark
92 Requires:       php-pear-DB
93 Requires:       php-pear-Date
94 Requires:       php-pear-HTTP_Request
95 Requires:       php-pear-Mail
96 Requires:       php-pear-Mail_Mime
97 Requires:       php-pear-Math_Stats
98 Requires:       php-pear-Net_DIME
99 Requires:       php-pear-Net_SMTP
100 Requires:       php-pear-Net_Socket
101 Requires:       php-pear-Net_URL
102 Requires:       php-pear-Net_UserAgent_Detect
103 Requires:       php-pear-PEAR-core
104 Requires:       php-pear-Text_Diff
105 Requires:       php-pear-XML_RPC
106 Requires:       php-session
107 Requires:       webapps
108 BuildArch:      noarch
109 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
110
111 %define         _noautoreq      'pear(/etc/webapps/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)'
112
113 %define         _libdir         %{_prefix}/lib/%{name}
114 %define         _appdir         %{_datadir}/%{name}
115 %define         _smartyplugindir        %{_appdir}/include/smarty
116 %define         _smartydir      /usr/share/php/Smarty
117 %define         _webapps        /etc/webapps
118 %define         _webapp         %{name}
119 %define         _webappdir      %{_webapps}/%{_webapp}
120 %define         _sysconfdir     /etc/%{name}
121
122 %description
123 Eventum is a user-friendly and flexible issue tracking system that can
124 be used by a support department to track incoming technical support
125 requests, or by a software development team to quickly organize tasks
126 and bugs. Eventum is used by the MySQL AB Technical Support team, and
127 has allowed us to dramatically improve our response times.
128
129 %description -l pl
130 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
131 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
132 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
133 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
134 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
135 reakcji.
136
137 %package base
138 Summary:        Eventum base package
139 Summary(pl):    Podstawowy pakiet Eventum
140 Group:          Applications/WWW
141 Requires(postun):       /usr/sbin/groupdel
142 Requires(postun):       /usr/sbin/userdel
143 Requires(pre):  /bin/id
144 Requires(pre):  /usr/bin/getgid
145 Requires(pre):  /usr/sbin/groupadd
146 Requires(pre):  /usr/sbin/useradd
147 Provides:       group(eventum)
148 Provides:       user(eventum)
149
150 %description base
151 This package contains base directory structure for Eventum.
152
153 %description base -l pl
154 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
155
156 %package setup
157 Summary:        Eventum setup package
158 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
159 Group:          Applications/WWW
160 Requires:       %{name} = %{version}-%{release}
161
162 %description setup
163 Install this package to configure initial Eventum installation. You
164 should uninstall this package when you're done, as it considered
165 insecure to keep the setup files in place.
166
167 %description setup -l pl
168 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
169 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
170 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
171
172 %package mail-queue
173 Summary:        Eventum mail queue process
174 Summary(pl):    Przetwarzanie kolejki poczty Eventum
175 Group:          Applications/WWW
176 Requires:       %{name} = %{version}-%{release}
177 Requires:       crondaemon
178
179 %description mail-queue
180 Beginning with the first release of Eventum, emails are not directly
181 sent out from the various scripts, but rather added to a mail queue
182 table that is processed by a cron job. If an email cannot be sent, it
183 will be marked as such in the mail queue log, and the cron job script
184 will re-try to send it again the next time it runs.
185
186 This package contains the cron job.
187
188 %description mail-queue -l pl
189 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
190 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
191 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
192 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
193 nastêpnym razem.
194
195 Ten pakiet zawiera zadanie dla crona.
196
197 %package mail-download
198 Summary:        Eventum email download
199 Summary(pl):    ¦ci±ganie poczty Eventum
200 Group:          Applications/WWW
201 Requires:       %{name} = %{version}-%{release}
202 Requires:       crondaemon
203
204 %description mail-download
205 In order for Eventum's email integration feature to work, you need to
206 setup a cron job to run the script every so often.
207
208 This package contains the cron job.
209
210 %description mail-download -l pl
211 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
212 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
213 czêsto.
214
215 Ten pakiet zawiera zadanie dla crona.
216
217 %package reminder
218 Summary:        Eventum Reminder System
219 Summary(pl):    System przypominania dla Eventum
220 Group:          Applications/WWW
221 Requires:       %{name} = %{version}-%{release}
222 Requires:       crondaemon
223
224 %description reminder
225 The reminder system was designed with the objective as serving as a
226 safe net for issues that need attention. Depending on what
227 configuration you create, you may have several reminders (or alerts)
228 be sent out whenever an issue needs attention, for whatever parameter
229 you may deem necessary.
230
231 This package contains the cron job.
232
233 %description reminder -l pl
234 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
235 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
236 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
237 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
238 uwa¿aæ za potrzebny.
239
240 Ten pakiet zawiera zadanie dla crona.
241
242 %package monitor
243 Summary:        Eventum Heartbeat Monitor
244 Summary(pl):    Monitor ¿ycia dla Eventum
245 Group:          Applications/WWW
246 Requires:       %{name} = %{version}-%{release}
247 Requires:       crondaemon
248 Requires:       php-posix
249
250 %description monitor
251 The heartbeat monitor is a feature designed for the administrator that
252 wants to be alerted whenever a common problem in Eventum is detected,
253 like the database server not being available anymore, or maybe when
254 the recommended permissions for certain configuration files are
255 changed.
256
257 Please note that before running the heartbeat monitor, you may need to
258 customize some of the checks to be appropriate for your own system,
259 particularly the permission and file checks on
260 Monitor::checkConfiguration().
261
262 This package contains the cron job.
263
264 %description monitor -l pl
265 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
266 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
267 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
268 do plików konfiguracyjnych.
269
270 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
271 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
272 testów uprawnieñ i plików w Monitor::checkConfiguration().
273
274 Ten pakiet zawiera zadanie dla crona.
275
276 %package route-drafts
277 Summary:        Eventum Draft Routing
278 Summary(pl):    Przekazywanie szkiców dla Eventum
279 Group:          Applications/WWW
280 Requires:       %{name} = %{version}-%{release}
281 Requires:       eventum(router)
282
283 %description route-drafts
284 The draft routing feature is used to automatically associate a thread
285 of drafts into an Eventum issue. By setting up qmail (or even Postfix)
286 to deliver emails sent to a specific address (usually
287 draft-<number>@<domain>) to the above script, users are able to send
288 drafts written in their mail client to be stored in Eventum. These
289 drafts will NOT broadcasted to the notification list.
290
291 %description route-drafts -l pl
292 Przekazywanie szkiców s³u¿y do automatycznego wi±zania w±tku szkiców z
293 problemem w Eventum. Ustawiaj±c qmaila (czy nawet Postfiksa), aby
294 dostarcza³ pocztê wys³an± na podany adres (zwykle
295 draft-<liczba>@<domena>) do tego skryptu umo¿liwia siê u¿ytkownikom
296 wysy³anie szkiców napisanych w ich kliencie pocztowym do zapisania w
297 Eventum. Szkice te NIE bêd± wysy³ane na listê powiadomieñ.
298
299 %package route-emails
300 Summary:        Eventum Email Routing
301 Summary(pl):    Przekazywanie poczty dla Eventum
302 Group:          Applications/WWW
303 Requires:       %{name} = %{version}-%{release}
304 Requires:       eventum(router)
305
306 %description route-emails
307 The email routing feature is used to automatically associate a thread
308 of emails into an Eventum issue. By setting up qmail (or even postfix)
309 to deliver emails sent to a specific address (usually
310 issue-<number>@<domain>) to the above script, users are able to use
311 their email clients to reply to emails coming from Eventum, and those
312 replies will be automatically associated with the issue and
313 broadcasted to the entire notification list.
314
315 %description route-emails -l pl
316 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
317 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
318 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
319 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
320 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
321 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
322 rozprowadzane do ca³ej listy og³oszeniowej.
323
324 %package route-notes
325 Summary:        Eventum Note Routing
326 Summary(pl):    Przekazywanie notatek dla Eventum
327 Group:          Applications/WWW
328 Requires:       %{name} = %{version}-%{release}
329 Requires:       eventum(router)
330
331 %description route-notes
332 The note routing feature is used to automatically associate a thread
333 of notes into an Eventum issue. By setting up qmail (or even postfix)
334 to deliver emails sent to a specific address (usually
335 note-<number>@<domain>) to the above script, users are able to use
336 their email clients to reply to internal notes coming from Eventum,
337 and those replies will be automatically associated with the issue and
338 broadcasted to the notification list staff members.
339
340 %description route-notes -l pl
341 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
342 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
343 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
344 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
345 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
346 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
347 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
348
349 %package router-qmail
350 Summary:        Eventum Mail Routing - qmail
351 Summary(pl):    Przekazywanie poczty Eventum - qmail
352 Group:          Applications/Mail
353 # loose dep is intentional. qmail subpackage isn't built on PLD
354 # builders and there really nothing changes.
355 Requires:       %{name} >= %{version}-%{release}
356 Requires:       qmail >= 1.03
357 Provides:       eventum(router)
358 Obsoletes:      eventum(router)
359
360 %description router-qmail
361 This package provides way of routing notes and emails back to Eventum
362 via qmail.
363
364 %description router-qmail -l pl
365 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
366 przez qmaila.
367
368 %package router-postfix
369 Summary:        Eventum Mail Routing - Postfix
370 Summary(pl):    Przekazywanie poczty Eventum - Postfix
371 Group:          Applications/Mail
372 Requires:       %{name} = %{version}-%{release}
373 Requires:       postfix
374 Provides:       eventum(router)
375 Obsoletes:      eventum(router)
376
377 %description router-postfix
378 This package provides way of routing notes and emails back to Eventum
379 via Postfix.
380
381 The Postfix configuration instructions you can find from
382 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
383
384 %description router-postfix -l pl
385 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
386 przez Postfiksa.
387
388 Opis konfiguracji Postfiksa mo¿na znale¼æ pod adresem
389 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
390
391 %package irc
392 Summary:        Eventum IRC Notification Bot
393 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
394 Group:          Applications/WWW
395 Requires(post,preun):   /sbin/chkconfig
396 Requires(triggerpostun):        sed >= 4.0
397 Requires:       %{name} = %{version}-%{release}
398 Requires:       php-pear-Net_SmartIRC
399 Requires:       php-sockets
400 Requires:       rc-scripts >= 0.4.0.18
401
402 %description irc
403 The IRC notification bot is a nice feature for remote teams that want
404 to handle issues and want to have a quick and easy way to get simple
405 notifications. Right now the bot notifies of the following actions:
406 - New Issues
407 - Blocked emails
408 - Issues that got their assignment list changed
409
410 NOTE: You will need to manually edit the bot.php script to set your
411 appropriate preferences, like IRC server and channel that the bot
412 should join.
413
414 %description irc -l pl
415 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
416 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
417 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
418 nastêpuj±cych zdarzeniach:
419 - nowych sprawach
420 - zablokowanych listach
421 - sprawach, dla których zmieni³a siê lista powi±zañ
422
423 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
424 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
425
426 %package cli
427 Summary:        Eventum command-line interface
428 Summary(pl):    Interfejs linii poleceñ dla Eventum
429 Group:          Applications/WWW
430 Requires:       %{name}-base = %{version}-%{release}
431 Requires:       php-cli
432 Requires:       php-common >= 3:4.1.0
433 Requires:       php-pear-XML_RPC
434
435 %description cli
436 The Eventum command-line interface allows you to access most of the
437 features of the web interface straight from your command shell.
438
439 %description cli -l pl
440 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
441 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
442
443 %package scm
444 Summary:        Eventum SCM integration
445 Summary(pl):    Integracja SCM dla Eventum
446 Group:          Applications/WWW
447 Requires:       %{name}-base = %{version}-%{release}
448 Requires:       php-cli
449 Requires:       php-common >= 3:4.1.0
450 Requires:       php-pcre
451
452 %description scm
453 This feature allows your software development teams to integrate your
454 Source Control Management system with your Issue Tracking System.
455
456 The integration is implemented in such a way that it will be forward
457 compatible with pretty much any SCM system, such as CVS.
458
459 For installation see
460 </eventum/help.php?topic=scm_integration_installation>.
461
462 %description scm -l pl
463 Ten pakiet pozwala zespo³om programistów na integracjê systemu
464 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
465 ¶ledzenia spraw.
466
467 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
468 prawie ka¿dym systemem SCM, jak np. CVS.
469
470 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
471 </eventum/help.php?topic=scm_integration_installation>.
472
473 %prep
474 %setup -q %{?_snap:-n %{name}-%{_snap}}
475 # undos the source
476 find . -type f -print0 | xargs -0 sed -i -e 's,\r$,,'
477
478 rm -f setup.conf.php # not to be installed by *.php glob
479 rm -rf misc/upgrade/*v1.[123]* # too old to support in PLD Linux
480 rm -f misc/upgrade/flush_compiled_templates.php
481 rm -rf misc/upgrade/*/upgrade_config.php # not needed in PLD Linux
482
483 # sample, not used in eventum
484 rm -f rpc/xmlrpc_client.php
485
486 # bug fixes.
487 %patch0 -p1
488 %patch1 -p1
489 %patch2 -p1
490 %patch3 -p1
491 %patch4 -p1
492 %patch5 -p1
493 %patch6 -p1
494 %patch7 -p1
495 %patch8 -p1
496 %patch9 -p1
497 %patch10 -p1
498 %{?with_order_patch:%patch11 -p1}
499 %patch12 -p1
500 %patch13 -p1
501 %patch14 -p1
502 %patch15 -p1
503 %patch16 -p1
504 %patch17 -p1
505 %patch18 -p1
506 #%patch19 -p1
507 %patch20 -p1
508 %patch21 -p1
509 %patch22 -p1
510 %patch23 -p1
511
512 # packaging
513 %patch100 -p1
514 %patch101 -p1
515 %patch102 -p1
516 %patch103 -p1
517 %patch104 -p1
518 %patch105 -p1
519 %patch106 -p1
520 %patch107 -p1
521
522 cat <<'EOF'> mysql-permissions.sql
523 # use this schema if you want to grant permissions manually instead of using setup
524 # this schema is extracted from setup/index.php.
525 GRANT SELECT, UPDATE, DELETE, INSERT, ALTER, DROP, CREATE, INDEX ON eventum.* TO 'eventum'@'localhost' IDENTIFIED BY 'password';
526 EOF
527
528 sed -e '1s,#!.*/bin/php -q,#!%{_bindir}/php,' misc/cli/eventum > %{name}-cli
529 sed -e '1i#!%{_bindir}/php' misc/scm/process_cvs_commits.php > %{name}-scm
530 sed -e '1i#!%{_bindir}/php' misc/irc/bot.php > %{name}-bot
531 mv misc/cli/eventumrc_example eventumrc
532 sed -i -e '1i#!%{_bindir}/php' misc/*.php
533 chmod +x misc/*.php
534 mv include/private_key.php private_key.php.in
535
536 # replace in remaining scripts config.inc.php to system one
537 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
538         s,include_once(".*config.inc.php"),include_once("%{_webappdir}/core.php"),
539 '
540
541 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
542         s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_webappdir}/private_key.php"),
543 '
544
545 # remove backups from patching as we use globs to package files to buildroot
546 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
547
548 %install
549 rm -rf $RPM_BUILD_ROOT
550 install -d \
551         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
552         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
553         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
554         $RPM_BUILD_ROOT/var/log/{archiv/,}%{name} \
555         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
556         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
557
558 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
559 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
560 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
561 cp -a templates $RPM_BUILD_ROOT%{_appdir}
562 cp -a include/{customer,custom_field,jpgraph,workflow} $RPM_BUILD_ROOT%{_appdir}/include
563 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
564 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
565 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
566
567 cp -a favicon.ico $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
568 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/setup/config.inc.php
569 install %{SOURCE13} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
570
571 # cli
572 install -d $RPM_BUILD_ROOT%{_appdir}/cli
573 cp -a misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
574 cp -a misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
575 install %{name}-cli $RPM_BUILD_ROOT%{_bindir}/%{name}
576 install %{name}-bot $RPM_BUILD_ROOT%{_sbindir}
577
578 # scm
579 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
580 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
581
582 # private key
583 cp -a private_key.php.in $RPM_BUILD_ROOT%{_webappdir}/private_key.php
584
585 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
586 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
587 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
588 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
589 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
590 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
591 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
592 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
593 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
594
595 sed -e '
596 s,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}}%{?_rc:-%{_rc}},
597 s,%%{PHP_PEAR_DIR}%%,%{php_pear_dir},
598 s,%%{APP_PATH}%%,%{_appdir},
599 s,%%{SMARTY_DIR}%%,%{_smartydir},
600 s,%%{SYSCONFDIR}%%,%{_webappdir},
601 ' %{SOURCE10} > $RPM_BUILD_ROOT%{_webappdir}/core.php
602
603 # config
604 > $RPM_BUILD_ROOT%{_webappdir}/setup.php
605 mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_webappdir}/config}.php
606
607 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
608 # These plugins are not in Smarty package (Smarty-2.6.2-3)
609 cp -a \
610         include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
611         include/Smarty/plugins/modifier.highlight_quoted.php \
612         $RPM_BUILD_ROOT%{_smartyplugindir}
613
614 # qmail router
615 %if %{with qmail}
616 d=$RPM_BUILD_ROOT/var/lib/%{name}
617 echo 'root' > $d/.qmail
618 echo 'root' > $d/.qmail-default
619 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
620 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
621 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
622 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
623 %endif
624 # postfix router
625 install %{SOURCE14} $RPM_BUILD_ROOT%{_libdir}/router-postfix
626
627 install -D %{SOURCE15} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
628
629 %clean
630 rm -rf $RPM_BUILD_ROOT
631
632 %pre
633 %addusertogroup http %{name}
634
635 %post
636 # check if the package is configured.
637 if grep -q 'header("Location: setup/")' %{_webappdir}/config.php; then
638 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
639 %banner %{name} -e <<EOF
640
641 You haven't yet configured Eventum!
642 Please open in browser <http://localhost/eventum/>
643 If you need access from elsewhere, you need to edit
644 %{_webappdir}/apache.conf and restart apache.
645
646 IMPORTANT: When You have configured Eventum, please uninstall the
647 setup package, so that %{name}-setup is able to secure your Eventum
648 installation.
649
650 EOF
651 #' vim syntax hack
652 else
653 %banner %{name} -e <<EOF
654
655 You haven't yet configured Eventum!
656
657 To setup eventum, please install %{name}-setup and open in browser
658 <http://localhost/eventum/>.
659 If you need access from elsewhere, you need to edit
660 %{_webappdir}/apache.conf and restart apache.
661
662 IMPORTANT: When You have configured Eventum, please uninstall the
663 setup package, so that %{name}-setup is able to secure your Eventum
664 installation.
665
666 EOF
667 #' vim syntax hack
668 fi
669
670 elif grep -q 'DEFAULTPRIVATEKEY' %{_webappdir}/private_key.php; then
671 %banner %{name} -e <<EOF
672
673 You have default private key installed!
674
675 Install %{name}-setup and open up http://yourserver/eventum/setup/
676 -- that will help you setup initial config.
677
678 when have configured Eventum, please uninstall the setup package,
679 so that %{name}-setup is able to secure your Eventum installation.
680
681 EOF
682         elif [ -d %{_appdir}/setup ]; then
683 %banner %{name} -e <<EOF
684
685 If you have have configured Eventum, please uninstall the setup package,
686 so that %{name}-setup is able to secure your Eventum installation.
687
688 EOF
689 fi
690
691 # nuke Smarty templates cache after upgrade
692 rm -f /var/cache/eventum/*.php
693
694 %preun
695 if [ "$1" = "0" ]; then
696         # nuke cache
697         rm -f /var/cache/eventum/*.php 2>/dev/null || :
698 fi
699
700 %pre base
701 %groupadd -P %{name}-base -g 146 %{name}
702 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
703
704 %postun base
705 if [ "$1" = "0" ]; then
706         %userremove %{name}
707         %groupremove %{name}
708 fi
709
710 %post router-qmail
711 CF=/etc/qmail/control/virtualdomains
712 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
713         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_webappdir}/config.php 2>/dev/null)
714         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
715         umask 022
716         echo "#${FQDN}:%{name}" >> $CF
717
718 %banner %{name}-qmail -e <<EOF
719
720 Added "#${FQDN}:%{name}" to $CF,
721 Please verify that it is correct and restart qmail:
722 # service qmail reload
723
724 Consult qmail-send(8) for more information on virtualdomains.
725
726 EOF
727 fi
728
729 %preun router-qmail
730 if [ "$1" = "0" ]; then
731         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
732 fi
733
734 %post setup
735 chmod 660 %{_webappdir}/{config,private_key}.php
736 chown root:eventum %{_webappdir}/{config,private_key}.php
737
738 %postun setup
739 if [ "$1" = "0" ]; then
740         chmod 640 %{_webappdir}/{config,private_key}.php
741         chown root:eventum %{_webappdir}/{config,private_key}.php
742 fi
743
744 %post irc
745 /sbin/chkconfig --add eventum-irc
746 %service eventum-irc restart "Eventum IRC Bot"
747
748 %preun irc
749 if [ "$1" = 0 ]; then
750         %service eventum-irc stop
751         /sbin/chkconfig --del eventum-irc
752 fi
753
754 %triggerin -- apache1
755 %webapp_register apache %{_webapp}
756
757 %triggerun -- apache1
758 %webapp_unregister apache %{_webapp}
759
760 %triggerin -- apache < 2.2.0, apache-base
761 %webapp_register httpd %{_webapp}
762
763 %triggerun -- apache < 2.2.0, apache-base
764 %webapp_unregister httpd %{_webapp}
765
766 # FIXME
767 # only one upgrade trigger is called if you're upgrading over two
768 # versions, say 1.5 to 1.5.3, only 1.5.3 trigger is called.
769 # use common trigger (the highest version and rpmvercmp from poldek?)
770 %triggerpostun -- eventum < 1.5.1-0.257
771 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5_to_v1.5.1 <<EOF
772 database_changes.php Perform database changes
773 EOF
774
775 %triggerpostun -- eventum < 1.5.2-0.289
776 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.1_to_v1.5.2 <<EOF
777 database_changes.php Perform database changes
778 set_priority_ranks.php Fix the ranking of priority values
779 EOF
780
781 %triggerpostun -- eventum < 1.5.3-0.291
782 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.2_to_v1.5.3 <<EOF
783 database_changes.php Perform database changes
784 EOF
785
786 %triggerpostun -- eventum < 1.5.4-1.12
787 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.3_to_v1.5.4 <<EOF
788 database_changes.php Perform database changes
789 EOF
790
791 %triggerpostun -- eventum < 1.6.0-RC2.6
792 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.5_to_v1.6.0 <<EOF
793 database_changes.php Perform database changes
794 upgrade_saved_searches.php Upgrade existing custom filters (saved searches)
795 EOF
796
797 %triggerpostun -- eventum < 1.6.1-0.2
798 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.0_to_v1.6.1 <<EOF
799 database_changes.php Perform database changes
800 EOF
801
802 %triggerpostun irc -- eventum-irc < 1.6.1-3.14
803 sed -i -e '
804 s,\$irc_host,$irc_server_hostname,
805 s,\$irc_port,$irc_server_port,
806 s,\$irc_nick,$nickname,
807 s,\$irc_realname,$realname,
808 s,\$irc_username,$username,
809 s,\$irc_password,$password,
810 ' /etc/eventum/irc.php
811
812 %triggerpostun -- eventum < 1.7.0-2.0.48
813 # migrate from apache-config macros
814 if [ -f /etc/%{name}/apache.conf.rpmsave ]; then
815         if [ -d /etc/apache/webapps.d ]; then
816                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
817                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
818         fi
819
820         if [ -d /etc/httpd/webapps.d ]; then
821                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
822                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
823         fi
824 fi
825
826 if [ -L /etc/apache/conf.d/99_%{_webapp}.conf ]; then
827         /usr/sbin/webapp register apache %{_webapp}
828         rm -f /etc/apache/conf.d/99_%{_webapp}.conf
829         %service -q apache reload
830 fi
831 if [ -L /etc/httpd/httpd.conf/99_%{_webapp}.conf ]; then
832         /usr/sbin/webapp register httpd %{_webapp}
833         rm -f /etc/httpd/httpd.conf/99_%{_webapp}.conf
834         %service -q httpd reload
835 fi
836
837 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.1_to_v1.7.0 <<EOF
838 database_changes.php Perform database changes
839 set_root_message_ids.php Set iss_root_message_id
840 EOF
841
842 # regular configs
843 for i in apache.conf config.php private_key.php setup.php; do
844         if [ -f /etc/eventum/$i.rpmsave ]; then
845                 mv -f %{_webappdir}/$i{,.rpmnew}
846                 mv -f /etc/eventum/$i.rpmsave %{_webappdir}/$i
847         fi
848 done
849
850 %triggerpostun cli -- %{name}-cli < 1.7.0-3.4
851 if [ -f %{_webappdir}/cli.php.rpmsave ]; then
852         mv -f %{_sysconfdir}/cli.php{,.rpmnew}
853         mv -f %{_webappdir}/cli.php.rpmsave %{_sysconfdir}/cli.php
854 fi
855
856 %triggerpostun irc -- %{name}-irc < 1.7.0-3.4
857 if [ -f %{_webappdir}/irc.php.rpmsave ]; then
858         mv -f %{_sysconfdir}/irc.php{,.rpmnew}
859         mv -f %{_webappdir}/irc.php.rpmsave %{_sysconfdir}/irc.php
860 fi
861
862 %files
863 %defattr(644,root,root,755)
864 %doc ChangeLog FAQ INSTALL README UPGRADE CONTRIB
865 %doc docs/* setup/schema.sql mysql-permissions.sql
866 %attr(751,root,root) %dir %{_webappdir}
867 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
868 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
869 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
870 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
871 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
872 %attr(640,root,eventum) %config %verify(not mtime) %{_webappdir}/core.php
873
874 %dir %attr(731,root,eventum) /var/log/%{name}
875 %attr(620,root,eventum) %ghost /var/log/%{name}/*
876 %dir %attr(750,root,root) /var/log/archiv/%{name}
877 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
878
879 %dir %{_appdir}/htdocs
880 %{_appdir}/htdocs/*.php
881 %{_appdir}/htdocs/*.ico
882 %{_appdir}/htdocs/css
883 %{_appdir}/htdocs/customer
884 %{_appdir}/htdocs/images
885 %{_appdir}/htdocs/js
886 %{_appdir}/htdocs/manage
887 %{_appdir}/htdocs/reports
888 %{_appdir}/htdocs/rpc
889 %{_appdir}/htdocs/misc
890 %{_appdir}/templates
891 %dir %{_appdir}/upgrade
892 %attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
893 %{_appdir}/upgrade/[!u]*
894 %{_smartyplugindir}
895
896 %dir %{_appdir}/include
897 %{_appdir}/include/customer
898 %{_appdir}/include/custom_field
899 %{_appdir}/include/jpgraph
900 %{_appdir}/include/workflow
901 %{_appdir}/include/class.[!m]*.php
902 %{_appdir}/include/class.mail.php
903 %{_appdir}/include/class.mail_queue.php
904 %{_appdir}/include/class.mime_helper.php
905 %{_appdir}/include/class.misc.php
906 %{_appdir}/include/db_access.php
907
908 %dir %attr(730,root,eventum) /var/run/%{name}
909 %dir %attr(730,root,eventum) /var/cache/%{name}
910
911 %files base
912 %defattr(644,root,root,755)
913 %attr(751,root,root) %dir %{_sysconfdir}
914 %dir %{_libdir}
915 %dir %{_appdir}
916 # qmail will ignore user, if it's home directory is not owned
917 %attr(750,eventum,eventum) %dir /var/lib/%{name}
918 # saved mail copies
919 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_emails
920 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_drafts
921 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_notes
922
923 %files setup
924 %defattr(644,root,root,755)
925 %{_appdir}/htdocs/setup
926
927 %files mail-queue
928 %defattr(644,root,root,755)
929 %attr(755,root,root) %{_appdir}/process_mail_queue.php
930 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
931
932 %files mail-download
933 %defattr(644,root,root,755)
934 %attr(755,root,root) %{_appdir}/download_emails.php
935 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
936
937 %files reminder
938 %defattr(644,root,root,755)
939 %attr(755,root,root) %{_appdir}/check_reminders.php
940 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
941
942 %files monitor
943 %defattr(644,root,root,755)
944 %{_appdir}/include/class.monitor.php
945 %attr(755,root,root) %{_appdir}/monitor.php
946 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
947
948 %files route-drafts
949 %defattr(644,root,root,755)
950 %attr(755,root,root) %{_appdir}/route_drafts.php
951
952 %files route-emails
953 %defattr(644,root,root,755)
954 %attr(755,root,root) %{_appdir}/route_emails.php
955
956 %files route-notes
957 %defattr(644,root,root,755)
958 %attr(755,root,root) %{_appdir}/route_notes.php
959
960 %if %{with qmail}
961 %files router-qmail
962 %defattr(644,root,root,755)
963 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
964 %attr(755,root,root) %{_libdir}/router-qmail
965 %endif
966
967 %files router-postfix
968 %defattr(644,root,root,755)
969 %attr(755,root,root) %{_libdir}/router-postfix
970
971 %files irc
972 %defattr(644,root,root,755)
973 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
974 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
975 %attr(755,root,root) %{_sbindir}/%{name}-bot
976 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
977
978 %files cli
979 %defattr(644,root,root,755)
980 %doc eventumrc
981 %attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
982 %attr(755,root,root) %{_bindir}/%{name}
983 %{_appdir}/cli
984
985 %files scm
986 %defattr(644,root,root,755)
987 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
988 %attr(755,root,root) %{_libdir}/scm
This page took 0.128854 seconds and 4 git commands to generate.