]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- pl for -router-*
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - system pear is incompatible, at least pear DB class seems broke Eventum
3 # - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
4 # - discard bundled packages (from INSTALL):
5 #  - JpGraph 1.5.3 (last GPL version)
6 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
7 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
8 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
9 #  - A few other small javascript libraries
10 # - need start-stop-daemon (from dpkg for now)
11
12 %bcond_with     pear    # build with system PEAR packages (or use bundled ones)
13
14 %define uid     146
15 %define gid     146
16
17 # snapshot: DATE
18 %define _snap 20050222
19
20 %if 0%{?_snap}
21 %define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
22 %else
23 %define _source http://mysql.wildyou.net/Downloads/%{name}/%{name}-%{version}.tar.gz
24 %endif
25
26 %define _rel 222
27
28 Summary:        Eventum Issue / Bug tracking system
29 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
30 Name:           eventum
31 Version:        1.4
32 Release:        2.%{?_snap:%{_snap}.}%{_rel}
33 License:        GPL
34 Group:          Applications/WWW
35 Source0:        %{_source}
36 # Source0-md5:  035bd8f7890260c1c058eaf1d54dcc90
37 Source1:        %{name}-apache.conf
38 Source2:        %{name}-mail-queue.cron
39 Source3:        %{name}-mail-download.cron
40 Source4:        %{name}-reminder.cron
41 Source5:        %{name}-monitor.cron
42 Source6:        %{name}-cvs.php
43 Source7:        %{name}-irc.php
44 Source8:        %{name}-irc.init
45 Source9:        %{name}-irc.sysconfig
46 Source10:       %{name}-config.php
47 Source11:       %{name}-router-qmail.sh
48 Patch0:         %{name}-paths.patch
49 Patch1:         %{name}-scm-encode.patch
50 Patch2:         %{name}-cvs-config.patch
51 Patch3:         %{name}-irc-config.patch
52 Patch4:         %{name}-PEAR.patch
53 Patch11:        %{name}-scm_checkin_associated.patch
54 Patch12:        %{name}-mail-queue.tpl.patch
55 Patch13:        %{name}-maildecode.patch
56 Patch14:        %{name}-send-typo.patch
57 Patch15:        %{name}-fixes.patch
58 Patch16:        %{name}-rss-charset.patch
59 Patch17:        %{name}-scm-silence-add.patch
60 Patch18:        %{name}-default-TZ.patch
61 Patch19:        %{name}-charset-mailsubj.patch
62 Patch20:        %{name}-monitor-bot-process.patch
63 URL:            http://dev.mysql.com/downloads/other/eventum/index.html
64 BuildRequires:  rpmbuild(macros) >= 1.177
65 BuildRequires:  sed >= 4.0
66 Requires:       php >= 4.2.0
67 Requires:       php-gd
68 Requires:       php-imap
69 Requires:       php-mysql
70 Requires:       php-pcre
71 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
72 Requires:       Smarty >= 2.6.2
73 %if %{with pear}
74 Requires:       php-pear-Benchmark
75 Requires:       php-pear-DB
76 Requires:       php-pear-Date
77 Requires:       php-pear-HTTP_Request
78 Requires:       php-pear-Mail
79 Requires:       php-pear-Math_Stats
80 Requires:       php-pear-Net_DIME
81 Requires:       php-pear-Net_POP3
82 Requires:       php-pear-Net_SMTP
83 Requires:       php-pear-Net_SmartIRC
84 Requires:       php-pear-Net_Socket
85 Requires:       php-pear-Net_URL
86 Requires:       php-pear-Net_UserAgent_Detect
87 Requires:       php-pear-PEAR
88 Requires:       php-pear-Text_Diff
89 Requires:       php-pear-XML_RPC
90 %endif
91 Requires:       apache >= 1.3.33-2
92 Requires:       apache(mod_dir)
93 Requires(triggerpostun):        sed >= 4.0
94 BuildArch:      noarch
95 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97 %define         _sysconfdir     /etc/%{name}
98 %define         _libdir         %{_prefix}/%{_lib}/%{name}
99 %define         _appdir %{_datadir}/%{name}
100 %define         _smartyplugindir        %{php_pear_dir}/Smarty/plugins
101
102 %define         _apache1dir     /etc/apache
103 %define         _apache2dir     /etc/httpd
104
105 %description
106 Eventum is a user-friendly and flexible issue tracking system that can
107 be used by a support department to track incoming technical support
108 requests, or by a software development team to quickly organize tasks
109 and bugs. Eventum is used by the MySQL AB Technical Support team, and
110 has allowed us to dramatically improve our response times.
111
112 %description -l pl
113 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
114 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
115 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
116 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
117 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
118 reakcji.
119
120 %package base
121 Summary:        Eventum base package
122 Summary(pl):    Podstawowy pakiet Eventum
123 Group:          Applications/WWW
124
125 %description base
126 This package contains base directory structure for Eventum.
127
128 %description base -l pl
129 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
130
131 %package setup
132 Summary:        Eventum setup package
133 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
134 Group:          Applications/WWW
135 PreReq:         %{name} = %{epoch}:%{version}-%{release}
136
137 %description setup
138 Install this package to configure initial Eventum installation. You
139 should uninstall this package when you're done, as it considered
140 insecure to keep the setup files in place.
141
142 %description setup -l pl
143 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
144 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
145 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
146
147 %package mail-queue
148 Summary:        Eventum mail queue process
149 Summary(pl):    Przetwarzanie kolejki poczty Eventum
150 Group:          Applications/WWW
151 Requires:       %{name} = %{epoch}:%{version}-%{release}
152 Requires:       crondaemon
153 Requires:       php >= 4.1.0
154
155 %description mail-queue
156 Beginning with the first release of Eventum, emails are not directly
157 sent out from the various scripts, but rather added to a mail queue
158 table that is processed by a cron job. If an email cannot be sent, it
159 will be marked as such in the mail queue log, and the cron job script
160 will re-try to send it again the next time it runs.
161
162 This package contains the cron job.
163
164 %description mail-queue -l pl
165 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
166 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
167 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
168 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
169 nastêpnym razem.
170
171 Ten pakiet zawiera zadanie dla crona.
172
173 %package mail-download
174 Summary:        Eventum email download
175 Summary(pl):    ¦ci±ganie poczty Eventum
176 Group:          Applications/WWW
177 Requires:       %{name} = %{epoch}:%{version}-%{release}
178 Requires:       crondaemon
179 Requires:       php >= 4.1.0
180
181 %description mail-download
182 In order for Eventum's email integration feature to work, you need to
183 setup a cron job to run the script every so often.
184
185 This package contains the cron job.
186
187 %description mail-download -l pl
188 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
189 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
190 czêsto.
191
192 Ten pakiet zawiera zadanie dla crona.
193
194 %package reminder
195 Summary:        Eventum Reminder System
196 Summary(pl):    System przypominania dla Eventum
197 Group:          Applications/WWW
198 Requires:       %{name} = %{epoch}:%{version}-%{release}
199 Requires:       php >= 4.1.0
200 Requires:       crondaemon
201
202 %description reminder
203 The reminder system was designed with the objective as serving as a
204 safe net for issues that need attention. Depending on what
205 configuration you create, you may have several reminders (or alerts)
206 be sent out whenever an issue needs attention, for whatever parameter
207 you may deem necessary.
208
209 This package contains the cron job.
210
211 %description reminder -l pl
212 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
213 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
214 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
215 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
216 uwa¿aæ za potrzebny.
217
218 Ten pakiet zawiera zadanie dla crona.
219
220 %package monitor
221 Summary:        Eventum Heartbeat Monitor
222 Summary(pl):    Monitor ¿ycia dla Eventum
223 Group:          Applications/WWW
224 Requires:       %{name} = %{epoch}:%{version}-%{release}
225 Requires:       php >= 4.1.0
226 Requires:       php-posix
227 Requires:       crondaemon
228
229 %description monitor
230 The heartbeat monitor is a feature designed for the administrator that
231 wants to be alerted whenever a common problem in Eventum is detected,
232 like the database server not being available anymore, or maybe when
233 the recommended permissions for certain configuration files are
234 changed.
235
236 Please note that before running the heartbeat monitor, you may need to
237 customize some of the checks to be appropriate for your own system,
238 particularly the permission and file checks on
239 Monitor::checkConfiguration().
240
241 This package contains the cron job.
242
243 %description monitor -l pl
244 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
245 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
246 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
247 do plików konfiguracyjnych.
248
249 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
250 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
251 testów uprawnieñ i plików w Monitor::checkConfiguration().
252
253 Ten pakiet zawiera zadanie dla crona.
254
255 %package route-emails
256 Summary:        Eventum Email Routing
257 Summary(pl):    Przekazywanie poczty dla Eventum
258 Group:          Applications/WWW
259 Requires:       %{name} = %{epoch}:%{version}-%{release}
260 Requires:       php >= 4.1.0
261 Requires:       eventum-router
262
263 %description route-emails
264 The email routing feature is used to automatically associate a thread
265 of emails into an Eventum issue. By setting up qmail (or even postfix)
266 to deliver emails sent to a specific address (usually
267 issue-<number>@<domain>) to the above script, users are able to use
268 their email clients to reply to emails coming from Eventum, and those
269 replies will be automatically associated with the issue and
270 broadcasted to the entire notification list.
271
272 %description route-emails -l pl
273 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
274 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
275 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
276 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
277 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
278 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
279 rozprowadzane do ca³ej listy og³oszeniowej.
280
281 %package route-notes
282 Summary:        Eventum Note Routing
283 Summary(pl):    Przekazywanie notatek dla Eventum
284 Group:          Applications/WWW
285 Requires:       %{name} = %{epoch}:%{version}-%{release}
286 Requires:       php >= 4.1.0
287 Requires:       eventum-router
288
289 %description route-notes
290 The note routing feature is used to automatically associate a thread
291 of notes into an Eventum issue. By setting up qmail (or even postfix)
292 to deliver emails sent to a specific address (usually
293 note-<number>@<domain>) to the above script, users are able to use
294 their email clients to reply to internal notes coming from Eventum,
295 and those replies will be automatically associated with the issue and
296 broadcasted to the notification list staff members.
297
298 %description route-notes -l pl
299 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
300 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
301 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
302 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
303 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
304 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
305 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
306
307 %package router-qmail
308 Summary:        Eventum Mail Routing - qmail
309 Summary(pl):    Przekazywanie poczty Eventum - qmail
310 Group:          Applications/Mail
311 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
312 Requires:       qmail >= 1.03
313 Provides:       eventum-router
314
315 %description router-qmail
316 This package provides way of routing notes and emails back to Eventum
317 via qmail.
318
319 %description router-qmail -l pl
320 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
321 przez qmaila.
322
323 %package router-postfix
324 Summary:        Eventum Mail Routing - Postfix
325 Summary(pl):    Przekazywanie poczty Eventum - Postfix
326 Group:          Applications/Mail
327 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
328 Requires:       postfix
329 Provides:       eventum-router
330
331 %description router-postfix
332 This package provides way of routing notes and emails back to Eventum
333 via Postfix.
334
335 %description router-postfix -l pl
336 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
337 przez Postfiksa.
338
339 %package irc
340 Summary:        Eventum IRC Notification Bot
341 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
342 Group:          Applications/WWW
343 Requires:       %{name} = %{epoch}:%{version}-%{release}
344 Requires:       php >= 4.1.0
345 Requires:       php-sockets
346 # FIXME just need start-stop-daemon
347 Requires:       dpkg
348
349 %description irc
350 The IRC notification bot is a nice feature for remote teams that want
351 to handle issues and want to have a quick and easy way to get simple
352 notifications. Right now the bot notifies of the following actions:
353 - New Issues
354 - Blocked emails
355 - Issues that got their assignment list changed
356
357 NOTE: You will need to manually edit the bot.php script to set your
358 appropriate preferences, like IRC server and channel that the bot
359 should join.
360
361 %description irc -l pl
362 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
363 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
364 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
365 nastêpuj±cych zdarzeniach:
366 - nowych sprawach
367 - zablokowanych listach
368 - sprawach, dla których zmieni³a siê lista powi±zañ
369
370 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
371 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
372
373 %package cli
374 Summary:        Eventum command-line interface
375 Summary(pl):    Interfejs linii poleceñ dla Eventum
376 Group:          Applications/WWW
377 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
378 Requires:       php >= 4.1.0
379 Requires:       php-cli
380 Requires:       php-curl
381 Requires:       php-xml
382 Requires:       php-pear-XML_RPC
383
384 %description cli
385 The Eventum command-line interface allows you to access most of the
386 features of the web interface straight from your command shell.
387
388 %description cli -l pl
389 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
390 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
391
392 %package scm
393 Summary:        Eventum SCM integration
394 Summary(pl):    Integracja SCM dla Eventum
395 Group:          Applications/WWW
396 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
397 Requires:       php >= 4.1.0
398
399 %description scm
400 This feature allows your software development teams to integrate your
401 Source Control Management system with your Issue Tracking System.
402
403 The integration is implemented in such a way that it will be forward
404 compatible with pretty much any SCM system, such as CVS.
405
406 For installation see
407 </eventum/help.php?topic=scm_integration_installation>.
408
409 %description scm -l pl
410 Ten pakiet pozwala zespo³om programistów na integracjê systemu
411 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
412 ¶ledzenia spraw.
413
414 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
415 prawie ka¿dym systemem SCM, jak np. CVS.
416
417 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
418 </eventum/help.php?topic=scm_integration_installation>.
419
420 %prep
421 %setup -q %{?_snap:-n %{name}-%{_snap}}
422 # undos the source
423 find . -type f -print0 | xargs -0 sed -i -e 's,
424 $,,'
425
426 # packaging
427 %patch0 -p1 -b .paths
428 %patch1 -p1
429 %patch2 -p1
430 %patch3 -p1
431 %{?with_pear:%patch4 -p1 -b .PEAR}
432
433 # bug fixes.
434 %patch11 -p1
435 #%patch12 -p1
436 #%patch13 -p1
437 #%patch14 -p1
438 #%patch15 -p1
439 #%patch16 -p1
440 #%patch17 -p1
441 #%patch18 -p1
442 %patch19 -p1
443 %patch20 -p1
444
445 # replace in remaining scripts config.inc.php to system one
446 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
447         s,include_once(".*config.inc.php"),include_once("%{_sysconfdir}/core.php"),
448 '
449 sed -i -e '
450         s,include(".*config.inc.php"),include_once("%{_sysconfdir}/core.php"),
451 ' misc/download_emails.php
452
453 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
454         s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_sysconfdir}/private_key.php"),
455 '
456
457 rm -f */*~ */*/*~
458
459 %install
460 rm -rf $RPM_BUILD_ROOT
461 install -d \
462         $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_libdir}} \
463         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
464         $RPM_BUILD_ROOT/var/{run,log,cache,lib}/%{name} \
465         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc} \
466
467 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
468 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
469 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
470 cp -a misc/irc $RPM_BUILD_ROOT%{_appdir}
471 cp -a templates $RPM_BUILD_ROOT%{_appdir}
472 cp -a include/{customer,jpgraph,pear,workflow} $RPM_BUILD_ROOT%{_appdir}/include
473 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
474 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
475
476 # cli
477 install -d $RPM_BUILD_ROOT%{_appdir}/cli
478 install misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
479 install misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
480 sed -e 's,/usr/local/bin/php,/usr/bin/php4,' misc/cli/eventum \
481         > $RPM_BUILD_ROOT%{_bindir}/%{name}
482 cp -f misc/cli/eventumrc_example eventumrc
483
484 # scm
485 echo '#!/usr/bin/php4 -q' > %{name}-scm
486 cat misc/scm/process_cvs_commits.php >> %{name}-scm
487 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
488
489 # private key
490 mv $RPM_BUILD_ROOT{%{_appdir}/include/private_key.php,%{_sysconfdir}}
491 # change private key, so we can easily grep
492 sed -i -e '
493 s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
494 ' $RPM_BUILD_ROOT%{_sysconfdir}/private_key.php
495
496 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
497 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
498 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
499 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
500 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
501 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
502 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
503 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
504 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
505 sed -e 's,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}},' \
506         %{SOURCE10} > $RPM_BUILD_ROOT%{_sysconfdir}/core.php
507
508 # config
509 > $RPM_BUILD_ROOT%{_sysconfdir}/setup.php
510 mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_sysconfdir}/config}.php
511
512 # sample, not used in eventum
513 rm -f $RPM_BUILD_ROOT%{_appdir}/htdocs/rpc/xmlrpc_client.php
514
515 %if %{with pear}
516 # provided by PEAR
517 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
518 %endif
519
520 # use system Smarty
521 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
522 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
523 # These plugins are not in Smarty package (Smarty-2.6.2-3)
524 cp -a include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
525         $RPM_BUILD_ROOT%{_smartyplugindir}
526
527 # qmail router
528 d=$RPM_BUILD_ROOT/var/lib/%{name}
529 echo 'root' > $d/.qmail
530 echo 'root' > $d/.qmail-default
531 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
532 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
533 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
534 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
535
536 %clean
537 rm -rf $RPM_BUILD_ROOT
538
539 %pre
540 %addusertogroup http %{name}
541
542 %post
543 # apache1
544 if [ -d %{_apache1dir}/conf.d ]; then
545         ln -sf %{_sysconfdir}/apache.conf %{_apache1dir}/conf.d/99_%{name}.conf
546         if [ -f /var/lock/subsys/apache ]; then
547                 /etc/rc.d/init.d/apache restart 1>&2
548         fi
549 fi
550 # apache2
551 if [ -d %{_apache2dir}/httpd.conf ]; then
552         ln -sf %{_sysconfdir}/apache.conf %{_apache2dir}/httpd.conf/99_%{name}.conf
553         if [ -f /var/lock/subsys/httpd ]; then
554                 /etc/rc.d/init.d/httpd restart 1>&2
555         fi
556 fi
557
558 # check if the package is configured.
559 if grep -q 'header("Location: setup/")' %{_sysconfdir}/config.php; then
560 %banner %{name} -e <<EOF
561
562 You haven't yet configured Eventum!
563
564 Install %{name}-setup and open up http://yourserver/eventum/
565 -- that will help you setup initial config.
566
567 when have configured Eventum, please uninstall the setup package,
568 so that %{name}-setup is able to secure your Eventum installation.
569
570 EOF
571 #' vim stupidity.
572
573 elif grep -q 'DEFAULTPRIVATEKEY' %{_sysconfdir}/private_key.php; then
574 %banner %{name} -e <<EOF
575
576 You have default private key installed!
577
578 Install %{name}-setup and open up http://yourserver/eventum/setup/
579 -- that will help you setup initial config.
580
581 when have configured Eventum, please uninstall the setup package,
582 so that %{name}-setup is able to secure your Eventum installation.
583
584 EOF
585         elif [ -d %{_appdir}/setup ]; then
586 %banner %{name} -e <<EOF
587
588 If you have have configured Eventum, please uninstall the setup package,
589 so that %{name}-setup is able to secure your Eventum installation.
590
591 EOF
592 fi
593
594 %preun
595 if [ "$1" = "0" ]; then
596         # apache1
597         if [ -f %{_apache1dir}/apache.conf ]; then
598                 rm -f %{_apache1dir}/conf.d/99_%{name}.conf
599                 if [ -f /var/lock/subsys/apache ]; then
600                         /etc/rc.d/init.d/apache restart 1>&2
601                 fi
602         fi
603         # apache2
604         if [ -d %{_apache2dir}/httpd.conf ]; then
605                 rm -f %{_apache2dir}/httpd.conf/99_%{name}.conf
606                 if [ -f /var/lock/subsys/httpd ]; then
607                         /etc/rc.d/init.d/httpd restart 1>&2
608                 fi
609         fi
610 fi
611
612 %postun
613 # nuke cache
614 rm -f /var/cache/eventum/*.php
615
616 %pre base
617 %groupadd -P %{name}-base %{name}
618 %useradd -P %{name}-base -d /var/lib/%{name} -g %{name} %{name} -c "Eventum User"
619
620 %postun base
621 if [ "$1" = "0" ]; then
622         %groupremove %{name}
623         %userremove %{name}
624 fi
625
626 %post router-qmail
627 CF=/etc/qmail/control/virtualdomains
628 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
629         FQDN=$(hostname -f 2>/dev/null || echo localhost)
630         umask 022
631         echo "#${FQDN}:%{name}" >> $CF
632
633 %banner %{name}-qmail -e <<EOF
634
635 Added "#${FQDN}:%{name}" to $CF,
636 Please verify that it is correct and restart qmail:
637 # service qmail reload
638
639 Consult qmail-send(8) for more details on virtualdomains.
640
641 EOF
642 fi
643
644 %preun router-qmail
645 if [ "$1" = "0" ]; then
646         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
647 fi
648
649 %post setup
650 chmod 660 %{_sysconfdir}/{config,private_key}.php
651 chown root:eventum %{_sysconfdir}/{config,private_key}.php
652
653 %postun setup
654 if [ "$1" = "0" ]; then
655         chmod 640 %{_sysconfdir}/{config,private_key}.php
656         chown root:eventum %{_sysconfdir}/{config,private_key}.php
657 fi
658
659 %triggerpostun -- eventum < 1.4-2.160
660 cp -f %{_sysconfdir}/config.php{,.rpmsave}
661 # very loose trigger
662 sed -i -e '
663 /config.php/,/SQL variables/d;/_LOG/d;/APP_VERSION/d;/APP_BENCHMARK/,/content-type:/d
664 ' %{_sysconfdir}/config.php
665
666 %triggerpostun -- eventum < 1.4-2.174
667 cp -f %{_sysconfdir}/apache.conf{,.rpmsave}
668 # loosely fix htdocs directory
669 sed -i -e '
670 s,%{_appdir},%{_appdir}/htdocs,
671 ' %{_sysconfdir}/apache.conf
672
673 %triggerpostun mail-download -- eventum-mail-download < 1.4-2.20050222.2.200
674 sed -i -e 's,%{_appdir}/misc,%{_appdir},' /etc/cron.d/eventum-mail-download
675 touch /etc/cron.d/eventum-mail-download
676
677 %triggerpostun mail-queue -- eventum-mail-queue < 1.4-2.20050222.2.200
678 sed -i -e 's,%{_appdir}/misc,%{_appdir},' /etc/cron.d/eventum-mail-queue
679 touch /etc/cron.d/eventum-mail-queue
680
681 %triggerpostun monitor -- eventum-monitor < 1.4-2.20050222.2.200
682 sed -i -e 's,%{_appdir}/misc,%{_appdir},' /etc/cron.d/eventum-monitor
683 touch /etc/cron.d/eventum-monitor
684
685 %triggerpostun reminder -- eventum-reminder < 1.4-2.20050222.2.200
686 sed -i -e 's,%{_appdir}/misc,%{_appdir},' /etc/cron.d/eventum-reminder
687 touch /etc/cron.d/eventum-reminder
688
689 %triggerpostun -- eventum < 1.4-2.20050222.2.208
690 chgrp eventum %{_sysconfdir}/{core,config,private_key,setup}.php
691
692 %triggerpostun irc -- eventum-irc < 1.4-2.20050222.2.208
693 chgrp eventum %{_sysconfdir}/irc.php
694
695 %triggerpostun base -- eventum-base < 1.4-2.20050222.212
696 if [ "`getent passwd %{name} | cut -d: -f6`" = "%{_appdir}" ]; then
697         /usr/sbin/usermod -d /var/lib/%{name} %{name}
698 fi
699
700 %files
701 %defattr(644,root,root,755)
702 %doc ChangeLog FAQ INSTALL README UPGRADE
703 %doc misc/upgrade docs/* rpc/xmlrpc_client.php setup/schema.sql
704 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
705 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
706 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/private_key.php
707 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/setup.php
708 %attr(640,root,eventum) %config %verify(not mtime) %{_sysconfdir}/core.php
709
710 %dir %attr(731,root,eventum) /var/log/%{name}
711 %attr(620,root,eventum) %ghost /var/log/%{name}/*
712
713 %dir %{_appdir}/htdocs
714 %{_appdir}/htdocs/*.php
715 %{_appdir}/htdocs/css
716 %{_appdir}/htdocs/customer
717 %{_appdir}/htdocs/images
718 %{_appdir}/htdocs/js
719 %{_appdir}/htdocs/manage
720 %{_appdir}/htdocs/reports
721 %{_appdir}/htdocs/rpc
722 %{_appdir}/htdocs/misc
723
724 %{_appdir}/templates
725
726 %{_smartyplugindir}/*
727 %if %{without pear}
728 %{_appdir}/include/pear
729 %endif
730
731 %dir %{_appdir}/include
732 %{_appdir}/include/customer
733 %{_appdir}/include/jpgraph
734 %{_appdir}/include/workflow
735 %{_appdir}/include/class.[^m]*.php
736 %{_appdir}/include/class.mail.php
737 %{_appdir}/include/class.mail_queue.php
738 %{_appdir}/include/class.mime_helper.php
739 %{_appdir}/include/class.misc.php
740 %{_appdir}/include/db_access.php
741 %{_appdir}/include/jsrsServer.inc.php
742
743 %dir %attr(730,root,eventum) /var/run/%{name}
744 %dir %attr(730,root,eventum) /var/cache/%{name}
745
746 %files base
747 %defattr(644,root,root,755)
748 %attr(751,root,root) %dir %{_sysconfdir}
749 %dir %{_libdir}
750 %dir %{_appdir}
751 %attr(750,root,eventum) %dir /var/lib/%{name}
752
753 %files setup
754 %defattr(644,root,root,755)
755 %{_appdir}/htdocs/setup
756
757 %files mail-queue
758 %defattr(644,root,root,755)
759 %{_appdir}/process_mail_queue.php
760 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
761
762 %files mail-download
763 %defattr(644,root,root,755)
764 %{_appdir}/download_emails.php
765 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
766
767 %files reminder
768 %defattr(644,root,root,755)
769 %{_appdir}/check_reminders.php
770 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
771
772 %files monitor
773 %defattr(644,root,root,755)
774 %{_appdir}/include/class.monitor.php
775 %{_appdir}/monitor.php
776 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
777
778 %files route-emails
779 %defattr(644,root,root,755)
780 %{_appdir}/route_emails.php
781
782 %files route-notes
783 %defattr(644,root,root,755)
784 %{_appdir}/route_drafts.php
785 %{_appdir}/route_notes.php
786
787 %files router-qmail
788 %defattr(644,root,root,755)
789 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
790 %attr(755,root,root) %{_libdir}/router-qmail
791
792 %files router-postfix
793 %defattr(644,root,root,755)
794
795 %files irc
796 %defattr(644,root,root,755)
797 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
798 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
799 %{_appdir}/irc
800 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
801
802 %files cli
803 %defattr(644,root,root,755)
804 %doc eventumrc
805 %attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
806 %attr(755,root,root) %{_bindir}/%{name}
807 %{_appdir}/cli
808
809 %files scm
810 %defattr(644,root,root,755)
811 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
812 %attr(755,root,root) %{_libdir}/scm
This page took 0.11826 seconds and 4 git commands to generate.