]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- use system Smarty (bundled one is identical version)
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - system pear is incompatible, at least pear DB class seems broke Eventum
3 # - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
4 # - discard bundled packages (from INSTALL):
5 #  - JpGraph 1.5.3 (last GPL version)
6 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
7 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
8 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
9 #  - A few other small javascript libraries
10 # - create eventum-router-qmail, eventum-router-postfix for -route-mails and -route-notes
11 # - need start-stop-daemon (from dpkg for now)
12 # - use eventum user for irc bot?
13
14 %bcond_with     pear    # build with system PEAR packages (or use bundled ones)
15
16 # snapshot: DATE
17 #define _snap 20050217
18
19 %if 0%{?_snap}
20 %define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
21 %else
22 %define _source http://mysql.wildyou.net/Downloads/%{name}/%{name}-%{version}.tar.gz
23 %endif
24
25 %define _rel 2.161
26
27 Summary:        Eventum Issue - a bug tracking system
28 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
29 Name:           eventum
30 Version:        1.4
31 Release:        %{?_snap:0.%{_snap}.}%{_rel}
32 License:        GPL
33 Group:          Applications/WWW
34 Source0:        %{_source}
35 # Source0-md5:  361c1355e46a6bbfa54e420964ec92cf
36 Source1:        %{name}-apache.conf
37 Source2:        %{name}-mail-queue.cron
38 Source3:        %{name}-mail-download.cron
39 Source4:        %{name}-reminder.cron
40 Source5:        %{name}-monitor.cron
41 Source6:        %{name}-cvs.php
42 Source7:        %{name}-irc.php
43 Source8:        %{name}-irc.init
44 Source9:        %{name}-irc.sysconfig
45 Source10:       %{name}-config.php
46 Patch0:         %{name}-paths.patch
47 Patch1:         %{name}-scm-encode.patch
48 Patch2:         %{name}-cvs-config.patch
49 Patch3:         %{name}-irc-config.patch
50 Patch4:         %{name}-PEAR.patch
51 Patch11:                %{name}-scm_checkin_associated.patch
52 Patch12:                %{name}-mail-queue.tpl.patch
53 Patch13:                %{name}-maildecode.patch
54 Patch14:                %{name}-send-typo.patch
55 Patch15:                %{name}-fixes.patch
56 Patch16:                %{name}-rss-charset.patch
57 Patch17:                %{name}-scm-silence-add.patch
58 Patch18:                %{name}-default-TZ.patch
59 Patch19:                %{name}-charset-mailsubj.patch
60 URL:            http://dev.mysql.com/downloads/other/eventum/index.html
61 BuildRequires:  rpmbuild(macros) >= 1.177
62 BuildRequires:  sed >= 4.0
63 # is_a(), which wrapper we removed from config, is from 4.2.0
64 Requires:       php >= 4.2.0
65 Requires:       php-gd
66 Requires:       php-imap
67 Requires:       php-mysql
68 Requires:       php-pcre
69 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
70 Requires:       Smarty >= 2.6.2
71 %if %{with pear}
72 Requires:       php-pear-Benchmark
73 Requires:       php-pear-DB
74 Requires:       php-pear-Date
75 Requires:       php-pear-HTTP_Request
76 Requires:       php-pear-Mail
77 Requires:       php-pear-Math_Stats
78 Requires:       php-pear-Net_DIME
79 Requires:       php-pear-Net_POP3
80 Requires:       php-pear-Net_SMTP
81 Requires:       php-pear-Net_SmartIRC
82 Requires:       php-pear-Net_Socket
83 Requires:       php-pear-Net_URL
84 Requires:       php-pear-Net_UserAgent_Detect
85 Requires:       php-pear-PEAR
86 Requires:       php-pear-Text_Diff
87 Requires:       php-pear-XML_RPC
88 %endif
89 Requires:       apache >= 1.3.33-2
90 Requires:       apache(mod_dir)
91 BuildArch:      noarch
92 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93
94 %define         _sysconfdir     /etc/%{name}
95 %define         _libdir         %{_prefix}/%{_lib}/%{name}
96 %define         _appdir %{_datadir}/%{name}
97 %define         _smartyplugindir        %{php_pear_dir}/Smarty/plugins
98
99 %define         _apache1dir     /etc/apache
100 %define         _apache2dir     /etc/httpd
101
102 %description
103 Eventum is a user-friendly and flexible issue tracking system that can
104 be used by a support department to track incoming technical support
105 requests, or by a software development team to quickly organize tasks
106 and bugs. Eventum is used by the MySQL AB Technical Support team, and
107 has allowed us to dramatically improve our response times.
108
109 %description -l pl
110 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
111 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
112 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
113 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
114 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
115 reakcji.
116
117 %package base
118 Summary:        Eventum base package
119 Summary(pl):    Podstawowy pakiet Eventum
120 Group:          Applications/WWW
121
122 %description base
123 This package contains base directory structure for Eventum.
124
125 %description base -l pl
126 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
127
128 %package setup
129 Summary:        Eventum setup package
130 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
131 Group:          Applications/WWW
132 PreReq:         %{name} = %{epoch}:%{version}-%{release}
133
134 %description setup
135 Install this package to configure initial Eventum installation. You
136 should uninstall this package when you're done, as it considered
137 insecure to keep the setup files in place.
138
139 %description setup -l pl
140 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
141 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
142 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
143
144 %package mail-queue
145 Summary:        Eventum mail queue process
146 Summary(pl):    Przetwarzanie kolejki poczty Eventum
147 Group:          Applications/WWW
148 Requires:       %{name} = %{epoch}:%{version}-%{release}
149 Requires:       crondaemon
150 Requires:       php >= 4.1.0
151
152 %description mail-queue
153 Beginning with the first release of Eventum, emails are not directly
154 sent out from the various scripts, but rather added to a mail queue
155 table that is processed by a cron job. If an email cannot be sent, it
156 will be marked as such in the mail queue log, and the cron job script
157 will re-try to send it again the next time it runs.
158
159 This package contains the cron job.
160
161 %description mail-queue -l pl
162 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
163 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
164 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
165 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
166 nastêpnym razem.
167
168 Ten pakiet zawiera zadanie dla crona.
169
170 %package mail-download
171 Summary:        Eventum email download
172 Summary(pl):    ¦ci±ganie poczty Eventum
173 Group:          Applications/WWW
174 Requires:       %{name} = %{epoch}:%{version}-%{release}
175 Requires:       crondaemon
176 Requires:       php >= 4.1.0
177
178 %description mail-download
179 In order for Eventum's email integration feature to work, you need to
180 setup a cron job to run the script every so often.
181
182 This package contains the cron job.
183
184 %description mail-download -l pl
185 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
186 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
187 czêsto.
188
189 Ten pakiet zawiera zadanie dla crona.
190
191 %package reminder
192 Summary:        Eventum Reminder System
193 Summary(pl):    System przypominania dla Eventum
194 Group:          Applications/WWW
195 Requires:       %{name} = %{epoch}:%{version}-%{release}
196 Requires:       php >= 4.1.0
197 Requires:       crondaemon
198
199 %description reminder
200 The reminder system was designed with the objective as serving as a
201 safe net for issues that need attention. Depending on what
202 configuration you create, you may have several reminders (or alerts)
203 be sent out whenever an issue needs attention, for whatever parameter
204 you may deem necessary.
205
206 This package contains the cron job.
207
208 %description reminder -l pl
209 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
210 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
211 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
212 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
213 uwa¿aæ za potrzebny.
214
215 Ten pakiet zawiera zadanie dla crona.
216
217 %package monitor
218 Summary:        Eventum Heartbeat Monitor
219 Summary(pl):    Monitor ¿ycia dla Eventum
220 Group:          Applications/WWW
221 Requires:       %{name} = %{epoch}:%{version}-%{release}
222 Requires:       php >= 4.1.0
223 Requires:       crondaemon
224
225 %description monitor
226 The heartbeat monitor is a feature designed for the administrator that
227 wants to be alerted whenever a common problem in Eventum is detected,
228 like the database server not being available anymore, or maybe when
229 the recommended permissions for certain configuration files are
230 changed.
231
232 Please note that before running the heartbeat monitor, you may need to
233 customize some of the checks to be appropriate for your own system,
234 particularly the permission and file checks on
235 Monitor::checkConfiguration().
236
237 This package contains the cron job.
238
239 %description monitor -l pl
240 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
241 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
242 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
243 do plików konfiguracyjnych.
244
245 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
246 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
247 testów uprawnieñ i plików w Monitor::checkConfiguration().
248
249 Ten pakiet zawiera zadanie dla crona.
250
251 %package route-emails
252 Summary:        Eventum Email Routing
253 Summary(pl):    Przekazywanie poczty dla Eventum
254 Group:          Applications/WWW
255 Requires:       %{name} = %{epoch}:%{version}-%{release}
256 Requires:       php >= 4.1.0
257 #Requires:      eventum-router
258
259 %description route-emails
260 The email routing feature is used to automatically associate a thread
261 of emails into an Eventum issue. By setting up qmail (or even postfix)
262 to deliver emails sent to a specific address (usually
263 issue-<number>@<domain>) to the above script, users are able to use
264 their email clients to reply to emails coming from Eventum, and those
265 replies will be automatically associated with the issue and
266 broadcasted to the entire notification list.
267
268 %description route-emails -l pl
269 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
270 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
271 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
272 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
273 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
274 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
275 rozprowadzane do ca³ej listy og³oszeniowej.
276
277 %package route-notes
278 Summary:        Eventum Note Routing
279 Summary(pl):    Przekazywanie notatek dla Eventum
280 Group:          Applications/WWW
281 Requires:       %{name} = %{epoch}:%{version}-%{release}
282 Requires:       php >= 4.1.0
283 #Requires:      eventum-router
284
285 %description route-notes
286 The note routing feature is used to automatically associate a thread
287 of notes into an Eventum issue. By setting up qmail (or even postfix)
288 to deliver emails sent to a specific address (usually
289 note-<number>@<domain>) to the above script, users are able to use
290 their email clients to reply to internal notes coming from Eventum,
291 and those replies will be automatically associated with the issue and
292 broadcasted to the notification list staff members.
293
294 %description route-notes -l pl
295 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
296 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
297 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
298 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
299 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
300 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
301 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
302
303 %package irc
304 Summary:        Eventum IRC Notification Bot
305 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
306 Group:          Applications/WWW
307 Requires:       %{name} = %{epoch}:%{version}-%{release}
308 Requires:       php >= 4.1.0
309 Requires:       php-sockets
310 # FIXME just need start-stop-daemon
311 Requires:       dpkg
312
313 %description irc
314 The IRC notification bot is a nice feature for remote teams that want
315 to handle issues and want to have a quick and easy way to get simple
316 notifications. Right now the bot notifies of the following actions:
317 - New Issues
318 - Blocked emails
319 - Issues that got their assignment list changed
320
321 NOTE: You will need to manually edit the bot.php script to set your
322 appropriate preferences, like IRC server and channel that the bot
323 should join.
324
325 %description irc -l pl
326 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
327 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
328 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
329 nastêpuj±cych zdarzeniach:
330 - nowych sprawach
331 - zablokowanych listach
332 - sprawach, dla których zmieni³a siê lista powi±zañ
333
334 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
335 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
336
337 %package cli
338 Summary:        Eventum command-line interface
339 Summary(pl):    Interfejs linii poleceñ dla Eventum
340 Group:          Applications/WWW
341 Requires:       %{name} = %{epoch}:%{version}-%{release}
342 Requires:       php >= 4.1.0
343 Requires:       php-cli
344 Requires:       php-curl
345 Requires:       php-xml
346 Requires:       php-pear-XML_RPC
347
348 %description cli
349 The Eventum command-line interface allows you to access most of the
350 features of the web interface straight from your command shell.
351
352 %description cli -l pl
353 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
354 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
355
356 %package scm
357 Summary:        Eventum SCM integration
358 Summary(pl):    Integracja SCM dla Eventum
359 Group:          Applications/WWW
360 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
361 Requires:       php >= 4.1.0
362
363 %description scm
364 This feature allows your software development teams to integrate your
365 Source Control Management system with your Issue Tracking System.
366
367 The integration is implemented in such a way that it will be forward
368 compatible with pretty much any SCM system, such as CVS.
369
370 For installation see
371 </eventum/help.php?topic=scm_integration_installation>.
372
373 %description scm -l pl
374 Ten pakiet pozwala zespo³om programistów na integracjê systemu
375 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
376 ¶ledzenia spraw.
377
378 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
379 prawie ka¿dym systemem SCM, jak np. CVS.
380
381 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
382 </eventum/help.php?topic=scm_integration_installation>.
383
384 %prep
385 %setup -q %{?_snap:-n %{name}-%{_snap}}
386 # undos the source
387 find . -type f -print0 | xargs -0 sed -i -e 's,
388 $,,'
389
390 # packaging
391 %patch0 -p1 -b .paths
392 %patch1 -p1
393 %patch2 -p1
394 %patch3 -p1
395 %{?with_pear:%patch4 -p1 -b .PEAR}
396
397 # bug fixes.
398 %patch11 -p1
399 %patch12 -p1
400 %patch13 -p1
401 %patch14 -p1
402 %patch15 -p1
403 %patch16 -p1
404 %patch17 -p1
405 %patch18 -p1
406 %patch19 -p1
407
408 rm -f */*~ */*/*~
409
410 %install
411 rm -rf $RPM_BUILD_ROOT
412 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_libdir},%{_appdir}} \
413         $RPM_BUILD_ROOT{/etc/{rc.d/init.d,cron.d},/var/log/%{name}} \
414         $RPM_BUILD_ROOT{/var/run/eventum,/var/cache/eventum,/etc/sysconfig}
415
416 cp -a *.php {css,customer,images,include,js} \
417         {manage,misc,reports,rpc,setup,templates} $RPM_BUILD_ROOT%{_appdir}
418 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
419
420 > $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
421
422 sed -i -e 's,/usr/local/bin/php,/usr/bin/php4,' $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum
423 echo '#!/usr/bin/php4 -q' > %{name}-scm
424 cat $RPM_BUILD_ROOT%{_appdir}/misc/scm/process_cvs_commits.php >> %{name}-scm
425
426 # change private key, so we can easily grep
427 sed -i -e '
428 s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
429 ' $RPM_BUILD_ROOT%{_appdir}/include/private_key.php
430
431 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
432 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
433 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
434 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
435 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
436 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
437 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
438 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
439 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
440 sed -e 's,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}},' %{SOURCE10} > $RPM_BUILD_ROOT%{_sysconfdir}/core.php
441
442 # in conf
443 mv $RPM_BUILD_ROOT%{_appdir}/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/config.php
444 mv $RPM_BUILD_ROOT%{_appdir}/setup.conf.php $RPM_BUILD_ROOT%{_sysconfdir}/setup.php
445 mv $RPM_BUILD_ROOT%{_appdir}/include/private_key.php $RPM_BUILD_ROOT%{_sysconfdir}
446 mv $RPM_BUILD_ROOT%{_appdir}/misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
447 ln -s %{_sysconfdir}/core.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
448 ln -s %{_sysconfdir}/setup.php $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
449 ln -s %{_sysconfdir}/private_key.php $RPM_BUILD_ROOT%{_appdir}/include/private_key.php
450
451 # in doc
452 rm -rf $RPM_BUILD_ROOT%{_appdir}/misc/upgrade
453 # sample, not used in eventum
454 rm -rf $RPM_BUILD_ROOT%{_appdir}/rpc/xmlrpc_client.php
455
456 # in bindir
457 mv $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum $RPM_BUILD_ROOT%{_bindir}
458 rm -f $RPM_BUILD_ROOT%{_appdir}/misc/{cli/eventumrc_example,scm/process_cvs_commits.php}
459 cp -f misc/cli/eventumrc_example eventumrc
460 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
461
462 %if %{with pear}
463 # provided by PEAR
464 rm -rf $RPM_BUILD_ROOT%{_appdir}/misc/cli/include/pear
465 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
466 %endif
467
468 # use system Smarty
469 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
470 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
471 # These plugins are not in Smarty package (Smarty-2.6.2-3)
472 cp -a include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
473         $RPM_BUILD_ROOT%{_smartyplugindir}
474
475 %clean
476 rm -rf $RPM_BUILD_ROOT
477
478 %post
479 # apache1
480 if [ -d %{_apache1dir}/conf.d ]; then
481         ln -sf %{_sysconfdir}/apache.conf %{_apache1dir}/conf.d/99_%{name}.conf
482         if [ -f /var/lock/subsys/apache ]; then
483                 /etc/rc.d/init.d/apache restart 1>&2
484         fi
485 fi
486 # apache2
487 if [ -d %{_apache2dir}/httpd.conf ]; then
488         ln -sf %{_sysconfdir}/apache.conf %{_apache2dir}/httpd.conf/99_%{name}.conf
489         if [ -f /var/lock/subsys/httpd ]; then
490                 /etc/rc.d/init.d/httpd restart 1>&2
491         fi
492 fi
493
494 # check if the package is configured.
495 if grep -q 'header("Location: setup/")' %{_sysconfdir}/config.php; then
496 %banner %{name} -e <<EOF
497
498 You haven't yet configured Eventum!
499
500 Install %{name}-setup and open up http://yourserver/eventum/
501 -- that will help you setup initial config.
502
503 when have configured Eventum, please uninstall the setup package,
504 so that %{name}-setup is able to secure your Eventum installation.
505
506 EOF
507 #' vim stupidity.
508
509 elif grep -q 'DEFAULTPRIVATEKEY' %{_sysconfdir}/private_key.php; then
510 %banner %{name} -e <<EOF
511
512 You have default private key installed!
513
514 Install %{name}-setup and open up http://yourserver/eventum/setup/
515 -- that will help you setup initial config.
516
517 when have configured Eventum, please uninstall the setup package,
518 so that %{name}-setup is able to secure your Eventum installation.
519
520 EOF
521         elif [ -d %{_appdir}/setup ]; then
522 %banner %{name} -e <<EOF
523
524 If you have have configured Eventum, please uninstall the setup package,
525 so that %{name}-setup is able to secure your Eventum installation.
526
527 EOF
528 fi
529
530
531 %preun
532 if [ "$1" = "0" ]; then
533         # apache1
534         if [ -f %{_apache1dir}/apache.conf ]; then
535                 rm -f %{_apache1dir}/conf.d/99_%{name}.conf
536                 if [ -f /var/lock/subsys/apache ]; then
537                         /etc/rc.d/init.d/apache restart 1>&2
538                 fi
539         fi
540         # apache2
541         if [ -d %{_apache2dir}/httpd.conf ]; then
542                 rm -f %{_apache2dir}/httpd.conf/99_%{name}.conf
543                 if [ -f /var/lock/subsys/httpd ]; then
544                         /etc/rc.d/init.d/httpd restart 1>&2
545                 fi
546         fi
547 fi
548
549 %post setup
550 chmod 660 %{_sysconfdir}/{config,private_key}.php
551 chown root:http %{_sysconfdir}/{config,private_key}.php
552
553 %postun setup
554 if [ "$1" = "0" ]; then
555         chmod 640 %{_sysconfdir}/{config,private_key}.php
556         chown root:http %{_sysconfdir}/{config,private_key}.php
557 fi
558
559 %triggerpostun -- eventum < 2.160
560 cp -f %{_sysconfdir}/config.php{,.rpmsave}
561 # very loose trigger
562 sed -i -e '
563 /config.php/,/SQL variables/d;/_LOG/d;/APP_VERSION/d;/APP_BENCHMARK/,/content-type:/d' %{_sysconfdir}/config.php
564
565 %files
566 %defattr(644,root,root,755)
567 %doc ChangeLog FAQ INSTALL README UPGRADE
568 %doc misc/upgrade docs/* rpc/xmlrpc_client.php setup/schema.sql 
569 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
570 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
571 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/private_key.php
572 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/setup.php
573 %attr(660,root,http) %verify(not md5 mtime size) %{_sysconfdir}/core.php
574
575 %dir %{_appdir}
576 %dir %{_appdir}/misc
577
578 %dir %attr(731,root,http) /var/log/%{name}
579 %attr(620,root,http) %ghost /var/log/%{name}/*
580
581 %{_appdir}/*.php
582 %{_appdir}/css
583 %{_appdir}/customer
584 %{_appdir}/images
585 %{_appdir}/js
586 %{_appdir}/manage
587 %{_appdir}/reports
588 %{_appdir}/rpc
589 %{_appdir}/templates
590
591 %{_smartyplugindir}/*
592 %if %{without pear}
593 %{_appdir}/include/pear
594 %endif
595
596 %dir %{_appdir}/include
597 %{_appdir}/include/customer
598 %{_appdir}/include/jpgraph
599 %{_appdir}/include/workflow
600 %{_appdir}/include/*.php
601
602 %dir %attr(730,root,http) /var/run/%{name}
603 %dir %attr(730,root,http) /var/cache/%{name}
604
605 %{_appdir}/misc/blank.html
606
607 %files base
608 %defattr(644,root,root,755)
609 %attr(751,root,root) %dir %{_sysconfdir}
610 %dir %{_libdir}
611
612 %files setup
613 %defattr(644,root,root,755)
614 %{_appdir}/setup
615
616 %files mail-queue
617 %defattr(644,root,root,755)
618 %{_appdir}/misc/process_mail_queue.php
619 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
620
621 %files mail-download
622 %defattr(644,root,root,755)
623 %{_appdir}/misc/download_emails.php
624 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
625
626 %files reminder
627 %defattr(644,root,root,755)
628 %{_appdir}/misc/check_reminders.php
629 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
630
631 %files monitor
632 %defattr(644,root,root,755)
633 %{_appdir}/misc/monitor.php
634 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
635
636 %files route-emails
637 %defattr(644,root,root,755)
638 %{_appdir}/misc/route_emails.php
639
640 %files route-notes
641 %defattr(644,root,root,755)
642 %{_appdir}/misc/route_drafts.php
643 %{_appdir}/misc/route_notes.php
644
645 %files irc
646 %defattr(644,root,root,755)
647 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
648 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
649 %{_appdir}/misc/irc
650 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
651
652 %files cli
653 %defattr(644,root,root,755)
654 %doc eventumrc
655 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cli.php
656 %attr(755,root,root) %{_bindir}/%{name}
657 %dir %{_appdir}/misc/cli
658 %{_appdir}/misc/cli/include
659
660 %files scm
661 %defattr(644,root,root,755)
662 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
663 %attr(755,root,root) %{_libdir}/scm
This page took 0.148806 seconds and 4 git commands to generate.