]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- mail header encoding related fixes
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - system pear is incompatible, at least pear DB class seems broke Eventum
3 # - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
4 # - discard bundled packages (from INSTALL):
5 #  - JpGraph 1.5.3 (last GPL version)
6 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
7 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
8 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
9 #  - A few other small javascript libraries
10 # - create eventum-router-qmail, eventum-router-postfix for -route-mails and -route-notes
11 # - need start-stop-daemon (from dpkg for now)
12 # - use eventum user for irc bot?
13
14 %bcond_with     pear    # build with system PEAR packages (or use bundled ones)
15
16 # snapshot: DATE
17 #define _snap 20050124
18
19 %if 0%{?_snap}
20 %define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
21 %else
22 %define _source http://mysql.wildyou.net/Downloads/%{name}/%{name}-%{version}.tar.gz
23 %endif
24
25 %define _rel 1.138
26
27 Summary:        Eventum Issue - a bug tracking system
28 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
29 Name:           eventum
30 Version:        1.4
31 Release:        %{?_snap:0.%{_snap}.}%{_rel}
32 License:        GPL
33 Group:          Applications/WWW
34 Source0:        %{_source}
35 # Source0-md5:  361c1355e46a6bbfa54e420964ec92cf
36 Source1:        %{name}-apache.conf
37 Source2:        %{name}-mail-queue.cron
38 Source3:        %{name}-mail-download.cron
39 Source4:        %{name}-reminder.cron
40 Source5:        %{name}-monitor.cron
41 Source6:        %{name}-cvs.php
42 Source7:        %{name}-irc.php
43 Source8:        %{name}-irc.init
44 Patch0:         %{name}-paths.patch
45 Patch1:         %{name}-scm-encode.patch
46 Patch2:         %{name}-cvs-config.patch
47 Patch3:         %{name}-irc-config.patch
48 Patch4:         %{name}-PEAR.patch
49 Patch10:                %{name}-clock-status.patch
50 Patch11:                %{name}-scm_checkin_associated.patch
51 Patch12:                %{name}-mail-queue.tpl.patch
52 Patch13:                %{name}-maildecode.patch
53 Patch14:                %{name}-send-typo.patch
54 Patch15:                %{name}-fixes.patch
55 URL:            http://dev.mysql.com/downloads/other/eventum/index.html
56 BuildRequires:  rpmbuild(macros) >= 1.177
57 BuildRequires:  sed >= 4.0
58 Requires:       php >= 4.1.0
59 Requires:       php-gd
60 Requires:       php-imap
61 Requires:       php-mysql
62 Requires:       php-pcre
63 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
64 %if %{with pear}
65 Requires:       Smarty >= 2.6.2
66 Requires:       php-pear-Benchmark
67 Requires:       php-pear-DB
68 Requires:       php-pear-Date
69 Requires:       php-pear-HTTP_Request
70 Requires:       php-pear-Mail
71 Requires:       php-pear-Math_Stats
72 Requires:       php-pear-Net_DIME
73 Requires:       php-pear-Net_POP3
74 Requires:       php-pear-Net_SMTP
75 Requires:       php-pear-Net_SmartIRC
76 Requires:       php-pear-Net_Socket
77 Requires:       php-pear-Net_URL
78 Requires:       php-pear-Net_UserAgent_Detect
79 Requires:       php-pear-PEAR
80 Requires:       php-pear-Text_Diff
81 Requires:       php-pear-XML_RPC
82 %endif
83 #Requires:      apache-mod_dir
84 # conflict with non-confdir apache
85 Conflicts:      apache1 < 1.3.33-1.1
86 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
87
88 %define         _sysconfdir     /etc/%{name}
89 %define         _appdir %{_datadir}/%{name}
90 %define         _smartyplugindir        %{php_pear_dir}/Smarty/plugins
91
92 %define         _apache1dir     /etc/apache
93 %define         _apache2dir     /etc/httpd
94
95 %description
96 Eventum is a user-friendly and flexible issue tracking system that can
97 be used by a support department to track incoming technical support
98 requests, or by a software development team to quickly organize tasks
99 and bugs. Eventum is used by the MySQL AB Technical Support team, and
100 has allowed us to dramatically improve our response times.
101
102 %description -l pl
103 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
104 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
105 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
106 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
107 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
108 reakcji.
109
110 %package base
111 Summary:        Eventum base package
112 Summary(pl):    Podstawowy pakiet Eventum
113 Group:          Applications/WWW
114
115 %description base
116 This package contains base directory structure for Eventum.
117
118 %description base -l pl
119 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
120
121 %package setup
122 Summary:        Eventum setup package
123 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
124 Group:          Applications/WWW
125 PreReq:         %{name} = %{epoch}:%{version}-%{release}
126
127 %description setup
128 Install this package to configure initial Eventum installation. You
129 should uninstall this package when you're done, as it considered
130 insecure to keep the setup files in place.
131
132 %description setup -l pl
133 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
134 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
135 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
136
137 %package mail-queue
138 Summary:        Eventum mail queue process
139 Summary(pl):    Przetwarzanie kolejki poczty Eventum
140 Group:          Applications/WWW
141 Requires:       %{name} = %{epoch}:%{version}-%{release}
142 Requires:       crondaemon
143 Requires:       php4 >= 4.1.0
144
145 %description mail-queue
146 Beginning with the first release of Eventum, emails are not directly
147 sent out from the various scripts, but rather added to a mail queue
148 table that is processed by a cron job. If an email cannot be sent, it
149 will be marked as such in the mail queue log, and the cron job script
150 will re-try to send it again the next time it runs.
151
152 This package contains the cron job.
153
154 %description mail-queue -l pl
155 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
156 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
157 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
158 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
159 nastêpnym razem.
160
161 Ten pakiet zawiera zadanie dla crona.
162
163 %package mail-download
164 Summary:        Eventum email download
165 Summary(pl):    ¦ci±ganie poczty Eventum
166 Group:          Applications/WWW
167 Requires:       %{name} = %{epoch}:%{version}-%{release}
168 Requires:       crondaemon
169 Requires:       php4 >= 4.1.0
170
171 %description mail-download
172 In order for Eventum's email integration feature to work, you need to
173 setup a cron job to run the script every so often.
174
175 This package contains the cron job.
176
177 %description mail-download -l pl
178 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
179 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
180 czêsto.
181
182 Ten pakiet zawiera zadanie dla crona.
183
184 %package reminder
185 Summary:        Eventum Reminder System
186 Summary(pl):    System przypominania dla Eventum
187 Group:          Applications/WWW
188 Requires:       %{name} = %{epoch}:%{version}-%{release}
189 Requires:       php4 >= 4.1.0
190 Requires:       crondaemon
191
192 %description reminder
193 The reminder system was designed with the objective as serving as a
194 safe net for issues that need attention. Depending on what
195 configuration you create, you may have several reminders (or alerts)
196 be sent out whenever an issue needs attention, for whatever parameter
197 you may deem necessary.
198
199 This package contains the cron job.
200
201 %description reminder -l pl
202 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
203 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
204 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
205 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
206 uwa¿aæ za potrzebny.
207
208 Ten pakiet zawiera zadanie dla crona.
209
210 %package monitor
211 Summary:        Eventum Heartbeat Monitor
212 Summary(pl):    Monitor ¿ycia dla Eventum
213 Group:          Applications/WWW
214 Requires:       %{name} = %{epoch}:%{version}-%{release}
215 Requires:       php4 >= 4.1.0
216 Requires:       crondaemon
217
218 %description monitor
219 The heartbeat monitor is a feature designed for the administrator that
220 wants to be alerted whenever a common problem in Eventum is detected,
221 like the database server not being available anymore, or maybe when
222 the recommended permissions for certain configuration files are
223 changed.
224
225 Please note that before running the heartbeat monitor, you may need to
226 customize some of the checks to be appropriate for your own system,
227 particularly the permission and file checks on
228 Monitor::checkConfiguration().
229
230 This package contains the cron job.
231
232 %description monitor -l pl
233 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
234 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
235 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
236 do plików konfiguracyjnych.
237
238 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
239 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
240 testów uprawnieñ i plików w Monitor::checkConfiguration().
241
242 Ten pakiet zawiera zadanie dla crona.
243
244 %package route-emails
245 Summary:        Eventum Email Routing
246 Summary(pl):    Przekazywanie poczty dla Eventum
247 Group:          Applications/WWW
248 Requires:       %{name} = %{epoch}:%{version}-%{release}
249 Requires:       php4 >= 4.1.0
250 #Requires:      eventum-router
251
252 %description route-emails
253 The email routing feature is used to automatically associate a thread
254 of emails into an Eventum issue. By setting up qmail (or even postfix)
255 to deliver emails sent to a specific address (usually
256 issue-<number>@<domain>) to the above script, users are able to use
257 their email clients to reply to emails coming from Eventum, and those
258 replies will be automatically associated with the issue and
259 broadcasted to the entire notification list.
260
261 %description route-emails -l pl
262 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
263 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
264 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
265 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
266 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
267 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
268 rozprowadzane do ca³ej listy og³oszeniowej.
269
270 %package route-notes
271 Summary:        Eventum Note Routing
272 Summary(pl):    Przekazywanie notatek dla Eventum
273 Group:          Applications/WWW
274 Requires:       %{name} = %{epoch}:%{version}-%{release}
275 Requires:       php4 >= 4.1.0
276 #Requires:      eventum-router
277
278 %description route-notes
279 The note routing feature is used to automatically associate a thread
280 of notes into an Eventum issue. By setting up qmail (or even postfix)
281 to deliver emails sent to a specific address (usually
282 note-<number>@<domain>) to the above script, users are able to use
283 their email clients to reply to internal notes coming from Eventum,
284 and those replies will be automatically associated with the issue and
285 broadcasted to the notification list staff members.
286
287 %description route-notes -l pl
288 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
289 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
290 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
291 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
292 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
293 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
294 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
295
296 %package irc
297 Summary:        Eventum IRC Notification Bot
298 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
299 Group:          Applications/WWW
300 Requires:       %{name} = %{epoch}:%{version}-%{release}
301 Requires:       php >= 4.1.0
302 Requires:       php-sockets
303 # FIXME just need start-stop-daemon
304 Requires:       dpkg
305
306 %description irc
307 The IRC notification bot is a nice feature for remote teams that want
308 to handle issues and want to have a quick and easy way to get simple
309 notifications. Right now the bot notifies of the following actions:
310 - New Issues
311 - Blocked emails
312 - Issues that got their assignment list changed
313
314 NOTE: You will need to manually edit the bot.php script to set your
315 appropriate preferences, like IRC server and channel that the bot
316 should join.
317
318 %description irc -l pl
319 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
320 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
321 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
322 nastêpuj±cych zdarzeniach:
323 - nowych sprawach
324 - zablokowanych listach
325 - sprawach, dla których zmieni³a siê lista powi±zañ
326
327 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
328 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
329
330 %package cli
331 Summary:        Eventum command-line interface
332 Summary(pl):    Interfejs linii poleceñ dla Eventum
333 Group:          Applications/WWW
334 Requires:       %{name} = %{epoch}:%{version}-%{release}
335 Requires:       php4 >= 4.1.0
336 Requires:       php4-cli
337 Requires:       php4-curl
338 Requires:       php4-xml
339 Requires:       php-pear-XML_RPC
340
341 %description cli
342 The Eventum command-line interface allows you to access most of the
343 features of the web interface straight from your command shell.
344
345 %description cli -l pl
346 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
347 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
348
349 %package scm
350 Summary:        Eventum SCM integration
351 Summary(pl):    Integracja SCM dla Eventum
352 Group:          Applications/WWW
353 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
354 Requires:       php4 >= 4.1.0
355
356 %description scm
357 This feature allows your software development teams to integrate your
358 Source Control Management system with your Issue Tracking System.
359
360 The integration is implemented in such a way that it will be forward
361 compatible with pretty much any SCM system, such as CVS.
362
363 For installation see
364 /eventum/help.php?topic=scm_integration_installation .
365
366 %description scm -l pl
367 Ten pakiet pozwala zespo³om programistów na integracjê systemu
368 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
369 ¶ledzenia spraw.
370
371 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
372 prawie ka¿dym systemem SCM, jak np. CVS.
373
374 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
375 /eventum/help.php?topic=scm_integration_installation .
376
377 %prep
378 %setup -q %{?_snap:-n %{name}-%{_snap}}
379 # undos the source
380 find . -type f -print0 | xargs -0 sed -i -e 's,
381 $,,'
382
383 # packaging
384 %patch0 -p1 -b .paths
385 %patch1 -p1
386 %patch2 -p1
387 %patch3 -p1
388 %{?with_pear:%patch4 -p1 -b .PEAR}
389
390 # bug fixes
391 %patch10 -p1
392 %patch11 -p1
393 %patch12 -p1
394 %patch13 -p1
395 %patch14 -p1
396 %patch15 -p1
397
398 rm -f */*~ */*/*~
399
400 %install
401 rm -rf $RPM_BUILD_ROOT
402 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_appdir}} \
403         $RPM_BUILD_ROOT{/etc/{rc.d/init.d,cron.d},/var/log/%{name}} \
404         $RPM_BUILD_ROOT{/var/run/eventum,/var/cache/eventum}
405
406 cp -a *.php {css,customer,images,include,js} \
407         {manage,misc,reports,rpc,setup,templates} $RPM_BUILD_ROOT%{_appdir}
408 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
409
410 > $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
411
412 sed -i -e 's,/usr/local/bin/php,/usr/bin/php4,' $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum
413 echo '#!/usr/bin/php4 -q' > %{name}-scm
414 cat $RPM_BUILD_ROOT%{_appdir}/misc/scm/process_cvs_commits.php >> %{name}-scm
415
416 # change private key, so we can easily grep
417 sed -i -e '
418 s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
419 ' $RPM_BUILD_ROOT%{_appdir}/include/private_key.php
420
421 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
422 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
423 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
424 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
425 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
426 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
427 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
428 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
429
430 # in conf
431 mv $RPM_BUILD_ROOT%{_appdir}/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/config.php
432 mv $RPM_BUILD_ROOT%{_appdir}/setup.conf.php $RPM_BUILD_ROOT%{_sysconfdir}/setup.php
433 mv $RPM_BUILD_ROOT%{_appdir}/include/private_key.php $RPM_BUILD_ROOT%{_sysconfdir}
434 mv $RPM_BUILD_ROOT%{_appdir}/misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
435 ln -s %{_sysconfdir}/config.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
436 ln -s %{_sysconfdir}/setup.php $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
437 ln -s %{_sysconfdir}/private_key.php $RPM_BUILD_ROOT%{_appdir}/include/private_key.php
438
439 # in doc
440 rm -rf $RPM_BUILD_ROOT%{_appdir}/misc/upgrade
441 # sample, not used in eventum
442 rm -rf $RPM_BUILD_ROOT%{_appdir}/rpc/xmlrpc_client.php
443
444 # in bindir
445 mv $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum $RPM_BUILD_ROOT%{_bindir}
446 rm -f $RPM_BUILD_ROOT%{_appdir}/misc/{cli/eventumrc_example,scm/process_cvs_commits.php}
447 cp misc/cli/eventumrc_example eventumrc
448 install %{name}-scm $RPM_BUILD_ROOT%{_bindir}/%{name}-scm
449
450 %if %{with pear}
451 # provided by PEAR
452 rm -rf $RPM_BUILD_ROOT%{_appdir}/misc/cli/include/pear
453 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
454
455 # use system Smarty
456 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
457 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
458 # These plugins are not in Smarty package (Smarty-2.6.2-3)
459 cp -a include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php $RPM_BUILD_ROOT%{_smartyplugindir}
460 %endif
461
462 %clean
463 rm -rf $RPM_BUILD_ROOT
464
465 %post
466 # apache1
467 if [ -f %{_apache1dir}/apache.conf ]; then
468         ln -sf %{_sysconfdir}/apache.conf %{_apache1dir}/conf.d/99_%{name}.conf
469         if [ -f /var/lock/subsys/apache ]; then
470                 /etc/rc.d/init.d/apache restart 1>&2
471         fi
472 fi
473 # apache2
474 if [ -d %{_apache2dir}/httpd.conf ]; then
475         ln -sf %{_sysconfdir}/apache.conf %{_apache2dir}/httpd.conf/99_%{name}.conf
476         if [ -f /var/lock/subsys/httpd ]; then
477                 /etc/rc.d/init.d/httpd restart 1>&2
478         fi
479 fi
480
481 # check if the package is configured.
482 if grep -q 'header("Location: setup/")' %{_sysconfdir}/config.php; then
483 %banner %{name} -e <<EOF
484
485 You haven't yet configured Eventum!
486
487 Install %{name}-setup and open up http://yourserver/eventum/
488 -- that will help you setup initial config.
489
490 when have configured Eventum, please uninstall the setup package,
491 so that %{name}-setup is able to secure your Eventum installation.
492
493 EOF
494 #' vim stupidity.
495
496 elif grep -q 'DEFAULTPRIVATEKEY' %{_sysconfdir}/private_key.php; then
497 %banner %{name} -e <<EOF
498
499 You have default private key installed!
500
501 Install %{name}-setup and open up http://yourserver/eventum/setup/
502 -- that will help you setup initial config.
503
504 when have configured Eventum, please uninstall the setup package,
505 so that %{name}-setup is able to secure your Eventum installation.
506
507 EOF
508         elif [ -d %{_appdir}/setup ]; then
509 %banner %{name} -e <<EOF
510
511 If you have have configured Eventum, please uninstall the setup package,
512 so that %{name}-setup is able to secure your Eventum installation.
513
514 EOF
515 fi
516
517
518 %preun
519 if [ "$1" = "0" ]; then
520         # apache1
521         if [ -f %{_apache1dir}/apache.conf ]; then
522                 rm -f %{_apache1dir}/conf.d/99_%{name}.conf
523                 if [ -f /var/lock/subsys/apache ]; then
524                         /etc/rc.d/init.d/apache restart 1>&2
525                 fi
526         fi
527         # apache2
528         if [ -d %{_apache2dir}/httpd.conf ]; then
529                 rm -f %{_apache1dir}/httpd.conf/99_%{name}.conf
530                 if [ -f /var/lock/subsys/httpd ]; then
531                         /etc/rc.d/init.d/httpd restart 1>&2
532                 fi
533         fi
534 fi
535
536 %post setup
537 chmod 660 %{_sysconfdir}/{config,private_key}.php
538 chown root:http %{_sysconfdir}/{config,private_key}.php
539
540 %postun setup
541 if [ "$1" = "0" ]; then
542         chmod 640 %{_sysconfdir}/{config,private_key}.php
543         chown root:http %{_sysconfdir}/{config,private_key}.php
544 fi
545
546 %files
547 %defattr(644,root,root,755)
548 %doc ChangeLog FAQ INSTALL README UPGRADE misc/upgrade docs/* rpc/xmlrpc_client.php
549 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
550 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
551 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/private_key.php
552 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/setup.php
553
554 %dir %{_appdir}
555 %dir %{_appdir}/misc
556
557 %dir %attr(731,root,http) /var/log/%{name}
558 %attr(620,root,http) %ghost /var/log/%{name}/*
559
560 %{_appdir}/*.php
561 %{_appdir}/css
562 %{_appdir}/customer
563 %{_appdir}/images
564 %{_appdir}/js
565 %{_appdir}/manage
566 %{_appdir}/reports
567 %{_appdir}/rpc
568 %{_appdir}/templates
569
570 %if %{with pear}
571 %{_smartyplugindir}/*
572 %else
573 %{_appdir}/include/pear
574 %{_appdir}/include/Smarty
575 %endif
576
577 %dir %{_appdir}/include
578 %{_appdir}/include/customer
579 %{_appdir}/include/jpgraph
580 %{_appdir}/include/workflow
581 %{_appdir}/include/*.php
582
583 %dir %attr(730,root,http) /var/run/%{name}
584 %dir %attr(730,root,http) /var/cache/%{name}
585
586 %{_appdir}/misc/blank.html
587
588 %files base
589 %defattr(644,root,root,755)
590 %attr(751,root,root) %dir %{_sysconfdir}
591
592 %files setup
593 %defattr(644,root,root,755)
594 %{_appdir}/setup
595
596 %files mail-queue
597 %defattr(644,root,root,755)
598 %{_appdir}/misc/process_mail_queue.php
599 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
600
601 %files mail-download
602 %defattr(644,root,root,755)
603 %{_appdir}/misc/download_emails.php
604 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
605
606 %files reminder
607 %defattr(644,root,root,755)
608 %{_appdir}/misc/check_reminders.php
609 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
610
611 %files monitor
612 %defattr(644,root,root,755)
613 %{_appdir}/misc/monitor.php
614 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
615
616 %files route-emails
617 %defattr(644,root,root,755)
618 %{_appdir}/misc/route_emails.php
619
620 %files route-notes
621 %defattr(644,root,root,755)
622 %{_appdir}/misc/route_drafts.php
623 %{_appdir}/misc/route_notes.php
624
625 %files irc
626 %defattr(644,root,root,755)
627 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
628 %{_appdir}/misc/irc
629 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
630
631 %files cli
632 %defattr(644,root,root,755)
633 %doc eventumrc
634 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cli.php
635 %attr(755,root,root) %{_bindir}/%{name}
636 %dir %{_appdir}/misc/cli
637 %{_appdir}/misc/cli/include
638
639 %files scm
640 %defattr(644,root,root,755)
641 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
642 # FIXME: not sure about this naming.
643 %attr(755,root,root) %{_bindir}/%{name}-scm
This page took 0.109086 seconds and 4 git commands to generate.