]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- add INDEX privilege on setup patch
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - system pear is incompatible, at least pear DB class seems broke Eventum
3 # - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
4 # - discard bundled packages (from INSTALL):
5 #  - JpGraph 1.5.3 (last GPL version)
6 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
7 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
8 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
9 #  - A few other small javascript libraries
10 # - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
11
12 %bcond_with     pear    # build with system PEAR packages (or use bundled ones)
13 %bcond_with     qmail   # build the router-qmail subpackage
14
15 # snapshot: DATE
16 #define _snap 20050227
17
18 # release candidate
19 #define _rc             RC2
20
21 %define _rel    2
22
23 %if 0%{?_snap}
24 %if 0%{?_rc}
25 %define _source http://pessoal.org/%{name}-%{version}-%{_rc}.tar.gz
26 %else
27 %define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
28 %endif
29 %else
30 %define _source http://mysql.dataphone.se/Downloads/%{name}/%{name}-%{version}.tar.gz
31 %endif
32
33 Summary:        Eventum Issue / Bug tracking system
34 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
35 Name:           eventum
36 Version:        1.6.0
37 Release:        %{?_snap:0.%{_snap}.}%{?_rc:%{_rc}.}%{_rel}
38 License:        GPL
39 Group:          Applications/WWW
40 Source0:        %{_source}
41 # Source0-md5:  a13d95ff52264d7460c688419794ffcc
42 %{?_snap:NoSource:      0}
43 Source1:        %{name}-apache.conf
44 Source2:        %{name}-mail-queue.cron
45 Source3:        %{name}-mail-download.cron
46 Source4:        %{name}-reminder.cron
47 Source5:        %{name}-monitor.cron
48 Source6:        %{name}-cvs.php
49 Source7:        %{name}-irc.php
50 Source8:        %{name}-irc.init
51 Source9:        %{name}-irc.sysconfig
52 Source10:       %{name}-config.php
53 Source11:       %{name}-router-qmail.sh
54 Source12:       http://dev.mysql.com/common/favicon.ico
55 # Source12-md5: 858be0130832da4144c08d4b59116411
56 Source13:       %{name}-config-setup.php
57 Source14:       %{name}-upgrade.sh
58 Patch0:         %{name}-paths.patch
59 Patch1:         %{name}-cvs-config.patch
60 Patch2:         %{name}-irc-config.patch
61 Patch3:         %{name}-PEAR.patch
62 Patch4:         http://glen.alkohol.ee/pld/%{name}-reply-subject.patch
63 Patch5:         %{name}-lf.patch
64 Patch6:         http://glen.alkohol.ee/pld/%{name}-maq-subject.patch
65 Patch7:         %{name}-bot-reconnect.patch
66 Patch8:         http://glen.alkohol.ee/pld/eventum-priv-index.patch
67 Patch9:         http://glen.alkohol.ee/pld/eventum-httpclient-clientside.patch
68 Patch22:        eventum-cli-wr-separated.patch
69 URL:            http://dev.mysql.com/downloads/other/eventum/
70 BuildRequires:  rpmbuild(macros) >= 1.223
71 BuildRequires:  sed >= 4.0
72 Requires:       php >= 4.2.0
73 Requires:       php-gd
74 Requires:       php-imap
75 Requires:       php-mysql
76 Requires:       php-pcre
77 Requires:       php-session
78 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
79 Requires:       Smarty >= 2.6.2
80 %if %{with pear}
81 Requires:       php-pear-Benchmark
82 Requires:       php-pear-DB
83 Requires:       php-pear-Date
84 Requires:       php-pear-HTTP_Request
85 Requires:       php-pear-Mail
86 Requires:       php-pear-Math_Stats
87 Requires:       php-pear-Net_DIME
88 Requires:       php-pear-Net_POP3
89 Requires:       php-pear-Net_SMTP
90 Requires:       php-pear-Net_SmartIRC
91 Requires:       php-pear-Net_Socket
92 Requires:       php-pear-Net_URL
93 Requires:       php-pear-Net_UserAgent_Detect
94 Requires:       php-pear-PEAR
95 Requires:       php-pear-Text_Diff
96 Requires:       php-pear-XML_RPC
97 %endif
98 Requires:       apache >= 1.3.33-2
99 Requires:       apache(mod_dir)
100 Requires(triggerpostun):        sed >= 4.0
101 BuildArch:      noarch
102 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
103
104 %define         _sysconfdir     /etc/%{name}
105 %define         _libdir         %{_prefix}/lib/%{name}
106 %define         _appdir %{_datadir}/%{name}
107 %define         _smartyplugindir        %{php_pear_dir}/Smarty/plugins
108
109 %description
110 Eventum is a user-friendly and flexible issue tracking system that can
111 be used by a support department to track incoming technical support
112 requests, or by a software development team to quickly organize tasks
113 and bugs. Eventum is used by the MySQL AB Technical Support team, and
114 has allowed us to dramatically improve our response times.
115
116 %description -l pl
117 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
118 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
119 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
120 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
121 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
122 reakcji.
123
124 %package base
125 Summary:        Eventum base package
126 Summary(pl):    Podstawowy pakiet Eventum
127 Group:          Applications/WWW
128 Requires(pre):  /bin/id
129 Requires(pre):  /usr/bin/getgid
130 Requires(pre):  /usr/sbin/useradd
131 Requires(pre):  /usr/sbin/groupadd
132 Requires(postun):       /usr/sbin/userdel
133 Requires(postun):       /usr/sbin/groupdel
134 Provides:       user(eventum)
135 Provides:       group(eventum)
136
137 %description base
138 This package contains base directory structure for Eventum.
139
140 %description base -l pl
141 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
142
143 %package setup
144 Summary:        Eventum setup package
145 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
146 Group:          Applications/WWW
147 PreReq:         %{name} = %{epoch}:%{version}-%{release}
148
149 %description setup
150 Install this package to configure initial Eventum installation. You
151 should uninstall this package when you're done, as it considered
152 insecure to keep the setup files in place.
153
154 %description setup -l pl
155 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
156 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
157 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
158
159 %package mail-queue
160 Summary:        Eventum mail queue process
161 Summary(pl):    Przetwarzanie kolejki poczty Eventum
162 Group:          Applications/WWW
163 Requires:       %{name} = %{epoch}:%{version}-%{release}
164 Requires:       crondaemon
165 Requires:       php >= 4.1.0
166
167 %description mail-queue
168 Beginning with the first release of Eventum, emails are not directly
169 sent out from the various scripts, but rather added to a mail queue
170 table that is processed by a cron job. If an email cannot be sent, it
171 will be marked as such in the mail queue log, and the cron job script
172 will re-try to send it again the next time it runs.
173
174 This package contains the cron job.
175
176 %description mail-queue -l pl
177 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
178 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
179 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
180 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
181 nastêpnym razem.
182
183 Ten pakiet zawiera zadanie dla crona.
184
185 %package mail-download
186 Summary:        Eventum email download
187 Summary(pl):    ¦ci±ganie poczty Eventum
188 Group:          Applications/WWW
189 Requires:       %{name} = %{epoch}:%{version}-%{release}
190 Requires:       crondaemon
191 Requires:       php >= 4.1.0
192
193 %description mail-download
194 In order for Eventum's email integration feature to work, you need to
195 setup a cron job to run the script every so often.
196
197 This package contains the cron job.
198
199 %description mail-download -l pl
200 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
201 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
202 czêsto.
203
204 Ten pakiet zawiera zadanie dla crona.
205
206 %package reminder
207 Summary:        Eventum Reminder System
208 Summary(pl):    System przypominania dla Eventum
209 Group:          Applications/WWW
210 Requires:       %{name} = %{epoch}:%{version}-%{release}
211 Requires:       php >= 4.1.0
212 Requires:       crondaemon
213
214 %description reminder
215 The reminder system was designed with the objective as serving as a
216 safe net for issues that need attention. Depending on what
217 configuration you create, you may have several reminders (or alerts)
218 be sent out whenever an issue needs attention, for whatever parameter
219 you may deem necessary.
220
221 This package contains the cron job.
222
223 %description reminder -l pl
224 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
225 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
226 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
227 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
228 uwa¿aæ za potrzebny.
229
230 Ten pakiet zawiera zadanie dla crona.
231
232 %package monitor
233 Summary:        Eventum Heartbeat Monitor
234 Summary(pl):    Monitor ¿ycia dla Eventum
235 Group:          Applications/WWW
236 Requires:       %{name} = %{epoch}:%{version}-%{release}
237 Requires:       php >= 4.1.0
238 Requires:       php-posix
239 Requires:       crondaemon
240
241 %description monitor
242 The heartbeat monitor is a feature designed for the administrator that
243 wants to be alerted whenever a common problem in Eventum is detected,
244 like the database server not being available anymore, or maybe when
245 the recommended permissions for certain configuration files are
246 changed.
247
248 Please note that before running the heartbeat monitor, you may need to
249 customize some of the checks to be appropriate for your own system,
250 particularly the permission and file checks on
251 Monitor::checkConfiguration().
252
253 This package contains the cron job.
254
255 %description monitor -l pl
256 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
257 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
258 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
259 do plików konfiguracyjnych.
260
261 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
262 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
263 testów uprawnieñ i plików w Monitor::checkConfiguration().
264
265 Ten pakiet zawiera zadanie dla crona.
266
267 %package route-emails
268 Summary:        Eventum Email Routing
269 Summary(pl):    Przekazywanie poczty dla Eventum
270 Group:          Applications/WWW
271 Requires:       %{name} = %{epoch}:%{version}-%{release}
272 Requires:       php >= 4.1.0
273 Requires:       eventum(router)
274
275 %description route-emails
276 The email routing feature is used to automatically associate a thread
277 of emails into an Eventum issue. By setting up qmail (or even postfix)
278 to deliver emails sent to a specific address (usually
279 issue-<number>@<domain>) to the above script, users are able to use
280 their email clients to reply to emails coming from Eventum, and those
281 replies will be automatically associated with the issue and
282 broadcasted to the entire notification list.
283
284 %description route-emails -l pl
285 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
286 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
287 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
288 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
289 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
290 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
291 rozprowadzane do ca³ej listy og³oszeniowej.
292
293 %package route-notes
294 Summary:        Eventum Note Routing
295 Summary(pl):    Przekazywanie notatek dla Eventum
296 Group:          Applications/WWW
297 Requires:       %{name} = %{epoch}:%{version}-%{release}
298 Requires:       php >= 4.1.0
299 Requires:       eventum(router)
300
301 %description route-notes
302 The note routing feature is used to automatically associate a thread
303 of notes into an Eventum issue. By setting up qmail (or even postfix)
304 to deliver emails sent to a specific address (usually
305 note-<number>@<domain>) to the above script, users are able to use
306 their email clients to reply to internal notes coming from Eventum,
307 and those replies will be automatically associated with the issue and
308 broadcasted to the notification list staff members.
309
310 %description route-notes -l pl
311 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
312 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
313 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
314 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
315 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
316 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
317 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
318
319 %package router-qmail
320 Summary:        Eventum Mail Routing - qmail
321 Summary(pl):    Przekazywanie poczty Eventum - qmail
322 Group:          Applications/Mail
323 Requires:       %{name} = %{epoch}:%{version}-%{release}
324 Requires:       qmail >= 1.03
325 Provides:       eventum(router)
326 Obsoletes:      eventum(router)
327
328 %description router-qmail
329 This package provides way of routing notes and emails back to Eventum
330 via qmail.
331
332 %description router-qmail -l pl
333 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
334 przez qmaila.
335
336 %package router-postfix
337 Summary:        Eventum Mail Routing - Postfix
338 Summary(pl):    Przekazywanie poczty Eventum - Postfix
339 Group:          Applications/Mail
340 Requires:       %{name} = %{epoch}:%{version}-%{release}
341 Requires:       postfix
342 Provides:       eventum(router)
343 Obsoletes:      eventum(router)
344
345 %description router-postfix
346 This package provides way of routing notes and emails back to Eventum
347 via Postfix.
348
349 %description router-postfix -l pl
350 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
351 przez Postfiksa.
352
353 %package irc
354 Summary:        Eventum IRC Notification Bot
355 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
356 Group:          Applications/WWW
357 Requires:       %{name} = %{epoch}:%{version}-%{release}
358 Requires:       php >= 4.1.0
359 Requires:       php-sockets
360 PreReq:         rc-scripts >= 0.4.0.18
361
362 %description irc
363 The IRC notification bot is a nice feature for remote teams that want
364 to handle issues and want to have a quick and easy way to get simple
365 notifications. Right now the bot notifies of the following actions:
366 - New Issues
367 - Blocked emails
368 - Issues that got their assignment list changed
369
370 NOTE: You will need to manually edit the bot.php script to set your
371 appropriate preferences, like IRC server and channel that the bot
372 should join.
373
374 %description irc -l pl
375 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
376 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
377 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
378 nastêpuj±cych zdarzeniach:
379 - nowych sprawach
380 - zablokowanych listach
381 - sprawach, dla których zmieni³a siê lista powi±zañ
382
383 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
384 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
385
386 %package cli
387 Summary:        Eventum command-line interface
388 Summary(pl):    Interfejs linii poleceñ dla Eventum
389 Group:          Applications/WWW
390 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
391 Requires:       php >= 4.1.0
392 Requires:       php-cli
393 Requires:       php-curl
394 Requires:       php-xml
395 Requires:       php-pear-XML_RPC
396
397 %description cli
398 The Eventum command-line interface allows you to access most of the
399 features of the web interface straight from your command shell.
400
401 %description cli -l pl
402 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
403 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
404
405 %package scm
406 Summary:        Eventum SCM integration
407 Summary(pl):    Integracja SCM dla Eventum
408 Group:          Applications/WWW
409 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
410 Requires:       php-cli >= 4.1.0
411 Requires:       php-pcre
412
413 %description scm
414 This feature allows your software development teams to integrate your
415 Source Control Management system with your Issue Tracking System.
416
417 The integration is implemented in such a way that it will be forward
418 compatible with pretty much any SCM system, such as CVS.
419
420 For installation see
421 </eventum/help.php?topic=scm_integration_installation>.
422
423 %description scm -l pl
424 Ten pakiet pozwala zespo³om programistów na integracjê systemu
425 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
426 ¶ledzenia spraw.
427
428 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
429 prawie ka¿dym systemem SCM, jak np. CVS.
430
431 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
432 </eventum/help.php?topic=scm_integration_installation>.
433
434 %prep
435 %setup -q %{?_snap:-n %{name}-%{_snap}}
436 # undos the source
437 find . -type f -print0 | xargs -0 sed -i -e 's,
438 $,,'
439
440 rm -f setup.conf.php
441 rm -rf misc/upgrade/*v1.[123]* # too old to support in PLD
442
443 # packaging
444 %patch0 -p1 -b .paths
445 %patch1 -p1
446 %patch2 -p1
447 %{?with_pear:%patch3 -p1 -b .PEAR}
448
449 # bug fixes.
450 %patch4 -p1
451 %patch5 -p1
452 %patch6 -p1
453 %patch7 -p1
454 %patch8 -p1
455 %patch9 -p1
456 %patch22 -p1
457
458 # replace in remaining scripts config.inc.php to system one
459 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
460         s,include_once(".*config.inc.php"),include_once("%{_sysconfdir}/core.php"),
461 '
462 sed -i -e '
463         s,include(".*config.inc.php"),include_once("%{_sysconfdir}/core.php"),
464 ' misc/download_emails.php
465
466 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
467         s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_sysconfdir}/private_key.php"),
468 '
469 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
470
471 %install
472 rm -rf $RPM_BUILD_ROOT
473 install -d \
474         $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_libdir}} \
475         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
476         $RPM_BUILD_ROOT/var/{run,log,cache,lib}/%{name} \
477         $RPM_BUILD_ROOT/var/lib/%{name}/routed_emails \
478         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
479
480 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
481 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
482 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
483 cp -a misc/irc $RPM_BUILD_ROOT%{_appdir}
484 cp -a templates $RPM_BUILD_ROOT%{_appdir}
485 cp -a include/{customer,jpgraph,pear,workflow} $RPM_BUILD_ROOT%{_appdir}/include
486 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
487 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
488 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
489
490 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
491 install %{SOURCE13} $RPM_BUILD_ROOT%{_appdir}/htdocs/setup/config.inc.php
492 install %{SOURCE14} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
493
494 # cli
495 install -d $RPM_BUILD_ROOT%{_appdir}/cli
496 install misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
497 install misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
498 sed -e '1s,#!.*/bin/php,#!%{_bindir}/php4,' \
499         misc/cli/eventum > $RPM_BUILD_ROOT%{_bindir}/%{name}
500 cp -f misc/cli/eventumrc_example eventumrc
501
502 # scm
503 echo '#!%{_bindir}/php4 -q' > %{name}-scm
504 cat misc/scm/process_cvs_commits.php >> %{name}-scm
505 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
506
507 # private key
508 mv $RPM_BUILD_ROOT{%{_appdir}/include/private_key.php,%{_sysconfdir}}
509 # change private key, so we can easily grep
510 sed -i -e '
511 s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
512 ' $RPM_BUILD_ROOT%{_sysconfdir}/private_key.php
513
514 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
515 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
516 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
517 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
518 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
519 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
520 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
521 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
522 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
523 sed -e 's,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}},' \
524         %{SOURCE10} > $RPM_BUILD_ROOT%{_sysconfdir}/core.php
525
526 # config
527 > $RPM_BUILD_ROOT%{_sysconfdir}/setup.php
528 mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_sysconfdir}/config}.php
529
530 # sample, not used in eventum
531 rm -f $RPM_BUILD_ROOT%{_appdir}/htdocs/rpc/xmlrpc_client.php
532
533 %if %{with pear}
534 # provided by PEAR
535 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
536 %endif
537
538 # use system Smarty
539 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
540 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
541 # These plugins are not in Smarty package (Smarty-2.6.2-3)
542 cp -a include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
543         $RPM_BUILD_ROOT%{_smartyplugindir}
544
545 # qmail router
546 %if %{with qmail}
547 d=$RPM_BUILD_ROOT/var/lib/%{name}
548 echo 'root' > $d/.qmail
549 echo 'root' > $d/.qmail-default
550 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
551 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
552 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
553 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
554 %endif
555
556 %clean
557 rm -rf $RPM_BUILD_ROOT
558
559 %pre
560 %addusertogroup http %{name}
561
562 %post
563 # check if the package is configured.
564 if grep -q 'header("Location: setup/")' %{_sysconfdir}/config.php; then
565 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
566 %banner %{name} -e <<EOF
567
568 You haven't yet configured Eventum!
569 Please open in browser <http://localhost/eventum/>
570 If you need access from elsewhere, you need to edit
571 %{_sysconfdir}/apache.conf and restart apache.
572
573 IMPORTANT: When You have configured Eventum, please uninstall the
574 setup package, so that %{name}-setup is able to secure your Eventum
575 installation.
576
577 EOF
578 #' vim stupidity.
579 else
580 %banner %{name} -e <<EOF
581
582 You haven't yet configured Eventum!
583
584 To setup eventum, please install %{name}-setup and open in browser
585 <http://localhost/eventum/>.
586 If you need access from elsewhere, you need to edit
587 %{_sysconfdir}/apache.conf and restart apache.
588
589 IMPORTANT: When You have configured Eventum, please uninstall the
590 setup package, so that %{name}-setup is able to secure your Eventum
591 installation.
592
593 EOF
594 #' vim stupidity.
595 fi
596
597 elif grep -q 'DEFAULTPRIVATEKEY' %{_sysconfdir}/private_key.php; then
598 %banner %{name} -e <<EOF
599
600 You have default private key installed!
601
602 Install %{name}-setup and open up http://yourserver/eventum/setup/
603 -- that will help you setup initial config.
604
605 when have configured Eventum, please uninstall the setup package,
606 so that %{name}-setup is able to secure your Eventum installation.
607
608 EOF
609         elif [ -d %{_appdir}/setup ]; then
610 %banner %{name} -e <<EOF
611
612 If you have have configured Eventum, please uninstall the setup package,
613 so that %{name}-setup is able to secure your Eventum installation.
614
615 EOF
616 fi
617
618 # nuke Smarty templates cache after upgrade
619 rm -f /var/cache/eventum/*.php
620
621 %preun
622 if [ "$1" = "0" ]; then
623         # nuke cache
624         rm -f /var/cache/eventum/*.php 2>/dev/null || :
625 fi
626
627 %pre base
628 %groupadd -P %{name}-base -g 146 %{name}
629 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
630
631 %postun base
632 if [ "$1" = "0" ]; then
633         %userremove %{name}
634         %groupremove %{name}
635 fi
636
637 %if %{with qmail}
638 %post router-qmail
639 CF=/etc/qmail/control/virtualdomains
640 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
641         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_sysconfdir}/config.php 2>/dev/null)
642         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
643         umask 022
644         echo "#${FQDN}:%{name}" >> $CF
645
646 %banner %{name}-qmail -e <<EOF
647
648 Added "#${FQDN}:%{name}" to $CF,
649 Please verify that it is correct and restart qmail:
650 # service qmail reload
651
652 Consult qmail-send(8) for more information on virtualdomains.
653
654 EOF
655 fi
656
657 %preun router-qmail
658 if [ "$1" = "0" ]; then
659         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
660 fi
661 %endif
662
663 %post setup
664 chmod 660 %{_sysconfdir}/{config,private_key}.php
665 chown root:eventum %{_sysconfdir}/{config,private_key}.php
666
667 %postun setup
668 if [ "$1" = "0" ]; then
669         chmod 640 %{_sysconfdir}/{config,private_key}.php
670         chown root:eventum %{_sysconfdir}/{config,private_key}.php
671 fi
672
673 %triggerin -- apache1 >= 1.3.33-2
674 %apache_config_install -v 1 -c %{_sysconfdir}/apache.conf
675
676 %triggerun -- apache1 >= 1.3.33-2
677 %apache_config_uninstall -v 1
678
679 %triggerin -- apache >= 2.0.0
680 %apache_config_install -v 2 -c %{_sysconfdir}/apache.conf
681
682 %triggerun -- apache >= 2.0.0
683 %apache_config_uninstall -v 2
684
685 # FIXME
686 # only one upgrade trigger is called if you're upgrading over two
687 # versions, say 1.5 to 1.5.3, only 1.5.3 trigger is called.
688 # use common trigger (the highest version and rpmvercmp from poldek?)
689 %triggerpostun -- eventum < 1.5.1-0.257
690 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5_to_v1.5.1 <<EOF
691 database_changes.php Perform database changes
692 EOF
693
694 %triggerpostun -- eventum < 1.5.2-0.289
695 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.1_to_v1.5.2 <<EOF
696 database_changes.php Perform database changes
697 set_priority_ranks.php Fix the ranking of priority values
698 EOF
699
700 %triggerpostun -- eventum < 1.5.3-0.291
701 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.2_to_v1.5.3 <<EOF
702 database_changes.php Perform database changes
703 EOF
704
705 %triggerpostun -- eventum < 1.5.4-1.12
706 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.3_to_v1.5.4 <<EOF
707 database_changes.php Perform database changes
708 EOF
709
710 %triggerpostun -- eventum < 1.6.0-RC2.6
711 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.5_to_v1.6.0 <<EOF
712 database_changes.php Perform database changes
713 upgrade_saved_searches.php Upgrade existing custom filters (saved searches)
714 EOF
715
716 %files
717 %defattr(644,root,root,755)
718 %doc ChangeLog FAQ INSTALL README UPGRADE
719 %doc docs/* rpc/xmlrpc_client.php setup/schema.sql
720 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
721 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
722 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/private_key.php
723 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/setup.php
724 %attr(640,root,eventum) %config %verify(not mtime) %{_sysconfdir}/core.php
725
726 %dir %attr(731,root,eventum) /var/log/%{name}
727 %attr(620,root,eventum) %ghost /var/log/%{name}/*
728
729 %dir %{_appdir}/htdocs
730 %{_appdir}/htdocs/*.php
731 %{_appdir}/htdocs/*.ico
732 %{_appdir}/htdocs/css
733 %{_appdir}/htdocs/customer
734 %{_appdir}/htdocs/images
735 %{_appdir}/htdocs/js
736 %{_appdir}/htdocs/manage
737 %{_appdir}/htdocs/reports
738 %{_appdir}/htdocs/rpc
739 %{_appdir}/htdocs/misc
740
741 %{_appdir}/templates
742 %dir %{_appdir}/upgrade
743 %attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
744 %{_appdir}/upgrade/[!u]*
745
746 %{_smartyplugindir}/*
747 %if %{without pear}
748 %{_appdir}/include/pear
749 %endif
750
751 %dir %{_appdir}/include
752 %{_appdir}/include/customer
753 %{_appdir}/include/jpgraph
754 %{_appdir}/include/workflow
755 %{_appdir}/include/class.[!m]*.php
756 %{_appdir}/include/class.mail.php
757 %{_appdir}/include/class.mail_queue.php
758 %{_appdir}/include/class.mime_helper.php
759 %{_appdir}/include/class.misc.php
760 %{_appdir}/include/db_access.php
761
762 %dir %attr(730,root,eventum) /var/run/%{name}
763 %dir %attr(730,root,eventum) /var/cache/%{name}
764
765 %files base
766 %defattr(644,root,root,755)
767 %attr(751,root,root) %dir %{_sysconfdir}
768 %dir %{_libdir}
769 %dir %{_appdir}
770 # qmail will ignore user, if it's home directory is not owned
771 %attr(750,eventum,eventum) %dir /var/lib/%{name}
772 # for saved routed emails
773 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_emails
774
775 %files setup
776 %defattr(644,root,root,755)
777 %{_appdir}/htdocs/setup
778
779 %files mail-queue
780 %defattr(644,root,root,755)
781 %{_appdir}/process_mail_queue.php
782 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
783
784 %files mail-download
785 %defattr(644,root,root,755)
786 %{_appdir}/download_emails.php
787 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
788
789 %files reminder
790 %defattr(644,root,root,755)
791 %{_appdir}/check_reminders.php
792 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
793
794 %files monitor
795 %defattr(644,root,root,755)
796 %{_appdir}/include/class.monitor.php
797 %{_appdir}/monitor.php
798 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
799
800 %files route-emails
801 %defattr(644,root,root,755)
802 %{_appdir}/route_emails.php
803
804 %files route-notes
805 %defattr(644,root,root,755)
806 %{_appdir}/route_drafts.php
807 %{_appdir}/route_notes.php
808
809 %if %{with qmail}
810 %files router-qmail
811 %defattr(644,root,root,755)
812 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
813 %attr(755,root,root) %{_libdir}/router-qmail
814 %endif
815
816 %files router-postfix
817 %defattr(644,root,root,755)
818
819 %files irc
820 %defattr(644,root,root,755)
821 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
822 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
823 %{_appdir}/irc
824 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
825
826 %files cli
827 %defattr(644,root,root,755)
828 %doc eventumrc
829 %attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
830 %attr(755,root,root) %{_bindir}/%{name}
831 %{_appdir}/cli
832
833 %files scm
834 %defattr(644,root,root,755)
835 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
836 %attr(755,root,root) %{_libdir}/scm
This page took 0.192435 seconds and 4 git commands to generate.