]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- 20060314 snap, msgid-case and route-and-download patches
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 # - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
9 #
10 # Conditional build:
11 %bcond_without  pear    # build with system PEAR packages (or use bundled ones)
12 %bcond_with     qmail   # build the router-qmail subpackage
13 #
14 # snapshot: DATE
15 %define _snap 20060314
16
17 %define _rel    0.5
18
19 %{?with_pear:%include   /usr/lib/rpm/macros.php}
20 Summary:        Eventum Issue / Bug tracking system
21 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
22 Name:           eventum
23 Version:        1.7.0
24 Release:        %{?_snap:4.%{_snap}.}%{?_rc:%{_rc}.}%{_rel}
25 License:        GPL
26 Group:          Applications/WWW
27 #Source0:       http://mysql.dataphone.se/Downloads/%{name}/%{name}-%{version}.tar.gz
28 Source0:        http://downloads.mysql.com/snapshots/eventum/%{name}-nightly-%{_snap}.tar.gz
29 # Source0-md5:  f9b9e49bbba4a58638240bcfc1e15555
30 Source1:        %{name}-apache.conf
31 Source2:        %{name}-mail-queue.cron
32 Source3:        %{name}-mail-download.cron
33 Source4:        %{name}-reminder.cron
34 Source5:        %{name}-monitor.cron
35 Source6:        %{name}-cvs.php
36 Source7:        %{name}-irc.php
37 Source8:        %{name}-irc.init
38 Source9:        %{name}-irc.sysconfig
39 Source10:       %{name}-config.php
40 Source11:       %{name}-router-qmail.sh
41 Source12:       %{name}-config-setup.php
42 Source13:       %{name}-upgrade.sh
43 Source14:       %{name}-router-postfix.sh
44 Patch0:         %{name}-paths.patch
45 Patch1:         %{name}-cvs-config.patch
46 Patch2:         %{name}-irc-config.patch
47 Patch3:         %{name}-PEAR.patch
48 Patch4:         http://glen.alkohol.ee/pld/%{name}-reply-subject.patch
49 Patch5:         %{name}-lf.patch
50 Patch6:         http://glen.alkohol.ee/pld/%{name}-maq-subject.patch
51 Patch7:         %{name}-bot-reconnect.patch
52 Patch8:         %{name}-perms.patch
53 Patch9:         http://glen.alkohol.ee/pld/%{name}-httpclient-clientside.patch
54 Patch10:        %{name}-cli-wr-separated.patch
55 Patch12:        %{name}-htmloptions-truncate.patch
56 Patch13:        %{name}-link_filter-updates.patch
57 Patch14:        %{name}-irc-mem.patch
58 Patch16:        %{name}-recent_activity-usability.patch
59 Patch17:        http://glen.alkohol.ee/pld/%{name}-upload-error-keep-popup.patch
60 Patch18:        http://glen.alkohol.ee/pld/%{name}-scm-parse-response.patch
61 Patch19:        %{name}-double-decode.patch
62 Patch20:        http://glen.alkohol.ee/pld/%{name}-keep-submitbutton.patch
63 Patch21:        http://glen.alkohol.ee/pld/%{name}-tt-unhide.patch
64 Patch22:        %{name}-route-mem.patch
65 Patch23:        http://glen.alkohol.ee/pld/%{name}-msgid-case.patch
66 Patch24:        http://glen.alkohol.ee/pld/%{name}-route-and-download.patch
67 URL:            http://dev.mysql.com/downloads/other/eventum/
68 %{?with_pear:BuildRequires:     rpm-php-pearprov >= 4.0.2-98}
69 BuildRequires:  rpmbuild(macros) >= 1.268
70 BuildRequires:  sed >= 4.0
71 Requires:       %{name}-base = %{version}-%{release}
72 Requires:       Smarty >= 2.6.10-4
73 Requires:       php >= 3:4.2.0
74 Requires:       php-gd
75 Requires:       php-imap
76 Requires:       php-mysql
77 Requires:       php-pcre
78 Requires:       php-session
79 %if %{with pear}
80 Requires:       php-pear-Benchmark
81 Requires:       php-pear-DB
82 Requires:       php-pear-Date
83 Requires:       php-pear-HTTP_Request
84 Requires:       php-pear-Mail
85 Requires:       php-pear-Mail_Mime
86 Requires:       php-pear-Math_Stats
87 Requires:       php-pear-Net_DIME
88 Requires:       php-pear-Net_SMTP
89 Requires:       php-pear-Net_Socket
90 Requires:       php-pear-Net_URL
91 Requires:       php-pear-Net_UserAgent_Detect
92 Requires:       php-pear-PEAR-core
93 Requires:       php-pear-Text_Diff
94 Requires:       php-pear-XML_RPC
95 %endif
96 Requires(triggerpostun):        /usr/bin/php
97 Requires(triggerpostun):        sed >= 4.0
98 Requires:       apache(mod_dir)
99 Requires:       webapps
100 Requires:       webserver = apache
101 BuildArch:      noarch
102 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
103
104 %define         _noautoreq      'pear(/etc/webapps/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)'
105
106 %define         _libdir         %{_prefix}/lib/%{name}
107 %define         _appdir         %{_datadir}/%{name}
108 %define         _smartyplugindir        %{_appdir}/include/smarty
109 %define         _smartydir      /usr/share/php/Smarty
110 %define         _webapps        /etc/webapps
111 %define         _webapp         %{name}
112 %define         _webappdir      %{_webapps}/%{_webapp}
113 %define         _sysconfdir     /etc/%{name}
114
115 %description
116 Eventum is a user-friendly and flexible issue tracking system that can
117 be used by a support department to track incoming technical support
118 requests, or by a software development team to quickly organize tasks
119 and bugs. Eventum is used by the MySQL AB Technical Support team, and
120 has allowed us to dramatically improve our response times.
121
122 %description -l pl
123 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
124 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
125 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
126 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
127 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
128 reakcji.
129
130 %package base
131 Summary:        Eventum base package
132 Summary(pl):    Podstawowy pakiet Eventum
133 Group:          Applications/WWW
134 Requires(postun):       /usr/sbin/groupdel
135 Requires(postun):       /usr/sbin/userdel
136 Requires(pre):  /bin/id
137 Requires(pre):  /usr/bin/getgid
138 Requires(pre):  /usr/sbin/groupadd
139 Requires(pre):  /usr/sbin/useradd
140 Provides:       group(eventum)
141 Provides:       user(eventum)
142
143 %description base
144 This package contains base directory structure for Eventum.
145
146 %description base -l pl
147 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
148
149 %package setup
150 Summary:        Eventum setup package
151 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
152 Group:          Applications/WWW
153 Requires:       %{name} = %{version}-%{release}
154
155 %description setup
156 Install this package to configure initial Eventum installation. You
157 should uninstall this package when you're done, as it considered
158 insecure to keep the setup files in place.
159
160 %description setup -l pl
161 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
162 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
163 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
164
165 %package mail-queue
166 Summary:        Eventum mail queue process
167 Summary(pl):    Przetwarzanie kolejki poczty Eventum
168 Group:          Applications/WWW
169 Requires:       %{name} = %{version}-%{release}
170 Requires:       crondaemon
171
172 %description mail-queue
173 Beginning with the first release of Eventum, emails are not directly
174 sent out from the various scripts, but rather added to a mail queue
175 table that is processed by a cron job. If an email cannot be sent, it
176 will be marked as such in the mail queue log, and the cron job script
177 will re-try to send it again the next time it runs.
178
179 This package contains the cron job.
180
181 %description mail-queue -l pl
182 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
183 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
184 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
185 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
186 nastêpnym razem.
187
188 Ten pakiet zawiera zadanie dla crona.
189
190 %package mail-download
191 Summary:        Eventum email download
192 Summary(pl):    ¦ci±ganie poczty Eventum
193 Group:          Applications/WWW
194 Requires:       %{name} = %{version}-%{release}
195 Requires:       crondaemon
196
197 %description mail-download
198 In order for Eventum's email integration feature to work, you need to
199 setup a cron job to run the script every so often.
200
201 This package contains the cron job.
202
203 %description mail-download -l pl
204 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
205 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
206 czêsto.
207
208 Ten pakiet zawiera zadanie dla crona.
209
210 %package reminder
211 Summary:        Eventum Reminder System
212 Summary(pl):    System przypominania dla Eventum
213 Group:          Applications/WWW
214 Requires:       %{name} = %{version}-%{release}
215 Requires:       crondaemon
216
217 %description reminder
218 The reminder system was designed with the objective as serving as a
219 safe net for issues that need attention. Depending on what
220 configuration you create, you may have several reminders (or alerts)
221 be sent out whenever an issue needs attention, for whatever parameter
222 you may deem necessary.
223
224 This package contains the cron job.
225
226 %description reminder -l pl
227 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
228 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
229 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
230 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
231 uwa¿aæ za potrzebny.
232
233 Ten pakiet zawiera zadanie dla crona.
234
235 %package monitor
236 Summary:        Eventum Heartbeat Monitor
237 Summary(pl):    Monitor ¿ycia dla Eventum
238 Group:          Applications/WWW
239 Requires:       %{name} = %{version}-%{release}
240 Requires:       crondaemon
241 Requires:       php-posix
242
243 %description monitor
244 The heartbeat monitor is a feature designed for the administrator that
245 wants to be alerted whenever a common problem in Eventum is detected,
246 like the database server not being available anymore, or maybe when
247 the recommended permissions for certain configuration files are
248 changed.
249
250 Please note that before running the heartbeat monitor, you may need to
251 customize some of the checks to be appropriate for your own system,
252 particularly the permission and file checks on
253 Monitor::checkConfiguration().
254
255 This package contains the cron job.
256
257 %description monitor -l pl
258 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
259 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
260 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
261 do plików konfiguracyjnych.
262
263 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
264 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
265 testów uprawnieñ i plików w Monitor::checkConfiguration().
266
267 Ten pakiet zawiera zadanie dla crona.
268
269 %package route-drafts
270 Summary:        Eventum Draft Routing
271 Summary(pl):    Przekazywanie szkiców dla Eventum
272 Group:          Applications/WWW
273 Requires:       %{name} = %{version}-%{release}
274 Requires:       eventum(router)
275
276 %description route-drafts
277 The draft routing feature is used to automatically associate a thread
278 of drafts into an Eventum issue. By setting up qmail (or even Postfix)
279 to deliver emails sent to a specific address (usually
280 draft-<number>@<domain>) to the above script, users are able to send
281 drafts written in their mail client to be stored in Eventum. These
282 drafts will NOT broadcasted to the notification list.
283
284 %description route-drafts -l pl
285 Przekazywanie szkiców s³u¿y do automatycznego wi±zania w±tku szkiców z
286 problemem w Eventum. Ustawiaj±c qmaila (czy nawet Postfiksa), aby
287 dostarcza³ pocztê wys³an± na podany adres (zwykle
288 draft-<liczba>@<domena>) do tego skryptu umo¿liwia siê u¿ytkownikom
289 wysy³anie szkiców napisanych w ich kliencie pocztowym do zapisania w
290 Eventum. Szkice te NIE bêd± wysy³ane na listê powiadomieñ.
291
292 %package route-emails
293 Summary:        Eventum Email Routing
294 Summary(pl):    Przekazywanie poczty dla Eventum
295 Group:          Applications/WWW
296 Requires:       %{name} = %{version}-%{release}
297 Requires:       eventum(router)
298
299 %description route-emails
300 The email routing feature is used to automatically associate a thread
301 of emails into an Eventum issue. By setting up qmail (or even postfix)
302 to deliver emails sent to a specific address (usually
303 issue-<number>@<domain>) to the above script, users are able to use
304 their email clients to reply to emails coming from Eventum, and those
305 replies will be automatically associated with the issue and
306 broadcasted to the entire notification list.
307
308 %description route-emails -l pl
309 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
310 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
311 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
312 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
313 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
314 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
315 rozprowadzane do ca³ej listy og³oszeniowej.
316
317 %package route-notes
318 Summary:        Eventum Note Routing
319 Summary(pl):    Przekazywanie notatek dla Eventum
320 Group:          Applications/WWW
321 Requires:       %{name} = %{version}-%{release}
322 Requires:       eventum(router)
323
324 %description route-notes
325 The note routing feature is used to automatically associate a thread
326 of notes into an Eventum issue. By setting up qmail (or even postfix)
327 to deliver emails sent to a specific address (usually
328 note-<number>@<domain>) to the above script, users are able to use
329 their email clients to reply to internal notes coming from Eventum,
330 and those replies will be automatically associated with the issue and
331 broadcasted to the notification list staff members.
332
333 %description route-notes -l pl
334 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
335 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
336 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
337 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
338 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
339 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
340 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
341
342 %package router-qmail
343 Summary:        Eventum Mail Routing - qmail
344 Summary(pl):    Przekazywanie poczty Eventum - qmail
345 Group:          Applications/Mail
346 # loose dep is intentional. qmail subpackage isn't built on PLD
347 # builders and there really nothing changes.
348 Requires:       %{name} >= %{version}-%{release}
349 Requires:       qmail >= 1.03
350 Provides:       eventum(router)
351 Obsoletes:      eventum(router)
352
353 %description router-qmail
354 This package provides way of routing notes and emails back to Eventum
355 via qmail.
356
357 %description router-qmail -l pl
358 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
359 przez qmaila.
360
361 %package router-postfix
362 Summary:        Eventum Mail Routing - Postfix
363 Summary(pl):    Przekazywanie poczty Eventum - Postfix
364 Group:          Applications/Mail
365 Requires:       %{name} = %{version}-%{release}
366 Requires:       postfix
367 Provides:       eventum(router)
368 Obsoletes:      eventum(router)
369
370 %description router-postfix
371 This package provides way of routing notes and emails back to Eventum
372 via Postfix.
373
374 The Postfix configuration instructions you can find from
375 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
376
377 %description router-postfix -l pl
378 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
379 przez Postfiksa.
380
381 Opis konfiguracji Postfiksa mo¿na znale¼æ pod adresem
382 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
383
384 %package irc
385 Summary:        Eventum IRC Notification Bot
386 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
387 Group:          Applications/WWW
388 Requires(triggerpostun):        sed >= 4.0
389 Requires:       %{name} = %{version}-%{release}
390 Requires:       php-pear-Net_SmartIRC
391 Requires:       php-sockets
392 Requires:       rc-scripts >= 0.4.0.18
393
394 %description irc
395 The IRC notification bot is a nice feature for remote teams that want
396 to handle issues and want to have a quick and easy way to get simple
397 notifications. Right now the bot notifies of the following actions:
398 - New Issues
399 - Blocked emails
400 - Issues that got their assignment list changed
401
402 NOTE: You will need to manually edit the bot.php script to set your
403 appropriate preferences, like IRC server and channel that the bot
404 should join.
405
406 %description irc -l pl
407 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
408 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
409 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
410 nastêpuj±cych zdarzeniach:
411 - nowych sprawach
412 - zablokowanych listach
413 - sprawach, dla których zmieni³a siê lista powi±zañ
414
415 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
416 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
417
418 %package cli
419 Summary:        Eventum command-line interface
420 Summary(pl):    Interfejs linii poleceñ dla Eventum
421 Group:          Applications/WWW
422 Requires:       %{name}-base = %{version}-%{release}
423 Requires:       php-cli
424 Requires:       php-common >= 3:4.1.0
425 Requires:       php-curl
426 Requires:       php-pear-XML_RPC
427 Requires:       php-xml
428
429 %description cli
430 The Eventum command-line interface allows you to access most of the
431 features of the web interface straight from your command shell.
432
433 %description cli -l pl
434 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
435 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
436
437 %package scm
438 Summary:        Eventum SCM integration
439 Summary(pl):    Integracja SCM dla Eventum
440 Group:          Applications/WWW
441 Requires:       %{name}-base = %{version}-%{release}
442 Requires:       php-cli
443 Requires:       php-common >= 3:4.1.0
444 Requires:       php-pcre
445
446 %description scm
447 This feature allows your software development teams to integrate your
448 Source Control Management system with your Issue Tracking System.
449
450 The integration is implemented in such a way that it will be forward
451 compatible with pretty much any SCM system, such as CVS.
452
453 For installation see
454 </eventum/help.php?topic=scm_integration_installation>.
455
456 %description scm -l pl
457 Ten pakiet pozwala zespo³om programistów na integracjê systemu
458 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
459 ¶ledzenia spraw.
460
461 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
462 prawie ka¿dym systemem SCM, jak np. CVS.
463
464 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
465 </eventum/help.php?topic=scm_integration_installation>.
466
467 %prep
468 %setup -q %{?_snap:-n %{name}-%{_snap}}
469 # undos the source
470 find . -type f -print0 | xargs -0 sed -i -e 's,\r$,,'
471
472 rm -f setup.conf.php # not to be installed by *.php glob
473 rm -rf misc/upgrade/*v1.[123]* # too old to support in PLD Linux
474 rm -f misc/upgrade/flush_compiled_templates.php
475 rm -rf misc/upgrade/*/upgrade_config.php # not needed nor supported in PLD Linux
476
477 # sample, not used in eventum
478 rm -f rpc/xmlrpc_client.php
479
480 # packaging
481 %patch0 -p1
482 %patch1 -p1
483 %patch14 -p1
484 %patch2 -p1
485 %{?with_pear:%patch3 -p1}
486
487 # bug fixes.
488 %patch4 -p1
489 %patch5 -p1
490 %patch6 -p1
491 %patch7 -p1
492 %patch8 -p1
493 %patch9 -p1
494 %patch10 -p1
495 %patch12 -p1
496 %patch13 -p1
497 %patch16 -p1
498 %patch17 -p1
499 %patch18 -p1
500 %patch19 -p1
501 %patch20 -p1
502 %patch21 -p1
503 %patch22 -p1
504 %patch23 -p1
505 %patch24 -p1
506
507 sed -e '1s,#!.*/bin/php -q,#!%{_bindir}/php,' misc/cli/eventum > %{name}-cli
508 sed -e '1i#!%{_bindir}/php' misc/scm/process_cvs_commits.php > %{name}-scm
509 sed -e '1i#!%{_bindir}/php' misc/irc/bot.php > %{name}-bot
510 mv misc/cli/eventumrc_example eventumrc
511 sed -i -e '1i#!%{_bindir}/php' misc/*.php
512 chmod +x misc/*.php
513
514 sed -e '
515 s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
516 ' < include/private_key.php > private_key.php.in
517 rm -f include/private_key.php
518
519 # replace in remaining scripts config.inc.php to system one
520 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
521         s,include_once(".*config.inc.php"),include_once("%{_webappdir}/core.php"),
522 '
523
524 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
525         s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_webappdir}/private_key.php"),
526 '
527
528 # remove backups from patching as we use globs to package files to buildroot
529 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
530
531 %install
532 rm -rf $RPM_BUILD_ROOT
533 install -d \
534         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
535         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
536         $RPM_BUILD_ROOT/var/{run,log,cache,lib}/%{name} \
537         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
538         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
539
540 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
541 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
542 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
543 cp -a templates $RPM_BUILD_ROOT%{_appdir}
544 cp -a include/{customer,custom_field,jpgraph,pear,workflow} $RPM_BUILD_ROOT%{_appdir}/include
545 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
546 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
547 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
548
549 cp -a favicon.ico $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
550 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/setup/config.inc.php
551 install %{SOURCE13} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
552
553 # cli
554 install -d $RPM_BUILD_ROOT%{_appdir}/cli
555 cp -a misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
556 cp -a misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
557 install %{name}-cli $RPM_BUILD_ROOT%{_bindir}/%{name}
558 install %{name}-bot $RPM_BUILD_ROOT%{_sbindir}
559
560 # scm
561 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
562 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
563
564 # private key
565 cp -a private_key.php.in $RPM_BUILD_ROOT%{_webappdir}/private_key.php
566
567 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
568 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
569 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
570 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
571 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
572 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
573 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
574 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
575 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
576
577 sed -e '
578 s,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}},
579 s,%%{PHP_PEAR_DIR}%%,%{?with_pear:%{php_pear_dir}}%{!?with_pear:%{_appdir}/includes/pear},
580 s,%%{APP_PATH}%%,%{_appdir},
581 s,%%{SMARTY_DIR}%%,%{_smartydir},
582 s,%%{SYSCONFDIR}%%,%{_webappdir},
583 ' %{SOURCE10} > $RPM_BUILD_ROOT%{_webappdir}/core.php
584
585 # config
586 > $RPM_BUILD_ROOT%{_webappdir}/setup.php
587 mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_webappdir}/config}.php
588
589 %if %{with pear}
590 # provided by PEAR
591 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
592 %endif
593
594 # use system Smarty
595 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
596 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
597 # These plugins are not in Smarty package (Smarty-2.6.2-3)
598 cp -a \
599         include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
600         include/Smarty/plugins/modifier.highlight_quoted.php \
601         $RPM_BUILD_ROOT%{_smartyplugindir}
602
603 # qmail router
604 %if %{with qmail}
605 d=$RPM_BUILD_ROOT/var/lib/%{name}
606 echo 'root' > $d/.qmail
607 echo 'root' > $d/.qmail-default
608 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
609 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
610 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
611 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
612 %endif
613 # postfix router
614 install %{SOURCE14} $RPM_BUILD_ROOT%{_libdir}/router-postfix
615
616 %clean
617 rm -rf $RPM_BUILD_ROOT
618
619 %pre
620 %addusertogroup http %{name}
621
622 %post
623 # check if the package is configured.
624 if grep -q 'header("Location: setup/")' %{_webappdir}/config.php; then
625 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
626 %banner %{name} -e <<EOF
627
628 You haven't yet configured Eventum!
629 Please open in browser <http://localhost/eventum/>
630 If you need access from elsewhere, you need to edit
631 %{_webappdir}/apache.conf and restart apache.
632
633 IMPORTANT: When You have configured Eventum, please uninstall the
634 setup package, so that %{name}-setup is able to secure your Eventum
635 installation.
636
637 EOF
638 #' vim syntax hack
639 else
640 %banner %{name} -e <<EOF
641
642 You haven't yet configured Eventum!
643
644 To setup eventum, please install %{name}-setup and open in browser
645 <http://localhost/eventum/>.
646 If you need access from elsewhere, you need to edit
647 %{_webappdir}/apache.conf and restart apache.
648
649 IMPORTANT: When You have configured Eventum, please uninstall the
650 setup package, so that %{name}-setup is able to secure your Eventum
651 installation.
652
653 EOF
654 #' vim syntax hack
655 fi
656
657 elif grep -q 'DEFAULTPRIVATEKEY' %{_webappdir}/private_key.php; then
658 %banner %{name} -e <<EOF
659
660 You have default private key installed!
661
662 Install %{name}-setup and open up http://yourserver/eventum/setup/
663 -- that will help you setup initial config.
664
665 when have configured Eventum, please uninstall the setup package,
666 so that %{name}-setup is able to secure your Eventum installation.
667
668 EOF
669         elif [ -d %{_appdir}/setup ]; then
670 %banner %{name} -e <<EOF
671
672 If you have have configured Eventum, please uninstall the setup package,
673 so that %{name}-setup is able to secure your Eventum installation.
674
675 EOF
676 fi
677
678 # nuke Smarty templates cache after upgrade
679 rm -f /var/cache/eventum/*.php
680
681 %preun
682 if [ "$1" = "0" ]; then
683         # nuke cache
684         rm -f /var/cache/eventum/*.php 2>/dev/null || :
685 fi
686
687 %pre base
688 %groupadd -P %{name}-base -g 146 %{name}
689 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
690
691 %postun base
692 if [ "$1" = "0" ]; then
693         %userremove %{name}
694         %groupremove %{name}
695 fi
696
697 %post router-qmail
698 CF=/etc/qmail/control/virtualdomains
699 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
700         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_webappdir}/config.php 2>/dev/null)
701         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
702         umask 022
703         echo "#${FQDN}:%{name}" >> $CF
704
705 %banner %{name}-qmail -e <<EOF
706
707 Added "#${FQDN}:%{name}" to $CF,
708 Please verify that it is correct and restart qmail:
709 # service qmail reload
710
711 Consult qmail-send(8) for more information on virtualdomains.
712
713 EOF
714 fi
715
716 %preun router-qmail
717 if [ "$1" = "0" ]; then
718         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
719 fi
720
721 %post setup
722 chmod 660 %{_webappdir}/{config,private_key}.php
723 chown root:eventum %{_webappdir}/{config,private_key}.php
724
725 %postun setup
726 if [ "$1" = "0" ]; then
727         chmod 640 %{_webappdir}/{config,private_key}.php
728         chown root:eventum %{_webappdir}/{config,private_key}.php
729 fi
730
731 %post irc
732 /sbin/chkconfig --add eventum-irc
733 %service eventum-irc restart "Eventum IRC Bot"
734
735 %triggerin -- apache1
736 %webapp_register apache %{_webapp}
737
738 %triggerun -- apache1
739 %webapp_unregister apache %{_webapp}
740
741 %triggerin -- apache >= 2.0.0
742 %webapp_register httpd %{_webapp}
743
744 %triggerun -- apache >= 2.0.0
745 %webapp_unregister httpd %{_webapp}
746
747 # FIXME
748 # only one upgrade trigger is called if you're upgrading over two
749 # versions, say 1.5 to 1.5.3, only 1.5.3 trigger is called.
750 # use common trigger (the highest version and rpmvercmp from poldek?)
751 %triggerpostun -- eventum < 1.5.1-0.257
752 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5_to_v1.5.1 <<EOF
753 database_changes.php Perform database changes
754 EOF
755
756 %triggerpostun -- eventum < 1.5.2-0.289
757 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.1_to_v1.5.2 <<EOF
758 database_changes.php Perform database changes
759 set_priority_ranks.php Fix the ranking of priority values
760 EOF
761
762 %triggerpostun -- eventum < 1.5.3-0.291
763 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.2_to_v1.5.3 <<EOF
764 database_changes.php Perform database changes
765 EOF
766
767 %triggerpostun -- eventum < 1.5.4-1.12
768 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.3_to_v1.5.4 <<EOF
769 database_changes.php Perform database changes
770 EOF
771
772 %triggerpostun -- eventum < 1.6.0-RC2.6
773 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.5_to_v1.6.0 <<EOF
774 database_changes.php Perform database changes
775 upgrade_saved_searches.php Upgrade existing custom filters (saved searches)
776 EOF
777
778 %triggerpostun -- eventum < 1.6.1-0.2
779 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.0_to_v1.6.1 <<EOF
780 database_changes.php Perform database changes
781 EOF
782
783 %triggerpostun irc -- eventum-irc < 1.6.1-3.14
784 sed -i -e '
785 s,\$irc_host,$irc_server_hostname,
786 s,\$irc_port,$irc_server_port,
787 s,\$irc_nick,$nickname,
788 s,\$irc_realname,$realname,
789 s,\$irc_username,$username,
790 s,\$irc_password,$password,
791 ' /etc/eventum/irc.php
792
793 %triggerpostun -- eventum < 1.7.0-2.0.48
794 # migrate from apache-config macros
795 if [ -f /etc/%{name}/apache.conf.rpmsave ]; then
796         if [ -d /etc/apache/webapps.d ]; then
797                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
798                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
799         fi
800
801         if [ -d /etc/httpd/webapps.d ]; then
802                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
803                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
804         fi
805 fi
806
807 if [ -L /etc/apache/conf.d/99_%{_webapp}.conf ]; then
808         /usr/sbin/webapp register apache %{_webapp}
809         rm -f /etc/apache/conf.d/99_%{_webapp}.conf
810         %service -q apache reload
811 fi
812 if [ -L /etc/httpd/httpd.conf/99_%{_webapp}.conf ]; then
813         /usr/sbin/webapp register httpd %{_webapp}
814         rm -f /etc/httpd/httpd.conf/99_%{_webapp}.conf
815         %service -q httpd reload
816 fi
817
818 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.1_to_v1.7.0 <<EOF
819 database_changes.php Perform database changes
820 set_root_message_ids.php Set iss_root_message_id
821 EOF
822
823 # regular configs
824 for i in apache.conf config.php private_key.php setup.php; do
825         if [ -f /etc/eventum/$i.rpmsave ]; then
826                 mv -f %{_webappdir}/$i{,.rpmnew}
827                 mv -f /etc/eventum/$i.rpmsave %{_webappdir}/$i
828         fi
829 done
830
831 %triggerpostun cli -- %{name}-cli < 1.7.0-3.4
832 if [ -f %{_webappdir}/cli.php.rpmsave ]; then
833         mv -f %{_sysconfdir}/cli.php{,.rpmnew}
834         mv -f %{_webappdir}/cli.php.rpmsave %{_sysconfdir}/cli.php
835 fi
836
837 %triggerpostun irc -- %{name}-irc < 1.7.0-3.4
838 if [ -f %{_webappdir}/irc.php.rpmsave ]; then
839         mv -f %{_sysconfdir}/irc.php{,.rpmnew}
840         mv -f %{_webappdir}/irc.php.rpmsave %{_sysconfdir}/irc.php
841 fi
842
843 %files
844 %defattr(644,root,root,755)
845 %doc ChangeLog FAQ INSTALL README UPGRADE CONTRIB
846 %doc docs/* setup/schema.sql
847 %attr(751,root,root) %dir %{_webappdir}
848 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
849 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
850 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
851 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
852 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
853 %attr(640,root,eventum) %config %verify(not mtime) %{_webappdir}/core.php
854
855 %dir %attr(731,root,eventum) /var/log/%{name}
856 %attr(620,root,eventum) %ghost /var/log/%{name}/*
857
858 %dir %{_appdir}/htdocs
859 %{_appdir}/htdocs/*.php
860 %{_appdir}/htdocs/*.ico
861 %{_appdir}/htdocs/css
862 %{_appdir}/htdocs/customer
863 %{_appdir}/htdocs/images
864 %{_appdir}/htdocs/js
865 %{_appdir}/htdocs/manage
866 %{_appdir}/htdocs/reports
867 %{_appdir}/htdocs/rpc
868 %{_appdir}/htdocs/misc
869
870 %{_appdir}/templates
871 %dir %{_appdir}/upgrade
872 %attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
873 %{_appdir}/upgrade/[!u]*
874
875 %{_smartyplugindir}
876 %if %{without pear}
877 %{_appdir}/include/pear
878 %endif
879
880 %dir %{_appdir}/include
881 %{_appdir}/include/customer
882 %{_appdir}/include/custom_field
883 %{_appdir}/include/jpgraph
884 %{_appdir}/include/workflow
885 %{_appdir}/include/class.[!m]*.php
886 %{_appdir}/include/class.mail.php
887 %{_appdir}/include/class.mail_queue.php
888 %{_appdir}/include/class.mime_helper.php
889 %{_appdir}/include/class.misc.php
890 %{_appdir}/include/db_access.php
891
892 %dir %attr(730,root,eventum) /var/run/%{name}
893 %dir %attr(730,root,eventum) /var/cache/%{name}
894
895 %files base
896 %defattr(644,root,root,755)
897 %attr(751,root,root) %dir %{_sysconfdir}
898 %dir %{_libdir}
899 %dir %{_appdir}
900 # qmail will ignore user, if it's home directory is not owned
901 %attr(750,eventum,eventum) %dir /var/lib/%{name}
902 # saved mail copies
903 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_emails
904 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_drafts
905 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_notes
906
907 %files setup
908 %defattr(644,root,root,755)
909 %{_appdir}/htdocs/setup
910
911 %files mail-queue
912 %defattr(644,root,root,755)
913 %attr(755,root,root) %{_appdir}/process_mail_queue.php
914 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
915
916 %files mail-download
917 %defattr(644,root,root,755)
918 %attr(755,root,root) %{_appdir}/download_emails.php
919 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
920
921 %files reminder
922 %defattr(644,root,root,755)
923 %attr(755,root,root) %{_appdir}/check_reminders.php
924 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
925
926 %files monitor
927 %defattr(644,root,root,755)
928 %{_appdir}/include/class.monitor.php
929 %attr(755,root,root) %{_appdir}/monitor.php
930 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
931
932 %files route-drafts
933 %defattr(644,root,root,755)
934 %attr(755,root,root) %{_appdir}/route_drafts.php
935
936 %files route-emails
937 %defattr(644,root,root,755)
938 %attr(755,root,root) %{_appdir}/route_emails.php
939
940 %files route-notes
941 %defattr(644,root,root,755)
942 %attr(755,root,root) %{_appdir}/route_notes.php
943
944 %if %{with qmail}
945 %files router-qmail
946 %defattr(644,root,root,755)
947 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
948 %attr(755,root,root) %{_libdir}/router-qmail
949 %endif
950
951 %files router-postfix
952 %defattr(644,root,root,755)
953 %attr(755,root,root) %{_libdir}/router-postfix
954
955 %files irc
956 %defattr(644,root,root,755)
957 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
958 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
959 %attr(755,root,root) %{_sbindir}/%{name}-bot
960 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
961
962 %files cli
963 %defattr(644,root,root,755)
964 %doc eventumrc
965 %attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
966 %attr(755,root,root) %{_bindir}/%{name}
967 %{_appdir}/cli
968
969 %files scm
970 %defattr(644,root,root,755)
971 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
972 %attr(755,root,root) %{_libdir}/scm
This page took 1.253967 seconds and 4 git commands to generate.