]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
up to eventum-3.0.3-305-gb67258d; irc bot requires php pcntl extension
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1.10
6 %define         subver  305
7 %define         githash b67258d
8 %define         php_min_version 5.3.3
9 %include        /usr/lib/rpm/macros.php
10 Summary:        Eventum Issue / Bug tracking system
11 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
12 Name:           eventum
13 Version:        3.0.3
14 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
15 License:        GPL v2
16 Group:          Applications/WWW
17 #Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
18 Source0:        %{name}-%{version}-%{subver}-g%{githash}.tar.gz
19 # Source0-md5:  5937959683a82b3f083f092a8408d037
20 Source1:        %{name}-apache.conf
21 Source2:        %{name}-mail-queue.cron
22 Source3:        %{name}-mail-download.cron
23 Source4:        %{name}-reminder.cron
24 Source5:        %{name}-monitor.cron
25 Source6:        %{name}-cvs.php
26 Source8:        %{name}-irc.init
27 Source9:        %{name}-irc.sysconfig
28 Source10:       sphinx.crontab
29 Source13:       %{name}-router-postfix.sh
30 Source14:       %{name}.logrotate
31 Source15:       %{name}-lighttpd.conf
32 Source16:       http://www.isocra.com/images/updown2.gif
33 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
34 Source17:       %{name}.tmpfiles
35 Patch2:         %{name}-order.patch
36 #Patch3:                group-users.patch
37 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
38 # packaging patches that probably never go upstream
39 Patch100:       %{name}-paths.patch
40 Patch101:       %{name}-cvs-config.patch
41 Patch107:       %{name}-gettext.patch
42 Patch108:       autoload.patch
43 # some tests
44 Patch200:       %{name}-fixed-nav.patch
45 URL:            http://eventum.mysql.org/
46 BuildRequires:  /usr/bin/php
47 BuildRequires:  gettext-devel
48 BuildRequires:  php(core) >= %{php_min_version}
49 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
50 BuildRequires:  rpmbuild(macros) >= 1.654
51 BuildRequires:  sed >= 4.0
52 Requires:       %{name}-base = %{version}-%{release}
53 Requires:       fonts-TTF-RedHat-liberation
54 Requires:       php(core) >= %{php_min_version}
55 Requires:       php(filter)
56 Requires:       php(iconv)
57 Requires:       php(imap)
58 Requires:       php(json)
59 Requires:       php(mbstring)
60 Requires:       php(mysqli)
61 Requires:       php(pcre)
62 Requires:       php(session)
63 Requires:       php-Smarty >= 3.1
64 Requires:       php-Smarty-plugin-gettext
65 Requires:       php-pear-DB
66 Requires:       php-pear-Mail
67 Requires:       php-pear-Mail_Mime
68 Requires:       php-pear-Mail_mimeDecode
69 Requires:       php-pear-Math_Stats
70 Requires:       php-pear-Net_DIME
71 Requires:       php-pear-Net_SMTP
72 Requires:       php-pear-Net_Socket
73 Requires:       php-pear-Net_URL
74 Requires:       php-pear-Net_UserAgent_Detect
75 Requires:       php-pear-PEAR-core
76 Requires:       php-pear-Text_Diff
77 Requires:       php-pear-XML_RPC
78 Requires:       phplot >= 5.8.0
79 Requires:       webapps
80 Requires:       webserver(access)
81 Requires:       webserver(alias)
82 Requires:       webserver(indexfile)
83 Requires:       webserver(php) >= 4.2.0
84 Suggests:       localedb
85 Suggests:       php-pear-Net_LDAP2
86 Conflicts:      logrotate < 3.8.0
87 BuildArch:      noarch
88 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
89
90 %define         _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
91
92 # exclude optional php dependencies
93 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
94
95 %define         _noautoreq      %{_noautophp}
96
97 %define         _libdir         %{_prefix}/lib/%{name}
98 %define         _appdir         %{_datadir}/%{name}
99 %define         _smartydir      %{php_data_dir}/Smarty
100 %define         _webapps        /etc/webapps
101 %define         _webapp         %{name}
102 %define         _webappdir      %{_webapps}/%{_webapp}
103 %define         _sysconfdir     /etc/%{name}
104
105 %description
106 Eventum is a user-friendly and flexible issue tracking system that can
107 be used by a support department to track incoming technical support
108 requests, or by a software development team to quickly organize tasks
109 and bugs. Eventum is used by the MySQL AB Technical Support team, and
110 has allowed us to dramatically improve our response times.
111
112 %description -l pl.UTF-8
113 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
114 może być używany przez dział obsługi do śledzenia przychodzących żądań
115 obsługi technicznej albo przez zespół tworzący oprogramowanie do
116 szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
117 Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
118 reakcji.
119
120 %package base
121 Summary:        Eventum base package
122 Summary(pl.UTF-8):      Podstawowy pakiet Eventum
123 Group:          Applications/WWW
124 Requires(postun):       /usr/sbin/groupdel
125 Requires(postun):       /usr/sbin/userdel
126 Requires(pre):  /bin/id
127 Requires(pre):  /usr/bin/getgid
128 Requires(pre):  /usr/sbin/groupadd
129 Requires(pre):  /usr/sbin/useradd
130 Provides:       group(eventum)
131 Provides:       user(eventum)
132
133 %description base
134 This package contains base directory structure for Eventum.
135
136 %description base -l pl.UTF-8
137 Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
138
139 %package setup
140 Summary:        Eventum setup package
141 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
142 Group:          Applications/WWW
143 Requires:       %{name} = %{version}-%{release}
144
145 %description setup
146 Install this package to configure initial Eventum installation. You
147 should uninstall this package when you're done, as it considered
148 insecure to keep the setup files in place.
149
150 %description setup -l pl.UTF-8
151 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
152 pierwszej instalacji. Potem należy go odinstalować, jako że
153 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
154
155 %package doc
156 Summary:        Eventum documentation and Wiki
157 Group:          Documentation
158
159 %description doc
160 Eventum documentation and copy of Wiki.
161
162 %package mail-queue
163 Summary:        Eventum mail queue process
164 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
165 Group:          Applications/WWW
166 Requires:       %{name} = %{version}-%{release}
167 Requires:       crondaemon
168
169 %description mail-queue
170 Beginning with the first release of Eventum, emails are not directly
171 sent out from the various scripts, but rather added to a mail queue
172 table that is processed by a cron job. If an email cannot be sent, it
173 will be marked as such in the mail queue log, and the cron job script
174 will re-try to send it again the next time it runs.
175
176 This package contains the cron job.
177
178 %description mail-queue -l pl.UTF-8
179 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
180 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
181 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
182 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
183 następnym razem.
184
185 Ten pakiet zawiera zadanie dla crona.
186
187 %package mail-download
188 Summary:        Eventum email download
189 Summary(pl.UTF-8):      Ściąganie poczty Eventum
190 Group:          Applications/WWW
191 Requires:       %{name} = %{version}-%{release}
192 Requires:       crondaemon
193
194 %description mail-download
195 In order for Eventum's email integration feature to work, you need to
196 setup a cron job to run the script every so often.
197
198 This package contains the cron job.
199
200 %description mail-download -l pl.UTF-8
201 Aby integracja poczty elektronicznej w Eventum działała, trzeba
202 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
203 często.
204
205 Ten pakiet zawiera zadanie dla crona.
206
207 %package reminder
208 Summary:        Eventum Reminder System
209 Summary(pl.UTF-8):      System przypominania dla Eventum
210 Group:          Applications/WWW
211 Requires:       %{name} = %{version}-%{release}
212 Requires:       crondaemon
213
214 %description reminder
215 The reminder system was designed with the objective as serving as a
216 safe net for issues that need attention. Depending on what
217 configuration you create, you may have several reminders (or alerts)
218 be sent out whenever an issue needs attention, for whatever parameter
219 you may deem necessary.
220
221 This package contains the cron job.
222
223 %description reminder -l pl.UTF-8
224 System przypominania został zaprojektowany tak, aby służył jako
225 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
226 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
227 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
228 uważać za potrzebny.
229
230 Ten pakiet zawiera zadanie dla crona.
231
232 %package monitor
233 Summary:        Eventum Heartbeat Monitor
234 Summary(pl.UTF-8):      Monitor życia dla Eventum
235 Group:          Applications/WWW
236 Requires:       %{name} = %{version}-%{release}
237 Requires:       crondaemon
238 Requires:       php(posix)
239
240 %description monitor
241 The heartbeat monitor is a feature designed for the administrator that
242 wants to be alerted whenever a common problem in Eventum is detected,
243 like the database server not being available anymore, or maybe when
244 the recommended permissions for certain configuration files are
245 changed.
246
247 Please note that before running the heartbeat monitor, you may need to
248 customize some of the checks to be appropriate for your own system,
249 particularly the permission and file checks on
250 Monitor::checkConfiguration().
251
252 This package contains the cron job.
253
254 %description monitor -l pl.UTF-8
255 Monitor życia to funkcjonalność zaprojektowana dla administratora
256 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
257 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
258 do plików konfiguracyjnych.
259
260 Należy zauważyć, że przed uruchomieniem tego monitora może być
261 konieczne dostosowanie niektórych testów do systemu, w szczególności
262 testów uprawnień i plików w Monitor::checkConfiguration().
263
264 Ten pakiet zawiera zadanie dla crona.
265
266 %package route-drafts
267 Summary:        Eventum Draft Routing
268 Summary(pl.UTF-8):      Przekazywanie szkiców dla Eventum
269 Group:          Applications/WWW
270 Requires:       %{name} = %{version}-%{release}
271 Requires:       eventum(router)
272
273 %description route-drafts
274 The draft routing feature is used to automatically associate a thread
275 of drafts into an Eventum issue. By setting up Postfix to deliver
276 emails sent to a specific address (usually draft-<number>@<domain>) to
277 the above script, users are able to send drafts written in their mail
278 client to be stored in Eventum. These drafts will NOT broadcasted to
279 the notification list.
280
281 %description route-drafts -l pl.UTF-8
282 Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
283 problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
284 wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
285 skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
286 kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
287 na listę powiadomień.
288
289 %package route-emails
290 Summary:        Eventum Email Routing
291 Summary(pl.UTF-8):      Przekazywanie poczty dla Eventum
292 Group:          Applications/WWW
293 Requires:       %{name} = %{version}-%{release}
294 Requires:       eventum(router)
295
296 %description route-emails
297 The email routing feature is used to automatically associate a thread
298 of emails into an Eventum issue. By setting up Postfix to deliver
299 emails sent to a specific address (usually issue-<number>@<domain>) to
300 the above script, users are able to use their email clients to reply
301 to emails coming from Eventum, and those replies will be automatically
302 associated with the issue and broadcasted to the entire notification
303 list.
304
305 %description route-emails -l pl.UTF-8
306 Funkcjonalność przekazywania poczty służy do automatycznego wiązania
307 wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
308 aby dostarczał listy wysyłane na pewien adres (zwykle
309 issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
310 używać klientów pocztowych do odpowiadania na listy przychodzące z
311 Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
312 rozprowadzane do całej listy ogłoszeniowej.
313
314 %package route-notes
315 Summary:        Eventum Note Routing
316 Summary(pl.UTF-8):      Przekazywanie notatek dla Eventum
317 Group:          Applications/WWW
318 Requires:       %{name} = %{version}-%{release}
319 Requires:       eventum(router)
320
321 %description route-notes
322 The note routing feature is used to automatically associate a thread
323 of notes into an Eventum issue. By setting up Postfix to deliver
324 emails sent to a specific address (usually note-<number>@<domain>) to
325 the above script, users are able to use their email clients to reply
326 to internal notes coming from Eventum, and those replies will be
327 automatically associated with the issue and broadcasted to the
328 notification list staff members.
329
330 %description route-notes -l pl.UTF-8
331 Funkcjonalność przekazywania notatek służy do automatycznego wiązania
332 wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
333 dostarczał listy wysyłane na pewien adres (zwykle
334 note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
335 używać klientów pocztowych do odpowiadania na wewnętrzne notatki
336 pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
337 sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
338
339 %package router-postfix
340 Summary:        Eventum Mail Routing - Postfix
341 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
342 Group:          Applications/Mail
343 Requires:       %{name} = %{version}-%{release}
344 Requires:       postfix
345 Provides:       eventum(router)
346 Obsoletes:      eventum(router)
347
348 %description router-postfix
349 This package provides way of routing notes and emails back to Eventum
350 via Postfix.
351
352 The Postfix configuration instructions you can find from
353 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
354
355 %description router-postfix -l pl.UTF-8
356 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
357 przez Postfiksa.
358
359 Opis konfiguracji Postfiksa można znaleźć pod adresem
360 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
361
362 %package irc
363 Summary:        Eventum IRC Notification Bot
364 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
365 Group:          Applications/WWW
366 Requires(post,preun):   /sbin/chkconfig
367 Requires:       %{name} = %{version}-%{release}
368 Requires:       php(pcntl)
369 Requires:       php(sockets)
370 Requires:       php-pear-Net_SmartIRC >= 1.1
371 Requires:       rc-scripts >= 0.4.0.18
372
373 %description irc
374 The IRC notification bot is a nice feature for remote teams that want
375 to handle issues and want to have a quick and easy way to get simple
376 notifications. Right now the bot notifies of the following actions:
377 - New Issues
378 - Blocked emails
379 - Issues that got their assignment list changed
380
381 NOTE: You will need to manually edit the bot.php script to set your
382 appropriate preferences, like IRC server and channel that the bot
383 should join.
384
385 %description irc -l pl.UTF-8
386 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
387 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
388 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
389 następujących zdarzeniach:
390 - nowych sprawach
391 - zablokowanych listach
392 - sprawach, dla których zmieniła się lista powiązań
393
394 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
395 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
396
397 %package cli
398 Summary:        Eventum command-line interface
399 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
400 Group:          Applications/WWW
401 Requires:       %{name}-base = %{version}-%{release}
402 Requires:       php(core) >= %{php_min_version}
403 Requires:       php(phar)
404 Requires:       php-pear-XML_RPC
405
406 %description cli
407 The Eventum command-line interface allows you to access most of the
408 features of the web interface straight from your command shell.
409
410 %description cli -l pl.UTF-8
411 Interfejs linii poleceń Eventum pozwala na dostęp do większości
412 funkcji interfejsu WWW prosto z linii poleceń powłoki.
413
414 %package scm
415 Summary:        Eventum SCM integration
416 Summary(pl.UTF-8):      Integracja SCM dla Eventum
417 Group:          Applications/WWW
418 Requires:       php(core) >= %{php_min_version}
419 Requires:       php(json)
420 Requires:       php(pcre)
421 Requires:       php(spl)
422 Suggests:       cvs
423 Suggests:       git-core
424 Suggests:       php(openssl)
425 Suggests:       subversion
426
427 %description scm
428 This feature allows your software development teams to integrate your
429 Source Control Management system with your Issue Tracking System.
430
431 The integration is implemented in such a way that it will be forward
432 compatible with pretty much any SCM system, such as CVS.
433
434 For installation see
435 </eventum/help.php?topic=scm_integration_installation>.
436
437 %description scm -l pl.UTF-8
438 Ten pakiet pozwala zespołom programistów na integrację systemu
439 zarządzania źródłami (SCM - Source Control Management) z systemem
440 śledzenia spraw.
441
442 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
443 prawie każdym systemem SCM, jak np. CVS.
444
445 Szczegóły na temat instalacji można przeczytać pod
446 </eventum/help.php?topic=scm_integration_installation>.
447
448 %package sphinx
449 Summary:        Eventum Sphinx Search
450 Group:          Applications/WWW
451 Requires:       %{name} = %{version}-%{release}
452 Requires:       crondaemon
453 Requires:       sphinx
454
455 %description sphinx
456 Sphinx search integration for Eventum.
457
458 This package contains the cron job.
459
460 %prep
461 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
462
463 mv docs/examples .
464
465 # GPL v2
466 rm docs/COPYING
467
468 # bug fixes / features
469 %{?with_order:%patch2 -p1}
470 #%patch3 -p0
471 #%patch4 -p1
472
473 %{?with_order:cp -p %{SOURCE16} htdocs/images}
474
475 #%patch200 -p1
476
477 # produce default sphinx config
478 # must be run before paths.patch
479 %if 0
480 cat <<'EOF' > config/config.php
481 <?php
482 define('APP_SQL_DBTYPE', 'mysql');
483 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
484 define('APP_SQL_DBPORT', 3306);
485 define('APP_SQL_DBNAME', 'eventum');
486 define('APP_SQL_DBUSER', 'mysql');
487 define('APP_SQL_DBPASS', '');
488 define('APP_TABLE_PREFIX', 'eventum_');
489 EOF
490 php config/sphinx.conf.php > config/sphinx.conf
491 rm -f config/config.php
492 %endif
493
494 # packaging
495 %patch100 -p1
496 %patch101 -p1
497 %patch107 -p1
498 %patch108 -p1
499
500 # cleanup vendor. keep only needed libraries.
501 # (the rest are packaged with system packages)
502 mv vendor vendor.dist
503 vendor() {
504         local path dir
505         for path; do
506                 dir=$(dirname $path)
507                 test -d vendor/$dir || mkdir -p vendor/$dir
508                 mv vendor.dist/$path vendor/$path
509         done
510 }
511 vendor autoload.php
512 vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
513 vendor composer/ClassLoader.php
514 vendor ircmaxell/{password-compat,random-lib,security-lib}
515 vendor zendframework/zend-config
516
517 # remove backups from patching as we use globs to package files to buildroot
518 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
519
520 %build
521 %{__make} -C localization
522
523 %install
524 rm -rf $RPM_BUILD_ROOT
525 install -d \
526         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
527         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
528         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
529         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
530         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
531         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
532         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
533
534 %{__make} install-eventum install-cli install-scm install-localization \
535         sysconfdir=%{_webappdir} \
536         localedir=%{_localedir} \
537         DESTDIR=$RPM_BUILD_ROOT
538
539 ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
540
541 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
542
543 # unsupported locale
544 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
545
546 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
547 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
548
549 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
550
551 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
552 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
553 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
554 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
555
556 install -d $RPM_BUILD_ROOT/etc/sphinx
557 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
558 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
559
560 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
561 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
562 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
563 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
564 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
565
566 cp -p config/irc_config.dist.php $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
567
568 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
569 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
570
571 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
572
573 # postfix router
574 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
575
576 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
577
578 %find_lang %{name}
579
580 # scm
581 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
582
583 %clean
584 rm -rf $RPM_BUILD_ROOT
585
586 %pre
587 %addusertogroup http %{name}
588
589 %post
590 # greate empty ghost files
591 for a in cli.log errors.log irc_bot.log login_attempts.log; do
592         if [ ! -f /var/log/%{name}/$a ]; then
593                 install -m 0620 -o root -g eventum /dev/null /var/log/%{name}/$a
594         fi
595 done
596
597 # run database update if configured
598 test -s %{_webappdir}/config.php && \
599 %{_appdir}/upgrade/update-database.php || :
600
601 # nuke Smarty templates cache after upgrade
602 rm -f /var/cache/eventum/*.php
603
604 # Restart webserver on upgrade to get .mo translations reloaded.
605 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
606 %php_webserver_restart
607
608 %preun
609 if [ "$1" = "0" ]; then
610         # nuke cache
611         rm -f /var/cache/eventum/*.php 2>/dev/null || :
612 fi
613
614 %pre base
615 %groupadd -P %{name}-base -g 146 %{name}
616 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
617
618 %postun base
619 if [ "$1" = "0" ]; then
620         %userremove %{name}
621         %groupremove %{name}
622 fi
623
624 %post setup
625 chmod 660 %{_webappdir}/{config,private_key}.php
626 chown root:http %{_webappdir}/{config,private_key}.php
627
628 %postun setup
629 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
630         chmod 640 %{_webappdir}/{config,private_key}.php
631         chown root:http %{_webappdir}/{config,private_key}.php
632 fi
633
634 %post irc
635 /sbin/chkconfig --add eventum-irc
636 %service eventum-irc restart "Eventum IRC Bot"
637
638 %preun irc
639 if [ "$1" = 0 ]; then
640         %service eventum-irc stop
641         /sbin/chkconfig --del eventum-irc
642 fi
643
644 %triggerin -- apache1 < 1.3.37-3, apache1-base
645 %webapp_register apache %{_webapp}
646
647 %triggerun -- apache1 < 1.3.37-3, apache1-base
648 %webapp_unregister apache %{_webapp}
649
650 %triggerin -- apache < 2.2.0, apache-base
651 %webapp_register httpd %{_webapp}
652
653 %triggerun -- apache < 2.2.0, apache-base
654 %webapp_unregister httpd %{_webapp}
655
656 %triggerin -- lighttpd
657 %webapp_register lighttpd %{_webapp}
658
659 %triggerun -- lighttpd
660 %webapp_unregister lighttpd %{_webapp}
661
662 %triggerpostun -- %{name} < 3.0.0-0.2
663 for f in /etc/cron.d/eventum-*; do
664         # crontabs moved to bin
665         %{__sed} -i -e '
666                 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
667                 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
668                 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
669                 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
670         ' $f
671 done
672
673 %files -f %{name}.lang
674 %defattr(644,root,root,755)
675 %attr(751,root,root) %dir %{_webappdir}
676 %attr(751,root,root) %dir %{_webappdir}/custom_field
677 %attr(751,root,root) %dir %{_webappdir}/templates
678 %attr(751,root,root) %dir %{_webappdir}/workflow
679 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
680 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
681 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
682 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
683 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
684 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
685 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
686
687 %dir %attr(731,root,http) /var/log/%{name}
688 %attr(620,root,http) %ghost /var/log/%{name}/*
689 %dir %attr(750,root,root) /var/log/archive/%{name}
690 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
691
692 %{_appdir}/config
693
694 %dir %{_appdir}/bin
695 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
696
697 %{_appdir}/autoload.php
698 %{_appdir}/init.php
699 %dir %{_appdir}/htdocs
700 %{_appdir}/htdocs/*.php
701 %{_appdir}/htdocs/*.ico
702 %{_appdir}/htdocs/ajax
703 %{_appdir}/htdocs/css
704 %{_appdir}/htdocs/customer
705 %{_appdir}/htdocs/images
706 %{_appdir}/htdocs/js
707 %{_appdir}/htdocs/manage
708 %{_appdir}/htdocs/misc
709 %{_appdir}/htdocs/reports
710 %{_appdir}/htdocs/rpc
711 %{_appdir}/htdocs/components
712 %{_appdir}/templates
713
714 %dir %{_appdir}/upgrade
715 %{_appdir}/upgrade/flush_compiled_templates.php
716 %{_appdir}/upgrade/*.sql
717 %attr(755,root,root) %{_appdir}/upgrade/update-database.php
718 %attr(755,root,root) %{_appdir}/upgrade/ldap_import.php
719 %attr(755,root,root) %{_appdir}/upgrade/ldap_update_users.php
720 %attr(755,root,root) %{_appdir}/upgrade/scm_trac_import.php
721 %{_appdir}/upgrade/patches
722
723 %{_appdir}/vendor
724
725 %dir %{_appdir}/lib
726 %{_appdir}/lib/eventum
727 %exclude %{_appdir}/lib/eventum/class.monitor.php
728
729 %{systemdtmpfilesdir}/%{name}.conf
730 %dir %attr(730,root,http) /var/run/%{name}
731 %dir %attr(730,root,http) /var/cache/%{name}
732
733 %files base
734 %defattr(644,root,root,755)
735 %attr(751,root,root) %dir %{_sysconfdir}
736 %dir %{_libdir}
737 %dir %{_appdir}
738 %dir /var/lib/%{name}
739 # saved mail copies
740 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
741 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
742 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
743
744 %files setup
745 %defattr(644,root,root,755)
746 %{_appdir}/htdocs/setup
747
748 %files doc
749 %defattr(644,root,root,755)
750 %doc docs/*
751 %{_examplesdir}/%{name}-%{version}
752
753 %files mail-queue
754 %defattr(644,root,root,755)
755 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
756 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
757 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
758
759 %files mail-download
760 %defattr(644,root,root,755)
761 %attr(755,root,root) %{_appdir}/bin/download_emails.php
762 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
763
764 %files reminder
765 %defattr(644,root,root,755)
766 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
767 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
768
769 %files monitor
770 %defattr(644,root,root,755)
771 %{_appdir}/lib/eventum/class.monitor.php
772 %attr(755,root,root) %{_appdir}/bin/monitor.php
773 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
774
775 %files route-drafts
776 %defattr(644,root,root,755)
777 %attr(755,root,root) %{_appdir}/bin/route_drafts.php
778
779 %files route-emails
780 %defattr(644,root,root,755)
781 %attr(755,root,root) %{_appdir}/bin/route_emails.php
782
783 %files route-notes
784 %defattr(644,root,root,755)
785 %attr(755,root,root) %{_appdir}/bin/route_notes.php
786
787 %files router-postfix
788 %defattr(644,root,root,755)
789 %attr(755,root,root) %{_libdir}/router-postfix
790
791 %files irc
792 %defattr(644,root,root,755)
793 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
794 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
795 %attr(755,root,root) %{_appdir}/bin/irc-bot.php
796 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
797
798 %files cli
799 %defattr(644,root,root,755)
800 %doc cli/eventumrc
801 %attr(755,root,root) %{_bindir}/%{name}
802
803 %files scm
804 %defattr(644,root,root,755)
805 %attr(751,root,root) %dir %{_sysconfdir}
806 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
807 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
808 %attr(755,root,root) %{_sbindir}/eventum-git-hook
809 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
810 %attr(755,root,root) %{_sbindir}/helpers.php
811
812 %files sphinx
813 %defattr(644,root,root,755)
814 %{_webappdir}/sphinx.conf.php
815 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
816 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.102276 seconds and 4 git commands to generate.