]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
preparations for 3.0
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 #
9 # Conditional build:
10 %bcond_with     order   # with experimental order patch
11
12 %define         php_min_version 5.3.3
13 %include        /usr/lib/rpm/macros.php
14 Summary:        Eventum Issue / Bug tracking system
15 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
16 Name:           eventum
17 Version:        3.0.0
18 Release:        0.1
19 License:        GPL v2
20 Group:          Applications/WWW
21 Source0:        %{name}-2.4.0-pre1-474-g45f7853.tar.gz
22 # Source0-md5:  acfe413a3a9b530b301cf37e0bb43064
23 Source1:        %{name}-apache.conf
24 Source2:        %{name}-mail-queue.cron
25 Source3:        %{name}-mail-download.cron
26 Source4:        %{name}-reminder.cron
27 Source5:        %{name}-monitor.cron
28 Source6:        %{name}-cvs.php
29 Source7:        %{name}-irc.php
30 Source8:        %{name}-irc.init
31 Source9:        %{name}-irc.sysconfig
32 Source10:       sphinx.crontab
33 Source13:       %{name}-router-postfix.sh
34 Source14:       %{name}.logrotate
35 Source15:       %{name}-lighttpd.conf
36 Source16:       http://www.isocra.com/images/updown2.gif
37 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
38 Source17:       %{name}.tmpfiles
39 #Patch0:                %{name}-lf.patch
40 Patch2:         %{name}-order.patch
41 #Patch3:                group-users.patch
42 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
43 # packaging patches that probably never go upstream
44 Patch100:       %{name}-paths.patch
45 Patch101:       %{name}-cvs-config.patch
46 Patch105:       %{name}-bot-reconnect.patch
47 Patch107:       %{name}-gettext.patch
48 # some tests
49 Patch200:       %{name}-fixed-nav.patch
50 URL:            http://eventum.mysql.org/
51 BuildRequires:  /usr/bin/php
52 BuildRequires:  gettext-tools
53 BuildRequires:  php(core) >= %{php_min_version}
54 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
55 BuildRequires:  rpmbuild(macros) >= 1.654
56 BuildRequires:  sed >= 4.0
57 Requires:       %{name}-base = %{version}-%{release}
58 Requires:       Smarty >= 2.6.10-4
59 Requires:       Smarty-plugin-gettext
60 Requires:       php(core) >= %{php_min_version}
61 Requires:       php(filter)
62 Requires:       php(gd)
63 Requires:       php(iconv)
64 Requires:       php(imap)
65 Requires:       php(json)
66 Requires:       php(mbstring)
67 Requires:       php(mysql)
68 Requires:       php(pcre)
69 Requires:       php(session)
70 Requires:       php-pear-DB
71 Requires:       php-pear-Date
72 Requires:       php-pear-Mail
73 Requires:       php-pear-Mail_Mime
74 Requires:       php-pear-Mail_mimeDecode
75 Requires:       php-pear-Math_Stats
76 Requires:       php-pear-Net_DIME
77 Requires:       php-pear-Net_SMTP
78 Requires:       php-pear-Net_Socket
79 Requires:       php-pear-Net_URL
80 Requires:       php-pear-Net_UserAgent_Detect
81 Requires:       php-pear-PEAR-core
82 Requires:       php-pear-Text_Diff
83 Requires:       php-pear-XML_RPC
84 Requires:       webapps
85 Requires:       webserver(access)
86 Requires:       webserver(alias)
87 Requires:       webserver(indexfile)
88 Requires:       webserver(php) >= 4.2.0
89 Suggests:       localedb
90 Suggests:       php-pear-Net_LDAP2
91 Conflicts:      logrotate < 3.8.0
92 BuildArch:      noarch
93 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94
95 %define         _noautoreq_pear ../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* jpgraph_dir.php .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.php
96
97 # exclude optional php dependencies
98 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
99
100 %define         _noautoreq      %{_noautophp}
101
102 %define         _libdir         %{_prefix}/lib/%{name}
103 %define         _appdir         %{_datadir}/%{name}
104 %define         _smartydir      %{php_data_dir}/Smarty
105 %define         _webapps        /etc/webapps
106 %define         _webapp         %{name}
107 %define         _webappdir      %{_webapps}/%{_webapp}
108 %define         _sysconfdir     /etc/%{name}
109
110 %description
111 Eventum is a user-friendly and flexible issue tracking system that can
112 be used by a support department to track incoming technical support
113 requests, or by a software development team to quickly organize tasks
114 and bugs. Eventum is used by the MySQL AB Technical Support team, and
115 has allowed us to dramatically improve our response times.
116
117 %description -l pl.UTF-8
118 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
119 może być używany przez dział obsługi do śledzenia przychodzących żądań
120 obsługi technicznej albo przez zespół tworzący oprogramowanie do
121 szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
122 Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
123 reakcji.
124
125 %package base
126 Summary:        Eventum base package
127 Summary(pl.UTF-8):      Podstawowy pakiet Eventum
128 Group:          Applications/WWW
129 Requires(postun):       /usr/sbin/groupdel
130 Requires(postun):       /usr/sbin/userdel
131 Requires(pre):  /bin/id
132 Requires(pre):  /usr/bin/getgid
133 Requires(pre):  /usr/sbin/groupadd
134 Requires(pre):  /usr/sbin/useradd
135 Provides:       group(eventum)
136 Provides:       user(eventum)
137
138 %description base
139 This package contains base directory structure for Eventum.
140
141 %description base -l pl.UTF-8
142 Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
143
144 %package setup
145 Summary:        Eventum setup package
146 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
147 Group:          Applications/WWW
148 Requires:       %{name} = %{version}-%{release}
149
150 %description setup
151 Install this package to configure initial Eventum installation. You
152 should uninstall this package when you're done, as it considered
153 insecure to keep the setup files in place.
154
155 %description setup -l pl.UTF-8
156 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
157 pierwszej instalacji. Potem należy go odinstalować, jako że
158 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
159
160 %package mail-queue
161 Summary:        Eventum mail queue process
162 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
163 Group:          Applications/WWW
164 Requires:       %{name} = %{version}-%{release}
165 Requires:       crondaemon
166
167 %description mail-queue
168 Beginning with the first release of Eventum, emails are not directly
169 sent out from the various scripts, but rather added to a mail queue
170 table that is processed by a cron job. If an email cannot be sent, it
171 will be marked as such in the mail queue log, and the cron job script
172 will re-try to send it again the next time it runs.
173
174 This package contains the cron job.
175
176 %description mail-queue -l pl.UTF-8
177 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
178 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
179 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
180 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
181 następnym razem.
182
183 Ten pakiet zawiera zadanie dla crona.
184
185 %package mail-download
186 Summary:        Eventum email download
187 Summary(pl.UTF-8):      Ściąganie poczty Eventum
188 Group:          Applications/WWW
189 Requires:       %{name} = %{version}-%{release}
190 Requires:       crondaemon
191
192 %description mail-download
193 In order for Eventum's email integration feature to work, you need to
194 setup a cron job to run the script every so often.
195
196 This package contains the cron job.
197
198 %description mail-download -l pl.UTF-8
199 Aby integracja poczty elektronicznej w Eventum działała, trzeba
200 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
201 często.
202
203 Ten pakiet zawiera zadanie dla crona.
204
205 %package reminder
206 Summary:        Eventum Reminder System
207 Summary(pl.UTF-8):      System przypominania dla Eventum
208 Group:          Applications/WWW
209 Requires:       %{name} = %{version}-%{release}
210 Requires:       crondaemon
211
212 %description reminder
213 The reminder system was designed with the objective as serving as a
214 safe net for issues that need attention. Depending on what
215 configuration you create, you may have several reminders (or alerts)
216 be sent out whenever an issue needs attention, for whatever parameter
217 you may deem necessary.
218
219 This package contains the cron job.
220
221 %description reminder -l pl.UTF-8
222 System przypominania został zaprojektowany tak, aby służył jako
223 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
224 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
225 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
226 uważać za potrzebny.
227
228 Ten pakiet zawiera zadanie dla crona.
229
230 %package monitor
231 Summary:        Eventum Heartbeat Monitor
232 Summary(pl.UTF-8):      Monitor życia dla Eventum
233 Group:          Applications/WWW
234 Requires:       %{name} = %{version}-%{release}
235 Requires:       crondaemon
236 Requires:       php(posix)
237
238 %description monitor
239 The heartbeat monitor is a feature designed for the administrator that
240 wants to be alerted whenever a common problem in Eventum is detected,
241 like the database server not being available anymore, or maybe when
242 the recommended permissions for certain configuration files are
243 changed.
244
245 Please note that before running the heartbeat monitor, you may need to
246 customize some of the checks to be appropriate for your own system,
247 particularly the permission and file checks on
248 Monitor::checkConfiguration().
249
250 This package contains the cron job.
251
252 %description monitor -l pl.UTF-8
253 Monitor życia to funkcjonalność zaprojektowana dla administratora
254 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
255 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
256 do plików konfiguracyjnych.
257
258 Należy zauważyć, że przed uruchomieniem tego monitora może być
259 konieczne dostosowanie niektórych testów do systemu, w szczególności
260 testów uprawnień i plików w Monitor::checkConfiguration().
261
262 Ten pakiet zawiera zadanie dla crona.
263
264 %package route-drafts
265 Summary:        Eventum Draft Routing
266 Summary(pl.UTF-8):      Przekazywanie szkiców dla Eventum
267 Group:          Applications/WWW
268 Requires:       %{name} = %{version}-%{release}
269 Requires:       eventum(router)
270
271 %description route-drafts
272 The draft routing feature is used to automatically associate a thread
273 of drafts into an Eventum issue. By setting up Postfix to deliver
274 emails sent to a specific address (usually draft-<number>@<domain>) to
275 the above script, users are able to send drafts written in their mail
276 client to be stored in Eventum. These drafts will NOT broadcasted to
277 the notification list.
278
279 %description route-drafts -l pl.UTF-8
280 Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
281 problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
282 wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
283 skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
284 kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
285 na listę powiadomień.
286
287 %package route-emails
288 Summary:        Eventum Email Routing
289 Summary(pl.UTF-8):      Przekazywanie poczty dla Eventum
290 Group:          Applications/WWW
291 Requires:       %{name} = %{version}-%{release}
292 Requires:       eventum(router)
293
294 %description route-emails
295 The email routing feature is used to automatically associate a thread
296 of emails into an Eventum issue. By setting up Postfix to deliver
297 emails sent to a specific address (usually issue-<number>@<domain>) to
298 the above script, users are able to use their email clients to reply
299 to emails coming from Eventum, and those replies will be automatically
300 associated with the issue and broadcasted to the entire notification
301 list.
302
303 %description route-emails -l pl.UTF-8
304 Funkcjonalność przekazywania poczty służy do automatycznego wiązania
305 wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
306 aby dostarczał listy wysyłane na pewien adres (zwykle
307 issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
308 używać klientów pocztowych do odpowiadania na listy przychodzące z
309 Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
310 rozprowadzane do całej listy ogłoszeniowej.
311
312 %package route-notes
313 Summary:        Eventum Note Routing
314 Summary(pl.UTF-8):      Przekazywanie notatek dla Eventum
315 Group:          Applications/WWW
316 Requires:       %{name} = %{version}-%{release}
317 Requires:       eventum(router)
318
319 %description route-notes
320 The note routing feature is used to automatically associate a thread
321 of notes into an Eventum issue. By setting up Postfix to deliver
322 emails sent to a specific address (usually note-<number>@<domain>) to
323 the above script, users are able to use their email clients to reply
324 to internal notes coming from Eventum, and those replies will be
325 automatically associated with the issue and broadcasted to the
326 notification list staff members.
327
328 %description route-notes -l pl.UTF-8
329 Funkcjonalność przekazywania notatek służy do automatycznego wiązania
330 wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
331 dostarczał listy wysyłane na pewien adres (zwykle
332 note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
333 używać klientów pocztowych do odpowiadania na wewnętrzne notatki
334 pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
335 sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
336
337 %package router-postfix
338 Summary:        Eventum Mail Routing - Postfix
339 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
340 Group:          Applications/Mail
341 Requires:       %{name} = %{version}-%{release}
342 Requires:       postfix
343 Provides:       eventum(router)
344 Obsoletes:      eventum(router)
345
346 %description router-postfix
347 This package provides way of routing notes and emails back to Eventum
348 via Postfix.
349
350 The Postfix configuration instructions you can find from
351 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
352
353 %description router-postfix -l pl.UTF-8
354 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
355 przez Postfiksa.
356
357 Opis konfiguracji Postfiksa można znaleźć pod adresem
358 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
359
360 %package irc
361 Summary:        Eventum IRC Notification Bot
362 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
363 Group:          Applications/WWW
364 Requires(post,preun):   /sbin/chkconfig
365 Requires:       %{name} = %{version}-%{release}
366 Requires:       php(sockets)
367 Requires:       php-pear-Net_SmartIRC
368 Requires:       rc-scripts >= 0.4.0.18
369
370 %description irc
371 The IRC notification bot is a nice feature for remote teams that want
372 to handle issues and want to have a quick and easy way to get simple
373 notifications. Right now the bot notifies of the following actions:
374 - New Issues
375 - Blocked emails
376 - Issues that got their assignment list changed
377
378 NOTE: You will need to manually edit the bot.php script to set your
379 appropriate preferences, like IRC server and channel that the bot
380 should join.
381
382 %description irc -l pl.UTF-8
383 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
384 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
385 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
386 następujących zdarzeniach:
387 - nowych sprawach
388 - zablokowanych listach
389 - sprawach, dla których zmieniła się lista powiązań
390
391 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
392 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
393
394 %package cli
395 Summary:        Eventum command-line interface
396 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
397 Group:          Applications/WWW
398 Requires:       %{name}-base = %{version}-%{release}
399 Requires:       php(core) >= %{php_min_version}
400 Requires:       php-pear-XML_RPC
401
402 %description cli
403 The Eventum command-line interface allows you to access most of the
404 features of the web interface straight from your command shell.
405
406 %description cli -l pl.UTF-8
407 Interfejs linii poleceń Eventum pozwala na dostęp do większości
408 funkcji interfejsu WWW prosto z linii poleceń powłoki.
409
410 %package scm
411 Summary:        Eventum SCM integration
412 Summary(pl.UTF-8):      Integracja SCM dla Eventum
413 Group:          Applications/WWW
414 Requires:       %{name}-base = %{version}-%{release}
415 Requires:       php(core) >= %{php_min_version}
416 Requires:       php(pcre)
417
418 %description scm
419 This feature allows your software development teams to integrate your
420 Source Control Management system with your Issue Tracking System.
421
422 The integration is implemented in such a way that it will be forward
423 compatible with pretty much any SCM system, such as CVS.
424
425 For installation see
426 </eventum/help.php?topic=scm_integration_installation>.
427
428 %description scm -l pl.UTF-8
429 Ten pakiet pozwala zespołom programistów na integrację systemu
430 zarządzania źródłami (SCM - Source Control Management) z systemem
431 śledzenia spraw.
432
433 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
434 prawie każdym systemem SCM, jak np. CVS.
435
436 Szczegóły na temat instalacji można przeczytać pod
437 </eventum/help.php?topic=scm_integration_installation>.
438
439 %package sphinx
440 Summary:        Eventum Sphinx Search
441 Group:          Applications/WWW
442 Requires:       %{name} = %{version}-%{release}
443 Requires:       crondaemon
444 Requires:       sphinx
445
446 %description sphinx
447 Sphinx search integration for Eventum.
448
449 This package contains the cron job.
450
451 %prep
452 %setup -qc
453 mv eventum-*/* .
454
455 # GPL v2
456 rm docs/COPYING
457
458 # bug fixes / features
459 #%patch0 -p1
460 %{?with_order:%patch2 -p1}
461 #%patch3 -p0
462 #%patch4 -p1
463
464 %{?with_order:cp -p %{SOURCE16} htdocs/images}
465
466 #%patch200 -p1
467
468 # produce default sphinx config
469 # must be run before paths.patch
470 %if 0
471 cat <<'EOF' > config/config.php
472 <?php
473 define('APP_SQL_DBTYPE', 'mysql');
474 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
475 define('APP_SQL_DBPORT', 3306);
476 define('APP_SQL_DBNAME', 'eventum');
477 define('APP_SQL_DBUSER', 'mysql');
478 define('APP_SQL_DBPASS', '');
479 define('APP_TABLE_PREFIX', 'eventum_');
480 EOF
481 php config/sphinx.conf.php > config/sphinx.conf
482 rm -f config/config.php
483 %endif
484
485 # packaging
486 %patch100 -p1
487 #%patch101 -p1
488 %patch105 -p1
489 %patch107 -p1
490
491 %{__sed} -i -e "
492 s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
493 " upgrade/{*/,}*.php
494
495 # remove backups from patching as we use globs to package files to buildroot
496 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
497
498 %build
499 %{__make} -C localization
500
501 %install
502 rm -rf $RPM_BUILD_ROOT
503 install -d \
504         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
505         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
506         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
507         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
508         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
509         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
510         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
511
512 %{__make} install-eventum install-irc install-scm install-jpgraph install-localization \
513         sysconfdir=%{_webappdir} \
514         localedir=%{_localedir} \
515         DESTDIR=$RPM_BUILD_ROOT
516
517 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
518
519 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
520 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
521 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
522 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
523
524 install -d $RPM_BUILD_ROOT/etc/sphinx
525 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
526 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
527
528 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
529 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
530 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
531 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
532 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
533
534 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
535
536 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
537 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
538
539 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
540
541 # postfix router
542 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
543
544 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
545
546 %find_lang %{name}
547
548 # scm
549 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
550
551 # old compat
552 #ln -s %{_sbindir}/eventum-cvs-hook $RPM_BUILD_ROOT%{_libdir}/process_cvs_commits
553 #ln -s %{_sbindir}/eventum-svn-hook $RPM_BUILD_ROOT%{_libdir}/process_svn_commits
554
555 # skip pear for cli
556 #rm -r $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
557 #cp -a cli/lib/eventum $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
558
559 %clean
560 rm -rf $RPM_BUILD_ROOT
561
562 %pre
563 %addusertogroup http %{name}
564
565 %post
566 # greate empty ghost files
567 for a in cli.log errors.log irc_bot.log login_attempts.log; do
568         if [ ! -f /var/log/%{name}/$a ]; then
569                 install -m 0620 -o root -g eventum /dev/null /var/log/%{name}/$a
570         fi
571 done
572
573 # run database update if configured
574 test -s %{_webappdir}/config.php && \
575 %{_appdir}/upgrade/update-database.php || :
576
577 # nuke Smarty templates cache after upgrade
578 rm -f /var/cache/eventum/*.php
579
580 # Restart webserver on upgrade to get .mo translations reloaded.
581 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
582 %php_webserver_restart
583
584 %preun
585 if [ "$1" = "0" ]; then
586         # nuke cache
587         rm -f /var/cache/eventum/*.php 2>/dev/null || :
588 fi
589
590 %pre base
591 %groupadd -P %{name}-base -g 146 %{name}
592 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
593
594 %postun base
595 if [ "$1" = "0" ]; then
596         %userremove %{name}
597         %groupremove %{name}
598 fi
599
600 %post setup
601 chmod 660 %{_webappdir}/{config,private_key}.php
602 chown root:http %{_webappdir}/{config,private_key}.php
603
604 %postun setup
605 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
606         chmod 640 %{_webappdir}/{config,private_key}.php
607         chown root:http %{_webappdir}/{config,private_key}.php
608 fi
609
610 %post irc
611 /sbin/chkconfig --add eventum-irc
612 %service eventum-irc restart "Eventum IRC Bot"
613
614 %preun irc
615 if [ "$1" = 0 ]; then
616         %service eventum-irc stop
617         /sbin/chkconfig --del eventum-irc
618 fi
619
620 %triggerin -- apache1 < 1.3.37-3, apache1-base
621 %webapp_register apache %{_webapp}
622
623 %triggerun -- apache1 < 1.3.37-3, apache1-base
624 %webapp_unregister apache %{_webapp}
625
626 %triggerin -- apache < 2.2.0, apache-base
627 %webapp_register httpd %{_webapp}
628
629 %triggerun -- apache < 2.2.0, apache-base
630 %webapp_unregister httpd %{_webapp}
631
632 %triggerin -- lighttpd
633 %webapp_register lighttpd %{_webapp}
634
635 %triggerun -- lighttpd
636 %webapp_unregister lighttpd %{_webapp}
637
638 %triggerpostun -- %{name} < 2.2-2.57
639 # switching eventum->http user
640 chgrp http %{_webappdir}/config.php
641 chgrp http %{_webappdir}/private_key.php
642 chgrp http %{_webappdir}/setup.php
643 chgrp http /var/log/%{name}/*
644 # update crontab user
645 for a in /etc/cron.d/eventum-*; do
646         [ -f "$a" ] || continue
647         awk '!/#/ && NR > 6 && $6 =="eventum" {sub("eventum", "http", $6)}{print}'  $a > $a.rpmtmp && cat $a.rpmtmp > $a
648         rm -f $a.rpmtmp
649
650         # crontabs moved to crons subdir
651         %{__sed} -i -e '
652                 s,/usr/share/eventum/process_mail_queue.php,/usr/share/eventum/crons/process_mail_queue.php,
653                 s,/usr/share/eventum/download_emails.php,/usr/share/eventum/crons/download_emails.php,
654                 s,/usr/share/eventum/check_reminders.php,/usr/share/eventum/crons/check_reminders.php,
655                 s,/usr/share/eventum/monitor.php,/usr/share/eventum/crons/monitor.php,
656         ' $a
657 done
658
659 %files -f %{name}.lang
660 %defattr(644,root,root,755)
661 %doc docs/*
662 %attr(751,root,root) %dir %{_webappdir}
663 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
664 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
665 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
666 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
667 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
668 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
669 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
670
671 %dir %attr(731,root,http) /var/log/%{name}
672 %attr(620,root,http) %ghost /var/log/%{name}/*
673 %dir %attr(750,root,root) /var/log/archive/%{name}
674 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
675
676 %dir %{_appdir}/bin
677 %attr(755,root,root) %{_appdir}/bin/download_emails.php
678 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
679
680 %{_appdir}/init.php
681 %dir %{_appdir}/htdocs
682 %{_appdir}/htdocs/*.php
683 %{_appdir}/htdocs/*.ico
684 %{_appdir}/htdocs/ajax
685 %{_appdir}/htdocs/css
686 %{_appdir}/htdocs/customer
687 %{_appdir}/htdocs/images
688 %{_appdir}/htdocs/js
689 %{_appdir}/htdocs/manage
690 %{_appdir}/htdocs/misc
691 %{_appdir}/htdocs/reports
692 %{_appdir}/htdocs/rpc
693 %{_appdir}/htdocs/components
694 %{_appdir}/templates
695
696 %dir %{_appdir}/upgrade
697 %{_appdir}/upgrade/flush_compiled_templates.php
698 %{_appdir}/upgrade/*.sql
699 %attr(755,root,root) %{_appdir}/upgrade/update-database.php
700 %attr(755,root,root) %{_appdir}/upgrade/ldap_import.php
701 %attr(755,root,root) %{_appdir}/upgrade/ldap_update_users.php
702 %attr(755,root,root) %{_appdir}/upgrade/scm_trac_import.php
703 %{_appdir}/upgrade/patches
704
705 %dir %{_appdir}/lib
706 %{_appdir}/lib/eventum
707 %{_appdir}/lib/jpgraph
708 %exclude %{_appdir}/lib/eventum/class.monitor.php
709 %{systemdtmpfilesdir}/%{name}.conf
710 %dir %attr(730,root,http) /var/run/%{name}
711 %dir %attr(730,root,http) /var/cache/%{name}
712
713 %files base
714 %defattr(644,root,root,755)
715 %attr(751,root,root) %dir %{_sysconfdir}
716 %dir %{_libdir}
717 %dir %{_appdir}
718 %dir /var/lib/%{name}
719 # saved mail copies
720 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
721 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
722 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
723
724 %files setup
725 %defattr(644,root,root,755)
726 %{_appdir}/htdocs/setup
727
728 %files mail-queue
729 %defattr(644,root,root,755)
730 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
731 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
732
733 %files mail-download
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{_appdir}/bin/download_emails.php
736 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
737
738 %files reminder
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
741 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
742
743 %files monitor
744 %defattr(644,root,root,755)
745 %{_appdir}/lib/eventum/class.monitor.php
746 %attr(755,root,root) %{_appdir}/bin/monitor.php
747 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
748
749 %files route-drafts
750 %defattr(644,root,root,755)
751 %attr(755,root,root) %{_appdir}/bin/route_drafts.php
752
753 %files route-emails
754 %defattr(644,root,root,755)
755 %attr(755,root,root) %{_appdir}/bin/route_emails.php
756
757 %files route-notes
758 %defattr(644,root,root,755)
759 %attr(755,root,root) %{_appdir}/bin/route_notes.php
760
761 %files router-postfix
762 %defattr(644,root,root,755)
763 %attr(755,root,root) %{_libdir}/router-postfix
764
765 %files irc
766 %defattr(644,root,root,755)
767 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
768 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
769 %attr(755,root,root) %{_sbindir}/%{name}-irc-bot
770 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
771
772 %files cli
773 %defattr(644,root,root,755)
774 %doc cli/eventumrc
775 #%attr(755,root,root) %{_bindir}/%{name}
776 #%{_appdir}/cli
777
778 %files scm
779 %defattr(644,root,root,755)
780 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
781 #%attr(755,root,root) %{_libdir}/process_cvs_commits
782 #%attr(755,root,root) %{_libdir}/process_svn_commits
783 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
784 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
785
786 %files sphinx
787 %defattr(644,root,root,755)
788 %{_webappdir}/sphinx.conf.php
789 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
790 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.092546 seconds and 4 git commands to generate.