]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
up to 3.5.6-75-g293a8feb
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1
6 %define         subver  75
7 %define         githash 293a8feb
8 %define         php_min_version 5.6.0
9 Summary:        Eventum Issue / Bug tracking system
10 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
11 Name:           eventum
12 Version:        3.5.6
13 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
14 License:        GPL v2+
15 Group:          Applications/WWW
16 #Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.xz
17 Source0:        https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.xz
18 # Source0-md5:  e3059184b6eafb87b4504722f64fb93f
19 Source1:        %{name}-apache.conf
20 Source2:        %{name}-mail-queue.cron
21 Source3:        %{name}-mail-download.cron
22 Source4:        %{name}-reminder.cron
23 Source5:        %{name}-monitor.cron
24 Source10:       sphinx.crontab
25 Source13:       %{name}-router-postfix.sh
26 Source14:       %{name}.logrotate
27 Source15:       %{name}-lighttpd.conf
28 Source16:       http://www.isocra.com/images/updown2.gif
29 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
30 Source17:       %{name}.tmpfiles
31 Patch2:         %{name}-order.patch
32 #Patch3:                group-users.patch
33 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
34 # packaging patches that probably never go upstream
35 Patch100:       %{name}-paths.patch
36 Patch107:       %{name}-gettext.patch
37 Patch108:       autoload.patch
38 # some tests
39 Patch200:       %{name}-fixed-nav.patch
40 URL:            https://wiki.github.com/eventum/eventum/
41 BuildRequires:  gettext-tools
42 BuildRequires:  rpmbuild(macros) >= 1.654
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  tar >= 1:1.22
45 BuildRequires:  xz
46 Requires(post): sudo
47 Requires(postun):       /usr/sbin/groupdel
48 Requires(postun):       /usr/sbin/userdel
49 Requires(pre):  /bin/id
50 Requires(pre):  /usr/bin/getgid
51 Requires(pre):  /usr/sbin/groupadd
52 Requires(pre):  /usr/sbin/useradd
53 Requires:       fonts-TTF-RedHat-liberation
54 Requires:       php(core) >= %{php_min_version}
55 Requires:       php(filter)
56 Requires:       php(iconv)
57 Requires:       php(imap)
58 Requires:       php(json)
59 Requires:       php(mbstring)
60 Requires:       php(pcre)
61 Requires:       php(pdo_mysql)
62 Requires:       php(session)
63 Requires:       php-Smarty >= 3.1
64 Requires:       php-Smarty-plugin-gettext
65 Requires:       php-ZendFramework-Config >= 2.4
66 Requires:       php-ZendFramework-Loader >= 2.4
67 Requires:       php-ZendFramework-Mail >= 2.4.13-2
68 Requires:       php-ZendFramework-Mime >= 2.4
69 Requires:       php-ZendFramework-ServiceManager >= 2.4
70 Requires:       php-ZendFramework-Validator >= 2.4
71 Requires:       php-monolog >= 1.17.2
72 Requires:       php-pear-Math_Stats
73 Requires:       php-pear-Net_SMTP
74 Requires:       php-pear-Net_Socket
75 Requires:       php-pear-Net_URL
76 Requires:       php-pear-PEAR-core
77 Requires:       php-pear-Text_Diff
78 Requires:       php-psr-Log >= 1.0.0-2
79 Requires:       phplot >= 5.8.0
80 Requires:       webapps
81 Requires:       webserver(access)
82 Requires:       webserver(alias)
83 Requires:       webserver(indexfile)
84 Requires:       webserver(php) >= 4.2.0
85 Suggests:       localedb
86 Suggests:       php(mcrypt)
87 Suggests:       php(openssl)
88 Suggests:       php-pear-Net_POP3
89 Suggests:       webserver(setenv)
90 Provides:       group(eventum)
91 Provides:       user(eventum)
92 Obsoletes:      eventum-base < 3.0.3-1.305
93 Obsoletes:      eventum-route-drafts < 3.0.8-1.1
94 Obsoletes:      eventum-route-emails < 3.0.8-1.1
95 Obsoletes:      eventum-route-notes < 3.0.8-1.1
96 Conflicts:      logrotate < 3.8.0
97 BuildArch:      noarch
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %define         _libdir         %{_prefix}/lib/%{name}
101 %define         _appdir         %{_datadir}/%{name}
102 %define         _smartydir      %{php_data_dir}/Smarty
103 %define         _webapps        /etc/webapps
104 %define         _webapp         %{name}
105 %define         _webappdir      %{_webapps}/%{_webapp}
106 %define         _sysconfdir     /etc/%{name}
107
108 %description
109 Eventum is a user-friendly and flexible issue tracking system that can
110 be used by a support department to track incoming technical support
111 requests, or by a software development team to quickly organize tasks
112 and bugs.
113
114 %description -l pl.UTF-8
115 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
116 może być używany przez dział obsługi do śledzenia przychodzących żądań
117 obsługi technicznej albo przez zespół tworzący oprogramowanie do
118 szybkiej organizacji zadań i błędów.
119
120 %package setup
121 Summary:        Eventum setup package
122 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
123 Group:          Applications/WWW
124 Requires:       %{name} = %{version}-%{release}
125
126 %description setup
127 Install this package to configure initial Eventum installation. You
128 should uninstall this package when you're done, as it considered
129 insecure to keep the setup files in place.
130
131 %description setup -l pl.UTF-8
132 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
133 pierwszej instalacji. Potem należy go odinstalować, jako że
134 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
135
136 %package doc
137 Summary:        Eventum documentation and Wiki
138 Group:          Documentation
139
140 %description doc
141 Eventum documentation and copy of Wiki.
142
143 %package mail-queue
144 Summary:        Eventum mail queue process
145 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
146 Group:          Applications/WWW
147 Requires:       %{name} = %{version}-%{release}
148 Requires:       crondaemon
149
150 %description mail-queue
151 Beginning with the first release of Eventum, emails are not directly
152 sent out from the various scripts, but rather added to a mail queue
153 table that is processed by a cron job. If an email cannot be sent, it
154 will be marked as such in the mail queue log, and the cron job script
155 will re-try to send it again the next time it runs.
156
157 This package contains the cron job.
158
159 %description mail-queue -l pl.UTF-8
160 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
161 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
162 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
163 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
164 następnym razem.
165
166 Ten pakiet zawiera zadanie dla crona.
167
168 %package mail-download
169 Summary:        Eventum email download
170 Summary(pl.UTF-8):      Ściąganie poczty Eventum
171 Group:          Applications/WWW
172 Requires:       %{name} = %{version}-%{release}
173 Requires:       crondaemon
174
175 %description mail-download
176 In order for Eventum's email integration feature to work, you need to
177 setup a cron job to run the script every so often.
178
179 This package contains the cron job.
180
181 %description mail-download -l pl.UTF-8
182 Aby integracja poczty elektronicznej w Eventum działała, trzeba
183 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
184 często.
185
186 Ten pakiet zawiera zadanie dla crona.
187
188 %package reminder
189 Summary:        Eventum Reminder System
190 Summary(pl.UTF-8):      System przypominania dla Eventum
191 Group:          Applications/WWW
192 Requires:       %{name} = %{version}-%{release}
193 Requires:       crondaemon
194
195 %description reminder
196 The reminder system was designed with the objective as serving as a
197 safe net for issues that need attention. Depending on what
198 configuration you create, you may have several reminders (or alerts)
199 be sent out whenever an issue needs attention, for whatever parameter
200 you may deem necessary.
201
202 This package contains the cron job.
203
204 %description reminder -l pl.UTF-8
205 System przypominania został zaprojektowany tak, aby służył jako
206 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
207 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
208 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
209 uważać za potrzebny.
210
211 Ten pakiet zawiera zadanie dla crona.
212
213 %package monitor
214 Summary:        Eventum Heartbeat Monitor
215 Summary(pl.UTF-8):      Monitor życia dla Eventum
216 Group:          Applications/WWW
217 Requires:       %{name} = %{version}-%{release}
218 Requires:       crondaemon
219 Requires:       php(posix)
220
221 %description monitor
222 The heartbeat monitor is a feature designed for the administrator that
223 wants to be alerted whenever a common problem in Eventum is detected,
224 like the database server not being available anymore, or maybe when
225 the recommended permissions for certain configuration files are
226 changed.
227
228 Please note that before running the heartbeat monitor, you may need to
229 customize some of the checks to be appropriate for your own system,
230 particularly the permission and file checks on
231 Monitor::checkConfiguration().
232
233 This package contains the cron job.
234
235 %description monitor -l pl.UTF-8
236 Monitor życia to funkcjonalność zaprojektowana dla administratora
237 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
238 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
239 do plików konfiguracyjnych.
240
241 Należy zauważyć, że przed uruchomieniem tego monitora może być
242 konieczne dostosowanie niektórych testów do systemu, w szczególności
243 testów uprawnień i plików w Monitor::checkConfiguration().
244
245 Ten pakiet zawiera zadanie dla crona.
246
247 %package router-postfix
248 Summary:        Eventum Mail Routing - Postfix
249 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
250 Group:          Applications/Mail
251 Requires:       %{name} = %{version}-%{release}
252 Requires:       postfix
253 Provides:       eventum(router)
254 Obsoletes:      eventum(router)
255
256 %description router-postfix
257 This package provides way of routing notes and emails back to Eventum
258 via Postfix.
259
260 The Postfix configuration instructions you can find from
261 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
262
263 %description router-postfix -l pl.UTF-8
264 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
265 przez Postfiksa.
266
267 Opis konfiguracji Postfiksa można znaleźć pod adresem
268 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
269
270 %package cli
271 Summary:        Eventum command-line interface
272 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
273 Group:          Applications/WWW
274 Requires:       php(core) >= %{php_min_version}
275 Requires:       php(phar)
276
277 %description cli
278 The Eventum command-line interface allows you to access most of the
279 features of the web interface straight from your command shell.
280
281 %description cli -l pl.UTF-8
282 Interfejs linii poleceń Eventum pozwala na dostęp do większości
283 funkcji interfejsu WWW prosto z linii poleceń powłoki.
284
285 %package sphinx
286 Summary:        Eventum Sphinx Search
287 Group:          Applications/WWW
288 Requires:       %{name} = %{version}-%{release}
289 Requires:       crondaemon
290 Requires:       sphinx
291
292 %description sphinx
293 Sphinx search integration for Eventum.
294
295 This package contains the cron job.
296
297 %prep
298 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
299
300 mv docs/examples .
301
302 # bug fixes / features
303 %{?with_order:%patch2 -p1}
304 #%patch3 -p0
305 #%patch4 -p1
306 %{?with_order:cp -p %{SOURCE16} htdocs/images}
307 #%patch200 -p1
308
309 # produce default sphinx config
310 # must be run before paths.patch
311 %if 0
312 cat <<'EOF' > config/config.php
313 <?php
314 define('APP_SQL_DBTYPE', 'mysql');
315 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
316 define('APP_SQL_DBPORT', 3306);
317 define('APP_SQL_DBNAME', 'eventum');
318 define('APP_SQL_DBUSER', 'mysql');
319 define('APP_SQL_DBPASS', '');
320 define('APP_TABLE_PREFIX', 'eventum_');
321 EOF
322 php config/sphinx.conf.php > config/sphinx.conf
323 rm config/config.php
324 %endif
325
326 # packaging
327 %patch100 -p1
328 %patch107 -p1
329 %patch108 -p1
330
331 rm htdocs/.htaccess.dist
332 rm config/config.dist.php
333
334 # cleanup vendor. keep only needed libraries.
335 # (the rest are packaged with system packages)
336 mv vendor vendor.dist
337 vendor() {
338         local path dir
339         for path; do
340                 dir=$(dirname $path)
341                 test -d vendor/$dir || mkdir -p vendor/$dir
342                 mv vendor.dist/$path vendor/$path
343         done
344 }
345 vendor autoload.php
346 vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
347 vendor composer/ClassLoader.php
348 vendor ircmaxell/{random-lib,security-lib}
349 vendor defuse/php-encryption
350 vendor willdurand/email-reply-parser
351 vendor theorchard/monolog-cascade
352 vendor malkusch/lock
353 vendor phpxmlrpc/phpxmlrpc
354 vendor robmorgan/phinx
355 vendor mnapoli/silly
356 vendor psr/container
357 vendor phlib/flysystem-pdo
358 vendor league/flysystem
359 vendor php-di/invoker
360 vendor symfony/config
361 vendor symfony/console
362 vendor symfony/contracts
363 vendor symfony/event-dispatcher
364 vendor symfony/filesystem
365 vendor symfony/http-foundation
366 vendor symfony/options-resolver
367 vendor symfony/serializer
368 vendor symfony/yaml
369 vendor symfony/ldap
370 vendor paragonie/random_compat
371 vendor symfony/polyfill-intl-normalizer
372 vendor symfony/security-core
373 vendor symfony/security-csrf
374 vendor glen/filename-normalizer
375 vendor doctrine/annotations
376 vendor doctrine/cache
377 vendor doctrine/collections
378 vendor doctrine/common
379 vendor doctrine/dbal
380 vendor doctrine/inflector
381 vendor doctrine/instantiator
382 vendor doctrine/lexer
383 vendor doctrine/orm
384 vendor cebe/markdown
385 vendor enrise/urihelper
386 vendor cakephp/core
387 vendor cakephp/collection
388 vendor cakephp/utility
389
390 # remove backups from patching as we use globs to package files to buildroot
391 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
392
393 %build
394 %{__make} -C localization
395
396 %install
397 rm -rf $RPM_BUILD_ROOT
398 install -d \
399         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
400         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
401         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
402         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
403         $RPM_BUILD_ROOT/var/lib/%{name}/{routed_{emails,drafts,notes},storage} \
404         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
405
406 %{__make} install-eventum install-cli install-localization \
407         sysconfdir=%{_webappdir} \
408         localedir=%{_localedir} \
409         DESTDIR=$RPM_BUILD_ROOT
410
411 ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
412
413 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
414
415 # unsupported locale
416 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
417
418 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
419 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
420
421 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
422
423 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
424 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
425 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
426 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
427
428 install -d $RPM_BUILD_ROOT/etc/sphinx
429 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
430 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
431
432 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
433 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
434 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
435 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
436 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
437
438 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
439
440 # postfix router
441 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
442
443 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
444
445 %find_lang %{name}
446
447 %clean
448 rm -rf $RPM_BUILD_ROOT
449
450 %pre
451 %groupadd -g 146 %{name}
452 %useradd -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
453 %addusertogroup http %{name}
454
455 %post
456 # create empty ghost files
457 # these permissions ensure the logs are write only
458 for a in \
459         errors.log login_attempts.log \
460         eventum.log \
461         auth.log cli.log \
462 ; do
463         test -f /var/log/%{name}/$a && continue
464         install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
465 done
466
467 # run database update if configured
468 test -s %{_webappdir}/config.php && \
469 sudo -H -u http -- %{_appdir}/bin/upgrade.php || :
470
471 # nuke Smarty templates cache after upgrade
472 rm -f /var/cache/eventum/*.php
473
474 # Restart webserver on upgrade to get .mo translations reloaded.
475 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
476 %php_webserver_restart
477
478 %preun
479 if [ "$1" = "0" ]; then
480         # nuke cache
481         rm -f /var/cache/eventum/*.php 2>/dev/null || :
482 fi
483
484 %postun
485 if [ "$1" = "0" ]; then
486         %userremove %{name}
487         %groupremove %{name}
488 fi
489
490 %post setup
491 chmod 660 %{_webappdir}/{config,private_key,secret_key}.php
492 chown root:http %{_webappdir}/{config,private_key,secret_key}.php
493
494 %postun setup
495 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
496         chmod 640 %{_webappdir}/{config,private_key,secret_key}.php
497         chown root:http %{_webappdir}/{config,private_key,secret_key}.php
498 fi
499
500 %triggerin -- apache1 < 1.3.37-3, apache1-base
501 %webapp_register apache %{_webapp}
502
503 %triggerun -- apache1 < 1.3.37-3, apache1-base
504 %webapp_unregister apache %{_webapp}
505
506 %triggerin -- apache < 2.2.0, apache-base
507 %webapp_register httpd %{_webapp}
508
509 %triggerun -- apache < 2.2.0, apache-base
510 %webapp_unregister httpd %{_webapp}
511
512 %triggerin -- lighttpd
513 %webapp_register lighttpd %{_webapp}
514
515 %triggerun -- lighttpd
516 %webapp_unregister lighttpd %{_webapp}
517
518 %files -f %{name}.lang
519 %defattr(644,root,root,755)
520 %attr(771,root,http) %dir %{_webappdir}
521 %attr(751,root,http) %dir %{_webappdir}/crm
522 %attr(751,root,http) %dir %{_webappdir}/custom_field
523 %attr(751,root,http) %dir %{_webappdir}/partner
524 %attr(751,root,http) %dir %{_webappdir}/templates
525 %attr(751,root,http) %dir %{_webappdir}/workflow
526 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
527 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
528 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
529 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
530 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
531 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
532 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
533 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
534
535 %dir %attr(731,root,http) /var/log/%{name}
536 %attr(620,root,http) %ghost /var/log/%{name}/*
537 %dir %attr(750,root,root) /var/log/archive/%{name}
538 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
539
540 %dir %{_appdir}
541 %{_appdir}/config
542
543 %dir %{_appdir}/bin
544 %attr(755,root,root) %{_appdir}/bin/extension.php
545 %attr(755,root,root) %{_appdir}/bin/ldapsync.php
546 %attr(755,root,root) %{_appdir}/bin/migrate_storage_adapter.php
547 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
548 %attr(755,root,root) %{_appdir}/bin/upgrade.php
549
550 %{_appdir}/autoload.php
551 %{_appdir}/globals.php
552 %{_appdir}/init.php
553 %{_appdir}/phinx.php
554 %dir %{_appdir}/htdocs
555 %{_appdir}/htdocs/*.php
556 %{_appdir}/htdocs/*.ico
557 %{_appdir}/htdocs/ajax
558 %{_appdir}/htdocs/css
559 %{_appdir}/htdocs/customer
560 %{_appdir}/htdocs/images
561 %{_appdir}/htdocs/js
562 %{_appdir}/htdocs/manage
563 %{_appdir}/htdocs/reports
564 %{_appdir}/htdocs/rpc
565 %{_appdir}/htdocs/components
566 %{_appdir}/templates
567
568 %dir %{_appdir}/db
569 %dir %{_appdir}/db/migrations
570 %{_appdir}/db/migrations/*.php
571
572 %{_appdir}/res
573 %{_appdir}/src
574 %{_appdir}/vendor
575 %dir %{_appdir}/lib
576 %{_appdir}/lib/eventum
577 %exclude %{_appdir}/src/Console/Command/MailDownloadCommand.php
578 %exclude %{_appdir}/src/Console/Command/MailQueueProcessCommand.php
579 %exclude %{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
580 %exclude %{_appdir}/src/Console/Command/MonitorCommand.php
581 %exclude %{_appdir}/src/Console/Command/ReminderCheckCommand.php
582
583 %dir %{_libdir}
584
585 %{systemdtmpfilesdir}/%{name}.conf
586
587 %dir /var/lib/%{name}
588 %dir %attr(730,root,http) /var/run/%{name}
589 %dir %attr(730,root,http) /var/cache/%{name}
590
591 # saved mail copies
592 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
593 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
594 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
595 # attachment storage
596 %attr(770,root,http) %dir /var/lib/%{name}/storage
597
598 %files setup
599 %defattr(644,root,root,755)
600 %{_appdir}/htdocs/setup
601
602 %files doc
603 %defattr(644,root,root,755)
604 %doc docs/*
605 %{_examplesdir}/%{name}-%{version}
606
607 %files mail-queue
608 %defattr(644,root,root,755)
609 %{_appdir}/src/Console/Command/MailQueueProcessCommand.php
610 %{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
611 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
612 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
613 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
614
615 %files mail-download
616 %defattr(644,root,root,755)
617 %{_appdir}/src/Console/Command/MailDownloadCommand.php
618 %attr(755,root,root) %{_appdir}/bin/download_emails.php
619 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
620
621 %files reminder
622 %defattr(644,root,root,755)
623 %{_appdir}/src/Console/Command/ReminderCheckCommand.php
624 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
625 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
626
627 %files monitor
628 %defattr(644,root,root,755)
629 %{_appdir}/src/Console/Command/MonitorCommand.php
630 %attr(755,root,root) %{_appdir}/bin/monitor.php
631 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
632
633 %files router-postfix
634 %defattr(644,root,root,755)
635 %attr(755,root,root) %{_libdir}/router-postfix
636
637 %files cli
638 %defattr(644,root,root,755)
639 %doc cli/eventumrc
640 %attr(755,root,root) %{_bindir}/%{name}
641
642 %files sphinx
643 %defattr(644,root,root,755)
644 %{_webappdir}/sphinx.conf.php
645 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
646 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.089544 seconds and 4 git commands to generate.