]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- add post 1.5.4 fixes
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - system pear is incompatible, at least pear DB class seems broke Eventum
3 # - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
4 # - discard bundled packages (from INSTALL):
5 #  - JpGraph 1.5.3 (last GPL version)
6 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
7 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
8 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
9 #  - A few other small javascript libraries
10 # - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
11 # - php4-pgsql crashes php (at least 4.3.11-1)
12
13 %bcond_with     pear    # build with system PEAR packages (or use bundled ones)
14 %bcond_with     qmail   # build the router-qmail subpackage
15
16 %define uid     146
17 %define gid     146
18
19 # snapshot: DATE
20 #define _snap 20050227
21
22 %if 0%{?_snap}
23 %define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
24 %else
25 %define _source http://mysql.dataphone.se/Downloads/%{name}/%{name}-%{version}.tar.gz
26 %endif
27
28 %define _rel    1.8
29
30 Summary:        Eventum Issue / Bug tracking system
31 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
32 Name:           eventum
33 Version:        1.5.4
34 Release:        %{?_snap:0.%{_snap}.}%{_rel}
35 License:        GPL
36 Group:          Applications/WWW
37 Source0:        %{_source}
38 # Source0-md5:  0de0b1cfe4b92179cb7a52a819871856
39 %{?_snap:NoSource:      0}
40 Source1:        %{name}-apache.conf
41 Source2:        %{name}-mail-queue.cron
42 Source3:        %{name}-mail-download.cron
43 Source4:        %{name}-reminder.cron
44 Source5:        %{name}-monitor.cron
45 Source6:        %{name}-cvs.php
46 Source7:        %{name}-irc.php
47 Source8:        %{name}-irc.init
48 Source9:        %{name}-irc.sysconfig
49 Source10:       %{name}-config.php
50 Source11:       %{name}-router-qmail.sh
51 Source12:       http://dev.mysql.com/common/favicon.ico
52 # Source12-md5: 858be0130832da4144c08d4b59116411
53 Source13:       %{name}-config-setup.php
54 Source14:       %{name}-upgrade.sh
55 Patch0:         %{name}-paths.patch
56 Patch1:         %{name}-cvs-config.patch
57 Patch2:         %{name}-irc-config.patch
58 Patch3:         %{name}-PEAR.patch
59 Patch4:         http://glen.alkohol.ee/pld/%{name}-reply-subject.patch
60 Patch5:         %{name}-lf.patch
61 Patch6:         http://glen.alkohol.ee/pld/%{name}-maq-subject.patch
62 Patch7:         %{name}-bot-reconnect.patch
63 Patch8:         %{name}-bug-10464.patch
64 Patch9:         %{name}-bug-10263.patch
65 Patch10:        %{name}-ft-enable.patch
66 URL:            http://dev.mysql.com/downloads/other/eventum/
67 BuildRequires:  rpmbuild(macros) >= 1.200
68 BuildRequires:  sed >= 4.0
69 Requires:       php >= 4.2.0
70 Requires:       php-gd
71 Requires:       php-imap
72 Requires:       php-mysql
73 Requires:       php-pcre
74 Requires:       php-session
75 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
76 Requires:       Smarty >= 2.6.2
77 %if %{with pear}
78 Requires:       php-pear-Benchmark
79 Requires:       php-pear-DB
80 Requires:       php-pear-Date
81 Requires:       php-pear-HTTP_Request
82 Requires:       php-pear-Mail
83 Requires:       php-pear-Math_Stats
84 Requires:       php-pear-Net_DIME
85 Requires:       php-pear-Net_POP3
86 Requires:       php-pear-Net_SMTP
87 Requires:       php-pear-Net_SmartIRC
88 Requires:       php-pear-Net_Socket
89 Requires:       php-pear-Net_URL
90 Requires:       php-pear-Net_UserAgent_Detect
91 Requires:       php-pear-PEAR
92 Requires:       php-pear-Text_Diff
93 Requires:       php-pear-XML_RPC
94 %endif
95 Requires:       apache >= 1.3.33-2
96 Requires:       apache(mod_dir)
97 Requires(triggerpostun):        sed >= 4.0
98 BuildArch:      noarch
99 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101 %define         _sysconfdir     /etc/%{name}
102 %define         _libdir         %{_prefix}/%{_lib}/%{name}
103 %define         _appdir %{_datadir}/%{name}
104 %define         _smartyplugindir        %{php_pear_dir}/Smarty/plugins
105
106 %define         _apache1dir     /etc/apache
107 %define         _apache2dir     /etc/httpd
108
109 %description
110 Eventum is a user-friendly and flexible issue tracking system that can
111 be used by a support department to track incoming technical support
112 requests, or by a software development team to quickly organize tasks
113 and bugs. Eventum is used by the MySQL AB Technical Support team, and
114 has allowed us to dramatically improve our response times.
115
116 %description -l pl
117 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
118 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
119 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
120 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
121 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
122 reakcji.
123
124 %package base
125 Summary:        Eventum base package
126 Summary(pl):    Podstawowy pakiet Eventum
127 Group:          Applications/WWW
128 Requires(pre):  /bin/id
129 Requires(pre):  /usr/bin/getgid
130 Requires(pre):  /usr/sbin/useradd
131 Requires(pre):  /usr/sbin/groupadd
132 Requires(postun):       /usr/sbin/userdel
133 Requires(postun):       /usr/sbin/groupdel
134 Provides:       user(eventum)
135 Provides:       group(eventum)
136
137 %description base
138 This package contains base directory structure for Eventum.
139
140 %description base -l pl
141 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
142
143 %package setup
144 Summary:        Eventum setup package
145 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
146 Group:          Applications/WWW
147 PreReq:         %{name} = %{epoch}:%{version}-%{release}
148
149 %description setup
150 Install this package to configure initial Eventum installation. You
151 should uninstall this package when you're done, as it considered
152 insecure to keep the setup files in place.
153
154 %description setup -l pl
155 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
156 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
157 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
158
159 %package mail-queue
160 Summary:        Eventum mail queue process
161 Summary(pl):    Przetwarzanie kolejki poczty Eventum
162 Group:          Applications/WWW
163 Requires:       %{name} = %{epoch}:%{version}-%{release}
164 Requires:       crondaemon
165 Requires:       php >= 4.1.0
166
167 %description mail-queue
168 Beginning with the first release of Eventum, emails are not directly
169 sent out from the various scripts, but rather added to a mail queue
170 table that is processed by a cron job. If an email cannot be sent, it
171 will be marked as such in the mail queue log, and the cron job script
172 will re-try to send it again the next time it runs.
173
174 This package contains the cron job.
175
176 %description mail-queue -l pl
177 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
178 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
179 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
180 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
181 nastêpnym razem.
182
183 Ten pakiet zawiera zadanie dla crona.
184
185 %package mail-download
186 Summary:        Eventum email download
187 Summary(pl):    ¦ci±ganie poczty Eventum
188 Group:          Applications/WWW
189 Requires:       %{name} = %{epoch}:%{version}-%{release}
190 Requires:       crondaemon
191 Requires:       php >= 4.1.0
192
193 %description mail-download
194 In order for Eventum's email integration feature to work, you need to
195 setup a cron job to run the script every so often.
196
197 This package contains the cron job.
198
199 %description mail-download -l pl
200 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
201 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
202 czêsto.
203
204 Ten pakiet zawiera zadanie dla crona.
205
206 %package reminder
207 Summary:        Eventum Reminder System
208 Summary(pl):    System przypominania dla Eventum
209 Group:          Applications/WWW
210 Requires:       %{name} = %{epoch}:%{version}-%{release}
211 Requires:       php >= 4.1.0
212 Requires:       crondaemon
213
214 %description reminder
215 The reminder system was designed with the objective as serving as a
216 safe net for issues that need attention. Depending on what
217 configuration you create, you may have several reminders (or alerts)
218 be sent out whenever an issue needs attention, for whatever parameter
219 you may deem necessary.
220
221 This package contains the cron job.
222
223 %description reminder -l pl
224 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
225 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
226 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
227 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
228 uwa¿aæ za potrzebny.
229
230 Ten pakiet zawiera zadanie dla crona.
231
232 %package monitor
233 Summary:        Eventum Heartbeat Monitor
234 Summary(pl):    Monitor ¿ycia dla Eventum
235 Group:          Applications/WWW
236 Requires:       %{name} = %{epoch}:%{version}-%{release}
237 Requires:       php >= 4.1.0
238 Requires:       php-posix
239 Requires:       crondaemon
240
241 %description monitor
242 The heartbeat monitor is a feature designed for the administrator that
243 wants to be alerted whenever a common problem in Eventum is detected,
244 like the database server not being available anymore, or maybe when
245 the recommended permissions for certain configuration files are
246 changed.
247
248 Please note that before running the heartbeat monitor, you may need to
249 customize some of the checks to be appropriate for your own system,
250 particularly the permission and file checks on
251 Monitor::checkConfiguration().
252
253 This package contains the cron job.
254
255 %description monitor -l pl
256 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
257 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
258 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
259 do plików konfiguracyjnych.
260
261 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
262 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
263 testów uprawnieñ i plików w Monitor::checkConfiguration().
264
265 Ten pakiet zawiera zadanie dla crona.
266
267 %package route-emails
268 Summary:        Eventum Email Routing
269 Summary(pl):    Przekazywanie poczty dla Eventum
270 Group:          Applications/WWW
271 Requires:       %{name} = %{epoch}:%{version}-%{release}
272 Requires:       php >= 4.1.0
273 Requires:       eventum(router)
274
275 %description route-emails
276 The email routing feature is used to automatically associate a thread
277 of emails into an Eventum issue. By setting up qmail (or even postfix)
278 to deliver emails sent to a specific address (usually
279 issue-<number>@<domain>) to the above script, users are able to use
280 their email clients to reply to emails coming from Eventum, and those
281 replies will be automatically associated with the issue and
282 broadcasted to the entire notification list.
283
284 %description route-emails -l pl
285 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
286 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
287 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
288 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
289 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
290 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
291 rozprowadzane do ca³ej listy og³oszeniowej.
292
293 %package route-notes
294 Summary:        Eventum Note Routing
295 Summary(pl):    Przekazywanie notatek dla Eventum
296 Group:          Applications/WWW
297 Requires:       %{name} = %{epoch}:%{version}-%{release}
298 Requires:       php >= 4.1.0
299 Requires:       eventum(router)
300
301 %description route-notes
302 The note routing feature is used to automatically associate a thread
303 of notes into an Eventum issue. By setting up qmail (or even postfix)
304 to deliver emails sent to a specific address (usually
305 note-<number>@<domain>) to the above script, users are able to use
306 their email clients to reply to internal notes coming from Eventum,
307 and those replies will be automatically associated with the issue and
308 broadcasted to the notification list staff members.
309
310 %description route-notes -l pl
311 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
312 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
313 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
314 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
315 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
316 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
317 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
318
319 %package router-qmail
320 Summary:        Eventum Mail Routing - qmail
321 Summary(pl):    Przekazywanie poczty Eventum - qmail
322 Group:          Applications/Mail
323 Requires:       %{name} = %{epoch}:%{version}-%{release}
324 Requires:       qmail >= 1.03
325 Provides:       eventum(router)
326 Obsoletes:      eventum(router)
327
328 %description router-qmail
329 This package provides way of routing notes and emails back to Eventum
330 via qmail.
331
332 %description router-qmail -l pl
333 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
334 przez qmaila.
335
336 %package router-postfix
337 Summary:        Eventum Mail Routing - Postfix
338 Summary(pl):    Przekazywanie poczty Eventum - Postfix
339 Group:          Applications/Mail
340 Requires:       %{name} = %{epoch}:%{version}-%{release}
341 Requires:       postfix
342 Provides:       eventum(router)
343 Obsoletes:      eventum(router)
344
345 %description router-postfix
346 This package provides way of routing notes and emails back to Eventum
347 via Postfix.
348
349 %description router-postfix -l pl
350 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
351 przez Postfiksa.
352
353 %package irc
354 Summary:        Eventum IRC Notification Bot
355 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
356 Group:          Applications/WWW
357 Requires:       %{name} = %{epoch}:%{version}-%{release}
358 Requires:       php >= 4.1.0
359 Requires:       php-sockets
360 Requires:       rc-scripts >= 0.4.0.18
361
362 %description irc
363 The IRC notification bot is a nice feature for remote teams that want
364 to handle issues and want to have a quick and easy way to get simple
365 notifications. Right now the bot notifies of the following actions:
366 - New Issues
367 - Blocked emails
368 - Issues that got their assignment list changed
369
370 NOTE: You will need to manually edit the bot.php script to set your
371 appropriate preferences, like IRC server and channel that the bot
372 should join.
373
374 %description irc -l pl
375 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
376 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
377 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
378 nastêpuj±cych zdarzeniach:
379 - nowych sprawach
380 - zablokowanych listach
381 - sprawach, dla których zmieni³a siê lista powi±zañ
382
383 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
384 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
385
386 %package cli
387 Summary:        Eventum command-line interface
388 Summary(pl):    Interfejs linii poleceñ dla Eventum
389 Group:          Applications/WWW
390 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
391 Requires:       php >= 4.1.0
392 Requires:       php-cli
393 Requires:       php-curl
394 Requires:       php-xml
395 Requires:       php-pear-XML_RPC
396
397 %description cli
398 The Eventum command-line interface allows you to access most of the
399 features of the web interface straight from your command shell.
400
401 %description cli -l pl
402 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
403 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
404
405 %package scm
406 Summary:        Eventum SCM integration
407 Summary(pl):    Integracja SCM dla Eventum
408 Group:          Applications/WWW
409 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
410 Requires:       php-cli >= 4.1.0
411 Requires:       php-pcre
412
413 %description scm
414 This feature allows your software development teams to integrate your
415 Source Control Management system with your Issue Tracking System.
416
417 The integration is implemented in such a way that it will be forward
418 compatible with pretty much any SCM system, such as CVS.
419
420 For installation see
421 </eventum/help.php?topic=scm_integration_installation>.
422
423 %description scm -l pl
424 Ten pakiet pozwala zespo³om programistów na integracjê systemu
425 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
426 ¶ledzenia spraw.
427
428 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
429 prawie ka¿dym systemem SCM, jak np. CVS.
430
431 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
432 </eventum/help.php?topic=scm_integration_installation>.
433
434 %prep
435 %setup -q %{?_snap:-n %{name}-%{_snap}}
436 # undos the source
437 find . -type f -print0 | xargs -0 sed -i -e 's,
438 $,,'
439
440 # packaging
441 %patch0 -p1 -b .paths
442 %patch1 -p1
443 %patch2 -p1
444 %{?with_pear:%patch3 -p1 -b .PEAR}
445
446 # bug fixes.
447 %patch4 -p1
448 %patch5 -p1
449 %patch6 -p1
450 %patch7 -p1
451 %patch8 -p1
452 %patch9 -p1
453 %patch10 -p1
454
455 # replace in remaining scripts config.inc.php to system one
456 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
457         s,include_once(".*config.inc.php"),include_once("%{_sysconfdir}/core.php"),
458 '
459 sed -i -e '
460         s,include(".*config.inc.php"),include_once("%{_sysconfdir}/core.php"),
461 ' misc/download_emails.php
462
463 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
464         s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_sysconfdir}/private_key.php"),
465 '
466 find -name '*~' | xargs -r rm -v
467
468 %install
469 rm -rf $RPM_BUILD_ROOT
470 install -d \
471         $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_libdir}} \
472         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
473         $RPM_BUILD_ROOT/var/{run,log,cache,lib}/%{name} \
474         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
475
476 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
477 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
478 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
479 cp -a misc/irc $RPM_BUILD_ROOT%{_appdir}
480 cp -a templates $RPM_BUILD_ROOT%{_appdir}
481 cp -a include/{customer,jpgraph,pear,workflow} $RPM_BUILD_ROOT%{_appdir}/include
482 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
483 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
484 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
485
486 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
487 install %{SOURCE13} $RPM_BUILD_ROOT%{_appdir}/htdocs/setup/config.inc.php
488 install %{SOURCE14} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
489
490 # cli
491 install -d $RPM_BUILD_ROOT%{_appdir}/cli
492 install misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
493 install misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
494 sed -e '1s,#!.*/bin/php,#!%{_bindir}/php4,' \
495         misc/cli/eventum > $RPM_BUILD_ROOT%{_bindir}/%{name}
496 cp -f misc/cli/eventumrc_example eventumrc
497
498 # scm
499 echo '#!%{_bindir}/php4 -q' > %{name}-scm
500 cat misc/scm/process_cvs_commits.php >> %{name}-scm
501 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
502
503 # private key
504 mv $RPM_BUILD_ROOT{%{_appdir}/include/private_key.php,%{_sysconfdir}}
505 # change private key, so we can easily grep
506 sed -i -e '
507 s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
508 ' $RPM_BUILD_ROOT%{_sysconfdir}/private_key.php
509
510 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
511 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
512 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
513 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
514 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
515 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
516 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
517 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
518 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
519 sed -e 's,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}},' \
520         %{SOURCE10} > $RPM_BUILD_ROOT%{_sysconfdir}/core.php
521
522 # config
523 > $RPM_BUILD_ROOT%{_sysconfdir}/setup.php
524 mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_sysconfdir}/config}.php
525
526 # sample, not used in eventum
527 rm -f $RPM_BUILD_ROOT%{_appdir}/htdocs/rpc/xmlrpc_client.php
528
529 %if %{with pear}
530 # provided by PEAR
531 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
532 %endif
533
534 # use system Smarty
535 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
536 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
537 # These plugins are not in Smarty package (Smarty-2.6.2-3)
538 cp -a include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
539         $RPM_BUILD_ROOT%{_smartyplugindir}
540
541 # qmail router
542 %if %{with qmail}
543 d=$RPM_BUILD_ROOT/var/lib/%{name}
544 echo 'root' > $d/.qmail
545 echo 'root' > $d/.qmail-default
546 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
547 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
548 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
549 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
550 %endif
551
552 %clean
553 rm -rf $RPM_BUILD_ROOT
554
555 %pre
556 %addusertogroup http %{name}
557
558 %post
559 # apache1
560 if [ -d %{_apache1dir}/conf.d ]; then
561         ln -sf %{_sysconfdir}/apache.conf %{_apache1dir}/conf.d/99_%{name}.conf
562         if [ -f /var/lock/subsys/apache ]; then
563                 /etc/rc.d/init.d/apache restart 1>&2
564         fi
565 fi
566 # apache2
567 if [ -d %{_apache2dir}/httpd.conf ]; then
568         ln -sf %{_sysconfdir}/apache.conf %{_apache2dir}/httpd.conf/99_%{name}.conf
569         if [ -f /var/lock/subsys/httpd ]; then
570                 /etc/rc.d/init.d/httpd restart 1>&2
571         fi
572 fi
573
574 # check if the package is configured.
575 if grep -q 'header("Location: setup/")' %{_sysconfdir}/config.php; then
576 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
577 %banner %{name} -e <<EOF
578
579 You haven't yet configured Eventum!
580 Please open in browser <http://localhost/eventum/>
581 If you need access from elsewhere, you need to edit
582 %{_sysconfdir}/apache.conf and restart apache.
583
584 IMPORTANT: When You have configured Eventum, please uninstall the
585 setup package, so that %{name}-setup is able to secure your Eventum
586 installation.
587
588 EOF
589 #' vim stupidity.
590 else
591 %banner %{name} -e <<EOF
592
593 You haven't yet configured Eventum!
594
595 To setup eventum, please install %{name}-setup and open in browser
596 <http://localhost/eventum/>.
597 If you need access from elsewhere, you need to edit
598 %{_sysconfdir}/apache.conf and restart apache.
599
600 IMPORTANT: When You have configured Eventum, please uninstall the
601 setup package, so that %{name}-setup is able to secure your Eventum
602 installation.
603
604 EOF
605 #' vim stupidity.
606 fi
607
608 elif grep -q 'DEFAULTPRIVATEKEY' %{_sysconfdir}/private_key.php; then
609 %banner %{name} -e <<EOF
610
611 You have default private key installed!
612
613 Install %{name}-setup and open up http://yourserver/eventum/setup/
614 -- that will help you setup initial config.
615
616 when have configured Eventum, please uninstall the setup package,
617 so that %{name}-setup is able to secure your Eventum installation.
618
619 EOF
620         elif [ -d %{_appdir}/setup ]; then
621 %banner %{name} -e <<EOF
622
623 If you have have configured Eventum, please uninstall the setup package,
624 so that %{name}-setup is able to secure your Eventum installation.
625
626 EOF
627 fi
628
629 # nuke Smarty templates cache after upgrade
630 rm -f /var/cache/eventum/*.php
631
632 %preun
633 if [ "$1" = "0" ]; then
634         # apache1
635         if [ -f %{_apache1dir}/apache.conf ]; then
636                 rm -f %{_apache1dir}/conf.d/99_%{name}.conf
637                 if [ -f /var/lock/subsys/apache ]; then
638                         /etc/rc.d/init.d/apache restart 1>&2
639                 fi
640         fi
641         # apache2
642         if [ -d %{_apache2dir}/httpd.conf ]; then
643                 rm -f %{_apache2dir}/httpd.conf/99_%{name}.conf
644                 if [ -f /var/lock/subsys/httpd ]; then
645                         /etc/rc.d/init.d/httpd restart 1>&2
646                 fi
647         fi
648
649         # nuke cache
650         rm -f /var/cache/eventum/*.php 2>/dev/null || :
651 fi
652
653 %pre base
654 %groupadd -P %{name}-base -g %{gid} %{name}
655 %useradd -P %{name}-base -u %{uid} -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
656
657 %postun base
658 if [ "$1" = "0" ]; then
659         %userremove %{name}
660         %groupremove %{name}
661 fi
662
663 %if %{with qmail}
664 %post router-qmail
665 CF=/etc/qmail/control/virtualdomains
666 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
667         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_sysconfdir}/config.php 2>/dev/null)
668         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
669         umask 022
670         echo "#${FQDN}:%{name}" >> $CF
671
672 %banner %{name}-qmail -e <<EOF
673
674 Added "#${FQDN}:%{name}" to $CF,
675 Please verify that it is correct and restart qmail:
676 # service qmail reload
677
678 Consult qmail-send(8) for more information on virtualdomains.
679
680 EOF
681 fi
682
683 %preun router-qmail
684 if [ "$1" = "0" ]; then
685         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
686 fi
687 %endif
688
689 %post setup
690 chmod 660 %{_sysconfdir}/{config,private_key}.php
691 chown root:eventum %{_sysconfdir}/{config,private_key}.php
692
693 %postun setup
694 if [ "$1" = "0" ]; then
695         chmod 640 %{_sysconfdir}/{config,private_key}.php
696         chown root:eventum %{_sysconfdir}/{config,private_key}.php
697 fi
698
699 # FIXME
700 # only one upgrade trigger is called if you're upgrading over two
701 # versions, say 1.5 to 1.5.3, only 1.5.3 trigger is called.
702 # use common trigger (the highest version and rpmvercmp from poldek?)
703 %triggerpostun -- eventum < 1.5.1-0.257
704 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5_to_v1.5.1 <<EOF
705 database_changes.php Perform database changes
706 EOF
707
708 %triggerpostun -- eventum < 1.5.2-0.289
709 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.1_to_v1.5.2 <<EOF
710 database_changes.php Perform database changes
711 set_priority_ranks.php Fix the ranking of priority values
712 EOF
713
714 %triggerpostun -- eventum < 1.5.3-0.291
715 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.2_to_v1.5.3 <<EOF
716 database_changes.php Perform database changes
717 EOF
718
719 %triggerpostun -- eventum < 1.5.4-1.5
720 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.3_to_v1.5.4 <<EOF
721 database_changes.php Perform database changes
722 EOF
723
724 %files
725 %defattr(644,root,root,755)
726 %doc ChangeLog FAQ INSTALL README UPGRADE
727 %doc docs/* rpc/xmlrpc_client.php setup/schema.sql
728 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
729 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
730 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/private_key.php
731 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/setup.php
732 %attr(640,root,eventum) %config %verify(not mtime) %{_sysconfdir}/core.php
733
734 %dir %attr(731,root,eventum) /var/log/%{name}
735 %attr(620,root,eventum) %ghost /var/log/%{name}/*
736
737 %dir %{_appdir}/htdocs
738 %{_appdir}/htdocs/*.php
739 %{_appdir}/htdocs/*.ico
740 %{_appdir}/htdocs/css
741 %{_appdir}/htdocs/customer
742 %{_appdir}/htdocs/images
743 %{_appdir}/htdocs/js
744 %{_appdir}/htdocs/manage
745 %{_appdir}/htdocs/reports
746 %{_appdir}/htdocs/rpc
747 %{_appdir}/htdocs/misc
748
749 %{_appdir}/templates
750 %dir %{_appdir}/upgrade
751 %attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
752 %{_appdir}/upgrade/[!u]*
753
754 %{_smartyplugindir}/*
755 %if %{without pear}
756 %{_appdir}/include/pear
757 %endif
758
759 %dir %{_appdir}/include
760 %{_appdir}/include/customer
761 %{_appdir}/include/jpgraph
762 %{_appdir}/include/workflow
763 %{_appdir}/include/class.[!m]*.php
764 %{_appdir}/include/class.mail.php
765 %{_appdir}/include/class.mail_queue.php
766 %{_appdir}/include/class.mime_helper.php
767 %{_appdir}/include/class.misc.php
768 %{_appdir}/include/db_access.php
769 %{_appdir}/include/jsrsServer.inc.php
770
771 %dir %attr(730,root,eventum) /var/run/%{name}
772 %dir %attr(730,root,eventum) /var/cache/%{name}
773
774 %files base
775 %defattr(644,root,root,755)
776 %attr(751,root,root) %dir %{_sysconfdir}
777 %dir %{_libdir}
778 %dir %{_appdir}
779 # qmail will ignore user, if it's home directory is not owned
780 %attr(750,eventum,eventum) %dir /var/lib/%{name}
781
782 %files setup
783 %defattr(644,root,root,755)
784 %{_appdir}/htdocs/setup
785
786 %files mail-queue
787 %defattr(644,root,root,755)
788 %{_appdir}/process_mail_queue.php
789 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
790
791 %files mail-download
792 %defattr(644,root,root,755)
793 %{_appdir}/download_emails.php
794 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
795
796 %files reminder
797 %defattr(644,root,root,755)
798 %{_appdir}/check_reminders.php
799 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
800
801 %files monitor
802 %defattr(644,root,root,755)
803 %{_appdir}/include/class.monitor.php
804 %{_appdir}/monitor.php
805 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
806
807 %files route-emails
808 %defattr(644,root,root,755)
809 %{_appdir}/route_emails.php
810
811 %files route-notes
812 %defattr(644,root,root,755)
813 %{_appdir}/route_drafts.php
814 %{_appdir}/route_notes.php
815
816 %if %{with qmail}
817 %files router-qmail
818 %defattr(644,root,root,755)
819 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
820 %attr(755,root,root) %{_libdir}/router-qmail
821 %endif
822
823 %files router-postfix
824 %defattr(644,root,root,755)
825
826 %files irc
827 %defattr(644,root,root,755)
828 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
829 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
830 %{_appdir}/irc
831 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
832
833 %files cli
834 %defattr(644,root,root,755)
835 %doc eventumrc
836 %attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
837 %attr(755,root,root) %{_bindir}/%{name}
838 %{_appdir}/cli
839
840 %files scm
841 %defattr(644,root,root,755)
842 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
843 %attr(755,root,root) %{_libdir}/scm
This page took 0.147359 seconds and 4 git commands to generate.