]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- remove also .orig files produced by patching on builders
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - system pear is incompatible, at least pear DB class seems broke Eventum
3 # - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
4 # - discard bundled packages (from INSTALL):
5 #  - JpGraph 1.5.3 (last GPL version)
6 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
7 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
8 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
9 #  - A few other small javascript libraries
10 # - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
11
12 %bcond_with     pear    # build with system PEAR packages (or use bundled ones)
13 %bcond_with     qmail   # build the router-qmail subpackage
14
15 %define uid     146
16 %define gid     146
17
18 # snapshot: DATE
19 #define _snap 20050227
20
21 %if 0%{?_snap}
22 %define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
23 %else
24 %define _source http://mysql.dataphone.se/Downloads/%{name}/%{name}-%{version}.tar.gz
25 %endif
26
27 %define _rel    3
28
29 Summary:        Eventum Issue / Bug tracking system
30 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
31 Name:           eventum
32 Version:        1.5.4
33 Release:        %{?_snap:0.%{_snap}.}%{_rel}
34 License:        GPL
35 Group:          Applications/WWW
36 Source0:        %{_source}
37 # Source0-md5:  0de0b1cfe4b92179cb7a52a819871856
38 %{?_snap:NoSource:      0}
39 Source1:        %{name}-apache.conf
40 Source2:        %{name}-mail-queue.cron
41 Source3:        %{name}-mail-download.cron
42 Source4:        %{name}-reminder.cron
43 Source5:        %{name}-monitor.cron
44 Source6:        %{name}-cvs.php
45 Source7:        %{name}-irc.php
46 Source8:        %{name}-irc.init
47 Source9:        %{name}-irc.sysconfig
48 Source10:       %{name}-config.php
49 Source11:       %{name}-router-qmail.sh
50 Source12:       http://dev.mysql.com/common/favicon.ico
51 # Source12-md5: 858be0130832da4144c08d4b59116411
52 Source13:       %{name}-config-setup.php
53 Source14:       %{name}-upgrade.sh
54 Patch0:         %{name}-paths.patch
55 Patch1:         %{name}-cvs-config.patch
56 Patch2:         %{name}-irc-config.patch
57 Patch3:         %{name}-PEAR.patch
58 Patch4:         http://glen.alkohol.ee/pld/%{name}-reply-subject.patch
59 Patch5:         %{name}-lf.patch
60 Patch6:         http://glen.alkohol.ee/pld/%{name}-maq-subject.patch
61 Patch7:         %{name}-bot-reconnect.patch
62 Patch8:         %{name}-bug-10464.patch
63 Patch9:         %{name}-bug-10263.patch
64 Patch10:        %{name}-ft-enable.patch
65 Patch11:        %{name}-upgrade-exit.patch
66 URL:            http://dev.mysql.com/downloads/other/eventum/
67 BuildRequires:  rpmbuild(macros) >= 1.200
68 BuildRequires:  sed >= 4.0
69 Requires:       php >= 4.2.0
70 Requires:       php-gd
71 Requires:       php-imap
72 Requires:       php-mysql
73 Requires:       php-pcre
74 Requires:       php-session
75 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
76 Requires:       Smarty >= 2.6.2
77 %if %{with pear}
78 Requires:       php-pear-Benchmark
79 Requires:       php-pear-DB
80 Requires:       php-pear-Date
81 Requires:       php-pear-HTTP_Request
82 Requires:       php-pear-Mail
83 Requires:       php-pear-Math_Stats
84 Requires:       php-pear-Net_DIME
85 Requires:       php-pear-Net_POP3
86 Requires:       php-pear-Net_SMTP
87 Requires:       php-pear-Net_SmartIRC
88 Requires:       php-pear-Net_Socket
89 Requires:       php-pear-Net_URL
90 Requires:       php-pear-Net_UserAgent_Detect
91 Requires:       php-pear-PEAR
92 Requires:       php-pear-Text_Diff
93 Requires:       php-pear-XML_RPC
94 %endif
95 Requires:       apache >= 1.3.33-2
96 Requires:       apache(mod_dir)
97 Requires(triggerpostun):        sed >= 4.0
98 BuildArch:      noarch
99 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101 %define         _sysconfdir     /etc/%{name}
102 %define         _libdir         %{_prefix}/%{_lib}/%{name}
103 %define         _appdir %{_datadir}/%{name}
104 %define         _smartyplugindir        %{php_pear_dir}/Smarty/plugins
105
106 %define         _apache1dir     /etc/apache
107 %define         _apache2dir     /etc/httpd
108
109 %description
110 Eventum is a user-friendly and flexible issue tracking system that can
111 be used by a support department to track incoming technical support
112 requests, or by a software development team to quickly organize tasks
113 and bugs. Eventum is used by the MySQL AB Technical Support team, and
114 has allowed us to dramatically improve our response times.
115
116 %description -l pl
117 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
118 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
119 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
120 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
121 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
122 reakcji.
123
124 %package base
125 Summary:        Eventum base package
126 Summary(pl):    Podstawowy pakiet Eventum
127 Group:          Applications/WWW
128 Requires(pre):  /bin/id
129 Requires(pre):  /usr/bin/getgid
130 Requires(pre):  /usr/sbin/useradd
131 Requires(pre):  /usr/sbin/groupadd
132 Requires(postun):       /usr/sbin/userdel
133 Requires(postun):       /usr/sbin/groupdel
134 Provides:       user(eventum)
135 Provides:       group(eventum)
136
137 %description base
138 This package contains base directory structure for Eventum.
139
140 %description base -l pl
141 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
142
143 %package setup
144 Summary:        Eventum setup package
145 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
146 Group:          Applications/WWW
147 PreReq:         %{name} = %{epoch}:%{version}-%{release}
148
149 %description setup
150 Install this package to configure initial Eventum installation. You
151 should uninstall this package when you're done, as it considered
152 insecure to keep the setup files in place.
153
154 %description setup -l pl
155 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
156 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
157 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
158
159 %package mail-queue
160 Summary:        Eventum mail queue process
161 Summary(pl):    Przetwarzanie kolejki poczty Eventum
162 Group:          Applications/WWW
163 Requires:       %{name} = %{epoch}:%{version}-%{release}
164 Requires:       crondaemon
165 Requires:       php >= 4.1.0
166
167 %description mail-queue
168 Beginning with the first release of Eventum, emails are not directly
169 sent out from the various scripts, but rather added to a mail queue
170 table that is processed by a cron job. If an email cannot be sent, it
171 will be marked as such in the mail queue log, and the cron job script
172 will re-try to send it again the next time it runs.
173
174 This package contains the cron job.
175
176 %description mail-queue -l pl
177 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
178 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
179 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
180 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
181 nastêpnym razem.
182
183 Ten pakiet zawiera zadanie dla crona.
184
185 %package mail-download
186 Summary:        Eventum email download
187 Summary(pl):    ¦ci±ganie poczty Eventum
188 Group:          Applications/WWW
189 Requires:       %{name} = %{epoch}:%{version}-%{release}
190 Requires:       crondaemon
191 Requires:       php >= 4.1.0
192
193 %description mail-download
194 In order for Eventum's email integration feature to work, you need to
195 setup a cron job to run the script every so often.
196
197 This package contains the cron job.
198
199 %description mail-download -l pl
200 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
201 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
202 czêsto.
203
204 Ten pakiet zawiera zadanie dla crona.
205
206 %package reminder
207 Summary:        Eventum Reminder System
208 Summary(pl):    System przypominania dla Eventum
209 Group:          Applications/WWW
210 Requires:       %{name} = %{epoch}:%{version}-%{release}
211 Requires:       php >= 4.1.0
212 Requires:       crondaemon
213
214 %description reminder
215 The reminder system was designed with the objective as serving as a
216 safe net for issues that need attention. Depending on what
217 configuration you create, you may have several reminders (or alerts)
218 be sent out whenever an issue needs attention, for whatever parameter
219 you may deem necessary.
220
221 This package contains the cron job.
222
223 %description reminder -l pl
224 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
225 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
226 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
227 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
228 uwa¿aæ za potrzebny.
229
230 Ten pakiet zawiera zadanie dla crona.
231
232 %package monitor
233 Summary:        Eventum Heartbeat Monitor
234 Summary(pl):    Monitor ¿ycia dla Eventum
235 Group:          Applications/WWW
236 Requires:       %{name} = %{epoch}:%{version}-%{release}
237 Requires:       php >= 4.1.0
238 Requires:       php-posix
239 Requires:       crondaemon
240
241 %description monitor
242 The heartbeat monitor is a feature designed for the administrator that
243 wants to be alerted whenever a common problem in Eventum is detected,
244 like the database server not being available anymore, or maybe when
245 the recommended permissions for certain configuration files are
246 changed.
247
248 Please note that before running the heartbeat monitor, you may need to
249 customize some of the checks to be appropriate for your own system,
250 particularly the permission and file checks on
251 Monitor::checkConfiguration().
252
253 This package contains the cron job.
254
255 %description monitor -l pl
256 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
257 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
258 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
259 do plików konfiguracyjnych.
260
261 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
262 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
263 testów uprawnieñ i plików w Monitor::checkConfiguration().
264
265 Ten pakiet zawiera zadanie dla crona.
266
267 %package route-emails
268 Summary:        Eventum Email Routing
269 Summary(pl):    Przekazywanie poczty dla Eventum
270 Group:          Applications/WWW
271 Requires:       %{name} = %{epoch}:%{version}-%{release}
272 Requires:       php >= 4.1.0
273 Requires:       eventum(router)
274
275 %description route-emails
276 The email routing feature is used to automatically associate a thread
277 of emails into an Eventum issue. By setting up qmail (or even postfix)
278 to deliver emails sent to a specific address (usually
279 issue-<number>@<domain>) to the above script, users are able to use
280 their email clients to reply to emails coming from Eventum, and those
281 replies will be automatically associated with the issue and
282 broadcasted to the entire notification list.
283
284 %description route-emails -l pl
285 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
286 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
287 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
288 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
289 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
290 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
291 rozprowadzane do ca³ej listy og³oszeniowej.
292
293 %package route-notes
294 Summary:        Eventum Note Routing
295 Summary(pl):    Przekazywanie notatek dla Eventum
296 Group:          Applications/WWW
297 Requires:       %{name} = %{epoch}:%{version}-%{release}
298 Requires:       php >= 4.1.0
299 Requires:       eventum(router)
300
301 %description route-notes
302 The note routing feature is used to automatically associate a thread
303 of notes into an Eventum issue. By setting up qmail (or even postfix)
304 to deliver emails sent to a specific address (usually
305 note-<number>@<domain>) to the above script, users are able to use
306 their email clients to reply to internal notes coming from Eventum,
307 and those replies will be automatically associated with the issue and
308 broadcasted to the notification list staff members.
309
310 %description route-notes -l pl
311 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
312 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
313 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
314 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
315 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
316 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
317 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
318
319 %package router-qmail
320 Summary:        Eventum Mail Routing - qmail
321 Summary(pl):    Przekazywanie poczty Eventum - qmail
322 Group:          Applications/Mail
323 Requires:       %{name} = %{epoch}:%{version}-%{release}
324 Requires:       qmail >= 1.03
325 Provides:       eventum(router)
326 Obsoletes:      eventum(router)
327
328 %description router-qmail
329 This package provides way of routing notes and emails back to Eventum
330 via qmail.
331
332 %description router-qmail -l pl
333 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
334 przez qmaila.
335
336 %package router-postfix
337 Summary:        Eventum Mail Routing - Postfix
338 Summary(pl):    Przekazywanie poczty Eventum - Postfix
339 Group:          Applications/Mail
340 Requires:       %{name} = %{epoch}:%{version}-%{release}
341 Requires:       postfix
342 Provides:       eventum(router)
343 Obsoletes:      eventum(router)
344
345 %description router-postfix
346 This package provides way of routing notes and emails back to Eventum
347 via Postfix.
348
349 %description router-postfix -l pl
350 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
351 przez Postfiksa.
352
353 %package irc
354 Summary:        Eventum IRC Notification Bot
355 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
356 Group:          Applications/WWW
357 Requires:       %{name} = %{epoch}:%{version}-%{release}
358 Requires:       php >= 4.1.0
359 Requires:       php-sockets
360 Requires:       rc-scripts >= 0.4.0.18
361
362 %description irc
363 The IRC notification bot is a nice feature for remote teams that want
364 to handle issues and want to have a quick and easy way to get simple
365 notifications. Right now the bot notifies of the following actions:
366 - New Issues
367 - Blocked emails
368 - Issues that got their assignment list changed
369
370 NOTE: You will need to manually edit the bot.php script to set your
371 appropriate preferences, like IRC server and channel that the bot
372 should join.
373
374 %description irc -l pl
375 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
376 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
377 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
378 nastêpuj±cych zdarzeniach:
379 - nowych sprawach
380 - zablokowanych listach
381 - sprawach, dla których zmieni³a siê lista powi±zañ
382
383 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
384 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
385
386 %package cli
387 Summary:        Eventum command-line interface
388 Summary(pl):    Interfejs linii poleceñ dla Eventum
389 Group:          Applications/WWW
390 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
391 Requires:       php >= 4.1.0
392 Requires:       php-cli
393 Requires:       php-curl
394 Requires:       php-xml
395 Requires:       php-pear-XML_RPC
396
397 %description cli
398 The Eventum command-line interface allows you to access most of the
399 features of the web interface straight from your command shell.
400
401 %description cli -l pl
402 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
403 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
404
405 %package scm
406 Summary:        Eventum SCM integration
407 Summary(pl):    Integracja SCM dla Eventum
408 Group:          Applications/WWW
409 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
410 Requires:       php-cli >= 4.1.0
411 Requires:       php-pcre
412
413 %description scm
414 This feature allows your software development teams to integrate your
415 Source Control Management system with your Issue Tracking System.
416
417 The integration is implemented in such a way that it will be forward
418 compatible with pretty much any SCM system, such as CVS.
419
420 For installation see
421 </eventum/help.php?topic=scm_integration_installation>.
422
423 %description scm -l pl
424 Ten pakiet pozwala zespo³om programistów na integracjê systemu
425 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
426 ¶ledzenia spraw.
427
428 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
429 prawie ka¿dym systemem SCM, jak np. CVS.
430
431 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
432 </eventum/help.php?topic=scm_integration_installation>.
433
434 %prep
435 %setup -q %{?_snap:-n %{name}-%{_snap}}
436 # undos the source
437 find . -type f -print0 | xargs -0 sed -i -e 's,
438 $,,'
439
440 # packaging
441 %patch0 -p1 -b .paths
442 %patch1 -p1
443 %patch2 -p1
444 %{?with_pear:%patch3 -p1 -b .PEAR}
445
446 # bug fixes.
447 %patch4 -p1
448 %patch5 -p1
449 %patch6 -p1
450 %patch7 -p1
451 %patch8 -p1
452 %patch9 -p1
453 %patch10 -p1
454 %patch11 -p1
455
456 # replace in remaining scripts config.inc.php to system one
457 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
458         s,include_once(".*config.inc.php"),include_once("%{_sysconfdir}/core.php"),
459 '
460 sed -i -e '
461         s,include(".*config.inc.php"),include_once("%{_sysconfdir}/core.php"),
462 ' misc/download_emails.php
463
464 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
465         s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_sysconfdir}/private_key.php"),
466 '
467 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
468
469 %install
470 rm -rf $RPM_BUILD_ROOT
471 install -d \
472         $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_libdir}} \
473         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
474         $RPM_BUILD_ROOT/var/{run,log,cache,lib}/%{name} \
475         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
476
477 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
478 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
479 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
480 cp -a misc/irc $RPM_BUILD_ROOT%{_appdir}
481 cp -a templates $RPM_BUILD_ROOT%{_appdir}
482 cp -a include/{customer,jpgraph,pear,workflow} $RPM_BUILD_ROOT%{_appdir}/include
483 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
484 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
485 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
486
487 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
488 install %{SOURCE13} $RPM_BUILD_ROOT%{_appdir}/htdocs/setup/config.inc.php
489 install %{SOURCE14} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
490
491 # cli
492 install -d $RPM_BUILD_ROOT%{_appdir}/cli
493 install misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
494 install misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
495 sed -e '1s,#!.*/bin/php,#!%{_bindir}/php4,' \
496         misc/cli/eventum > $RPM_BUILD_ROOT%{_bindir}/%{name}
497 cp -f misc/cli/eventumrc_example eventumrc
498
499 # scm
500 echo '#!%{_bindir}/php4 -q' > %{name}-scm
501 cat misc/scm/process_cvs_commits.php >> %{name}-scm
502 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
503
504 # private key
505 mv $RPM_BUILD_ROOT{%{_appdir}/include/private_key.php,%{_sysconfdir}}
506 # change private key, so we can easily grep
507 sed -i -e '
508 s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
509 ' $RPM_BUILD_ROOT%{_sysconfdir}/private_key.php
510
511 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
512 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
513 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
514 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
515 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
516 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
517 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
518 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
519 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
520 sed -e 's,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}},' \
521         %{SOURCE10} > $RPM_BUILD_ROOT%{_sysconfdir}/core.php
522
523 # config
524 > $RPM_BUILD_ROOT%{_sysconfdir}/setup.php
525 mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_sysconfdir}/config}.php
526
527 # sample, not used in eventum
528 rm -f $RPM_BUILD_ROOT%{_appdir}/htdocs/rpc/xmlrpc_client.php
529
530 %if %{with pear}
531 # provided by PEAR
532 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
533 %endif
534
535 # use system Smarty
536 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
537 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
538 # These plugins are not in Smarty package (Smarty-2.6.2-3)
539 cp -a include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
540         $RPM_BUILD_ROOT%{_smartyplugindir}
541
542 # qmail router
543 %if %{with qmail}
544 d=$RPM_BUILD_ROOT/var/lib/%{name}
545 echo 'root' > $d/.qmail
546 echo 'root' > $d/.qmail-default
547 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
548 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
549 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
550 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
551 %endif
552
553 %clean
554 rm -rf $RPM_BUILD_ROOT
555
556 %pre
557 %addusertogroup http %{name}
558
559 %post
560 # apache1
561 if [ -d %{_apache1dir}/conf.d ]; then
562         ln -sf %{_sysconfdir}/apache.conf %{_apache1dir}/conf.d/99_%{name}.conf
563         if [ -f /var/lock/subsys/apache ]; then
564                 /etc/rc.d/init.d/apache restart 1>&2
565         fi
566 fi
567 # apache2
568 if [ -d %{_apache2dir}/httpd.conf ]; then
569         ln -sf %{_sysconfdir}/apache.conf %{_apache2dir}/httpd.conf/99_%{name}.conf
570         if [ -f /var/lock/subsys/httpd ]; then
571                 /etc/rc.d/init.d/httpd restart 1>&2
572         fi
573 fi
574
575 # check if the package is configured.
576 if grep -q 'header("Location: setup/")' %{_sysconfdir}/config.php; then
577 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
578 %banner %{name} -e <<EOF
579
580 You haven't yet configured Eventum!
581 Please open in browser <http://localhost/eventum/>
582 If you need access from elsewhere, you need to edit
583 %{_sysconfdir}/apache.conf and restart apache.
584
585 IMPORTANT: When You have configured Eventum, please uninstall the
586 setup package, so that %{name}-setup is able to secure your Eventum
587 installation.
588
589 EOF
590 #' vim stupidity.
591 else
592 %banner %{name} -e <<EOF
593
594 You haven't yet configured Eventum!
595
596 To setup eventum, please install %{name}-setup and open in browser
597 <http://localhost/eventum/>.
598 If you need access from elsewhere, you need to edit
599 %{_sysconfdir}/apache.conf and restart apache.
600
601 IMPORTANT: When You have configured Eventum, please uninstall the
602 setup package, so that %{name}-setup is able to secure your Eventum
603 installation.
604
605 EOF
606 #' vim stupidity.
607 fi
608
609 elif grep -q 'DEFAULTPRIVATEKEY' %{_sysconfdir}/private_key.php; then
610 %banner %{name} -e <<EOF
611
612 You have default private key installed!
613
614 Install %{name}-setup and open up http://yourserver/eventum/setup/
615 -- that will help you setup initial config.
616
617 when have configured Eventum, please uninstall the setup package,
618 so that %{name}-setup is able to secure your Eventum installation.
619
620 EOF
621         elif [ -d %{_appdir}/setup ]; then
622 %banner %{name} -e <<EOF
623
624 If you have have configured Eventum, please uninstall the setup package,
625 so that %{name}-setup is able to secure your Eventum installation.
626
627 EOF
628 fi
629
630 # nuke Smarty templates cache after upgrade
631 rm -f /var/cache/eventum/*.php
632
633 %preun
634 if [ "$1" = "0" ]; then
635         # apache1
636         if [ -f %{_apache1dir}/apache.conf ]; then
637                 rm -f %{_apache1dir}/conf.d/99_%{name}.conf
638                 if [ -f /var/lock/subsys/apache ]; then
639                         /etc/rc.d/init.d/apache restart 1>&2
640                 fi
641         fi
642         # apache2
643         if [ -d %{_apache2dir}/httpd.conf ]; then
644                 rm -f %{_apache2dir}/httpd.conf/99_%{name}.conf
645                 if [ -f /var/lock/subsys/httpd ]; then
646                         /etc/rc.d/init.d/httpd restart 1>&2
647                 fi
648         fi
649
650         # nuke cache
651         rm -f /var/cache/eventum/*.php 2>/dev/null || :
652 fi
653
654 %pre base
655 %groupadd -P %{name}-base -g %{gid} %{name}
656 %useradd -P %{name}-base -u %{uid} -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
657
658 %postun base
659 if [ "$1" = "0" ]; then
660         %userremove %{name}
661         %groupremove %{name}
662 fi
663
664 %if %{with qmail}
665 %post router-qmail
666 CF=/etc/qmail/control/virtualdomains
667 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
668         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_sysconfdir}/config.php 2>/dev/null)
669         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
670         umask 022
671         echo "#${FQDN}:%{name}" >> $CF
672
673 %banner %{name}-qmail -e <<EOF
674
675 Added "#${FQDN}:%{name}" to $CF,
676 Please verify that it is correct and restart qmail:
677 # service qmail reload
678
679 Consult qmail-send(8) for more information on virtualdomains.
680
681 EOF
682 fi
683
684 %preun router-qmail
685 if [ "$1" = "0" ]; then
686         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
687 fi
688 %endif
689
690 %post setup
691 chmod 660 %{_sysconfdir}/{config,private_key}.php
692 chown root:eventum %{_sysconfdir}/{config,private_key}.php
693
694 %postun setup
695 if [ "$1" = "0" ]; then
696         chmod 640 %{_sysconfdir}/{config,private_key}.php
697         chown root:eventum %{_sysconfdir}/{config,private_key}.php
698 fi
699
700 # FIXME
701 # only one upgrade trigger is called if you're upgrading over two
702 # versions, say 1.5 to 1.5.3, only 1.5.3 trigger is called.
703 # use common trigger (the highest version and rpmvercmp from poldek?)
704 %triggerpostun -- eventum < 1.5.1-0.257
705 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5_to_v1.5.1 <<EOF
706 database_changes.php Perform database changes
707 EOF
708
709 %triggerpostun -- eventum < 1.5.2-0.289
710 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.1_to_v1.5.2 <<EOF
711 database_changes.php Perform database changes
712 set_priority_ranks.php Fix the ranking of priority values
713 EOF
714
715 %triggerpostun -- eventum < 1.5.3-0.291
716 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.2_to_v1.5.3 <<EOF
717 database_changes.php Perform database changes
718 EOF
719
720 %triggerpostun -- eventum < 1.5.4-1.12
721 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.3_to_v1.5.4 <<EOF
722 database_changes.php Perform database changes
723 EOF
724
725 %files
726 %defattr(644,root,root,755)
727 %doc ChangeLog FAQ INSTALL README UPGRADE
728 %doc docs/* rpc/xmlrpc_client.php setup/schema.sql
729 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
730 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
731 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/private_key.php
732 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/setup.php
733 %attr(640,root,eventum) %config %verify(not mtime) %{_sysconfdir}/core.php
734
735 %dir %attr(731,root,eventum) /var/log/%{name}
736 %attr(620,root,eventum) %ghost /var/log/%{name}/*
737
738 %dir %{_appdir}/htdocs
739 %{_appdir}/htdocs/*.php
740 %{_appdir}/htdocs/*.ico
741 %{_appdir}/htdocs/css
742 %{_appdir}/htdocs/customer
743 %{_appdir}/htdocs/images
744 %{_appdir}/htdocs/js
745 %{_appdir}/htdocs/manage
746 %{_appdir}/htdocs/reports
747 %{_appdir}/htdocs/rpc
748 %{_appdir}/htdocs/misc
749
750 %{_appdir}/templates
751 %dir %{_appdir}/upgrade
752 %attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
753 %{_appdir}/upgrade/[!u]*
754
755 %{_smartyplugindir}/*
756 %if %{without pear}
757 %{_appdir}/include/pear
758 %endif
759
760 %dir %{_appdir}/include
761 %{_appdir}/include/customer
762 %{_appdir}/include/jpgraph
763 %{_appdir}/include/workflow
764 %{_appdir}/include/class.[!m]*.php
765 %{_appdir}/include/class.mail.php
766 %{_appdir}/include/class.mail_queue.php
767 %{_appdir}/include/class.mime_helper.php
768 %{_appdir}/include/class.misc.php
769 %{_appdir}/include/db_access.php
770 %{_appdir}/include/jsrsServer.inc.php
771
772 %dir %attr(730,root,eventum) /var/run/%{name}
773 %dir %attr(730,root,eventum) /var/cache/%{name}
774
775 %files base
776 %defattr(644,root,root,755)
777 %attr(751,root,root) %dir %{_sysconfdir}
778 %dir %{_libdir}
779 %dir %{_appdir}
780 # qmail will ignore user, if it's home directory is not owned
781 %attr(750,eventum,eventum) %dir /var/lib/%{name}
782
783 %files setup
784 %defattr(644,root,root,755)
785 %{_appdir}/htdocs/setup
786
787 %files mail-queue
788 %defattr(644,root,root,755)
789 %{_appdir}/process_mail_queue.php
790 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
791
792 %files mail-download
793 %defattr(644,root,root,755)
794 %{_appdir}/download_emails.php
795 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
796
797 %files reminder
798 %defattr(644,root,root,755)
799 %{_appdir}/check_reminders.php
800 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
801
802 %files monitor
803 %defattr(644,root,root,755)
804 %{_appdir}/include/class.monitor.php
805 %{_appdir}/monitor.php
806 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
807
808 %files route-emails
809 %defattr(644,root,root,755)
810 %{_appdir}/route_emails.php
811
812 %files route-notes
813 %defattr(644,root,root,755)
814 %{_appdir}/route_drafts.php
815 %{_appdir}/route_notes.php
816
817 %if %{with qmail}
818 %files router-qmail
819 %defattr(644,root,root,755)
820 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
821 %attr(755,root,root) %{_libdir}/router-qmail
822 %endif
823
824 %files router-postfix
825 %defattr(644,root,root,755)
826
827 %files irc
828 %defattr(644,root,root,755)
829 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
830 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
831 %{_appdir}/irc
832 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
833
834 %files cli
835 %defattr(644,root,root,755)
836 %doc eventumrc
837 %attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
838 %attr(755,root,root) %{_bindir}/%{name}
839 %{_appdir}/cli
840
841 %files scm
842 %defattr(644,root,root,755)
843 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
844 %attr(755,root,root) %{_libdir}/scm
This page took 0.07817 seconds and 4 git commands to generate.