]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- up to 2.3.1 release
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 #
9 # Conditional build:
10 %bcond_without  order   # with experimental order patch
11
12 %define         php_min_version 5.1.2
13 %define         subver  4282
14 %define         rel             1
15 %include        /usr/lib/rpm/macros.php
16 Summary:        Eventum Issue / Bug tracking system
17 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
18 Name:           eventum
19 Version:        2.3.1
20 Release:        %{rel}.bzr%{subver}
21 License:        GPL
22 Group:          Applications/WWW
23 Source0:        http://launchpad.net/eventum/trunk/%{version}/+download/%{name}-%{version}.tar.gz
24 # Source0-md5:  7eb5055260fcf096bc48b0e6c4758e3b
25 #Source0:       %{name}-%{version}-dev-r%{subver}.tar.gz
26 Source1:        %{name}-apache.conf
27 Source2:        %{name}-mail-queue.cron
28 Source3:        %{name}-mail-download.cron
29 Source4:        %{name}-reminder.cron
30 Source5:        %{name}-monitor.cron
31 Source6:        %{name}-cvs.php
32 Source7:        %{name}-irc.php
33 Source8:        %{name}-irc.init
34 Source9:        %{name}-irc.sysconfig
35 Source13:       %{name}-router-postfix.sh
36 Source14:       %{name}.logrotate
37 Source15:       %{name}-lighttpd.conf
38 Source16:       http://www.isocra.com/images/updown2.gif
39 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
40 Patch0:         %{name}-lf.patch
41 Patch2:         %{name}-order.patch
42 Patch3:         group-users.patch
43 # packaging patches that probably never go upstream
44 Patch100:       %{name}-paths.patch
45 Patch101:       %{name}-cvs-config.patch
46 Patch105:       %{name}-bot-reconnect.patch
47 Patch107:       %{name}-gettext.patch
48 # some tests
49 Patch200:       %{name}-fixed-nav.patch
50 URL:            http://eventum.mysql.org/
51 BuildRequires:  gettext-devel
52 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
53 BuildRequires:  rpmbuild(macros) >= 1.461
54 BuildRequires:  sed >= 4.0
55 Requires:       %{name}-base = %{version}-%{release}
56 Requires:       Smarty >= 2.6.10-4
57 Requires:       php-common >= 4:%{php_min_version}
58 Requires:       php-filter
59 Requires:       php-gd
60 Requires:       php-iconv
61 Requires:       php-imap
62 Requires:       php-mbstring
63 Requires:       php-mysql
64 Requires:       php-pcre
65 Requires:       php-pear-DB
66 Requires:       php-pear-Date
67 Requires:       php-pear-Mail
68 Requires:       php-pear-Mail_Mime
69 Requires:       php-pear-Mail_mimeDecode
70 Requires:       php-pear-Math_Stats
71 Requires:       php-pear-Net_DIME
72 Requires:       php-pear-Net_SMTP
73 Requires:       php-pear-Net_Socket
74 Requires:       php-pear-Net_URL
75 Requires:       php-pear-Net_UserAgent_Detect
76 Requires:       php-pear-PEAR-core
77 Requires:       php-pear-Text_Diff
78 Requires:       php-pear-XML_RPC
79 Requires:       php-session
80 Requires:       smarty-gettext
81 Requires:       webapps
82 Requires:       webserver(access)
83 Requires:       webserver(alias)
84 Requires:       webserver(indexfile)
85 Requires:       webserver(php) >= 4.2.0
86 Suggests:       localedb
87 Conflicts:      logrotate < 3.7-4
88 BuildArch:      noarch
89 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
90
91 %define         _noautopear     pear(../init.php) pear(init.php) pear(/etc/webapps/.*) pear(%{_appdir}/.*) pear(jpgraph_dir.php) pear(.*Smarty.class.php) pear(Services/JSON.php) pear(class.date_helper.php)
92
93 # exclude optional php dependencies
94 %define         _noautophp      php-gnupg php-hash php-pecl-http php-json php-tk
95
96 %define         _noautoreq      %{_noautophp} %{_noautopear}
97
98 %define         _libdir         %{_prefix}/lib/%{name}
99 %define         _appdir         %{_datadir}/%{name}
100 %define         _smartydir      %{php_data_dir}/Smarty
101 %define         _webapps        /etc/webapps
102 %define         _webapp         %{name}
103 %define         _webappdir      %{_webapps}/%{_webapp}
104 %define         _sysconfdir     /etc/%{name}
105
106 %description
107 Eventum is a user-friendly and flexible issue tracking system that can
108 be used by a support department to track incoming technical support
109 requests, or by a software development team to quickly organize tasks
110 and bugs. Eventum is used by the MySQL AB Technical Support team, and
111 has allowed us to dramatically improve our response times.
112
113 %description -l pl.UTF-8
114 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
115 może być używany przez dział obsługi do śledzenia przychodzących żądań
116 obsługi technicznej albo przez zespół tworzący oprogramowanie do
117 szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
118 Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
119 reakcji.
120
121 %package base
122 Summary:        Eventum base package
123 Summary(pl.UTF-8):      Podstawowy pakiet Eventum
124 Group:          Applications/WWW
125 Requires(postun):       /usr/sbin/groupdel
126 Requires(postun):       /usr/sbin/userdel
127 Requires(pre):  /bin/id
128 Requires(pre):  /usr/bin/getgid
129 Requires(pre):  /usr/sbin/groupadd
130 Requires(pre):  /usr/sbin/useradd
131 Provides:       group(eventum)
132 Provides:       user(eventum)
133
134 %description base
135 This package contains base directory structure for Eventum.
136
137 %description base -l pl.UTF-8
138 Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
139
140 %package setup
141 Summary:        Eventum setup package
142 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
143 Group:          Applications/WWW
144 Requires:       %{name} = %{version}-%{release}
145
146 %description setup
147 Install this package to configure initial Eventum installation. You
148 should uninstall this package when you're done, as it considered
149 insecure to keep the setup files in place.
150
151 %description setup -l pl.UTF-8
152 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
153 pierwszej instalacji. Potem należy go odinstalować, jako że
154 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
155
156 %package mail-queue
157 Summary:        Eventum mail queue process
158 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
159 Group:          Applications/WWW
160 Requires:       %{name} = %{version}-%{release}
161 Requires:       crondaemon
162
163 %description mail-queue
164 Beginning with the first release of Eventum, emails are not directly
165 sent out from the various scripts, but rather added to a mail queue
166 table that is processed by a cron job. If an email cannot be sent, it
167 will be marked as such in the mail queue log, and the cron job script
168 will re-try to send it again the next time it runs.
169
170 This package contains the cron job.
171
172 %description mail-queue -l pl.UTF-8
173 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
174 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
175 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
176 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
177 następnym razem.
178
179 Ten pakiet zawiera zadanie dla crona.
180
181 %package mail-download
182 Summary:        Eventum email download
183 Summary(pl.UTF-8):      Ściąganie poczty Eventum
184 Group:          Applications/WWW
185 Requires:       %{name} = %{version}-%{release}
186 Requires:       crondaemon
187
188 %description mail-download
189 In order for Eventum's email integration feature to work, you need to
190 setup a cron job to run the script every so often.
191
192 This package contains the cron job.
193
194 %description mail-download -l pl.UTF-8
195 Aby integracja poczty elektronicznej w Eventum działała, trzeba
196 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
197 często.
198
199 Ten pakiet zawiera zadanie dla crona.
200
201 %package reminder
202 Summary:        Eventum Reminder System
203 Summary(pl.UTF-8):      System przypominania dla Eventum
204 Group:          Applications/WWW
205 Requires:       %{name} = %{version}-%{release}
206 Requires:       crondaemon
207
208 %description reminder
209 The reminder system was designed with the objective as serving as a
210 safe net for issues that need attention. Depending on what
211 configuration you create, you may have several reminders (or alerts)
212 be sent out whenever an issue needs attention, for whatever parameter
213 you may deem necessary.
214
215 This package contains the cron job.
216
217 %description reminder -l pl.UTF-8
218 System przypominania został zaprojektowany tak, aby służył jako
219 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
220 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
221 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
222 uważać za potrzebny.
223
224 Ten pakiet zawiera zadanie dla crona.
225
226 %package monitor
227 Summary:        Eventum Heartbeat Monitor
228 Summary(pl.UTF-8):      Monitor życia dla Eventum
229 Group:          Applications/WWW
230 Requires:       %{name} = %{version}-%{release}
231 Requires:       crondaemon
232 Requires:       php(posix)
233
234 %description monitor
235 The heartbeat monitor is a feature designed for the administrator that
236 wants to be alerted whenever a common problem in Eventum is detected,
237 like the database server not being available anymore, or maybe when
238 the recommended permissions for certain configuration files are
239 changed.
240
241 Please note that before running the heartbeat monitor, you may need to
242 customize some of the checks to be appropriate for your own system,
243 particularly the permission and file checks on
244 Monitor::checkConfiguration().
245
246 This package contains the cron job.
247
248 %description monitor -l pl.UTF-8
249 Monitor życia to funkcjonalność zaprojektowana dla administratora
250 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
251 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
252 do plików konfiguracyjnych.
253
254 Należy zauważyć, że przed uruchomieniem tego monitora może być
255 konieczne dostosowanie niektórych testów do systemu, w szczególności
256 testów uprawnień i plików w Monitor::checkConfiguration().
257
258 Ten pakiet zawiera zadanie dla crona.
259
260 %package route-drafts
261 Summary:        Eventum Draft Routing
262 Summary(pl.UTF-8):      Przekazywanie szkiców dla Eventum
263 Group:          Applications/WWW
264 Requires:       %{name} = %{version}-%{release}
265 Requires:       eventum(router)
266
267 %description route-drafts
268 The draft routing feature is used to automatically associate a thread
269 of drafts into an Eventum issue. By setting up Postfix to deliver
270 emails sent to a specific address (usually draft-<number>@<domain>) to
271 the above script, users are able to send drafts written in their mail
272 client to be stored in Eventum. These drafts will NOT broadcasted to
273 the notification list.
274
275 %description route-drafts -l pl.UTF-8
276 Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
277 problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
278 wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
279 skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
280 kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
281 na listę powiadomień.
282
283 %package route-emails
284 Summary:        Eventum Email Routing
285 Summary(pl.UTF-8):      Przekazywanie poczty dla Eventum
286 Group:          Applications/WWW
287 Requires:       %{name} = %{version}-%{release}
288 Requires:       eventum(router)
289
290 %description route-emails
291 The email routing feature is used to automatically associate a thread
292 of emails into an Eventum issue. By setting up Postfix to deliver
293 emails sent to a specific address (usually issue-<number>@<domain>) to
294 the above script, users are able to use their email clients to reply
295 to emails coming from Eventum, and those replies will be automatically
296 associated with the issue and broadcasted to the entire notification
297 list.
298
299 %description route-emails -l pl.UTF-8
300 Funkcjonalność przekazywania poczty służy do automatycznego wiązania
301 wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
302 aby dostarczał listy wysyłane na pewien adres (zwykle
303 issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
304 używać klientów pocztowych do odpowiadania na listy przychodzące z
305 Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
306 rozprowadzane do całej listy ogłoszeniowej.
307
308 %package route-notes
309 Summary:        Eventum Note Routing
310 Summary(pl.UTF-8):      Przekazywanie notatek dla Eventum
311 Group:          Applications/WWW
312 Requires:       %{name} = %{version}-%{release}
313 Requires:       eventum(router)
314
315 %description route-notes
316 The note routing feature is used to automatically associate a thread
317 of notes into an Eventum issue. By setting up Postfix to deliver
318 emails sent to a specific address (usually note-<number>@<domain>) to
319 the above script, users are able to use their email clients to reply
320 to internal notes coming from Eventum, and those replies will be
321 automatically associated with the issue and broadcasted to the
322 notification list staff members.
323
324 %description route-notes -l pl.UTF-8
325 Funkcjonalność przekazywania notatek służy do automatycznego wiązania
326 wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
327 dostarczał listy wysyłane na pewien adres (zwykle
328 note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
329 używać klientów pocztowych do odpowiadania na wewnętrzne notatki
330 pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
331 sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
332
333 %package router-postfix
334 Summary:        Eventum Mail Routing - Postfix
335 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
336 Group:          Applications/Mail
337 Requires:       %{name} = %{version}-%{release}
338 Requires:       postfix
339 Provides:       eventum(router)
340 Obsoletes:      eventum(router)
341
342 %description router-postfix
343 This package provides way of routing notes and emails back to Eventum
344 via Postfix.
345
346 The Postfix configuration instructions you can find from
347 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
348
349 %description router-postfix -l pl.UTF-8
350 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
351 przez Postfiksa.
352
353 Opis konfiguracji Postfiksa można znaleźć pod adresem
354 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
355
356 %package irc
357 Summary:        Eventum IRC Notification Bot
358 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
359 Group:          Applications/WWW
360 Requires(post,preun):   /sbin/chkconfig
361 Requires:       %{name} = %{version}-%{release}
362 Requires:       php(sockets)
363 Requires:       php-pear-Net_SmartIRC
364 Requires:       rc-scripts >= 0.4.0.18
365
366 %description irc
367 The IRC notification bot is a nice feature for remote teams that want
368 to handle issues and want to have a quick and easy way to get simple
369 notifications. Right now the bot notifies of the following actions:
370 - New Issues
371 - Blocked emails
372 - Issues that got their assignment list changed
373
374 NOTE: You will need to manually edit the bot.php script to set your
375 appropriate preferences, like IRC server and channel that the bot
376 should join.
377
378 %description irc -l pl.UTF-8
379 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
380 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
381 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
382 następujących zdarzeniach:
383 - nowych sprawach
384 - zablokowanych listach
385 - sprawach, dla których zmieniła się lista powiązań
386
387 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
388 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
389
390 %package cli
391 Summary:        Eventum command-line interface
392 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
393 Group:          Applications/WWW
394 Requires:       %{name}-base = %{version}-%{release}
395 Requires:       php-cli
396 Requires:       php-common >= 4:%{php_min_version}
397 Requires:       php-pear-XML_RPC
398
399 %description cli
400 The Eventum command-line interface allows you to access most of the
401 features of the web interface straight from your command shell.
402
403 %description cli -l pl.UTF-8
404 Interfejs linii poleceń Eventum pozwala na dostęp do większości
405 funkcji interfejsu WWW prosto z linii poleceń powłoki.
406
407 %package scm
408 Summary:        Eventum SCM integration
409 Summary(pl.UTF-8):      Integracja SCM dla Eventum
410 Group:          Applications/WWW
411 Requires:       %{name}-base = %{version}-%{release}
412 Requires:       php-cli
413 Requires:       php-common >= 4:%{php_min_version}
414 Requires:       php-pcre
415
416 %description scm
417 This feature allows your software development teams to integrate your
418 Source Control Management system with your Issue Tracking System.
419
420 The integration is implemented in such a way that it will be forward
421 compatible with pretty much any SCM system, such as CVS.
422
423 For installation see
424 </eventum/help.php?topic=scm_integration_installation>.
425
426 %description scm -l pl.UTF-8
427 Ten pakiet pozwala zespołom programistów na integrację systemu
428 zarządzania źródłami (SCM - Source Control Management) z systemem
429 śledzenia spraw.
430
431 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
432 prawie każdym systemem SCM, jak np. CVS.
433
434 Szczegóły na temat instalacji można przeczytać pod
435 </eventum/help.php?topic=scm_integration_installation>.
436
437 %prep
438 %setup -q
439
440 # GPL v2
441 rm docs/COPYING
442
443 rm -r upgrade/*v1.[123]* # too old to support in PLD Linux
444 rm -r upgrade/v{1.,2.0,2.1_}* # no longer supported in PLD Linux
445 rm upgrade/flush_compiled_templates.php
446 rm -r upgrade/{*/,}index.html # not needed in PLD Linux
447
448 # bug fixes / features
449 %patch0 -p1
450 %{?with_order:%patch2 -p1}
451 %patch3 -p0
452
453 cp -a %{SOURCE16} htdocs/images
454
455 #%patch200 -p1
456
457 # packaging
458 %patch100 -p1
459 %patch101 -p1
460 %patch105 -p1
461 %patch107 -p1
462
463 %{__sed} -i -e "
464 s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
465 " upgrade/{*/,}*.php
466
467 # remove backups from patching as we use globs to package files to buildroot
468 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
469
470 %build
471 %{__make} -C localization
472
473 %install
474 rm -rf $RPM_BUILD_ROOT
475 install -d \
476         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
477         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
478         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
479         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
480         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
481         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
482
483 %{__make} install-eventum install-cli install-irc install-scm install-jpgraph install-localization \
484         sysconfdir=%{_webappdir} \
485         DESTDIR=$RPM_BUILD_ROOT
486
487 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
488
489 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
490 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
491 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
492 cp -a %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
493
494 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
495 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
496 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
497 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
498
499 cp -a %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
500
501 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
502 cp -a %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
503
504 cp -a %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
505
506 # postfix router
507 install %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
508
509 %find_lang %{name}
510
511 # scm
512 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
513
514 # old compat
515 ln -s %{_sbindir}/eventum-cvs-hook $RPM_BUILD_ROOT%{_libdir}/process_cvs_commits
516 ln -s %{_sbindir}/eventum-svn-hook $RPM_BUILD_ROOT%{_libdir}/process_svn_commits
517
518 # skip pear for cli
519 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
520 cp -a cli/lib/eventum $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
521
522 %clean
523 rm -rf $RPM_BUILD_ROOT
524
525 %pre
526 %addusertogroup http %{name}
527
528 %post
529 # greate empty ghost files
530 for a in cli.log errors.log irc_bot.log login_attempts.log; do
531         if [ ! -f /var/log/%{name}/$a ]; then
532                 install -m 0620 -o root -g eventum /dev/null /var/log/%{name}/$a
533         fi
534 done
535
536 # database update
537 %{_appdir}/upgrade/update-database.php || :
538
539 # nuke Smarty templates cache after upgrade
540 rm -f /var/cache/eventum/*.php
541
542 # Restart webserver on upgrade to get .mo translations reloaded.
543 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
544 %php_webserver_restart
545
546 %preun
547 if [ "$1" = "0" ]; then
548         # nuke cache
549         rm -f /var/cache/eventum/*.php 2>/dev/null || :
550 fi
551
552 %pre base
553 %groupadd -P %{name}-base -g 146 %{name}
554 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
555
556 %postun base
557 if [ "$1" = "0" ]; then
558         %userremove %{name}
559         %groupremove %{name}
560 fi
561
562 %post setup
563 chmod 660 %{_webappdir}/{config,private_key}.php
564 chown root:http %{_webappdir}/{config,private_key}.php
565
566 %postun setup
567 if [ "$1" = "0" ]; then
568         chmod 640 %{_webappdir}/{config,private_key}.php
569         chown root:http %{_webappdir}/{config,private_key}.php
570 fi
571
572 %post irc
573 /sbin/chkconfig --add eventum-irc
574 %service eventum-irc restart "Eventum IRC Bot"
575
576 %preun irc
577 if [ "$1" = 0 ]; then
578         %service eventum-irc stop
579         /sbin/chkconfig --del eventum-irc
580 fi
581
582 %triggerin -- apache1 < 1.3.37-3, apache1-base
583 %webapp_register apache %{_webapp}
584
585 %triggerun -- apache1 < 1.3.37-3, apache1-base
586 %webapp_unregister apache %{_webapp}
587
588 %triggerin -- apache < 2.2.0, apache-base
589 %webapp_register httpd %{_webapp}
590
591 %triggerun -- apache < 2.2.0, apache-base
592 %webapp_unregister httpd %{_webapp}
593
594 %triggerin -- lighttpd
595 %webapp_register lighttpd %{_webapp}
596
597 %triggerun -- lighttpd
598 %webapp_unregister lighttpd %{_webapp}
599
600 %triggerpostun -- %{name} < 2.2-2.57
601 # switching eventum->http user
602 chgrp http %{_webappdir}/config.php
603 chgrp http %{_webappdir}/private_key.php
604 chgrp http %{_webappdir}/setup.php
605 chgrp http /var/log/%{name}/*
606 # update crontab user
607 for a in /etc/cron.d/eventum-*; do
608         [ -f "$a" ] || continue
609         awk '!/#/ && NR > 6 && $6 =="eventum" {sub("eventum", "http", $6)}{print}'  $a > $a.rpmtmp && cat $a.rpmtmp > $a
610         rm -f $a.rpmtmp
611
612         # crontabs moved to crons subdir
613         %{__sed} -i -e '
614                 s,/usr/share/eventum/process_mail_queue.php,/usr/share/eventum/crons/process_mail_queue.php,
615                 s,/usr/share/eventum/download_emails.php,/usr/share/eventum/crons/download_emails.php,
616                 s,/usr/share/eventum/check_reminders.php,/usr/share/eventum/crons/check_reminders.php,
617                 s,/usr/share/eventum/monitor.php,/usr/share/eventum/crons/monitor.php,
618         ' $a
619 done
620
621 %files -f %{name}.lang
622 %defattr(644,root,root,755)
623 %doc docs/* htdocs/setup/schema.sql
624 %attr(751,root,root) %dir %{_webappdir}
625 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
626 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
627 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
628 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
629 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
630 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
631 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
632
633 %dir %attr(731,root,http) /var/log/%{name}
634 %attr(620,root,http) %ghost /var/log/%{name}/*
635 %dir %attr(750,root,root) /var/log/archive/%{name}
636 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
637
638 %dir %{_appdir}/crons
639 %{_appdir}/init.php
640 %dir %{_appdir}/htdocs
641 %{_appdir}/htdocs/*.php
642 %{_appdir}/htdocs/*.ico
643 %{_appdir}/htdocs/css
644 %{_appdir}/htdocs/customer
645 %{_appdir}/htdocs/images
646 %{_appdir}/htdocs/js
647 %{_appdir}/htdocs/manage
648 %{_appdir}/htdocs/reports
649 %{_appdir}/htdocs/rpc
650 %{_appdir}/htdocs/misc
651 %if %{with order}
652 %{_appdir}/htdocs/ajax
653 %endif
654 %{_appdir}/templates
655
656 %dir %{_appdir}/upgrade
657 %{_appdir}/upgrade/init.php
658 %attr(755,root,root) %{_appdir}/upgrade/update-database.php
659 %dir %{_appdir}/upgrade/v*
660 %attr(755,root,root) %{_appdir}/upgrade/v*/*.php
661 %{_appdir}/upgrade/patches
662
663 %dir %{_appdir}/lib
664 %{_appdir}/lib/eventum
665 %{_appdir}/lib/jpgraph
666 %exclude %{_appdir}/lib/eventum/class.monitor.php
667
668 %dir %attr(730,root,http) /var/run/%{name}
669 %dir %attr(730,root,http) /var/cache/%{name}
670
671 %files base
672 %defattr(644,root,root,755)
673 %attr(751,root,root) %dir %{_sysconfdir}
674 %dir %{_libdir}
675 %dir %{_appdir}
676 %dir /var/lib/%{name}
677 # saved mail copies
678 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
679 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
680 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
681
682 %files setup
683 %defattr(644,root,root,755)
684 %{_appdir}/htdocs/setup
685
686 %files mail-queue
687 %defattr(644,root,root,755)
688 %attr(755,root,root) %{_appdir}/crons/process_mail_queue.php
689 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
690
691 %files mail-download
692 %defattr(644,root,root,755)
693 %attr(755,root,root) %{_appdir}/crons/download_emails.php
694 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
695
696 %files reminder
697 %defattr(644,root,root,755)
698 %attr(755,root,root) %{_appdir}/crons/check_reminders.php
699 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
700
701 %files monitor
702 %defattr(644,root,root,755)
703 %{_appdir}/lib/eventum/class.monitor.php
704 %attr(755,root,root) %{_appdir}/crons/monitor.php
705 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
706
707 %files route-drafts
708 %defattr(644,root,root,755)
709 %attr(755,root,root) %{_appdir}/route_drafts.php
710
711 %files route-emails
712 %defattr(644,root,root,755)
713 %attr(755,root,root) %{_appdir}/route_emails.php
714
715 %files route-notes
716 %defattr(644,root,root,755)
717 %attr(755,root,root) %{_appdir}/route_notes.php
718
719 %files router-postfix
720 %defattr(644,root,root,755)
721 %attr(755,root,root) %{_libdir}/router-postfix
722
723 %files irc
724 %defattr(644,root,root,755)
725 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
726 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
727 %attr(755,root,root) %{_sbindir}/%{name}-irc-bot
728 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
729
730 %files cli
731 %defattr(644,root,root,755)
732 %doc cli/eventumrc
733 %attr(755,root,root) %{_bindir}/%{name}
734 %{_appdir}/cli
735
736 %files scm
737 %defattr(644,root,root,755)
738 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
739 %attr(755,root,root) %{_libdir}/process_cvs_commits
740 %attr(755,root,root) %{_libdir}/process_svn_commits
741 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
742 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
This page took 0.280207 seconds and 4 git commands to generate.