]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
uses smarty3
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 #
9 # Conditional build:
10 %bcond_with     order   # with experimental order patch
11
12 %define         subver  pre1
13 %define         rel             0.6
14 %define         php_min_version 5.3.3
15 %include        /usr/lib/rpm/macros.php
16 Summary:        Eventum Issue / Bug tracking system
17 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
18 Name:           eventum
19 Version:        3.0.0
20 Release:        0.%{subver}.%{rel}
21 License:        GPL v2
22 Group:          Applications/WWW
23 Source0:        https://github.com/eventum/eventum/releases/download/v%{version}-pre1/%{name}-%{version}-%{subver}.tar.gz
24 # Source0-md5:  786930171e278f03baa7b174f52e43d0
25 Source1:        %{name}-apache.conf
26 Source2:        %{name}-mail-queue.cron
27 Source3:        %{name}-mail-download.cron
28 Source4:        %{name}-reminder.cron
29 Source5:        %{name}-monitor.cron
30 Source6:        %{name}-cvs.php
31 Source7:        %{name}-irc.php
32 Source8:        %{name}-irc.init
33 Source9:        %{name}-irc.sysconfig
34 Source10:       sphinx.crontab
35 Source13:       %{name}-router-postfix.sh
36 Source14:       %{name}.logrotate
37 Source15:       %{name}-lighttpd.conf
38 Source16:       http://www.isocra.com/images/updown2.gif
39 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
40 Source17:       %{name}.tmpfiles
41 #Patch0:                %{name}-lf.patch
42 Patch2:         %{name}-order.patch
43 #Patch3:                group-users.patch
44 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
45 # packaging patches that probably never go upstream
46 Patch100:       %{name}-paths.patch
47 Patch101:       %{name}-cvs-config.patch
48 Patch105:       %{name}-bot-reconnect.patch
49 Patch107:       %{name}-gettext.patch
50 # some tests
51 Patch200:       %{name}-fixed-nav.patch
52 URL:            http://eventum.mysql.org/
53 BuildRequires:  /usr/bin/php
54 BuildRequires:  gettext-tools
55 BuildRequires:  php(core) >= %{php_min_version}
56 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
57 BuildRequires:  rpmbuild(macros) >= 1.654
58 BuildRequires:  sed >= 4.0
59 Requires:       %{name}-base = %{version}-%{release}
60 Requires:       php(core) >= %{php_min_version}
61 Requires:       php(filter)
62 Requires:       php(gd)
63 Requires:       php(iconv)
64 Requires:       php(imap)
65 Requires:       php(json)
66 Requires:       php(mbstring)
67 Requires:       php(mysql)
68 Requires:       php(pcre)
69 Requires:       php(session)
70 Requires:       php-Smarty >= 3.1
71 Requires:       php-Smarty-plugin-gettext
72 Requires:       php-pear-DB
73 Requires:       php-pear-Date
74 Requires:       php-pear-Mail
75 Requires:       php-pear-Mail_Mime
76 Requires:       php-pear-Mail_mimeDecode
77 Requires:       php-pear-Math_Stats
78 Requires:       php-pear-Net_DIME
79 Requires:       php-pear-Net_SMTP
80 Requires:       php-pear-Net_Socket
81 Requires:       php-pear-Net_URL
82 Requires:       php-pear-Net_UserAgent_Detect
83 Requires:       php-pear-PEAR-core
84 Requires:       php-pear-Text_Diff
85 Requires:       php-pear-XML_RPC
86 Requires:       webapps
87 Requires:       webserver(access)
88 Requires:       webserver(alias)
89 Requires:       webserver(indexfile)
90 Requires:       webserver(php) >= 4.2.0
91 Suggests:       localedb
92 Suggests:       php-pear-Net_LDAP2
93 Conflicts:      logrotate < 3.8.0
94 BuildArch:      noarch
95 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97 %define         _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* jpgraph_dir.php .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
98
99 # exclude optional php dependencies
100 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
101
102 %define         _noautoreq      %{_noautophp}
103
104 %define         _libdir         %{_prefix}/lib/%{name}
105 %define         _appdir         %{_datadir}/%{name}
106 %define         _smartydir      %{php_data_dir}/Smarty
107 %define         _webapps        /etc/webapps
108 %define         _webapp         %{name}
109 %define         _webappdir      %{_webapps}/%{_webapp}
110 %define         _sysconfdir     /etc/%{name}
111
112 %description
113 Eventum is a user-friendly and flexible issue tracking system that can
114 be used by a support department to track incoming technical support
115 requests, or by a software development team to quickly organize tasks
116 and bugs. Eventum is used by the MySQL AB Technical Support team, and
117 has allowed us to dramatically improve our response times.
118
119 %description -l pl.UTF-8
120 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
121 może być używany przez dział obsługi do śledzenia przychodzących żądań
122 obsługi technicznej albo przez zespół tworzący oprogramowanie do
123 szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
124 Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
125 reakcji.
126
127 %package base
128 Summary:        Eventum base package
129 Summary(pl.UTF-8):      Podstawowy pakiet Eventum
130 Group:          Applications/WWW
131 Requires(postun):       /usr/sbin/groupdel
132 Requires(postun):       /usr/sbin/userdel
133 Requires(pre):  /bin/id
134 Requires(pre):  /usr/bin/getgid
135 Requires(pre):  /usr/sbin/groupadd
136 Requires(pre):  /usr/sbin/useradd
137 Provides:       group(eventum)
138 Provides:       user(eventum)
139
140 %description base
141 This package contains base directory structure for Eventum.
142
143 %description base -l pl.UTF-8
144 Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
145
146 %package setup
147 Summary:        Eventum setup package
148 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
149 Group:          Applications/WWW
150 Requires:       %{name} = %{version}-%{release}
151
152 %description setup
153 Install this package to configure initial Eventum installation. You
154 should uninstall this package when you're done, as it considered
155 insecure to keep the setup files in place.
156
157 %description setup -l pl.UTF-8
158 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
159 pierwszej instalacji. Potem należy go odinstalować, jako że
160 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
161
162 %package mail-queue
163 Summary:        Eventum mail queue process
164 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
165 Group:          Applications/WWW
166 Requires:       %{name} = %{version}-%{release}
167 Requires:       crondaemon
168
169 %description mail-queue
170 Beginning with the first release of Eventum, emails are not directly
171 sent out from the various scripts, but rather added to a mail queue
172 table that is processed by a cron job. If an email cannot be sent, it
173 will be marked as such in the mail queue log, and the cron job script
174 will re-try to send it again the next time it runs.
175
176 This package contains the cron job.
177
178 %description mail-queue -l pl.UTF-8
179 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
180 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
181 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
182 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
183 następnym razem.
184
185 Ten pakiet zawiera zadanie dla crona.
186
187 %package mail-download
188 Summary:        Eventum email download
189 Summary(pl.UTF-8):      Ściąganie poczty Eventum
190 Group:          Applications/WWW
191 Requires:       %{name} = %{version}-%{release}
192 Requires:       crondaemon
193
194 %description mail-download
195 In order for Eventum's email integration feature to work, you need to
196 setup a cron job to run the script every so often.
197
198 This package contains the cron job.
199
200 %description mail-download -l pl.UTF-8
201 Aby integracja poczty elektronicznej w Eventum działała, trzeba
202 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
203 często.
204
205 Ten pakiet zawiera zadanie dla crona.
206
207 %package reminder
208 Summary:        Eventum Reminder System
209 Summary(pl.UTF-8):      System przypominania dla Eventum
210 Group:          Applications/WWW
211 Requires:       %{name} = %{version}-%{release}
212 Requires:       crondaemon
213
214 %description reminder
215 The reminder system was designed with the objective as serving as a
216 safe net for issues that need attention. Depending on what
217 configuration you create, you may have several reminders (or alerts)
218 be sent out whenever an issue needs attention, for whatever parameter
219 you may deem necessary.
220
221 This package contains the cron job.
222
223 %description reminder -l pl.UTF-8
224 System przypominania został zaprojektowany tak, aby służył jako
225 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
226 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
227 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
228 uważać za potrzebny.
229
230 Ten pakiet zawiera zadanie dla crona.
231
232 %package monitor
233 Summary:        Eventum Heartbeat Monitor
234 Summary(pl.UTF-8):      Monitor życia dla Eventum
235 Group:          Applications/WWW
236 Requires:       %{name} = %{version}-%{release}
237 Requires:       crondaemon
238 Requires:       php(posix)
239
240 %description monitor
241 The heartbeat monitor is a feature designed for the administrator that
242 wants to be alerted whenever a common problem in Eventum is detected,
243 like the database server not being available anymore, or maybe when
244 the recommended permissions for certain configuration files are
245 changed.
246
247 Please note that before running the heartbeat monitor, you may need to
248 customize some of the checks to be appropriate for your own system,
249 particularly the permission and file checks on
250 Monitor::checkConfiguration().
251
252 This package contains the cron job.
253
254 %description monitor -l pl.UTF-8
255 Monitor życia to funkcjonalność zaprojektowana dla administratora
256 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
257 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
258 do plików konfiguracyjnych.
259
260 Należy zauważyć, że przed uruchomieniem tego monitora może być
261 konieczne dostosowanie niektórych testów do systemu, w szczególności
262 testów uprawnień i plików w Monitor::checkConfiguration().
263
264 Ten pakiet zawiera zadanie dla crona.
265
266 %package route-drafts
267 Summary:        Eventum Draft Routing
268 Summary(pl.UTF-8):      Przekazywanie szkiców dla Eventum
269 Group:          Applications/WWW
270 Requires:       %{name} = %{version}-%{release}
271 Requires:       eventum(router)
272
273 %description route-drafts
274 The draft routing feature is used to automatically associate a thread
275 of drafts into an Eventum issue. By setting up Postfix to deliver
276 emails sent to a specific address (usually draft-<number>@<domain>) to
277 the above script, users are able to send drafts written in their mail
278 client to be stored in Eventum. These drafts will NOT broadcasted to
279 the notification list.
280
281 %description route-drafts -l pl.UTF-8
282 Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
283 problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
284 wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
285 skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
286 kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
287 na listę powiadomień.
288
289 %package route-emails
290 Summary:        Eventum Email Routing
291 Summary(pl.UTF-8):      Przekazywanie poczty dla Eventum
292 Group:          Applications/WWW
293 Requires:       %{name} = %{version}-%{release}
294 Requires:       eventum(router)
295
296 %description route-emails
297 The email routing feature is used to automatically associate a thread
298 of emails into an Eventum issue. By setting up Postfix to deliver
299 emails sent to a specific address (usually issue-<number>@<domain>) to
300 the above script, users are able to use their email clients to reply
301 to emails coming from Eventum, and those replies will be automatically
302 associated with the issue and broadcasted to the entire notification
303 list.
304
305 %description route-emails -l pl.UTF-8
306 Funkcjonalność przekazywania poczty służy do automatycznego wiązania
307 wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
308 aby dostarczał listy wysyłane na pewien adres (zwykle
309 issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
310 używać klientów pocztowych do odpowiadania na listy przychodzące z
311 Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
312 rozprowadzane do całej listy ogłoszeniowej.
313
314 %package route-notes
315 Summary:        Eventum Note Routing
316 Summary(pl.UTF-8):      Przekazywanie notatek dla Eventum
317 Group:          Applications/WWW
318 Requires:       %{name} = %{version}-%{release}
319 Requires:       eventum(router)
320
321 %description route-notes
322 The note routing feature is used to automatically associate a thread
323 of notes into an Eventum issue. By setting up Postfix to deliver
324 emails sent to a specific address (usually note-<number>@<domain>) to
325 the above script, users are able to use their email clients to reply
326 to internal notes coming from Eventum, and those replies will be
327 automatically associated with the issue and broadcasted to the
328 notification list staff members.
329
330 %description route-notes -l pl.UTF-8
331 Funkcjonalność przekazywania notatek służy do automatycznego wiązania
332 wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
333 dostarczał listy wysyłane na pewien adres (zwykle
334 note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
335 używać klientów pocztowych do odpowiadania na wewnętrzne notatki
336 pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
337 sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
338
339 %package router-postfix
340 Summary:        Eventum Mail Routing - Postfix
341 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
342 Group:          Applications/Mail
343 Requires:       %{name} = %{version}-%{release}
344 Requires:       postfix
345 Provides:       eventum(router)
346 Obsoletes:      eventum(router)
347
348 %description router-postfix
349 This package provides way of routing notes and emails back to Eventum
350 via Postfix.
351
352 The Postfix configuration instructions you can find from
353 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
354
355 %description router-postfix -l pl.UTF-8
356 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
357 przez Postfiksa.
358
359 Opis konfiguracji Postfiksa można znaleźć pod adresem
360 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
361
362 %package irc
363 Summary:        Eventum IRC Notification Bot
364 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
365 Group:          Applications/WWW
366 Requires(post,preun):   /sbin/chkconfig
367 Requires:       %{name} = %{version}-%{release}
368 Requires:       php(sockets)
369 Requires:       php-pear-Net_SmartIRC
370 Requires:       rc-scripts >= 0.4.0.18
371
372 %description irc
373 The IRC notification bot is a nice feature for remote teams that want
374 to handle issues and want to have a quick and easy way to get simple
375 notifications. Right now the bot notifies of the following actions:
376 - New Issues
377 - Blocked emails
378 - Issues that got their assignment list changed
379
380 NOTE: You will need to manually edit the bot.php script to set your
381 appropriate preferences, like IRC server and channel that the bot
382 should join.
383
384 %description irc -l pl.UTF-8
385 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
386 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
387 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
388 następujących zdarzeniach:
389 - nowych sprawach
390 - zablokowanych listach
391 - sprawach, dla których zmieniła się lista powiązań
392
393 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
394 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
395
396 %package cli
397 Summary:        Eventum command-line interface
398 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
399 Group:          Applications/WWW
400 Requires:       %{name}-base = %{version}-%{release}
401 Requires:       php(core) >= %{php_min_version}
402 Requires:       php(phar)
403 Requires:       php-pear-XML_RPC
404
405 %description cli
406 The Eventum command-line interface allows you to access most of the
407 features of the web interface straight from your command shell.
408
409 %description cli -l pl.UTF-8
410 Interfejs linii poleceń Eventum pozwala na dostęp do większości
411 funkcji interfejsu WWW prosto z linii poleceń powłoki.
412
413 %package scm
414 Summary:        Eventum SCM integration
415 Summary(pl.UTF-8):      Integracja SCM dla Eventum
416 Group:          Applications/WWW
417 Requires:       %{name}-base = %{version}-%{release}
418 Requires:       php(core) >= %{php_min_version}
419 Requires:       php(pcre)
420
421 %description scm
422 This feature allows your software development teams to integrate your
423 Source Control Management system with your Issue Tracking System.
424
425 The integration is implemented in such a way that it will be forward
426 compatible with pretty much any SCM system, such as CVS.
427
428 For installation see
429 </eventum/help.php?topic=scm_integration_installation>.
430
431 %description scm -l pl.UTF-8
432 Ten pakiet pozwala zespołom programistów na integrację systemu
433 zarządzania źródłami (SCM - Source Control Management) z systemem
434 śledzenia spraw.
435
436 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
437 prawie każdym systemem SCM, jak np. CVS.
438
439 Szczegóły na temat instalacji można przeczytać pod
440 </eventum/help.php?topic=scm_integration_installation>.
441
442 %package sphinx
443 Summary:        Eventum Sphinx Search
444 Group:          Applications/WWW
445 Requires:       %{name} = %{version}-%{release}
446 Requires:       crondaemon
447 Requires:       sphinx
448
449 %description sphinx
450 Sphinx search integration for Eventum.
451
452 This package contains the cron job.
453
454 %prep
455 %setup -qn %{name}-%{version}%{?subver:-%{subver}}
456
457 mv docs/examples .
458
459 # GPL v2
460 rm docs/COPYING
461
462 # bug fixes / features
463 #%patch0 -p1
464 %{?with_order:%patch2 -p1}
465 #%patch3 -p0
466 #%patch4 -p1
467
468 %{?with_order:cp -p %{SOURCE16} htdocs/images}
469
470 #%patch200 -p1
471
472 # produce default sphinx config
473 # must be run before paths.patch
474 %if 0
475 cat <<'EOF' > config/config.php
476 <?php
477 define('APP_SQL_DBTYPE', 'mysql');
478 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
479 define('APP_SQL_DBPORT', 3306);
480 define('APP_SQL_DBNAME', 'eventum');
481 define('APP_SQL_DBUSER', 'mysql');
482 define('APP_SQL_DBPASS', '');
483 define('APP_TABLE_PREFIX', 'eventum_');
484 EOF
485 php config/sphinx.conf.php > config/sphinx.conf
486 rm -f config/config.php
487 %endif
488
489 # packaging
490 %patch100 -p1
491 #%patch101 -p1
492 %patch105 -p1
493 %patch107 -p1
494
495 %{__sed} -i -e "
496 s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
497 " upgrade/{*/,}*.php
498
499 # remove backups from patching as we use globs to package files to buildroot
500 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
501
502 %build
503 %{__make} -C localization
504
505 %install
506 rm -rf $RPM_BUILD_ROOT
507 install -d \
508         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
509         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
510         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
511         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
512         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
513         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
514         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
515
516 %{__make} install-eventum install-cli install-irc install-scm install-jpgraph install-localization \
517         sysconfdir=%{_webappdir} \
518         localedir=%{_localedir} \
519         DESTDIR=$RPM_BUILD_ROOT
520
521 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
522 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
523
524 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
525
526 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
527
528 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
529 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
530 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
531 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
532
533 install -d $RPM_BUILD_ROOT/etc/sphinx
534 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
535 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
536
537 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
538 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
539 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
540 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
541 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
542
543 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
544
545 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
546 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
547
548 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
549
550 # postfix router
551 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
552
553 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
554
555 %find_lang %{name}
556
557 # scm
558 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
559
560 %clean
561 rm -rf $RPM_BUILD_ROOT
562
563 %pre
564 %addusertogroup http %{name}
565
566 %post
567 # greate empty ghost files
568 for a in cli.log errors.log irc_bot.log login_attempts.log; do
569         if [ ! -f /var/log/%{name}/$a ]; then
570                 install -m 0620 -o root -g eventum /dev/null /var/log/%{name}/$a
571         fi
572 done
573
574 # run database update if configured
575 test -s %{_webappdir}/config.php && \
576 %{_appdir}/upgrade/update-database.php || :
577
578 # nuke Smarty templates cache after upgrade
579 rm -f /var/cache/eventum/*.php
580
581 # Restart webserver on upgrade to get .mo translations reloaded.
582 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
583 %php_webserver_restart
584
585 %preun
586 if [ "$1" = "0" ]; then
587         # nuke cache
588         rm -f /var/cache/eventum/*.php 2>/dev/null || :
589 fi
590
591 %pre base
592 %groupadd -P %{name}-base -g 146 %{name}
593 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
594
595 %postun base
596 if [ "$1" = "0" ]; then
597         %userremove %{name}
598         %groupremove %{name}
599 fi
600
601 %post setup
602 chmod 660 %{_webappdir}/{config,private_key}.php
603 chown root:http %{_webappdir}/{config,private_key}.php
604
605 %postun setup
606 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
607         chmod 640 %{_webappdir}/{config,private_key}.php
608         chown root:http %{_webappdir}/{config,private_key}.php
609 fi
610
611 %post irc
612 /sbin/chkconfig --add eventum-irc
613 %service eventum-irc restart "Eventum IRC Bot"
614
615 %preun irc
616 if [ "$1" = 0 ]; then
617         %service eventum-irc stop
618         /sbin/chkconfig --del eventum-irc
619 fi
620
621 %triggerin -- apache1 < 1.3.37-3, apache1-base
622 %webapp_register apache %{_webapp}
623
624 %triggerun -- apache1 < 1.3.37-3, apache1-base
625 %webapp_unregister apache %{_webapp}
626
627 %triggerin -- apache < 2.2.0, apache-base
628 %webapp_register httpd %{_webapp}
629
630 %triggerun -- apache < 2.2.0, apache-base
631 %webapp_unregister httpd %{_webapp}
632
633 %triggerin -- lighttpd
634 %webapp_register lighttpd %{_webapp}
635
636 %triggerun -- lighttpd
637 %webapp_unregister lighttpd %{_webapp}
638
639 %triggerpostun -- %{name} < 3.0.0-0.2
640 for f in /etc/cron.d/eventum-*; do
641         # crontabs moved to bin
642         %{__sed} -i -e '
643                 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
644                 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
645                 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
646                 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
647         ' $f
648 done
649
650 %files -f %{name}.lang
651 %defattr(644,root,root,755)
652 %doc docs/*
653 %attr(751,root,root) %dir %{_webappdir}
654 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
655 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
656 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
657 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
658 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
659 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
660 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
661
662 %dir %attr(731,root,http) /var/log/%{name}
663 %attr(620,root,http) %ghost /var/log/%{name}/*
664 %dir %attr(750,root,root) /var/log/archive/%{name}
665 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
666
667 %dir %{_appdir}/bin
668 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
669
670 %{_appdir}/init.php
671 %dir %{_appdir}/htdocs
672 %{_appdir}/htdocs/*.php
673 %{_appdir}/htdocs/*.ico
674 %{_appdir}/htdocs/ajax
675 %{_appdir}/htdocs/css
676 %{_appdir}/htdocs/customer
677 %{_appdir}/htdocs/images
678 %{_appdir}/htdocs/js
679 %{_appdir}/htdocs/manage
680 %{_appdir}/htdocs/misc
681 %{_appdir}/htdocs/reports
682 %{_appdir}/htdocs/rpc
683 %{_appdir}/htdocs/components
684 %{_appdir}/templates
685
686 %dir %{_appdir}/upgrade
687 %{_appdir}/upgrade/flush_compiled_templates.php
688 %{_appdir}/upgrade/*.sql
689 %attr(755,root,root) %{_appdir}/upgrade/update-database.php
690 %attr(755,root,root) %{_appdir}/upgrade/ldap_import.php
691 %attr(755,root,root) %{_appdir}/upgrade/ldap_update_users.php
692 %attr(755,root,root) %{_appdir}/upgrade/scm_trac_import.php
693 %{_appdir}/upgrade/patches
694
695 %dir %{_appdir}/lib
696 %{_appdir}/lib/eventum
697 %{_appdir}/lib/jpgraph
698 %exclude %{_appdir}/lib/eventum/class.monitor.php
699
700 %{_appdir}/vendor
701
702 %{_examplesdir}/%{name}-%{version}
703
704 %{systemdtmpfilesdir}/%{name}.conf
705 %dir %attr(730,root,http) /var/run/%{name}
706 %dir %attr(730,root,http) /var/cache/%{name}
707
708 %files base
709 %defattr(644,root,root,755)
710 %attr(751,root,root) %dir %{_sysconfdir}
711 %dir %{_libdir}
712 %dir %{_appdir}
713 %dir /var/lib/%{name}
714 # saved mail copies
715 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
716 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
717 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
718
719 %files setup
720 %defattr(644,root,root,755)
721 %{_appdir}/htdocs/setup
722
723 %files mail-queue
724 %defattr(644,root,root,755)
725 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
726 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
727
728 %files mail-download
729 %defattr(644,root,root,755)
730 %attr(755,root,root) %{_appdir}/bin/download_emails.php
731 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
732
733 %files reminder
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
736 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
737
738 %files monitor
739 %defattr(644,root,root,755)
740 %{_appdir}/lib/eventum/class.monitor.php
741 %attr(755,root,root) %{_appdir}/bin/monitor.php
742 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
743
744 %files route-drafts
745 %defattr(644,root,root,755)
746 %attr(755,root,root) %{_appdir}/bin/route_drafts.php
747
748 %files route-emails
749 %defattr(644,root,root,755)
750 %attr(755,root,root) %{_appdir}/bin/route_emails.php
751
752 %files route-notes
753 %defattr(644,root,root,755)
754 %attr(755,root,root) %{_appdir}/bin/route_notes.php
755
756 %files router-postfix
757 %defattr(644,root,root,755)
758 %attr(755,root,root) %{_libdir}/router-postfix
759
760 %files irc
761 %defattr(644,root,root,755)
762 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
763 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
764 %attr(755,root,root) %{_sbindir}/%{name}-irc-bot
765 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
766
767 %files cli
768 %defattr(644,root,root,755)
769 %doc cli/eventumrc
770 %attr(755,root,root) %{_bindir}/%{name}
771
772 %files scm
773 %defattr(644,root,root,755)
774 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
775 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
776 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
777
778 %files sphinx
779 %defattr(644,root,root,755)
780 %{_webappdir}/sphinx.conf.php
781 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
782 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.078516 seconds and 4 git commands to generate.