]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- 64bit problem
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - system pear is incompatible, at least pear DB class seems broke Eventum
3 # - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
4 # - discard bundled packages (from INSTALL):
5 #  - JpGraph 1.5.3 (last GPL version)
6 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
7 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
8 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
9 #  - A few other small javascript libraries
10 # - need start-stop-daemon (from dpkg for now)
11 # - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
12
13 %bcond_with     pear    # build with system PEAR packages (or use bundled ones)
14
15 %define uid     146
16 %define gid     146
17
18 # snapshot: DATE
19 #define _snap 20050227
20
21 %if 0%{?_snap}
22 %define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
23 %else
24 %define _source http://mysql.wildyou.net/Downloads/%{name}/%{name}-%{version}.tar.gz
25 %endif
26
27 %define _rel 271
28
29 Summary:        Eventum Issue / Bug tracking system
30 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
31 Name:           eventum
32 Version:        1.5.1
33 Release:        0.%{?_snap:%{_snap}.}%{_rel}
34 License:        GPL
35 Group:          Applications/WWW
36 Source0:        %{_source}
37 # Source0-md5:  d326ef39b52001efcbbc0ae8db5454a5
38 Source1:        %{name}-apache.conf
39 Source2:        %{name}-mail-queue.cron
40 Source3:        %{name}-mail-download.cron
41 Source4:        %{name}-reminder.cron
42 Source5:        %{name}-monitor.cron
43 Source6:        %{name}-cvs.php
44 Source7:        %{name}-irc.php
45 Source8:        %{name}-irc.init
46 Source9:        %{name}-irc.sysconfig
47 Source10:       %{name}-config.php
48 Source11:       %{name}-router-qmail.sh
49 Source12:       http://dev.mysql.com/common/favicon.ico
50 # Source12-md5: 858be0130832da4144c08d4b59116411
51 Patch0:         %{name}-paths.patch
52 Patch1:         %{name}-cvs-config.patch
53 Patch2:         %{name}-irc-config.patch
54 Patch3:         %{name}-PEAR.patch
55 Patch4:         %{name}-db-20050227.patch
56 Patch10:        %{name}-charset-recent-activity.patch
57 Patch11:        http://glen.alkohol.ee/pld/eventum-cli-rpc-base64.patch
58 Patch12:        http://glen.alkohol.ee/pld/eventum-send-height.patch
59 Patch13:        http://glen.alkohol.ee/pld/eventum-reply-subject.patch
60 Patch14:        http://glen.alkohol.ee/pld/eventum-rss-updates.patch
61 Patch15:        http://glen.alkohol.ee/pld/eventum-opera.patch
62 Patch16:        eventum-lf.patch
63 Patch17:        eventum-iss-ass-fix.patch
64 Patch18:        eventum-iss-close.patch
65 Patch19:        http://glen.alkohol.ee/pld/eventum-attach-activate-links.patch
66 URL:            http://dev.mysql.com/downloads/other/eventum/
67 BuildRequires:  rpmbuild(macros) >= 1.177
68 BuildRequires:  sed >= 4.0
69 Requires:       php >= 4.2.0
70 Requires:       php-gd
71 Requires:       php-imap
72 Requires:       php-mysql
73 Requires:       php-pcre
74 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
75 Requires:       Smarty >= 2.6.2
76 %if %{with pear}
77 Requires:       php-pear-Benchmark
78 Requires:       php-pear-DB
79 Requires:       php-pear-Date
80 Requires:       php-pear-HTTP_Request
81 Requires:       php-pear-Mail
82 Requires:       php-pear-Math_Stats
83 Requires:       php-pear-Net_DIME
84 Requires:       php-pear-Net_POP3
85 Requires:       php-pear-Net_SMTP
86 Requires:       php-pear-Net_SmartIRC
87 Requires:       php-pear-Net_Socket
88 Requires:       php-pear-Net_URL
89 Requires:       php-pear-Net_UserAgent_Detect
90 Requires:       php-pear-PEAR
91 Requires:       php-pear-Text_Diff
92 Requires:       php-pear-XML_RPC
93 %endif
94 Requires:       apache >= 1.3.33-2
95 Requires:       apache(mod_dir)
96 Requires(triggerpostun):        sed >= 4.0
97 BuildArch:      noarch
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %define         _sysconfdir     /etc/%{name}
101 %define         _libdir         %{_prefix}/%{_lib}/%{name}
102 %define         _appdir %{_datadir}/%{name}
103 %define         _smartyplugindir        %{php_pear_dir}/Smarty/plugins
104
105 %define         _apache1dir     /etc/apache
106 %define         _apache2dir     /etc/httpd
107
108 %description
109 Eventum is a user-friendly and flexible issue tracking system that can
110 be used by a support department to track incoming technical support
111 requests, or by a software development team to quickly organize tasks
112 and bugs. Eventum is used by the MySQL AB Technical Support team, and
113 has allowed us to dramatically improve our response times.
114
115 %description -l pl
116 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
117 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
118 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
119 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
120 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
121 reakcji.
122
123 %package base
124 Summary:        Eventum base package
125 Summary(pl):    Podstawowy pakiet Eventum
126 Group:          Applications/WWW
127
128 %description base
129 This package contains base directory structure for Eventum.
130
131 %description base -l pl
132 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
133
134 %package setup
135 Summary:        Eventum setup package
136 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
137 Group:          Applications/WWW
138 PreReq:         %{name} = %{epoch}:%{version}-%{release}
139
140 %description setup
141 Install this package to configure initial Eventum installation. You
142 should uninstall this package when you're done, as it considered
143 insecure to keep the setup files in place.
144
145 %description setup -l pl
146 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
147 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
148 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
149
150 %package mail-queue
151 Summary:        Eventum mail queue process
152 Summary(pl):    Przetwarzanie kolejki poczty Eventum
153 Group:          Applications/WWW
154 Requires:       %{name} = %{epoch}:%{version}-%{release}
155 Requires:       crondaemon
156 Requires:       php >= 4.1.0
157
158 %description mail-queue
159 Beginning with the first release of Eventum, emails are not directly
160 sent out from the various scripts, but rather added to a mail queue
161 table that is processed by a cron job. If an email cannot be sent, it
162 will be marked as such in the mail queue log, and the cron job script
163 will re-try to send it again the next time it runs.
164
165 This package contains the cron job.
166
167 %description mail-queue -l pl
168 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
169 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
170 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
171 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
172 nastêpnym razem.
173
174 Ten pakiet zawiera zadanie dla crona.
175
176 %package mail-download
177 Summary:        Eventum email download
178 Summary(pl):    ¦ci±ganie poczty Eventum
179 Group:          Applications/WWW
180 Requires:       %{name} = %{epoch}:%{version}-%{release}
181 Requires:       crondaemon
182 Requires:       php >= 4.1.0
183
184 %description mail-download
185 In order for Eventum's email integration feature to work, you need to
186 setup a cron job to run the script every so often.
187
188 This package contains the cron job.
189
190 %description mail-download -l pl
191 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
192 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
193 czêsto.
194
195 Ten pakiet zawiera zadanie dla crona.
196
197 %package reminder
198 Summary:        Eventum Reminder System
199 Summary(pl):    System przypominania dla Eventum
200 Group:          Applications/WWW
201 Requires:       %{name} = %{epoch}:%{version}-%{release}
202 Requires:       php >= 4.1.0
203 Requires:       crondaemon
204
205 %description reminder
206 The reminder system was designed with the objective as serving as a
207 safe net for issues that need attention. Depending on what
208 configuration you create, you may have several reminders (or alerts)
209 be sent out whenever an issue needs attention, for whatever parameter
210 you may deem necessary.
211
212 This package contains the cron job.
213
214 %description reminder -l pl
215 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
216 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
217 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
218 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
219 uwa¿aæ za potrzebny.
220
221 Ten pakiet zawiera zadanie dla crona.
222
223 %package monitor
224 Summary:        Eventum Heartbeat Monitor
225 Summary(pl):    Monitor ¿ycia dla Eventum
226 Group:          Applications/WWW
227 Requires:       %{name} = %{epoch}:%{version}-%{release}
228 Requires:       php >= 4.1.0
229 Requires:       php-posix
230 Requires:       crondaemon
231
232 %description monitor
233 The heartbeat monitor is a feature designed for the administrator that
234 wants to be alerted whenever a common problem in Eventum is detected,
235 like the database server not being available anymore, or maybe when
236 the recommended permissions for certain configuration files are
237 changed.
238
239 Please note that before running the heartbeat monitor, you may need to
240 customize some of the checks to be appropriate for your own system,
241 particularly the permission and file checks on
242 Monitor::checkConfiguration().
243
244 This package contains the cron job.
245
246 %description monitor -l pl
247 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
248 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
249 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
250 do plików konfiguracyjnych.
251
252 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
253 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
254 testów uprawnieñ i plików w Monitor::checkConfiguration().
255
256 Ten pakiet zawiera zadanie dla crona.
257
258 %package route-emails
259 Summary:        Eventum Email Routing
260 Summary(pl):    Przekazywanie poczty dla Eventum
261 Group:          Applications/WWW
262 Requires:       %{name} = %{epoch}:%{version}-%{release}
263 Requires:       php >= 4.1.0
264 Requires:       eventum(router)
265
266 %description route-emails
267 The email routing feature is used to automatically associate a thread
268 of emails into an Eventum issue. By setting up qmail (or even postfix)
269 to deliver emails sent to a specific address (usually
270 issue-<number>@<domain>) to the above script, users are able to use
271 their email clients to reply to emails coming from Eventum, and those
272 replies will be automatically associated with the issue and
273 broadcasted to the entire notification list.
274
275 %description route-emails -l pl
276 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
277 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
278 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
279 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
280 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
281 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
282 rozprowadzane do ca³ej listy og³oszeniowej.
283
284 %package route-notes
285 Summary:        Eventum Note Routing
286 Summary(pl):    Przekazywanie notatek dla Eventum
287 Group:          Applications/WWW
288 Requires:       %{name} = %{epoch}:%{version}-%{release}
289 Requires:       php >= 4.1.0
290 Requires:       eventum(router)
291
292 %description route-notes
293 The note routing feature is used to automatically associate a thread
294 of notes into an Eventum issue. By setting up qmail (or even postfix)
295 to deliver emails sent to a specific address (usually
296 note-<number>@<domain>) to the above script, users are able to use
297 their email clients to reply to internal notes coming from Eventum,
298 and those replies will be automatically associated with the issue and
299 broadcasted to the notification list staff members.
300
301 %description route-notes -l pl
302 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
303 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
304 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
305 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
306 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
307 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
308 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
309
310 %package router-qmail
311 Summary:        Eventum Mail Routing - qmail
312 Summary(pl):    Przekazywanie poczty Eventum - qmail
313 Group:          Applications/Mail
314 Requires:       %{name} = %{epoch}:%{version}-%{release}
315 Requires:       qmail >= 1.03
316 Provides:       eventum(router)
317 Obsoletes:      eventum(router)
318
319 %description router-qmail
320 This package provides way of routing notes and emails back to Eventum
321 via qmail.
322
323 %description router-qmail -l pl
324 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
325 przez qmaila.
326
327 %package router-postfix
328 Summary:        Eventum Mail Routing - Postfix
329 Summary(pl):    Przekazywanie poczty Eventum - Postfix
330 Group:          Applications/Mail
331 Requires:       %{name} = %{epoch}:%{version}-%{release}
332 Requires:       postfix
333 Provides:       eventum(router)
334 Obsoletes:      eventum(router)
335
336 %description router-postfix
337 This package provides way of routing notes and emails back to Eventum
338 via Postfix.
339
340 %description router-postfix -l pl
341 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
342 przez Postfiksa.
343
344 %package irc
345 Summary:        Eventum IRC Notification Bot
346 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
347 Group:          Applications/WWW
348 Requires:       %{name} = %{epoch}:%{version}-%{release}
349 Requires:       php >= 4.1.0
350 Requires:       php-sockets
351 Requires:       rc-scripts >= 0.4.0.18
352
353 %description irc
354 The IRC notification bot is a nice feature for remote teams that want
355 to handle issues and want to have a quick and easy way to get simple
356 notifications. Right now the bot notifies of the following actions:
357 - New Issues
358 - Blocked emails
359 - Issues that got their assignment list changed
360
361 NOTE: You will need to manually edit the bot.php script to set your
362 appropriate preferences, like IRC server and channel that the bot
363 should join.
364
365 %description irc -l pl
366 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
367 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
368 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
369 nastêpuj±cych zdarzeniach:
370 - nowych sprawach
371 - zablokowanych listach
372 - sprawach, dla których zmieni³a siê lista powi±zañ
373
374 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
375 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
376
377 %package cli
378 Summary:        Eventum command-line interface
379 Summary(pl):    Interfejs linii poleceñ dla Eventum
380 Group:          Applications/WWW
381 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
382 Requires:       php >= 4.1.0
383 Requires:       php-cli
384 Requires:       php-curl
385 Requires:       php-xml
386 Requires:       php-pear-XML_RPC
387
388 %description cli
389 The Eventum command-line interface allows you to access most of the
390 features of the web interface straight from your command shell.
391
392 %description cli -l pl
393 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
394 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
395
396 %package scm
397 Summary:        Eventum SCM integration
398 Summary(pl):    Integracja SCM dla Eventum
399 Group:          Applications/WWW
400 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
401 Requires:       php >= 4.1.0
402
403 %description scm
404 This feature allows your software development teams to integrate your
405 Source Control Management system with your Issue Tracking System.
406
407 The integration is implemented in such a way that it will be forward
408 compatible with pretty much any SCM system, such as CVS.
409
410 For installation see
411 </eventum/help.php?topic=scm_integration_installation>.
412
413 %description scm -l pl
414 Ten pakiet pozwala zespo³om programistów na integracjê systemu
415 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
416 ¶ledzenia spraw.
417
418 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
419 prawie ka¿dym systemem SCM, jak np. CVS.
420
421 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
422 </eventum/help.php?topic=scm_integration_installation>.
423
424 %prep
425 %setup -q %{?_snap:-n %{name}-%{_snap}}
426 # undos the source
427 find . -type f -print0 | xargs -0 sed -i -e 's,
428 $,,'
429
430 # packaging
431 %patch0 -p1 -b .paths
432 %patch1 -p1
433 %patch2 -p1
434 %{?with_pear:%patch3 -p1 -b .PEAR}
435 %patch4 -p1
436
437 # bug fixes.
438 %patch10 -p1
439 %patch11 -p1
440 %patch12 -p0
441 %patch13 -p1
442 %patch14 -p1
443 %patch15 -p1
444 %patch16 -p1
445 %patch17 -p1
446 %patch18 -p1
447 %patch19 -p1
448
449 # replace in remaining scripts config.inc.php to system one
450 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
451         s,include_once(".*config.inc.php"),include_once("%{_sysconfdir}/core.php"),
452 '
453 sed -i -e '
454         s,include(".*config.inc.php"),include_once("%{_sysconfdir}/core.php"),
455 ' misc/download_emails.php
456
457 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
458         s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_sysconfdir}/private_key.php"),
459 '
460
461 rm -f */*~ */*/*~
462
463 %install
464 rm -rf $RPM_BUILD_ROOT
465 install -d \
466         $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_libdir}} \
467         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
468         $RPM_BUILD_ROOT/var/{run,log,cache,lib}/%{name} \
469         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
470
471 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
472 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
473 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
474 cp -a misc/irc $RPM_BUILD_ROOT%{_appdir}
475 cp -a templates $RPM_BUILD_ROOT%{_appdir}
476 cp -a include/{customer,jpgraph,pear,workflow} $RPM_BUILD_ROOT%{_appdir}/include
477 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
478 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
479 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
480
481 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
482
483 # cli
484 install -d $RPM_BUILD_ROOT%{_appdir}/cli
485 install misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
486 install misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
487 sed -e 's,/usr/local/bin/php,/usr/bin/php4,' misc/cli/eventum \
488         > $RPM_BUILD_ROOT%{_bindir}/%{name}
489 cp -f misc/cli/eventumrc_example eventumrc
490
491 # scm
492 echo '#!/usr/bin/php4 -q' > %{name}-scm
493 cat misc/scm/process_cvs_commits.php >> %{name}-scm
494 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
495
496 # private key
497 mv $RPM_BUILD_ROOT{%{_appdir}/include/private_key.php,%{_sysconfdir}}
498 # change private key, so we can easily grep
499 sed -i -e '
500 s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
501 ' $RPM_BUILD_ROOT%{_sysconfdir}/private_key.php
502
503 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
504 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
505 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
506 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
507 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
508 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
509 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
510 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
511 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
512 sed -e 's,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}},' \
513         %{SOURCE10} > $RPM_BUILD_ROOT%{_sysconfdir}/core.php
514
515 # config
516 > $RPM_BUILD_ROOT%{_sysconfdir}/setup.php
517 mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_sysconfdir}/config}.php
518
519 # sample, not used in eventum
520 rm -f $RPM_BUILD_ROOT%{_appdir}/htdocs/rpc/xmlrpc_client.php
521
522 %if %{with pear}
523 # provided by PEAR
524 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
525 %endif
526
527 # use system Smarty
528 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
529 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
530 # These plugins are not in Smarty package (Smarty-2.6.2-3)
531 cp -a include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
532         $RPM_BUILD_ROOT%{_smartyplugindir}
533
534 # qmail router
535 d=$RPM_BUILD_ROOT/var/lib/%{name}
536 echo 'root' > $d/.qmail
537 echo 'root' > $d/.qmail-default
538 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
539 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
540 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
541 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
542
543 %clean
544 rm -rf $RPM_BUILD_ROOT
545
546 %pre
547 %addusertogroup http %{name}
548
549 %post
550 # apache1
551 if [ -d %{_apache1dir}/conf.d ]; then
552         ln -sf %{_sysconfdir}/apache.conf %{_apache1dir}/conf.d/99_%{name}.conf
553         if [ -f /var/lock/subsys/apache ]; then
554                 /etc/rc.d/init.d/apache restart 1>&2
555         fi
556 fi
557 # apache2
558 if [ -d %{_apache2dir}/httpd.conf ]; then
559         ln -sf %{_sysconfdir}/apache.conf %{_apache2dir}/httpd.conf/99_%{name}.conf
560         if [ -f /var/lock/subsys/httpd ]; then
561                 /etc/rc.d/init.d/httpd restart 1>&2
562         fi
563 fi
564
565 # check if the package is configured.
566 if grep -q 'header("Location: setup/")' %{_sysconfdir}/config.php; then
567 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
568 %banner %{name} -e <<EOF
569
570 You haven't yet configured Eventum!
571 Please open in browser <http://localhost/eventum/>
572 If you need access from elsewhere, you need to edit
573 %{_sysconfdir}/apache.conf and restart apache.
574
575 IMPORTANT: When You have configured Eventum, please uninstall the
576 setup package, so that %{name}-setup is able to secure your Eventum
577 installation.
578
579 EOF
580 #' vim stupidity.
581 else
582 %banner %{name} -e <<EOF
583
584 You haven't yet configured Eventum!
585
586 To setup eventum, please install %{name}-setup and open in browser
587 <http://localhost/eventum/>.
588 If you need access from elsewhere, you need to edit
589 %{_sysconfdir}/apache.conf and restart apache.
590
591 IMPORTANT: When You have configured Eventum, please uninstall the
592 setup package, so that %{name}-setup is able to secure your Eventum
593 installation.
594
595 EOF
596 #' vim stupidity.
597 fi
598
599 elif grep -q 'DEFAULTPRIVATEKEY' %{_sysconfdir}/private_key.php; then
600 %banner %{name} -e <<EOF
601
602 You have default private key installed!
603
604 Install %{name}-setup and open up http://yourserver/eventum/setup/
605 -- that will help you setup initial config.
606
607 when have configured Eventum, please uninstall the setup package,
608 so that %{name}-setup is able to secure your Eventum installation.
609
610 EOF
611         elif [ -d %{_appdir}/setup ]; then
612 %banner %{name} -e <<EOF
613
614 If you have have configured Eventum, please uninstall the setup package,
615 so that %{name}-setup is able to secure your Eventum installation.
616
617 EOF
618 fi
619
620 # nuke Smarty templates cache after upgrade
621 rm -f /var/cache/eventum/*.php
622
623 %preun
624 if [ "$1" = "0" ]; then
625         # apache1
626         if [ -f %{_apache1dir}/apache.conf ]; then
627                 rm -f %{_apache1dir}/conf.d/99_%{name}.conf
628                 if [ -f /var/lock/subsys/apache ]; then
629                         /etc/rc.d/init.d/apache restart 1>&2
630                 fi
631         fi
632         # apache2
633         if [ -d %{_apache2dir}/httpd.conf ]; then
634                 rm -f %{_apache2dir}/httpd.conf/99_%{name}.conf
635                 if [ -f /var/lock/subsys/httpd ]; then
636                         /etc/rc.d/init.d/httpd restart 1>&2
637                 fi
638         fi
639 fi
640
641 %postun
642 # nuke cache
643 rm -f /var/cache/eventum/*.php
644
645 %pre base
646 %groupadd -P %{name}-base %{name}
647 %useradd -P %{name}-base -d /var/lib/%{name} -g %{name} %{name} -c "Eventum User"
648
649 %postun base
650 if [ "$1" = "0" ]; then
651         %userremove %{name}
652         %groupremove %{name}
653 fi
654
655 %post router-qmail
656 CF=/etc/qmail/control/virtualdomains
657 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
658         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_sysconfdir}/config.php 2>/dev/null)
659         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
660         umask 022
661         echo "#${FQDN}:%{name}" >> $CF
662
663 %banner %{name}-qmail -e <<EOF
664
665 Added "#${FQDN}:%{name}" to $CF,
666 Please verify that it is correct and restart qmail:
667 # service qmail reload
668
669 Consult qmail-send(8) for more information on virtualdomains.
670
671 EOF
672 fi
673
674 %preun router-qmail
675 if [ "$1" = "0" ]; then
676         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
677 fi
678
679 %post setup
680 chmod 660 %{_sysconfdir}/{config,private_key}.php
681 chown root:eventum %{_sysconfdir}/{config,private_key}.php
682
683 %postun setup
684 if [ "$1" = "0" ]; then
685         chmod 640 %{_sysconfdir}/{config,private_key}.php
686         chown root:eventum %{_sysconfdir}/{config,private_key}.php
687 fi
688
689 %triggerpostun base -- eventum-base < 1.4-2.20050222.212
690 if [ "`getent passwd %{name} | cut -d: -f6`" = "%{_appdir}" ]; then
691         /usr/sbin/usermod -d /var/lib/%{name} %{name}
692 fi
693
694 %triggerpostun -- eventum < 1.5-0.240
695 scriptdir=%{_appdir}/upgrade/v1.4_to_1.5
696 %banner %{name}-trigger-1.5 -e <<-EOF
697
698         Running eventum upgrade scripts to 1.5 in $scriptdir
699         These will fail if your eventum user doesn't have ALTER privilege to database.
700
701 EOF
702 #'
703
704 /usr/bin/php4 -q $scriptdir/database_changes.php || {
705         echo >&2 "Please run manually: /usr/bin/php4 -q $scriptdir/database_changes.php"
706 }
707
708 %triggerpostun -- eventum < 1.5.1-0.257
709 scriptdir=%{_appdir}/upgrade/v1.5_to_v1.5.1
710 %banner %{name}-trigger-1.5.1 -e <<-EOF
711
712         Running eventum upgrade scripts to 1.5.1 in $scriptdir
713         These will fail if your eventum user doesn't have ALTER privilege to database.
714
715 EOF
716 #'
717
718 /usr/bin/php4 -q $scriptdir/database_changes.php || {
719         echo >&2 "Please run manually: /usr/bin/php4 -q $scriptdir/database_changes.php"
720 }
721
722 %files
723 %defattr(644,root,root,755)
724 %doc ChangeLog FAQ INSTALL README UPGRADE
725 %doc docs/* rpc/xmlrpc_client.php setup/schema.sql
726 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
727 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
728 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/private_key.php
729 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/setup.php
730 %attr(640,root,eventum) %config %verify(not mtime) %{_sysconfdir}/core.php
731
732 %dir %attr(731,root,eventum) /var/log/%{name}
733 %attr(620,root,eventum) %ghost /var/log/%{name}/*
734
735 %dir %{_appdir}/htdocs
736 %{_appdir}/htdocs/*.php
737 %{_appdir}/htdocs/*.ico
738 %{_appdir}/htdocs/css
739 %{_appdir}/htdocs/customer
740 %{_appdir}/htdocs/images
741 %{_appdir}/htdocs/js
742 %{_appdir}/htdocs/manage
743 %{_appdir}/htdocs/reports
744 %{_appdir}/htdocs/rpc
745 %{_appdir}/htdocs/misc
746
747 %{_appdir}/templates
748 %{_appdir}/upgrade
749
750 %{_smartyplugindir}/*
751 %if %{without pear}
752 %{_appdir}/include/pear
753 %endif
754
755 %dir %{_appdir}/include
756 %{_appdir}/include/customer
757 %{_appdir}/include/jpgraph
758 %{_appdir}/include/workflow
759 %{_appdir}/include/class.[!m]*.php
760 %{_appdir}/include/class.mail.php
761 %{_appdir}/include/class.mail_queue.php
762 %{_appdir}/include/class.mime_helper.php
763 %{_appdir}/include/class.misc.php
764 %{_appdir}/include/db_access.php
765 %{_appdir}/include/jsrsServer.inc.php
766
767 %dir %attr(730,root,eventum) /var/run/%{name}
768 %dir %attr(730,root,eventum) /var/cache/%{name}
769
770 %files base
771 %defattr(644,root,root,755)
772 %attr(751,root,root) %dir %{_sysconfdir}
773 %dir %{_libdir}
774 %dir %{_appdir}
775 # qmail will ignore user, if it's home directory is not owned
776 %attr(750,eventum,eventum) %dir /var/lib/%{name}
777
778 %files setup
779 %defattr(644,root,root,755)
780 %{_appdir}/htdocs/setup
781
782 %files mail-queue
783 %defattr(644,root,root,755)
784 %{_appdir}/process_mail_queue.php
785 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
786
787 %files mail-download
788 %defattr(644,root,root,755)
789 %{_appdir}/download_emails.php
790 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
791
792 %files reminder
793 %defattr(644,root,root,755)
794 %{_appdir}/check_reminders.php
795 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
796
797 %files monitor
798 %defattr(644,root,root,755)
799 %{_appdir}/include/class.monitor.php
800 %{_appdir}/monitor.php
801 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
802
803 %files route-emails
804 %defattr(644,root,root,755)
805 %{_appdir}/route_emails.php
806
807 %files route-notes
808 %defattr(644,root,root,755)
809 %{_appdir}/route_drafts.php
810 %{_appdir}/route_notes.php
811
812 %files router-qmail
813 %defattr(644,root,root,755)
814 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
815 %attr(755,root,root) %{_libdir}/router-qmail
816
817 %files router-postfix
818 %defattr(644,root,root,755)
819
820 %files irc
821 %defattr(644,root,root,755)
822 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
823 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
824 %{_appdir}/irc
825 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
826
827 %files cli
828 %defattr(644,root,root,755)
829 %doc eventumrc
830 %attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
831 %attr(755,root,root) %{_bindir}/%{name}
832 %{_appdir}/cli
833
834 %files scm
835 %defattr(644,root,root,755)
836 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
837 %attr(755,root,root) %{_libdir}/scm
This page took 0.167435 seconds and 4 git commands to generate.