]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- adapterized
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - system pear is incompatible, at least pear DB class seems broke Eventum
3 # - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
4 # - discard bundled packages (from INSTALL):
5 #  - JpGraph 1.5.3 (last GPL version)
6 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
7 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
8 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
9 #  - A few other small javascript libraries
10 # - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
11 # - php4-pgsql crashes php (at least 4.3.11-1)
12
13 %bcond_with     pear    # build with system PEAR packages (or use bundled ones)
14
15 %define uid     146
16 %define gid     146
17
18 # snapshot: DATE
19 #define _snap 20050227
20
21 %if 0%{?_snap}
22 %define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
23 %else
24 %define _source http://mysql.dataphone.se/Downloads/%{name}/%{name}-%{version}.tar.gz
25 %endif
26
27 %define _rel 295
28
29 Summary:        Eventum Issue / Bug tracking system
30 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
31 Name:           eventum
32 Version:        1.5.3
33 Release:        0.%{?_snap:%{_snap}.}%{_rel}
34 License:        GPL
35 Group:          Applications/WWW
36 Source0:        %{_source}
37 # Source0-md5:  e8a5ac661d7ebdd71c8b38695c6e4af8
38 Source1:        %{name}-apache.conf
39 Source2:        %{name}-mail-queue.cron
40 Source3:        %{name}-mail-download.cron
41 Source4:        %{name}-reminder.cron
42 Source5:        %{name}-monitor.cron
43 Source6:        %{name}-cvs.php
44 Source7:        %{name}-irc.php
45 Source8:        %{name}-irc.init
46 Source9:        %{name}-irc.sysconfig
47 Source10:       %{name}-config.php
48 Source11:       %{name}-router-qmail.sh
49 Source12:       http://dev.mysql.com/common/favicon.ico
50 # Source12-md5: 858be0130832da4144c08d4b59116411
51 Source13:       %{name}-config-setup.php
52 Source14:       %{name}-upgrade.sh
53 Patch0:         %{name}-paths.patch
54 Patch1:         %{name}-cvs-config.patch
55 Patch2:         %{name}-irc-config.patch
56 Patch3:         %{name}-PEAR.patch
57 Patch4:         http://glen.alkohol.ee/pld/%{name}-reply-subject.patch
58 Patch5:         %{name}-lf.patch
59 Patch6:         http://glen.alkohol.ee/pld/%{name}-maq-subject.patch
60 URL:            http://dev.mysql.com/downloads/other/eventum/
61 BuildRequires:  rpmbuild(macros) >= 1.200
62 BuildRequires:  sed >= 4.0
63 Requires:       php >= 4.2.0
64 Requires:       php-gd
65 Requires:       php-imap
66 Requires:       php-mysql
67 Requires:       php-pcre
68 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
69 Requires:       Smarty >= 2.6.2
70 %if %{with pear}
71 Requires:       php-pear-Benchmark
72 Requires:       php-pear-DB
73 Requires:       php-pear-Date
74 Requires:       php-pear-HTTP_Request
75 Requires:       php-pear-Mail
76 Requires:       php-pear-Math_Stats
77 Requires:       php-pear-Net_DIME
78 Requires:       php-pear-Net_POP3
79 Requires:       php-pear-Net_SMTP
80 Requires:       php-pear-Net_SmartIRC
81 Requires:       php-pear-Net_Socket
82 Requires:       php-pear-Net_URL
83 Requires:       php-pear-Net_UserAgent_Detect
84 Requires:       php-pear-PEAR
85 Requires:       php-pear-Text_Diff
86 Requires:       php-pear-XML_RPC
87 %endif
88 Requires:       apache >= 1.3.33-2
89 Requires:       apache(mod_dir)
90 Requires(triggerpostun):        sed >= 4.0
91 BuildArch:      noarch
92 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93
94 %define         _sysconfdir     /etc/%{name}
95 %define         _libdir         %{_prefix}/%{_lib}/%{name}
96 %define         _appdir %{_datadir}/%{name}
97 %define         _smartyplugindir        %{php_pear_dir}/Smarty/plugins
98
99 %define         _apache1dir     /etc/apache
100 %define         _apache2dir     /etc/httpd
101
102 %description
103 Eventum is a user-friendly and flexible issue tracking system that can
104 be used by a support department to track incoming technical support
105 requests, or by a software development team to quickly organize tasks
106 and bugs. Eventum is used by the MySQL AB Technical Support team, and
107 has allowed us to dramatically improve our response times.
108
109 %description -l pl
110 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
111 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
112 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
113 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
114 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
115 reakcji.
116
117 %package base
118 Summary:        Eventum base package
119 Summary(pl):    Podstawowy pakiet Eventum
120 Group:          Applications/WWW
121 Requires(pre):  /bin/id
122 Requires(pre):  /usr/bin/getgid
123 Requires(pre):  /usr/sbin/useradd
124 Requires(pre):  /usr/sbin/groupadd
125 Provides:       user(eventum)
126 Provides:       group(eventum)
127
128 %description base
129 This package contains base directory structure for Eventum.
130
131 %description base -l pl
132 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
133
134 %package setup
135 Summary:        Eventum setup package
136 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
137 Group:          Applications/WWW
138 PreReq:         %{name} = %{epoch}:%{version}-%{release}
139
140 %description setup
141 Install this package to configure initial Eventum installation. You
142 should uninstall this package when you're done, as it considered
143 insecure to keep the setup files in place.
144
145 %description setup -l pl
146 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
147 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
148 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
149
150 %package mail-queue
151 Summary:        Eventum mail queue process
152 Summary(pl):    Przetwarzanie kolejki poczty Eventum
153 Group:          Applications/WWW
154 Requires:       %{name} = %{epoch}:%{version}-%{release}
155 Requires:       crondaemon
156 Requires:       php >= 4.1.0
157
158 %description mail-queue
159 Beginning with the first release of Eventum, emails are not directly
160 sent out from the various scripts, but rather added to a mail queue
161 table that is processed by a cron job. If an email cannot be sent, it
162 will be marked as such in the mail queue log, and the cron job script
163 will re-try to send it again the next time it runs.
164
165 This package contains the cron job.
166
167 %description mail-queue -l pl
168 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
169 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
170 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
171 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
172 nastêpnym razem.
173
174 Ten pakiet zawiera zadanie dla crona.
175
176 %package mail-download
177 Summary:        Eventum email download
178 Summary(pl):    ¦ci±ganie poczty Eventum
179 Group:          Applications/WWW
180 Requires:       %{name} = %{epoch}:%{version}-%{release}
181 Requires:       crondaemon
182 Requires:       php >= 4.1.0
183
184 %description mail-download
185 In order for Eventum's email integration feature to work, you need to
186 setup a cron job to run the script every so often.
187
188 This package contains the cron job.
189
190 %description mail-download -l pl
191 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
192 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
193 czêsto.
194
195 Ten pakiet zawiera zadanie dla crona.
196
197 %package reminder
198 Summary:        Eventum Reminder System
199 Summary(pl):    System przypominania dla Eventum
200 Group:          Applications/WWW
201 Requires:       %{name} = %{epoch}:%{version}-%{release}
202 Requires:       php >= 4.1.0
203 Requires:       crondaemon
204
205 %description reminder
206 The reminder system was designed with the objective as serving as a
207 safe net for issues that need attention. Depending on what
208 configuration you create, you may have several reminders (or alerts)
209 be sent out whenever an issue needs attention, for whatever parameter
210 you may deem necessary.
211
212 This package contains the cron job.
213
214 %description reminder -l pl
215 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
216 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
217 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
218 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
219 uwa¿aæ za potrzebny.
220
221 Ten pakiet zawiera zadanie dla crona.
222
223 %package monitor
224 Summary:        Eventum Heartbeat Monitor
225 Summary(pl):    Monitor ¿ycia dla Eventum
226 Group:          Applications/WWW
227 Requires:       %{name} = %{epoch}:%{version}-%{release}
228 Requires:       php >= 4.1.0
229 Requires:       php-posix
230 Requires:       crondaemon
231
232 %description monitor
233 The heartbeat monitor is a feature designed for the administrator that
234 wants to be alerted whenever a common problem in Eventum is detected,
235 like the database server not being available anymore, or maybe when
236 the recommended permissions for certain configuration files are
237 changed.
238
239 Please note that before running the heartbeat monitor, you may need to
240 customize some of the checks to be appropriate for your own system,
241 particularly the permission and file checks on
242 Monitor::checkConfiguration().
243
244 This package contains the cron job.
245
246 %description monitor -l pl
247 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
248 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
249 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
250 do plików konfiguracyjnych.
251
252 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
253 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
254 testów uprawnieñ i plików w Monitor::checkConfiguration().
255
256 Ten pakiet zawiera zadanie dla crona.
257
258 %package route-emails
259 Summary:        Eventum Email Routing
260 Summary(pl):    Przekazywanie poczty dla Eventum
261 Group:          Applications/WWW
262 Requires:       %{name} = %{epoch}:%{version}-%{release}
263 Requires:       php >= 4.1.0
264 Requires:       eventum(router)
265
266 %description route-emails
267 The email routing feature is used to automatically associate a thread
268 of emails into an Eventum issue. By setting up qmail (or even postfix)
269 to deliver emails sent to a specific address (usually
270 issue-<number>@<domain>) to the above script, users are able to use
271 their email clients to reply to emails coming from Eventum, and those
272 replies will be automatically associated with the issue and
273 broadcasted to the entire notification list.
274
275 %description route-emails -l pl
276 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
277 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
278 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
279 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
280 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
281 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
282 rozprowadzane do ca³ej listy og³oszeniowej.
283
284 %package route-notes
285 Summary:        Eventum Note Routing
286 Summary(pl):    Przekazywanie notatek dla Eventum
287 Group:          Applications/WWW
288 Requires:       %{name} = %{epoch}:%{version}-%{release}
289 Requires:       php >= 4.1.0
290 Requires:       eventum(router)
291
292 %description route-notes
293 The note routing feature is used to automatically associate a thread
294 of notes into an Eventum issue. By setting up qmail (or even postfix)
295 to deliver emails sent to a specific address (usually
296 note-<number>@<domain>) to the above script, users are able to use
297 their email clients to reply to internal notes coming from Eventum,
298 and those replies will be automatically associated with the issue and
299 broadcasted to the notification list staff members.
300
301 %description route-notes -l pl
302 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
303 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
304 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
305 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
306 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
307 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
308 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
309
310 %package router-qmail
311 Summary:        Eventum Mail Routing - qmail
312 Summary(pl):    Przekazywanie poczty Eventum - qmail
313 Group:          Applications/Mail
314 Requires:       %{name} = %{epoch}:%{version}-%{release}
315 Requires:       qmail >= 1.03
316 Provides:       eventum(router)
317 Obsoletes:      eventum(router)
318
319 %description router-qmail
320 This package provides way of routing notes and emails back to Eventum
321 via qmail.
322
323 %description router-qmail -l pl
324 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
325 przez qmaila.
326
327 %package router-postfix
328 Summary:        Eventum Mail Routing - Postfix
329 Summary(pl):    Przekazywanie poczty Eventum - Postfix
330 Group:          Applications/Mail
331 Requires:       %{name} = %{epoch}:%{version}-%{release}
332 Requires:       postfix
333 Provides:       eventum(router)
334 Obsoletes:      eventum(router)
335
336 %description router-postfix
337 This package provides way of routing notes and emails back to Eventum
338 via Postfix.
339
340 %description router-postfix -l pl
341 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
342 przez Postfiksa.
343
344 %package irc
345 Summary:        Eventum IRC Notification Bot
346 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
347 Group:          Applications/WWW
348 Requires:       %{name} = %{epoch}:%{version}-%{release}
349 Requires:       php >= 4.1.0
350 Requires:       php-sockets
351 Requires:       rc-scripts >= 0.4.0.18
352
353 %description irc
354 The IRC notification bot is a nice feature for remote teams that want
355 to handle issues and want to have a quick and easy way to get simple
356 notifications. Right now the bot notifies of the following actions:
357 - New Issues
358 - Blocked emails
359 - Issues that got their assignment list changed
360
361 NOTE: You will need to manually edit the bot.php script to set your
362 appropriate preferences, like IRC server and channel that the bot
363 should join.
364
365 %description irc -l pl
366 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
367 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
368 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
369 nastêpuj±cych zdarzeniach:
370 - nowych sprawach
371 - zablokowanych listach
372 - sprawach, dla których zmieni³a siê lista powi±zañ
373
374 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
375 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
376
377 %package cli
378 Summary:        Eventum command-line interface
379 Summary(pl):    Interfejs linii poleceñ dla Eventum
380 Group:          Applications/WWW
381 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
382 Requires:       php >= 4.1.0
383 Requires:       php-cli
384 Requires:       php-curl
385 Requires:       php-xml
386 Requires:       php-pear-XML_RPC
387
388 %description cli
389 The Eventum command-line interface allows you to access most of the
390 features of the web interface straight from your command shell.
391
392 %description cli -l pl
393 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
394 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
395
396 %package scm
397 Summary:        Eventum SCM integration
398 Summary(pl):    Integracja SCM dla Eventum
399 Group:          Applications/WWW
400 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
401 Requires:       php >= 4.1.0
402
403 %description scm
404 This feature allows your software development teams to integrate your
405 Source Control Management system with your Issue Tracking System.
406
407 The integration is implemented in such a way that it will be forward
408 compatible with pretty much any SCM system, such as CVS.
409
410 For installation see
411 </eventum/help.php?topic=scm_integration_installation>.
412
413 %description scm -l pl
414 Ten pakiet pozwala zespo³om programistów na integracjê systemu
415 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
416 ¶ledzenia spraw.
417
418 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
419 prawie ka¿dym systemem SCM, jak np. CVS.
420
421 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
422 </eventum/help.php?topic=scm_integration_installation>.
423
424 %prep
425 %setup -q %{?_snap:-n %{name}-%{_snap}}
426 # undos the source
427 find . -type f -print0 | xargs -0 sed -i -e 's,
428 $,,'
429
430 # packaging
431 %patch0 -p1 -b .paths
432 %patch1 -p1
433 %patch2 -p1
434 %{?with_pear:%patch3 -p1 -b .PEAR}
435
436 # bug fixes.
437 %patch4 -p1
438 %patch5 -p1
439 %patch6 -p1
440
441 # replace in remaining scripts config.inc.php to system one
442 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
443         s,include_once(".*config.inc.php"),include_once("%{_sysconfdir}/core.php"),
444 '
445 sed -i -e '
446         s,include(".*config.inc.php"),include_once("%{_sysconfdir}/core.php"),
447 ' misc/download_emails.php
448
449 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
450         s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_sysconfdir}/private_key.php"),
451 '
452 find -name '*~' | xargs -r rm -v
453
454 %install
455 rm -rf $RPM_BUILD_ROOT
456 install -d \
457         $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_libdir}} \
458         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
459         $RPM_BUILD_ROOT/var/{run,log,cache,lib}/%{name} \
460         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
461
462 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
463 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
464 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
465 cp -a misc/irc $RPM_BUILD_ROOT%{_appdir}
466 cp -a templates $RPM_BUILD_ROOT%{_appdir}
467 cp -a include/{customer,jpgraph,pear,workflow} $RPM_BUILD_ROOT%{_appdir}/include
468 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
469 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
470 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
471
472 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
473 install %{SOURCE13} $RPM_BUILD_ROOT%{_appdir}/htdocs/setup/config.inc.php
474 install %{SOURCE14} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
475
476 # cli
477 install -d $RPM_BUILD_ROOT%{_appdir}/cli
478 install misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
479 install misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
480 sed -e '1s,#!.*/bin/php,#!%{_bindir}/php4,' \
481         misc/cli/eventum > $RPM_BUILD_ROOT%{_bindir}/%{name}
482 cp -f misc/cli/eventumrc_example eventumrc
483
484 # scm
485 echo '#!%{_bindir}/php4 -q' > %{name}-scm
486 cat misc/scm/process_cvs_commits.php >> %{name}-scm
487 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
488
489 # private key
490 mv $RPM_BUILD_ROOT{%{_appdir}/include/private_key.php,%{_sysconfdir}}
491 # change private key, so we can easily grep
492 sed -i -e '
493 s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
494 ' $RPM_BUILD_ROOT%{_sysconfdir}/private_key.php
495
496 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
497 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
498 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
499 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
500 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
501 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
502 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
503 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
504 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
505 sed -e 's,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}},' \
506         %{SOURCE10} > $RPM_BUILD_ROOT%{_sysconfdir}/core.php
507
508 # config
509 > $RPM_BUILD_ROOT%{_sysconfdir}/setup.php
510 mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_sysconfdir}/config}.php
511
512 # sample, not used in eventum
513 rm -f $RPM_BUILD_ROOT%{_appdir}/htdocs/rpc/xmlrpc_client.php
514
515 %if %{with pear}
516 # provided by PEAR
517 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
518 %endif
519
520 # use system Smarty
521 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
522 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
523 # These plugins are not in Smarty package (Smarty-2.6.2-3)
524 cp -a include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
525         $RPM_BUILD_ROOT%{_smartyplugindir}
526
527 # qmail router
528 d=$RPM_BUILD_ROOT/var/lib/%{name}
529 echo 'root' > $d/.qmail
530 echo 'root' > $d/.qmail-default
531 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
532 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
533 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
534 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
535
536 %clean
537 rm -rf $RPM_BUILD_ROOT
538
539 %pre
540 %addusertogroup http %{name}
541
542 %post
543 # apache1
544 if [ -d %{_apache1dir}/conf.d ]; then
545         ln -sf %{_sysconfdir}/apache.conf %{_apache1dir}/conf.d/99_%{name}.conf
546         if [ -f /var/lock/subsys/apache ]; then
547                 /etc/rc.d/init.d/apache restart 1>&2
548         fi
549 fi
550 # apache2
551 if [ -d %{_apache2dir}/httpd.conf ]; then
552         ln -sf %{_sysconfdir}/apache.conf %{_apache2dir}/httpd.conf/99_%{name}.conf
553         if [ -f /var/lock/subsys/httpd ]; then
554                 /etc/rc.d/init.d/httpd restart 1>&2
555         fi
556 fi
557
558 # check if the package is configured.
559 if grep -q 'header("Location: setup/")' %{_sysconfdir}/config.php; then
560 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
561 %banner %{name} -e <<EOF
562
563 You haven't yet configured Eventum!
564 Please open in browser <http://localhost/eventum/>
565 If you need access from elsewhere, you need to edit
566 %{_sysconfdir}/apache.conf and restart apache.
567
568 IMPORTANT: When You have configured Eventum, please uninstall the
569 setup package, so that %{name}-setup is able to secure your Eventum
570 installation.
571
572 EOF
573 #' vim stupidity.
574 else
575 %banner %{name} -e <<EOF
576
577 You haven't yet configured Eventum!
578
579 To setup eventum, please install %{name}-setup and open in browser
580 <http://localhost/eventum/>.
581 If you need access from elsewhere, you need to edit
582 %{_sysconfdir}/apache.conf and restart apache.
583
584 IMPORTANT: When You have configured Eventum, please uninstall the
585 setup package, so that %{name}-setup is able to secure your Eventum
586 installation.
587
588 EOF
589 #' vim stupidity.
590 fi
591
592 elif grep -q 'DEFAULTPRIVATEKEY' %{_sysconfdir}/private_key.php; then
593 %banner %{name} -e <<EOF
594
595 You have default private key installed!
596
597 Install %{name}-setup and open up http://yourserver/eventum/setup/
598 -- that will help you setup initial config.
599
600 when have configured Eventum, please uninstall the setup package,
601 so that %{name}-setup is able to secure your Eventum installation.
602
603 EOF
604         elif [ -d %{_appdir}/setup ]; then
605 %banner %{name} -e <<EOF
606
607 If you have have configured Eventum, please uninstall the setup package,
608 so that %{name}-setup is able to secure your Eventum installation.
609
610 EOF
611 fi
612
613 # nuke Smarty templates cache after upgrade
614 rm -f /var/cache/eventum/*.php
615
616 %preun
617 if [ "$1" = "0" ]; then
618         # apache1
619         if [ -f %{_apache1dir}/apache.conf ]; then
620                 rm -f %{_apache1dir}/conf.d/99_%{name}.conf
621                 if [ -f /var/lock/subsys/apache ]; then
622                         /etc/rc.d/init.d/apache restart 1>&2
623                 fi
624         fi
625         # apache2
626         if [ -d %{_apache2dir}/httpd.conf ]; then
627                 rm -f %{_apache2dir}/httpd.conf/99_%{name}.conf
628                 if [ -f /var/lock/subsys/httpd ]; then
629                         /etc/rc.d/init.d/httpd restart 1>&2
630                 fi
631         fi
632
633         # nuke cache
634         rm -f /var/cache/eventum/*.php 2>/dev/null || :
635 fi
636
637 %pre base
638 %groupadd -P %{name}-base -g %{gid} %{name}
639 %useradd -P %{name}-base -u %{uid} -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
640
641 %postun base
642 if [ "$1" = "0" ]; then
643         %userremove %{name}
644         %groupremove %{name}
645 fi
646
647 %post router-qmail
648 CF=/etc/qmail/control/virtualdomains
649 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
650         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_sysconfdir}/config.php 2>/dev/null)
651         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
652         umask 022
653         echo "#${FQDN}:%{name}" >> $CF
654
655 %banner %{name}-qmail -e <<EOF
656
657 Added "#${FQDN}:%{name}" to $CF,
658 Please verify that it is correct and restart qmail:
659 # service qmail reload
660
661 Consult qmail-send(8) for more information on virtualdomains.
662
663 EOF
664 fi
665
666 %preun router-qmail
667 if [ "$1" = "0" ]; then
668         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
669 fi
670
671 %post setup
672 chmod 660 %{_sysconfdir}/{config,private_key}.php
673 chown root:eventum %{_sysconfdir}/{config,private_key}.php
674
675 %postun setup
676 if [ "$1" = "0" ]; then
677         chmod 640 %{_sysconfdir}/{config,private_key}.php
678         chown root:eventum %{_sysconfdir}/{config,private_key}.php
679 fi
680
681 # FIXME
682 # only one upgrade trigger is called if you're upgrading over two
683 # versions, say 1.5 to 1.5.3, only 1.5.3 trigger is called.
684 # use common trigger (the highest version and rpmvercmp from poldek?)
685 %triggerpostun -- eventum < 1.5.1-0.257
686 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5_to_v1.5.1 <<EOF
687 database_changes.php Perform database changes
688 EOF
689
690 %triggerpostun -- eventum < 1.5.2-0.289
691 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.1_to_v1.5.2 <<EOF
692 database_changes.php Perform database changes
693 set_priority_ranks.php Fix the ranking of priority values
694 EOF
695
696 %triggerpostun -- eventum < 1.5.3-0.291
697 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.2_to_v1.5.3 <<EOF
698 database_changes.php Perform database changes
699 EOF
700
701 %files
702 %defattr(644,root,root,755)
703 %doc ChangeLog FAQ INSTALL README UPGRADE
704 %doc docs/* rpc/xmlrpc_client.php setup/schema.sql
705 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
706 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
707 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/private_key.php
708 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/setup.php
709 %attr(640,root,eventum) %config %verify(not mtime) %{_sysconfdir}/core.php
710
711 %dir %attr(731,root,eventum) /var/log/%{name}
712 %attr(620,root,eventum) %ghost /var/log/%{name}/*
713
714 %dir %{_appdir}/htdocs
715 %{_appdir}/htdocs/*.php
716 %{_appdir}/htdocs/*.ico
717 %{_appdir}/htdocs/css
718 %{_appdir}/htdocs/customer
719 %{_appdir}/htdocs/images
720 %{_appdir}/htdocs/js
721 %{_appdir}/htdocs/manage
722 %{_appdir}/htdocs/reports
723 %{_appdir}/htdocs/rpc
724 %{_appdir}/htdocs/misc
725
726 %{_appdir}/templates
727 %dir %{_appdir}/upgrade
728 %attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
729 %{_appdir}/upgrade/[!u]*
730
731 %{_smartyplugindir}/*
732 %if %{without pear}
733 %{_appdir}/include/pear
734 %endif
735
736 %dir %{_appdir}/include
737 %{_appdir}/include/customer
738 %{_appdir}/include/jpgraph
739 %{_appdir}/include/workflow
740 %{_appdir}/include/class.[!m]*.php
741 %{_appdir}/include/class.mail.php
742 %{_appdir}/include/class.mail_queue.php
743 %{_appdir}/include/class.mime_helper.php
744 %{_appdir}/include/class.misc.php
745 %{_appdir}/include/db_access.php
746 %{_appdir}/include/jsrsServer.inc.php
747
748 %dir %attr(730,root,eventum) /var/run/%{name}
749 %dir %attr(730,root,eventum) /var/cache/%{name}
750
751 %files base
752 %defattr(644,root,root,755)
753 %attr(751,root,root) %dir %{_sysconfdir}
754 %dir %{_libdir}
755 %dir %{_appdir}
756 # qmail will ignore user, if it's home directory is not owned
757 %attr(750,eventum,eventum) %dir /var/lib/%{name}
758
759 %files setup
760 %defattr(644,root,root,755)
761 %{_appdir}/htdocs/setup
762
763 %files mail-queue
764 %defattr(644,root,root,755)
765 %{_appdir}/process_mail_queue.php
766 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
767
768 %files mail-download
769 %defattr(644,root,root,755)
770 %{_appdir}/download_emails.php
771 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
772
773 %files reminder
774 %defattr(644,root,root,755)
775 %{_appdir}/check_reminders.php
776 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
777
778 %files monitor
779 %defattr(644,root,root,755)
780 %{_appdir}/include/class.monitor.php
781 %{_appdir}/monitor.php
782 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
783
784 %files route-emails
785 %defattr(644,root,root,755)
786 %{_appdir}/route_emails.php
787
788 %files route-notes
789 %defattr(644,root,root,755)
790 %{_appdir}/route_drafts.php
791 %{_appdir}/route_notes.php
792
793 %files router-qmail
794 %defattr(644,root,root,755)
795 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
796 %attr(755,root,root) %{_libdir}/router-qmail
797
798 %files router-postfix
799 %defattr(644,root,root,755)
800
801 %files irc
802 %defattr(644,root,root,755)
803 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
804 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
805 %{_appdir}/irc
806 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
807
808 %files cli
809 %defattr(644,root,root,755)
810 %doc eventumrc
811 %attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
812 %attr(755,root,root) %{_bindir}/%{name}
813 %{_appdir}/cli
814
815 %files scm
816 %defattr(644,root,root,755)
817 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
818 %attr(755,root,root) %{_libdir}/scm
This page took 0.120242 seconds and 4 git commands to generate.