]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- patch that allows local TZ setting
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - system pear is incompatible, at least pear DB class seems broke Eventum
3 # - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
4 # - discard bundled packages (from INSTALL):
5 #  - JpGraph 1.5.3 (last GPL version)
6 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
7 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
8 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
9 #  - A few other small javascript libraries
10 # - create eventum-router-qmail, eventum-router-postfix for -route-mails and -route-notes
11 # - need start-stop-daemon (from dpkg for now)
12 # - use eventum user for irc bot?
13
14 %bcond_with     pear    # build with system PEAR packages (or use bundled ones)
15
16 # snapshot: DATE
17 #define _snap 20050217
18
19 %if 0%{?_snap}
20 %define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
21 %else
22 %define _source http://mysql.wildyou.net/Downloads/%{name}/%{name}-%{version}.tar.gz
23 %endif
24
25 %define _rel 1.147
26
27 Summary:        Eventum Issue - a bug tracking system
28 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
29 Name:           eventum
30 Version:        1.4
31 Release:        %{?_snap:0.%{_snap}.}%{_rel}
32 License:        GPL
33 Group:          Applications/WWW
34 Source0:        %{_source}
35 # Source0-md5:  361c1355e46a6bbfa54e420964ec92cf
36 Source1:        %{name}-apache.conf
37 Source2:        %{name}-mail-queue.cron
38 Source3:        %{name}-mail-download.cron
39 Source4:        %{name}-reminder.cron
40 Source5:        %{name}-monitor.cron
41 Source6:        %{name}-cvs.php
42 Source7:        %{name}-irc.php
43 Source8:        %{name}-irc.init
44 Patch0:         %{name}-paths.patch
45 Patch1:         %{name}-scm-encode.patch
46 Patch2:         %{name}-cvs-config.patch
47 Patch3:         %{name}-irc-config.patch
48 Patch4:         %{name}-PEAR.patch
49 Patch11:                %{name}-scm_checkin_associated.patch
50 Patch12:                %{name}-mail-queue.tpl.patch
51 Patch13:                %{name}-maildecode.patch
52 Patch14:                %{name}-send-typo.patch
53 Patch15:                %{name}-fixes.patch
54 Patch16:                %{name}-rss-charset.patch
55 Patch17:                %{name}-scm-silence-add.patch
56 Patch18:                %{name}-default-TZ.patch
57 URL:            http://dev.mysql.com/downloads/other/eventum/index.html
58 BuildRequires:  rpmbuild(macros) >= 1.177
59 BuildRequires:  sed >= 4.0
60 Requires:       php >= 4.1.0
61 Requires:       php-gd
62 Requires:       php-imap
63 Requires:       php-mysql
64 Requires:       php-pcre
65 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
66 %if %{with pear}
67 Requires:       Smarty >= 2.6.2
68 Requires:       php-pear-Benchmark
69 Requires:       php-pear-DB
70 Requires:       php-pear-Date
71 Requires:       php-pear-HTTP_Request
72 Requires:       php-pear-Mail
73 Requires:       php-pear-Math_Stats
74 Requires:       php-pear-Net_DIME
75 Requires:       php-pear-Net_POP3
76 Requires:       php-pear-Net_SMTP
77 Requires:       php-pear-Net_SmartIRC
78 Requires:       php-pear-Net_Socket
79 Requires:       php-pear-Net_URL
80 Requires:       php-pear-Net_UserAgent_Detect
81 Requires:       php-pear-PEAR
82 Requires:       php-pear-Text_Diff
83 Requires:       php-pear-XML_RPC
84 %endif
85 Requires:       apache-mod_dir
86 # conflict with non-confdir apache
87 Conflicts:      apache1 < 1.3.33-1.1
88 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
89
90 %define         _sysconfdir     /etc/%{name}
91 %define         _libdir         %{_prefix}/%{_lib}/%{name}
92 %define         _appdir %{_datadir}/%{name}
93 %define         _smartyplugindir        %{php_pear_dir}/Smarty/plugins
94
95 %define         _apache1dir     /etc/apache
96 %define         _apache2dir     /etc/httpd
97
98 %description
99 Eventum is a user-friendly and flexible issue tracking system that can
100 be used by a support department to track incoming technical support
101 requests, or by a software development team to quickly organize tasks
102 and bugs. Eventum is used by the MySQL AB Technical Support team, and
103 has allowed us to dramatically improve our response times.
104
105 %description -l pl
106 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
107 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
108 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
109 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
110 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
111 reakcji.
112
113 %package base
114 Summary:        Eventum base package
115 Summary(pl):    Podstawowy pakiet Eventum
116 Group:          Applications/WWW
117
118 %description base
119 This package contains base directory structure for Eventum.
120
121 %description base -l pl
122 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
123
124 %package setup
125 Summary:        Eventum setup package
126 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
127 Group:          Applications/WWW
128 PreReq:         %{name} = %{epoch}:%{version}-%{release}
129
130 %description setup
131 Install this package to configure initial Eventum installation. You
132 should uninstall this package when you're done, as it considered
133 insecure to keep the setup files in place.
134
135 %description setup -l pl
136 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
137 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
138 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
139
140 %package mail-queue
141 Summary:        Eventum mail queue process
142 Summary(pl):    Przetwarzanie kolejki poczty Eventum
143 Group:          Applications/WWW
144 Requires:       %{name} = %{epoch}:%{version}-%{release}
145 Requires:       crondaemon
146 Requires:       php4 >= 4.1.0
147
148 %description mail-queue
149 Beginning with the first release of Eventum, emails are not directly
150 sent out from the various scripts, but rather added to a mail queue
151 table that is processed by a cron job. If an email cannot be sent, it
152 will be marked as such in the mail queue log, and the cron job script
153 will re-try to send it again the next time it runs.
154
155 This package contains the cron job.
156
157 %description mail-queue -l pl
158 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
159 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
160 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
161 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
162 nastêpnym razem.
163
164 Ten pakiet zawiera zadanie dla crona.
165
166 %package mail-download
167 Summary:        Eventum email download
168 Summary(pl):    ¦ci±ganie poczty Eventum
169 Group:          Applications/WWW
170 Requires:       %{name} = %{epoch}:%{version}-%{release}
171 Requires:       crondaemon
172 Requires:       php4 >= 4.1.0
173
174 %description mail-download
175 In order for Eventum's email integration feature to work, you need to
176 setup a cron job to run the script every so often.
177
178 This package contains the cron job.
179
180 %description mail-download -l pl
181 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
182 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
183 czêsto.
184
185 Ten pakiet zawiera zadanie dla crona.
186
187 %package reminder
188 Summary:        Eventum Reminder System
189 Summary(pl):    System przypominania dla Eventum
190 Group:          Applications/WWW
191 Requires:       %{name} = %{epoch}:%{version}-%{release}
192 Requires:       php4 >= 4.1.0
193 Requires:       crondaemon
194
195 %description reminder
196 The reminder system was designed with the objective as serving as a
197 safe net for issues that need attention. Depending on what
198 configuration you create, you may have several reminders (or alerts)
199 be sent out whenever an issue needs attention, for whatever parameter
200 you may deem necessary.
201
202 This package contains the cron job.
203
204 %description reminder -l pl
205 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
206 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
207 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
208 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
209 uwa¿aæ za potrzebny.
210
211 Ten pakiet zawiera zadanie dla crona.
212
213 %package monitor
214 Summary:        Eventum Heartbeat Monitor
215 Summary(pl):    Monitor ¿ycia dla Eventum
216 Group:          Applications/WWW
217 Requires:       %{name} = %{epoch}:%{version}-%{release}
218 Requires:       php4 >= 4.1.0
219 Requires:       crondaemon
220
221 %description monitor
222 The heartbeat monitor is a feature designed for the administrator that
223 wants to be alerted whenever a common problem in Eventum is detected,
224 like the database server not being available anymore, or maybe when
225 the recommended permissions for certain configuration files are
226 changed.
227
228 Please note that before running the heartbeat monitor, you may need to
229 customize some of the checks to be appropriate for your own system,
230 particularly the permission and file checks on
231 Monitor::checkConfiguration().
232
233 This package contains the cron job.
234
235 %description monitor -l pl
236 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
237 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
238 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
239 do plików konfiguracyjnych.
240
241 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
242 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
243 testów uprawnieñ i plików w Monitor::checkConfiguration().
244
245 Ten pakiet zawiera zadanie dla crona.
246
247 %package route-emails
248 Summary:        Eventum Email Routing
249 Summary(pl):    Przekazywanie poczty dla Eventum
250 Group:          Applications/WWW
251 Requires:       %{name} = %{epoch}:%{version}-%{release}
252 Requires:       php4 >= 4.1.0
253 #Requires:      eventum-router
254
255 %description route-emails
256 The email routing feature is used to automatically associate a thread
257 of emails into an Eventum issue. By setting up qmail (or even postfix)
258 to deliver emails sent to a specific address (usually
259 issue-<number>@<domain>) to the above script, users are able to use
260 their email clients to reply to emails coming from Eventum, and those
261 replies will be automatically associated with the issue and
262 broadcasted to the entire notification list.
263
264 %description route-emails -l pl
265 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
266 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
267 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
268 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
269 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
270 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
271 rozprowadzane do ca³ej listy og³oszeniowej.
272
273 %package route-notes
274 Summary:        Eventum Note Routing
275 Summary(pl):    Przekazywanie notatek dla Eventum
276 Group:          Applications/WWW
277 Requires:       %{name} = %{epoch}:%{version}-%{release}
278 Requires:       php4 >= 4.1.0
279 #Requires:      eventum-router
280
281 %description route-notes
282 The note routing feature is used to automatically associate a thread
283 of notes into an Eventum issue. By setting up qmail (or even postfix)
284 to deliver emails sent to a specific address (usually
285 note-<number>@<domain>) to the above script, users are able to use
286 their email clients to reply to internal notes coming from Eventum,
287 and those replies will be automatically associated with the issue and
288 broadcasted to the notification list staff members.
289
290 %description route-notes -l pl
291 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
292 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
293 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
294 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
295 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
296 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
297 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
298
299 %package irc
300 Summary:        Eventum IRC Notification Bot
301 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
302 Group:          Applications/WWW
303 Requires:       %{name} = %{epoch}:%{version}-%{release}
304 Requires:       php >= 4.1.0
305 Requires:       php-sockets
306 # FIXME just need start-stop-daemon
307 Requires:       dpkg
308
309 %description irc
310 The IRC notification bot is a nice feature for remote teams that want
311 to handle issues and want to have a quick and easy way to get simple
312 notifications. Right now the bot notifies of the following actions:
313 - New Issues
314 - Blocked emails
315 - Issues that got their assignment list changed
316
317 NOTE: You will need to manually edit the bot.php script to set your
318 appropriate preferences, like IRC server and channel that the bot
319 should join.
320
321 %description irc -l pl
322 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
323 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
324 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
325 nastêpuj±cych zdarzeniach:
326 - nowych sprawach
327 - zablokowanych listach
328 - sprawach, dla których zmieni³a siê lista powi±zañ
329
330 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
331 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
332
333 %package cli
334 Summary:        Eventum command-line interface
335 Summary(pl):    Interfejs linii poleceñ dla Eventum
336 Group:          Applications/WWW
337 Requires:       %{name} = %{epoch}:%{version}-%{release}
338 Requires:       php4 >= 4.1.0
339 Requires:       php4-cli
340 Requires:       php4-curl
341 Requires:       php4-xml
342 Requires:       php-pear-XML_RPC
343
344 %description cli
345 The Eventum command-line interface allows you to access most of the
346 features of the web interface straight from your command shell.
347
348 %description cli -l pl
349 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
350 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
351
352 %package scm
353 Summary:        Eventum SCM integration
354 Summary(pl):    Integracja SCM dla Eventum
355 Group:          Applications/WWW
356 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
357 Requires:       php4 >= 4.1.0
358
359 %description scm
360 This feature allows your software development teams to integrate your
361 Source Control Management system with your Issue Tracking System.
362
363 The integration is implemented in such a way that it will be forward
364 compatible with pretty much any SCM system, such as CVS.
365
366 For installation see
367 </eventum/help.php?topic=scm_integration_installation>.
368
369 %description scm -l pl
370 Ten pakiet pozwala zespo³om programistów na integracjê systemu
371 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
372 ¶ledzenia spraw.
373
374 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
375 prawie ka¿dym systemem SCM, jak np. CVS.
376
377 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
378 </eventum/help.php?topic=scm_integration_installation>.
379
380 %prep
381 %setup -q %{?_snap:-n %{name}-%{_snap}}
382 # undos the source
383 find . -type f -print0 | xargs -0 sed -i -e 's,
384 $,,'
385
386 # packaging
387 %patch0 -p1 -b .paths
388 %patch1 -p1
389 %patch2 -p1
390 %patch3 -p1
391 %{?with_pear:%patch4 -p1 -b .PEAR}
392
393 # bug fixes.
394 %patch11 -p1
395 %patch12 -p1
396 %patch13 -p1
397 %patch14 -p1
398 %patch15 -p1
399 %patch16 -p1
400 %patch17 -p1
401 %patch18 -p1
402
403 rm -f */*~ */*/*~
404
405 %install
406 rm -rf $RPM_BUILD_ROOT
407 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_libdir},%{_appdir}} \
408         $RPM_BUILD_ROOT{/etc/{rc.d/init.d,cron.d},/var/log/%{name}} \
409         $RPM_BUILD_ROOT{/var/run/eventum,/var/cache/eventum}
410
411 cp -a *.php {css,customer,images,include,js} \
412         {manage,misc,reports,rpc,setup,templates} $RPM_BUILD_ROOT%{_appdir}
413 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
414
415 > $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
416
417 sed -i -e 's,/usr/local/bin/php,/usr/bin/php4,' $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum
418 echo '#!/usr/bin/php4 -q' > %{name}-scm
419 cat $RPM_BUILD_ROOT%{_appdir}/misc/scm/process_cvs_commits.php >> %{name}-scm
420
421 # change private key, so we can easily grep
422 sed -i -e '
423 s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
424 ' $RPM_BUILD_ROOT%{_appdir}/include/private_key.php
425
426 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
427 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
428 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
429 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
430 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
431 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
432 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
433 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
434
435 # in conf
436 mv $RPM_BUILD_ROOT%{_appdir}/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/config.php
437 mv $RPM_BUILD_ROOT%{_appdir}/setup.conf.php $RPM_BUILD_ROOT%{_sysconfdir}/setup.php
438 mv $RPM_BUILD_ROOT%{_appdir}/include/private_key.php $RPM_BUILD_ROOT%{_sysconfdir}
439 mv $RPM_BUILD_ROOT%{_appdir}/misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
440 ln -s %{_sysconfdir}/config.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
441 ln -s %{_sysconfdir}/setup.php $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
442 ln -s %{_sysconfdir}/private_key.php $RPM_BUILD_ROOT%{_appdir}/include/private_key.php
443
444 # in doc
445 rm -rf $RPM_BUILD_ROOT%{_appdir}/misc/upgrade
446 # sample, not used in eventum
447 rm -rf $RPM_BUILD_ROOT%{_appdir}/rpc/xmlrpc_client.php
448
449 # in bindir
450 mv $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum $RPM_BUILD_ROOT%{_bindir}
451 rm -f $RPM_BUILD_ROOT%{_appdir}/misc/{cli/eventumrc_example,scm/process_cvs_commits.php}
452 cp misc/cli/eventumrc_example eventumrc
453 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
454
455 %if %{with pear}
456 # provided by PEAR
457 rm -rf $RPM_BUILD_ROOT%{_appdir}/misc/cli/include/pear
458 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
459
460 # use system Smarty
461 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
462 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
463 # These plugins are not in Smarty package (Smarty-2.6.2-3)
464 cp -a include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php $RPM_BUILD_ROOT%{_smartyplugindir}
465 %endif
466
467 %clean
468 rm -rf $RPM_BUILD_ROOT
469
470 %post
471 # apache1
472 if [ -d %{_apache1dir}/conf.d ]; then
473         ln -sf %{_sysconfdir}/apache.conf %{_apache1dir}/conf.d/99_%{name}.conf
474         if [ -f /var/lock/subsys/apache ]; then
475                 /etc/rc.d/init.d/apache restart 1>&2
476         fi
477 fi
478 # apache2
479 if [ -d %{_apache2dir}/httpd.conf ]; then
480         ln -sf %{_sysconfdir}/apache.conf %{_apache2dir}/httpd.conf/99_%{name}.conf
481         if [ -f /var/lock/subsys/httpd ]; then
482                 /etc/rc.d/init.d/httpd restart 1>&2
483         fi
484 fi
485
486 # check if the package is configured.
487 if grep -q 'header("Location: setup/")' %{_sysconfdir}/config.php; then
488 %banner %{name} -e <<EOF
489
490 You haven't yet configured Eventum!
491
492 Install %{name}-setup and open up http://yourserver/eventum/
493 -- that will help you setup initial config.
494
495 when have configured Eventum, please uninstall the setup package,
496 so that %{name}-setup is able to secure your Eventum installation.
497
498 EOF
499 #' vim stupidity.
500
501 elif grep -q 'DEFAULTPRIVATEKEY' %{_sysconfdir}/private_key.php; then
502 %banner %{name} -e <<EOF
503
504 You have default private key installed!
505
506 Install %{name}-setup and open up http://yourserver/eventum/setup/
507 -- that will help you setup initial config.
508
509 when have configured Eventum, please uninstall the setup package,
510 so that %{name}-setup is able to secure your Eventum installation.
511
512 EOF
513         elif [ -d %{_appdir}/setup ]; then
514 %banner %{name} -e <<EOF
515
516 If you have have configured Eventum, please uninstall the setup package,
517 so that %{name}-setup is able to secure your Eventum installation.
518
519 EOF
520 fi
521
522
523 %preun
524 if [ "$1" = "0" ]; then
525         # apache1
526         if [ -f %{_apache1dir}/apache.conf ]; then
527                 rm -f %{_apache1dir}/conf.d/99_%{name}.conf
528                 if [ -f /var/lock/subsys/apache ]; then
529                         /etc/rc.d/init.d/apache restart 1>&2
530                 fi
531         fi
532         # apache2
533         if [ -d %{_apache2dir}/httpd.conf ]; then
534                 rm -f %{_apache2dir}/httpd.conf/99_%{name}.conf
535                 if [ -f /var/lock/subsys/httpd ]; then
536                         /etc/rc.d/init.d/httpd restart 1>&2
537                 fi
538         fi
539 fi
540
541 %post setup
542 chmod 660 %{_sysconfdir}/{config,private_key}.php
543 chown root:http %{_sysconfdir}/{config,private_key}.php
544
545 %postun setup
546 if [ "$1" = "0" ]; then
547         chmod 640 %{_sysconfdir}/{config,private_key}.php
548         chown root:http %{_sysconfdir}/{config,private_key}.php
549 fi
550
551 %files
552 %defattr(644,root,root,755)
553 %doc ChangeLog FAQ INSTALL README UPGRADE
554 %doc misc/upgrade docs/* rpc/xmlrpc_client.php setup/schema.sql 
555 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
556 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
557 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/private_key.php
558 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/setup.php
559
560 %dir %{_appdir}
561 %dir %{_appdir}/misc
562
563 %dir %attr(731,root,http) /var/log/%{name}
564 %attr(620,root,http) %ghost /var/log/%{name}/*
565
566 %{_appdir}/*.php
567 %{_appdir}/css
568 %{_appdir}/customer
569 %{_appdir}/images
570 %{_appdir}/js
571 %{_appdir}/manage
572 %{_appdir}/reports
573 %{_appdir}/rpc
574 %{_appdir}/templates
575
576 %if %{with pear}
577 %{_smartyplugindir}/*
578 %else
579 %{_appdir}/include/pear
580 %{_appdir}/include/Smarty
581 %endif
582
583 %dir %{_appdir}/include
584 %{_appdir}/include/customer
585 %{_appdir}/include/jpgraph
586 %{_appdir}/include/workflow
587 %{_appdir}/include/*.php
588
589 %dir %attr(730,root,http) /var/run/%{name}
590 %dir %attr(730,root,http) /var/cache/%{name}
591
592 %{_appdir}/misc/blank.html
593
594 %files base
595 %defattr(644,root,root,755)
596 %attr(751,root,root) %dir %{_sysconfdir}
597 %dir %{_libdir}
598
599 %files setup
600 %defattr(644,root,root,755)
601 %{_appdir}/setup
602
603 %files mail-queue
604 %defattr(644,root,root,755)
605 %{_appdir}/misc/process_mail_queue.php
606 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
607
608 %files mail-download
609 %defattr(644,root,root,755)
610 %{_appdir}/misc/download_emails.php
611 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
612
613 %files reminder
614 %defattr(644,root,root,755)
615 %{_appdir}/misc/check_reminders.php
616 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
617
618 %files monitor
619 %defattr(644,root,root,755)
620 %{_appdir}/misc/monitor.php
621 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
622
623 %files route-emails
624 %defattr(644,root,root,755)
625 %{_appdir}/misc/route_emails.php
626
627 %files route-notes
628 %defattr(644,root,root,755)
629 %{_appdir}/misc/route_drafts.php
630 %{_appdir}/misc/route_notes.php
631
632 %files irc
633 %defattr(644,root,root,755)
634 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
635 %{_appdir}/misc/irc
636 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
637
638 %files cli
639 %defattr(644,root,root,755)
640 %doc eventumrc
641 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cli.php
642 %attr(755,root,root) %{_bindir}/%{name}
643 %dir %{_appdir}/misc/cli
644 %{_appdir}/misc/cli/include
645
646 %files scm
647 %defattr(644,root,root,755)
648 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
649 %attr(755,root,root) %{_libdir}/scm
This page took 0.066753 seconds and 4 git commands to generate.