]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
use bzr snapshot @4591
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 #
9 # Conditional build:
10 %bcond_without  order   # with experimental order patch
11
12 %define         php_min_version 5.1.2
13 %define         subver  4591
14 %define         rel             2.11
15 %include        /usr/lib/rpm/macros.php
16 Summary:        Eventum Issue / Bug tracking system
17 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
18 Name:           eventum
19 Version:        2.3.3
20 #Release:       %{rel}
21 Release:        %{rel}.bzr%{subver}
22 License:        GPL
23 Group:          Applications/WWW
24 #Source0:       http://launchpad.net/eventum/trunk/%{version}/+download/%{name}-%{version}.tar.gz
25 Source0:        %{name}-%{version}-dev-r%{subver}.tar.gz
26 # Source0-md5:  a98dd5ba8dfdb654b3a39314d13eef85
27 #Source0:       %{name}-%{version}%{subver}.tar.gz
28 Source1:        %{name}-apache.conf
29 Source2:        %{name}-mail-queue.cron
30 Source3:        %{name}-mail-download.cron
31 Source4:        %{name}-reminder.cron
32 Source5:        %{name}-monitor.cron
33 Source6:        %{name}-cvs.php
34 Source7:        %{name}-irc.php
35 Source8:        %{name}-irc.init
36 Source9:        %{name}-irc.sysconfig
37 Source10:       sphinx.crontab
38 Source13:       %{name}-router-postfix.sh
39 Source14:       %{name}.logrotate
40 Source15:       %{name}-lighttpd.conf
41 Source16:       http://www.isocra.com/images/updown2.gif
42 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
43 Source17:       %{name}.tmpfiles
44 Patch0:         %{name}-lf.patch
45 Patch2:         %{name}-order.patch
46 Patch3:         group-users.patch
47 Patch4:         https://github.com/glensc/eventum/compare/cf_escape.patch
48 # Patch4-md5:   d3d7865b785ebe3b05b18e2005cf843c
49 Patch5:         https://github.com/glensc/eventum/compare/ttc_project.patch
50 # Patch5-md5:   83e1bead35a2b6778e912d17fdafba20
51 Patch6:         https://github.com/glensc/eventum/compare/master...deprecation.patch
52 # Patch6-md5:   8595e27df27a8f254ad3761c59930b26
53 # packaging patches that probably never go upstream
54 Patch100:       %{name}-paths.patch
55 Patch101:       %{name}-cvs-config.patch
56 Patch105:       %{name}-bot-reconnect.patch
57 Patch107:       %{name}-gettext.patch
58 # some tests
59 Patch200:       %{name}-fixed-nav.patch
60 URL:            http://eventum.mysql.org/
61 BuildRequires:  gettext-devel
62 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
63 BuildRequires:  rpmbuild(macros) >= 1.461
64 BuildRequires:  sed >= 4.0
65 Requires:       %{name}-base = %{version}-%{release}
66 Requires:       Smarty >= 2.6.10-4
67 Requires:       php(core) >= %{php_min_version}
68 Requires:       php-filter
69 Requires:       php-gd
70 Requires:       php-iconv
71 Requires:       php-imap
72 Requires:       php-json
73 Requires:       php-mbstring
74 Requires:       php-mysql
75 Requires:       php-pcre
76 Requires:       php-pear-DB
77 Requires:       php-pear-Date
78 Requires:       php-pear-Mail
79 Requires:       php-pear-Mail_Mime
80 Requires:       php-pear-Mail_mimeDecode
81 Requires:       php-pear-Math_Stats
82 Requires:       php-pear-Net_DIME
83 Requires:       php-pear-Net_SMTP
84 Requires:       php-pear-Net_Socket
85 Requires:       php-pear-Net_URL
86 Requires:       php-pear-Net_UserAgent_Detect
87 Requires:       php-pear-PEAR-core
88 Requires:       php-pear-Text_Diff
89 Requires:       php-pear-XML_RPC
90 Requires:       php-session
91 Requires:       smarty-gettext
92 Requires:       webapps
93 Requires:       webserver(access)
94 Requires:       webserver(alias)
95 Requires:       webserver(indexfile)
96 Requires:       webserver(php) >= 4.2.0
97 Suggests:       localedb
98 Suggests:       php-pear-Net_LDAP2
99 Conflicts:      logrotate < 3.8.0
100 BuildArch:      noarch
101 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
102
103 %define         _noautopear     pear(../init.php) pear(init.php) pear(/usr/share/eventum/init.php) pear(/etc/webapps/.*) pear(%{_appdir}/.*) pear(jpgraph_dir.php) pear(.*Smarty.class.php) pear(Services/JSON.php) pear(class.date_helper.php) pear(sphinxapi.php) pear(Net/LDAP2.php)
104
105 # exclude optional php dependencies
106 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
107
108 %define         _noautoreq      %{_noautophp} %{_noautopear}
109
110 %define         _libdir         %{_prefix}/lib/%{name}
111 %define         _appdir         %{_datadir}/%{name}
112 %define         _smartydir      %{php_data_dir}/Smarty
113 %define         _webapps        /etc/webapps
114 %define         _webapp         %{name}
115 %define         _webappdir      %{_webapps}/%{_webapp}
116 %define         _sysconfdir     /etc/%{name}
117
118 %description
119 Eventum is a user-friendly and flexible issue tracking system that can
120 be used by a support department to track incoming technical support
121 requests, or by a software development team to quickly organize tasks
122 and bugs. Eventum is used by the MySQL AB Technical Support team, and
123 has allowed us to dramatically improve our response times.
124
125 %description -l pl.UTF-8
126 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
127 może być używany przez dział obsługi do śledzenia przychodzących żądań
128 obsługi technicznej albo przez zespół tworzący oprogramowanie do
129 szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
130 Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
131 reakcji.
132
133 %package base
134 Summary:        Eventum base package
135 Summary(pl.UTF-8):      Podstawowy pakiet Eventum
136 Group:          Applications/WWW
137 Requires(postun):       /usr/sbin/groupdel
138 Requires(postun):       /usr/sbin/userdel
139 Requires(pre):  /bin/id
140 Requires(pre):  /usr/bin/getgid
141 Requires(pre):  /usr/sbin/groupadd
142 Requires(pre):  /usr/sbin/useradd
143 Provides:       group(eventum)
144 Provides:       user(eventum)
145
146 %description base
147 This package contains base directory structure for Eventum.
148
149 %description base -l pl.UTF-8
150 Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
151
152 %package setup
153 Summary:        Eventum setup package
154 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
155 Group:          Applications/WWW
156 Requires:       %{name} = %{version}-%{release}
157
158 %description setup
159 Install this package to configure initial Eventum installation. You
160 should uninstall this package when you're done, as it considered
161 insecure to keep the setup files in place.
162
163 %description setup -l pl.UTF-8
164 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
165 pierwszej instalacji. Potem należy go odinstalować, jako że
166 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
167
168 %package mail-queue
169 Summary:        Eventum mail queue process
170 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
171 Group:          Applications/WWW
172 Requires:       %{name} = %{version}-%{release}
173 Requires:       crondaemon
174
175 %description mail-queue
176 Beginning with the first release of Eventum, emails are not directly
177 sent out from the various scripts, but rather added to a mail queue
178 table that is processed by a cron job. If an email cannot be sent, it
179 will be marked as such in the mail queue log, and the cron job script
180 will re-try to send it again the next time it runs.
181
182 This package contains the cron job.
183
184 %description mail-queue -l pl.UTF-8
185 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
186 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
187 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
188 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
189 następnym razem.
190
191 Ten pakiet zawiera zadanie dla crona.
192
193 %package mail-download
194 Summary:        Eventum email download
195 Summary(pl.UTF-8):      Ściąganie poczty Eventum
196 Group:          Applications/WWW
197 Requires:       %{name} = %{version}-%{release}
198 Requires:       crondaemon
199
200 %description mail-download
201 In order for Eventum's email integration feature to work, you need to
202 setup a cron job to run the script every so often.
203
204 This package contains the cron job.
205
206 %description mail-download -l pl.UTF-8
207 Aby integracja poczty elektronicznej w Eventum działała, trzeba
208 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
209 często.
210
211 Ten pakiet zawiera zadanie dla crona.
212
213 %package reminder
214 Summary:        Eventum Reminder System
215 Summary(pl.UTF-8):      System przypominania dla Eventum
216 Group:          Applications/WWW
217 Requires:       %{name} = %{version}-%{release}
218 Requires:       crondaemon
219
220 %description reminder
221 The reminder system was designed with the objective as serving as a
222 safe net for issues that need attention. Depending on what
223 configuration you create, you may have several reminders (or alerts)
224 be sent out whenever an issue needs attention, for whatever parameter
225 you may deem necessary.
226
227 This package contains the cron job.
228
229 %description reminder -l pl.UTF-8
230 System przypominania został zaprojektowany tak, aby służył jako
231 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
232 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
233 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
234 uważać za potrzebny.
235
236 Ten pakiet zawiera zadanie dla crona.
237
238 %package monitor
239 Summary:        Eventum Heartbeat Monitor
240 Summary(pl.UTF-8):      Monitor życia dla Eventum
241 Group:          Applications/WWW
242 Requires:       %{name} = %{version}-%{release}
243 Requires:       crondaemon
244 Requires:       php-posix
245
246 %description monitor
247 The heartbeat monitor is a feature designed for the administrator that
248 wants to be alerted whenever a common problem in Eventum is detected,
249 like the database server not being available anymore, or maybe when
250 the recommended permissions for certain configuration files are
251 changed.
252
253 Please note that before running the heartbeat monitor, you may need to
254 customize some of the checks to be appropriate for your own system,
255 particularly the permission and file checks on
256 Monitor::checkConfiguration().
257
258 This package contains the cron job.
259
260 %description monitor -l pl.UTF-8
261 Monitor życia to funkcjonalność zaprojektowana dla administratora
262 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
263 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
264 do plików konfiguracyjnych.
265
266 Należy zauważyć, że przed uruchomieniem tego monitora może być
267 konieczne dostosowanie niektórych testów do systemu, w szczególności
268 testów uprawnień i plików w Monitor::checkConfiguration().
269
270 Ten pakiet zawiera zadanie dla crona.
271
272 %package route-drafts
273 Summary:        Eventum Draft Routing
274 Summary(pl.UTF-8):      Przekazywanie szkiców dla Eventum
275 Group:          Applications/WWW
276 Requires:       %{name} = %{version}-%{release}
277 Requires:       eventum(router)
278
279 %description route-drafts
280 The draft routing feature is used to automatically associate a thread
281 of drafts into an Eventum issue. By setting up Postfix to deliver
282 emails sent to a specific address (usually draft-<number>@<domain>) to
283 the above script, users are able to send drafts written in their mail
284 client to be stored in Eventum. These drafts will NOT broadcasted to
285 the notification list.
286
287 %description route-drafts -l pl.UTF-8
288 Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
289 problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
290 wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
291 skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
292 kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
293 na listę powiadomień.
294
295 %package route-emails
296 Summary:        Eventum Email Routing
297 Summary(pl.UTF-8):      Przekazywanie poczty dla Eventum
298 Group:          Applications/WWW
299 Requires:       %{name} = %{version}-%{release}
300 Requires:       eventum(router)
301
302 %description route-emails
303 The email routing feature is used to automatically associate a thread
304 of emails into an Eventum issue. By setting up Postfix to deliver
305 emails sent to a specific address (usually issue-<number>@<domain>) to
306 the above script, users are able to use their email clients to reply
307 to emails coming from Eventum, and those replies will be automatically
308 associated with the issue and broadcasted to the entire notification
309 list.
310
311 %description route-emails -l pl.UTF-8
312 Funkcjonalność przekazywania poczty służy do automatycznego wiązania
313 wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
314 aby dostarczał listy wysyłane na pewien adres (zwykle
315 issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
316 używać klientów pocztowych do odpowiadania na listy przychodzące z
317 Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
318 rozprowadzane do całej listy ogłoszeniowej.
319
320 %package route-notes
321 Summary:        Eventum Note Routing
322 Summary(pl.UTF-8):      Przekazywanie notatek dla Eventum
323 Group:          Applications/WWW
324 Requires:       %{name} = %{version}-%{release}
325 Requires:       eventum(router)
326
327 %description route-notes
328 The note routing feature is used to automatically associate a thread
329 of notes into an Eventum issue. By setting up Postfix to deliver
330 emails sent to a specific address (usually note-<number>@<domain>) to
331 the above script, users are able to use their email clients to reply
332 to internal notes coming from Eventum, and those replies will be
333 automatically associated with the issue and broadcasted to the
334 notification list staff members.
335
336 %description route-notes -l pl.UTF-8
337 Funkcjonalność przekazywania notatek służy do automatycznego wiązania
338 wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
339 dostarczał listy wysyłane na pewien adres (zwykle
340 note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
341 używać klientów pocztowych do odpowiadania na wewnętrzne notatki
342 pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
343 sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
344
345 %package router-postfix
346 Summary:        Eventum Mail Routing - Postfix
347 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
348 Group:          Applications/Mail
349 Requires:       %{name} = %{version}-%{release}
350 Requires:       postfix
351 Provides:       eventum(router)
352 Obsoletes:      eventum(router)
353
354 %description router-postfix
355 This package provides way of routing notes and emails back to Eventum
356 via Postfix.
357
358 The Postfix configuration instructions you can find from
359 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
360
361 %description router-postfix -l pl.UTF-8
362 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
363 przez Postfiksa.
364
365 Opis konfiguracji Postfiksa można znaleźć pod adresem
366 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
367
368 %package irc
369 Summary:        Eventum IRC Notification Bot
370 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
371 Group:          Applications/WWW
372 Requires(post,preun):   /sbin/chkconfig
373 Requires:       %{name} = %{version}-%{release}
374 Requires:       php-pear-Net_SmartIRC
375 Requires:       php-sockets
376 Requires:       rc-scripts >= 0.4.0.18
377
378 %description irc
379 The IRC notification bot is a nice feature for remote teams that want
380 to handle issues and want to have a quick and easy way to get simple
381 notifications. Right now the bot notifies of the following actions:
382 - New Issues
383 - Blocked emails
384 - Issues that got their assignment list changed
385
386 NOTE: You will need to manually edit the bot.php script to set your
387 appropriate preferences, like IRC server and channel that the bot
388 should join.
389
390 %description irc -l pl.UTF-8
391 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
392 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
393 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
394 następujących zdarzeniach:
395 - nowych sprawach
396 - zablokowanych listach
397 - sprawach, dla których zmieniła się lista powiązań
398
399 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
400 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
401
402 %package cli
403 Summary:        Eventum command-line interface
404 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
405 Group:          Applications/WWW
406 Requires:       %{name}-base = %{version}-%{release}
407 Requires:       php(core) >= %{php_min_version}
408 Requires:       php-cli
409 Requires:       php-pear-XML_RPC
410
411 %description cli
412 The Eventum command-line interface allows you to access most of the
413 features of the web interface straight from your command shell.
414
415 %description cli -l pl.UTF-8
416 Interfejs linii poleceń Eventum pozwala na dostęp do większości
417 funkcji interfejsu WWW prosto z linii poleceń powłoki.
418
419 %package scm
420 Summary:        Eventum SCM integration
421 Summary(pl.UTF-8):      Integracja SCM dla Eventum
422 Group:          Applications/WWW
423 Requires:       %{name}-base = %{version}-%{release}
424 Requires:       php(core) >= %{php_min_version}
425 Requires:       php-cli
426 Requires:       php-pcre
427
428 %description scm
429 This feature allows your software development teams to integrate your
430 Source Control Management system with your Issue Tracking System.
431
432 The integration is implemented in such a way that it will be forward
433 compatible with pretty much any SCM system, such as CVS.
434
435 For installation see
436 </eventum/help.php?topic=scm_integration_installation>.
437
438 %description scm -l pl.UTF-8
439 Ten pakiet pozwala zespołom programistów na integrację systemu
440 zarządzania źródłami (SCM - Source Control Management) z systemem
441 śledzenia spraw.
442
443 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
444 prawie każdym systemem SCM, jak np. CVS.
445
446 Szczegóły na temat instalacji można przeczytać pod
447 </eventum/help.php?topic=scm_integration_installation>.
448
449 %package sphinx
450 Summary:        Eventum Sphinx Search
451 Group:          Applications/WWW
452 Requires:       %{name} = %{version}-%{release}
453 Requires:       crondaemon
454 Requires:       sphinx
455
456 %description sphinx
457 Sphinx search integration for Eventum.
458
459 This package contains the cron job.
460
461 %prep
462 %setup -q
463
464 # GPL v2
465 rm docs/COPYING
466
467 rm -r upgrade/*v1.[123]* # too old to support in PLD Linux
468 rm -r upgrade/v{1.,2.0,2.1_}* # no longer supported in PLD Linux
469 rm upgrade/flush_compiled_templates.php
470 rm -r upgrade/{*/,}index.html # not needed in PLD Linux
471
472 # bug fixes / features
473 %patch0 -p1
474 %{?with_order:%patch2 -p1}
475 %patch3 -p0
476 %patch4 -p1
477 %patch5 -p1
478 %patch6 -p1
479
480 cp -p %{SOURCE16} htdocs/images
481
482 #%patch200 -p1
483
484 # produce default sphinx config
485 # must be run before paths.patch
486 cat <<'EOF' > config/config.php
487 <?php
488 define('APP_SQL_DBTYPE', 'mysql');
489 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
490 define('APP_SQL_DBPORT', 3306);
491 define('APP_SQL_DBNAME', 'eventum');
492 define('APP_SQL_DBUSER', 'mysql');
493 define('APP_SQL_DBPASS', '');
494 define('APP_TABLE_PREFIX', 'eventum_');
495 EOF
496 php config/sphinx.conf.php > config/sphinx.conf
497 rm -f config/config.php
498
499 # packaging
500 %patch100 -p1
501 %patch101 -p1
502 %patch105 -p1
503 %patch107 -p1
504
505 %{__sed} -i -e "
506 s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
507 " upgrade/{*/,}*.php
508
509 # remove backups from patching as we use globs to package files to buildroot
510 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
511
512 %build
513 %{__make} -C localization
514
515 %install
516 rm -rf $RPM_BUILD_ROOT
517 install -d \
518         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
519         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
520         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
521         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
522         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
523         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
524         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
525
526 %{__make} install-eventum install-cli install-irc install-scm install-jpgraph install-localization \
527         sysconfdir=%{_webappdir} \
528         DESTDIR=$RPM_BUILD_ROOT
529
530 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
531
532 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
533 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
534 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
535 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
536
537 install -d $RPM_BUILD_ROOT/etc/sphinx
538 cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
539 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
540
541 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
542 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
543 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
544 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
545 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
546
547 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
548
549 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
550 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
551
552 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
553
554 # postfix router
555 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
556
557 install %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
558
559 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
560
561 %find_lang %{name}
562
563 # scm
564 install -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
565
566 # old compat
567 ln -s %{_sbindir}/eventum-cvs-hook $RPM_BUILD_ROOT%{_libdir}/process_cvs_commits
568 ln -s %{_sbindir}/eventum-svn-hook $RPM_BUILD_ROOT%{_libdir}/process_svn_commits
569
570 # skip pear for cli
571 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
572 cp -a cli/lib/eventum $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
573
574 %clean
575 rm -rf $RPM_BUILD_ROOT
576
577 %pre
578 %addusertogroup http %{name}
579
580 %post
581 # greate empty ghost files
582 for a in cli.log errors.log irc_bot.log login_attempts.log; do
583         if [ ! -f /var/log/%{name}/$a ]; then
584                 install -m 0620 -o root -g eventum /dev/null /var/log/%{name}/$a
585         fi
586 done
587
588 # database update
589 %{_appdir}/upgrade/update-database.php || :
590
591 # nuke Smarty templates cache after upgrade
592 rm -f /var/cache/eventum/*.php
593
594 # Restart webserver on upgrade to get .mo translations reloaded.
595 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
596 %php_webserver_restart
597
598 %preun
599 if [ "$1" = "0" ]; then
600         # nuke cache
601         rm -f /var/cache/eventum/*.php 2>/dev/null || :
602 fi
603
604 %pre base
605 %groupadd -P %{name}-base -g 146 %{name}
606 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
607
608 %postun base
609 if [ "$1" = "0" ]; then
610         %userremove %{name}
611         %groupremove %{name}
612 fi
613
614 %post setup
615 chmod 660 %{_webappdir}/{config,private_key}.php
616 chown root:http %{_webappdir}/{config,private_key}.php
617
618 %postun setup
619 if [ "$1" = "0" ]; then
620         chmod 640 %{_webappdir}/{config,private_key}.php
621         chown root:http %{_webappdir}/{config,private_key}.php
622 fi
623
624 %post irc
625 /sbin/chkconfig --add eventum-irc
626 %service eventum-irc restart "Eventum IRC Bot"
627
628 %preun irc
629 if [ "$1" = 0 ]; then
630         %service eventum-irc stop
631         /sbin/chkconfig --del eventum-irc
632 fi
633
634 %triggerin -- apache1 < 1.3.37-3, apache1-base
635 %webapp_register apache %{_webapp}
636
637 %triggerun -- apache1 < 1.3.37-3, apache1-base
638 %webapp_unregister apache %{_webapp}
639
640 %triggerin -- apache < 2.2.0, apache-base
641 %webapp_register httpd %{_webapp}
642
643 %triggerun -- apache < 2.2.0, apache-base
644 %webapp_unregister httpd %{_webapp}
645
646 %triggerin -- lighttpd
647 %webapp_register lighttpd %{_webapp}
648
649 %triggerun -- lighttpd
650 %webapp_unregister lighttpd %{_webapp}
651
652 %triggerpostun -- %{name} < 2.2-2.57
653 # switching eventum->http user
654 chgrp http %{_webappdir}/config.php
655 chgrp http %{_webappdir}/private_key.php
656 chgrp http %{_webappdir}/setup.php
657 chgrp http /var/log/%{name}/*
658 # update crontab user
659 for a in /etc/cron.d/eventum-*; do
660         [ -f "$a" ] || continue
661         awk '!/#/ && NR > 6 && $6 =="eventum" {sub("eventum", "http", $6)}{print}'  $a > $a.rpmtmp && cat $a.rpmtmp > $a
662         rm -f $a.rpmtmp
663
664         # crontabs moved to crons subdir
665         %{__sed} -i -e '
666                 s,/usr/share/eventum/process_mail_queue.php,/usr/share/eventum/crons/process_mail_queue.php,
667                 s,/usr/share/eventum/download_emails.php,/usr/share/eventum/crons/download_emails.php,
668                 s,/usr/share/eventum/check_reminders.php,/usr/share/eventum/crons/check_reminders.php,
669                 s,/usr/share/eventum/monitor.php,/usr/share/eventum/crons/monitor.php,
670         ' $a
671 done
672
673 %files -f %{name}.lang
674 %defattr(644,root,root,755)
675 %doc docs/* htdocs/setup/schema.sql
676 %attr(751,root,root) %dir %{_webappdir}
677 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
678 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
679 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
680 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
681 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
682 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
683 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
684
685 %dir %attr(731,root,http) /var/log/%{name}
686 %attr(620,root,http) %ghost /var/log/%{name}/*
687 %dir %attr(750,root,root) /var/log/archive/%{name}
688 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
689
690 %dir %{_appdir}/crons
691 %{_appdir}/init.php
692 %dir %{_appdir}/htdocs
693 %{_appdir}/htdocs/*.php
694 %{_appdir}/htdocs/*.ico
695 %{_appdir}/htdocs/css
696 %{_appdir}/htdocs/customer
697 %{_appdir}/htdocs/images
698 %{_appdir}/htdocs/js
699 %{_appdir}/htdocs/manage
700 %{_appdir}/htdocs/reports
701 %{_appdir}/htdocs/rpc
702 %{_appdir}/htdocs/misc
703 %if %{with order}
704 %{_appdir}/htdocs/ajax
705 %endif
706 %{_appdir}/templates
707
708 %dir %{_appdir}/upgrade
709 %{_appdir}/upgrade/init.php
710 %attr(755,root,root) %{_appdir}/upgrade/update-database.php
711 %attr(755,root,root) %{_appdir}/upgrade/ldap_import.php
712 %dir %{_appdir}/upgrade/v*
713 %attr(755,root,root) %{_appdir}/upgrade/v*/*.php
714 %{_appdir}/upgrade/patches
715
716 %dir %{_appdir}/lib
717 %{_appdir}/lib/eventum
718 %{_appdir}/lib/jpgraph
719 %exclude %{_appdir}/lib/eventum/class.monitor.php
720 %{systemdtmpfilesdir}/%{name}.conf
721 %dir %attr(730,root,http) /var/run/%{name}
722 %dir %attr(730,root,http) /var/cache/%{name}
723
724 %files base
725 %defattr(644,root,root,755)
726 %attr(751,root,root) %dir %{_sysconfdir}
727 %dir %{_libdir}
728 %dir %{_appdir}
729 %dir /var/lib/%{name}
730 # saved mail copies
731 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
732 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
733 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
734
735 %files setup
736 %defattr(644,root,root,755)
737 %{_appdir}/htdocs/setup
738
739 %files mail-queue
740 %defattr(644,root,root,755)
741 %attr(755,root,root) %{_appdir}/crons/process_mail_queue.php
742 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
743
744 %files mail-download
745 %defattr(644,root,root,755)
746 %attr(755,root,root) %{_appdir}/crons/download_emails.php
747 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
748
749 %files reminder
750 %defattr(644,root,root,755)
751 %attr(755,root,root) %{_appdir}/crons/check_reminders.php
752 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
753
754 %files monitor
755 %defattr(644,root,root,755)
756 %{_appdir}/lib/eventum/class.monitor.php
757 %attr(755,root,root) %{_appdir}/crons/monitor.php
758 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
759
760 %files route-drafts
761 %defattr(644,root,root,755)
762 %attr(755,root,root) %{_appdir}/route_drafts.php
763
764 %files route-emails
765 %defattr(644,root,root,755)
766 %attr(755,root,root) %{_appdir}/route_emails.php
767
768 %files route-notes
769 %defattr(644,root,root,755)
770 %attr(755,root,root) %{_appdir}/route_notes.php
771
772 %files router-postfix
773 %defattr(644,root,root,755)
774 %attr(755,root,root) %{_libdir}/router-postfix
775
776 %files irc
777 %defattr(644,root,root,755)
778 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
779 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
780 %attr(755,root,root) %{_sbindir}/%{name}-irc-bot
781 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
782
783 %files cli
784 %defattr(644,root,root,755)
785 %doc cli/eventumrc
786 %attr(755,root,root) %{_bindir}/%{name}
787 %{_appdir}/cli
788
789 %files scm
790 %defattr(644,root,root,755)
791 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
792 %attr(755,root,root) %{_libdir}/process_cvs_commits
793 %attr(755,root,root) %{_libdir}/process_svn_commits
794 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
795 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
796
797 %files sphinx
798 %defattr(644,root,root,755)
799 %{_webappdir}/sphinx.conf.php
800 %attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
801 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.110635 seconds and 4 git commands to generate.