]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
up to 3.0.3-296-gb988181, use upstream irc config as default
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1.10
6 %define         subver  296
7 %define         githash b988181
8 %define         php_min_version 5.3.3
9 %include        /usr/lib/rpm/macros.php
10 Summary:        Eventum Issue / Bug tracking system
11 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
12 Name:           eventum
13 Version:        3.0.3
14 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
15 License:        GPL v2
16 Group:          Applications/WWW
17 #Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
18 Source0:        %{name}-%{version}-%{subver}-g%{githash}.tar.gz
19 # Source0-md5:  78e9b382584b8d8928dca55be7992e59
20 Source1:        %{name}-apache.conf
21 Source2:        %{name}-mail-queue.cron
22 Source3:        %{name}-mail-download.cron
23 Source4:        %{name}-reminder.cron
24 Source5:        %{name}-monitor.cron
25 Source6:        %{name}-cvs.php
26 Source8:        %{name}-irc.init
27 Source9:        %{name}-irc.sysconfig
28 Source10:       sphinx.crontab
29 Source13:       %{name}-router-postfix.sh
30 Source14:       %{name}.logrotate
31 Source15:       %{name}-lighttpd.conf
32 Source16:       http://www.isocra.com/images/updown2.gif
33 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
34 Source17:       %{name}.tmpfiles
35 Patch2:         %{name}-order.patch
36 #Patch3:                group-users.patch
37 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
38 # packaging patches that probably never go upstream
39 Patch100:       %{name}-paths.patch
40 Patch101:       %{name}-cvs-config.patch
41 Patch107:       %{name}-gettext.patch
42 Patch108:       autoload.patch
43 # some tests
44 Patch200:       %{name}-fixed-nav.patch
45 URL:            http://eventum.mysql.org/
46 BuildRequires:  /usr/bin/php
47 BuildRequires:  gettext-devel
48 BuildRequires:  php(core) >= %{php_min_version}
49 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
50 BuildRequires:  rpmbuild(macros) >= 1.654
51 BuildRequires:  sed >= 4.0
52 Requires:       %{name}-base = %{version}-%{release}
53 Requires:       fonts-TTF-RedHat-liberation
54 Requires:       php(core) >= %{php_min_version}
55 Requires:       php(filter)
56 Requires:       php(iconv)
57 Requires:       php(imap)
58 Requires:       php(json)
59 Requires:       php(mbstring)
60 Requires:       php(mysqli)
61 Requires:       php(pcre)
62 Requires:       php(session)
63 Requires:       php-Smarty >= 3.1
64 Requires:       php-Smarty-plugin-gettext
65 Requires:       php-pear-DB
66 Requires:       php-pear-Mail
67 Requires:       php-pear-Mail_Mime
68 Requires:       php-pear-Mail_mimeDecode
69 Requires:       php-pear-Math_Stats
70 Requires:       php-pear-Net_DIME
71 Requires:       php-pear-Net_SMTP
72 Requires:       php-pear-Net_Socket
73 Requires:       php-pear-Net_URL
74 Requires:       php-pear-Net_UserAgent_Detect
75 Requires:       php-pear-PEAR-core
76 Requires:       php-pear-Text_Diff
77 Requires:       php-pear-XML_RPC
78 Requires:       phplot >= 5.8.0
79 Requires:       webapps
80 Requires:       webserver(access)
81 Requires:       webserver(alias)
82 Requires:       webserver(indexfile)
83 Requires:       webserver(php) >= 4.2.0
84 Suggests:       localedb
85 Suggests:       php-pear-Net_LDAP2
86 Conflicts:      logrotate < 3.8.0
87 BuildArch:      noarch
88 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
89
90 %define         _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
91
92 # exclude optional php dependencies
93 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
94
95 %define         _noautoreq      %{_noautophp}
96
97 %define         _libdir         %{_prefix}/lib/%{name}
98 %define         _appdir         %{_datadir}/%{name}
99 %define         _smartydir      %{php_data_dir}/Smarty
100 %define         _webapps        /etc/webapps
101 %define         _webapp         %{name}
102 %define         _webappdir      %{_webapps}/%{_webapp}
103 %define         _sysconfdir     /etc/%{name}
104
105 %description
106 Eventum is a user-friendly and flexible issue tracking system that can
107 be used by a support department to track incoming technical support
108 requests, or by a software development team to quickly organize tasks
109 and bugs. Eventum is used by the MySQL AB Technical Support team, and
110 has allowed us to dramatically improve our response times.
111
112 %description -l pl.UTF-8
113 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
114 może być używany przez dział obsługi do śledzenia przychodzących żądań
115 obsługi technicznej albo przez zespół tworzący oprogramowanie do
116 szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
117 Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
118 reakcji.
119
120 %package base
121 Summary:        Eventum base package
122 Summary(pl.UTF-8):      Podstawowy pakiet Eventum
123 Group:          Applications/WWW
124 Requires(postun):       /usr/sbin/groupdel
125 Requires(postun):       /usr/sbin/userdel
126 Requires(pre):  /bin/id
127 Requires(pre):  /usr/bin/getgid
128 Requires(pre):  /usr/sbin/groupadd
129 Requires(pre):  /usr/sbin/useradd
130 Provides:       group(eventum)
131 Provides:       user(eventum)
132
133 %description base
134 This package contains base directory structure for Eventum.
135
136 %description base -l pl.UTF-8
137 Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
138
139 %package setup
140 Summary:        Eventum setup package
141 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
142 Group:          Applications/WWW
143 Requires:       %{name} = %{version}-%{release}
144
145 %description setup
146 Install this package to configure initial Eventum installation. You
147 should uninstall this package when you're done, as it considered
148 insecure to keep the setup files in place.
149
150 %description setup -l pl.UTF-8
151 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
152 pierwszej instalacji. Potem należy go odinstalować, jako że
153 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
154
155 %package doc
156 Summary:        Eventum documentation and Wiki
157 Group:          Documentation
158
159 %description doc
160 Eventum documentation and copy of Wiki.
161
162 %package mail-queue
163 Summary:        Eventum mail queue process
164 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
165 Group:          Applications/WWW
166 Requires:       %{name} = %{version}-%{release}
167 Requires:       crondaemon
168
169 %description mail-queue
170 Beginning with the first release of Eventum, emails are not directly
171 sent out from the various scripts, but rather added to a mail queue
172 table that is processed by a cron job. If an email cannot be sent, it
173 will be marked as such in the mail queue log, and the cron job script
174 will re-try to send it again the next time it runs.
175
176 This package contains the cron job.
177
178 %description mail-queue -l pl.UTF-8
179 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
180 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
181 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
182 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
183 następnym razem.
184
185 Ten pakiet zawiera zadanie dla crona.
186
187 %package mail-download
188 Summary:        Eventum email download
189 Summary(pl.UTF-8):      Ściąganie poczty Eventum
190 Group:          Applications/WWW
191 Requires:       %{name} = %{version}-%{release}
192 Requires:       crondaemon
193
194 %description mail-download
195 In order for Eventum's email integration feature to work, you need to
196 setup a cron job to run the script every so often.
197
198 This package contains the cron job.
199
200 %description mail-download -l pl.UTF-8
201 Aby integracja poczty elektronicznej w Eventum działała, trzeba
202 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
203 często.
204
205 Ten pakiet zawiera zadanie dla crona.
206
207 %package reminder
208 Summary:        Eventum Reminder System
209 Summary(pl.UTF-8):      System przypominania dla Eventum
210 Group:          Applications/WWW
211 Requires:       %{name} = %{version}-%{release}
212 Requires:       crondaemon
213
214 %description reminder
215 The reminder system was designed with the objective as serving as a
216 safe net for issues that need attention. Depending on what
217 configuration you create, you may have several reminders (or alerts)
218 be sent out whenever an issue needs attention, for whatever parameter
219 you may deem necessary.
220
221 This package contains the cron job.
222
223 %description reminder -l pl.UTF-8
224 System przypominania został zaprojektowany tak, aby służył jako
225 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
226 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
227 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
228 uważać za potrzebny.
229
230 Ten pakiet zawiera zadanie dla crona.
231
232 %package monitor
233 Summary:        Eventum Heartbeat Monitor
234 Summary(pl.UTF-8):      Monitor życia dla Eventum
235 Group:          Applications/WWW
236 Requires:       %{name} = %{version}-%{release}
237 Requires:       crondaemon
238 Requires:       php(posix)
239
240 %description monitor
241 The heartbeat monitor is a feature designed for the administrator that
242 wants to be alerted whenever a common problem in Eventum is detected,
243 like the database server not being available anymore, or maybe when
244 the recommended permissions for certain configuration files are
245 changed.
246
247 Please note that before running the heartbeat monitor, you may need to
248 customize some of the checks to be appropriate for your own system,
249 particularly the permission and file checks on
250 Monitor::checkConfiguration().
251
252 This package contains the cron job.
253
254 %description monitor -l pl.UTF-8
255 Monitor życia to funkcjonalność zaprojektowana dla administratora
256 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
257 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
258 do plików konfiguracyjnych.
259
260 Należy zauważyć, że przed uruchomieniem tego monitora może być
261 konieczne dostosowanie niektórych testów do systemu, w szczególności
262 testów uprawnień i plików w Monitor::checkConfiguration().
263
264 Ten pakiet zawiera zadanie dla crona.
265
266 %package route-drafts
267 Summary:        Eventum Draft Routing
268 Summary(pl.UTF-8):      Przekazywanie szkiców dla Eventum
269 Group:          Applications/WWW
270 Requires:       %{name} = %{version}-%{release}
271 Requires:       eventum(router)
272
273 %description route-drafts
274 The draft routing feature is used to automatically associate a thread
275 of drafts into an Eventum issue. By setting up Postfix to deliver
276 emails sent to a specific address (usually draft-<number>@<domain>) to
277 the above script, users are able to send drafts written in their mail
278 client to be stored in Eventum. These drafts will NOT broadcasted to
279 the notification list.
280
281 %description route-drafts -l pl.UTF-8
282 Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
283 problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
284 wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
285 skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
286 kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
287 na listę powiadomień.
288
289 %package route-emails
290 Summary:        Eventum Email Routing
291 Summary(pl.UTF-8):      Przekazywanie poczty dla Eventum
292 Group:          Applications/WWW
293 Requires:       %{name} = %{version}-%{release}
294 Requires:       eventum(router)
295
296 %description route-emails
297 The email routing feature is used to automatically associate a thread
298 of emails into an Eventum issue. By setting up Postfix to deliver
299 emails sent to a specific address (usually issue-<number>@<domain>) to
300 the above script, users are able to use their email clients to reply
301 to emails coming from Eventum, and those replies will be automatically
302 associated with the issue and broadcasted to the entire notification
303 list.
304
305 %description route-emails -l pl.UTF-8
306 Funkcjonalność przekazywania poczty służy do automatycznego wiązania
307 wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
308 aby dostarczał listy wysyłane na pewien adres (zwykle
309 issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
310 używać klientów pocztowych do odpowiadania na listy przychodzące z
311 Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
312 rozprowadzane do całej listy ogłoszeniowej.
313
314 %package route-notes
315 Summary:        Eventum Note Routing
316 Summary(pl.UTF-8):      Przekazywanie notatek dla Eventum
317 Group:          Applications/WWW
318 Requires:       %{name} = %{version}-%{release}
319 Requires:       eventum(router)
320
321 %description route-notes
322 The note routing feature is used to automatically associate a thread
323 of notes into an Eventum issue. By setting up Postfix to deliver
324 emails sent to a specific address (usually note-<number>@<domain>) to
325 the above script, users are able to use their email clients to reply
326 to internal notes coming from Eventum, and those replies will be
327 automatically associated with the issue and broadcasted to the
328 notification list staff members.
329
330 %description route-notes -l pl.UTF-8
331 Funkcjonalność przekazywania notatek służy do automatycznego wiązania
332 wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
333 dostarczał listy wysyłane na pewien adres (zwykle
334 note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
335 używać klientów pocztowych do odpowiadania na wewnętrzne notatki
336 pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
337 sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
338
339 %package router-postfix
340 Summary:        Eventum Mail Routing - Postfix
341 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
342 Group:          Applications/Mail
343 Requires:       %{name} = %{version}-%{release}
344 Requires:       postfix
345 Provides:       eventum(router)
346 Obsoletes:      eventum(router)
347
348 %description router-postfix
349 This package provides way of routing notes and emails back to Eventum
350 via Postfix.
351
352 The Postfix configuration instructions you can find from
353 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
354
355 %description router-postfix -l pl.UTF-8
356 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
357 przez Postfiksa.
358
359 Opis konfiguracji Postfiksa można znaleźć pod adresem
360 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
361
362 %package irc
363 Summary:        Eventum IRC Notification Bot
364 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
365 Group:          Applications/WWW
366 Requires(post,preun):   /sbin/chkconfig
367 Requires:       %{name} = %{version}-%{release}
368 Requires:       php(sockets)
369 Requires:       php-pear-Net_SmartIRC >= 1.1
370 Requires:       rc-scripts >= 0.4.0.18
371
372 %description irc
373 The IRC notification bot is a nice feature for remote teams that want
374 to handle issues and want to have a quick and easy way to get simple
375 notifications. Right now the bot notifies of the following actions:
376 - New Issues
377 - Blocked emails
378 - Issues that got their assignment list changed
379
380 NOTE: You will need to manually edit the bot.php script to set your
381 appropriate preferences, like IRC server and channel that the bot
382 should join.
383
384 %description irc -l pl.UTF-8
385 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
386 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
387 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
388 następujących zdarzeniach:
389 - nowych sprawach
390 - zablokowanych listach
391 - sprawach, dla których zmieniła się lista powiązań
392
393 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
394 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
395
396 %package cli
397 Summary:        Eventum command-line interface
398 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
399 Group:          Applications/WWW
400 Requires:       %{name}-base = %{version}-%{release}
401 Requires:       php(core) >= %{php_min_version}
402 Requires:       php(phar)
403 Requires:       php-pear-XML_RPC
404
405 %description cli
406 The Eventum command-line interface allows you to access most of the
407 features of the web interface straight from your command shell.
408
409 %description cli -l pl.UTF-8
410 Interfejs linii poleceń Eventum pozwala na dostęp do większości
411 funkcji interfejsu WWW prosto z linii poleceń powłoki.
412
413 %package scm
414 Summary:        Eventum SCM integration
415 Summary(pl.UTF-8):      Integracja SCM dla Eventum
416 Group:          Applications/WWW
417 Requires:       php(core) >= %{php_min_version}
418 Requires:       php(json)
419 Requires:       php(pcre)
420 Requires:       php(spl)
421 Suggests:       cvs
422 Suggests:       git-core
423 Suggests:       php(openssl)
424 Suggests:       subversion
425
426 %description scm
427 This feature allows your software development teams to integrate your
428 Source Control Management system with your Issue Tracking System.
429
430 The integration is implemented in such a way that it will be forward
431 compatible with pretty much any SCM system, such as CVS.
432
433 For installation see
434 </eventum/help.php?topic=scm_integration_installation>.
435
436 %description scm -l pl.UTF-8
437 Ten pakiet pozwala zespołom programistów na integrację systemu
438 zarządzania źródłami (SCM - Source Control Management) z systemem
439 śledzenia spraw.
440
441 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
442 prawie każdym systemem SCM, jak np. CVS.
443
444 Szczegóły na temat instalacji można przeczytać pod
445 </eventum/help.php?topic=scm_integration_installation>.
446
447 %package sphinx
448 Summary:        Eventum Sphinx Search
449 Group:          Applications/WWW
450 Requires:       %{name} = %{version}-%{release}
451 Requires:       crondaemon
452 Requires:       sphinx
453
454 %description sphinx
455 Sphinx search integration for Eventum.
456
457 This package contains the cron job.
458
459 %prep
460 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
461
462 mv docs/examples .
463
464 # GPL v2
465 rm docs/COPYING
466
467 # bug fixes / features
468 %{?with_order:%patch2 -p1}
469 #%patch3 -p0
470 #%patch4 -p1
471
472 %{?with_order:cp -p %{SOURCE16} htdocs/images}
473
474 #%patch200 -p1
475
476 # produce default sphinx config
477 # must be run before paths.patch
478 %if 0
479 cat <<'EOF' > config/config.php
480 <?php
481 define('APP_SQL_DBTYPE', 'mysql');
482 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
483 define('APP_SQL_DBPORT', 3306);
484 define('APP_SQL_DBNAME', 'eventum');
485 define('APP_SQL_DBUSER', 'mysql');
486 define('APP_SQL_DBPASS', '');
487 define('APP_TABLE_PREFIX', 'eventum_');
488 EOF
489 php config/sphinx.conf.php > config/sphinx.conf
490 rm -f config/config.php
491 %endif
492
493 # packaging
494 %patch100 -p1
495 %patch101 -p1
496 %patch107 -p1
497 %patch108 -p1
498
499 # cleanup vendor. keep only needed libraries.
500 # (the rest are packaged with system packages)
501 mv vendor vendor.dist
502 vendor() {
503         local path dir
504         for path; do
505                 dir=$(dirname $path)
506                 test -d vendor/$dir || mkdir -p vendor/$dir
507                 mv vendor.dist/$path vendor/$path
508         done
509 }
510 vendor autoload.php
511 vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
512 vendor composer/ClassLoader.php
513 vendor ircmaxell/{password-compat,random-lib,security-lib}
514 vendor zendframework/zend-config
515
516 # remove backups from patching as we use globs to package files to buildroot
517 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
518
519 %build
520 %{__make} -C localization
521
522 %install
523 rm -rf $RPM_BUILD_ROOT
524 install -d \
525         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
526         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
527         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
528         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
529         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
530         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
531         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
532
533 %{__make} install-eventum install-cli install-scm install-localization \
534         sysconfdir=%{_webappdir} \
535         localedir=%{_localedir} \
536         DESTDIR=$RPM_BUILD_ROOT
537
538 ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
539
540 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
541
542 # unsupported locale
543 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
544
545 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
546 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
547
548 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
549
550 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
551 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
552 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
553 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
554
555 install -d $RPM_BUILD_ROOT/etc/sphinx
556 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
557 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
558
559 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
560 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
561 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
562 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
563 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
564
565 cp -p config/irc_config.dist.php $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
566
567 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
568 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
569
570 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
571
572 # postfix router
573 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
574
575 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
576
577 %find_lang %{name}
578
579 # scm
580 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
581
582 %clean
583 rm -rf $RPM_BUILD_ROOT
584
585 %pre
586 %addusertogroup http %{name}
587
588 %post
589 # greate empty ghost files
590 for a in cli.log errors.log irc_bot.log login_attempts.log; do
591         if [ ! -f /var/log/%{name}/$a ]; then
592                 install -m 0620 -o root -g eventum /dev/null /var/log/%{name}/$a
593         fi
594 done
595
596 # run database update if configured
597 test -s %{_webappdir}/config.php && \
598 %{_appdir}/upgrade/update-database.php || :
599
600 # nuke Smarty templates cache after upgrade
601 rm -f /var/cache/eventum/*.php
602
603 # Restart webserver on upgrade to get .mo translations reloaded.
604 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
605 %php_webserver_restart
606
607 %preun
608 if [ "$1" = "0" ]; then
609         # nuke cache
610         rm -f /var/cache/eventum/*.php 2>/dev/null || :
611 fi
612
613 %pre base
614 %groupadd -P %{name}-base -g 146 %{name}
615 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
616
617 %postun base
618 if [ "$1" = "0" ]; then
619         %userremove %{name}
620         %groupremove %{name}
621 fi
622
623 %post setup
624 chmod 660 %{_webappdir}/{config,private_key}.php
625 chown root:http %{_webappdir}/{config,private_key}.php
626
627 %postun setup
628 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
629         chmod 640 %{_webappdir}/{config,private_key}.php
630         chown root:http %{_webappdir}/{config,private_key}.php
631 fi
632
633 %post irc
634 /sbin/chkconfig --add eventum-irc
635 %service eventum-irc restart "Eventum IRC Bot"
636
637 %preun irc
638 if [ "$1" = 0 ]; then
639         %service eventum-irc stop
640         /sbin/chkconfig --del eventum-irc
641 fi
642
643 %triggerin -- apache1 < 1.3.37-3, apache1-base
644 %webapp_register apache %{_webapp}
645
646 %triggerun -- apache1 < 1.3.37-3, apache1-base
647 %webapp_unregister apache %{_webapp}
648
649 %triggerin -- apache < 2.2.0, apache-base
650 %webapp_register httpd %{_webapp}
651
652 %triggerun -- apache < 2.2.0, apache-base
653 %webapp_unregister httpd %{_webapp}
654
655 %triggerin -- lighttpd
656 %webapp_register lighttpd %{_webapp}
657
658 %triggerun -- lighttpd
659 %webapp_unregister lighttpd %{_webapp}
660
661 %triggerpostun -- %{name} < 3.0.0-0.2
662 for f in /etc/cron.d/eventum-*; do
663         # crontabs moved to bin
664         %{__sed} -i -e '
665                 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
666                 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
667                 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
668                 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
669         ' $f
670 done
671
672 %files -f %{name}.lang
673 %defattr(644,root,root,755)
674 %attr(751,root,root) %dir %{_webappdir}
675 %attr(751,root,root) %dir %{_webappdir}/custom_field
676 %attr(751,root,root) %dir %{_webappdir}/templates
677 %attr(751,root,root) %dir %{_webappdir}/workflow
678 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
679 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
680 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
681 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
682 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
683 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
684 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
685
686 %dir %attr(731,root,http) /var/log/%{name}
687 %attr(620,root,http) %ghost /var/log/%{name}/*
688 %dir %attr(750,root,root) /var/log/archive/%{name}
689 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
690
691 %{_appdir}/config
692
693 %dir %{_appdir}/bin
694 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
695
696 %{_appdir}/autoload.php
697 %{_appdir}/init.php
698 %dir %{_appdir}/htdocs
699 %{_appdir}/htdocs/*.php
700 %{_appdir}/htdocs/*.ico
701 %{_appdir}/htdocs/ajax
702 %{_appdir}/htdocs/css
703 %{_appdir}/htdocs/customer
704 %{_appdir}/htdocs/images
705 %{_appdir}/htdocs/js
706 %{_appdir}/htdocs/manage
707 %{_appdir}/htdocs/misc
708 %{_appdir}/htdocs/reports
709 %{_appdir}/htdocs/rpc
710 %{_appdir}/htdocs/components
711 %{_appdir}/templates
712
713 %dir %{_appdir}/upgrade
714 %{_appdir}/upgrade/flush_compiled_templates.php
715 %{_appdir}/upgrade/*.sql
716 %attr(755,root,root) %{_appdir}/upgrade/update-database.php
717 %attr(755,root,root) %{_appdir}/upgrade/ldap_import.php
718 %attr(755,root,root) %{_appdir}/upgrade/ldap_update_users.php
719 %attr(755,root,root) %{_appdir}/upgrade/scm_trac_import.php
720 %{_appdir}/upgrade/patches
721
722 %{_appdir}/vendor
723
724 %dir %{_appdir}/lib
725 %{_appdir}/lib/eventum
726 %exclude %{_appdir}/lib/eventum/class.monitor.php
727
728 %{systemdtmpfilesdir}/%{name}.conf
729 %dir %attr(730,root,http) /var/run/%{name}
730 %dir %attr(730,root,http) /var/cache/%{name}
731
732 %files base
733 %defattr(644,root,root,755)
734 %attr(751,root,root) %dir %{_sysconfdir}
735 %dir %{_libdir}
736 %dir %{_appdir}
737 %dir /var/lib/%{name}
738 # saved mail copies
739 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
740 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
741 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
742
743 %files setup
744 %defattr(644,root,root,755)
745 %{_appdir}/htdocs/setup
746
747 %files doc
748 %doc docs/*
749 %{_examplesdir}/%{name}-%{version}
750
751 %files mail-queue
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
754 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
755 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
756
757 %files mail-download
758 %defattr(644,root,root,755)
759 %attr(755,root,root) %{_appdir}/bin/download_emails.php
760 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
761
762 %files reminder
763 %defattr(644,root,root,755)
764 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
765 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
766
767 %files monitor
768 %defattr(644,root,root,755)
769 %{_appdir}/lib/eventum/class.monitor.php
770 %attr(755,root,root) %{_appdir}/bin/monitor.php
771 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
772
773 %files route-drafts
774 %defattr(644,root,root,755)
775 %attr(755,root,root) %{_appdir}/bin/route_drafts.php
776
777 %files route-emails
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{_appdir}/bin/route_emails.php
780
781 %files route-notes
782 %defattr(644,root,root,755)
783 %attr(755,root,root) %{_appdir}/bin/route_notes.php
784
785 %files router-postfix
786 %defattr(644,root,root,755)
787 %attr(755,root,root) %{_libdir}/router-postfix
788
789 %files irc
790 %defattr(644,root,root,755)
791 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
792 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
793 %attr(755,root,root) %{_appdir}/bin/irc-bot.php
794 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
795
796 %files cli
797 %defattr(644,root,root,755)
798 %doc cli/eventumrc
799 %attr(755,root,root) %{_bindir}/%{name}
800
801 %files scm
802 %defattr(644,root,root,755)
803 %attr(751,root,root) %dir %{_sysconfdir}
804 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
805 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
806 %attr(755,root,root) %{_sbindir}/eventum-git-hook
807 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
808 %attr(755,root,root) %{_sbindir}/helpers.php
809
810 %files sphinx
811 %defattr(644,root,root,755)
812 %{_webappdir}/sphinx.conf.php
813 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
814 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.127474 seconds and 4 git commands to generate.