]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- apply packaging patches last for easy sending patches upstream
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 # - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
9 #
10 # Conditional build:
11 %bcond_with     qmail   # build the router-qmail subpackage
12 #
13 # snapshot: DATE
14 %define _snap 20060328
15
16 %define _rel    0.3
17
18 %include        /usr/lib/rpm/macros.php
19 Summary:        Eventum Issue / Bug tracking system
20 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
21 Name:           eventum
22 Version:        1.7.0
23 Release:        %{?_snap:4.%{_snap}.}%{?_rc:%{_rc}.}%{_rel}
24 License:        GPL
25 Group:          Applications/WWW
26 #Source0:       http://mysql.dataphone.se/Downloads/%{name}/%{name}-%{version}.tar.gz
27 Source0:        http://downloads.mysql.com/snapshots/eventum/%{name}-nightly-%{_snap}.tar.gz
28 # Source0-md5:  051c38f914f33bc20afe1c33314663f9
29 Source1:        %{name}-apache.conf
30 Source2:        %{name}-mail-queue.cron
31 Source3:        %{name}-mail-download.cron
32 Source4:        %{name}-reminder.cron
33 Source5:        %{name}-monitor.cron
34 Source6:        %{name}-cvs.php
35 Source7:        %{name}-irc.php
36 Source8:        %{name}-irc.init
37 Source9:        %{name}-irc.sysconfig
38 Source10:       %{name}-config.php
39 Source11:       %{name}-router-qmail.sh
40 Source12:       %{name}-config-setup.php
41 Source13:       %{name}-upgrade.sh
42 Source14:       %{name}-router-postfix.sh
43 Patch0:         %{name}-paths.patch
44 Patch1:         %{name}-cvs-config.patch
45 Patch2:         %{name}-irc-config.patch
46 Patch3:         %{name}-PEAR.patch
47 Patch4:         http://glen.alkohol.ee/pld/%{name}-reply-subject.patch
48 Patch5:         %{name}-lf.patch
49 Patch6:         http://glen.alkohol.ee/pld/%{name}-maq-subject.patch
50 Patch7:         %{name}-bot-reconnect.patch
51 Patch8:         %{name}-perms.patch
52 Patch9:         http://glen.alkohol.ee/pld/%{name}-httpclient-clientside.patch
53 Patch10:        %{name}-cli-wr-separated.patch
54 Patch12:        %{name}-htmloptions-truncate.patch
55 Patch13:        %{name}-link_filter-updates.patch
56 Patch14:        %{name}-irc-mem.patch
57 Patch16:        %{name}-recent_activity-usability.patch
58 Patch17:        http://glen.alkohol.ee/pld/%{name}-upload-error-keep-popup.patch
59 Patch18:        http://glen.alkohol.ee/pld/%{name}-scm-parse-response.patch
60 Patch19:        %{name}-double-decode.patch
61 Patch20:        http://glen.alkohol.ee/pld/%{name}-keep-submitbutton.patch
62 Patch21:        http://glen.alkohol.ee/pld/%{name}-tt-unhide.patch
63 Patch22:        %{name}-route-mem.patch
64 Patch23:        http://glen.alkohol.ee/pld/%{name}-msgid-case.patch
65 Patch24:        http://glen.alkohol.ee/pld/%{name}-route-and-download.patch
66 Patch25:        %{name}-scm-pluscharisbad.patch
67 Patch26:        %{name}-scm-updates.patch
68 URL:            http://dev.mysql.com/downloads/other/eventum/
69 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
70 BuildRequires:  rpmbuild(macros) >= 1.268
71 BuildRequires:  sed >= 4.0
72 Requires:       %{name}-base = %{version}-%{release}
73 Requires:       Smarty >= 2.6.10-4
74 Requires:       php >= 3:4.2.0
75 Requires:       php-gd
76 Requires:       php-imap
77 Requires:       php-mysql
78 Requires:       php-pcre
79 Requires:       php-session
80 Requires:       php-pear-Benchmark
81 Requires:       php-pear-DB
82 Requires:       php-pear-Date
83 Requires:       php-pear-HTTP_Request
84 Requires:       php-pear-Mail
85 Requires:       php-pear-Mail_Mime
86 Requires:       php-pear-Math_Stats
87 Requires:       php-pear-Net_DIME
88 Requires:       php-pear-Net_SMTP
89 Requires:       php-pear-Net_Socket
90 Requires:       php-pear-Net_URL
91 Requires:       php-pear-Net_UserAgent_Detect
92 Requires:       php-pear-PEAR-core
93 Requires:       php-pear-Text_Diff
94 Requires:       php-pear-XML_RPC
95 Requires(triggerpostun):        /usr/bin/php
96 Requires(triggerpostun):        sed >= 4.0
97 Requires:       apache(mod_dir)
98 Requires:       webapps
99 Requires:       webserver = apache
100 BuildArch:      noarch
101 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
102
103 %define         _noautoreq      'pear(/etc/webapps/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)'
104
105 %define         _libdir         %{_prefix}/lib/%{name}
106 %define         _appdir         %{_datadir}/%{name}
107 %define         _smartyplugindir        %{_appdir}/include/smarty
108 %define         _smartydir      /usr/share/php/Smarty
109 %define         _webapps        /etc/webapps
110 %define         _webapp         %{name}
111 %define         _webappdir      %{_webapps}/%{_webapp}
112 %define         _sysconfdir     /etc/%{name}
113
114 %description
115 Eventum is a user-friendly and flexible issue tracking system that can
116 be used by a support department to track incoming technical support
117 requests, or by a software development team to quickly organize tasks
118 and bugs. Eventum is used by the MySQL AB Technical Support team, and
119 has allowed us to dramatically improve our response times.
120
121 %description -l pl
122 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
123 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
124 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
125 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
126 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
127 reakcji.
128
129 %package base
130 Summary:        Eventum base package
131 Summary(pl):    Podstawowy pakiet Eventum
132 Group:          Applications/WWW
133 Requires(postun):       /usr/sbin/groupdel
134 Requires(postun):       /usr/sbin/userdel
135 Requires(pre):  /bin/id
136 Requires(pre):  /usr/bin/getgid
137 Requires(pre):  /usr/sbin/groupadd
138 Requires(pre):  /usr/sbin/useradd
139 Provides:       group(eventum)
140 Provides:       user(eventum)
141
142 %description base
143 This package contains base directory structure for Eventum.
144
145 %description base -l pl
146 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
147
148 %package setup
149 Summary:        Eventum setup package
150 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
151 Group:          Applications/WWW
152 Requires:       %{name} = %{version}-%{release}
153
154 %description setup
155 Install this package to configure initial Eventum installation. You
156 should uninstall this package when you're done, as it considered
157 insecure to keep the setup files in place.
158
159 %description setup -l pl
160 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
161 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
162 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
163
164 %package mail-queue
165 Summary:        Eventum mail queue process
166 Summary(pl):    Przetwarzanie kolejki poczty Eventum
167 Group:          Applications/WWW
168 Requires:       %{name} = %{version}-%{release}
169 Requires:       crondaemon
170
171 %description mail-queue
172 Beginning with the first release of Eventum, emails are not directly
173 sent out from the various scripts, but rather added to a mail queue
174 table that is processed by a cron job. If an email cannot be sent, it
175 will be marked as such in the mail queue log, and the cron job script
176 will re-try to send it again the next time it runs.
177
178 This package contains the cron job.
179
180 %description mail-queue -l pl
181 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
182 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
183 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
184 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
185 nastêpnym razem.
186
187 Ten pakiet zawiera zadanie dla crona.
188
189 %package mail-download
190 Summary:        Eventum email download
191 Summary(pl):    ¦ci±ganie poczty Eventum
192 Group:          Applications/WWW
193 Requires:       %{name} = %{version}-%{release}
194 Requires:       crondaemon
195
196 %description mail-download
197 In order for Eventum's email integration feature to work, you need to
198 setup a cron job to run the script every so often.
199
200 This package contains the cron job.
201
202 %description mail-download -l pl
203 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
204 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
205 czêsto.
206
207 Ten pakiet zawiera zadanie dla crona.
208
209 %package reminder
210 Summary:        Eventum Reminder System
211 Summary(pl):    System przypominania dla Eventum
212 Group:          Applications/WWW
213 Requires:       %{name} = %{version}-%{release}
214 Requires:       crondaemon
215
216 %description reminder
217 The reminder system was designed with the objective as serving as a
218 safe net for issues that need attention. Depending on what
219 configuration you create, you may have several reminders (or alerts)
220 be sent out whenever an issue needs attention, for whatever parameter
221 you may deem necessary.
222
223 This package contains the cron job.
224
225 %description reminder -l pl
226 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
227 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
228 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
229 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
230 uwa¿aæ za potrzebny.
231
232 Ten pakiet zawiera zadanie dla crona.
233
234 %package monitor
235 Summary:        Eventum Heartbeat Monitor
236 Summary(pl):    Monitor ¿ycia dla Eventum
237 Group:          Applications/WWW
238 Requires:       %{name} = %{version}-%{release}
239 Requires:       crondaemon
240 Requires:       php-posix
241
242 %description monitor
243 The heartbeat monitor is a feature designed for the administrator that
244 wants to be alerted whenever a common problem in Eventum is detected,
245 like the database server not being available anymore, or maybe when
246 the recommended permissions for certain configuration files are
247 changed.
248
249 Please note that before running the heartbeat monitor, you may need to
250 customize some of the checks to be appropriate for your own system,
251 particularly the permission and file checks on
252 Monitor::checkConfiguration().
253
254 This package contains the cron job.
255
256 %description monitor -l pl
257 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
258 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
259 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
260 do plików konfiguracyjnych.
261
262 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
263 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
264 testów uprawnieñ i plików w Monitor::checkConfiguration().
265
266 Ten pakiet zawiera zadanie dla crona.
267
268 %package route-drafts
269 Summary:        Eventum Draft Routing
270 Summary(pl):    Przekazywanie szkiców dla Eventum
271 Group:          Applications/WWW
272 Requires:       %{name} = %{version}-%{release}
273 Requires:       eventum(router)
274
275 %description route-drafts
276 The draft routing feature is used to automatically associate a thread
277 of drafts into an Eventum issue. By setting up qmail (or even Postfix)
278 to deliver emails sent to a specific address (usually
279 draft-<number>@<domain>) to the above script, users are able to send
280 drafts written in their mail client to be stored in Eventum. These
281 drafts will NOT broadcasted to the notification list.
282
283 %description route-drafts -l pl
284 Przekazywanie szkiców s³u¿y do automatycznego wi±zania w±tku szkiców z
285 problemem w Eventum. Ustawiaj±c qmaila (czy nawet Postfiksa), aby
286 dostarcza³ pocztê wys³an± na podany adres (zwykle
287 draft-<liczba>@<domena>) do tego skryptu umo¿liwia siê u¿ytkownikom
288 wysy³anie szkiców napisanych w ich kliencie pocztowym do zapisania w
289 Eventum. Szkice te NIE bêd± wysy³ane na listê powiadomieñ.
290
291 %package route-emails
292 Summary:        Eventum Email Routing
293 Summary(pl):    Przekazywanie poczty dla Eventum
294 Group:          Applications/WWW
295 Requires:       %{name} = %{version}-%{release}
296 Requires:       eventum(router)
297
298 %description route-emails
299 The email routing feature is used to automatically associate a thread
300 of emails into an Eventum issue. By setting up qmail (or even postfix)
301 to deliver emails sent to a specific address (usually
302 issue-<number>@<domain>) to the above script, users are able to use
303 their email clients to reply to emails coming from Eventum, and those
304 replies will be automatically associated with the issue and
305 broadcasted to the entire notification list.
306
307 %description route-emails -l pl
308 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
309 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
310 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
311 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
312 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
313 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
314 rozprowadzane do ca³ej listy og³oszeniowej.
315
316 %package route-notes
317 Summary:        Eventum Note Routing
318 Summary(pl):    Przekazywanie notatek dla Eventum
319 Group:          Applications/WWW
320 Requires:       %{name} = %{version}-%{release}
321 Requires:       eventum(router)
322
323 %description route-notes
324 The note routing feature is used to automatically associate a thread
325 of notes into an Eventum issue. By setting up qmail (or even postfix)
326 to deliver emails sent to a specific address (usually
327 note-<number>@<domain>) to the above script, users are able to use
328 their email clients to reply to internal notes coming from Eventum,
329 and those replies will be automatically associated with the issue and
330 broadcasted to the notification list staff members.
331
332 %description route-notes -l pl
333 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
334 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
335 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
336 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
337 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
338 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
339 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
340
341 %package router-qmail
342 Summary:        Eventum Mail Routing - qmail
343 Summary(pl):    Przekazywanie poczty Eventum - qmail
344 Group:          Applications/Mail
345 # loose dep is intentional. qmail subpackage isn't built on PLD
346 # builders and there really nothing changes.
347 Requires:       %{name} >= %{version}-%{release}
348 Requires:       qmail >= 1.03
349 Provides:       eventum(router)
350 Obsoletes:      eventum(router)
351
352 %description router-qmail
353 This package provides way of routing notes and emails back to Eventum
354 via qmail.
355
356 %description router-qmail -l pl
357 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
358 przez qmaila.
359
360 %package router-postfix
361 Summary:        Eventum Mail Routing - Postfix
362 Summary(pl):    Przekazywanie poczty Eventum - Postfix
363 Group:          Applications/Mail
364 Requires:       %{name} = %{version}-%{release}
365 Requires:       postfix
366 Provides:       eventum(router)
367 Obsoletes:      eventum(router)
368
369 %description router-postfix
370 This package provides way of routing notes and emails back to Eventum
371 via Postfix.
372
373 The Postfix configuration instructions you can find from
374 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
375
376 %description router-postfix -l pl
377 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
378 przez Postfiksa.
379
380 Opis konfiguracji Postfiksa mo¿na znale¼æ pod adresem
381 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
382
383 %package irc
384 Summary:        Eventum IRC Notification Bot
385 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
386 Group:          Applications/WWW
387 Requires(triggerpostun):        sed >= 4.0
388 Requires:       %{name} = %{version}-%{release}
389 Requires:       php-pear-Net_SmartIRC
390 Requires:       php-sockets
391 Requires:       rc-scripts >= 0.4.0.18
392
393 %description irc
394 The IRC notification bot is a nice feature for remote teams that want
395 to handle issues and want to have a quick and easy way to get simple
396 notifications. Right now the bot notifies of the following actions:
397 - New Issues
398 - Blocked emails
399 - Issues that got their assignment list changed
400
401 NOTE: You will need to manually edit the bot.php script to set your
402 appropriate preferences, like IRC server and channel that the bot
403 should join.
404
405 %description irc -l pl
406 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
407 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
408 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
409 nastêpuj±cych zdarzeniach:
410 - nowych sprawach
411 - zablokowanych listach
412 - sprawach, dla których zmieni³a siê lista powi±zañ
413
414 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
415 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
416
417 %package cli
418 Summary:        Eventum command-line interface
419 Summary(pl):    Interfejs linii poleceñ dla Eventum
420 Group:          Applications/WWW
421 Requires:       %{name}-base = %{version}-%{release}
422 Requires:       php-cli
423 Requires:       php-common >= 3:4.1.0
424 Requires:       php-curl
425 Requires:       php-pear-XML_RPC
426 Requires:       php-xml
427
428 %description cli
429 The Eventum command-line interface allows you to access most of the
430 features of the web interface straight from your command shell.
431
432 %description cli -l pl
433 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
434 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
435
436 %package scm
437 Summary:        Eventum SCM integration
438 Summary(pl):    Integracja SCM dla Eventum
439 Group:          Applications/WWW
440 Requires:       %{name}-base = %{version}-%{release}
441 Requires:       php-cli
442 Requires:       php-common >= 3:4.1.0
443 Requires:       php-pcre
444
445 %description scm
446 This feature allows your software development teams to integrate your
447 Source Control Management system with your Issue Tracking System.
448
449 The integration is implemented in such a way that it will be forward
450 compatible with pretty much any SCM system, such as CVS.
451
452 For installation see
453 </eventum/help.php?topic=scm_integration_installation>.
454
455 %description scm -l pl
456 Ten pakiet pozwala zespo³om programistów na integracjê systemu
457 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
458 ¶ledzenia spraw.
459
460 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
461 prawie ka¿dym systemem SCM, jak np. CVS.
462
463 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
464 </eventum/help.php?topic=scm_integration_installation>.
465
466 %prep
467 %setup -q %{?_snap:-n %{name}-%{_snap}}
468 # undos the source
469 find . -type f -print0 | xargs -0 sed -i -e 's,\r$,,'
470
471 rm -f setup.conf.php # not to be installed by *.php glob
472 rm -rf misc/upgrade/*v1.[123]* # too old to support in PLD Linux
473 rm -f misc/upgrade/flush_compiled_templates.php
474 rm -rf misc/upgrade/*/upgrade_config.php # not needed nor supported in PLD Linux
475
476 # sample, not used in eventum
477 rm -f rpc/xmlrpc_client.php
478
479 # bug fixes.
480 %patch4 -p1
481 %patch5 -p1
482 %patch6 -p1
483 %patch7 -p1
484 %patch8 -p1
485 %patch9 -p1
486 %patch10 -p1
487 %patch12 -p1
488 %patch13 -p1
489 %patch16 -p1
490 %patch17 -p1
491 %patch18 -p1
492 %patch19 -p1
493 %patch20 -p1
494 %patch21 -p1
495 %patch22 -p1
496 %patch23 -p1
497 %patch24 -p1
498 %patch25 -p1
499 %patch26 -p1
500
501 # packaging
502 %patch0 -p1
503 %patch1 -p1
504 %patch14 -p1
505 %patch2 -p1
506 %patch3 -p1
507
508 sed -e '1s,#!.*/bin/php -q,#!%{_bindir}/php,' misc/cli/eventum > %{name}-cli
509 sed -e '1i#!%{_bindir}/php' misc/scm/process_cvs_commits.php > %{name}-scm
510 sed -e '1i#!%{_bindir}/php' misc/irc/bot.php > %{name}-bot
511 mv misc/cli/eventumrc_example eventumrc
512 sed -i -e '1i#!%{_bindir}/php' misc/*.php
513 chmod +x misc/*.php
514
515 sed -e '
516 s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
517 ' < include/private_key.php > private_key.php.in
518 rm -f include/private_key.php
519
520 # replace in remaining scripts config.inc.php to system one
521 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
522         s,include_once(".*config.inc.php"),include_once("%{_webappdir}/core.php"),
523 '
524
525 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
526         s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_webappdir}/private_key.php"),
527 '
528
529 # remove backups from patching as we use globs to package files to buildroot
530 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
531
532 %install
533 rm -rf $RPM_BUILD_ROOT
534 install -d \
535         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
536         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
537         $RPM_BUILD_ROOT/var/{run,log,cache,lib}/%{name} \
538         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
539         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
540
541 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
542 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
543 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
544 cp -a templates $RPM_BUILD_ROOT%{_appdir}
545 cp -a include/{customer,custom_field,jpgraph,pear,workflow} $RPM_BUILD_ROOT%{_appdir}/include
546 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
547 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
548 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
549
550 cp -a favicon.ico $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
551 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/setup/config.inc.php
552 install %{SOURCE13} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
553
554 # cli
555 install -d $RPM_BUILD_ROOT%{_appdir}/cli
556 cp -a misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
557 cp -a misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
558 install %{name}-cli $RPM_BUILD_ROOT%{_bindir}/%{name}
559 install %{name}-bot $RPM_BUILD_ROOT%{_sbindir}
560
561 # scm
562 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
563 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
564
565 # private key
566 cp -a private_key.php.in $RPM_BUILD_ROOT%{_webappdir}/private_key.php
567
568 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
569 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
570 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
571 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
572 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
573 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
574 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
575 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
576 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
577
578 sed -e '
579 s,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}},
580 s,%%{PHP_PEAR_DIR}%%,%{php_pear_dir},
581 s,%%{APP_PATH}%%,%{_appdir},
582 s,%%{SMARTY_DIR}%%,%{_smartydir},
583 s,%%{SYSCONFDIR}%%,%{_webappdir},
584 ' %{SOURCE10} > $RPM_BUILD_ROOT%{_webappdir}/core.php
585
586 # config
587 > $RPM_BUILD_ROOT%{_webappdir}/setup.php
588 mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_webappdir}/config}.php
589
590 # provided by PEAR
591 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
592
593 # use system Smarty
594 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
595 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
596 # These plugins are not in Smarty package (Smarty-2.6.2-3)
597 cp -a \
598         include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
599         include/Smarty/plugins/modifier.highlight_quoted.php \
600         $RPM_BUILD_ROOT%{_smartyplugindir}
601
602 # qmail router
603 %if %{with qmail}
604 d=$RPM_BUILD_ROOT/var/lib/%{name}
605 echo 'root' > $d/.qmail
606 echo 'root' > $d/.qmail-default
607 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
608 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
609 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
610 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
611 %endif
612 # postfix router
613 install %{SOURCE14} $RPM_BUILD_ROOT%{_libdir}/router-postfix
614
615 %clean
616 rm -rf $RPM_BUILD_ROOT
617
618 %pre
619 %addusertogroup http %{name}
620
621 %post
622 # check if the package is configured.
623 if grep -q 'header("Location: setup/")' %{_webappdir}/config.php; then
624 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
625 %banner %{name} -e <<EOF
626
627 You haven't yet configured Eventum!
628 Please open in browser <http://localhost/eventum/>
629 If you need access from elsewhere, you need to edit
630 %{_webappdir}/apache.conf and restart apache.
631
632 IMPORTANT: When You have configured Eventum, please uninstall the
633 setup package, so that %{name}-setup is able to secure your Eventum
634 installation.
635
636 EOF
637 #' vim syntax hack
638 else
639 %banner %{name} -e <<EOF
640
641 You haven't yet configured Eventum!
642
643 To setup eventum, please install %{name}-setup and open in browser
644 <http://localhost/eventum/>.
645 If you need access from elsewhere, you need to edit
646 %{_webappdir}/apache.conf and restart apache.
647
648 IMPORTANT: When You have configured Eventum, please uninstall the
649 setup package, so that %{name}-setup is able to secure your Eventum
650 installation.
651
652 EOF
653 #' vim syntax hack
654 fi
655
656 elif grep -q 'DEFAULTPRIVATEKEY' %{_webappdir}/private_key.php; then
657 %banner %{name} -e <<EOF
658
659 You have default private key installed!
660
661 Install %{name}-setup and open up http://yourserver/eventum/setup/
662 -- that will help you setup initial config.
663
664 when have configured Eventum, please uninstall the setup package,
665 so that %{name}-setup is able to secure your Eventum installation.
666
667 EOF
668         elif [ -d %{_appdir}/setup ]; then
669 %banner %{name} -e <<EOF
670
671 If you have have configured Eventum, please uninstall the setup package,
672 so that %{name}-setup is able to secure your Eventum installation.
673
674 EOF
675 fi
676
677 # nuke Smarty templates cache after upgrade
678 rm -f /var/cache/eventum/*.php
679
680 %preun
681 if [ "$1" = "0" ]; then
682         # nuke cache
683         rm -f /var/cache/eventum/*.php 2>/dev/null || :
684 fi
685
686 %pre base
687 %groupadd -P %{name}-base -g 146 %{name}
688 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
689
690 %postun base
691 if [ "$1" = "0" ]; then
692         %userremove %{name}
693         %groupremove %{name}
694 fi
695
696 %post router-qmail
697 CF=/etc/qmail/control/virtualdomains
698 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
699         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_webappdir}/config.php 2>/dev/null)
700         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
701         umask 022
702         echo "#${FQDN}:%{name}" >> $CF
703
704 %banner %{name}-qmail -e <<EOF
705
706 Added "#${FQDN}:%{name}" to $CF,
707 Please verify that it is correct and restart qmail:
708 # service qmail reload
709
710 Consult qmail-send(8) for more information on virtualdomains.
711
712 EOF
713 fi
714
715 %preun router-qmail
716 if [ "$1" = "0" ]; then
717         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
718 fi
719
720 %post setup
721 chmod 660 %{_webappdir}/{config,private_key}.php
722 chown root:eventum %{_webappdir}/{config,private_key}.php
723
724 %postun setup
725 if [ "$1" = "0" ]; then
726         chmod 640 %{_webappdir}/{config,private_key}.php
727         chown root:eventum %{_webappdir}/{config,private_key}.php
728 fi
729
730 %post irc
731 /sbin/chkconfig --add eventum-irc
732 %service eventum-irc restart "Eventum IRC Bot"
733
734 %triggerin -- apache1
735 %webapp_register apache %{_webapp}
736
737 %triggerun -- apache1
738 %webapp_unregister apache %{_webapp}
739
740 %triggerin -- apache >= 2.0.0
741 %webapp_register httpd %{_webapp}
742
743 %triggerun -- apache >= 2.0.0
744 %webapp_unregister httpd %{_webapp}
745
746 # FIXME
747 # only one upgrade trigger is called if you're upgrading over two
748 # versions, say 1.5 to 1.5.3, only 1.5.3 trigger is called.
749 # use common trigger (the highest version and rpmvercmp from poldek?)
750 %triggerpostun -- eventum < 1.5.1-0.257
751 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5_to_v1.5.1 <<EOF
752 database_changes.php Perform database changes
753 EOF
754
755 %triggerpostun -- eventum < 1.5.2-0.289
756 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.1_to_v1.5.2 <<EOF
757 database_changes.php Perform database changes
758 set_priority_ranks.php Fix the ranking of priority values
759 EOF
760
761 %triggerpostun -- eventum < 1.5.3-0.291
762 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.2_to_v1.5.3 <<EOF
763 database_changes.php Perform database changes
764 EOF
765
766 %triggerpostun -- eventum < 1.5.4-1.12
767 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.3_to_v1.5.4 <<EOF
768 database_changes.php Perform database changes
769 EOF
770
771 %triggerpostun -- eventum < 1.6.0-RC2.6
772 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.5_to_v1.6.0 <<EOF
773 database_changes.php Perform database changes
774 upgrade_saved_searches.php Upgrade existing custom filters (saved searches)
775 EOF
776
777 %triggerpostun -- eventum < 1.6.1-0.2
778 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.0_to_v1.6.1 <<EOF
779 database_changes.php Perform database changes
780 EOF
781
782 %triggerpostun irc -- eventum-irc < 1.6.1-3.14
783 sed -i -e '
784 s,\$irc_host,$irc_server_hostname,
785 s,\$irc_port,$irc_server_port,
786 s,\$irc_nick,$nickname,
787 s,\$irc_realname,$realname,
788 s,\$irc_username,$username,
789 s,\$irc_password,$password,
790 ' /etc/eventum/irc.php
791
792 %triggerpostun -- eventum < 1.7.0-2.0.48
793 # migrate from apache-config macros
794 if [ -f /etc/%{name}/apache.conf.rpmsave ]; then
795         if [ -d /etc/apache/webapps.d ]; then
796                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
797                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
798         fi
799
800         if [ -d /etc/httpd/webapps.d ]; then
801                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
802                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
803         fi
804 fi
805
806 if [ -L /etc/apache/conf.d/99_%{_webapp}.conf ]; then
807         /usr/sbin/webapp register apache %{_webapp}
808         rm -f /etc/apache/conf.d/99_%{_webapp}.conf
809         %service -q apache reload
810 fi
811 if [ -L /etc/httpd/httpd.conf/99_%{_webapp}.conf ]; then
812         /usr/sbin/webapp register httpd %{_webapp}
813         rm -f /etc/httpd/httpd.conf/99_%{_webapp}.conf
814         %service -q httpd reload
815 fi
816
817 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.1_to_v1.7.0 <<EOF
818 database_changes.php Perform database changes
819 set_root_message_ids.php Set iss_root_message_id
820 EOF
821
822 # regular configs
823 for i in apache.conf config.php private_key.php setup.php; do
824         if [ -f /etc/eventum/$i.rpmsave ]; then
825                 mv -f %{_webappdir}/$i{,.rpmnew}
826                 mv -f /etc/eventum/$i.rpmsave %{_webappdir}/$i
827         fi
828 done
829
830 %triggerpostun cli -- %{name}-cli < 1.7.0-3.4
831 if [ -f %{_webappdir}/cli.php.rpmsave ]; then
832         mv -f %{_sysconfdir}/cli.php{,.rpmnew}
833         mv -f %{_webappdir}/cli.php.rpmsave %{_sysconfdir}/cli.php
834 fi
835
836 %triggerpostun irc -- %{name}-irc < 1.7.0-3.4
837 if [ -f %{_webappdir}/irc.php.rpmsave ]; then
838         mv -f %{_sysconfdir}/irc.php{,.rpmnew}
839         mv -f %{_webappdir}/irc.php.rpmsave %{_sysconfdir}/irc.php
840 fi
841
842 %files
843 %defattr(644,root,root,755)
844 %doc ChangeLog FAQ INSTALL README UPGRADE CONTRIB
845 %doc docs/* setup/schema.sql
846 %attr(751,root,root) %dir %{_webappdir}
847 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
848 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
849 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
850 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
851 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
852 %attr(640,root,eventum) %config %verify(not mtime) %{_webappdir}/core.php
853
854 %dir %attr(731,root,eventum) /var/log/%{name}
855 %attr(620,root,eventum) %ghost /var/log/%{name}/*
856
857 %dir %{_appdir}/htdocs
858 %{_appdir}/htdocs/*.php
859 %{_appdir}/htdocs/*.ico
860 %{_appdir}/htdocs/css
861 %{_appdir}/htdocs/customer
862 %{_appdir}/htdocs/images
863 %{_appdir}/htdocs/js
864 %{_appdir}/htdocs/manage
865 %{_appdir}/htdocs/reports
866 %{_appdir}/htdocs/rpc
867 %{_appdir}/htdocs/misc
868 %{_appdir}/templates
869 %dir %{_appdir}/upgrade
870 %attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
871 %{_appdir}/upgrade/[!u]*
872 %{_smartyplugindir}
873
874 %dir %{_appdir}/include
875 %{_appdir}/include/customer
876 %{_appdir}/include/custom_field
877 %{_appdir}/include/jpgraph
878 %{_appdir}/include/workflow
879 %{_appdir}/include/class.[!m]*.php
880 %{_appdir}/include/class.mail.php
881 %{_appdir}/include/class.mail_queue.php
882 %{_appdir}/include/class.mime_helper.php
883 %{_appdir}/include/class.misc.php
884 %{_appdir}/include/db_access.php
885
886 %dir %attr(730,root,eventum) /var/run/%{name}
887 %dir %attr(730,root,eventum) /var/cache/%{name}
888
889 %files base
890 %defattr(644,root,root,755)
891 %attr(751,root,root) %dir %{_sysconfdir}
892 %dir %{_libdir}
893 %dir %{_appdir}
894 # qmail will ignore user, if it's home directory is not owned
895 %attr(750,eventum,eventum) %dir /var/lib/%{name}
896 # saved mail copies
897 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_emails
898 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_drafts
899 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_notes
900
901 %files setup
902 %defattr(644,root,root,755)
903 %{_appdir}/htdocs/setup
904
905 %files mail-queue
906 %defattr(644,root,root,755)
907 %attr(755,root,root) %{_appdir}/process_mail_queue.php
908 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
909
910 %files mail-download
911 %defattr(644,root,root,755)
912 %attr(755,root,root) %{_appdir}/download_emails.php
913 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
914
915 %files reminder
916 %defattr(644,root,root,755)
917 %attr(755,root,root) %{_appdir}/check_reminders.php
918 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
919
920 %files monitor
921 %defattr(644,root,root,755)
922 %{_appdir}/include/class.monitor.php
923 %attr(755,root,root) %{_appdir}/monitor.php
924 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
925
926 %files route-drafts
927 %defattr(644,root,root,755)
928 %attr(755,root,root) %{_appdir}/route_drafts.php
929
930 %files route-emails
931 %defattr(644,root,root,755)
932 %attr(755,root,root) %{_appdir}/route_emails.php
933
934 %files route-notes
935 %defattr(644,root,root,755)
936 %attr(755,root,root) %{_appdir}/route_notes.php
937
938 %if %{with qmail}
939 %files router-qmail
940 %defattr(644,root,root,755)
941 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
942 %attr(755,root,root) %{_libdir}/router-qmail
943 %endif
944
945 %files router-postfix
946 %defattr(644,root,root,755)
947 %attr(755,root,root) %{_libdir}/router-postfix
948
949 %files irc
950 %defattr(644,root,root,755)
951 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
952 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
953 %attr(755,root,root) %{_sbindir}/%{name}-bot
954 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
955
956 %files cli
957 %defattr(644,root,root,755)
958 %doc eventumrc
959 %attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
960 %attr(755,root,root) %{_bindir}/%{name}
961 %{_appdir}/cli
962
963 %files scm
964 %defattr(644,root,root,755)
965 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
966 %attr(755,root,root) %{_libdir}/scm
This page took 0.109286 seconds and 4 git commands to generate.