]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- scm ping now can do https if php-openssl present
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 # - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
9 #
10 # Conditional build:
11 %bcond_with     qmail   # build the router-qmail subpackage
12 %bcond_with     order_patch     # with custom issue order patch
13
14 #define _snap   20060330
15 #define _rc             RC3
16 %define _rel    2.29
17
18 %include        /usr/lib/rpm/macros.php
19 Summary:        Eventum Issue / Bug tracking system
20 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
21 Name:           eventum
22 Version:        1.7.1
23 Release:        %{?_snap:0.%{_snap}.}%{?_rc:%{_rc}.}%{_rel}
24 License:        GPL
25 Group:          Applications/WWW
26 #Source0:       http://downloads.mysql.com/snapshots/eventum/%{name}-nightly-%{_snap}.tar.gz
27 Source0:        http://mysql.dataphone.se/Downloads/eventum/%{name}-%{version}.tar.gz
28 # Source0-md5:  e1845de39b4d9bd30ddec9c26031a7d5
29 Source1:        %{name}-apache.conf
30 Source2:        %{name}-mail-queue.cron
31 Source3:        %{name}-mail-download.cron
32 Source4:        %{name}-reminder.cron
33 Source5:        %{name}-monitor.cron
34 Source6:        %{name}-cvs.php
35 Source7:        %{name}-irc.php
36 Source8:        %{name}-irc.init
37 Source9:        %{name}-irc.sysconfig
38 Source10:       %{name}-config.php
39 Source11:       %{name}-router-qmail.sh
40 Source12:       %{name}-config-setup.php
41 Source13:       %{name}-upgrade.sh
42 Source14:       %{name}-router-postfix.sh
43 Source15:       %{name}.logrotate
44 Patch0:         %{name}-lf.patch
45 Patch1:         %{name}-perms.patch
46 Patch2:         %{name}-cli-wr-separated.patch
47 Patch3:         %{name}-scm-parse-response.patch
48 Patch4:         %{name}-double-decode.patch
49 Patch5:         %{name}-route-mem.patch
50 Patch6:         %{name}-scm-pluscharisbad.patch
51 Patch7:         %{name}-scm-updates.patch
52 Patch8:         %{name}-close-signature.patch
53 Patch9:         %{name}-list-sorting.patch
54 Patch10:        %{name}-workflow-handlenewnote-note_id.patch
55 Patch11:        %{name}-order4b.patch
56 Patch12:        %{name}-cli-errorcheck.patch
57 Patch13:        %{name}-combined.patch
58 Patch14:        %{name}-xml-inline.patch
59 Patch15:        %{name}-timetracking-advanced-logic.patch
60 Patch16:        %{name}-timedisplay.patch
61 Patch17:        %{name}-bug-17267.patch
62 Patch18:        %{name}-compact-issue-display.patch
63 Patch19:        %{name}-fixed-nav.patch
64 Patch20:        %{name}-scm-ssl.patch
65 # packaging patches that probably never go upstream
66 Patch100:       %{name}-paths.patch
67 Patch101:       %{name}-cvs-config.patch
68 Patch102:       %{name}-irc-mem.patch
69 Patch103:       %{name}-irc-config.patch
70 Patch104:       %{name}-PEAR.patch
71 Patch105:       %{name}-httpclient-clientside.patch
72 Patch106:       %{name}-bot-reconnect.patch
73 Patch107:       %{name}-private-key.patch
74 URL:            http://dev.mysql.com/downloads/other/eventum/
75 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
76 BuildRequires:  rpmbuild(macros) >= 1.268
77 BuildRequires:  sed >= 4.0
78 Requires(triggerpostun):        /usr/bin/php
79 Requires(triggerpostun):        sed >= 4.0
80 Requires:       %{name}-base = %{version}-%{release}
81 Requires:       Smarty >= 2.6.10-4
82 Requires:       apache(mod_dir)
83 Requires:       php >= 3:4.2.0
84 Requires:       php-gd
85 Requires:       php-imap
86 Requires:       php-mysql
87 Requires:       php-pcre
88 Requires:       php-pear-Benchmark
89 Requires:       php-pear-DB
90 Requires:       php-pear-Date
91 Requires:       php-pear-HTTP_Request
92 Requires:       php-pear-Mail
93 Requires:       php-pear-Mail_Mime
94 Requires:       php-pear-Math_Stats
95 Requires:       php-pear-Net_DIME
96 Requires:       php-pear-Net_SMTP
97 Requires:       php-pear-Net_Socket
98 Requires:       php-pear-Net_URL
99 Requires:       php-pear-Net_UserAgent_Detect
100 Requires:       php-pear-PEAR-core
101 Requires:       php-pear-Text_Diff
102 Requires:       php-pear-XML_RPC
103 Requires:       php-session
104 Requires:       webapps
105 BuildArch:      noarch
106 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
107
108 %define         _noautoreq      'pear(/etc/webapps/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)'
109
110 %define         _libdir         %{_prefix}/lib/%{name}
111 %define         _appdir         %{_datadir}/%{name}
112 %define         _smartyplugindir        %{_appdir}/include/smarty
113 %define         _smartydir      /usr/share/php/Smarty
114 %define         _webapps        /etc/webapps
115 %define         _webapp         %{name}
116 %define         _webappdir      %{_webapps}/%{_webapp}
117 %define         _sysconfdir     /etc/%{name}
118
119 %description
120 Eventum is a user-friendly and flexible issue tracking system that can
121 be used by a support department to track incoming technical support
122 requests, or by a software development team to quickly organize tasks
123 and bugs. Eventum is used by the MySQL AB Technical Support team, and
124 has allowed us to dramatically improve our response times.
125
126 %description -l pl
127 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
128 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
129 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
130 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
131 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
132 reakcji.
133
134 %package base
135 Summary:        Eventum base package
136 Summary(pl):    Podstawowy pakiet Eventum
137 Group:          Applications/WWW
138 Requires(postun):       /usr/sbin/groupdel
139 Requires(postun):       /usr/sbin/userdel
140 Requires(pre):  /bin/id
141 Requires(pre):  /usr/bin/getgid
142 Requires(pre):  /usr/sbin/groupadd
143 Requires(pre):  /usr/sbin/useradd
144 Provides:       group(eventum)
145 Provides:       user(eventum)
146
147 %description base
148 This package contains base directory structure for Eventum.
149
150 %description base -l pl
151 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
152
153 %package setup
154 Summary:        Eventum setup package
155 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
156 Group:          Applications/WWW
157 Requires:       %{name} = %{version}-%{release}
158
159 %description setup
160 Install this package to configure initial Eventum installation. You
161 should uninstall this package when you're done, as it considered
162 insecure to keep the setup files in place.
163
164 %description setup -l pl
165 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
166 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
167 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
168
169 %package mail-queue
170 Summary:        Eventum mail queue process
171 Summary(pl):    Przetwarzanie kolejki poczty Eventum
172 Group:          Applications/WWW
173 Requires:       %{name} = %{version}-%{release}
174 Requires:       crondaemon
175
176 %description mail-queue
177 Beginning with the first release of Eventum, emails are not directly
178 sent out from the various scripts, but rather added to a mail queue
179 table that is processed by a cron job. If an email cannot be sent, it
180 will be marked as such in the mail queue log, and the cron job script
181 will re-try to send it again the next time it runs.
182
183 This package contains the cron job.
184
185 %description mail-queue -l pl
186 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
187 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
188 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
189 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
190 nastêpnym razem.
191
192 Ten pakiet zawiera zadanie dla crona.
193
194 %package mail-download
195 Summary:        Eventum email download
196 Summary(pl):    ¦ci±ganie poczty Eventum
197 Group:          Applications/WWW
198 Requires:       %{name} = %{version}-%{release}
199 Requires:       crondaemon
200
201 %description mail-download
202 In order for Eventum's email integration feature to work, you need to
203 setup a cron job to run the script every so often.
204
205 This package contains the cron job.
206
207 %description mail-download -l pl
208 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
209 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
210 czêsto.
211
212 Ten pakiet zawiera zadanie dla crona.
213
214 %package reminder
215 Summary:        Eventum Reminder System
216 Summary(pl):    System przypominania dla Eventum
217 Group:          Applications/WWW
218 Requires:       %{name} = %{version}-%{release}
219 Requires:       crondaemon
220
221 %description reminder
222 The reminder system was designed with the objective as serving as a
223 safe net for issues that need attention. Depending on what
224 configuration you create, you may have several reminders (or alerts)
225 be sent out whenever an issue needs attention, for whatever parameter
226 you may deem necessary.
227
228 This package contains the cron job.
229
230 %description reminder -l pl
231 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
232 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
233 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
234 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
235 uwa¿aæ za potrzebny.
236
237 Ten pakiet zawiera zadanie dla crona.
238
239 %package monitor
240 Summary:        Eventum Heartbeat Monitor
241 Summary(pl):    Monitor ¿ycia dla Eventum
242 Group:          Applications/WWW
243 Requires:       %{name} = %{version}-%{release}
244 Requires:       crondaemon
245 Requires:       php-posix
246
247 %description monitor
248 The heartbeat monitor is a feature designed for the administrator that
249 wants to be alerted whenever a common problem in Eventum is detected,
250 like the database server not being available anymore, or maybe when
251 the recommended permissions for certain configuration files are
252 changed.
253
254 Please note that before running the heartbeat monitor, you may need to
255 customize some of the checks to be appropriate for your own system,
256 particularly the permission and file checks on
257 Monitor::checkConfiguration().
258
259 This package contains the cron job.
260
261 %description monitor -l pl
262 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
263 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
264 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
265 do plików konfiguracyjnych.
266
267 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
268 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
269 testów uprawnieñ i plików w Monitor::checkConfiguration().
270
271 Ten pakiet zawiera zadanie dla crona.
272
273 %package route-drafts
274 Summary:        Eventum Draft Routing
275 Summary(pl):    Przekazywanie szkiców dla Eventum
276 Group:          Applications/WWW
277 Requires:       %{name} = %{version}-%{release}
278 Requires:       eventum(router)
279
280 %description route-drafts
281 The draft routing feature is used to automatically associate a thread
282 of drafts into an Eventum issue. By setting up qmail (or even Postfix)
283 to deliver emails sent to a specific address (usually
284 draft-<number>@<domain>) to the above script, users are able to send
285 drafts written in their mail client to be stored in Eventum. These
286 drafts will NOT broadcasted to the notification list.
287
288 %description route-drafts -l pl
289 Przekazywanie szkiców s³u¿y do automatycznego wi±zania w±tku szkiców z
290 problemem w Eventum. Ustawiaj±c qmaila (czy nawet Postfiksa), aby
291 dostarcza³ pocztê wys³an± na podany adres (zwykle
292 draft-<liczba>@<domena>) do tego skryptu umo¿liwia siê u¿ytkownikom
293 wysy³anie szkiców napisanych w ich kliencie pocztowym do zapisania w
294 Eventum. Szkice te NIE bêd± wysy³ane na listê powiadomieñ.
295
296 %package route-emails
297 Summary:        Eventum Email Routing
298 Summary(pl):    Przekazywanie poczty dla Eventum
299 Group:          Applications/WWW
300 Requires:       %{name} = %{version}-%{release}
301 Requires:       eventum(router)
302
303 %description route-emails
304 The email routing feature is used to automatically associate a thread
305 of emails into an Eventum issue. By setting up qmail (or even postfix)
306 to deliver emails sent to a specific address (usually
307 issue-<number>@<domain>) to the above script, users are able to use
308 their email clients to reply to emails coming from Eventum, and those
309 replies will be automatically associated with the issue and
310 broadcasted to the entire notification list.
311
312 %description route-emails -l pl
313 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
314 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
315 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
316 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
317 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
318 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
319 rozprowadzane do ca³ej listy og³oszeniowej.
320
321 %package route-notes
322 Summary:        Eventum Note Routing
323 Summary(pl):    Przekazywanie notatek dla Eventum
324 Group:          Applications/WWW
325 Requires:       %{name} = %{version}-%{release}
326 Requires:       eventum(router)
327
328 %description route-notes
329 The note routing feature is used to automatically associate a thread
330 of notes into an Eventum issue. By setting up qmail (or even postfix)
331 to deliver emails sent to a specific address (usually
332 note-<number>@<domain>) to the above script, users are able to use
333 their email clients to reply to internal notes coming from Eventum,
334 and those replies will be automatically associated with the issue and
335 broadcasted to the notification list staff members.
336
337 %description route-notes -l pl
338 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
339 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
340 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
341 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
342 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
343 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
344 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
345
346 %package router-qmail
347 Summary:        Eventum Mail Routing - qmail
348 Summary(pl):    Przekazywanie poczty Eventum - qmail
349 Group:          Applications/Mail
350 # loose dep is intentional. qmail subpackage isn't built on PLD
351 # builders and there really nothing changes.
352 Requires:       %{name} >= %{version}-%{release}
353 Requires:       qmail >= 1.03
354 Provides:       eventum(router)
355 Obsoletes:      eventum(router)
356
357 %description router-qmail
358 This package provides way of routing notes and emails back to Eventum
359 via qmail.
360
361 %description router-qmail -l pl
362 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
363 przez qmaila.
364
365 %package router-postfix
366 Summary:        Eventum Mail Routing - Postfix
367 Summary(pl):    Przekazywanie poczty Eventum - Postfix
368 Group:          Applications/Mail
369 Requires:       %{name} = %{version}-%{release}
370 Requires:       postfix
371 Provides:       eventum(router)
372 Obsoletes:      eventum(router)
373
374 %description router-postfix
375 This package provides way of routing notes and emails back to Eventum
376 via Postfix.
377
378 The Postfix configuration instructions you can find from
379 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
380
381 %description router-postfix -l pl
382 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
383 przez Postfiksa.
384
385 Opis konfiguracji Postfiksa mo¿na znale¼æ pod adresem
386 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
387
388 %package irc
389 Summary:        Eventum IRC Notification Bot
390 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
391 Group:          Applications/WWW
392 Requires(post,preun):   /sbin/chkconfig
393 Requires(triggerpostun):        sed >= 4.0
394 Requires:       %{name} = %{version}-%{release}
395 Requires:       php-pear-Net_SmartIRC
396 Requires:       php-sockets
397 Requires:       rc-scripts >= 0.4.0.18
398
399 %description irc
400 The IRC notification bot is a nice feature for remote teams that want
401 to handle issues and want to have a quick and easy way to get simple
402 notifications. Right now the bot notifies of the following actions:
403 - New Issues
404 - Blocked emails
405 - Issues that got their assignment list changed
406
407 NOTE: You will need to manually edit the bot.php script to set your
408 appropriate preferences, like IRC server and channel that the bot
409 should join.
410
411 %description irc -l pl
412 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
413 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
414 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
415 nastêpuj±cych zdarzeniach:
416 - nowych sprawach
417 - zablokowanych listach
418 - sprawach, dla których zmieni³a siê lista powi±zañ
419
420 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
421 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
422
423 %package cli
424 Summary:        Eventum command-line interface
425 Summary(pl):    Interfejs linii poleceñ dla Eventum
426 Group:          Applications/WWW
427 Requires:       %{name}-base = %{version}-%{release}
428 Requires:       php-cli
429 Requires:       php-common >= 3:4.1.0
430 Requires:       php-pear-XML_RPC
431
432 %description cli
433 The Eventum command-line interface allows you to access most of the
434 features of the web interface straight from your command shell.
435
436 %description cli -l pl
437 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
438 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
439
440 %package scm
441 Summary:        Eventum SCM integration
442 Summary(pl):    Integracja SCM dla Eventum
443 Group:          Applications/WWW
444 Requires:       %{name}-base = %{version}-%{release}
445 Requires:       php-cli
446 Requires:       php-common >= 3:4.1.0
447 Requires:       php-pcre
448
449 %description scm
450 This feature allows your software development teams to integrate your
451 Source Control Management system with your Issue Tracking System.
452
453 The integration is implemented in such a way that it will be forward
454 compatible with pretty much any SCM system, such as CVS.
455
456 For installation see
457 </eventum/help.php?topic=scm_integration_installation>.
458
459 %description scm -l pl
460 Ten pakiet pozwala zespo³om programistów na integracjê systemu
461 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
462 ¶ledzenia spraw.
463
464 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
465 prawie ka¿dym systemem SCM, jak np. CVS.
466
467 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
468 </eventum/help.php?topic=scm_integration_installation>.
469
470 %prep
471 %setup -q %{?_snap:-n %{name}-%{_snap}}
472 # undos the source
473 find . -type f -print0 | xargs -0 sed -i -e 's,\r$,,'
474
475 rm -f setup.conf.php # not to be installed by *.php glob
476 rm -rf misc/upgrade/*v1.[123]* # too old to support in PLD Linux
477 rm -f misc/upgrade/flush_compiled_templates.php
478 rm -rf misc/upgrade/*/upgrade_config.php # not needed in PLD Linux
479
480 # sample, not used in eventum
481 rm -f rpc/xmlrpc_client.php
482
483 # bug fixes.
484 %patch0 -p1
485 %patch1 -p1
486 %patch2 -p1
487 %patch3 -p1
488 %patch4 -p1
489 %patch5 -p1
490 %patch6 -p1
491 %patch7 -p1
492 %patch8 -p1
493 %patch9 -p1
494 %patch10 -p1
495 %{?with_order_patch:%patch11 -p1}
496 %patch12 -p1
497 %patch13 -p1
498 %patch14 -p1
499 %patch15 -p1
500 %patch16 -p1
501 %patch17 -p1
502 %patch18 -p1
503 #%patch19 -p1
504 %patch20 -p1
505
506 # packaging
507 %patch100 -p1
508 %patch101 -p1
509 %patch102 -p1
510 %patch103 -p1
511 %patch104 -p1
512 %patch105 -p1
513 %patch106 -p1
514 %patch107 -p1
515
516 cat <<'EOF'> mysql-permissions.sql
517 # use this schema if you want to grant permissions manually instead of using setup
518 # this schema is extracted from setup/index.php.
519 GRANT SELECT, UPDATE, DELETE, INSERT, ALTER, DROP, CREATE, INDEX ON eventum.* TO 'eventum'@'localhost' IDENTIFIED BY 'password';
520 EOF
521
522 sed -e '1s,#!.*/bin/php -q,#!%{_bindir}/php,' misc/cli/eventum > %{name}-cli
523 sed -e '1i#!%{_bindir}/php' misc/scm/process_cvs_commits.php > %{name}-scm
524 sed -e '1i#!%{_bindir}/php' misc/irc/bot.php > %{name}-bot
525 mv misc/cli/eventumrc_example eventumrc
526 sed -i -e '1i#!%{_bindir}/php' misc/*.php
527 chmod +x misc/*.php
528 mv include/private_key.php private_key.php.in
529
530 # replace in remaining scripts config.inc.php to system one
531 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
532         s,include_once(".*config.inc.php"),include_once("%{_webappdir}/core.php"),
533 '
534
535 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
536         s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_webappdir}/private_key.php"),
537 '
538
539 # remove backups from patching as we use globs to package files to buildroot
540 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
541
542 %install
543 rm -rf $RPM_BUILD_ROOT
544 install -d \
545         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
546         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
547         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
548         $RPM_BUILD_ROOT/var/log/{archiv/,}%{name} \
549         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
550         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
551
552 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
553 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
554 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
555 cp -a templates $RPM_BUILD_ROOT%{_appdir}
556 cp -a include/{customer,custom_field,jpgraph,workflow} $RPM_BUILD_ROOT%{_appdir}/include
557 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
558 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
559 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
560
561 cp -a favicon.ico $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
562 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/setup/config.inc.php
563 install %{SOURCE13} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
564
565 # cli
566 install -d $RPM_BUILD_ROOT%{_appdir}/cli
567 cp -a misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
568 cp -a misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
569 install %{name}-cli $RPM_BUILD_ROOT%{_bindir}/%{name}
570 install %{name}-bot $RPM_BUILD_ROOT%{_sbindir}
571
572 # scm
573 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
574 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
575
576 # private key
577 cp -a private_key.php.in $RPM_BUILD_ROOT%{_webappdir}/private_key.php
578
579 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
580 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
581 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
582 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
583 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
584 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
585 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
586 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
587 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
588
589 sed -e '
590 s,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}}%{?_rc:-%{_rc}},
591 s,%%{PHP_PEAR_DIR}%%,%{php_pear_dir},
592 s,%%{APP_PATH}%%,%{_appdir},
593 s,%%{SMARTY_DIR}%%,%{_smartydir},
594 s,%%{SYSCONFDIR}%%,%{_webappdir},
595 ' %{SOURCE10} > $RPM_BUILD_ROOT%{_webappdir}/core.php
596
597 # config
598 > $RPM_BUILD_ROOT%{_webappdir}/setup.php
599 mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_webappdir}/config}.php
600
601 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
602 # These plugins are not in Smarty package (Smarty-2.6.2-3)
603 cp -a \
604         include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
605         include/Smarty/plugins/modifier.highlight_quoted.php \
606         $RPM_BUILD_ROOT%{_smartyplugindir}
607
608 # qmail router
609 %if %{with qmail}
610 d=$RPM_BUILD_ROOT/var/lib/%{name}
611 echo 'root' > $d/.qmail
612 echo 'root' > $d/.qmail-default
613 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
614 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
615 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
616 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
617 %endif
618 # postfix router
619 install %{SOURCE14} $RPM_BUILD_ROOT%{_libdir}/router-postfix
620
621 install -D %{SOURCE15} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
622
623 %clean
624 rm -rf $RPM_BUILD_ROOT
625
626 %pre
627 %addusertogroup http %{name}
628
629 %post
630 # check if the package is configured.
631 if grep -q 'header("Location: setup/")' %{_webappdir}/config.php; then
632 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
633 %banner %{name} -e <<EOF
634
635 You haven't yet configured Eventum!
636 Please open in browser <http://localhost/eventum/>
637 If you need access from elsewhere, you need to edit
638 %{_webappdir}/apache.conf and restart apache.
639
640 IMPORTANT: When You have configured Eventum, please uninstall the
641 setup package, so that %{name}-setup is able to secure your Eventum
642 installation.
643
644 EOF
645 #' vim syntax hack
646 else
647 %banner %{name} -e <<EOF
648
649 You haven't yet configured Eventum!
650
651 To setup eventum, please install %{name}-setup and open in browser
652 <http://localhost/eventum/>.
653 If you need access from elsewhere, you need to edit
654 %{_webappdir}/apache.conf and restart apache.
655
656 IMPORTANT: When You have configured Eventum, please uninstall the
657 setup package, so that %{name}-setup is able to secure your Eventum
658 installation.
659
660 EOF
661 #' vim syntax hack
662 fi
663
664 elif grep -q 'DEFAULTPRIVATEKEY' %{_webappdir}/private_key.php; then
665 %banner %{name} -e <<EOF
666
667 You have default private key installed!
668
669 Install %{name}-setup and open up http://yourserver/eventum/setup/
670 -- that will help you setup initial config.
671
672 when have configured Eventum, please uninstall the setup package,
673 so that %{name}-setup is able to secure your Eventum installation.
674
675 EOF
676         elif [ -d %{_appdir}/setup ]; then
677 %banner %{name} -e <<EOF
678
679 If you have have configured Eventum, please uninstall the setup package,
680 so that %{name}-setup is able to secure your Eventum installation.
681
682 EOF
683 fi
684
685 # nuke Smarty templates cache after upgrade
686 rm -f /var/cache/eventum/*.php
687
688 %preun
689 if [ "$1" = "0" ]; then
690         # nuke cache
691         rm -f /var/cache/eventum/*.php 2>/dev/null || :
692 fi
693
694 %pre base
695 %groupadd -P %{name}-base -g 146 %{name}
696 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
697
698 %postun base
699 if [ "$1" = "0" ]; then
700         %userremove %{name}
701         %groupremove %{name}
702 fi
703
704 %post router-qmail
705 CF=/etc/qmail/control/virtualdomains
706 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
707         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_webappdir}/config.php 2>/dev/null)
708         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
709         umask 022
710         echo "#${FQDN}:%{name}" >> $CF
711
712 %banner %{name}-qmail -e <<EOF
713
714 Added "#${FQDN}:%{name}" to $CF,
715 Please verify that it is correct and restart qmail:
716 # service qmail reload
717
718 Consult qmail-send(8) for more information on virtualdomains.
719
720 EOF
721 fi
722
723 %preun router-qmail
724 if [ "$1" = "0" ]; then
725         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
726 fi
727
728 %post setup
729 chmod 660 %{_webappdir}/{config,private_key}.php
730 chown root:eventum %{_webappdir}/{config,private_key}.php
731
732 %postun setup
733 if [ "$1" = "0" ]; then
734         chmod 640 %{_webappdir}/{config,private_key}.php
735         chown root:eventum %{_webappdir}/{config,private_key}.php
736 fi
737
738 %post irc
739 /sbin/chkconfig --add eventum-irc
740 %service eventum-irc restart "Eventum IRC Bot"
741
742 %preun irc
743 if [ "$1" = 0 ]; then
744         %service eventum-irc stop
745         /sbin/chkconfig --del eventum-irc
746 fi
747
748 %triggerin -- apache1
749 %webapp_register apache %{_webapp}
750
751 %triggerun -- apache1
752 %webapp_unregister apache %{_webapp}
753
754 %triggerin -- apache < 2.2.0, apache-base
755 %webapp_register httpd %{_webapp}
756
757 %triggerun -- apache < 2.2.0, apache-base
758 %webapp_unregister httpd %{_webapp}
759
760 # FIXME
761 # only one upgrade trigger is called if you're upgrading over two
762 # versions, say 1.5 to 1.5.3, only 1.5.3 trigger is called.
763 # use common trigger (the highest version and rpmvercmp from poldek?)
764 %triggerpostun -- eventum < 1.5.1-0.257
765 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5_to_v1.5.1 <<EOF
766 database_changes.php Perform database changes
767 EOF
768
769 %triggerpostun -- eventum < 1.5.2-0.289
770 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.1_to_v1.5.2 <<EOF
771 database_changes.php Perform database changes
772 set_priority_ranks.php Fix the ranking of priority values
773 EOF
774
775 %triggerpostun -- eventum < 1.5.3-0.291
776 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.2_to_v1.5.3 <<EOF
777 database_changes.php Perform database changes
778 EOF
779
780 %triggerpostun -- eventum < 1.5.4-1.12
781 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.3_to_v1.5.4 <<EOF
782 database_changes.php Perform database changes
783 EOF
784
785 %triggerpostun -- eventum < 1.6.0-RC2.6
786 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.5_to_v1.6.0 <<EOF
787 database_changes.php Perform database changes
788 upgrade_saved_searches.php Upgrade existing custom filters (saved searches)
789 EOF
790
791 %triggerpostun -- eventum < 1.6.1-0.2
792 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.0_to_v1.6.1 <<EOF
793 database_changes.php Perform database changes
794 EOF
795
796 %triggerpostun irc -- eventum-irc < 1.6.1-3.14
797 sed -i -e '
798 s,\$irc_host,$irc_server_hostname,
799 s,\$irc_port,$irc_server_port,
800 s,\$irc_nick,$nickname,
801 s,\$irc_realname,$realname,
802 s,\$irc_username,$username,
803 s,\$irc_password,$password,
804 ' /etc/eventum/irc.php
805
806 %triggerpostun -- eventum < 1.7.0-2.0.48
807 # migrate from apache-config macros
808 if [ -f /etc/%{name}/apache.conf.rpmsave ]; then
809         if [ -d /etc/apache/webapps.d ]; then
810                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
811                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
812         fi
813
814         if [ -d /etc/httpd/webapps.d ]; then
815                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
816                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
817         fi
818 fi
819
820 if [ -L /etc/apache/conf.d/99_%{_webapp}.conf ]; then
821         /usr/sbin/webapp register apache %{_webapp}
822         rm -f /etc/apache/conf.d/99_%{_webapp}.conf
823         %service -q apache reload
824 fi
825 if [ -L /etc/httpd/httpd.conf/99_%{_webapp}.conf ]; then
826         /usr/sbin/webapp register httpd %{_webapp}
827         rm -f /etc/httpd/httpd.conf/99_%{_webapp}.conf
828         %service -q httpd reload
829 fi
830
831 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.1_to_v1.7.0 <<EOF
832 database_changes.php Perform database changes
833 set_root_message_ids.php Set iss_root_message_id
834 EOF
835
836 # regular configs
837 for i in apache.conf config.php private_key.php setup.php; do
838         if [ -f /etc/eventum/$i.rpmsave ]; then
839                 mv -f %{_webappdir}/$i{,.rpmnew}
840                 mv -f /etc/eventum/$i.rpmsave %{_webappdir}/$i
841         fi
842 done
843
844 %triggerpostun cli -- %{name}-cli < 1.7.0-3.4
845 if [ -f %{_webappdir}/cli.php.rpmsave ]; then
846         mv -f %{_sysconfdir}/cli.php{,.rpmnew}
847         mv -f %{_webappdir}/cli.php.rpmsave %{_sysconfdir}/cli.php
848 fi
849
850 %triggerpostun irc -- %{name}-irc < 1.7.0-3.4
851 if [ -f %{_webappdir}/irc.php.rpmsave ]; then
852         mv -f %{_sysconfdir}/irc.php{,.rpmnew}
853         mv -f %{_webappdir}/irc.php.rpmsave %{_sysconfdir}/irc.php
854 fi
855
856 %files
857 %defattr(644,root,root,755)
858 %doc ChangeLog FAQ INSTALL README UPGRADE CONTRIB
859 %doc docs/* setup/schema.sql mysql-permissions.sql
860 %attr(751,root,root) %dir %{_webappdir}
861 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
862 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
863 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
864 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
865 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
866 %attr(640,root,eventum) %config %verify(not mtime) %{_webappdir}/core.php
867
868 %dir %attr(731,root,eventum) /var/log/%{name}
869 %attr(620,root,eventum) %ghost /var/log/%{name}/*
870 %dir %attr(750,root,root) /var/log/archiv/%{name}
871 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
872
873 %dir %{_appdir}/htdocs
874 %{_appdir}/htdocs/*.php
875 %{_appdir}/htdocs/*.ico
876 %{_appdir}/htdocs/css
877 %{_appdir}/htdocs/customer
878 %{_appdir}/htdocs/images
879 %{_appdir}/htdocs/js
880 %{_appdir}/htdocs/manage
881 %{_appdir}/htdocs/reports
882 %{_appdir}/htdocs/rpc
883 %{_appdir}/htdocs/misc
884 %{_appdir}/templates
885 %dir %{_appdir}/upgrade
886 %attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
887 %{_appdir}/upgrade/[!u]*
888 %{_smartyplugindir}
889
890 %dir %{_appdir}/include
891 %{_appdir}/include/customer
892 %{_appdir}/include/custom_field
893 %{_appdir}/include/jpgraph
894 %{_appdir}/include/workflow
895 %{_appdir}/include/class.[!m]*.php
896 %{_appdir}/include/class.mail.php
897 %{_appdir}/include/class.mail_queue.php
898 %{_appdir}/include/class.mime_helper.php
899 %{_appdir}/include/class.misc.php
900 %{_appdir}/include/db_access.php
901
902 %dir %attr(730,root,eventum) /var/run/%{name}
903 %dir %attr(730,root,eventum) /var/cache/%{name}
904
905 %files base
906 %defattr(644,root,root,755)
907 %attr(751,root,root) %dir %{_sysconfdir}
908 %dir %{_libdir}
909 %dir %{_appdir}
910 # qmail will ignore user, if it's home directory is not owned
911 %attr(750,eventum,eventum) %dir /var/lib/%{name}
912 # saved mail copies
913 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_emails
914 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_drafts
915 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_notes
916
917 %files setup
918 %defattr(644,root,root,755)
919 %{_appdir}/htdocs/setup
920
921 %files mail-queue
922 %defattr(644,root,root,755)
923 %attr(755,root,root) %{_appdir}/process_mail_queue.php
924 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
925
926 %files mail-download
927 %defattr(644,root,root,755)
928 %attr(755,root,root) %{_appdir}/download_emails.php
929 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
930
931 %files reminder
932 %defattr(644,root,root,755)
933 %attr(755,root,root) %{_appdir}/check_reminders.php
934 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
935
936 %files monitor
937 %defattr(644,root,root,755)
938 %{_appdir}/include/class.monitor.php
939 %attr(755,root,root) %{_appdir}/monitor.php
940 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
941
942 %files route-drafts
943 %defattr(644,root,root,755)
944 %attr(755,root,root) %{_appdir}/route_drafts.php
945
946 %files route-emails
947 %defattr(644,root,root,755)
948 %attr(755,root,root) %{_appdir}/route_emails.php
949
950 %files route-notes
951 %defattr(644,root,root,755)
952 %attr(755,root,root) %{_appdir}/route_notes.php
953
954 %if %{with qmail}
955 %files router-qmail
956 %defattr(644,root,root,755)
957 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
958 %attr(755,root,root) %{_libdir}/router-qmail
959 %endif
960
961 %files router-postfix
962 %defattr(644,root,root,755)
963 %attr(755,root,root) %{_libdir}/router-postfix
964
965 %files irc
966 %defattr(644,root,root,755)
967 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
968 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
969 %attr(755,root,root) %{_sbindir}/%{name}-bot
970 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
971
972 %files cli
973 %defattr(644,root,root,755)
974 %doc eventumrc
975 %attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
976 %attr(755,root,root) %{_bindir}/%{name}
977 %{_appdir}/cli
978
979 %files scm
980 %defattr(644,root,root,755)
981 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
982 %attr(755,root,root) %{_libdir}/scm
This page took 0.171441 seconds and 4 git commands to generate.