]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
add HSTS sample
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1
6 #define         subver  105
7 #define         githash 9c49ee5
8 %define         php_min_version 5.3.3
9 %include        /usr/lib/rpm/macros.php
10 Summary:        Eventum Issue / Bug tracking system
11 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
12 Name:           eventum
13 Version:        3.0.3
14 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
15 License:        GPL v2
16 Group:          Applications/WWW
17 Source0:        https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
18 # Source0-md5:  0ecee925e49d96cc827e99089848f55a
19 #Source0:       %{name}-%{version}-%{subver}-g%{githash}.tar.gz
20 Source1:        %{name}-apache.conf
21 Source2:        %{name}-mail-queue.cron
22 Source3:        %{name}-mail-download.cron
23 Source4:        %{name}-reminder.cron
24 Source5:        %{name}-monitor.cron
25 Source6:        %{name}-cvs.php
26 Source7:        %{name}-irc.php
27 Source8:        %{name}-irc.init
28 Source9:        %{name}-irc.sysconfig
29 Source10:       sphinx.crontab
30 Source13:       %{name}-router-postfix.sh
31 Source14:       %{name}.logrotate
32 Source15:       %{name}-lighttpd.conf
33 Source16:       http://www.isocra.com/images/updown2.gif
34 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
35 Source17:       %{name}.tmpfiles
36 Patch2:         %{name}-order.patch
37 #Patch3:                group-users.patch
38 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
39 # packaging patches that probably never go upstream
40 Patch100:       %{name}-paths.patch
41 Patch101:       %{name}-cvs-config.patch
42 Patch105:       %{name}-bot-reconnect.patch
43 Patch107:       %{name}-gettext.patch
44 Patch108:       autoload.patch
45 # some tests
46 Patch200:       %{name}-fixed-nav.patch
47 URL:            http://eventum.mysql.org/
48 BuildRequires:  /usr/bin/php
49 BuildRequires:  gettext-devel
50 BuildRequires:  php(core) >= %{php_min_version}
51 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
52 BuildRequires:  rpmbuild(macros) >= 1.654
53 BuildRequires:  sed >= 4.0
54 Requires:       %{name}-base = %{version}-%{release}
55 Requires:       fonts-TTF-RedHat-liberation
56 Requires:       php(core) >= %{php_min_version}
57 Requires:       php(filter)
58 Requires:       php(iconv)
59 Requires:       php(imap)
60 Requires:       php(json)
61 Requires:       php(mbstring)
62 Requires:       php(mysqli)
63 Requires:       php(pcre)
64 Requires:       php(session)
65 Requires:       php-Smarty >= 3.1
66 Requires:       php-Smarty-plugin-gettext
67 Requires:       php-pear-DB
68 Requires:       php-pear-Mail
69 Requires:       php-pear-Mail_Mime
70 Requires:       php-pear-Mail_mimeDecode
71 Requires:       php-pear-Math_Stats
72 Requires:       php-pear-Net_DIME
73 Requires:       php-pear-Net_SMTP
74 Requires:       php-pear-Net_Socket
75 Requires:       php-pear-Net_URL
76 Requires:       php-pear-Net_UserAgent_Detect
77 Requires:       php-pear-PEAR-core
78 Requires:       php-pear-Text_Diff
79 Requires:       php-pear-XML_RPC
80 Requires:       phplot >= 5.8.0
81 Requires:       webapps
82 Requires:       webserver(access)
83 Requires:       webserver(alias)
84 Requires:       webserver(indexfile)
85 Requires:       webserver(php) >= 4.2.0
86 Suggests:       localedb
87 Suggests:       php-pear-Net_LDAP2
88 Suggests:       webserver(setenv)
89 Conflicts:      logrotate < 3.8.0
90 BuildArch:      noarch
91 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
93 %define         _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
94
95 # exclude optional php dependencies
96 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
97
98 %define         _noautoreq      %{_noautophp}
99
100 %define         _libdir         %{_prefix}/lib/%{name}
101 %define         _appdir         %{_datadir}/%{name}
102 %define         _smartydir      %{php_data_dir}/Smarty
103 %define         _webapps        /etc/webapps
104 %define         _webapp         %{name}
105 %define         _webappdir      %{_webapps}/%{_webapp}
106 %define         _sysconfdir     /etc/%{name}
107
108 %description
109 Eventum is a user-friendly and flexible issue tracking system that can
110 be used by a support department to track incoming technical support
111 requests, or by a software development team to quickly organize tasks
112 and bugs. Eventum is used by the MySQL AB Technical Support team, and
113 has allowed us to dramatically improve our response times.
114
115 %description -l pl.UTF-8
116 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
117 może być używany przez dział obsługi do śledzenia przychodzących żądań
118 obsługi technicznej albo przez zespół tworzący oprogramowanie do
119 szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
120 Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
121 reakcji.
122
123 %package base
124 Summary:        Eventum base package
125 Summary(pl.UTF-8):      Podstawowy pakiet Eventum
126 Group:          Applications/WWW
127 Requires(postun):       /usr/sbin/groupdel
128 Requires(postun):       /usr/sbin/userdel
129 Requires(pre):  /bin/id
130 Requires(pre):  /usr/bin/getgid
131 Requires(pre):  /usr/sbin/groupadd
132 Requires(pre):  /usr/sbin/useradd
133 Provides:       group(eventum)
134 Provides:       user(eventum)
135
136 %description base
137 This package contains base directory structure for Eventum.
138
139 %description base -l pl.UTF-8
140 Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
141
142 %package setup
143 Summary:        Eventum setup package
144 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
145 Group:          Applications/WWW
146 Requires:       %{name} = %{version}-%{release}
147
148 %description setup
149 Install this package to configure initial Eventum installation. You
150 should uninstall this package when you're done, as it considered
151 insecure to keep the setup files in place.
152
153 %description setup -l pl.UTF-8
154 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
155 pierwszej instalacji. Potem należy go odinstalować, jako że
156 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
157
158 %package doc
159 Summary:        Eventum documentation and Wiki
160 Group:          Documentation
161
162 %description doc
163 Eventum documentation and copy of Wiki.
164
165 %package mail-queue
166 Summary:        Eventum mail queue process
167 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
168 Group:          Applications/WWW
169 Requires:       %{name} = %{version}-%{release}
170 Requires:       crondaemon
171
172 %description mail-queue
173 Beginning with the first release of Eventum, emails are not directly
174 sent out from the various scripts, but rather added to a mail queue
175 table that is processed by a cron job. If an email cannot be sent, it
176 will be marked as such in the mail queue log, and the cron job script
177 will re-try to send it again the next time it runs.
178
179 This package contains the cron job.
180
181 %description mail-queue -l pl.UTF-8
182 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
183 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
184 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
185 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
186 następnym razem.
187
188 Ten pakiet zawiera zadanie dla crona.
189
190 %package mail-download
191 Summary:        Eventum email download
192 Summary(pl.UTF-8):      Ściąganie poczty Eventum
193 Group:          Applications/WWW
194 Requires:       %{name} = %{version}-%{release}
195 Requires:       crondaemon
196
197 %description mail-download
198 In order for Eventum's email integration feature to work, you need to
199 setup a cron job to run the script every so often.
200
201 This package contains the cron job.
202
203 %description mail-download -l pl.UTF-8
204 Aby integracja poczty elektronicznej w Eventum działała, trzeba
205 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
206 często.
207
208 Ten pakiet zawiera zadanie dla crona.
209
210 %package reminder
211 Summary:        Eventum Reminder System
212 Summary(pl.UTF-8):      System przypominania dla Eventum
213 Group:          Applications/WWW
214 Requires:       %{name} = %{version}-%{release}
215 Requires:       crondaemon
216
217 %description reminder
218 The reminder system was designed with the objective as serving as a
219 safe net for issues that need attention. Depending on what
220 configuration you create, you may have several reminders (or alerts)
221 be sent out whenever an issue needs attention, for whatever parameter
222 you may deem necessary.
223
224 This package contains the cron job.
225
226 %description reminder -l pl.UTF-8
227 System przypominania został zaprojektowany tak, aby służył jako
228 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
229 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
230 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
231 uważać za potrzebny.
232
233 Ten pakiet zawiera zadanie dla crona.
234
235 %package monitor
236 Summary:        Eventum Heartbeat Monitor
237 Summary(pl.UTF-8):      Monitor życia dla Eventum
238 Group:          Applications/WWW
239 Requires:       %{name} = %{version}-%{release}
240 Requires:       crondaemon
241 Requires:       php(posix)
242
243 %description monitor
244 The heartbeat monitor is a feature designed for the administrator that
245 wants to be alerted whenever a common problem in Eventum is detected,
246 like the database server not being available anymore, or maybe when
247 the recommended permissions for certain configuration files are
248 changed.
249
250 Please note that before running the heartbeat monitor, you may need to
251 customize some of the checks to be appropriate for your own system,
252 particularly the permission and file checks on
253 Monitor::checkConfiguration().
254
255 This package contains the cron job.
256
257 %description monitor -l pl.UTF-8
258 Monitor życia to funkcjonalność zaprojektowana dla administratora
259 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
260 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
261 do plików konfiguracyjnych.
262
263 Należy zauważyć, że przed uruchomieniem tego monitora może być
264 konieczne dostosowanie niektórych testów do systemu, w szczególności
265 testów uprawnień i plików w Monitor::checkConfiguration().
266
267 Ten pakiet zawiera zadanie dla crona.
268
269 %package route-drafts
270 Summary:        Eventum Draft Routing
271 Summary(pl.UTF-8):      Przekazywanie szkiców dla Eventum
272 Group:          Applications/WWW
273 Requires:       %{name} = %{version}-%{release}
274 Requires:       eventum(router)
275
276 %description route-drafts
277 The draft routing feature is used to automatically associate a thread
278 of drafts into an Eventum issue. By setting up Postfix to deliver
279 emails sent to a specific address (usually draft-<number>@<domain>) to
280 the above script, users are able to send drafts written in their mail
281 client to be stored in Eventum. These drafts will NOT broadcasted to
282 the notification list.
283
284 %description route-drafts -l pl.UTF-8
285 Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
286 problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
287 wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
288 skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
289 kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
290 na listę powiadomień.
291
292 %package route-emails
293 Summary:        Eventum Email Routing
294 Summary(pl.UTF-8):      Przekazywanie poczty dla Eventum
295 Group:          Applications/WWW
296 Requires:       %{name} = %{version}-%{release}
297 Requires:       eventum(router)
298
299 %description route-emails
300 The email routing feature is used to automatically associate a thread
301 of emails into an Eventum issue. By setting up Postfix to deliver
302 emails sent to a specific address (usually issue-<number>@<domain>) to
303 the above script, users are able to use their email clients to reply
304 to emails coming from Eventum, and those replies will be automatically
305 associated with the issue and broadcasted to the entire notification
306 list.
307
308 %description route-emails -l pl.UTF-8
309 Funkcjonalność przekazywania poczty służy do automatycznego wiązania
310 wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
311 aby dostarczał listy wysyłane na pewien adres (zwykle
312 issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
313 używać klientów pocztowych do odpowiadania na listy przychodzące z
314 Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
315 rozprowadzane do całej listy ogłoszeniowej.
316
317 %package route-notes
318 Summary:        Eventum Note Routing
319 Summary(pl.UTF-8):      Przekazywanie notatek dla Eventum
320 Group:          Applications/WWW
321 Requires:       %{name} = %{version}-%{release}
322 Requires:       eventum(router)
323
324 %description route-notes
325 The note routing feature is used to automatically associate a thread
326 of notes into an Eventum issue. By setting up Postfix to deliver
327 emails sent to a specific address (usually note-<number>@<domain>) to
328 the above script, users are able to use their email clients to reply
329 to internal notes coming from Eventum, and those replies will be
330 automatically associated with the issue and broadcasted to the
331 notification list staff members.
332
333 %description route-notes -l pl.UTF-8
334 Funkcjonalność przekazywania notatek służy do automatycznego wiązania
335 wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
336 dostarczał listy wysyłane na pewien adres (zwykle
337 note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
338 używać klientów pocztowych do odpowiadania na wewnętrzne notatki
339 pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
340 sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
341
342 %package router-postfix
343 Summary:        Eventum Mail Routing - Postfix
344 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
345 Group:          Applications/Mail
346 Requires:       %{name} = %{version}-%{release}
347 Requires:       postfix
348 Provides:       eventum(router)
349 Obsoletes:      eventum(router)
350
351 %description router-postfix
352 This package provides way of routing notes and emails back to Eventum
353 via Postfix.
354
355 The Postfix configuration instructions you can find from
356 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
357
358 %description router-postfix -l pl.UTF-8
359 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
360 przez Postfiksa.
361
362 Opis konfiguracji Postfiksa można znaleźć pod adresem
363 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
364
365 %package irc
366 Summary:        Eventum IRC Notification Bot
367 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
368 Group:          Applications/WWW
369 Requires(post,preun):   /sbin/chkconfig
370 Requires:       %{name} = %{version}-%{release}
371 Requires:       php(sockets)
372 Requires:       php-pear-Net_SmartIRC
373 Requires:       rc-scripts >= 0.4.0.18
374
375 %description irc
376 The IRC notification bot is a nice feature for remote teams that want
377 to handle issues and want to have a quick and easy way to get simple
378 notifications. Right now the bot notifies of the following actions:
379 - New Issues
380 - Blocked emails
381 - Issues that got their assignment list changed
382
383 NOTE: You will need to manually edit the bot.php script to set your
384 appropriate preferences, like IRC server and channel that the bot
385 should join.
386
387 %description irc -l pl.UTF-8
388 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
389 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
390 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
391 następujących zdarzeniach:
392 - nowych sprawach
393 - zablokowanych listach
394 - sprawach, dla których zmieniła się lista powiązań
395
396 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
397 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
398
399 %package cli
400 Summary:        Eventum command-line interface
401 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
402 Group:          Applications/WWW
403 Requires:       %{name}-base = %{version}-%{release}
404 Requires:       php(core) >= %{php_min_version}
405 Requires:       php(phar)
406 Requires:       php-pear-XML_RPC
407
408 %description cli
409 The Eventum command-line interface allows you to access most of the
410 features of the web interface straight from your command shell.
411
412 %description cli -l pl.UTF-8
413 Interfejs linii poleceń Eventum pozwala na dostęp do większości
414 funkcji interfejsu WWW prosto z linii poleceń powłoki.
415
416 %package scm
417 Summary:        Eventum SCM integration
418 Summary(pl.UTF-8):      Integracja SCM dla Eventum
419 Group:          Applications/WWW
420 Requires:       php(core) >= %{php_min_version}
421 Requires:       php(json)
422 Requires:       php(pcre)
423 Requires:       php(spl)
424 Suggests:       cvs
425 Suggests:       git-core
426 Suggests:       php(openssl)
427 Suggests:       subversion
428
429 %description scm
430 This feature allows your software development teams to integrate your
431 Source Control Management system with your Issue Tracking System.
432
433 The integration is implemented in such a way that it will be forward
434 compatible with pretty much any SCM system, such as CVS.
435
436 For installation see
437 </eventum/help.php?topic=scm_integration_installation>.
438
439 %description scm -l pl.UTF-8
440 Ten pakiet pozwala zespołom programistów na integrację systemu
441 zarządzania źródłami (SCM - Source Control Management) z systemem
442 śledzenia spraw.
443
444 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
445 prawie każdym systemem SCM, jak np. CVS.
446
447 Szczegóły na temat instalacji można przeczytać pod
448 </eventum/help.php?topic=scm_integration_installation>.
449
450 %package sphinx
451 Summary:        Eventum Sphinx Search
452 Group:          Applications/WWW
453 Requires:       %{name} = %{version}-%{release}
454 Requires:       crondaemon
455 Requires:       sphinx
456
457 %description sphinx
458 Sphinx search integration for Eventum.
459
460 This package contains the cron job.
461
462 %prep
463 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
464
465 mv docs/examples .
466
467 # GPL v2
468 rm docs/COPYING
469
470 # bug fixes / features
471 %{?with_order:%patch2 -p1}
472 #%patch3 -p0
473 #%patch4 -p1
474
475 %{?with_order:cp -p %{SOURCE16} htdocs/images}
476
477 #%patch200 -p1
478
479 # produce default sphinx config
480 # must be run before paths.patch
481 %if 0
482 cat <<'EOF' > config/config.php
483 <?php
484 define('APP_SQL_DBTYPE', 'mysql');
485 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
486 define('APP_SQL_DBPORT', 3306);
487 define('APP_SQL_DBNAME', 'eventum');
488 define('APP_SQL_DBUSER', 'mysql');
489 define('APP_SQL_DBPASS', '');
490 define('APP_TABLE_PREFIX', 'eventum_');
491 EOF
492 php config/sphinx.conf.php > config/sphinx.conf
493 rm -f config/config.php
494 %endif
495
496 # packaging
497 %patch100 -p1
498 %patch101 -p1
499 %patch105 -p1
500 %patch107 -p1
501 %patch108 -p1
502
503 %{__sed} -i -e "
504 s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
505 " upgrade/{*/,}*.php
506
507 # remove backups from patching as we use globs to package files to buildroot
508 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
509
510 %build
511 %{__make} -C localization
512
513 %install
514 rm -rf $RPM_BUILD_ROOT
515 install -d \
516         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
517         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
518         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
519         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
520         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
521         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
522         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
523
524 %{__make} install-eventum install-cli install-irc install-scm install-localization \
525         sysconfdir=%{_webappdir} \
526         localedir=%{_localedir} \
527         DESTDIR=$RPM_BUILD_ROOT
528
529 install -d $RPM_BUILD_ROOT%{_appdir}/vendor
530 cp -a vendor/autoload.php vendor/composer $RPM_BUILD_ROOT%{_appdir}/vendor
531 rm $RPM_BUILD_ROOT%{_appdir}/vendor/composer/include_paths.php
532 rm $RPM_BUILD_ROOT%{_appdir}/vendor/composer/autoload_psr4.php
533
534 # unsupported locale
535 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
536
537 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
538 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
539
540 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
541
542 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
543 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
544 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
545 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
546
547 install -d $RPM_BUILD_ROOT/etc/sphinx
548 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
549 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
550
551 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
552 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
553 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
554 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
555 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
556
557 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
558
559 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
560 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
561
562 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
563
564 # postfix router
565 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
566
567 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
568
569 %find_lang %{name}
570
571 # scm
572 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
573
574 %clean
575 rm -rf $RPM_BUILD_ROOT
576
577 %pre
578 %addusertogroup http %{name}
579
580 %post
581 # greate empty ghost files
582 for a in cli.log errors.log irc_bot.log login_attempts.log; do
583         if [ ! -f /var/log/%{name}/$a ]; then
584                 install -m 0620 -o root -g eventum /dev/null /var/log/%{name}/$a
585         fi
586 done
587
588 # run database update if configured
589 test -s %{_webappdir}/config.php && \
590 %{_appdir}/upgrade/update-database.php || :
591
592 # nuke Smarty templates cache after upgrade
593 rm -f /var/cache/eventum/*.php
594
595 # Restart webserver on upgrade to get .mo translations reloaded.
596 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
597 %php_webserver_restart
598
599 %preun
600 if [ "$1" = "0" ]; then
601         # nuke cache
602         rm -f /var/cache/eventum/*.php 2>/dev/null || :
603 fi
604
605 %pre base
606 %groupadd -P %{name}-base -g 146 %{name}
607 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
608
609 %postun base
610 if [ "$1" = "0" ]; then
611         %userremove %{name}
612         %groupremove %{name}
613 fi
614
615 %post setup
616 chmod 660 %{_webappdir}/{config,private_key}.php
617 chown root:http %{_webappdir}/{config,private_key}.php
618
619 %postun setup
620 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
621         chmod 640 %{_webappdir}/{config,private_key}.php
622         chown root:http %{_webappdir}/{config,private_key}.php
623 fi
624
625 %post irc
626 /sbin/chkconfig --add eventum-irc
627 %service eventum-irc restart "Eventum IRC Bot"
628
629 %preun irc
630 if [ "$1" = 0 ]; then
631         %service eventum-irc stop
632         /sbin/chkconfig --del eventum-irc
633 fi
634
635 %triggerin -- apache1 < 1.3.37-3, apache1-base
636 %webapp_register apache %{_webapp}
637
638 %triggerun -- apache1 < 1.3.37-3, apache1-base
639 %webapp_unregister apache %{_webapp}
640
641 %triggerin -- apache < 2.2.0, apache-base
642 %webapp_register httpd %{_webapp}
643
644 %triggerun -- apache < 2.2.0, apache-base
645 %webapp_unregister httpd %{_webapp}
646
647 %triggerin -- lighttpd
648 %webapp_register lighttpd %{_webapp}
649
650 %triggerun -- lighttpd
651 %webapp_unregister lighttpd %{_webapp}
652
653 %triggerpostun -- %{name} < 3.0.0-0.2
654 for f in /etc/cron.d/eventum-*; do
655         # crontabs moved to bin
656         %{__sed} -i -e '
657                 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
658                 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
659                 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
660                 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
661         ' $f
662 done
663
664 %files -f %{name}.lang
665 %defattr(644,root,root,755)
666 %attr(751,root,root) %dir %{_webappdir}
667 %attr(751,root,root) %dir %{_webappdir}/custom_field
668 %attr(751,root,root) %dir %{_webappdir}/templates
669 %attr(751,root,root) %dir %{_webappdir}/workflow
670 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
671 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
672 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
673 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
674 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
675 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
676 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
677
678 %dir %attr(731,root,http) /var/log/%{name}
679 %attr(620,root,http) %ghost /var/log/%{name}/*
680 %dir %attr(750,root,root) /var/log/archive/%{name}
681 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
682
683 %dir %{_appdir}/bin
684 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
685
686 %{_appdir}/autoload.php
687 %{_appdir}/init.php
688 %dir %{_appdir}/htdocs
689 %{_appdir}/htdocs/*.php
690 %{_appdir}/htdocs/*.ico
691 %{_appdir}/htdocs/ajax
692 %{_appdir}/htdocs/css
693 %{_appdir}/htdocs/customer
694 %{_appdir}/htdocs/images
695 %{_appdir}/htdocs/js
696 %{_appdir}/htdocs/manage
697 %{_appdir}/htdocs/misc
698 %{_appdir}/htdocs/reports
699 %{_appdir}/htdocs/rpc
700 %{_appdir}/htdocs/components
701 %{_appdir}/templates
702
703 %dir %{_appdir}/upgrade
704 %{_appdir}/upgrade/flush_compiled_templates.php
705 %{_appdir}/upgrade/*.sql
706 %attr(755,root,root) %{_appdir}/upgrade/update-database.php
707 %attr(755,root,root) %{_appdir}/upgrade/ldap_import.php
708 %attr(755,root,root) %{_appdir}/upgrade/ldap_update_users.php
709 %attr(755,root,root) %{_appdir}/upgrade/scm_trac_import.php
710 %{_appdir}/upgrade/patches
711
712 %dir %{_appdir}/vendor
713 %dir %{_appdir}/vendor/composer
714 %{_appdir}/vendor/autoload.php
715 %{_appdir}/vendor/composer/ClassLoader.php
716 %{_appdir}/vendor/composer/autoload_*.php
717
718 %dir %{_appdir}/lib
719 %{_appdir}/lib/eventum
720 %exclude %{_appdir}/lib/eventum/class.monitor.php
721
722 %{systemdtmpfilesdir}/%{name}.conf
723 %dir %attr(730,root,http) /var/run/%{name}
724 %dir %attr(730,root,http) /var/cache/%{name}
725
726 %files base
727 %defattr(644,root,root,755)
728 %attr(751,root,root) %dir %{_sysconfdir}
729 %dir %{_libdir}
730 %dir %{_appdir}
731 %dir /var/lib/%{name}
732 # saved mail copies
733 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
734 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
735 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
736
737 %files setup
738 %defattr(644,root,root,755)
739 %{_appdir}/htdocs/setup
740
741 %files doc
742 %defattr(644,root,root,755)
743 %doc docs/*
744 %{_examplesdir}/%{name}-%{version}
745
746 %files mail-queue
747 %defattr(644,root,root,755)
748 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
749 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
750 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
751
752 %files mail-download
753 %defattr(644,root,root,755)
754 %attr(755,root,root) %{_appdir}/bin/download_emails.php
755 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
756
757 %files reminder
758 %defattr(644,root,root,755)
759 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
760 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
761
762 %files monitor
763 %defattr(644,root,root,755)
764 %{_appdir}/lib/eventum/class.monitor.php
765 %attr(755,root,root) %{_appdir}/bin/monitor.php
766 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
767
768 %files route-drafts
769 %defattr(644,root,root,755)
770 %attr(755,root,root) %{_appdir}/bin/route_drafts.php
771
772 %files route-emails
773 %defattr(644,root,root,755)
774 %attr(755,root,root) %{_appdir}/bin/route_emails.php
775
776 %files route-notes
777 %defattr(644,root,root,755)
778 %attr(755,root,root) %{_appdir}/bin/route_notes.php
779
780 %files router-postfix
781 %defattr(644,root,root,755)
782 %attr(755,root,root) %{_libdir}/router-postfix
783
784 %files irc
785 %defattr(644,root,root,755)
786 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
787 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
788 %attr(755,root,root) %{_sbindir}/%{name}-irc-bot
789 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
790
791 %files cli
792 %defattr(644,root,root,755)
793 %doc cli/eventumrc
794 %attr(755,root,root) %{_bindir}/%{name}
795
796 %files scm
797 %defattr(644,root,root,755)
798 %attr(751,root,root) %dir %{_sysconfdir}
799 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
800 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
801 %attr(755,root,root) %{_sbindir}/eventum-git-hook
802 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
803 %attr(755,root,root) %{_sbindir}/helpers.php
804
805 %files sphinx
806 %defattr(644,root,root,755)
807 %{_webappdir}/sphinx.conf.php
808 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
809 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.080792 seconds and 4 git commands to generate.