]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- cleanups
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 # - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
9 #
10 # Conditional build:
11 %bcond_with     qmail   # build the router-qmail subpackage
12 #
13 # snapshot: DATE
14 %define _snap 20060330
15
16 %define _rel    0.5
17
18 %include        /usr/lib/rpm/macros.php
19 Summary:        Eventum Issue / Bug tracking system
20 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
21 Name:           eventum
22 Version:        1.7.0
23 Release:        %{?_snap:4.%{_snap}.}%{?_rc:%{_rc}.}%{_rel}
24 License:        GPL
25 Group:          Applications/WWW
26 #Source0:       http://mysql.dataphone.se/Downloads/%{name}/%{name}-%{version}.tar.gz
27 Source0:        http://downloads.mysql.com/snapshots/eventum/%{name}-nightly-%{_snap}.tar.gz
28 # Source0-md5:  bef923d9f8c1555ac16a53ba57820372
29 Source1:        %{name}-apache.conf
30 Source2:        %{name}-mail-queue.cron
31 Source3:        %{name}-mail-download.cron
32 Source4:        %{name}-reminder.cron
33 Source5:        %{name}-monitor.cron
34 Source6:        %{name}-cvs.php
35 Source7:        %{name}-irc.php
36 Source8:        %{name}-irc.init
37 Source9:        %{name}-irc.sysconfig
38 Source10:       %{name}-config.php
39 Source11:       %{name}-router-qmail.sh
40 Source12:       %{name}-config-setup.php
41 Source13:       %{name}-upgrade.sh
42 Source14:       %{name}-router-postfix.sh
43 Patch0:         %{name}-paths.patch
44 Patch1:         %{name}-cvs-config.patch
45 Patch2:         %{name}-irc-config.patch
46 Patch3:         %{name}-PEAR.patch
47 Patch5:         %{name}-lf.patch
48 Patch7:         %{name}-bot-reconnect.patch
49 Patch8:         %{name}-perms.patch
50 Patch9:         %{name}-httpclient-clientside.patch
51 Patch10:        %{name}-cli-wr-separated.patch
52 Patch13:        %{name}-link_filter-updates.patch
53 Patch14:        %{name}-irc-mem.patch
54 Patch16:        %{name}-recent_activity-usability.patch
55 Patch18:        %{name}-scm-parse-response.patch
56 Patch19:        %{name}-double-decode.patch
57 Patch21:        %{name}-tt-unhide.patch
58 Patch22:        %{name}-route-mem.patch
59 Patch25:        %{name}-scm-pluscharisbad.patch
60 Patch26:        %{name}-scm-updates.patch
61 Patch27:        %{name}-private-key.patch
62 URL:            http://dev.mysql.com/downloads/other/eventum/
63 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
64 BuildRequires:  rpmbuild(macros) >= 1.268
65 BuildRequires:  sed >= 4.0
66 Requires(triggerpostun):        /usr/bin/php
67 Requires(triggerpostun):        sed >= 4.0
68 Requires:       %{name}-base = %{version}-%{release}
69 Requires:       Smarty >= 2.6.10-4
70 Requires:       apache(mod_dir)
71 Requires:       php >= 3:4.2.0
72 Requires:       php-gd
73 Requires:       php-imap
74 Requires:       php-mysql
75 Requires:       php-pcre
76 Requires:       php-pear-Benchmark
77 Requires:       php-pear-DB
78 Requires:       php-pear-Date
79 Requires:       php-pear-HTTP_Request
80 Requires:       php-pear-Mail
81 Requires:       php-pear-Mail_Mime
82 Requires:       php-pear-Math_Stats
83 Requires:       php-pear-Net_DIME
84 Requires:       php-pear-Net_SMTP
85 Requires:       php-pear-Net_Socket
86 Requires:       php-pear-Net_URL
87 Requires:       php-pear-Net_UserAgent_Detect
88 Requires:       php-pear-PEAR-core
89 Requires:       php-pear-Text_Diff
90 Requires:       php-pear-XML_RPC
91 Requires:       php-session
92 Requires:       webapps
93 BuildArch:      noarch
94 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
95
96 %define         _noautoreq      'pear(/etc/webapps/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)'
97
98 %define         _libdir         %{_prefix}/lib/%{name}
99 %define         _appdir         %{_datadir}/%{name}
100 %define         _smartyplugindir        %{_appdir}/include/smarty
101 %define         _smartydir      /usr/share/php/Smarty
102 %define         _webapps        /etc/webapps
103 %define         _webapp         %{name}
104 %define         _webappdir      %{_webapps}/%{_webapp}
105 %define         _sysconfdir     /etc/%{name}
106
107 %description
108 Eventum is a user-friendly and flexible issue tracking system that can
109 be used by a support department to track incoming technical support
110 requests, or by a software development team to quickly organize tasks
111 and bugs. Eventum is used by the MySQL AB Technical Support team, and
112 has allowed us to dramatically improve our response times.
113
114 %description -l pl
115 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
116 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
117 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
118 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
119 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
120 reakcji.
121
122 %package base
123 Summary:        Eventum base package
124 Summary(pl):    Podstawowy pakiet Eventum
125 Group:          Applications/WWW
126 Requires(postun):       /usr/sbin/groupdel
127 Requires(postun):       /usr/sbin/userdel
128 Requires(pre):  /bin/id
129 Requires(pre):  /usr/bin/getgid
130 Requires(pre):  /usr/sbin/groupadd
131 Requires(pre):  /usr/sbin/useradd
132 Provides:       group(eventum)
133 Provides:       user(eventum)
134
135 %description base
136 This package contains base directory structure for Eventum.
137
138 %description base -l pl
139 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
140
141 %package setup
142 Summary:        Eventum setup package
143 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
144 Group:          Applications/WWW
145 Requires:       %{name} = %{version}-%{release}
146
147 %description setup
148 Install this package to configure initial Eventum installation. You
149 should uninstall this package when you're done, as it considered
150 insecure to keep the setup files in place.
151
152 %description setup -l pl
153 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
154 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
155 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
156
157 %package mail-queue
158 Summary:        Eventum mail queue process
159 Summary(pl):    Przetwarzanie kolejki poczty Eventum
160 Group:          Applications/WWW
161 Requires:       %{name} = %{version}-%{release}
162 Requires:       crondaemon
163
164 %description mail-queue
165 Beginning with the first release of Eventum, emails are not directly
166 sent out from the various scripts, but rather added to a mail queue
167 table that is processed by a cron job. If an email cannot be sent, it
168 will be marked as such in the mail queue log, and the cron job script
169 will re-try to send it again the next time it runs.
170
171 This package contains the cron job.
172
173 %description mail-queue -l pl
174 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
175 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
176 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
177 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
178 nastêpnym razem.
179
180 Ten pakiet zawiera zadanie dla crona.
181
182 %package mail-download
183 Summary:        Eventum email download
184 Summary(pl):    ¦ci±ganie poczty Eventum
185 Group:          Applications/WWW
186 Requires:       %{name} = %{version}-%{release}
187 Requires:       crondaemon
188
189 %description mail-download
190 In order for Eventum's email integration feature to work, you need to
191 setup a cron job to run the script every so often.
192
193 This package contains the cron job.
194
195 %description mail-download -l pl
196 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
197 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
198 czêsto.
199
200 Ten pakiet zawiera zadanie dla crona.
201
202 %package reminder
203 Summary:        Eventum Reminder System
204 Summary(pl):    System przypominania dla Eventum
205 Group:          Applications/WWW
206 Requires:       %{name} = %{version}-%{release}
207 Requires:       crondaemon
208
209 %description reminder
210 The reminder system was designed with the objective as serving as a
211 safe net for issues that need attention. Depending on what
212 configuration you create, you may have several reminders (or alerts)
213 be sent out whenever an issue needs attention, for whatever parameter
214 you may deem necessary.
215
216 This package contains the cron job.
217
218 %description reminder -l pl
219 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
220 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
221 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
222 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
223 uwa¿aæ za potrzebny.
224
225 Ten pakiet zawiera zadanie dla crona.
226
227 %package monitor
228 Summary:        Eventum Heartbeat Monitor
229 Summary(pl):    Monitor ¿ycia dla Eventum
230 Group:          Applications/WWW
231 Requires:       %{name} = %{version}-%{release}
232 Requires:       crondaemon
233 Requires:       php-posix
234
235 %description monitor
236 The heartbeat monitor is a feature designed for the administrator that
237 wants to be alerted whenever a common problem in Eventum is detected,
238 like the database server not being available anymore, or maybe when
239 the recommended permissions for certain configuration files are
240 changed.
241
242 Please note that before running the heartbeat monitor, you may need to
243 customize some of the checks to be appropriate for your own system,
244 particularly the permission and file checks on
245 Monitor::checkConfiguration().
246
247 This package contains the cron job.
248
249 %description monitor -l pl
250 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
251 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
252 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
253 do plików konfiguracyjnych.
254
255 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
256 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
257 testów uprawnieñ i plików w Monitor::checkConfiguration().
258
259 Ten pakiet zawiera zadanie dla crona.
260
261 %package route-drafts
262 Summary:        Eventum Draft Routing
263 Summary(pl):    Przekazywanie szkiców dla Eventum
264 Group:          Applications/WWW
265 Requires:       %{name} = %{version}-%{release}
266 Requires:       eventum(router)
267
268 %description route-drafts
269 The draft routing feature is used to automatically associate a thread
270 of drafts into an Eventum issue. By setting up qmail (or even Postfix)
271 to deliver emails sent to a specific address (usually
272 draft-<number>@<domain>) to the above script, users are able to send
273 drafts written in their mail client to be stored in Eventum. These
274 drafts will NOT broadcasted to the notification list.
275
276 %description route-drafts -l pl
277 Przekazywanie szkiców s³u¿y do automatycznego wi±zania w±tku szkiców z
278 problemem w Eventum. Ustawiaj±c qmaila (czy nawet Postfiksa), aby
279 dostarcza³ pocztê wys³an± na podany adres (zwykle
280 draft-<liczba>@<domena>) do tego skryptu umo¿liwia siê u¿ytkownikom
281 wysy³anie szkiców napisanych w ich kliencie pocztowym do zapisania w
282 Eventum. Szkice te NIE bêd± wysy³ane na listê powiadomieñ.
283
284 %package route-emails
285 Summary:        Eventum Email Routing
286 Summary(pl):    Przekazywanie poczty dla Eventum
287 Group:          Applications/WWW
288 Requires:       %{name} = %{version}-%{release}
289 Requires:       eventum(router)
290
291 %description route-emails
292 The email routing feature is used to automatically associate a thread
293 of emails into an Eventum issue. By setting up qmail (or even postfix)
294 to deliver emails sent to a specific address (usually
295 issue-<number>@<domain>) to the above script, users are able to use
296 their email clients to reply to emails coming from Eventum, and those
297 replies will be automatically associated with the issue and
298 broadcasted to the entire notification list.
299
300 %description route-emails -l pl
301 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
302 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
303 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
304 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
305 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
306 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
307 rozprowadzane do ca³ej listy og³oszeniowej.
308
309 %package route-notes
310 Summary:        Eventum Note Routing
311 Summary(pl):    Przekazywanie notatek dla Eventum
312 Group:          Applications/WWW
313 Requires:       %{name} = %{version}-%{release}
314 Requires:       eventum(router)
315
316 %description route-notes
317 The note routing feature is used to automatically associate a thread
318 of notes into an Eventum issue. By setting up qmail (or even postfix)
319 to deliver emails sent to a specific address (usually
320 note-<number>@<domain>) to the above script, users are able to use
321 their email clients to reply to internal notes coming from Eventum,
322 and those replies will be automatically associated with the issue and
323 broadcasted to the notification list staff members.
324
325 %description route-notes -l pl
326 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
327 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
328 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
329 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
330 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
331 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
332 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
333
334 %package router-qmail
335 Summary:        Eventum Mail Routing - qmail
336 Summary(pl):    Przekazywanie poczty Eventum - qmail
337 Group:          Applications/Mail
338 # loose dep is intentional. qmail subpackage isn't built on PLD
339 # builders and there really nothing changes.
340 Requires:       %{name} >= %{version}-%{release}
341 Requires:       qmail >= 1.03
342 Provides:       eventum(router)
343 Obsoletes:      eventum(router)
344
345 %description router-qmail
346 This package provides way of routing notes and emails back to Eventum
347 via qmail.
348
349 %description router-qmail -l pl
350 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
351 przez qmaila.
352
353 %package router-postfix
354 Summary:        Eventum Mail Routing - Postfix
355 Summary(pl):    Przekazywanie poczty Eventum - Postfix
356 Group:          Applications/Mail
357 Requires:       %{name} = %{version}-%{release}
358 Requires:       postfix
359 Provides:       eventum(router)
360 Obsoletes:      eventum(router)
361
362 %description router-postfix
363 This package provides way of routing notes and emails back to Eventum
364 via Postfix.
365
366 The Postfix configuration instructions you can find from
367 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
368
369 %description router-postfix -l pl
370 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
371 przez Postfiksa.
372
373 Opis konfiguracji Postfiksa mo¿na znale¼æ pod adresem
374 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
375
376 %package irc
377 Summary:        Eventum IRC Notification Bot
378 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
379 Group:          Applications/WWW
380 Requires(triggerpostun):        sed >= 4.0
381 Requires:       %{name} = %{version}-%{release}
382 Requires:       php-pear-Net_SmartIRC
383 Requires:       php-sockets
384 Requires:       rc-scripts >= 0.4.0.18
385
386 %description irc
387 The IRC notification bot is a nice feature for remote teams that want
388 to handle issues and want to have a quick and easy way to get simple
389 notifications. Right now the bot notifies of the following actions:
390 - New Issues
391 - Blocked emails
392 - Issues that got their assignment list changed
393
394 NOTE: You will need to manually edit the bot.php script to set your
395 appropriate preferences, like IRC server and channel that the bot
396 should join.
397
398 %description irc -l pl
399 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
400 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
401 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
402 nastêpuj±cych zdarzeniach:
403 - nowych sprawach
404 - zablokowanych listach
405 - sprawach, dla których zmieni³a siê lista powi±zañ
406
407 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
408 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
409
410 %package cli
411 Summary:        Eventum command-line interface
412 Summary(pl):    Interfejs linii poleceñ dla Eventum
413 Group:          Applications/WWW
414 Requires:       %{name}-base = %{version}-%{release}
415 Requires:       php-cli
416 Requires:       php-common >= 3:4.1.0
417 Requires:       php-curl
418 Requires:       php-pear-XML_RPC
419 Requires:       php-xml
420
421 %description cli
422 The Eventum command-line interface allows you to access most of the
423 features of the web interface straight from your command shell.
424
425 %description cli -l pl
426 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
427 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
428
429 %package scm
430 Summary:        Eventum SCM integration
431 Summary(pl):    Integracja SCM dla Eventum
432 Group:          Applications/WWW
433 Requires:       %{name}-base = %{version}-%{release}
434 Requires:       php-cli
435 Requires:       php-common >= 3:4.1.0
436 Requires:       php-pcre
437
438 %description scm
439 This feature allows your software development teams to integrate your
440 Source Control Management system with your Issue Tracking System.
441
442 The integration is implemented in such a way that it will be forward
443 compatible with pretty much any SCM system, such as CVS.
444
445 For installation see
446 </eventum/help.php?topic=scm_integration_installation>.
447
448 %description scm -l pl
449 Ten pakiet pozwala zespo³om programistów na integracjê systemu
450 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
451 ¶ledzenia spraw.
452
453 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
454 prawie ka¿dym systemem SCM, jak np. CVS.
455
456 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
457 </eventum/help.php?topic=scm_integration_installation>.
458
459 %prep
460 %setup -q %{?_snap:-n %{name}-%{_snap}}
461 # undos the source
462 find . -type f -print0 | xargs -0 sed -i -e 's,\r$,,'
463
464 rm -f setup.conf.php # not to be installed by *.php glob
465 rm -rf misc/upgrade/*v1.[123]* # too old to support in PLD Linux
466 rm -f misc/upgrade/flush_compiled_templates.php
467 rm -rf misc/upgrade/*/upgrade_config.php # not needed in PLD Linux
468
469 # sample, not used in eventum
470 rm -f rpc/xmlrpc_client.php
471
472 # bug fixes.
473 %patch8 -p1
474 %patch10 -p1
475 %patch13 -p1
476 %patch16 -p1
477 %patch18 -p1
478 %patch19 -p1
479 %patch21 -p1
480 %patch22 -p1
481 %patch25 -p1
482 %patch26 -p1
483 %patch5 -p1
484
485 # packaging
486 %patch0 -p1
487 %patch1 -p1
488 %patch14 -p1
489 %patch2 -p1
490 %patch3 -p1
491 %patch9 -p1
492 %patch7 -p1
493 %patch27 -p1
494
495 sed -e '1s,#!.*/bin/php -q,#!%{_bindir}/php,' misc/cli/eventum > %{name}-cli
496 sed -e '1i#!%{_bindir}/php' misc/scm/process_cvs_commits.php > %{name}-scm
497 sed -e '1i#!%{_bindir}/php' misc/irc/bot.php > %{name}-bot
498 mv misc/cli/eventumrc_example eventumrc
499 sed -i -e '1i#!%{_bindir}/php' misc/*.php
500 chmod +x misc/*.php
501 mv include/private_key.php private_key.php.in
502
503 # replace in remaining scripts config.inc.php to system one
504 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
505         s,include_once(".*config.inc.php"),include_once("%{_webappdir}/core.php"),
506 '
507
508 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
509         s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_webappdir}/private_key.php"),
510 '
511
512 # remove backups from patching as we use globs to package files to buildroot
513 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
514
515 %install
516 rm -rf $RPM_BUILD_ROOT
517 install -d \
518         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
519         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
520         $RPM_BUILD_ROOT/var/{run,log,cache,lib}/%{name} \
521         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
522         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
523
524 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
525 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
526 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
527 cp -a templates $RPM_BUILD_ROOT%{_appdir}
528 cp -a include/{customer,custom_field,jpgraph,workflow} $RPM_BUILD_ROOT%{_appdir}/include
529 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
530 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
531 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
532
533 cp -a favicon.ico $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
534 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/setup/config.inc.php
535 install %{SOURCE13} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
536
537 # cli
538 install -d $RPM_BUILD_ROOT%{_appdir}/cli
539 cp -a misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
540 cp -a misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
541 install %{name}-cli $RPM_BUILD_ROOT%{_bindir}/%{name}
542 install %{name}-bot $RPM_BUILD_ROOT%{_sbindir}
543
544 # scm
545 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
546 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
547
548 # private key
549 cp -a private_key.php.in $RPM_BUILD_ROOT%{_webappdir}/private_key.php
550
551 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
552 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
553 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
554 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
555 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
556 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
557 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
558 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
559 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
560
561 sed -e '
562 s,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}},
563 s,%%{PHP_PEAR_DIR}%%,%{php_pear_dir},
564 s,%%{APP_PATH}%%,%{_appdir},
565 s,%%{SMARTY_DIR}%%,%{_smartydir},
566 s,%%{SYSCONFDIR}%%,%{_webappdir},
567 ' %{SOURCE10} > $RPM_BUILD_ROOT%{_webappdir}/core.php
568
569 # config
570 > $RPM_BUILD_ROOT%{_webappdir}/setup.php
571 mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_webappdir}/config}.php
572
573 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
574 # These plugins are not in Smarty package (Smarty-2.6.2-3)
575 cp -a \
576         include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
577         include/Smarty/plugins/modifier.highlight_quoted.php \
578         $RPM_BUILD_ROOT%{_smartyplugindir}
579
580 # qmail router
581 %if %{with qmail}
582 d=$RPM_BUILD_ROOT/var/lib/%{name}
583 echo 'root' > $d/.qmail
584 echo 'root' > $d/.qmail-default
585 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
586 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
587 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
588 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
589 %endif
590 # postfix router
591 install %{SOURCE14} $RPM_BUILD_ROOT%{_libdir}/router-postfix
592
593 %clean
594 rm -rf $RPM_BUILD_ROOT
595
596 %pre
597 %addusertogroup http %{name}
598
599 %post
600 # check if the package is configured.
601 if grep -q 'header("Location: setup/")' %{_webappdir}/config.php; then
602 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
603 %banner %{name} -e <<EOF
604
605 You haven't yet configured Eventum!
606 Please open in browser <http://localhost/eventum/>
607 If you need access from elsewhere, you need to edit
608 %{_webappdir}/apache.conf and restart apache.
609
610 IMPORTANT: When You have configured Eventum, please uninstall the
611 setup package, so that %{name}-setup is able to secure your Eventum
612 installation.
613
614 EOF
615 #' vim syntax hack
616 else
617 %banner %{name} -e <<EOF
618
619 You haven't yet configured Eventum!
620
621 To setup eventum, please install %{name}-setup and open in browser
622 <http://localhost/eventum/>.
623 If you need access from elsewhere, you need to edit
624 %{_webappdir}/apache.conf and restart apache.
625
626 IMPORTANT: When You have configured Eventum, please uninstall the
627 setup package, so that %{name}-setup is able to secure your Eventum
628 installation.
629
630 EOF
631 #' vim syntax hack
632 fi
633
634 elif grep -q 'DEFAULTPRIVATEKEY' %{_webappdir}/private_key.php; then
635 %banner %{name} -e <<EOF
636
637 You have default private key installed!
638
639 Install %{name}-setup and open up http://yourserver/eventum/setup/
640 -- that will help you setup initial config.
641
642 when have configured Eventum, please uninstall the setup package,
643 so that %{name}-setup is able to secure your Eventum installation.
644
645 EOF
646         elif [ -d %{_appdir}/setup ]; then
647 %banner %{name} -e <<EOF
648
649 If you have have configured Eventum, please uninstall the setup package,
650 so that %{name}-setup is able to secure your Eventum installation.
651
652 EOF
653 fi
654
655 # nuke Smarty templates cache after upgrade
656 rm -f /var/cache/eventum/*.php
657
658 %preun
659 if [ "$1" = "0" ]; then
660         # nuke cache
661         rm -f /var/cache/eventum/*.php 2>/dev/null || :
662 fi
663
664 %pre base
665 %groupadd -P %{name}-base -g 146 %{name}
666 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
667
668 %postun base
669 if [ "$1" = "0" ]; then
670         %userremove %{name}
671         %groupremove %{name}
672 fi
673
674 %post router-qmail
675 CF=/etc/qmail/control/virtualdomains
676 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
677         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_webappdir}/config.php 2>/dev/null)
678         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
679         umask 022
680         echo "#${FQDN}:%{name}" >> $CF
681
682 %banner %{name}-qmail -e <<EOF
683
684 Added "#${FQDN}:%{name}" to $CF,
685 Please verify that it is correct and restart qmail:
686 # service qmail reload
687
688 Consult qmail-send(8) for more information on virtualdomains.
689
690 EOF
691 fi
692
693 %preun router-qmail
694 if [ "$1" = "0" ]; then
695         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
696 fi
697
698 %post setup
699 chmod 660 %{_webappdir}/{config,private_key}.php
700 chown root:eventum %{_webappdir}/{config,private_key}.php
701
702 %postun setup
703 if [ "$1" = "0" ]; then
704         chmod 640 %{_webappdir}/{config,private_key}.php
705         chown root:eventum %{_webappdir}/{config,private_key}.php
706 fi
707
708 %post irc
709 /sbin/chkconfig --add eventum-irc
710 %service eventum-irc restart "Eventum IRC Bot"
711
712 %triggerin -- apache1
713 %webapp_register apache %{_webapp}
714
715 %triggerun -- apache1
716 %webapp_unregister apache %{_webapp}
717
718 %triggerin -- apache < 2.2.0, apache-base
719 %webapp_register httpd %{_webapp}
720
721 %triggerun -- apache < 2.2.0, apache-base
722 %webapp_unregister httpd %{_webapp}
723
724 # FIXME
725 # only one upgrade trigger is called if you're upgrading over two
726 # versions, say 1.5 to 1.5.3, only 1.5.3 trigger is called.
727 # use common trigger (the highest version and rpmvercmp from poldek?)
728 %triggerpostun -- eventum < 1.5.1-0.257
729 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5_to_v1.5.1 <<EOF
730 database_changes.php Perform database changes
731 EOF
732
733 %triggerpostun -- eventum < 1.5.2-0.289
734 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.1_to_v1.5.2 <<EOF
735 database_changes.php Perform database changes
736 set_priority_ranks.php Fix the ranking of priority values
737 EOF
738
739 %triggerpostun -- eventum < 1.5.3-0.291
740 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.2_to_v1.5.3 <<EOF
741 database_changes.php Perform database changes
742 EOF
743
744 %triggerpostun -- eventum < 1.5.4-1.12
745 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.3_to_v1.5.4 <<EOF
746 database_changes.php Perform database changes
747 EOF
748
749 %triggerpostun -- eventum < 1.6.0-RC2.6
750 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.5_to_v1.6.0 <<EOF
751 database_changes.php Perform database changes
752 upgrade_saved_searches.php Upgrade existing custom filters (saved searches)
753 EOF
754
755 %triggerpostun -- eventum < 1.6.1-0.2
756 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.0_to_v1.6.1 <<EOF
757 database_changes.php Perform database changes
758 EOF
759
760 %triggerpostun irc -- eventum-irc < 1.6.1-3.14
761 sed -i -e '
762 s,\$irc_host,$irc_server_hostname,
763 s,\$irc_port,$irc_server_port,
764 s,\$irc_nick,$nickname,
765 s,\$irc_realname,$realname,
766 s,\$irc_username,$username,
767 s,\$irc_password,$password,
768 ' /etc/eventum/irc.php
769
770 %triggerpostun -- eventum < 1.7.0-2.0.48
771 # migrate from apache-config macros
772 if [ -f /etc/%{name}/apache.conf.rpmsave ]; then
773         if [ -d /etc/apache/webapps.d ]; then
774                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
775                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
776         fi
777
778         if [ -d /etc/httpd/webapps.d ]; then
779                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
780                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
781         fi
782 fi
783
784 if [ -L /etc/apache/conf.d/99_%{_webapp}.conf ]; then
785         /usr/sbin/webapp register apache %{_webapp}
786         rm -f /etc/apache/conf.d/99_%{_webapp}.conf
787         %service -q apache reload
788 fi
789 if [ -L /etc/httpd/httpd.conf/99_%{_webapp}.conf ]; then
790         /usr/sbin/webapp register httpd %{_webapp}
791         rm -f /etc/httpd/httpd.conf/99_%{_webapp}.conf
792         %service -q httpd reload
793 fi
794
795 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.1_to_v1.7.0 <<EOF
796 database_changes.php Perform database changes
797 set_root_message_ids.php Set iss_root_message_id
798 EOF
799
800 # regular configs
801 for i in apache.conf config.php private_key.php setup.php; do
802         if [ -f /etc/eventum/$i.rpmsave ]; then
803                 mv -f %{_webappdir}/$i{,.rpmnew}
804                 mv -f /etc/eventum/$i.rpmsave %{_webappdir}/$i
805         fi
806 done
807
808 %triggerpostun cli -- %{name}-cli < 1.7.0-3.4
809 if [ -f %{_webappdir}/cli.php.rpmsave ]; then
810         mv -f %{_sysconfdir}/cli.php{,.rpmnew}
811         mv -f %{_webappdir}/cli.php.rpmsave %{_sysconfdir}/cli.php
812 fi
813
814 %triggerpostun irc -- %{name}-irc < 1.7.0-3.4
815 if [ -f %{_webappdir}/irc.php.rpmsave ]; then
816         mv -f %{_sysconfdir}/irc.php{,.rpmnew}
817         mv -f %{_webappdir}/irc.php.rpmsave %{_sysconfdir}/irc.php
818 fi
819
820 %files
821 %defattr(644,root,root,755)
822 %doc ChangeLog FAQ INSTALL README UPGRADE CONTRIB
823 %doc docs/* setup/schema.sql
824 %attr(751,root,root) %dir %{_webappdir}
825 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
826 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
827 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
828 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
829 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
830 %attr(640,root,eventum) %config %verify(not mtime) %{_webappdir}/core.php
831
832 %dir %attr(731,root,eventum) /var/log/%{name}
833 %attr(620,root,eventum) %ghost /var/log/%{name}/*
834
835 %dir %{_appdir}/htdocs
836 %{_appdir}/htdocs/*.php
837 %{_appdir}/htdocs/*.ico
838 %{_appdir}/htdocs/css
839 %{_appdir}/htdocs/customer
840 %{_appdir}/htdocs/images
841 %{_appdir}/htdocs/js
842 %{_appdir}/htdocs/manage
843 %{_appdir}/htdocs/reports
844 %{_appdir}/htdocs/rpc
845 %{_appdir}/htdocs/misc
846 %{_appdir}/templates
847 %dir %{_appdir}/upgrade
848 %attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
849 %{_appdir}/upgrade/[!u]*
850 %{_smartyplugindir}
851
852 %dir %{_appdir}/include
853 %{_appdir}/include/customer
854 %{_appdir}/include/custom_field
855 %{_appdir}/include/jpgraph
856 %{_appdir}/include/workflow
857 %{_appdir}/include/class.[!m]*.php
858 %{_appdir}/include/class.mail.php
859 %{_appdir}/include/class.mail_queue.php
860 %{_appdir}/include/class.mime_helper.php
861 %{_appdir}/include/class.misc.php
862 %{_appdir}/include/db_access.php
863
864 %dir %attr(730,root,eventum) /var/run/%{name}
865 %dir %attr(730,root,eventum) /var/cache/%{name}
866
867 %files base
868 %defattr(644,root,root,755)
869 %attr(751,root,root) %dir %{_sysconfdir}
870 %dir %{_libdir}
871 %dir %{_appdir}
872 # qmail will ignore user, if it's home directory is not owned
873 %attr(750,eventum,eventum) %dir /var/lib/%{name}
874 # saved mail copies
875 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_emails
876 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_drafts
877 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_notes
878
879 %files setup
880 %defattr(644,root,root,755)
881 %{_appdir}/htdocs/setup
882
883 %files mail-queue
884 %defattr(644,root,root,755)
885 %attr(755,root,root) %{_appdir}/process_mail_queue.php
886 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
887
888 %files mail-download
889 %defattr(644,root,root,755)
890 %attr(755,root,root) %{_appdir}/download_emails.php
891 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
892
893 %files reminder
894 %defattr(644,root,root,755)
895 %attr(755,root,root) %{_appdir}/check_reminders.php
896 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
897
898 %files monitor
899 %defattr(644,root,root,755)
900 %{_appdir}/include/class.monitor.php
901 %attr(755,root,root) %{_appdir}/monitor.php
902 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
903
904 %files route-drafts
905 %defattr(644,root,root,755)
906 %attr(755,root,root) %{_appdir}/route_drafts.php
907
908 %files route-emails
909 %defattr(644,root,root,755)
910 %attr(755,root,root) %{_appdir}/route_emails.php
911
912 %files route-notes
913 %defattr(644,root,root,755)
914 %attr(755,root,root) %{_appdir}/route_notes.php
915
916 %if %{with qmail}
917 %files router-qmail
918 %defattr(644,root,root,755)
919 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
920 %attr(755,root,root) %{_libdir}/router-qmail
921 %endif
922
923 %files router-postfix
924 %defattr(644,root,root,755)
925 %attr(755,root,root) %{_libdir}/router-postfix
926
927 %files irc
928 %defattr(644,root,root,755)
929 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
930 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
931 %attr(755,root,root) %{_sbindir}/%{name}-bot
932 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
933
934 %files cli
935 %defattr(644,root,root,755)
936 %doc eventumrc
937 %attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
938 %attr(755,root,root) %{_bindir}/%{name}
939 %{_appdir}/cli
940
941 %files scm
942 %defattr(644,root,root,755)
943 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
944 %attr(755,root,root) %{_libdir}/scm
This page took 0.10116 seconds and 4 git commands to generate.