]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- pl for -base
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
3 # - discard bundled packages (from INSTALL):
4 #  - JpGraph 1.5.3 (last GPL version)
5 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
6 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
7 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
8 #  - A few other small javascript libraries
9 # - create eventum-router-qmail, eventum-router-postfix for -route-mails and -route-notes
10 # - need start-stop-daemon (from dpkg for now)
11 # - use eventum user for irc bot?
12
13 # snapshot: DATE
14 #define _snap 20050124
15
16 %if 0%{?_snap}
17 %define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
18 %else
19 %define _source http://mysql.wildyou.net/Downloads/%{name}/%{name}-%{version}.tar.gz
20 %endif
21
22 %define _rel 1.129
23
24 Summary:        Eventum Issue - a bug tracking system
25 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
26 Name:           eventum
27 Version:        1.4
28 Release:        %{?_snap:0.%{_snap}.}%{_rel}
29 License:        GPL
30 Group:          Applications/WWW
31 Source0:        %{_source}
32 # Source0-md5:  361c1355e46a6bbfa54e420964ec92cf
33 Source1:        %{name}-apache.conf
34 Source2:        %{name}-mail-queue.cron
35 Source3:        %{name}-mail-download.cron
36 Source4:        %{name}-reminder.cron
37 Source5:        %{name}-monitor.cron
38 Source6:        %{name}-cvs.php
39 Source7:        %{name}-irc.php
40 Source8:        %{name}-irc.init
41 # packaging
42 Patch0:         %{name}-paths.patch
43 Patch1:         %{name}-scm-encode.patch
44 Patch2:         %{name}-cvs-config.patch
45 Patch3:         %{name}-irc-config.patch
46 # bug fixes
47 Patch10:                %{name}-clock-status.patch
48 Patch11:                %{name}-scm_checkin_associated.patch
49 Patch12:                %{name}-mail-queue.tpl.patch
50 URL:            http://dev.mysql.com/downloads/other/eventum/index.html
51 BuildRequires:  rpmbuild(macros) >= 1.177
52 BuildRequires:  sed >= 4.0
53 Requires:       php >= 4.1.0
54 Requires:       php-gd
55 Requires:       php-imap
56 Requires:       php-mysql
57 Requires:       php-pcre
58 Requires:       Smarty >= 2.6.2
59 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
60 Requires:       php-pear-Benchmark
61 Requires:       php-pear-DB
62 Requires:       php-pear-Date
63 Requires:       php-pear-HTTP_Request
64 Requires:       php-pear-Mail
65 Requires:       php-pear-Math_Stats
66 Requires:       php-pear-Net_DIME
67 Requires:       php-pear-Net_POP3
68 Requires:       php-pear-Net_SMTP
69 Requires:       php-pear-Net_SmartIRC
70 Requires:       php-pear-Net_Socket
71 Requires:       php-pear-Net_URL
72 Requires:       php-pear-Net_UserAgent_Detect
73 Requires:       php-pear-PEAR
74 Requires:       php-pear-Text_Diff
75 Requires:       php-pear-XML_RPC
76 #Requires:      apache-mod_dir
77 # conflict with non-confdir apache
78 Conflicts:      apache1 < 1.3.33-1.1
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %define         _sysconfdir     /etc/%{name}
82 %define         _appdir %{_datadir}/%{name}
83 %define         _smartyplugindir        %{php_pear_dir}/Smarty/plugins
84
85 %define         _apache1dir     /etc/apache
86 %define         _apache2dir     /etc/httpd
87
88 %description
89 Eventum is a user-friendly and flexible issue tracking system that can
90 be used by a support department to track incoming technical support
91 requests, or by a software development team to quickly organize tasks
92 and bugs. Eventum is used by the MySQL AB Technical Support team, and
93 has allowed us to dramatically improve our response times.
94
95 %description -l pl
96 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
97 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
98 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
99 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
100 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
101 reakcji.
102
103 %package base
104 Summary:        Eventum base package
105 Summary(pl):    Podstawowy pakiet Eventum
106 Group:          Applications/WWW
107
108 %description base
109 This package contains base directory structure for Eventum.
110
111 %description base -l pl
112 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
113
114 %package setup
115 Summary:        Eventum setup package
116 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
117 Group:          Applications/WWW
118 PreReq:         %{name} = %{epoch}:%{version}-%{release}
119
120 %description setup
121 Install this package to configure initial Eventum installation. You
122 should uninstall this package when you're done, as it considered
123 insecure to keep the setup files in place.
124
125 %description setup -l pl
126 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
127 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
128 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
129
130 %package mail-queue
131 Summary:        Eventum mail queue process
132 Summary(pl):    Przetwarzanie kolejki poczty Eventum
133 Group:          Applications/WWW
134 Requires:       %{name} = %{epoch}:%{version}-%{release}
135 Requires:       crondaemon
136 Requires:       php4 >= 4.1.0
137
138 %description mail-queue
139 Beginning with the first release of Eventum, emails are not directly
140 sent out from the various scripts, but rather added to a mail queue
141 table that is processed by a cron job. If an email cannot be sent, it
142 will be marked as such in the mail queue log, and the cron job script
143 will re-try to send it again the next time it runs.
144
145 This package contains the cron job.
146
147 %description mail-queue -l pl
148 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
149 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
150 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
151 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
152 nastêpnym razem.
153
154 Ten pakiet zawiera zadanie dla crona.
155
156 %package mail-download
157 Summary:        Eventum email download
158 Summary(pl):    ¦ci±ganie poczty Eventum
159 Group:          Applications/WWW
160 Requires:       %{name} = %{epoch}:%{version}-%{release}
161 Requires:       crondaemon
162 Requires:       php4 >= 4.1.0
163
164 %description mail-download
165 In order for Eventum's email integration feature to work, you need to
166 setup a cron job to run the script every so often.
167
168 This package contains the cron job.
169
170 %description mail-download -l pl
171 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
172 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
173 czêsto.
174
175 Ten pakiet zawiera zadanie dla crona.
176
177 %package reminder
178 Summary:        Eventum Reminder System
179 Summary(pl):    System przypominania dla Eventum
180 Group:          Applications/WWW
181 Requires:       %{name} = %{epoch}:%{version}-%{release}
182 Requires:       php4 >= 4.1.0
183 Requires:       crondaemon
184
185 %description reminder
186 The reminder system was designed with the objective as serving as a
187 safe net for issues that need attention. Depending on what
188 configuration you create, you may have several reminders (or alerts)
189 be sent out whenever an issue needs attention, for whatever parameter
190 you may deem necessary.
191
192 This package contains the cron job.
193
194 %description reminder -l pl
195 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
196 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
197 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
198 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
199 uwa¿aæ za potrzebny.
200
201 Ten pakiet zawiera zadanie dla crona.
202
203 %package monitor
204 Summary:        Eventum Heartbeat Monitor
205 Summary(pl):    Monitor ¿ycia dla Eventum
206 Group:          Applications/WWW
207 Requires:       %{name} = %{epoch}:%{version}-%{release}
208 Requires:       php4 >= 4.1.0
209 Requires:       crondaemon
210
211 %description monitor
212 The heartbeat monitor is a feature designed for the administrator that
213 wants to be alerted whenever a common problem in Eventum is detected,
214 like the database server not being available anymore, or maybe when
215 the recommended permissions for certain configuration files are
216 changed.
217
218 Please note that before running the heartbeat monitor, you may need to
219 customize some of the checks to be appropriate for your own system,
220 particularly the permission and file checks on
221 Monitor::checkConfiguration().
222
223 This package contains the cron job.
224
225 %description monitor -l pl
226 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
227 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
228 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
229 do plików konfiguracyjnych.
230
231 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
232 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
233 testów uprawnieñ i plików w Monitor::checkConfiguration().
234
235 Ten pakiet zawiera zadanie dla crona.
236
237 %package route-emails
238 Summary:        Eventum Email Routing
239 Summary(pl):    Przekazywanie poczty dla Eventum
240 Group:          Applications/WWW
241 Requires:       %{name} = %{epoch}:%{version}-%{release}
242 Requires:       php4 >= 4.1.0
243 #Requires:      eventum-router
244
245 %description route-emails
246 The email routing feature is used to automatically associate a thread
247 of emails into an Eventum issue. By setting up qmail (or even postfix)
248 to deliver emails sent to a specific address (usually
249 issue-<number>@<domain>) to the above script, users are able to use
250 their email clients to reply to emails coming from Eventum, and those
251 replies will be automatically associated with the issue and
252 broadcasted to the entire notification list.
253
254 %description route-emails -l pl
255 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
256 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
257 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
258 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
259 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
260 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
261 rozprowadzane do ca³ej listy og³oszeniowej.
262
263 %package route-notes
264 Summary:        Eventum Note Routing
265 Summary(pl):    Przekazywanie notatek dla Eventum
266 Group:          Applications/WWW
267 Requires:       %{name} = %{epoch}:%{version}-%{release}
268 Requires:       php4 >= 4.1.0
269 #Requires:      eventum-router
270
271 %description route-notes
272 The note routing feature is used to automatically associate a thread
273 of notes into an Eventum issue. By setting up qmail (or even postfix)
274 to deliver emails sent to a specific address (usually
275 note-<number>@<domain>) to the above script, users are able to use
276 their email clients to reply to internal notes coming from Eventum,
277 and those replies will be automatically associated with the issue and
278 broadcasted to the notification list staff members.
279
280 %description route-notes -l pl
281 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
282 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
283 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
284 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
285 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
286 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
287 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
288
289 %package irc
290 Summary:        Eventum IRC Notification Bot
291 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
292 Group:          Applications/WWW
293 Requires:       %{name} = %{epoch}:%{version}-%{release}
294 Requires:       php >= 4.1.0
295 Requires:       php-sockets
296 # FIXME just need start-stop-daemon
297 Requires:       dpkg
298
299 %description irc
300 The IRC notification bot is a nice feature for remote teams that want
301 to handle issues and want to have a quick and easy way to get simple
302 notifications. Right now the bot notifies of the following actions:
303 - New Issues
304 - Blocked emails
305 - Issues that got their assignment list changed
306
307 NOTE: You will need to manually edit the bot.php script to set your
308 appropriate preferences, like IRC server and channel that the bot
309 should join.
310
311 %description irc -l pl
312 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
313 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
314 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
315 nastêpuj±cych zdarzeniach:
316 - nowych sprawach
317 - zablokowanych listach
318 - sprawach, dla których zmieni³a siê lista powi±zañ
319
320 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
321 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
322
323 %package cli
324 Summary:        Eventum command-line interface
325 Summary(pl):    Interfejs linii poleceñ dla Eventum
326 Group:          Applications/WWW
327 Requires:       %{name} = %{epoch}:%{version}-%{release}
328 Requires:       php4 >= 4.1.0
329 Requires:       php4-cli
330 Requires:       php4-curl
331 Requires:       php4-xml
332 Requires:       php-pear-XML_RPC
333
334 %description cli
335 The Eventum command-line interface allows you to access most of the
336 features of the web interface straight from your command shell.
337
338 %description cli -l pl
339 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
340 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
341
342 %package scm
343 Summary:        Eventum SCM integration
344 Summary(pl):    Integracja SCM dla Eventum
345 Group:          Applications/WWW
346 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
347 Requires:       php4 >= 4.1.0
348
349 %description scm
350 This feature allows your software development teams to integrate your
351 Source Control Management system with your Issue Tracking System.
352
353 The integration is implemented in such a way that it will be forward
354 compatible with pretty much any SCM system, such as CVS.
355
356 For installation see
357 /eventum/help.php?topic=scm_integration_installation .
358
359 %description scm -l pl
360 Ten pakiet pozwala zespo³om programistów na integracjê systemu
361 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
362 ¶ledzenia spraw.
363
364 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
365 prawie ka¿dym systemem SCM, jak np. CVS.
366
367 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
368 /eventum/help.php?topic=scm_integration_installation .
369
370 %prep
371 %setup -q %{?_snap:-n %{name}-%{_snap}}
372 %patch0 -p1
373 %patch1 -p1
374 %patch2 -p1
375 %patch3 -p1
376
377 %patch10 -p1
378 %patch11 -p1
379 %patch12 -p1
380
381 %install
382 rm -rf $RPM_BUILD_ROOT
383 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_appdir}} \
384         $RPM_BUILD_ROOT{/etc/{rc.d/init.d,cron.d},/var/log} \
385         $RPM_BUILD_ROOT{/var/run/eventum,/var/cache/eventum}
386
387 rm -f eventumrc %{name}-scm
388 cp -a . $RPM_BUILD_ROOT%{_appdir}
389 # argsh! say no words
390 find $RPM_BUILD_ROOT%{_appdir} -type f -print0 | xargs -0 sed -i -e 's,
391 $,,'
392 sed -e 's,
393 $,,' misc/cli/eventumrc_example > eventumrc
394
395 > $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
396
397 sed -i -e 's,/usr/local/bin/php,/usr/bin/php4,' $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum
398 echo '#!/usr/bin/php4 -q' > %{name}-scm
399 cat $RPM_BUILD_ROOT%{_appdir}/misc/scm/process_cvs_commits.php >> %{name}-scm
400
401 # change private key, so we can easily grep
402 sed -i -e '
403 s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
404 ' $RPM_BUILD_ROOT%{_appdir}/include/private_key.php
405
406 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
407 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
408 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
409 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
410 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
411 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
412 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
413 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
414
415 # in conf
416 mv $RPM_BUILD_ROOT%{_appdir}/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/config.php
417 mv $RPM_BUILD_ROOT%{_appdir}/setup.conf.php $RPM_BUILD_ROOT%{_sysconfdir}/setup.php
418 mv $RPM_BUILD_ROOT%{_appdir}/include/private_key.php $RPM_BUILD_ROOT%{_sysconfdir}
419 mv $RPM_BUILD_ROOT%{_appdir}/misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
420 ln -s %{_sysconfdir}/config.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
421 ln -s %{_sysconfdir}/setup.php $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
422 ln -s %{_sysconfdir}/private_key.php $RPM_BUILD_ROOT%{_appdir}/include/private_key.php
423
424 # log directory
425 mv $RPM_BUILD_ROOT%{_appdir}/logs $RPM_BUILD_ROOT/var/log/%{name}
426
427 # in doc
428 rm -f $RPM_BUILD_ROOT%{_appdir}/{COPYING,ChangeLog,FAQ,INSTALL,README,UPGRADE}
429 rm -rf $RPM_BUILD_ROOT%{_appdir}/{docs,misc/upgrade}
430 # some sample, not used in eventum
431 rm -rf $RPM_BUILD_ROOT%{_appdir}/rpc/xmlrpc_client.php
432
433 # use system Smarty
434 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
435 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
436 # These plugins are not in Smarty package (Smarty-2.6.2-3)
437 cp -a include/Smarty/plugins/function.{calendar,get_display_style,get_innerhtml,get_textarea_size}.php $RPM_BUILD_ROOT%{_smartyplugindir}
438
439 # in bindir
440 mv $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum $RPM_BUILD_ROOT%{_bindir}
441 rm -f $RPM_BUILD_ROOT%{_appdir}/misc/{cli/eventumrc_example,scm/process_cvs_commits.php}
442 install %{name}-scm $RPM_BUILD_ROOT%{_bindir}/%{name}-scm
443
444 # provided by PEAR
445 rm -rf $RPM_BUILD_ROOT%{_appdir}/misc/cli/include/pear
446 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
447
448 %clean
449 rm -rf $RPM_BUILD_ROOT
450
451 %post
452 # apache1
453 if [ -f %{_apache1dir}/apache.conf ]; then
454         ln -sf %{_sysconfdir}/apache.conf %{_apache1dir}/conf.d/99_%{name}.conf
455         if [ -f /var/lock/subsys/apache ]; then
456                 /etc/rc.d/init.d/apache restart 1>&2
457         fi
458 fi
459 # apache2
460 if [ -d %{_apache2dir}/httpd.conf ]; then
461         ln -sf %{_sysconfdir}/apache.conf %{_apache2dir}/httpd.conf/99_%{name}.conf
462         if [ -f /var/lock/subsys/httpd ]; then
463                 /etc/rc.d/init.d/httpd restart 1>&2
464         fi
465 fi
466
467 # check if the package is configured.
468 if grep -q 'header("Location: setup/")' %{_sysconfdir}/config.php; then
469 %banner %{name} -e <<EOF
470
471 You haven't yet configured Eventum!
472
473 Install %{name}-setup and open up http://yourserver/eventum/
474 -- that will help you setup initial config.
475
476 when have configured Eventum, please uninstall the setup package,
477 so that %{name}-setup is able to secure your Eventum installation.
478
479 EOF
480 #' vim stupidity.
481
482 elif grep -q 'DEFAULTPRIVATEKEY' %{_sysconfdir}/private_key.php; then
483 %banner %{name} -e <<EOF
484
485 You have default private key installed!
486
487 Install %{name}-setup and open up http://yourserver/eventum/setup/
488 -- that will help you setup initial config.
489
490 when have configured Eventum, please uninstall the setup package,
491 so that %{name}-setup is able to secure your Eventum installation.
492
493 EOF
494         elif [ -d %{_appdir}/setup ]; then
495 %banner %{name} -e <<EOF
496
497 If you have have configured Eventum, please uninstall the setup package,
498 so that %{name}-setup is able to secure your Eventum installation.
499
500 EOF
501 fi
502
503
504 %preun
505 if [ "$1" = "0" ]; then
506         # apache1
507         if [ -f %{_apache1dir}/apache.conf ]; then
508                 rm -f %{_apache1dir}/conf.d/99_%{name}.conf
509                 if [ -f /var/lock/subsys/apache ]; then
510                         /etc/rc.d/init.d/apache restart 1>&2
511                 fi
512         fi
513         # apache2
514         if [ -d %{_apache2dir}/httpd.conf ]; then
515                 rm -f %{_apache1dir}/httpd.conf/99_%{name}.conf
516                 if [ -f /var/lock/subsys/httpd ]; then
517                         /etc/rc.d/init.d/httpd restart 1>&2
518                 fi
519         fi
520 fi
521
522 %post setup
523 chmod 660 %{_sysconfdir}/{config,private_key}.php
524 chown root:http %{_sysconfdir}/{config,private_key}.php
525
526 %postun setup
527 if [ "$1" = "0" ]; then
528         chmod 640 %{_sysconfdir}/{config,private_key}.php
529         chown root:http %{_sysconfdir}/{config,private_key}.php
530 fi
531
532 %files
533 %defattr(644,root,root,755)
534 %doc ChangeLog FAQ INSTALL README UPGRADE misc/upgrade docs/* rpc/xmlrpc_client.php
535 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
536 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
537 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/private_key.php
538 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/setup.php
539
540 %dir %{_appdir}
541 %dir %{_appdir}/misc
542
543 %dir %attr(731,root,http) /var/log/%{name}
544 %attr(620,root,http) %ghost /var/log/%{name}/*
545
546 %{_smartyplugindir}/*
547
548 %{_appdir}/*.php
549 %{_appdir}/css
550 %{_appdir}/customer
551 %{_appdir}/images
552 %{_appdir}/js
553 %{_appdir}/manage
554 %{_appdir}/reports
555 %{_appdir}/rpc
556 %{_appdir}/templates
557
558 %dir %{_appdir}/include
559 %{_appdir}/include/customer
560 %{_appdir}/include/jpgraph
561 %{_appdir}/include/workflow
562 %{_appdir}/include/*.php
563
564 %dir %attr(730,root,http) /var/run/%{name}
565 %dir %attr(730,root,http) /var/cache/%{name}
566
567 %{_appdir}/misc/blank.html
568
569 %files base
570 %defattr(644,root,root,755)
571 %attr(751,root,root) %dir %{_sysconfdir}
572
573 %files setup
574 %defattr(644,root,root,755)
575 %{_appdir}/setup
576
577 %files mail-queue
578 %defattr(644,root,root,755)
579 %{_appdir}/misc/process_mail_queue.php
580 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
581
582 %files mail-download
583 %defattr(644,root,root,755)
584 %{_appdir}/misc/download_emails.php
585 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
586
587 %files reminder
588 %defattr(644,root,root,755)
589 %{_appdir}/misc/check_reminders.php
590 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
591
592 %files monitor
593 %defattr(644,root,root,755)
594 %{_appdir}/misc/monitor.php
595 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
596
597 %files route-emails
598 %defattr(644,root,root,755)
599 %{_appdir}/misc/route_emails.php
600
601 %files route-notes
602 %defattr(644,root,root,755)
603 %{_appdir}/misc/route_drafts.php
604 %{_appdir}/misc/route_notes.php
605
606 %files irc
607 %defattr(644,root,root,755)
608 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
609 %{_appdir}/misc/irc
610 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
611
612 %files cli
613 %defattr(644,root,root,755)
614 %doc eventumrc
615 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cli.php
616 %attr(755,root,root) %{_bindir}/%{name}
617 %dir %{_appdir}/misc/cli
618 %{_appdir}/misc/cli/include
619
620 %files scm
621 %defattr(644,root,root,755)
622 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
623 # FIXME: not sure about this naming.
624 %attr(755,root,root) %{_bindir}/%{name}-scm
This page took 0.069396 seconds and 3 git commands to generate.