]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
vendor paragonie/random_compat, symfony/polyfill-php70
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1
6 %define         subver  365
7 %define         githash 65c5538f
8 %define         php_min_version 5.6.0
9 %include        /usr/lib/rpm/macros.php
10 Summary:        Eventum Issue / Bug tracking system
11 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
12 Name:           eventum
13 Version:        3.3.4
14 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
15 License:        GPL v2+
16 Group:          Applications/WWW
17 #Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
18 Source0:        https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.gz
19 # Source0-md5:  dd6a22d5798358e687b0a68eeb189581
20 Source1:        %{name}-apache.conf
21 Source2:        %{name}-mail-queue.cron
22 Source3:        %{name}-mail-download.cron
23 Source4:        %{name}-reminder.cron
24 Source5:        %{name}-monitor.cron
25 Source8:        %{name}-irc.init
26 Source9:        %{name}-irc.sysconfig
27 Source10:       sphinx.crontab
28 Source13:       %{name}-router-postfix.sh
29 Source14:       %{name}.logrotate
30 Source15:       %{name}-lighttpd.conf
31 Source16:       http://www.isocra.com/images/updown2.gif
32 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
33 Source17:       %{name}.tmpfiles
34 Patch2:         %{name}-order.patch
35 #Patch3:                group-users.patch
36 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
37 # packaging patches that probably never go upstream
38 Patch100:       %{name}-paths.patch
39 Patch107:       %{name}-gettext.patch
40 Patch108:       autoload.patch
41 # some tests
42 Patch200:       %{name}-fixed-nav.patch
43 URL:            https://wiki.github.com/eventum/eventum/
44 BuildRequires:  gettext-tools
45 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
46 BuildRequires:  rpmbuild(macros) >= 1.654
47 BuildRequires:  sed >= 4.0
48 Requires(postun):       /usr/sbin/groupdel
49 Requires(postun):       /usr/sbin/userdel
50 Requires(pre):  /bin/id
51 Requires(pre):  /usr/bin/getgid
52 Requires(pre):  /usr/sbin/groupadd
53 Requires(pre):  /usr/sbin/useradd
54 Requires:       fonts-TTF-RedHat-liberation
55 Requires:       php(core) >= %{php_min_version}
56 Requires:       php(filter)
57 Requires:       php(iconv)
58 Requires:       php(imap)
59 Requires:       php(json)
60 Requires:       php(mbstring)
61 Requires:       php(pcre)
62 Requires:       php(pdo_mysql)
63 Requires:       php(session)
64 Requires:       php-Smarty >= 3.1
65 Requires:       php-Smarty-plugin-gettext
66 Requires:       php-ZendFramework-Config >= 2.4
67 Requires:       php-ZendFramework-Loader >= 2.4
68 Requires:       php-ZendFramework-Mail >= 2.4.13-2
69 Requires:       php-ZendFramework-Mime >= 2.4
70 Requires:       php-ZendFramework-ServiceManager >= 2.4
71 Requires:       php-ZendFramework-Validator >= 2.4
72 Requires:       php-monolog >= 1.17.2
73 Requires:       php-pear-Math_Stats
74 Requires:       php-pear-Net_SMTP
75 Requires:       php-pear-Net_Socket
76 Requires:       php-pear-Net_URL
77 Requires:       php-pear-PEAR-core
78 Requires:       php-pear-Text_Diff
79 Requires:       php-psr-Log >= 1.0.0-2
80 Requires:       phplot >= 5.8.0
81 Requires:       webapps
82 Requires:       webserver(access)
83 Requires:       webserver(alias)
84 Requires:       webserver(indexfile)
85 Requires:       webserver(php) >= 4.2.0
86 Suggests:       localedb
87 Suggests:       php(mcrypt)
88 Suggests:       php(openssl)
89 Suggests:       php-pear-Net_POP3
90 Suggests:       webserver(setenv)
91 Provides:       group(eventum)
92 Provides:       user(eventum)
93 Obsoletes:      eventum-base < 3.0.3-1.305
94 Obsoletes:      eventum-route-drafts < 3.0.8-1.1
95 Obsoletes:      eventum-route-emails < 3.0.8-1.1
96 Obsoletes:      eventum-route-notes < 3.0.8-1.1
97 Conflicts:      logrotate < 3.8.0
98 BuildArch:      noarch
99 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101 %define         _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Auth/SASL.* Util.php smarty_internal.*
102
103 # exclude optional php dependencies
104 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
105
106 %define         _noautoreq      %{_noautophp}
107
108 %define         _libdir         %{_prefix}/lib/%{name}
109 %define         _appdir         %{_datadir}/%{name}
110 %define         _smartydir      %{php_data_dir}/Smarty
111 %define         _webapps        /etc/webapps
112 %define         _webapp         %{name}
113 %define         _webappdir      %{_webapps}/%{_webapp}
114 %define         _sysconfdir     /etc/%{name}
115
116 %description
117 Eventum is a user-friendly and flexible issue tracking system that can
118 be used by a support department to track incoming technical support
119 requests, or by a software development team to quickly organize tasks
120 and bugs.
121
122 %description -l pl.UTF-8
123 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
124 może być używany przez dział obsługi do śledzenia przychodzących żądań
125 obsługi technicznej albo przez zespół tworzący oprogramowanie do
126 szybkiej organizacji zadań i błędów.
127
128 %package setup
129 Summary:        Eventum setup package
130 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
131 Group:          Applications/WWW
132 Requires:       %{name} = %{version}-%{release}
133
134 %description setup
135 Install this package to configure initial Eventum installation. You
136 should uninstall this package when you're done, as it considered
137 insecure to keep the setup files in place.
138
139 %description setup -l pl.UTF-8
140 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
141 pierwszej instalacji. Potem należy go odinstalować, jako że
142 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
143
144 %package doc
145 Summary:        Eventum documentation and Wiki
146 Group:          Documentation
147
148 %description doc
149 Eventum documentation and copy of Wiki.
150
151 %package mail-queue
152 Summary:        Eventum mail queue process
153 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
154 Group:          Applications/WWW
155 Requires:       %{name} = %{version}-%{release}
156 Requires:       crondaemon
157
158 %description mail-queue
159 Beginning with the first release of Eventum, emails are not directly
160 sent out from the various scripts, but rather added to a mail queue
161 table that is processed by a cron job. If an email cannot be sent, it
162 will be marked as such in the mail queue log, and the cron job script
163 will re-try to send it again the next time it runs.
164
165 This package contains the cron job.
166
167 %description mail-queue -l pl.UTF-8
168 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
169 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
170 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
171 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
172 następnym razem.
173
174 Ten pakiet zawiera zadanie dla crona.
175
176 %package mail-download
177 Summary:        Eventum email download
178 Summary(pl.UTF-8):      Ściąganie poczty Eventum
179 Group:          Applications/WWW
180 Requires:       %{name} = %{version}-%{release}
181 Requires:       crondaemon
182
183 %description mail-download
184 In order for Eventum's email integration feature to work, you need to
185 setup a cron job to run the script every so often.
186
187 This package contains the cron job.
188
189 %description mail-download -l pl.UTF-8
190 Aby integracja poczty elektronicznej w Eventum działała, trzeba
191 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
192 często.
193
194 Ten pakiet zawiera zadanie dla crona.
195
196 %package reminder
197 Summary:        Eventum Reminder System
198 Summary(pl.UTF-8):      System przypominania dla Eventum
199 Group:          Applications/WWW
200 Requires:       %{name} = %{version}-%{release}
201 Requires:       crondaemon
202
203 %description reminder
204 The reminder system was designed with the objective as serving as a
205 safe net for issues that need attention. Depending on what
206 configuration you create, you may have several reminders (or alerts)
207 be sent out whenever an issue needs attention, for whatever parameter
208 you may deem necessary.
209
210 This package contains the cron job.
211
212 %description reminder -l pl.UTF-8
213 System przypominania został zaprojektowany tak, aby służył jako
214 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
215 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
216 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
217 uważać za potrzebny.
218
219 Ten pakiet zawiera zadanie dla crona.
220
221 %package monitor
222 Summary:        Eventum Heartbeat Monitor
223 Summary(pl.UTF-8):      Monitor życia dla Eventum
224 Group:          Applications/WWW
225 Requires:       %{name} = %{version}-%{release}
226 Requires:       crondaemon
227 Requires:       php(posix)
228
229 %description monitor
230 The heartbeat monitor is a feature designed for the administrator that
231 wants to be alerted whenever a common problem in Eventum is detected,
232 like the database server not being available anymore, or maybe when
233 the recommended permissions for certain configuration files are
234 changed.
235
236 Please note that before running the heartbeat monitor, you may need to
237 customize some of the checks to be appropriate for your own system,
238 particularly the permission and file checks on
239 Monitor::checkConfiguration().
240
241 This package contains the cron job.
242
243 %description monitor -l pl.UTF-8
244 Monitor życia to funkcjonalność zaprojektowana dla administratora
245 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
246 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
247 do plików konfiguracyjnych.
248
249 Należy zauważyć, że przed uruchomieniem tego monitora może być
250 konieczne dostosowanie niektórych testów do systemu, w szczególności
251 testów uprawnień i plików w Monitor::checkConfiguration().
252
253 Ten pakiet zawiera zadanie dla crona.
254
255 %package router-postfix
256 Summary:        Eventum Mail Routing - Postfix
257 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
258 Group:          Applications/Mail
259 Requires:       %{name} = %{version}-%{release}
260 Requires:       postfix
261 Provides:       eventum(router)
262 Obsoletes:      eventum(router)
263
264 %description router-postfix
265 This package provides way of routing notes and emails back to Eventum
266 via Postfix.
267
268 The Postfix configuration instructions you can find from
269 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
270
271 %description router-postfix -l pl.UTF-8
272 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
273 przez Postfiksa.
274
275 Opis konfiguracji Postfiksa można znaleźć pod adresem
276 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
277
278 %package irc
279 Summary:        Eventum IRC Notification Bot
280 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
281 Group:          Applications/WWW
282 Requires(post,preun):   /sbin/chkconfig
283 Requires:       %{name} = %{version}-%{release}
284 Requires:       php(pcntl)
285 Requires:       php(sockets)
286 Requires:       php-pear-Net_SmartIRC >= 1.1.9
287 Requires:       rc-scripts >= 0.4.0.18
288
289 %description irc
290 The IRC notification bot is a nice feature for remote teams that want
291 to handle issues and want to have a quick and easy way to get simple
292 notifications. Right now the bot notifies of the following actions:
293 - New Issues
294 - Blocked emails
295 - Issues that got their assignment list changed
296
297 NOTE: You will need to manually edit the bot.php script to set your
298 appropriate preferences, like IRC server and channel that the bot
299 should join.
300
301 %description irc -l pl.UTF-8
302 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
303 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
304 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
305 następujących zdarzeniach:
306 - nowych sprawach
307 - zablokowanych listach
308 - sprawach, dla których zmieniła się lista powiązań
309
310 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
311 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
312
313 %package cli
314 Summary:        Eventum command-line interface
315 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
316 Group:          Applications/WWW
317 Requires:       php(core) >= %{php_min_version}
318 Requires:       php(phar)
319
320 %description cli
321 The Eventum command-line interface allows you to access most of the
322 features of the web interface straight from your command shell.
323
324 %description cli -l pl.UTF-8
325 Interfejs linii poleceń Eventum pozwala na dostęp do większości
326 funkcji interfejsu WWW prosto z linii poleceń powłoki.
327
328 %package sphinx
329 Summary:        Eventum Sphinx Search
330 Group:          Applications/WWW
331 Requires:       %{name} = %{version}-%{release}
332 Requires:       crondaemon
333 Requires:       sphinx
334
335 %description sphinx
336 Sphinx search integration for Eventum.
337
338 This package contains the cron job.
339
340 %prep
341 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
342
343 mv docs/examples .
344
345 # bug fixes / features
346 %{?with_order:%patch2 -p1}
347 #%patch3 -p0
348 #%patch4 -p1
349
350 %{?with_order:cp -p %{SOURCE16} htdocs/images}
351
352 #%patch200 -p1
353
354 # produce default sphinx config
355 # must be run before paths.patch
356 %if 0
357 cat <<'EOF' > config/config.php
358 <?php
359 define('APP_SQL_DBTYPE', 'mysql');
360 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
361 define('APP_SQL_DBPORT', 3306);
362 define('APP_SQL_DBNAME', 'eventum');
363 define('APP_SQL_DBUSER', 'mysql');
364 define('APP_SQL_DBPASS', '');
365 define('APP_TABLE_PREFIX', 'eventum_');
366 EOF
367 php config/sphinx.conf.php > config/sphinx.conf
368 rm config/config.php
369 %endif
370
371 # packaging
372 %patch100 -p1
373 %patch107 -p1
374 %patch108 -p1
375
376 rm htdocs/.htaccess.dist
377
378 mv config/irc_config{.dist.php,.php}
379 rm config/config.dist.php
380
381 # cleanup vendor. keep only needed libraries.
382 # (the rest are packaged with system packages)
383 mv vendor vendor.dist
384 vendor() {
385         local path dir
386         for path; do
387                 dir=$(dirname $path)
388                 test -d vendor/$dir || mkdir -p vendor/$dir
389                 mv vendor.dist/$path vendor/$path
390         done
391 }
392 vendor autoload.php
393 vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
394 vendor composer/ClassLoader.php
395 vendor ircmaxell/{random-lib,security-lib}
396 vendor defuse/php-encryption
397 vendor willdurand/email-reply-parser
398 vendor theorchard/monolog-cascade
399 vendor malkusch/lock
400 vendor phpxmlrpc/phpxmlrpc
401 vendor robmorgan/phinx
402 vendor mnapoli/silly
403 vendor psr/container
404 vendor phlib/flysystem-pdo
405 vendor league/flysystem
406 vendor php-di/invoker
407 vendor container-interop/container-interop
408 vendor symfony/config
409 vendor symfony/console
410 vendor symfony/debug
411 vendor symfony/event-dispatcher
412 vendor symfony/filesystem
413 vendor symfony/http-foundation
414 vendor symfony/options-resolver
415 vendor symfony/serializer
416 vendor symfony/yaml
417 vendor symfony/ldap
418 vendor paragonie/random_compat
419 vendor symfony/polyfill-php70
420
421 # remove backups from patching as we use globs to package files to buildroot
422 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
423
424 %build
425 %{__make} -C localization
426
427 %install
428 rm -rf $RPM_BUILD_ROOT
429 install -d \
430         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
431         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
432         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
433         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
434         $RPM_BUILD_ROOT/var/lib/%{name}/{routed_{emails,drafts,notes},storage} \
435         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
436
437 %{__make} install-eventum install-cli install-localization \
438         sysconfdir=%{_webappdir} \
439         localedir=%{_localedir} \
440         DESTDIR=$RPM_BUILD_ROOT
441
442 ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
443
444 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
445
446 # unsupported locale
447 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
448
449 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
450 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
451
452 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
453
454 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
455 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
456 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
457 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
458
459 install -d $RPM_BUILD_ROOT/etc/sphinx
460 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
461 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
462
463 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
464 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
465 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
466 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
467 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
468
469 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
470 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
471
472 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
473
474 # postfix router
475 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
476
477 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
478
479 %find_lang %{name}
480
481 %clean
482 rm -rf $RPM_BUILD_ROOT
483
484 %pre
485 %groupadd -g 146 %{name}
486 %useradd -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
487 %addusertogroup http %{name}
488
489 %post
490 # create empty ghost files
491 # these permissions ensure the logs are write only
492 for a in \
493         errors.log login_attempts.log \
494         eventum.log \
495         auth.log cli.log \
496         irc_bot_error.log irc_bot_smartirc.log \
497 ; do
498         test -f /var/log/%{name}/$a && continue
499         install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
500 done
501
502 # run database update if configured
503 test -s %{_webappdir}/config.php && \
504 %{_appdir}/bin/upgrade.php || :
505
506 # nuke Smarty templates cache after upgrade
507 rm -f /var/cache/eventum/*.php
508
509 # Restart webserver on upgrade to get .mo translations reloaded.
510 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
511 %php_webserver_restart
512
513 %preun
514 if [ "$1" = "0" ]; then
515         # nuke cache
516         rm -f /var/cache/eventum/*.php 2>/dev/null || :
517 fi
518
519 %postun
520 if [ "$1" = "0" ]; then
521         %userremove %{name}
522         %groupremove %{name}
523 fi
524
525 %post setup
526 chmod 660 %{_webappdir}/{config,private_key,secret_key}.php
527 chown root:http %{_webappdir}/{config,private_key,secret_key}.php
528
529 %postun setup
530 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
531         chmod 640 %{_webappdir}/{config,private_key,secret_key}.php
532         chown root:http %{_webappdir}/{config,private_key,secret_key}.php
533 fi
534
535 %post irc
536 /sbin/chkconfig --add eventum-irc
537 %service eventum-irc restart "Eventum IRC Bot"
538
539 %preun irc
540 if [ "$1" = 0 ]; then
541         %service eventum-irc stop
542         /sbin/chkconfig --del eventum-irc
543 fi
544
545 %triggerin -- apache1 < 1.3.37-3, apache1-base
546 %webapp_register apache %{_webapp}
547
548 %triggerun -- apache1 < 1.3.37-3, apache1-base
549 %webapp_unregister apache %{_webapp}
550
551 %triggerin -- apache < 2.2.0, apache-base
552 %webapp_register httpd %{_webapp}
553
554 %triggerun -- apache < 2.2.0, apache-base
555 %webapp_unregister httpd %{_webapp}
556
557 %triggerin -- lighttpd
558 %webapp_register lighttpd %{_webapp}
559
560 %triggerun -- lighttpd
561 %webapp_unregister lighttpd %{_webapp}
562
563 %triggerpostun -- %{name} < 3.0.0-0.2
564 for f in /etc/cron.d/eventum-*; do
565         # crontabs moved to bin
566         %{__sed} -i -e '
567                 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
568                 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
569                 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
570                 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
571         ' $f
572 done
573
574 %files -f %{name}.lang
575 %defattr(644,root,root,755)
576 %attr(751,root,root) %dir %{_webappdir}
577 %attr(751,root,http) %dir %{_webappdir}/crm
578 %attr(751,root,http) %dir %{_webappdir}/custom_field
579 %attr(751,root,http) %dir %{_webappdir}/partner
580 %attr(751,root,http) %dir %{_webappdir}/templates
581 %attr(751,root,http) %dir %{_webappdir}/workflow
582 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
583 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
584 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
585 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
586 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
587 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
588 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
589 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
590
591 %dir %attr(731,root,http) /var/log/%{name}
592 %attr(620,root,http) %ghost /var/log/%{name}/*
593 %dir %attr(750,root,root) /var/log/archive/%{name}
594 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
595
596 %dir %{_appdir}
597 %{_appdir}/config
598
599 %dir %{_appdir}/bin
600 %attr(755,root,root) %{_appdir}/bin/extension.php
601 %attr(755,root,root) %{_appdir}/bin/ldapsync.php
602 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
603 %attr(755,root,root) %{_appdir}/bin/upgrade.php
604
605 %{_appdir}/autoload.php
606 %{_appdir}/globals.php
607 %{_appdir}/init.php
608 %{_appdir}/phinx.php
609 %dir %{_appdir}/htdocs
610 %{_appdir}/htdocs/*.php
611 %{_appdir}/htdocs/*.ico
612 %{_appdir}/htdocs/ajax
613 %{_appdir}/htdocs/css
614 %{_appdir}/htdocs/customer
615 %{_appdir}/htdocs/images
616 %{_appdir}/htdocs/js
617 %{_appdir}/htdocs/manage
618 %{_appdir}/htdocs/reports
619 %{_appdir}/htdocs/rpc
620 %{_appdir}/htdocs/components
621 %{_appdir}/templates
622
623 %dir %{_appdir}/db
624 %dir %{_appdir}/db/migrations
625 %{_appdir}/db/migrations/*.php
626
627 %{_appdir}/res
628 %{_appdir}/src
629 %{_appdir}/vendor
630 %dir %{_appdir}/lib
631 %{_appdir}/lib/eventum
632 %exclude %{_appdir}/src/Console/Command/MailDownloadCommand.php
633 %exclude %{_appdir}/src/Console/Command/MailQueueProcessCommand.php
634 %exclude %{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
635 %exclude %{_appdir}/src/Console/Command/MonitorCommand.php
636 %exclude %{_appdir}/src/Console/Command/ReminderCheckCommand.php
637
638 %dir %{_libdir}
639
640 %{systemdtmpfilesdir}/%{name}.conf
641
642 %dir /var/lib/%{name}
643 %dir %attr(730,root,http) /var/run/%{name}
644 %dir %attr(730,root,http) /var/cache/%{name}
645
646 # saved mail copies
647 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
648 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
649 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
650 # attachment storage
651 %attr(770,root,http) %dir /var/lib/%{name}/storage
652
653 %files setup
654 %defattr(644,root,root,755)
655 %{_appdir}/htdocs/setup
656
657 %files doc
658 %defattr(644,root,root,755)
659 %doc docs/*
660 %{_examplesdir}/%{name}-%{version}
661
662 %files mail-queue
663 %defattr(644,root,root,755)
664 %{_appdir}/src/Console/Command/MailQueueProcessCommand.php
665 %{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
666 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
667 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
668 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
669
670 %files mail-download
671 %defattr(644,root,root,755)
672 %{_appdir}/src/Console/Command/MailDownloadCommand.php
673 %attr(755,root,root) %{_appdir}/bin/download_emails.php
674 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
675
676 %files reminder
677 %defattr(644,root,root,755)
678 %{_appdir}/src/Console/Command/ReminderCheckCommand.php
679 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
680 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
681
682 %files monitor
683 %defattr(644,root,root,755)
684 %{_appdir}/src/Console/Command/MonitorCommand.php
685 %attr(755,root,root) %{_appdir}/bin/monitor.php
686 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
687
688 %files router-postfix
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{_libdir}/router-postfix
691
692 %files irc
693 %defattr(644,root,root,755)
694 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
695 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
696 %attr(755,root,root) %{_appdir}/bin/irc-bot.php
697 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
698
699 %files cli
700 %defattr(644,root,root,755)
701 %doc cli/eventumrc
702 %attr(755,root,root) %{_bindir}/%{name}
703
704 %files sphinx
705 %defattr(644,root,root,755)
706 %{_webappdir}/sphinx.conf.php
707 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
708 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.088179 seconds and 3 git commands to generate.