]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- use system PEAR packages
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
3 # - discard bundled packages (from INSTALL):
4 #  - JpGraph 1.5.3 (last GPL version)
5 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
6 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
7 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
8 #  - A few other small javascript libraries
9 # - create eventum-router-qmail, eventum-router-postfix for -route-mails and -route-notes
10 # - need start-stop-daemon (from dpkg for now)
11 # - use eventum user for irc bot?
12
13 # snapshot: DATE
14 #define _snap 20050124
15
16 %if 0%{?_snap}
17 %define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
18 %else
19 %define _source http://mysql.wildyou.net/Downloads/%{name}/%{name}-%{version}.tar.gz
20 %endif
21
22 %define _rel 1.129
23
24 Summary:        Eventum Issue - a bug tracking system
25 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
26 Name:           eventum
27 Version:        1.4
28 Release:        %{?_snap:0.%{_snap}.}%{_rel}
29 License:        GPL
30 Group:          Applications/WWW
31 Source0:        %{_source}
32 # Source0-md5:  361c1355e46a6bbfa54e420964ec92cf
33 Source1:        %{name}-apache.conf
34 Source2:        %{name}-mail-queue.cron
35 Source3:        %{name}-mail-download.cron
36 Source4:        %{name}-reminder.cron
37 Source5:        %{name}-monitor.cron
38 Source6:        %{name}-cvs.php
39 Source7:        %{name}-irc.php
40 Source8:        %{name}-irc.init
41 # packaging
42 Patch0:         %{name}-paths.patch
43 Patch1:         %{name}-scm-encode.patch
44 Patch2:         %{name}-cvs-config.patch
45 Patch3:         %{name}-irc-config.patch
46 # bug fixes
47 Patch10:                %{name}-clock-status.patch
48 Patch11:                %{name}-scm_checkin_associated.patch
49 Patch12:                %{name}-mail-queue.tpl.patch
50 URL:            http://dev.mysql.com/downloads/other/eventum/index.html
51 BuildRequires:  rpmbuild(macros) >= 1.177
52 BuildRequires:  sed >= 4.0
53 Requires:       php >= 4.1.0
54 Requires:       php-gd
55 Requires:       php-imap
56 Requires:       php-mysql
57 Requires:       php-pcre
58 Requires:       Smarty >= 2.6.2
59 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
60 Requires:       php-pear-Benchmark
61 Requires:       php-pear-DB
62 Requires:       php-pear-Date
63 Requires:       php-pear-HTTP_Request
64 Requires:       php-pear-Mail
65 Requires:       php-pear-Math_Stats
66 Requires:       php-pear-Net_DIME
67 Requires:       php-pear-Net_POP3
68 Requires:       php-pear-Net_SMTP
69 Requires:       php-pear-Net_SmartIRC
70 Requires:       php-pear-Net_Socket
71 Requires:       php-pear-Net_URL
72 Requires:       php-pear-Net_UserAgent_Detect
73 Requires:       php-pear-PEAR
74 Requires:       php-pear-Text_Diff
75 Requires:       php-pear-XML_RPC
76 #Requires:      apache-mod_dir
77 # conflict with non-confdir apache
78 Conflicts:      apache1 < 1.3.33-1.1
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %define         _sysconfdir     /etc/%{name}
82 %define         _appdir %{_datadir}/%{name}
83 %define         _smartyplugindir        %{php_pear_dir}/Smarty/plugins
84
85 %define         _apache1dir     /etc/apache
86 %define         _apache2dir     /etc/httpd
87
88 %description
89 Eventum is a user-friendly and flexible issue tracking system that can
90 be used by a support department to track incoming technical support
91 requests, or by a software development team to quickly organize tasks
92 and bugs. Eventum is used by the MySQL AB Technical Support team, and
93 has allowed us to dramatically improve our response times.
94
95 %description -l pl
96 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
97 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
98 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
99 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
100 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
101 reakcji.
102
103 %package base
104 Summary:        Eventum base package
105 Group:          Applications/WWW
106
107 %description base
108 This package contains base directory structure for Eventum.
109
110 %package setup
111 Summary:        Eventum setup package
112 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
113 Group:          Applications/WWW
114 PreReq:         %{name} = %{epoch}:%{version}-%{release}
115
116 %description setup
117 Install this package to configure initial Eventum installation. You
118 should uninstall this package when you're done, as it considered
119 insecure to keep the setup files in place.
120
121 %description setup -l pl
122 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
123 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
124 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
125
126 %package mail-queue
127 Summary:        Eventum mail queue process
128 Summary(pl):    Przetwarzanie kolejki poczty Eventum
129 Group:          Applications/WWW
130 Requires:       %{name} = %{epoch}:%{version}-%{release}
131 Requires:       crondaemon
132 Requires:       php4 >= 4.1.0
133
134 %description mail-queue
135 Beginning with the first release of Eventum, emails are not directly
136 sent out from the various scripts, but rather added to a mail queue
137 table that is processed by a cron job. If an email cannot be sent, it
138 will be marked as such in the mail queue log, and the cron job script
139 will re-try to send it again the next time it runs.
140
141 This package contains the cron job.
142
143 %description mail-queue -l pl
144 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
145 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
146 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
147 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
148 nastêpnym razem.
149
150 Ten pakiet zawiera zadanie dla crona.
151
152 %package mail-download
153 Summary:        Eventum email download
154 Summary(pl):    ¦ci±ganie poczty Eventum
155 Group:          Applications/WWW
156 Requires:       %{name} = %{epoch}:%{version}-%{release}
157 Requires:       crondaemon
158 Requires:       php4 >= 4.1.0
159
160 %description mail-download
161 In order for Eventum's email integration feature to work, you need to
162 setup a cron job to run the script every so often.
163
164 This package contains the cron job.
165
166 %description mail-download -l pl
167 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
168 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
169 czêsto.
170
171 Ten pakiet zawiera zadanie dla crona.
172
173 %package reminder
174 Summary:        Eventum Reminder System
175 Summary(pl):    System przypominania dla Eventum
176 Group:          Applications/WWW
177 Requires:       %{name} = %{epoch}:%{version}-%{release}
178 Requires:       php4 >= 4.1.0
179 Requires:       crondaemon
180
181 %description reminder
182 The reminder system was designed with the objective as serving as a
183 safe net for issues that need attention. Depending on what
184 configuration you create, you may have several reminders (or alerts)
185 be sent out whenever an issue needs attention, for whatever parameter
186 you may deem necessary.
187
188 This package contains the cron job.
189
190 %description reminder -l pl
191 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
192 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
193 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
194 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
195 uwa¿aæ za potrzebny.
196
197 Ten pakiet zawiera zadanie dla crona.
198
199 %package monitor
200 Summary:        Eventum Heartbeat Monitor
201 Summary(pl):    Monitor ¿ycia dla Eventum
202 Group:          Applications/WWW
203 Requires:       %{name} = %{epoch}:%{version}-%{release}
204 Requires:       php4 >= 4.1.0
205 Requires:       crondaemon
206
207 %description monitor
208 The heartbeat monitor is a feature designed for the administrator that
209 wants to be alerted whenever a common problem in Eventum is detected,
210 like the database server not being available anymore, or maybe when
211 the recommended permissions for certain configuration files are
212 changed.
213
214 Please note that before running the heartbeat monitor, you may need to
215 customize some of the checks to be appropriate for your own system,
216 particularly the permission and file checks on
217 Monitor::checkConfiguration().
218
219 This package contains the cron job.
220
221 %description monitor -l pl
222 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
223 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
224 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
225 do plików konfiguracyjnych.
226
227 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
228 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
229 testów uprawnieñ i plików w Monitor::checkConfiguration().
230
231 Ten pakiet zawiera zadanie dla crona.
232
233 %package route-emails
234 Summary:        Eventum Email Routing
235 Summary(pl):    Przekazywanie poczty dla Eventum
236 Group:          Applications/WWW
237 Requires:       %{name} = %{epoch}:%{version}-%{release}
238 Requires:       php4 >= 4.1.0
239 #Requires:      eventum-router
240
241 %description route-emails
242 The email routing feature is used to automatically associate a thread
243 of emails into an Eventum issue. By setting up qmail (or even postfix)
244 to deliver emails sent to a specific address (usually
245 issue-<number>@<domain>) to the above script, users are able to use
246 their email clients to reply to emails coming from Eventum, and those
247 replies will be automatically associated with the issue and
248 broadcasted to the entire notification list.
249
250 %description route-emails -l pl
251 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
252 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
253 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
254 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
255 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
256 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
257 rozprowadzane do ca³ej listy og³oszeniowej.
258
259 %package route-notes
260 Summary:        Eventum Note Routing
261 Summary(pl):    Przekazywanie notatek dla Eventum
262 Group:          Applications/WWW
263 Requires:       %{name} = %{epoch}:%{version}-%{release}
264 Requires:       php4 >= 4.1.0
265 #Requires:      eventum-router
266
267 %description route-notes
268 The note routing feature is used to automatically associate a thread
269 of notes into an Eventum issue. By setting up qmail (or even postfix)
270 to deliver emails sent to a specific address (usually
271 note-<number>@<domain>) to the above script, users are able to use
272 their email clients to reply to internal notes coming from Eventum,
273 and those replies will be automatically associated with the issue and
274 broadcasted to the notification list staff members.
275
276 %description route-notes -l pl
277 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
278 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
279 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
280 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
281 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
282 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
283 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
284
285 %package irc
286 Summary:        Eventum IRC Notification Bot
287 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
288 Group:          Applications/WWW
289 Requires:       %{name} = %{epoch}:%{version}-%{release}
290 Requires:       php >= 4.1.0
291 Requires:       php-sockets
292 # FIXME just need start-stop-daemon
293 Requires:       dpkg
294
295 %description irc
296 The IRC notification bot is a nice feature for remote teams that want
297 to handle issues and want to have a quick and easy way to get simple
298 notifications. Right now the bot notifies of the following actions:
299 - New Issues
300 - Blocked emails
301 - Issues that got their assignment list changed
302
303 NOTE: You will need to manually edit the bot.php script to set your
304 appropriate preferences, like IRC server and channel that the bot
305 should join.
306
307 %description irc -l pl
308 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
309 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
310 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
311 nastêpuj±cych zdarzeniach:
312 - nowych sprawach
313 - zablokowanych listach
314 - sprawach, dla których zmieni³a siê lista powi±zañ
315
316 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
317 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
318
319 %package cli
320 Summary:        Eventum command-line interface
321 Summary(pl):    Interfejs linii poleceñ dla Eventum
322 Group:          Applications/WWW
323 Requires:       %{name} = %{epoch}:%{version}-%{release}
324 Requires:       php4 >= 4.1.0
325 Requires:       php4-cli
326 Requires:       php4-curl
327 Requires:       php4-xml
328 Requires:       php-pear-XML_RPC
329
330 %description cli
331 The Eventum command-line interface allows you to access most of the
332 features of the web interface straight from your command shell.
333
334 %description cli -l pl
335 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
336 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
337
338 %package scm
339 Summary:        Eventum SCM integration
340 Summary(pl):    Integracja SCM dla Eventum
341 Group:          Applications/WWW
342 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
343 Requires:       php4 >= 4.1.0
344
345 %description scm
346 This feature allows your software development teams to integrate your
347 Source Control Management system with your Issue Tracking System.
348
349 The integration is implemented in such a way that it will be forward
350 compatible with pretty much any SCM system, such as CVS.
351
352 For installation see
353 /eventum/help.php?topic=scm_integration_installation .
354
355 %description scm -l pl
356 Ten pakiet pozwala zespo³om programistów na integracjê systemu
357 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
358 ¶ledzenia spraw.
359
360 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
361 prawie ka¿dym systemem SCM, jak np. CVS.
362
363 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
364 /eventum/help.php?topic=scm_integration_installation .
365
366 %prep
367 %setup -q %{?_snap:-n %{name}-%{_snap}}
368 %patch0 -p1
369 %patch1 -p1
370 %patch2 -p1
371 %patch3 -p1
372
373 %patch10 -p1
374 %patch11 -p1
375 %patch12 -p1
376
377 %build
378
379 %install
380 rm -rf $RPM_BUILD_ROOT
381 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_appdir}} \
382         $RPM_BUILD_ROOT{/etc/{rc.d/init.d,cron.d},/var/log} \
383         $RPM_BUILD_ROOT{/var/run/eventum,/var/cache/eventum}
384
385 rm -f eventumrc %{name}-scm
386 cp -a . $RPM_BUILD_ROOT%{_appdir}
387 # argsh! say no words
388 find $RPM_BUILD_ROOT%{_appdir} -type f -print0 | xargs -0 sed -i -e 's,
389 $,,'
390 sed -e 's,
391 $,,' misc/cli/eventumrc_example > eventumrc
392
393 > $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
394
395 sed -i -e 's,/usr/local/bin/php,/usr/bin/php4,' $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum
396 echo '#!/usr/bin/php4 -q' > %{name}-scm
397 cat $RPM_BUILD_ROOT%{_appdir}/misc/scm/process_cvs_commits.php >> %{name}-scm
398
399 # change private key, so we can easily grep
400 sed -i -e '
401 s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
402 ' $RPM_BUILD_ROOT%{_appdir}/include/private_key.php
403
404 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
405 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
406 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
407 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
408 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
409 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
410 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
411 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
412
413 # in conf
414 mv $RPM_BUILD_ROOT%{_appdir}/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/config.php
415 mv $RPM_BUILD_ROOT%{_appdir}/setup.conf.php $RPM_BUILD_ROOT%{_sysconfdir}/setup.php
416 mv $RPM_BUILD_ROOT%{_appdir}/include/private_key.php $RPM_BUILD_ROOT%{_sysconfdir}
417 mv $RPM_BUILD_ROOT%{_appdir}/misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
418 ln -s %{_sysconfdir}/config.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
419 ln -s %{_sysconfdir}/setup.php $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
420 ln -s %{_sysconfdir}/private_key.php $RPM_BUILD_ROOT%{_appdir}/include/private_key.php
421
422 # log directory
423 mv $RPM_BUILD_ROOT%{_appdir}/logs $RPM_BUILD_ROOT/var/log/%{name}
424
425 # in doc
426 rm -f $RPM_BUILD_ROOT%{_appdir}/{COPYING,ChangeLog,FAQ,INSTALL,README,UPGRADE}
427 rm -rf $RPM_BUILD_ROOT%{_appdir}/{docs,misc/upgrade}
428 # some sample, not used in eventum
429 rm -rf $RPM_BUILD_ROOT%{_appdir}/rpc/xmlrpc_client.php
430
431 # use system Smarty
432 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
433 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
434 # These plugins are not in Smarty package (Smarty-2.6.2-3)
435 cp -a include/Smarty/plugins/function.{calendar,get_display_style,get_innerhtml,get_textarea_size}.php $RPM_BUILD_ROOT%{_smartyplugindir}
436
437 # in bindir
438 mv $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum $RPM_BUILD_ROOT%{_bindir}
439 rm -f $RPM_BUILD_ROOT%{_appdir}/misc/{cli/eventumrc_example,scm/process_cvs_commits.php}
440 install %{name}-scm $RPM_BUILD_ROOT%{_bindir}/%{name}-scm
441
442 # provided by PEAR
443 rm -rf $RPM_BUILD_ROOT%{_appdir}/misc/cli/include/pear
444 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
445
446 %clean
447 rm -rf $RPM_BUILD_ROOT
448
449 %post
450 # apache1
451 if [ -f %{_apache1dir}/apache.conf ]; then
452         ln -sf %{_sysconfdir}/apache.conf %{_apache1dir}/conf.d/99_%{name}.conf
453         if [ -f /var/lock/subsys/apache ]; then
454                 /etc/rc.d/init.d/apache restart 1>&2
455         fi
456 fi
457 # apache2
458 if [ -d %{_apache2dir}/httpd.conf ]; then
459         ln -sf %{_sysconfdir}/apache.conf %{_apache2dir}/httpd.conf/99_%{name}.conf
460         if [ -f /var/lock/subsys/httpd ]; then
461                 /etc/rc.d/init.d/httpd restart 1>&2
462         fi
463 fi
464
465 # check if the package is configured.
466 if grep -q 'header("Location: setup/")' %{_sysconfdir}/config.php; then
467 %banner %{name} -e <<EOF
468
469 You haven't yet configured Eventum!
470
471 Install %{name}-setup and open up http://yourserver/eventum/
472 -- that will help you setup initial config.
473
474 when have configured Eventum, please uninstall the setup package,
475 so that %{name}-setup is able to secure your Eventum installation.
476
477 EOF
478 #' vim stupidity.
479
480 elif grep -q 'DEFAULTPRIVATEKEY' %{_sysconfdir}/private_key.php; then
481 %banner %{name} -e <<EOF
482
483 You have default private key installed!
484
485 Install %{name}-setup and open up http://yourserver/eventum/setup/
486 -- that will help you setup initial config.
487
488 when have configured Eventum, please uninstall the setup package,
489 so that %{name}-setup is able to secure your Eventum installation.
490
491 EOF
492         elif [ -d %{_appdir}/setup ]; then
493 %banner %{name} -e <<EOF
494
495 If you have have configured Eventum, please uninstall the setup package,
496 so that %{name}-setup is able to secure your Eventum installation.
497
498 EOF
499 fi
500
501
502 %preun
503 if [ "$1" = "0" ]; then
504         # apache1
505         if [ -f %{_apache1dir}/apache.conf ]; then
506                 rm -f %{_apache1dir}/conf.d/99_%{name}.conf
507                 if [ -f /var/lock/subsys/apache ]; then
508                         /etc/rc.d/init.d/apache restart 1>&2
509                 fi
510         fi
511         # apache2
512         if [ -d %{_apache2dir}/httpd.conf ]; then
513                 rm -f %{_apache1dir}/httpd.conf/99_%{name}.conf
514                 if [ -f /var/lock/subsys/httpd ]; then
515                         /etc/rc.d/init.d/httpd restart 1>&2
516                 fi
517         fi
518 fi
519
520 %post setup
521 chmod 660 %{_sysconfdir}/{config,private_key}.php
522 chown root:http %{_sysconfdir}/{config,private_key}.php
523
524 %postun setup
525 if [ "$1" = "0" ]; then
526         chmod 640 %{_sysconfdir}/{config,private_key}.php
527         chown root:http %{_sysconfdir}/{config,private_key}.php
528 fi
529
530 %files
531 %defattr(644,root,root,755)
532 %doc ChangeLog FAQ INSTALL README UPGRADE misc/upgrade docs/* rpc/xmlrpc_client.php
533 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
534 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
535 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/private_key.php
536 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/setup.php
537
538 %dir %{_appdir}
539 %dir %{_appdir}/misc
540
541 %dir %attr(731,root,http) /var/log/%{name}
542 %attr(620,root,http) %ghost /var/log/%{name}/*
543
544 %{_smartyplugindir}/*
545
546 %{_appdir}/*.php
547 %{_appdir}/css
548 %{_appdir}/customer
549 %{_appdir}/images
550 %{_appdir}/js
551 %{_appdir}/manage
552 %{_appdir}/reports
553 %{_appdir}/rpc
554 %{_appdir}/templates
555
556 %dir %{_appdir}/include
557 %{_appdir}/include/customer
558 %{_appdir}/include/jpgraph
559 %{_appdir}/include/workflow
560 %{_appdir}/include/*.php
561
562 %dir %attr(730,root,http) /var/run/%{name}
563 %dir %attr(730,root,http) /var/cache/%{name}
564
565 %{_appdir}/misc/blank.html
566
567 %files base
568 %defattr(644,root,root,755)
569 %attr(751,root,root) %dir %{_sysconfdir}
570
571 %files setup
572 %defattr(644,root,root,755)
573 %{_appdir}/setup
574
575 %files mail-queue
576 %defattr(644,root,root,755)
577 %{_appdir}/misc/process_mail_queue.php
578 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
579
580 %files mail-download
581 %defattr(644,root,root,755)
582 %{_appdir}/misc/download_emails.php
583 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
584
585 %files reminder
586 %defattr(644,root,root,755)
587 %{_appdir}/misc/check_reminders.php
588 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
589
590 %files monitor
591 %defattr(644,root,root,755)
592 %{_appdir}/misc/monitor.php
593 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
594
595 %files route-emails
596 %defattr(644,root,root,755)
597 %{_appdir}/misc/route_emails.php
598
599 %files route-notes
600 %defattr(644,root,root,755)
601 %{_appdir}/misc/route_drafts.php
602 %{_appdir}/misc/route_notes.php
603
604 %files irc
605 %defattr(644,root,root,755)
606 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
607 %{_appdir}/misc/irc
608 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
609
610 %files cli
611 %defattr(644,root,root,755)
612 %doc eventumrc
613 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cli.php
614 %attr(755,root,root) %{_bindir}/%{name}
615 %dir %{_appdir}/misc/cli
616 %{_appdir}/misc/cli/include
617
618 %files scm
619 %defattr(644,root,root,755)
620 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
621 # FIXME: not sure about this naming.
622 %attr(755,root,root) %{_bindir}/%{name}-scm
This page took 0.084416 seconds and 3 git commands to generate.