]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
- add sample permission grant script
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 # - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
9 #
10 # Conditional build:
11 %bcond_with     qmail   # build the router-qmail subpackage
12 %bcond_with     order_patch     # with custom issue order patch
13
14 #define _snap   20060330
15 #define _rc             RC3
16 %define _rel    2.26
17
18 %include        /usr/lib/rpm/macros.php
19 Summary:        Eventum Issue / Bug tracking system
20 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
21 Name:           eventum
22 Version:        1.7.1
23 Release:        %{?_snap:0.%{_snap}.}%{?_rc:%{_rc}.}%{_rel}
24 License:        GPL
25 Group:          Applications/WWW
26 #Source0:       http://downloads.mysql.com/snapshots/eventum/%{name}-nightly-%{_snap}.tar.gz
27 Source0:        http://mysql.dataphone.se/Downloads/eventum/%{name}-%{version}.tar.gz
28 # Source0-md5:  e1845de39b4d9bd30ddec9c26031a7d5
29 Source1:        %{name}-apache.conf
30 Source2:        %{name}-mail-queue.cron
31 Source3:        %{name}-mail-download.cron
32 Source4:        %{name}-reminder.cron
33 Source5:        %{name}-monitor.cron
34 Source6:        %{name}-cvs.php
35 Source7:        %{name}-irc.php
36 Source8:        %{name}-irc.init
37 Source9:        %{name}-irc.sysconfig
38 Source10:       %{name}-config.php
39 Source11:       %{name}-router-qmail.sh
40 Source12:       %{name}-config-setup.php
41 Source13:       %{name}-upgrade.sh
42 Source14:       %{name}-router-postfix.sh
43 Source15:       %{name}.logrotate
44 Patch0:         %{name}-lf.patch
45 Patch1:         %{name}-perms.patch
46 Patch2:         %{name}-cli-wr-separated.patch
47 Patch3:         %{name}-scm-parse-response.patch
48 Patch4:         %{name}-double-decode.patch
49 Patch5:         %{name}-route-mem.patch
50 Patch6:         %{name}-scm-pluscharisbad.patch
51 Patch7:         %{name}-scm-updates.patch
52 Patch8:         %{name}-close-signature.patch
53 Patch9:         %{name}-list-sorting.patch
54 Patch10:        %{name}-workflow-handlenewnote-note_id.patch
55 Patch11:        %{name}-order4b.patch
56 Patch12:        %{name}-cli-errorcheck.patch
57 Patch13:        %{name}-combined.patch
58 Patch14:        %{name}-xml-inline.patch
59 Patch15:        %{name}-timetracking-advanced-logic.patch
60 Patch16:        %{name}-timedisplay.patch
61 Patch17:        %{name}-bug-17267.patch
62 Patch18:        %{name}-compact-issue-display.patch
63 Patch19:        %{name}-fixed-nav.patch
64 # packaging patches that probably never go upstream
65 Patch100:       %{name}-paths.patch
66 Patch101:       %{name}-cvs-config.patch
67 Patch102:       %{name}-irc-mem.patch
68 Patch103:       %{name}-irc-config.patch
69 Patch104:       %{name}-PEAR.patch
70 Patch105:       %{name}-httpclient-clientside.patch
71 Patch106:       %{name}-bot-reconnect.patch
72 Patch107:       %{name}-private-key.patch
73 URL:            http://dev.mysql.com/downloads/other/eventum/
74 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
75 BuildRequires:  rpmbuild(macros) >= 1.268
76 BuildRequires:  sed >= 4.0
77 Requires(triggerpostun):        /usr/bin/php
78 Requires(triggerpostun):        sed >= 4.0
79 Requires:       %{name}-base = %{version}-%{release}
80 Requires:       Smarty >= 2.6.10-4
81 Requires:       apache(mod_dir)
82 Requires:       php >= 3:4.2.0
83 Requires:       php-gd
84 Requires:       php-imap
85 Requires:       php-mysql
86 Requires:       php-pcre
87 Requires:       php-pear-Benchmark
88 Requires:       php-pear-DB
89 Requires:       php-pear-Date
90 Requires:       php-pear-HTTP_Request
91 Requires:       php-pear-Mail
92 Requires:       php-pear-Mail_Mime
93 Requires:       php-pear-Math_Stats
94 Requires:       php-pear-Net_DIME
95 Requires:       php-pear-Net_SMTP
96 Requires:       php-pear-Net_Socket
97 Requires:       php-pear-Net_URL
98 Requires:       php-pear-Net_UserAgent_Detect
99 Requires:       php-pear-PEAR-core
100 Requires:       php-pear-Text_Diff
101 Requires:       php-pear-XML_RPC
102 Requires:       php-session
103 Requires:       webapps
104 BuildArch:      noarch
105 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
106
107 %define         _noautoreq      'pear(/etc/webapps/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)'
108
109 %define         _libdir         %{_prefix}/lib/%{name}
110 %define         _appdir         %{_datadir}/%{name}
111 %define         _smartyplugindir        %{_appdir}/include/smarty
112 %define         _smartydir      /usr/share/php/Smarty
113 %define         _webapps        /etc/webapps
114 %define         _webapp         %{name}
115 %define         _webappdir      %{_webapps}/%{_webapp}
116 %define         _sysconfdir     /etc/%{name}
117
118 %description
119 Eventum is a user-friendly and flexible issue tracking system that can
120 be used by a support department to track incoming technical support
121 requests, or by a software development team to quickly organize tasks
122 and bugs. Eventum is used by the MySQL AB Technical Support team, and
123 has allowed us to dramatically improve our response times.
124
125 %description -l pl
126 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
127 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
128 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
129 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
130 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
131 reakcji.
132
133 %package base
134 Summary:        Eventum base package
135 Summary(pl):    Podstawowy pakiet Eventum
136 Group:          Applications/WWW
137 Requires(postun):       /usr/sbin/groupdel
138 Requires(postun):       /usr/sbin/userdel
139 Requires(pre):  /bin/id
140 Requires(pre):  /usr/bin/getgid
141 Requires(pre):  /usr/sbin/groupadd
142 Requires(pre):  /usr/sbin/useradd
143 Provides:       group(eventum)
144 Provides:       user(eventum)
145
146 %description base
147 This package contains base directory structure for Eventum.
148
149 %description base -l pl
150 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
151
152 %package setup
153 Summary:        Eventum setup package
154 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
155 Group:          Applications/WWW
156 Requires:       %{name} = %{version}-%{release}
157
158 %description setup
159 Install this package to configure initial Eventum installation. You
160 should uninstall this package when you're done, as it considered
161 insecure to keep the setup files in place.
162
163 %description setup -l pl
164 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
165 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
166 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
167
168 %package mail-queue
169 Summary:        Eventum mail queue process
170 Summary(pl):    Przetwarzanie kolejki poczty Eventum
171 Group:          Applications/WWW
172 Requires:       %{name} = %{version}-%{release}
173 Requires:       crondaemon
174
175 %description mail-queue
176 Beginning with the first release of Eventum, emails are not directly
177 sent out from the various scripts, but rather added to a mail queue
178 table that is processed by a cron job. If an email cannot be sent, it
179 will be marked as such in the mail queue log, and the cron job script
180 will re-try to send it again the next time it runs.
181
182 This package contains the cron job.
183
184 %description mail-queue -l pl
185 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
186 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
187 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
188 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
189 nastêpnym razem.
190
191 Ten pakiet zawiera zadanie dla crona.
192
193 %package mail-download
194 Summary:        Eventum email download
195 Summary(pl):    ¦ci±ganie poczty Eventum
196 Group:          Applications/WWW
197 Requires:       %{name} = %{version}-%{release}
198 Requires:       crondaemon
199
200 %description mail-download
201 In order for Eventum's email integration feature to work, you need to
202 setup a cron job to run the script every so often.
203
204 This package contains the cron job.
205
206 %description mail-download -l pl
207 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
208 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
209 czêsto.
210
211 Ten pakiet zawiera zadanie dla crona.
212
213 %package reminder
214 Summary:        Eventum Reminder System
215 Summary(pl):    System przypominania dla Eventum
216 Group:          Applications/WWW
217 Requires:       %{name} = %{version}-%{release}
218 Requires:       crondaemon
219
220 %description reminder
221 The reminder system was designed with the objective as serving as a
222 safe net for issues that need attention. Depending on what
223 configuration you create, you may have several reminders (or alerts)
224 be sent out whenever an issue needs attention, for whatever parameter
225 you may deem necessary.
226
227 This package contains the cron job.
228
229 %description reminder -l pl
230 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
231 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
232 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
233 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
234 uwa¿aæ za potrzebny.
235
236 Ten pakiet zawiera zadanie dla crona.
237
238 %package monitor
239 Summary:        Eventum Heartbeat Monitor
240 Summary(pl):    Monitor ¿ycia dla Eventum
241 Group:          Applications/WWW
242 Requires:       %{name} = %{version}-%{release}
243 Requires:       crondaemon
244 Requires:       php-posix
245
246 %description monitor
247 The heartbeat monitor is a feature designed for the administrator that
248 wants to be alerted whenever a common problem in Eventum is detected,
249 like the database server not being available anymore, or maybe when
250 the recommended permissions for certain configuration files are
251 changed.
252
253 Please note that before running the heartbeat monitor, you may need to
254 customize some of the checks to be appropriate for your own system,
255 particularly the permission and file checks on
256 Monitor::checkConfiguration().
257
258 This package contains the cron job.
259
260 %description monitor -l pl
261 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
262 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
263 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
264 do plików konfiguracyjnych.
265
266 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
267 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
268 testów uprawnieñ i plików w Monitor::checkConfiguration().
269
270 Ten pakiet zawiera zadanie dla crona.
271
272 %package route-drafts
273 Summary:        Eventum Draft Routing
274 Summary(pl):    Przekazywanie szkiców dla Eventum
275 Group:          Applications/WWW
276 Requires:       %{name} = %{version}-%{release}
277 Requires:       eventum(router)
278
279 %description route-drafts
280 The draft routing feature is used to automatically associate a thread
281 of drafts into an Eventum issue. By setting up qmail (or even Postfix)
282 to deliver emails sent to a specific address (usually
283 draft-<number>@<domain>) to the above script, users are able to send
284 drafts written in their mail client to be stored in Eventum. These
285 drafts will NOT broadcasted to the notification list.
286
287 %description route-drafts -l pl
288 Przekazywanie szkiców s³u¿y do automatycznego wi±zania w±tku szkiców z
289 problemem w Eventum. Ustawiaj±c qmaila (czy nawet Postfiksa), aby
290 dostarcza³ pocztê wys³an± na podany adres (zwykle
291 draft-<liczba>@<domena>) do tego skryptu umo¿liwia siê u¿ytkownikom
292 wysy³anie szkiców napisanych w ich kliencie pocztowym do zapisania w
293 Eventum. Szkice te NIE bêd± wysy³ane na listê powiadomieñ.
294
295 %package route-emails
296 Summary:        Eventum Email Routing
297 Summary(pl):    Przekazywanie poczty dla Eventum
298 Group:          Applications/WWW
299 Requires:       %{name} = %{version}-%{release}
300 Requires:       eventum(router)
301
302 %description route-emails
303 The email routing feature is used to automatically associate a thread
304 of emails into an Eventum issue. By setting up qmail (or even postfix)
305 to deliver emails sent to a specific address (usually
306 issue-<number>@<domain>) to the above script, users are able to use
307 their email clients to reply to emails coming from Eventum, and those
308 replies will be automatically associated with the issue and
309 broadcasted to the entire notification list.
310
311 %description route-emails -l pl
312 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
313 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
314 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
315 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
316 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
317 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
318 rozprowadzane do ca³ej listy og³oszeniowej.
319
320 %package route-notes
321 Summary:        Eventum Note Routing
322 Summary(pl):    Przekazywanie notatek dla Eventum
323 Group:          Applications/WWW
324 Requires:       %{name} = %{version}-%{release}
325 Requires:       eventum(router)
326
327 %description route-notes
328 The note routing feature is used to automatically associate a thread
329 of notes into an Eventum issue. By setting up qmail (or even postfix)
330 to deliver emails sent to a specific address (usually
331 note-<number>@<domain>) to the above script, users are able to use
332 their email clients to reply to internal notes coming from Eventum,
333 and those replies will be automatically associated with the issue and
334 broadcasted to the notification list staff members.
335
336 %description route-notes -l pl
337 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
338 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
339 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
340 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
341 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
342 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
343 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
344
345 %package router-qmail
346 Summary:        Eventum Mail Routing - qmail
347 Summary(pl):    Przekazywanie poczty Eventum - qmail
348 Group:          Applications/Mail
349 # loose dep is intentional. qmail subpackage isn't built on PLD
350 # builders and there really nothing changes.
351 Requires:       %{name} >= %{version}-%{release}
352 Requires:       qmail >= 1.03
353 Provides:       eventum(router)
354 Obsoletes:      eventum(router)
355
356 %description router-qmail
357 This package provides way of routing notes and emails back to Eventum
358 via qmail.
359
360 %description router-qmail -l pl
361 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
362 przez qmaila.
363
364 %package router-postfix
365 Summary:        Eventum Mail Routing - Postfix
366 Summary(pl):    Przekazywanie poczty Eventum - Postfix
367 Group:          Applications/Mail
368 Requires:       %{name} = %{version}-%{release}
369 Requires:       postfix
370 Provides:       eventum(router)
371 Obsoletes:      eventum(router)
372
373 %description router-postfix
374 This package provides way of routing notes and emails back to Eventum
375 via Postfix.
376
377 The Postfix configuration instructions you can find from
378 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
379
380 %description router-postfix -l pl
381 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
382 przez Postfiksa.
383
384 Opis konfiguracji Postfiksa mo¿na znale¼æ pod adresem
385 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
386
387 %package irc
388 Summary:        Eventum IRC Notification Bot
389 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
390 Group:          Applications/WWW
391 Requires(post,preun):   /sbin/chkconfig
392 Requires(triggerpostun):        sed >= 4.0
393 Requires:       %{name} = %{version}-%{release}
394 Requires:       php-pear-Net_SmartIRC
395 Requires:       php-sockets
396 Requires:       rc-scripts >= 0.4.0.18
397
398 %description irc
399 The IRC notification bot is a nice feature for remote teams that want
400 to handle issues and want to have a quick and easy way to get simple
401 notifications. Right now the bot notifies of the following actions:
402 - New Issues
403 - Blocked emails
404 - Issues that got their assignment list changed
405
406 NOTE: You will need to manually edit the bot.php script to set your
407 appropriate preferences, like IRC server and channel that the bot
408 should join.
409
410 %description irc -l pl
411 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
412 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
413 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
414 nastêpuj±cych zdarzeniach:
415 - nowych sprawach
416 - zablokowanych listach
417 - sprawach, dla których zmieni³a siê lista powi±zañ
418
419 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
420 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
421
422 %package cli
423 Summary:        Eventum command-line interface
424 Summary(pl):    Interfejs linii poleceñ dla Eventum
425 Group:          Applications/WWW
426 Requires:       %{name}-base = %{version}-%{release}
427 Requires:       php-cli
428 Requires:       php-common >= 3:4.1.0
429 Requires:       php-pear-XML_RPC
430
431 %description cli
432 The Eventum command-line interface allows you to access most of the
433 features of the web interface straight from your command shell.
434
435 %description cli -l pl
436 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
437 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
438
439 %package scm
440 Summary:        Eventum SCM integration
441 Summary(pl):    Integracja SCM dla Eventum
442 Group:          Applications/WWW
443 Requires:       %{name}-base = %{version}-%{release}
444 Requires:       php-cli
445 Requires:       php-common >= 3:4.1.0
446 Requires:       php-pcre
447
448 %description scm
449 This feature allows your software development teams to integrate your
450 Source Control Management system with your Issue Tracking System.
451
452 The integration is implemented in such a way that it will be forward
453 compatible with pretty much any SCM system, such as CVS.
454
455 For installation see
456 </eventum/help.php?topic=scm_integration_installation>.
457
458 %description scm -l pl
459 Ten pakiet pozwala zespo³om programistów na integracjê systemu
460 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
461 ¶ledzenia spraw.
462
463 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
464 prawie ka¿dym systemem SCM, jak np. CVS.
465
466 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
467 </eventum/help.php?topic=scm_integration_installation>.
468
469 %prep
470 %setup -q %{?_snap:-n %{name}-%{_snap}}
471 # undos the source
472 find . -type f -print0 | xargs -0 sed -i -e 's,\r$,,'
473
474 rm -f setup.conf.php # not to be installed by *.php glob
475 rm -rf misc/upgrade/*v1.[123]* # too old to support in PLD Linux
476 rm -f misc/upgrade/flush_compiled_templates.php
477 rm -rf misc/upgrade/*/upgrade_config.php # not needed in PLD Linux
478
479 # sample, not used in eventum
480 rm -f rpc/xmlrpc_client.php
481
482 # bug fixes.
483 %patch0 -p1
484 %patch1 -p1
485 %patch2 -p1
486 %patch3 -p1
487 %patch4 -p1
488 %patch5 -p1
489 %patch6 -p1
490 %patch7 -p1
491 %patch8 -p1
492 %patch9 -p1
493 %patch10 -p1
494 %{?with_order_patch:%patch11 -p1}
495 %patch12 -p1
496 %patch13 -p1
497 %patch14 -p1
498 %patch15 -p1
499 %patch16 -p1
500 %patch17 -p1
501 %patch18 -p1
502 #%patch19 -p1
503
504 # packaging
505 %patch100 -p1
506 %patch101 -p1
507 %patch102 -p1
508 %patch103 -p1
509 %patch104 -p1
510 %patch105 -p1
511 %patch106 -p1
512 %patch107 -p1
513
514 cat <<'EOF'> mysql-permissions.sql
515 # use this schema if you want to grant permissions manually instead of using setup
516 # this schema is extracted from setup/index.php.
517 GRANT SELECT, UPDATE, DELETE, INSERT, ALTER, DROP, CREATE, INDEX ON eventum.* TO 'eventum'@'localhost' IDENTIFIED BY 'password';
518 EOF
519
520 sed -e '1s,#!.*/bin/php -q,#!%{_bindir}/php,' misc/cli/eventum > %{name}-cli
521 sed -e '1i#!%{_bindir}/php' misc/scm/process_cvs_commits.php > %{name}-scm
522 sed -e '1i#!%{_bindir}/php' misc/irc/bot.php > %{name}-bot
523 mv misc/cli/eventumrc_example eventumrc
524 sed -i -e '1i#!%{_bindir}/php' misc/*.php
525 chmod +x misc/*.php
526 mv include/private_key.php private_key.php.in
527
528 # replace in remaining scripts config.inc.php to system one
529 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
530         s,include_once(".*config.inc.php"),include_once("%{_webappdir}/core.php"),
531 '
532
533 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
534         s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_webappdir}/private_key.php"),
535 '
536
537 # remove backups from patching as we use globs to package files to buildroot
538 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
539
540 %install
541 rm -rf $RPM_BUILD_ROOT
542 install -d \
543         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
544         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
545         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
546         $RPM_BUILD_ROOT/var/log/{archiv/,}%{name} \
547         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
548         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
549
550 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
551 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
552 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
553 cp -a templates $RPM_BUILD_ROOT%{_appdir}
554 cp -a include/{customer,custom_field,jpgraph,workflow} $RPM_BUILD_ROOT%{_appdir}/include
555 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
556 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
557 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
558
559 cp -a favicon.ico $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
560 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/setup/config.inc.php
561 install %{SOURCE13} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
562
563 # cli
564 install -d $RPM_BUILD_ROOT%{_appdir}/cli
565 cp -a misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
566 cp -a misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
567 install %{name}-cli $RPM_BUILD_ROOT%{_bindir}/%{name}
568 install %{name}-bot $RPM_BUILD_ROOT%{_sbindir}
569
570 # scm
571 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
572 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
573
574 # private key
575 cp -a private_key.php.in $RPM_BUILD_ROOT%{_webappdir}/private_key.php
576
577 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
578 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
579 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
580 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
581 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
582 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
583 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
584 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
585 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
586
587 sed -e '
588 s,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}}%{?_rc:-%{_rc}},
589 s,%%{PHP_PEAR_DIR}%%,%{php_pear_dir},
590 s,%%{APP_PATH}%%,%{_appdir},
591 s,%%{SMARTY_DIR}%%,%{_smartydir},
592 s,%%{SYSCONFDIR}%%,%{_webappdir},
593 ' %{SOURCE10} > $RPM_BUILD_ROOT%{_webappdir}/core.php
594
595 # config
596 > $RPM_BUILD_ROOT%{_webappdir}/setup.php
597 mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_webappdir}/config}.php
598
599 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
600 # These plugins are not in Smarty package (Smarty-2.6.2-3)
601 cp -a \
602         include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
603         include/Smarty/plugins/modifier.highlight_quoted.php \
604         $RPM_BUILD_ROOT%{_smartyplugindir}
605
606 # qmail router
607 %if %{with qmail}
608 d=$RPM_BUILD_ROOT/var/lib/%{name}
609 echo 'root' > $d/.qmail
610 echo 'root' > $d/.qmail-default
611 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
612 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
613 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
614 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
615 %endif
616 # postfix router
617 install %{SOURCE14} $RPM_BUILD_ROOT%{_libdir}/router-postfix
618
619 install -D %{SOURCE15} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
620
621 %clean
622 rm -rf $RPM_BUILD_ROOT
623
624 %pre
625 %addusertogroup http %{name}
626
627 %post
628 # check if the package is configured.
629 if grep -q 'header("Location: setup/")' %{_webappdir}/config.php; then
630 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
631 %banner %{name} -e <<EOF
632
633 You haven't yet configured Eventum!
634 Please open in browser <http://localhost/eventum/>
635 If you need access from elsewhere, you need to edit
636 %{_webappdir}/apache.conf and restart apache.
637
638 IMPORTANT: When You have configured Eventum, please uninstall the
639 setup package, so that %{name}-setup is able to secure your Eventum
640 installation.
641
642 EOF
643 #' vim syntax hack
644 else
645 %banner %{name} -e <<EOF
646
647 You haven't yet configured Eventum!
648
649 To setup eventum, please install %{name}-setup and open in browser
650 <http://localhost/eventum/>.
651 If you need access from elsewhere, you need to edit
652 %{_webappdir}/apache.conf and restart apache.
653
654 IMPORTANT: When You have configured Eventum, please uninstall the
655 setup package, so that %{name}-setup is able to secure your Eventum
656 installation.
657
658 EOF
659 #' vim syntax hack
660 fi
661
662 elif grep -q 'DEFAULTPRIVATEKEY' %{_webappdir}/private_key.php; then
663 %banner %{name} -e <<EOF
664
665 You have default private key installed!
666
667 Install %{name}-setup and open up http://yourserver/eventum/setup/
668 -- that will help you setup initial config.
669
670 when have configured Eventum, please uninstall the setup package,
671 so that %{name}-setup is able to secure your Eventum installation.
672
673 EOF
674         elif [ -d %{_appdir}/setup ]; then
675 %banner %{name} -e <<EOF
676
677 If you have have configured Eventum, please uninstall the setup package,
678 so that %{name}-setup is able to secure your Eventum installation.
679
680 EOF
681 fi
682
683 # nuke Smarty templates cache after upgrade
684 rm -f /var/cache/eventum/*.php
685
686 %preun
687 if [ "$1" = "0" ]; then
688         # nuke cache
689         rm -f /var/cache/eventum/*.php 2>/dev/null || :
690 fi
691
692 %pre base
693 %groupadd -P %{name}-base -g 146 %{name}
694 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
695
696 %postun base
697 if [ "$1" = "0" ]; then
698         %userremove %{name}
699         %groupremove %{name}
700 fi
701
702 %post router-qmail
703 CF=/etc/qmail/control/virtualdomains
704 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
705         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_webappdir}/config.php 2>/dev/null)
706         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
707         umask 022
708         echo "#${FQDN}:%{name}" >> $CF
709
710 %banner %{name}-qmail -e <<EOF
711
712 Added "#${FQDN}:%{name}" to $CF,
713 Please verify that it is correct and restart qmail:
714 # service qmail reload
715
716 Consult qmail-send(8) for more information on virtualdomains.
717
718 EOF
719 fi
720
721 %preun router-qmail
722 if [ "$1" = "0" ]; then
723         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
724 fi
725
726 %post setup
727 chmod 660 %{_webappdir}/{config,private_key}.php
728 chown root:eventum %{_webappdir}/{config,private_key}.php
729
730 %postun setup
731 if [ "$1" = "0" ]; then
732         chmod 640 %{_webappdir}/{config,private_key}.php
733         chown root:eventum %{_webappdir}/{config,private_key}.php
734 fi
735
736 %post irc
737 /sbin/chkconfig --add eventum-irc
738 %service eventum-irc restart "Eventum IRC Bot"
739
740 %preun irc
741 if [ "$1" = 0 ]; then
742         %service eventum-irc stop
743         /sbin/chkconfig --del eventum-irc
744 fi
745
746 %triggerin -- apache1
747 %webapp_register apache %{_webapp}
748
749 %triggerun -- apache1
750 %webapp_unregister apache %{_webapp}
751
752 %triggerin -- apache < 2.2.0, apache-base
753 %webapp_register httpd %{_webapp}
754
755 %triggerun -- apache < 2.2.0, apache-base
756 %webapp_unregister httpd %{_webapp}
757
758 # FIXME
759 # only one upgrade trigger is called if you're upgrading over two
760 # versions, say 1.5 to 1.5.3, only 1.5.3 trigger is called.
761 # use common trigger (the highest version and rpmvercmp from poldek?)
762 %triggerpostun -- eventum < 1.5.1-0.257
763 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5_to_v1.5.1 <<EOF
764 database_changes.php Perform database changes
765 EOF
766
767 %triggerpostun -- eventum < 1.5.2-0.289
768 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.1_to_v1.5.2 <<EOF
769 database_changes.php Perform database changes
770 set_priority_ranks.php Fix the ranking of priority values
771 EOF
772
773 %triggerpostun -- eventum < 1.5.3-0.291
774 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.2_to_v1.5.3 <<EOF
775 database_changes.php Perform database changes
776 EOF
777
778 %triggerpostun -- eventum < 1.5.4-1.12
779 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.3_to_v1.5.4 <<EOF
780 database_changes.php Perform database changes
781 EOF
782
783 %triggerpostun -- eventum < 1.6.0-RC2.6
784 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.5_to_v1.6.0 <<EOF
785 database_changes.php Perform database changes
786 upgrade_saved_searches.php Upgrade existing custom filters (saved searches)
787 EOF
788
789 %triggerpostun -- eventum < 1.6.1-0.2
790 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.0_to_v1.6.1 <<EOF
791 database_changes.php Perform database changes
792 EOF
793
794 %triggerpostun irc -- eventum-irc < 1.6.1-3.14
795 sed -i -e '
796 s,\$irc_host,$irc_server_hostname,
797 s,\$irc_port,$irc_server_port,
798 s,\$irc_nick,$nickname,
799 s,\$irc_realname,$realname,
800 s,\$irc_username,$username,
801 s,\$irc_password,$password,
802 ' /etc/eventum/irc.php
803
804 %triggerpostun -- eventum < 1.7.0-2.0.48
805 # migrate from apache-config macros
806 if [ -f /etc/%{name}/apache.conf.rpmsave ]; then
807         if [ -d /etc/apache/webapps.d ]; then
808                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
809                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
810         fi
811
812         if [ -d /etc/httpd/webapps.d ]; then
813                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
814                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
815         fi
816 fi
817
818 if [ -L /etc/apache/conf.d/99_%{_webapp}.conf ]; then
819         /usr/sbin/webapp register apache %{_webapp}
820         rm -f /etc/apache/conf.d/99_%{_webapp}.conf
821         %service -q apache reload
822 fi
823 if [ -L /etc/httpd/httpd.conf/99_%{_webapp}.conf ]; then
824         /usr/sbin/webapp register httpd %{_webapp}
825         rm -f /etc/httpd/httpd.conf/99_%{_webapp}.conf
826         %service -q httpd reload
827 fi
828
829 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.1_to_v1.7.0 <<EOF
830 database_changes.php Perform database changes
831 set_root_message_ids.php Set iss_root_message_id
832 EOF
833
834 # regular configs
835 for i in apache.conf config.php private_key.php setup.php; do
836         if [ -f /etc/eventum/$i.rpmsave ]; then
837                 mv -f %{_webappdir}/$i{,.rpmnew}
838                 mv -f /etc/eventum/$i.rpmsave %{_webappdir}/$i
839         fi
840 done
841
842 %triggerpostun cli -- %{name}-cli < 1.7.0-3.4
843 if [ -f %{_webappdir}/cli.php.rpmsave ]; then
844         mv -f %{_sysconfdir}/cli.php{,.rpmnew}
845         mv -f %{_webappdir}/cli.php.rpmsave %{_sysconfdir}/cli.php
846 fi
847
848 %triggerpostun irc -- %{name}-irc < 1.7.0-3.4
849 if [ -f %{_webappdir}/irc.php.rpmsave ]; then
850         mv -f %{_sysconfdir}/irc.php{,.rpmnew}
851         mv -f %{_webappdir}/irc.php.rpmsave %{_sysconfdir}/irc.php
852 fi
853
854 %files
855 %defattr(644,root,root,755)
856 %doc ChangeLog FAQ INSTALL README UPGRADE CONTRIB
857 %doc docs/* setup/schema.sql mysql-permissions.sql
858 %attr(751,root,root) %dir %{_webappdir}
859 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
860 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
861 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
862 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
863 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
864 %attr(640,root,eventum) %config %verify(not mtime) %{_webappdir}/core.php
865
866 %dir %attr(731,root,eventum) /var/log/%{name}
867 %attr(620,root,eventum) %ghost /var/log/%{name}/*
868 %dir %attr(750,root,root) /var/log/archiv/%{name}
869 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
870
871 %dir %{_appdir}/htdocs
872 %{_appdir}/htdocs/*.php
873 %{_appdir}/htdocs/*.ico
874 %{_appdir}/htdocs/css
875 %{_appdir}/htdocs/customer
876 %{_appdir}/htdocs/images
877 %{_appdir}/htdocs/js
878 %{_appdir}/htdocs/manage
879 %{_appdir}/htdocs/reports
880 %{_appdir}/htdocs/rpc
881 %{_appdir}/htdocs/misc
882 %{_appdir}/templates
883 %dir %{_appdir}/upgrade
884 %attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
885 %{_appdir}/upgrade/[!u]*
886 %{_smartyplugindir}
887
888 %dir %{_appdir}/include
889 %{_appdir}/include/customer
890 %{_appdir}/include/custom_field
891 %{_appdir}/include/jpgraph
892 %{_appdir}/include/workflow
893 %{_appdir}/include/class.[!m]*.php
894 %{_appdir}/include/class.mail.php
895 %{_appdir}/include/class.mail_queue.php
896 %{_appdir}/include/class.mime_helper.php
897 %{_appdir}/include/class.misc.php
898 %{_appdir}/include/db_access.php
899
900 %dir %attr(730,root,eventum) /var/run/%{name}
901 %dir %attr(730,root,eventum) /var/cache/%{name}
902
903 %files base
904 %defattr(644,root,root,755)
905 %attr(751,root,root) %dir %{_sysconfdir}
906 %dir %{_libdir}
907 %dir %{_appdir}
908 # qmail will ignore user, if it's home directory is not owned
909 %attr(750,eventum,eventum) %dir /var/lib/%{name}
910 # saved mail copies
911 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_emails
912 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_drafts
913 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_notes
914
915 %files setup
916 %defattr(644,root,root,755)
917 %{_appdir}/htdocs/setup
918
919 %files mail-queue
920 %defattr(644,root,root,755)
921 %attr(755,root,root) %{_appdir}/process_mail_queue.php
922 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
923
924 %files mail-download
925 %defattr(644,root,root,755)
926 %attr(755,root,root) %{_appdir}/download_emails.php
927 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
928
929 %files reminder
930 %defattr(644,root,root,755)
931 %attr(755,root,root) %{_appdir}/check_reminders.php
932 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
933
934 %files monitor
935 %defattr(644,root,root,755)
936 %{_appdir}/include/class.monitor.php
937 %attr(755,root,root) %{_appdir}/monitor.php
938 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
939
940 %files route-drafts
941 %defattr(644,root,root,755)
942 %attr(755,root,root) %{_appdir}/route_drafts.php
943
944 %files route-emails
945 %defattr(644,root,root,755)
946 %attr(755,root,root) %{_appdir}/route_emails.php
947
948 %files route-notes
949 %defattr(644,root,root,755)
950 %attr(755,root,root) %{_appdir}/route_notes.php
951
952 %if %{with qmail}
953 %files router-qmail
954 %defattr(644,root,root,755)
955 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
956 %attr(755,root,root) %{_libdir}/router-qmail
957 %endif
958
959 %files router-postfix
960 %defattr(644,root,root,755)
961 %attr(755,root,root) %{_libdir}/router-postfix
962
963 %files irc
964 %defattr(644,root,root,755)
965 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
966 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
967 %attr(755,root,root) %{_sbindir}/%{name}-bot
968 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
969
970 %files cli
971 %defattr(644,root,root,755)
972 %doc eventumrc
973 %attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
974 %attr(755,root,root) %{_bindir}/%{name}
975 %{_appdir}/cli
976
977 %files scm
978 %defattr(644,root,root,755)
979 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
980 %attr(755,root,root) %{_libdir}/scm
This page took 0.17037 seconds and 3 git commands to generate.