]> git.pld-linux.org Git - packages/epiphany.git/blob - epiphany.spec
- merged update to 2.14.1.1 and deps update from AC-branch
[packages/epiphany.git] / epiphany.spec
1 #
2 # Conditinal build:
3 %bcond_without  mozilla_firefox # build with mozilla instead of mozilla-firefox
4 #
5 %define         basever 2.14
6 Summary:        Epiphany - gecko-based GNOME web browser
7 Summary(es):    Epiphany - navigador Web de GNOME basado en gecko
8 Summary(pl):    Epiphany - przegl±darka WWW dla GNOME
9 Name:           epiphany
10 Version:        2.14.1.1
11 Release:        1
12 License:        GPL v2
13 Group:          X11/Applications/Networking
14 Source0:        http://ftp.gnome.org/pub/gnome/sources/epiphany/%{basever}/%{name}-%{version}.tar.bz2
15 # Source0-md5:  f5770a6a934997382b91349bdc40af04
16 Patch0:         %{name}-first-tab.patch
17 Patch1:         %{name}-desktop.patch
18 Patch2:         %{name}-mozilla_includes.patch
19 Patch3:         %{name}-pld-homepage.patch
20 Patch4:         %{name}-configure.patch
21 URL:            http://www.gnome.org/projects/epiphany/
22 BuildRequires:  GConf2-devel >= 2.14.0
23 BuildRequires:  ORBit2-devel >= 1:2.14.0
24 BuildRequires:  autoconf >= 2.59
25 BuildRequires:  automake >= 1.8
26 BuildRequires:  dbus-glib-devel >= 0.60
27 BuildRequires:  gnome-common >= 2.8.0
28 BuildRequires:  gnome-desktop-devel >= 2.14.0
29 BuildRequires:  gnome-doc-utils >= 0.3.2-1
30 BuildRequires:  gnome-vfs2-devel >= 2.14.0
31 BuildRequires:  gtk+2-devel >= 2:2.8.3
32 BuildRequires:  gtk-doc >= 1.3
33 BuildRequires:  intltool >= 0.33
34 BuildRequires:  iso-codes >= 0.35
35 BuildRequires:  libglade2-devel >= 1:2.5.1
36 BuildRequires:  libgnomeprintui-devel >= 2.12.0
37 BuildRequires:  libgnomeui-devel >= 2.14.0
38 BuildRequires:  startup-notification-devel >= 0.5
39 BuildRequires:  libtool
40 BuildRequires:  libxslt-devel >= 1.1.15
41 %if %{with mozilla_firefox}
42 BuildRequires:  mozilla-firefox-devel >= 1.0.5
43 %else
44 BuildRequires:  mozilla-devel >= 5:1.7.9
45 %endif
46 BuildRequires:  pkgconfig
47 BuildRequires:  python-gnome-devel >= 2.6.0
48 BuildRequires:  python-pygtk-devel >= 2.6.0
49 BuildRequires:  rpmbuild(macros) >= 1.197
50 BuildRequires:  scrollkeeper
51 Requires(post,preun):   GConf2
52 Requires(post,postun):  desktop-file-utils
53 Requires(post,postun):  scrollkeeper
54 Requires:       dbus >= 0.60
55 Requires:       gnome-icon-theme >= 2.14.0
56 Requires:       gtk+2 >= 2:2.8.3
57 Requires:       libgnomeui >= 2.14.0
58 %if %{with mozilla_firefox}
59 %requires_eq    mozilla-firefox
60 %else
61 Requires:       mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
62 %endif
63 Obsoletes:      python-epiphany
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 # can be provided by mozilla or mozilla-embedded
67 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
68
69 %description
70 GNOME browser based on Gecko (Mozilla rendering engine).
71
72 %description -l es
73 Navigador Web de GNOME basado en Gecko (el engine plasmante de Mozilla).
74
75 %description -l pl
76 Epiphany jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
77 interpretacji stron Mozilli).
78
79 %package devel
80 Summary:        Epiphany header files
81 Summary(es):    Ficheros de cabecera de Epiphany
82 Summary(pl):    Pliki nag³ówkowe Epiphany
83 Group:          X11/Applications/Networking
84 # doesn't require base
85 Requires:       gtk+2-devel >= 2:2.8.3
86 Requires:       libxslt-devel >= 1.1.15
87
88 %description devel
89 Epiphany header files for plugin development.
90
91 %description devel -l es
92 Ficheros de cabecera de Epiphany para desarrollar plug-ins.
93
94 %description devel -l pl
95 Pliki nag³ówkowe Epiphany do tworzenia wtyczek.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100 %patch1 -p1
101 %patch2 -p1
102 %patch3 -p1
103 %patch4 -p1
104
105 %build
106 gnome-doc-prepare --copy --force
107 %{__gnome_doc_common}
108 %{__glib_gettextize}
109 %{__intltoolize}
110 %{__libtoolize}
111 %{__aclocal} -I m4
112 %{__autoheader}
113 %{__automake}
114 %{__autoconf}
115
116 %configure \
117         --disable-schemas-install \
118         --enable-dbus \
119         --enable-gtk-doc \
120         --enable-python \
121         --with-html-dir=%{_gtkdocdir}
122 # CFLAGS is a hack for gcc 3.3
123 %{__make} \
124         CFLAGS="%{rpmcflags} -fno-strict-aliasing"
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/%{basever}/extensions
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT \
132         HTML_DIR=%{_gtkdocdir}
133
134 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
135 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/%{basever}/plugins/*.la
136
137 # epiphany-2.0.mo, but gnome/help/epiphany
138 %find_lang %{name}-2.0 --with-gnome --all-name
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post
144 %gconf_schema_install epiphany-fonts.schemas
145 %gconf_schema_install epiphany-lockdown.schemas
146 %gconf_schema_install epiphany-pango.schemas
147 %gconf_schema_install epiphany.schemas
148 %scrollkeeper_update_post
149 %update_desktop_database_post
150
151 %preun
152 %gconf_schema_uninstall epiphany-fonts.schemas
153 %gconf_schema_uninstall epiphany-lockdown.schemas
154 %gconf_schema_uninstall epiphany-pango.schemas
155 %gconf_schema_uninstall epiphany.schemas
156
157 %postun
158 %scrollkeeper_update_postun
159 %update_desktop_database_postun
160
161 %files -f %{name}-2.0.lang
162 %defattr(644,root,root,755)
163 %doc AUTHORS ChangeLog NEWS README
164 %attr(755,root,root) %{_bindir}/*
165 %{_datadir}/dbus-1/services/*.service
166 %{_datadir}/%{name}
167 %{_desktopdir}/*
168 %{_pixmapsdir}/*
169 %{_sysconfdir}/gconf/schemas/epiphany-fonts.schemas
170 %{_sysconfdir}/gconf/schemas/epiphany-lockdown.schemas
171 %{_sysconfdir}/gconf/schemas/epiphany-pango.schemas
172 %{_sysconfdir}/gconf/schemas/epiphany.schemas
173 %{_omf_dest_dir}/*
174 %dir %{_libdir}/%{name}
175 %dir %{_libdir}/%{name}/%{basever}
176 %dir %{_libdir}/%{name}/%{basever}/extensions
177 %dir %{_libdir}/%{name}/%{basever}/plugins
178 %attr(755,root,root) %{_libdir}/epiphany/%{basever}/plugins/*.so*
179 %{_mandir}/man1/*
180
181 %files devel
182 %defattr(644,root,root,755)
183 %{_aclocaldir}/*
184 %{_includedir}/epiphany
185 %{_pkgconfigdir}/*.pc
186 %{_datadir}/pygtk/*/defs/epiphany.defs
187 %{_gtkdocdir}/*
This page took 0.060638 seconds and 4 git commands to generate.