]> git.pld-linux.org Git - packages/epiphany.git/blob - epiphany.spec
- require new gnome-common instead of ac-patch
[packages/epiphany.git] / epiphany.spec
1
2 %define         minmozver       1.4
3
4 Summary:        Epiphany - gecko-based GNOME web browser
5 Summary(pl):    Epiphany - przegl±darka WWW dla GNOME
6 Name:           epiphany
7 Version:        0.8.0
8 Release:        1
9 License:        GPL
10 Group:          X11/Applications/Networking
11 Source0:        http://ftp.gnome.org/pub/gnome/sources/%{name}/0.8/%{name}-%{version}.tar.bz2
12 # Source0-md5:  b75c4d7eae8c08eb7d817138e5867b73
13 Patch0:         %{name}-MOZILLA_FIVE_HOME.patch
14 URL:            http://epiphany.mozdev.org/
15 BuildRequires:  GConf2-devel
16 BuildRequires:  ORBit2-devel >= 2.7.3
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  libbonobo-devel >= 2.3.5
20 BuildRequires:  gnome-common >= 2.3.0
21 BuildRequires:  gnome-vfs2-devel
22 BuildRequires:  gtk+2-devel >= 2.0.6
23 BuildRequires:  intltool
24 BuildRequires:  libglade2-devel
25 BuildRequires:  libgnomeui-devel
26 BuildRequires:  libxml2-devel
27 BuildRequires:  mozilla-embedded-devel >= %{minmozver}
28 BuildRequires:  nautilus-devel >= 2.0.0
29 BuildRequires:  scrollkeeper
30 BuildRequires:  rpm-build >= 4.1-10
31 Requires(post): GConf2
32 Requires(post): scrollkeeper
33 Requires:       mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 # can be provided by mozilla or mozilla-embedded
37 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
38
39 %description
40 Gnome browser based on Gecko (Mozilla rendering engine).
41
42 %description -l pl
43 Epiphany jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
44 interpretacji stron Mozilli).
45
46 %package devel
47 Summary:        Epiphany header files
48 Summary(pl):    Pliki nag³ówkowe Epiphany
49 Group:          X11/Applications/Networking
50 Requires:       %{name} = %{version}
51
52 %description devel
53 Epiphany header files for plugin development.
54
55 %description devel -l pl
56 Pliki nag³ówkowe Epiphany do tworzenia wtyczek.
57
58
59 %prep
60 %setup -q
61 %patch0 -p1
62
63 %build
64 rm -f acconfig.h
65 glib-gettextize --copy --force
66 intltoolize --copy --force
67 %{__libtoolize}
68 %{__aclocal} -I %{_aclocaldir}/gnome2-macros
69 %{__autoheader}
70 %{__automake}
71 %{__autoconf}
72
73 # rebuild for new ORBit2
74 cd idl
75 orbit-idl-2 -I/usr/share/idl -I/usr/share/idl/bonobo-2.0 \
76         -I/usr/share/idl/bonobo-activation-2.0 EphyAutomation.idl
77 mv -f *.h *.c ../src
78 cd ..
79
80 %configure \
81         --disable-schemas-install \
82         --enable-nautilus-view=yes \
83         --with-mozilla-snapshot=1.4
84
85 # CFLAGS is a hack for gcc 3.3
86 %{__make} CFLAGS="%{rpmcflags} -fno-strict-aliasing"
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 # epiphany-2.0.mo, but gnome/help/epiphany
95 %find_lang %{name}-2.0 --with-gnome --all-name
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post
101 %gconf_schema_install
102 /usr/bin/scrollkeeper-update
103
104 %files -f %{name}-2.0.lang
105 %defattr(644,root,root,755)
106 %doc AUTHORS ChangeLog NEWS README
107 %attr(755,root,root) %{_bindir}/*
108 %{_libdir}/bonobo/servers/*
109 %{_datadir}/%{name}
110 %{_desktopdir}/*
111 %{_datadir}/application-registry/*
112 %{_pixmapsdir}/*
113 %{_sysconfdir}/gconf/schemas/*
114 %{_omf_dest_dir}/*
115
116 %files devel
117 %defattr(644,root,root,755)
118 %{_includedir}/epiphany-1.0
This page took 0.080132 seconds and 4 git commands to generate.