]> git.pld-linux.org Git - packages/epiphany.git/blob - epiphany.spec
- fix build with xulrunner 1.9
[packages/epiphany.git] / epiphany.spec
1 #
2 #Conditional build:
3 %bcond_with     webkit          # Build with experimental webkit suppor instead of xulrunner
4 #
5 %define         basever         2.22
6 Summary:        Epiphany - gecko-based GNOME web browser
7 Summary(es.UTF-8):      Epiphany - navigador Web de GNOME basado en gecko
8 Summary(pl.UTF-8):      Epiphany - przeglądarka WWW dla GNOME
9 Name:           epiphany
10 Version:        2.22.2
11 Release:        1
12 License:        GPL v2
13 Group:          X11/Applications/Networking
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/epiphany/2.22/%{name}-%{version}.tar.bz2
15 # Source0-md5:  f90dc0a01dae58dfa393b17bce717d3c
16 Patch0:         %{name}-pld-homepage.patch
17 Patch1:         %{name}-configure.patch
18 Patch2:         %{name}-ti-agent.patch
19 Patch3:         %{name}-agent.patch
20 Patch4:         %{name}-lt.patch
21 URL:            http://www.gnome.org/projects/epiphany/
22 BuildRequires:  GConf2-devel >= 2.20.0
23 BuildRequires:  NetworkManager-devel
24 BuildRequires:  ORBit2-devel >= 1:2.14.9
25 BuildRequires:  autoconf >= 2.59
26 BuildRequires:  automake >= 1:1.9
27 BuildRequires:  dbus-glib-devel >= 0.73
28 BuildRequires:  enchant-devel >= 1.0
29 BuildRequires:  gnome-common >= 2.20.0
30 BuildRequires:  gnome-desktop-devel >= 2.20.0
31 BuildRequires:  gnome-doc-utils >= 0.12.0
32 BuildRequires:  gnome-vfs2-devel >= 2.22.0
33 BuildRequires:  gtk+2-devel >= 2:2.12.0
34 BuildRequires:  gtk-doc >= 1.8
35 %if %{with webkit}
36 BuildRequires:  gtk-webkit-devel
37 BuildRequires:  libssh2-devel
38 %endif
39 BuildRequires:  intltool >= 0.36.2
40 BuildRequires:  iso-codes >= 0.53
41 BuildRequires:  libglade2-devel >= 1:2.6.2
42 BuildRequires:  libgnomeprintui-devel >= 2.18.0
43 BuildRequires:  libgnomeui-devel >= 2.22.0
44 BuildRequires:  libtool
45 BuildRequires:  libxml2-devel >= 1:2.6.28
46 BuildRequires:  libxslt-devel >= 1.1.20
47 BuildRequires:  pkgconfig
48 BuildRequires:  python-gnome-devel >= 2.20.0
49 BuildRequires:  python-pygtk-devel >= 2:2.12.0
50 BuildRequires:  rpm >= 4.4.9-56
51 BuildRequires:  rpmbuild(find_lang) >= 1.23
52 BuildRequires:  rpmbuild(macros) >= 1.311
53 BuildRequires:  scrollkeeper
54 BuildRequires:  startup-notification-devel >= 0.8
55 %if %{without webkit}
56 BuildRequires:  xulrunner
57 BuildRequires:  xulrunner-devel >= 1.8.1.6-1.20070731.2
58 %endif
59 Requires(post,postun):  desktop-file-utils
60 Requires(post,postun):  gtk+2
61 Requires(post,postun):  hicolor-icon-theme
62 Requires(post,postun):  scrollkeeper
63 Requires(post,preun):   GConf2
64 Requires:       dbus >= 1.0.2
65 Requires:       gnome-icon-theme >= 2.22.0
66 Requires:       libgnomeui >= 2.22.0
67 %if %{without webkit}
68 %requires_eq    xulrunner
69 %endif
70 Obsoletes:      python-epiphany
71 # sr@Latn vs. sr@latin
72 Conflicts:      glibc-misc < 6:2.7
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %if %{without webkit}
76 # can be provided by mozilla or mozilla-embedded
77 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
78 # we have strict deps for it
79 %define         _noautoreq      libxpcom.so
80 %endif
81
82 %description
83 GNOME browser based on Gecko (Mozilla rendering engine).
84
85 %description -l es.UTF-8
86 Navigador Web de GNOME basado en Gecko (el engine plasmante de
87 Mozilla).
88
89 %description -l pl.UTF-8
90 Epiphany jest przeglądarką WWW bazującą na Gecko (mechanizmie
91 interpretacji stron Mozilli).
92
93 %package devel
94 Summary:        Epiphany header files
95 Summary(es.UTF-8):      Ficheros de cabecera de Epiphany
96 Summary(pl.UTF-8):      Pliki nagłówkowe Epiphany
97 Group:          X11/Applications/Networking
98 # doesn't require base
99 Requires:       gtk+2-devel >= 2:2.12.0
100 Requires:       libxslt-devel >= 1.1.20
101
102 %description devel
103 Epiphany header files for plugin development.
104
105 %description devel -l es.UTF-8
106 Ficheros de cabecera de Epiphany para desarrollar plug-ins.
107
108 %description devel -l pl.UTF-8
109 Pliki nagłówkowe Epiphany do tworzenia wtyczek.
110
111 %package apidocs
112 Summary:        Epiphany API documentation
113 Summary(pl.UTF-8):      Dokumentacja API Epiphany
114 Group:          Documentation
115 Requires:       gtk-doc-common
116
117 %description apidocs
118 Epiphany API documentation.
119
120 %description apidocs -l pl.UTF-8
121 Dokumentacja API Epiphany.
122
123 %prep
124 %setup -q
125 %patch0 -p1
126 %patch1 -p1
127 %if "%{pld_release}" == "ti"
128 %patch2 -p1
129 %else
130 %patch3 -p1
131 %endif
132 %patch4 -p1
133
134 sed -i -e 's#sr@Latn#sr@latin#' po/LINGUAS
135 mv po/sr@{Latn,latin}.po
136
137 %build
138 %{__gnome_doc_prepare}
139 %{__gnome_doc_common}
140 %{__glib_gettextize}
141 %{__intltoolize}
142 %{__libtoolize}
143 %{__aclocal} -I m4
144 %{__autoheader}
145 %{__automake}
146 %{__autoconf}
147 %configure \
148         --disable-schemas-install \
149         --enable-dbus \
150         %{?!with_webkit:--enable-gtk-doc} \
151         --enable-network-manager \
152         --enable-python\
153         --enable-spell-checker \
154         %{?with_webkit:--with-engine=webkit} \
155         --with-html-dir=%{_gtkdocdir}
156 %{__make}
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/%{basever}/extensions
161
162 %{__make} install \
163         DESTDIR=$RPM_BUILD_ROOT \
164         HTML_DIR=%{_gtkdocdir}
165
166 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/%{basever}/plugins/*.la
167 rm -rf $RPM_BUILD_ROOT%{_iconsdir}/LowContrastLargePrint
168
169 %find_lang %{name} --with-gnome --with-omf
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %post
175 %gconf_schema_install epiphany-fonts.schemas
176 %gconf_schema_install epiphany-lockdown.schemas
177 %gconf_schema_install epiphany-pango.schemas
178 %gconf_schema_install epiphany.schemas
179 %scrollkeeper_update_post
180 %update_desktop_database_post
181 %update_icon_cache hicolor
182
183 %preun
184 %gconf_schema_uninstall epiphany-fonts.schemas
185 %gconf_schema_uninstall epiphany-lockdown.schemas
186 %gconf_schema_uninstall epiphany-pango.schemas
187 %gconf_schema_uninstall epiphany.schemas
188
189 %postun
190 %scrollkeeper_update_postun
191 %update_desktop_database_postun
192 %update_icon_cache hicolor
193
194 %files -f %{name}.lang
195 %defattr(644,root,root,755)
196 %doc AUTHORS ChangeLog NEWS README
197 %attr(755,root,root) %{_bindir}/*
198 %{_datadir}/dbus-1/services/*.service
199 %{_datadir}/%{name}
200 %{_desktopdir}/*.desktop
201 %{_iconsdir}/*/*/apps/*.*
202 %{_sysconfdir}/gconf/schemas/epiphany-fonts.schemas
203 %{_sysconfdir}/gconf/schemas/epiphany-lockdown.schemas
204 %{_sysconfdir}/gconf/schemas/epiphany-pango.schemas
205 %{_sysconfdir}/gconf/schemas/epiphany.schemas
206 %dir %{_libdir}/%{name}
207 %dir %{_libdir}/%{name}/%{basever}
208 %dir %{_libdir}/%{name}/%{basever}/extensions
209 %if %{without webkit}
210 %dir %{_libdir}/%{name}/%{basever}/plugins
211 %attr(755,root,root) %{_libdir}/epiphany/%{basever}/plugins/*.so*
212 %endif
213 %{_mandir}/man1/*
214
215 %files devel
216 %defattr(644,root,root,755)
217 %{_aclocaldir}/*
218 %{_includedir}/epiphany
219 %{_pkgconfigdir}/*.pc
220 %{_datadir}/pygtk/*/defs/epiphany.defs
221
222 %files apidocs
223 %defattr(644,root,root,755)
224 %{_gtkdocdir}/*
This page took 0.058506 seconds and 3 git commands to generate.