]> git.pld-linux.org Git - packages/emotion.git/blob - emotion.spec
- typos
[packages/emotion.git] / emotion.spec
1 #
2 # Conditional build:
3 %bcond_without  gstreamer       # don't build gstreamer decoder
4 %bcond_without  xine            # don't build xine decoder
5 %bcond_without  static_libs     # don't build static library
6 #
7 %if %{without gstreamer} && %{without xine}
8 error at last one backend must be enabled
9 %endif
10 #
11 Summary:        Enlightenment Fundation Libraries - Emotion
12 Summary(pl):    Podstawowe biblioteki Enlightenmenta - Emotion
13 Name:           emotion
14 Version:        0.0.1.004
15 %define _snap   20060307
16 Release:        2.%{_snap}.1
17 License:        BSD
18 Group:          X11/Libraries
19 #Source0:       http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
20 Source0:        http://sparky.homelinux.org/snaps/enli/e17/libs/%{name}-%{_snap}.tar.bz2
21 # Source0-md5:  fbc1342f7cc39575a117a76a87297b1d
22 URL:            http://enlightenment.org/Libraries/Emotion/
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  edje
26 BuildRequires:  edje-devel
27 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-base-devel >= 0.10}
28 BuildRequires:  libtool
29 BuildRequires:  pkgconfig
30 %{?with_xine:BuildRequires:     xine-lib-devel >= 2:1.1.1}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Emotion is a Media Library.
35
36 %description -l pl
37 Emotion to biblioteka multimedialna.
38
39 %package devel
40 Summary:        Emotion header files
41 Summary(pl):    Pliki nag³ówkowe Emotion
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44
45 %description devel
46 Header files for Emotion.
47
48 %description devel -l pl
49 Pliki nag³ówkowe Emotion.
50
51 %package static
52 Summary:        Static Emotion library
53 Summary(pl):    Statyczna biblioteka Emotion
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Static Emotion library.
59
60 %description static -l pl
61 Statyczna biblioteka Emotion.
62
63 %package decoder-gstreamer
64 Summary:        Emotion decoder using gstreamer
65 Summary(pl):    Dekoder Emotion u¿ywaj±cy gstreamera
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68
69 %description decoder-gstreamer
70 Emotion decoder using gstreamer.
71
72 %description decoder-gstreamer -l pl
73 Dekoder Emotion u¿ywaj±cy gstreamera.
74
75 %package decoder-xine
76 Summary:        Emotion decoder using xine
77 Summary(pl):    Dekoder Emotion u¿ywaj±cy xine
78 Group:          Development/Libraries
79 Requires:       %{name} = %{version}-%{release}
80
81 %description decoder-xine
82 Emotion decoder using xine.
83
84 %description decoder-xine -l pl
85 Dekoder Emotion u¿ywaj±cy xine.
86
87 %prep
88 %setup -q -n %{name}
89
90 %build
91 %{__libtoolize}
92 %{__aclocal} -I m4
93 %{__autoconf}
94 %{__autoheader}
95 %{__automake}
96 %configure \
97         %{!?with_static_libs:--disable-static} \
98         %{?without_gstreamer:--disable-gstreamer} \
99         %{?without_xine:--disable-xine}
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   -p /sbin/ldconfig
112 %postun -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %doc AUTHORS COPYING COPYING-PLAIN README TODO
117 %attr(755,root,root) %{_bindir}/emotion_*
118 %attr(755,root,root) %{_libdir}/libemotion.so.*.*.*
119 %dir %{_libdir}/%{name}
120 %{_datadir}/%{name}
121
122 %if %{with gstreamer}
123 %files decoder-gstreamer
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/%{name}/emotion_decoder_gstreamer.so
126 %endif
127
128 %if %{with xine}
129 %files decoder-xine
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_libdir}/%{name}/emotion_decoder_xine.so
132 %endif
133
134 %files devel
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_bindir}/emotion-config
137 %attr(755,root,root) %{_libdir}/libemotion.so
138 %{_libdir}/libemotion.la
139 %{_libdir}/%{name}/emotion_decoder_gstreamer.la
140 #%{_libdir}/%{name}/emotion_decoder_xine.la
141 %{_includedir}/Emotion*
142 %{_pkgconfigdir}/emotion.pc
143
144 %if %{with static_libs}
145 %files static
146 %defattr(644,root,root,755)
147 %{_libdir}/libemotion.a
148 %endif
This page took 0.084901 seconds and 4 git commands to generate.