]> git.pld-linux.org Git - packages/emotion.git/blob - emotion.spec
- rel .2
[packages/emotion.git] / emotion.spec
1 #
2 # Conditional build:
3 %bcond_without  gstreamer       # don't build gstreamer decoder
4 %bcond_without  xine            # don't build xine decoder
5 %bcond_without  static_libs     # don't build static library
6 #
7 %if !%{with gstreamer} && !%{with xine}
8 error at last one backend must be enabled
9 %endif
10 #
11 Summary:        Enlightenment Fundation Libraries - Emotion
12 Summary(pl):    Podstawowe biblioteki Enlightenmenta - Emotion
13 Name:           emotion
14 Version:        0.0.1.004
15 %define _snap   20060625
16 Release:        2.%{_snap}.2
17 License:        BSD
18 Group:          X11/Libraries
19 #Source0:       http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
20 Source0:        http://sparky.homelinux.org/snaps/enli/e17/libs/%{name}-%{_snap}.tar.bz2
21 # Source0-md5:  aa4f66fba709b4b08c2ed49eda196657
22 URL:            http://enlightenment.org/Libraries/Emotion/
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  edje
26 BuildRequires:  edje-devel
27 %if %{with gstreamer}
28 BuildRequires:  gstreamer-cdio
29 BuildRequires:  gstreamer-devel >= 0.10.2
30 BuildRequires:  gstreamer-ffmpeg
31 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.1
32 %endif
33 BuildRequires:  libtool
34 BuildRequires:  pkgconfig
35 %{?with_xine:BuildRequires:     xine-lib-devel >= 2:1.1.1}
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Emotion is a Media Library.
40
41 %description -l pl
42 Emotion to biblioteka multimedialna.
43
44 %package devel
45 Summary:        Emotion header files
46 Summary(pl):    Pliki nag³ówkowe Emotion
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49
50 %description devel
51 Header files for Emotion.
52
53 %description devel -l pl
54 Pliki nag³ówkowe Emotion.
55
56 %package static
57 Summary:        Static Emotion library
58 Summary(pl):    Statyczna biblioteka Emotion
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static Emotion library.
64
65 %description static -l pl
66 Statyczna biblioteka Emotion.
67
68 %package decoder-gstreamer
69 Summary:        Emotion decoder using gstreamer
70 Summary(pl):    Dekoder Emotion u¿ywaj±cy gstreamera
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73
74 %description decoder-gstreamer
75 Emotion decoder using gstreamer.
76
77 %description decoder-gstreamer -l pl
78 Dekoder Emotion u¿ywaj±cy gstreamera.
79
80 %package decoder-xine
81 Summary:        Emotion decoder using xine
82 Summary(pl):    Dekoder Emotion u¿ywaj±cy xine
83 Group:          Development/Libraries
84 Requires:       %{name} = %{version}-%{release}
85
86 %description decoder-xine
87 Emotion decoder using xine.
88
89 %description decoder-xine -l pl
90 Dekoder Emotion u¿ywaj±cy xine.
91
92 %prep
93 %setup -q -n %{name}
94
95 %build
96 %{__libtoolize}
97 %{__aclocal} -I m4
98 %{__autoconf}
99 %{__autoheader}
100 %{__automake}
101 %configure \
102         %{!?with_static_libs:--disable-static} \
103         %{!?with_gstreamer:--disable-gstreamer} \
104         %{!?with_xine:--disable-xine}
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post   -p /sbin/ldconfig
117 %postun -p /sbin/ldconfig
118
119 %files
120 %defattr(644,root,root,755)
121 %doc AUTHORS COPYING COPYING-PLAIN README TODO
122 %attr(755,root,root) %{_bindir}/emotion_*
123 %attr(755,root,root) %{_libdir}/libemotion.so.*.*.*
124 %dir %{_libdir}/%{name}
125 %{_datadir}/%{name}
126
127 %if %{with gstreamer}
128 %files decoder-gstreamer
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_libdir}/%{name}/emotion_decoder_gstreamer.so
131 %endif
132
133 %if %{with xine}
134 %files decoder-xine
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_libdir}/%{name}/emotion_decoder_xine.so
137 %endif
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_bindir}/emotion-config
142 %attr(755,root,root) %{_libdir}/libemotion.so
143 %{_libdir}/libemotion.la
144 %{_libdir}/%{name}/emotion_decoder_gstreamer.la
145 #%{_libdir}/%{name}/emotion_decoder_xine.la
146 %{_includedir}/Emotion*
147 %{_pkgconfigdir}/emotion.pc
148
149 %if %{with static_libs}
150 %files static
151 %defattr(644,root,root,755)
152 %{_libdir}/libemotion.a
153 %endif
This page took 0.061367 seconds and 4 git commands to generate.