]> git.pld-linux.org Git - packages/elfutils.git/blob - elfutils.spec
- PLDized
[packages/elfutils.git] / elfutils.spec
1 Summary:        A collection of utilities and DSOs to handle compiled objects.
2 Name:           elfutils
3 Version:        0.76
4 Release:        4
5 License:        GPL
6 Group:          Development/Tools
7 #URL: file://home/devel/drepper
8 Source0:        %{name}-%{version}.tar.gz
9 Requires:       elfutils-libelf = %{version}-%{release}
10 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11 BuildRequires:  gcc >= 3.2
12 BuildRequires:  sharutils
13
14 %define _programprefix eu-
15
16 %description
17 Elfutils is a collection of utilities, including ld (a linker), nm
18 (for listing symbols from object files), size (for listing the section
19 sizes of an object or archive file), strip (for discarding symbols),
20 readline (the see the raw ELF file structures), and elflint (to check
21 for well-formed ELF files). Also included are numerous helper
22 libraries which implement DWARF, ELF, and machine-specific ELF
23 handling.
24
25 %package devel
26 Summary:        Development libraries to handle compiled objects.
27 Group:          Development/Tools
28 Obsoletes:      libelf-devel
29 Requires:       elfutils = %{version}-%{release}
30
31 %description devel
32 The elfutils-devel package contains the libraries to create
33 applications for handling compiled objects. libelf allows you to
34 access the internals of the ELF object file format, so you can see the
35 different sections of an ELF file. libebl provides some higher-level
36 ELF access functionality. libdwarf provides access to the DWARF
37 debugging information. libasm provides a programmable assembler
38 interface.
39
40 %package libelf
41 Summary:        Library to read and write ELF files.
42 Group:          Development/Tools
43 Obsoletes:      libelf
44
45 %description libelf
46 The elfutils-libelf package provides a DSO which allows reading and
47 writing ELF files on a high level. Third party programs depend on this
48 package to read internals of ELF files. The programs of the elfutils
49 package use it also to generate new ELF files.
50
51 %prep
52 %setup -q
53
54 %build
55 %{__aclocal}
56 %{__autoheader}
57 %{__automake}
58 %{__autoconf}
59 %configure \
60    --program-prefix=%{_programprefix} \
61    --enable-shared
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d ${RPM_BUILD_ROOT}%{_prefix}
66
67 #make check
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
72 chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
73
74
75 # XXX Nuke unpackaged files
76 { cd ${RPM_BUILD_ROOT}
77   rm -f .%{_bindir}/eu-ld
78   rm -f .%{_includedir}/elfutils/libasm.h
79   rm -f .%{_includedir}/elfutils/libdw.h
80   rm -f .%{_includedir}/elfutils/libdwarf.h
81   rm -f .%{_libdir}/libasm-%{version}.so
82   rm -f .%{_libdir}/libasm.a
83   rm -f .%{_libdir}/libdw-%{version}.so
84   rm -f .%{_libdir}/libdw.a
85   rm -f .%{_libdir}/libdwarf.a
86 }
87
88 #%%check
89 #make check
90
91 %clean
92 rm -rf ${RPM_BUILD_ROOT}
93
94 %post -p /sbin/ldconfig
95
96 %postun -p /sbin/ldconfig
97
98 %post libelf -p /sbin/ldconfig
99
100 %postun libelf -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %doc README TODO libdwarf/AVAILABLE
105 %attr(755,root,root) %{_bindir}/eu-elflint
106 #%{_bindir}/eu-ld
107 %attr(755,root,root) %{_bindir}/eu-nm
108 %attr(755,root,root) %{_bindir}/eu-readelf
109 %attr(755,root,root) %{_bindir}/eu-size
110 %attr(755,root,root) %{_bindir}/eu-strip
111 #%{_libdir}/libasm-%{version}.so
112 %{_libdir}/libebl-%{version}.so
113 #%{_libdir}/libdw-%{version}.so
114 %{_libdir}/libdwarf-%{version}.so
115 #%{_libdir}/libasm*.so.*
116 %{_libdir}/libebl*.so.*
117 #%{_libdir}/libdw*.so.*
118 %{_libdir}/libdwarf*.so.*
119 %dir %{_libdir}/elfutils
120 %{_libdir}/elfutils/lib*.so
121
122 %files devel
123 %defattr(644,root,root,755)
124 %{_includedir}/dwarf.h
125 %{_includedir}/libelf.h
126 %{_includedir}/gelf.h
127 %{_includedir}/nlist.h
128 %dir %{_includedir}/elfutils
129 %{_includedir}/elfutils/elf-knowledge.h
130 %{_includedir}/elfutils/libebl.h
131 #%{_libdir}/libasm.a
132 %{_libdir}/libebl.a
133 %{_libdir}/libelf.a
134 #%{_libdir}/libdw.a
135 #%{_libdir}/libasm.so
136 %{_libdir}/libebl.so
137 %{_libdir}/libelf.so
138 #%{_libdir}/libdw.so
139 #%{_libdir}/libdwarf.so
140
141 %files libelf
142 %defattr(644,root,root,755)
143 %{_libdir}/libelf-%{version}.so
144 %{_libdir}/libelf*.so.*
This page took 0.040069 seconds and 4 git commands to generate.