]> git.pld-linux.org Git - packages/ejabberd.git/blob - ejabberd.spec
config patch is back
[packages/ejabberd.git] / ejabberd.spec
1 #
2 # TODO:
3 #       - add systemd unit
4
5 # Conditional build:
6 %bcond_with     pam             # PAM authentication support
7 %bcond_with     logdb           # enable mod_logdb (server-side message logging)
8 #
9
10 %define realname        ejabberd
11
12 Summary:        Fault-tolerant distributed Jabber/XMPP server
13 Summary(pl.UTF-8):      Odporny na awarie rozproszony serwer Jabbera/XMPP
14 Name:           %{realname}
15 Version:        13.10
16 Release:        0.1
17 License:        GPL
18 Group:          Applications/Communications
19 Source0:        http://www.process-one.net/downloads/ejabberd/%{version}/%{realname}-%{version}.tgz
20 # Source0-md5:  94ce4fe244ee72771eeafe27209d6d3c
21 Source1:        %{realname}.init
22 Source2:        %{realname}.sysconfig
23 #
24 # Archives created with the ejabberd-pack_deps.sh script (in this repo)
25 Source10:       ejabberd-goldrush-20131108.tar.gz
26 # Source10-md5: 3f61708d20fcee2e7d47036cc470f4e9
27 Source11:       ejabberd-lager-20131111.tar.gz
28 # Source11-md5: e0933da9d0462b045f6b9c4bbd320d3e
29 Source12:       ejabberd-p1_cache_tab-20130515.tar.gz
30 # Source12-md5: f2500cffdaff434b354d01eeb24d136d
31 Source13:       ejabberd-p1_iconv-20130602.tar.gz
32 # Source13-md5: ab0118d4097ee756f65fd087265c88ae
33 Source14:       ejabberd-p1_stringprep-20131113.tar.gz
34 # Source14-md5: 282d70c792a78ea9a7415b0b4e65e157
35 Source15:       ejabberd-p1_tls-20130717.tar.gz
36 # Source15-md5: 1211c5d8f0a95b58dfc5fb5bf4e13ded
37 Source16:       ejabberd-p1_xml-20131017.tar.gz
38 # Source16-md5: dc7ebd7ed1ed6340ff0e7739173d4438
39 Source17:       ejabberd-p1_yaml-20131031.tar.gz
40 # Source17-md5: 82d4bb5c5d56ab93a60f5d1c6e583dc1
41 Source18:       ejabberd-p1_zlib-20130515.tar.gz
42 # Source18-md5: a203d9359122ead64966eeb0bd1c8cf7
43 Source19:       ejabberd-xmlrpc-20130116.tar.gz
44 # Source19-md5: 22e02ff7ca174b4ac225005f63da10ad
45 Source20:       ejabberd-jiffy-20130702.tar.gz
46 # Source20-md5: 01b156e97005f07ce8bb46ecf27471ff
47 Source21:       ejabberd-p1_mysql-20131024.tar.gz
48 # Source21-md5: c02921f21ba030357d2cbbbf182af54a
49 Source22:       ejabberd-p1_pam-20130515.tar.gz
50 # Source22-md5: 0ca31094d93dfb047f05c7539136433a
51 Source23:       ejabberd-p1_pgsql-20130515.tar.gz
52 # Source23-md5: 1958be8e59d1b472499ef1bdf8edc1db
53 Source24:       ejabberd-p1_stun-20130624.tar.gz
54 # Source24-md5: 9a1c5ad9b3b95364d3f76446fcf58dc3
55 #
56 Patch0:         %{realname}-paths.patch
57 Patch1:         %{realname}-config.patch
58 # not available for 13.10
59 #Patch2:                %{realname}-vcard-access-get.patch
60 # http://www.dp.uz.gov.ua/o.palij/mod_logdb/patch-mod_logdb-2.1.12.diff
61 Patch3:         %{realname}-mod_logdb.patch
62 URL:            http://www.ejabberd.im/
63 BuildRequires:  autoconf
64 BuildRequires:  automake
65 BuildRequires:  erlang >= 1:R15B01
66 BuildRequires:  expat-devel >= 1.95
67 BuildRequires:  openssl-devel
68 %if %{with pam}
69 BuildRequires:  pam-devel
70 %endif
71 BuildRequires:  rpmbuild(macros) >= 1.268
72 BuildRequires:  yaml-devel
73 BuildRequires:  zlib-devel
74 BuildRequires:  git-core
75 Requires(post): /usr/bin/perl
76 Requires(post): jabber-common
77 Requires(post): sed >= 4.0
78 Requires(post): textutils
79 Requires(post,preun):   /sbin/chkconfig
80 Requires:       erlang
81 Requires:       expat >= 1.95
82 Requires:       rc-scripts
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 %define         _noautoprovfiles        %{_libdir}/%{name}/priv/lib/
86
87 %description
88 ejabberd is a Free and Open Source fault-tolerant distributed Jabber
89 server. It is written mostly in Erlang.
90
91 %description -l pl.UTF-8
92 ejabberd to darmowy, z otwartymi źródłami, odporny na awarie
93 rozproszony serwer Jabbera. Jest napisany w większości w Erlangu.
94
95 %package logdb
96 Summary:        Server-side logging module
97 Group:          Applications/Communications
98 Requires:       %{name} = %{version}-%{release}
99
100 %description logdb
101 Server-side logging module.
102
103 %prep
104 %setup -q -a 10 -a 11 -a 12 -a 13 -a 14 -a 15 -a 16 -a 17 -a 18 -a 19 -a 20 -a 21 -a 22 -a 23 -a 24
105 %patch0 -p1
106 %patch1 -p1
107 #%%patch2 -p1
108 %if %{with logdb}
109 %patch3 -p0
110 %endif
111
112 # Various parts of the build system use 'git describe'
113 # which returns nonsense on manual builds using the builder script
114 # and which fails on the PLD builders
115 # I was not able to locate all 'git describe' invocation, sot let's
116 # fool them with this dummy repository
117 unset GIT_DIR GIT_WORK_TREE
118 git init
119 git config user.email "dummy@example.com"
120 git config user.name "Dummy"
121 git add configure.ac
122 git commit -a -m "dummy commit"
123 git tag "%{version}"
124
125 %build
126 unset GIT_DIR GIT_WORK_TREE
127 %{__aclocal} -I m4
128 %{__autoconf}
129 %configure \
130         %{?with_pam --enable-pam} \
131         --with-openssl=%{_prefix} \
132         --enable-user=jabber \
133         --enable-full-xml \
134         --enable-nif \
135         --enable-odbc \
136         --enable-mysql \
137         --enable-pgsql \
138         %{?with_pam:--enable-pam} \
139         --enable-zlib \
140         --enable-stun \
141         --enable-json \
142         --enable-iconv \
143         --enable-lager
144 touch deps/.got
145
146 cd deps/p1_iconv
147 %configure
148 cd ../..
149 cd deps/p1_stringprep
150 %configure
151 cd ../..
152 cd deps/p1_tls
153 %configure
154 cd ../..
155 cd deps/p1_xml
156 %configure \
157         --enable-nif \
158         --enable-full-xml
159 cd ../..
160 cd deps/p1_yaml
161 %configure
162 cd ../..
163 cd deps/p1_zlib
164 %configure
165 cd ../..
166
167 %{__make} -j1
168
169 %install
170 rm -rf $RPM_BUILD_ROOT
171 install -d $RPM_BUILD_ROOT{/var/lib/%{realname},/etc/{sysconfig,rc.d/init.d},%{_sbindir}}
172
173 unset GIT_DIR GIT_WORK_TREE
174
175 %{__make} install -j1 \
176         CHOWN_COMMAND=true \
177         O_USER="" \
178         G_USER="" \
179         DESTDIR=$RPM_BUILD_ROOT
180
181 sed -e's,@libdir@,%{_libdir},g' -e 's,@EJABBERD_DOC_PATH@,%{_docdir}/%{name}-%{version}/doc,g' %{SOURCE1} > $RPM_BUILD_ROOT/etc/rc.d/init.d/%{realname}
182 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{realname}
183
184 chmod u+rw $RPM_BUILD_ROOT%{_sbindir}/%{realname}*
185
186 chmod 755 $RPM_BUILD_ROOT%{_libdir}/ejabberd/priv/lib/*.so
187
188 rm -rf _doc 2>/dev/null || :
189 mv $RPM_BUILD_ROOT%{_docdir}/%{name} _doc
190
191 touch $RPM_BUILD_ROOT%{_sysconfdir}/jabber/ejabberd.cfg
192 touch $RPM_BUILD_ROOT/var/lib/ejabberd/.erlang.cookie
193
194 %clean
195 rm -rf $RPM_BUILD_ROOT
196
197 %pre
198 if [ -e /etc/jabber/ejabberd.cfg ] ; then
199         if grep -Eq '^[^#]*access_get' ; then
200                 echo "Your 'ejabberd.cfg' config file seems to use 'access_get' option of mod_vcard" >&2
201                 echo "this is not supported by this ejabberd version in PLD" >&2
202                 exit 1
203         fi
204         %banner -e %{name} <<'EOF'
205 Old-style /etc/jabber/ejabberd.cfg configuration file exists. You should
206 consider converting it to the new YAML format. You can do this with the
207 ejabberctl command.
208 EOF
209 fi
210
211 %post
212 if [ -f %{_sysconfdir}/jabber/secret ] ; then
213         SECRET="$(cat %{_sysconfdir}/jabber/secret)"
214         if [ -n "$SECRET" ] ; then
215                 echo -n "Updating component authentication secret in ejabberd config file..." >&2
216                 %{__sed} -i -e "s/@service_secret@/$SECRET/" /etc/jabber/ejabberd.yml
217                 echo "done" >&2
218         fi
219 fi
220
221 /sbin/chkconfig --add ejabberd
222 %service ejabberd restart "ejabberd server"
223
224 %preun
225 if [ "$1" = "0" ]; then
226         %service ejabberd stop
227         /sbin/chkconfig --del ejabberd
228 fi
229
230 %triggerpostun -- %{name} < 13.10
231 # convert old 'NODENAME' in /etc/sysconfig/ejabberd
232 # to 'ERLANG_NODE' in /etc/jabber/ejabberdctl.cfg
233 # and move other settings
234 NODENAME="$(hostname)"
235 if [ -e /etc/sysconfig/ejabberd ] ; then
236         . /etc/sysconfig/ejabberd || :
237 fi
238 subst="s/^#ERLANG_NODE=.*/ERLANG_NODE=ejabberd@${NODENAME}/"
239 if [ -n "$ERL_MAX_PORTS" ] ; then
240         subst="$subst;s/^#ERL_MAX_PORTS=.*/ERL_MAX_PORTS=${ERL_MAX_PORTS}/"
241 fi
242 sed -i -e"$subst" /etc/jabber/ejabberdctl.cfg || :
243 if [ -e /etc/sysconfig/ejabberd ] ; then
244         sed -i.rpmsave \
245                 -e'/^[#[:space:]]*NODENAME=/d;/^# Node name/d' \
246                 -e'/^[#[:space:]]*ERL_MAX_PORTS=/d;/^# uncomment this to allow more then 1024 connections/d' \
247                 -e'/^[#[:space:]]*ERL_FULLSWEEP_AFTER=/d;/^# uncomment this to limit memory usage/d' \
248                 /etc/sysconfig/ejabberd || :
249 fi
250 cp %{_sysconfdir}/jabber/cookie /var/lib/ejabberd/.erlang.cookie || :
251
252 %files
253 %defattr(644,root,root,755)
254 %doc sql _doc/*
255 %attr(755,root,root) %{_sbindir}/*
256 %attr(640,root,jabber) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/jabber/ejabberd-inetrc
257 %attr(640,root,jabber) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/jabber/ejabberd.yml
258 %attr(640,root,jabber) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/jabber/ejabberdctl.cfg
259 # legacy config may still be there
260 %attr(640,root,jabber) %ghost %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/jabber/ejabberd.cfg
261 %attr(770,root,jabber) /var/log/ejabberd
262 %if %{with logdb}
263 %exclude %{_libdir}/ejabberd/ebin/mod_logdb*
264 %endif
265 %{_libdir}/ejabberd
266 %dir %attr(770,root,jabber) /var/lib/ejabberd
267 %ghost %attr(400,jabber,jabber) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/ejabberd/.erlang.cookie
268 %attr(754,root,root) /etc/rc.d/init.d/%{realname}
269 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{realname}
270
271 %if %{with logdb}
272 %files logdb
273 %defattr(644,root,root,755)
274 %{_libdir}/ejabberd/ebin/mod_logdb*
275 %endif
This page took 0.068223 seconds and 3 git commands to generate.