]> git.pld-linux.org Git - packages/eigen3.git/blob - eigen3.spec
- release 2 (by relup.sh)
[packages/eigen3.git] / eigen3.spec
1 Summary:        C++ template library for linear algebra
2 Summary(pl.UTF-8):      Biblioteka szablonów C++ do algebry liniowej
3 Name:           eigen3
4 Version:        3.2.2
5 Release:        2
6 License:        LGPL v3+ or GPL v2+
7 Group:          Development/Libraries
8 #Source0Download: http://eigen.tuxfamily.org/index.php?title=Main_Page
9 Source0:        https://bitbucket.org/eigen/eigen/get/%{version}.tar.bz2
10 # Source0-md5:  fc2e814ae449d16b331f7e1f4e272bd3
11 Patch0:         %{name}-buildtype.patch
12 URL:            http://eigen.tuxfamily.org/
13 BuildRequires:  cmake >= 2.6.2
14 BuildRequires:  rpmbuild(macros) >= 1.605
15 Requires:       libstdc++-devel
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Eigen is a C++ template library for linear algebra: vectors, matrices,
20 and related algorithms. It is versatile, fast, elegant and
21 compiler-friendly.
22
23 Eigen handles, without code duplication and in a completely integrated
24 way:
25  - both fixed-size and dynamic-size matrices and vectors
26  - both dense and sparse (the latter is still experimental) matrices
27    and vectors
28  - both plain matrices/vectors and abstract expressions
29  - both column-major (the default) and row-major matrix storage
30  - both basic matrix/vector manipulation and many more advanced,
31    specialized modules providing algorithms for linear algebra,
32    geometry, quaternions, or advanced array manipulation.
33
34 %description -l pl.UTF-8
35 Eigen to biblioteka szablonów C++ do algebry liniowej: wektorów,
36 macierzy i związanych z nimi algorytmów. Jest elastyczna, szybka,
37 elegancka i przyjazna dla kompilatorów.
38
39 Obsługuje bez powielania kodu i w całkowicie zintegrowany sposób:
40  - macierze i wektory o stałym i dynamicznym rozmiarze
41  - macierze i wektory gęste i rzadkie (te drugie jeszcze
42    eksperymentalnie)
43  - zwykłe macierze/wektory jak i abstrakcyjne wyrażenia
44  - przechowywanie danych kolumnowe (domyślne) oraz wierszowe
45  - podstawowe operacje na macierzach/wektorach, jak i wiele
46    bardziej zaawansowanych, specjalizowanych modułów z algorytmami
47    algebry liniowej, geometrii, kwaternionów i zaawansowanych operacji
48    na tablicach.
49
50 %prep
51 %setup -q -n eigen-eigen-1306d75b4a21
52 %patch0 -p1
53
54 %build
55 install -d build
56 cd build
57 %cmake .. \
58         -DCMAKE_CXX_COMPILER_WORKS=1 \
59         -DCMAKE_CXX_COMPILER="%{__cc}"
60
61 %{__make}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} -C build install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %{_includedir}/eigen3
75 %{_npkgconfigdir}/eigen3.pc
This page took 0.081428 seconds and 3 git commands to generate.