]> git.pld-linux.org Git - packages/eggdrop.git/blob - eggdrop.spec
- fixed usage of macros
[packages/eggdrop.git] / eggdrop.spec
1 Summary:        Eggdrop is an IRC bot, written in C
2 Summary(pl):    Eggdrop jest botem IRC napisanym w C
3 Name:           eggdrop
4 Version:        2.0.0
5 Release:        1.ALPHA
6 Copyright:      GPL
7 Group:          Applications/Communications
8 Group(pl):      Aplikacje/Komunikacja
9 Source0:        %{name}%{version}-ALPHA.tar.gz
10 Source1:        eggdrop.sh
11 Patch:          eggdrop-pld.patch
12 URL:            http://www.eggdrop.net/
13 Requires:       tcl
14 BuildRoot:      /tmp/%{name}-%{version}-root
15
16 %description
17 Eggdrop is an IRC bot, written in C.  If you don't know what IRC is,
18 this is probably not whatever you're looking for!  Eggdrop, being a
19 bot, sits on a channel and takes protective measures: to keep the
20 channel from being taken over (in the few ways that anything CAN),
21 to recognize banished users or sites and reject them, to recognize
22 privileged users and let them gain ops, etc.
23 Eggdrop also contains many modules and scripts, for example for
24 sending files.
25
26 %description -l pl
27 Eggdrop jest IRCowym botem napisanym w C. Eggdrop, bêd±c botem
28 jest na kanale i zajmuje siê jego ochron±: zabezpieczeniem przed
29 takeover-em, nadawaniem odpowiednich przywilejów zarejestrowanym
30 u¿ytkownikom, pilnowanie tzw. banów. itp.
31 Eggdrop poza tymi funkcjami posiada tak¿e wiele dodatków, jak
32 przesy³anie plików czy inne skrypty dla rozrywki.
33
34 %prep
35 %setup -q -n %{name}%{version}-ALPHA
36 %patch -p1
37
38 %build
39 CFLAGS="$RPM_OPT_FLAGS" \
40 ./configure %{_target_platform} \
41         --prefix=%{_bindir}
42
43 # Dziwny problem z -ldir w module filesys
44 cd src/mod/filesys.mod
45 rm -f config.cache config.log
46
47 CFLAGS="$RPM_OPT_FLAGS" \
48 ./configure %{_target_platform}
49
50 cd ../../..
51 CFLAGS="$RPM_OPT_FLAGS" make
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/eggdrop,%{_mandir}/man1}
57
58 make install DEST=$RPM_BUILD_ROOT%{_libdir}/eggdrop
59
60 rm -rf `find $RPM_BUILD_ROOT%{_libdir}/eggdrop -name CVS`
61 rm -rf `find $RPM_BUILD_DIR/%{name}%{version}-ALPHA/doc -name CVS`
62 mv -f $RPM_BUILD_ROOT%{_libdir}/eggdrop/doc/man1/* $RPM_BUILD_ROOT%{_mandir}/man1
63 rm -rf $RPM_BUILD_ROOT%{_libdir}/eggdrop/doc/*
64 install $RPM_SOURCE_DIR/eggdrop.sh $RPM_BUILD_ROOT%{_bindir}/eggdrop
65
66 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man*/* \
67         FEATURES README doc/{patch.howto,tricks,[A-Z]*,*.doc}
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files 
73 %defattr(644,root,root,755)
74 %doc FEATURES.gz README.gz doc/*.gz doc/html
75 %attr(755,root,root) %{_bindir}/*
76 %{_libdir}/eggdrop/filesys
77 %{_libdir}/eggdrop/help
78 %{_libdir}/eggdrop/language
79 %ghost %{_libdir}/eggdrop/modules
80 %{_libdir}/eggdrop/modules-%{version}
81 %{_libdir}/eggdrop/scripts
82 %attr(755,root,root) %{_libdir}/eggdrop/eggdrop2-%{version}
83 %ghost %{_libdir}/eggdrop/eggdrop2
84 %{_libdir}/eggdrop/eggdrop2.conf.*
85 %{_libdir}/eggdrop/motd
86 %{_mandir}/man*/*
This page took 0.044396 seconds and 4 git commands to generate.