]> git.pld-linux.org Git - packages/eet.git/blob - eet.spec
- fix for new automake; rel 2
[packages/eet.git] / eet.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Library for speedy data storage, retrieval, and compression
6 Summary(pl.UTF-8):      Biblioteka do szybkiego zapisywania, odtwarzania i kompresji danych
7 Name:           eet
8 Version:        1.5.0
9 Release:        2
10 License:        BSD
11 Group:          Libraries
12 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
13 # Source0-md5:  8d13801e90e817d9f6d047ed8d027d60
14 Patch0:         automake.patch
15 URL:            http://trac.enlightenment.org/e/wiki/Eet
16 BuildRequires:  autoconf >= 2.52
17 BuildRequires:  automake >= 1.6
18 BuildRequires:  eina-devel >= 1.1.0
19 BuildRequires:  gnutls-devel >= 1.7.6
20 BuildRequires:  libgcrypt-devel
21 BuildRequires:  libjpeg-devel
22 BuildRequires:  libtool
23 BuildRequires:  pkgconfig >= 1:0.22
24 BuildRequires:  sed >= 4.0
25 BuildRequires:  zlib-devel
26 Requires:       eina >= 1.1.0
27 Requires:       gnutls >= 1.7.6
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Eet is a tiny library designed to write an arbitary set of chunks of
32 data to a file and optionally compress each chunk (very much like a
33 zip file) and allow fast random-access reading of the file later on.
34 It does not do zip as a zip itself has more complexity than is needed,
35 and it was much simpler to implement this once here.
36
37 It also can encode and decode data structures in memory, as well as
38 image data for saving to eet files or sending across the network to
39 other machines, or just writing to arbitary files on the system. All
40 data is encoded in a platform independant way and can be written and
41 read by any architecture.
42
43 %description -l pl.UTF-8
44 Eet to mała biblioteka zaprojektowana do zapisu dowolnego zbioru
45 porcji danych do pliku i opcjonalnej kompresji każdej porcji (podobnie
46 do pliku zip) oraz umożliwienia później szybkiego odczytu pliku ze
47 swobodnym dostępem. Nie jest to zip, jako że sam zip jest bardziej
48 złożony niż trzeba, a było dużo prościej zaimplementować to tak, jak
49 jest.
50
51 Biblioteka może także kodować i dekodować struktury danych w pamięci,
52 a także dane obrazów do zapisu do plików eet lub wysyłania po sieci na
53 inne maszyny, lub po prostu zapisywania do dowolnych plików w
54 systemie. Wszystkie dane są kodowane w sposób niezależny od platformy
55 i mogą być zapisywane i odczytywane na dowolnej architekturze.
56
57 %package devel
58 Summary:        Header files for Eet library
59 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Eet
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       eina-devel >= 1.1.0
63 Requires:       gnutls-devel >= 1.7.6
64 Requires:       libgcrypt-devel
65 Requires:       libjpeg-devel
66 Requires:       zlib-devel
67
68 %description devel
69 Header files for Eet library.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe biblioteki Eet.
73
74 %package static
75 Summary:        Static Eet library
76 Summary(pl.UTF-8):      Statyczna biblioteka Eet
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static Eet library.
82
83 %description static -l pl.UTF-8
84 Statyczna biblioteka Eet.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89
90 %build
91 %{__libtoolize}
92 %{__aclocal} -I m4
93 %{__autoconf}
94 %{__autoheader}
95 %{__automake}
96 %configure \
97         --disable-silent-rules \
98         %{!?with_static_libs:--disable-static}
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 install -d $RPM_BUILD_ROOT%{_examplesdir}
108 mv -f $RPM_BUILD_ROOT%{_datadir}/eet/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   -p /sbin/ldconfig
114 %postun -p /sbin/ldconfig
115
116 %files
117 %defattr(644,root,root,755)
118 %doc AUTHORS COPYING NEWS README
119 %attr(755,root,root) %{_bindir}/eet
120 %attr(755,root,root) %{_libdir}/libeet.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libeet.so.1
122
123 %files devel
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/libeet.so
126 %{_libdir}/libeet.la
127 %{_includedir}/eet-1
128 %{_pkgconfigdir}/eet.pc
129 %{_examplesdir}/%{name}-%{version}
130
131 %if %{with static_libs}
132 %files static
133 %defattr(644,root,root,755)
134 %{_libdir}/libeet.a
135 %endif
This page took 0.04875 seconds and 4 git commands to generate.