]> git.pld-linux.org Git - packages/edje.git/blob - edje.spec
- converted to UTF-8
[packages/edje.git] / edje.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Complex Graphical Design/Layout Engine
6 Summary(pl.UTF-8):   Złożony silnik graficznego projektowania/planowania
7 Name:           edje
8 Version:        0.5.0.036
9 Release:        2
10 License:        BSD
11 Group:          X11/Libraries
12 Source0:        http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
13 # Source0-md5:  a954b46597cdf09560beac8d28e4155e
14 URL:            http://enlightenment.org/Libraries/Edje/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  ecore-devel
18 BuildRequires:  embryo-devel
19 BuildRequires:  imlib2-devel >= 1.2.1
20 BuildRequires:  libtool
21 Requires:       %{name}-libs = %{version}-%{release}
22 Requires:       cpp
23 Requires:       evas-engine-buffer
24 Requires:       evas-loader-png
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %undefine       __cxx
28 %define         specflags_x86_64        -mfpmath=387
29 %define         specflags_amd64         -mfpmath=387
30
31 %description
32 Edje is a complex graphical design and layout engine. It provides a
33 mechanism for allowing configuration data to define visual elements in
34 terms of layout, behavior, and appearance. Edje allows for multiple
35 collections of layouts in one file, allowing a complete set of images,
36 animations, and controls to exist as a unified whole.
37
38 Edje separates the arrangement, appearance, and behavior logic into
39 distinct independent entities. This allows visual objects to share
40 image data and configuration information without requiring them to do
41 so. This separation and simplistic event driven style of programming
42 can produce almost any look and feel one could want for basic visual
43 elements. Anything more complex is likely the domain of an application
44 or widget set that may use Edje as a convenient way of being able to
45 configure parts of the display.
46
47 %description -l pl.UTF-8
48 Edje to złożony silnik graficznego projektowania i planowania.
49 Dostarcza mechanizm pozwalający na definiowanie elementów graficznych
50 za pomocą danych konfiguracyjnych poprzez rozmieszczenie, zachowanie i
51 wygląd. Edje pozwala na wiele kolekcji projektów w jednym pliku,
52 zezwalając na istnienie pełnego zbioru obrazów, animacji i kontrolek
53 jako całości.
54
55 Edje oddziela rozmieszczenie, wygląd i logikę zachowania na różne,
56 niezależne elementy. Pozwala to na współdzielenie danych obrazów i
57 informacji o konfiguracji elementów graficznych bez wymagania tego.
58 Rozdzielenie to i uproszczony model programowania sterowanego
59 zdarzeniami może stworzyć prawie dowolny wygląd i zachowanie
60 podstawowych elementów graficznych. Wszystko bardziej złożone jest
61 raczej domeną aplikacji lub zbioru widgetów, które mogą używać Edje
62 jako wygodnego sposobu konfigurowania części ekranu.
63
64 %package libs
65 Summary:        Edje library
66 Summary(pl.UTF-8):   Biblioteka edje
67 Group:          X11/Libraries
68
69 %description libs
70 Edje library.
71
72 %description libs -l pl.UTF-8
73 Biblioteka edje.
74
75 %package devel
76 Summary:        Edje header files
77 Summary(pl.UTF-8):   Pliki nagłówkowe Edje
78 Group:          Development/Libraries
79 Requires:       %{name}-libs = %{version}-%{release}
80 Requires:       ecore-devel
81 Requires:       embryo-devel
82 Requires:       imlib2-devel >= 1.2.1
83
84 %description devel
85 Header files for Edje.
86
87 %description devel -l pl.UTF-8
88 Pliki nagłówkowe Edje.
89
90 %package static
91 Summary:        Static Edje library
92 Summary(pl.UTF-8):   Statyczna biblioteka Edje
93 Group:          Development/Libraries
94 Requires:       %{name}-devel = %{version}-%{release}
95
96 %description static
97 Static Edje library.
98
99 %description static -l pl.UTF-8
100 Statyczna biblioteka Edje.
101
102 %prep
103 %setup -q
104
105 %build
106 %{__libtoolize}
107 %{__aclocal} -I m4
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111 %configure \
112         %{!?with_static_libs:--disable-static} \
113         --enable-edje-cc
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post libs      -p /sbin/ldconfig
126 %postun libs    -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %doc AUTHORS COPYING COPYING-PLAIN INSTALL README
131 %attr(755,root,root) %{_bindir}/edje_cc
132 %attr(755,root,root) %{_bindir}/edje_decc
133 %attr(755,root,root) %{_bindir}/edje_recc
134 %{_datadir}/%{name}
135
136 %files libs
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_libdir}/libedje.so.*.*.*
139
140 %files devel
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_bindir}/edje-config
143 %attr(755,root,root) %{_libdir}/libedje.so
144 %{_libdir}/libedje.la
145 %{_includedir}/Edje*
146 %{_pkgconfigdir}/edje.pc
147
148 %if %{with static_libs}
149 %files static
150 %defattr(644,root,root,755)
151 %{_libdir}/libedje.a
152 %endif
This page took 0.031666 seconds and 3 git commands to generate.