]> git.pld-linux.org Git - packages/dtc.git/blob - dtc.spec
- defattr for -doc
[packages/dtc.git] / dtc.spec
1 #
2 # Conditional build:
3 %bcond_without  verbose         # verbose build (V=1)
4 #
5 Summary:        The Device Tree Compiler
6 Summary(pl.UTF-8): Kompilator drzewiastej struktury urządzeń
7 Name:           dtc
8 Version:        1.3.0
9 Release:        1
10 License:        GPL v2 (dtc), GPL/BSD (fdt library)
11 Group:          Libraries
12 Source0:        http://www.jdl.com/software/%{name}-v%{version}.tgz
13 # Source0-md5:  0b94ed452ed3d3b5c1546c27788c416f
14 URL:            http://git.jdl.com/gitweb/
15 BuildRequires:  bison
16 BuildRequires:  flex
17 Requires:       %{name}-doc = %{version}-%{release}
18 Requires:       libfdt = %{version}-%{release}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %{?debug:%define with_verbose 1}
22
23 %description
24 The Device Tree Compiler, dtc, takes as input a device-tree in a given
25 format and outputs a device-tree in another format. Typically, the
26 input format is "dts", a human readable source format, and creates a
27 "dtb", or binary format as output.
28
29 %description -l pl.UTF-8
30 Kompilator drzewiastej struktury urządzeń, dtc, przyjmuje na wejściu
31 dane w jednym formacie by na wyjściu wyprodukować strukturę danych w
32 innym. Najczęściej format wejściowy to "dts", intuicyjny i łatwy w
33 odczycie (tzw. human readable), natomiast wyjściowy to "dtb" lub
34 inaczej format binarny.
35
36 %package -n libfdt
37 Summary:        Device tree library
38 Summary(pl.UTF-8):      Biblioteka drzewiastej struktury urządzeń
39 Group:          Libraries
40 Requires:       %{name}-doc = %{version}-%{release}
41 # does not require base. see README.license
42
43 %description -n libfdt
44 Device tree library.
45
46 %description -n libfdt -l pl.UTF-8
47 Biblioteka drzewiastej struktury urządzeń.
48
49 %package -n libfdt-devel
50 Summary:        Header files for fdt library
51 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki fdt
52 Group:          Development/Libraries
53 Requires:       %{name}-doc = %{version}-%{release}
54 Requires:       libfdt = %{version}-%{release}
55 Obsoletes:      dtc-devel
56 # does not require base. see README.license
57
58 %description -n libfdt-devel
59 Header files for fdt library.
60
61 %description -n libfdt-devel -l pl.UTF-8
62 Pliki nagłówkowe biblioteki fdt.
63
64 %package -n libfdt-static
65 Summary:        Static fdt library
66 Summary(pl.UTF-8):      Statyczna biblioteka fdt
67 Group:          Development/Libraries
68 Requires:       libfdt-devel = %{version}-%{release}
69 Obsoletes:      dtc-static
70
71 %description -n libfdt-static
72 Static fdt library.
73
74 %description -n libfdt-static -l pl.UTF-8
75 Statyczna biblioteka fdt.
76
77 %package doc
78 Summary:        Dtc documentation
79 Summary(pl.UTF-8):      Dokumentacja dla dtc
80 Group:          Development/Libraries
81
82 %description doc
83 Dtc package documentation.
84
85 %description doc -l pl.UTF-8
86 Dokumentacja pakietu dtc.
87
88 %prep
89 %setup -q -n %{name}-v%{version}
90
91 %build
92 %{__make} \
93         %{?with_verbose:V=1} \
94         CC="%{__cc}" \
95         CFLAGS="%{rpmcflags} -fPIC"
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 %{__make} install \
100         %{?with_verbose:V=1} \
101         PREFIX=%{_prefix} \
102         LIBDIR=%{_libdir} \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post   -n libfdt -p /sbin/ldconfig
109 %postun -n libfdt -p /sbin/ldconfig 
110
111 %files
112 %defattr(644,root,root,755)
113 %attr(755,root,root) %{_bindir}/convert-dtsv0
114 %attr(755,root,root) %{_bindir}/dtc
115 %attr(755,root,root) %{_bindir}/dtdiff
116 %attr(755,root,root) %{_bindir}/ftdump
117
118 %files -n libfdt
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_libdir}/libfdt-%{version}.so
121 %attr(755,root,root) %ghost %{_libdir}/libfdt.so.1
122
123 %files -n libfdt-devel
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/libfdt.so
126 %{_includedir}/fdt.h
127 %{_includedir}/libfdt.h
128
129 %files -n libfdt-static
130 %defattr(644,root,root,755)
131 %{_libdir}/libfdt.a
132
133 %files doc
134 %defattr(644,root,root,755)
135 %doc TODO README.license Documentation/manual.txt
This page took 0.041808 seconds and 4 git commands to generate.