]> git.pld-linux.org Git - packages/dovecot.git/blob - dovecot.spec
- updated to 0.99.11
[packages/dovecot.git] / dovecot.spec
1 #
2 # Conditional build:
3 # _without_ldap         - without LDAP auth
4 # _without_pgsql        - without PostgreSQL auth
5 # _without_sasl         - without SASL auth
6 #
7 Summary:        IMAP and POP3 server written with security primarily in mind
8 Summary(pl):    Serwer IMAP i POP3 pisany g³ównie z my¶l± o bezpieczeñstwie
9 Name:           dovecot
10 Version:        0.99.11
11 Release:        1
12 License:        LGPL v2.1
13 Group:          Networking/Daemons
14 Source0:        http://dovecot.org/releases/%{name}-%{version}.tar.gz
15 # Source0-md5:  05090ad784540b96c84f32080ada9f97
16 Source1:        %{name}.pamd
17 Source2:        %{name}.init
18 Source3:        %{name}.sysconfig
19 Patch0:         %{name}-config.patch
20 URL:            http://dovecot.procontrol.fi/
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 %{!?_without_sasl:BuildRequires:        cyrus-sasl-devel >= 2.0}
24 BuildRequires:  gettext-devel
25 BuildRequires:  libtool
26 %{!?_without_ldap:BuildRequires:        openldap-devel}
27 BuildRequires:  openssl-devel >= 0.9.7d
28 BuildRequires:  pam-devel
29 BuildRequires:  pkgconfig
30 %{!?_without_pgsql:BuildRequires:       postgresql-devel}
31 Requires(post,preun):   /sbin/chkconfig
32 Requires:       pam >= 0.77.3
33 Provides:       imapdaemon
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Dovecot is an IMAP and POP3 server for Linux/UNIX-like systems,
38 written with security primarily in mind. Although it's written with C,
39 it uses several coding techniques to avoid most of the common
40 pitfalls.
41
42 Dovecot can work with standard mbox and maildir formats and it's fully
43 compatible with UW-IMAP and Courier IMAP servers as well as mail
44 clients accessing the mailboxes directly. It's also planned to support
45 storing mails in SQL databases.
46
47 Dovecot is easy to set up and doesn't require special maintenance.
48 Only thing you need is to get the authentication working properly - if
49 your users are in /etc/passwd there's hardly anything you have to do.
50
51 Dovecot should be pretty fast, mostly because of index files that
52 Dovecot maintains; instead of having to scan through all the data in
53 mailbox, Dovecot can get most of the wanted information from index
54 with little effort.
55
56 Status:
57  - should be quite ready for use with normal IMAP clients
58  - complete IMAP4rev1 support
59  - supports THREAD and SORT extensions, required by many IMAP webmails
60  - complete TLS/SSL support, using either GNUTLS or OpenSSL
61  - IPv6 ready
62  - shared mailboxes aren't yet supported
63  - Maildir++ quota isn't yet supported; hard filesystem quota can also
64    be problematic
65  - mbox support isn't yet perfect - there's a few more or less
66    theoretical problems, but nothing too bad.
67
68 %description -l pl
69 Dovecot to serwer IMAP i POP3 dla systemów linuksowych/uniksowych,
70 pisany g³ównie z my¶l± o bezpieczeñstwie. Chocia¿ jest pisany w C,
71 u¿ywa kilku technik kodowania zapobiegaj±cych wiêkszo¶ci popularnych
72 pu³apek.
73
74 Dovecot mo¿e dzia³aæ ze standardowymi formatami mbox i maildir, jest
75 ca³kowicie kompatybilny z serwerami UW-IMAP i Courier IMAP, a tak¿e z
76 klientami pocztowymi bezpo¶rednio dostaj±cymi siê do skrzynek.
77 Planowana jest tak¿e obs³uga przechowywania listów w bazach SQL.
78
79 Dovecot jest ³atwy do skonfigurowania i nie wymaga specjalnego
80 nadzoru. Wystarczy tylko doprowadziæ do dzia³ania uwierzytelnianie -
81 je¶li u¿ytkownicy s± w /etc/passwd, to w³a¶ciwie nie trzeba nic
82 zmieniaæ.
83
84 Dovecot powinien byæ w miarê szybki, g³ównie z powodu plików
85 indeksowych utrzymywanych przez serwer; zamiast potrzeby skanowania
86 wszystkich danych w skrzynce, Dovecot mo¿e ma³ym kosztem uzyskaæ
87 wiêkszo¶æ potrzebnych informacji z indeksu.
88
89 Stan:
90  - powinien byæ gotowy do u¿ycia ze zwyk³ymi klientami IMAP
91  - pe³na obs³uga IMAP4rev1
92  - obs³uga rozszerzeñ THREAD i SORT, wymaganych przez wiele webmaili
93    IMAP
94  - obs³uga IPv6
95  - jeszcze nie ma wspó³dzielonych skrzynek
96  - quota Maildir++ jeszcze nie jest obs³ugiwana; twarda quota na
97    systemach plików mo¿e sprawiaæ problemy
98  - obs³uga mboksów jeszcze nie jest idealna - jest jeszcze kilka mniej
99    lub bardziej teoretycznych problemów, ale nic strasznego.
100
101 %prep
102 %setup -q
103 %patch0 -p1
104
105 %build
106 %{__libtoolize}
107 %{__aclocal}
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111 %configure \
112         %{?debug:--enable-debug} \
113         %{!?_without_ldap:--with-ldap} \
114         %{!?_without_pgsql:--with-pgsql} \
115         %{!?_without_sasl:--with-cyrus-sasl2} \
116         --with-ssl=openssl \
117         --with-ssl-dir=/var/lib/openssl
118
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT/etc/{pam.d,rc.d/init.d,sysconfig,security}
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/{dovecot-example.conf,dovecot.conf}
129
130 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
131 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
132 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
133
134 touch $RPM_BUILD_ROOT/etc/security/blacklist.imap
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post
140 /sbin/chkconfig --add dovecot
141 if [ -f /var/lock/subsys/dovecot ]; then
142         /etc/rc.d/init.d/dovecot restart >&2
143 else
144         echo "Run \"/etc/rc.d/init.d/dovecot start\" to start dovecot daemon."
145 fi
146
147 %preun
148 if [ "$1" = "0" ]; then
149         if [ -f /var/lock/subsys/dovecot ]; then
150                 /etc/rc.d/init.d/dovecot stop >&2
151         fi
152         /sbin/chkconfig --del dovecot
153 fi
154
155 %files
156 %defattr(644,root,root,755)
157 # COPYING contains some notes, not actual LGPL text
158 %doc AUTHORS COPYING ChangeLog NEWS README TODO doc/*.txt doc/*.c*f
159 %attr(755,root,root) %{_sbindir}/%{name}
160 %config(noreplace) %verify(not size mtime md5) /etc/%{name}.conf
161 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/pam.d/%{name}
162 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/security/blacklist.imap
163 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/%{name}
164 %attr(754,root,root) /etc/rc.d/init.d/%{name}
165 %attr(755,root,root) %{_libdir}/%{name}
This page took 0.071771 seconds and 4 git commands to generate.