]> git.pld-linux.org Git - packages/dotnet-webkitgtk-sharp.git/blob - dotnet-webkitgtk-sharp.spec
update BR
[packages/dotnet-webkitgtk-sharp.git] / dotnet-webkitgtk-sharp.spec
1 # TODO
2 # - fix docs build
3 # - update descs (this is dor gtk3)
4 # - cleanup/update deps
5 #
6 # Conditional build:
7 %bcond_with     doc             # build with tests
8
9 %include        /usr/lib/rpm/macros.mono
10 Summary:        C# bindings for WebKitGTK+ 3.0 using GObject Introspection
11 Summary(pl.UTF-8):      WebKit# - wiązanie WebKit dla Mono
12 Name:           dotnet-webkitgtk-sharp
13 Version:        2.0.0
14 Release:        0.4
15 License:        LGPL v3
16 Group:          Libraries
17 Source0:        https://github.com/xDarkice/webkitgtk-sharp/releases/download/%{version}/webkitgtk-sharp-%{version}.tar.gz
18 # Source0-md5:  259d1b85975a93b878fa1bdc4254e83f
19 Patch0:         pkgconfig.patch
20 URL:            https://github.com/xDarkice/webkitgtk-sharp/
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  dotnet-gtk-sharp3
24 BuildRequires:  dotnet-soup-sharp
25 BuildRequires:  gtk-webkit3-devel
26 BuildRequires:  mono-csharp >= 1.1.0
27 BuildRequires:  monodoc >= 2.6
28 BuildRequires:  pkgconfig
29 BuildRequires:  sed >= 4.0
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 WebKit is a web content engine, derived from KHTML and KJS from KDE,
34 and used primarily in Apple's Safari browser. It is made to be
35 embedded in other applications, such as mail readers, or web browsers.
36
37 This package provides Mono bindings for WebKit libraries.
38
39 %description -l pl.UTF-8
40 WebKit to silnik przeglądarki internetowej, wywodzący się z projektów
41 KHTML i KJS dla platformy KDE, używany głównie w przeglądarce Safari
42 firmy Apple. Stworzony został aby móc osadzać go w innych aplikacjach,
43 takich jak czytniki poczty czy przeglądarki stron internetowych.
44
45 Ten pakiet dostarcza dowiązań Mono do bibliotek WebKit.
46
47 %package devel
48 Summary:        WebKit# development files
49 Summary(pl.UTF-8):      Pliki programistyczne WebKit#
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       monodoc >= 2.6
53
54 %description devel
55 WebKit# development files.
56
57 %description devel -l pl.UTF-8
58 Pliki programistyczne WebKit#.
59
60 %prep
61 %setup -q -n webkitgtk-sharp-%{version}
62 %patch0 -p1
63
64 %{__sed} -i -e '/SUBDIRS/ s/doc//' Makefile.am
65
66 %build
67 %{__aclocal} -I m4
68 %{__autoconf}
69 %{__automake}
70 %configure \
71         --disable-static
72 %{__make}
73 %{?with_doc:%{__make} -C doc}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libwebkitgtksharpglue-*.la
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc AUTHORS ChangeLog
88 %{_prefix}/lib/mono/gac/webkitgtk-sharp
89 %attr(755,root,root) %{_libdir}/libwebkitgtksharpglue-1.10.2.so
90 # -devel or runtime resource?
91 %{_datadir}/gapi-3.0/webkitgtk-sharp-api.xml
92
93 %files devel
94 %defattr(644,root,root,755)
95 %{_prefix}/lib/mono/webkitgtk-sharp
96 %{_pkgconfigdir}/webkitgtk-sharp-3.0.pc
97 # docs subpackage?
98 %{?with_doc:%{_prefix}/lib/monodoc/sources/webkit-sharp-docs*}
This page took 0.659203 seconds and 4 git commands to generate.